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 Introduction Section 1

1.1 Required Versions 
MicroStation V8i (SELECTseries 4) - Version 08.11.09.832 

InRoads V8i (SELECTseries 2) - Version 8.11.07.615 

1.2 Workflow Description 
This Workflow was developed for use with network drives (X-Drive) projects to bring 2016 Orthophotography 

from UCONN’s CT ECO webite  into a MicroStation V8i design file.  This workflow offers two methods to bring 

in the aerial images: Aerial Imagery WMS and Ortho Downloads. There are advantages and disadvantages to 

either method. It is up to the user to determine which one they would like to use. 

1. Aerial Imagery from UCONN’S CT ECO Web Map Server (WMS) connecting directly from MicroStation 

Disadvantage – Slower to create PDF 

Disadvantage – Slower to update a MicroStation View 

Advantage – One Step to bring in image 

2. Ortho downloads from UCONN’S CT ECO website 

Disadvantage – Multiple Steps to bring in image(s) 

Advantage – Quick to create PDF 

Prerequisites for using this workflow include basic MicroStation knowledge including understanding the 

Raster Manager and Referencing.  

Please Note: If you are using MicroStation through ProjectWise please use the Earth Exploration Toolset 

Workflow found on The ProjectWise Digital Design Environment website.  

1.3 Ortho Imagery File Formats 
Statewide Arial Photos can be found in several locations.  Keep in mind that all file formats found on websites 

may not be compatible with MicroStation V8i.  The NOAA Website and the UCONN/CT ECO Website recently 

published 4 band orthoimagery (MrSID4) for the Statewide 2016 Orthophotograhy flight. This format is not 

compatible with MicroStation V8i; however, the Statewide 2016 Orthophotograhy flight also produced 3 

band orthoimagery (MrSID3) which is compatible with MicroStation V8i.   

MicroStation V8i Orthoimagery Compatibility: 

 

 File Format 
Compatible with 
MicroStation V8i 

4 band orthoimagery 
(MrSID4) NO     

3 band orthoimagery 
(MrSID3)     YES     

http://cteco.uconn.edu/data/download/flight2016/index.htm
http://www.ct.gov/dot/cwp/view.asp?a=3194&Q=575828
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1.4 Raster Attachment Workflow 
 

CREATE RASTER 
CONTAINER DGN 

ATTACH 
ORTHOS 

REPROJECT 
IF NECESSARY  

RETRIEVE ORTHOS 

REFERENCE 

RASTER CONTAINER DGN 
INTO MASTER DGN 

REFERENCE 

WMS DGN INTO 
MASTER DGN 

DOWNLOAD 

DATA WEBSITE 

WMS DGN REFERENCE 
FILE 

SELECT 
DATA 

SOURCE 
METHOD 

OPTIONAL: REFERENCE 

MASTER DGN INTO SHEET 
MODEL 

ORTHO DOWNLOADS 

AERIAL IMAGERY WMS 



4 
 
 

 MicroStation & WMS Aerial Imagery Section 2
MicroStation V8i has the functionality of connecting to a live Web Map Server (WMS.)  WMS is a standard 

format for georeferenced map images that are generated from GIS databases and then served over the 

internet.   

 

Rather than using MicroStation Raster Manager to directly attach the WMS, we will reference a blank design 

file with the WMS files already attached for your convenience. Two MicroStation dgn files are provided in the 

workspace to reference into your projects: one for NAD 83 - 2D_Ortho_2016_83FT.dgn  and another for NAD 

27 - 2D_Ortho_2016_27FT.dgn.  [If you have a metric project, please contact AEC Applications staff for 

additional steps.] Each DGN references WMS images which are provided by The University Of Connecticut’s 

(UCONN) Connecticut Environmental Conditions Online (CT ECO.) 

2.1 Active Design File 
1 .  Start MicroStation through the CTDOT Accounting Menu. 

2 .  Open or create a new MicroStation design file using one of the design seed files listed below: 

 
Designer Users: 
W:\Workspace\Standards\seed\CT_Design_3D_V8i.dgn 
W:\Workspace\Standards\seed\CT_Design_2D_V8i.dgn  
Survey Users: 
W:\Workspace\Standards\seed\CT_Survey_3D_V8i.dgn 
W:\Workspace\Standards\seed\CT_Survey_2D_V8i.dgn 
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2.2 Reference WMS Design File 
1 .  Select References from the primary tool bar: 

 
 

2 .  From the References dialog box, navigate to Tools> Attach… 

 
 

3 .  From the Attach Reference dialog, browse to W:\Workspace\XWMS\ and select the 2D Ortho file that 

corresponds to your project Datum: 

2D_Ortho_2016_27FT.dgn 

2D_Ortho_2016_83FT.dgn 

4 .  Select Open: 
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5 .  The Reference Attachment Settings dialog will appear.  Enter a Logical Name, set the fields as shown 

below, and click OK.   

 
6 .  Fit the View.  This may take 10 or more seconds to load and display the two attached images:  the 2016 

Orthophotos, and the Interstate and State Routes. 
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2.3 Clip WMS Reference File 
1 .  Attach a ground survey file to reference if you wish.  Zoom to your project location and clip the Ortho 

Reference as needed. 

 

2 .  You may also wish to create a sheet model to reference your design, and place a border at a desired 

scale for the ease of publishing a PDF (see Section 4 Sheet Model Publishing.) 
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 Download selected CT ECO Orthophotography Section 3
The imagery on the UCONN CT ECO website uses the State Plane 1983 projection.  The 2016 Ortho imagery 

will come in lined up with projects using Horizontal NAD83 Datum ground survey.  If the ground survey uses a 

Horizontal NAD27 Datum the 2016 Orthos will need to be reprojected after they are brought into 

MicroStation.    

3.1 Retrieve 3 band Orthoimagery (MrSID3) 
1. Browse to the UCONN ECO site http://cteco.uconn.edu/data/download/flight2016/index.htm. 

 
 

2. Select a town from the drop down or type in an address and search for the project location. 

 
 

http://cteco.uconn.edu/data/download/flight2016/index.htm
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3. Once the location is found, check the Interactive Select Mode box. 

 

 

4. Click and drag from left to right in the map section to draw a selection rectangle. 
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5. The tiles touching the selection rectangle should highlight yellow and a list of the tiles should appear to 

the right of the map. 

 
 

6. Check the boxes next to each tile number, set the Download Tiles As field to MrSID3 and click the Go 

button. 
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7. A popup window should appear with links to each tile. Click the tile number listed. 

 
 

8. The save dialog will appear, click Save as and save the zip file in the Raster_Reference_Files folder 

located in your project container (repeat steps 7 & 8 for each tile listed in the pop-up window. 

 
9. Close the CT ECO 2016 imagery webpage. 
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3.2 Extract Zip Files 
1. Navigate to where the zip files were saved, right click on each zip file and select Extract All… and 

extract into your project folder.  

 
 

2. Delete the zip files from the folder if they were saved to the x-drive to save space, once the files are 

unzipped the zip version is not needed.  
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3.3 Create Raster Container Design File 
1. Open MicroStation through the CTDOT Accounting Menu. 

2. Create the MicroStation file that will be used as a container for the MrSID3 Orthophotography raster 

attachments.  Use the seed file: W:\Workspace\Standards\seed\Geospatial\2D_Poly_83FT.dgn.  

 
3. Open the new file, on the MicroStation main menu bar navigate to Workspace > Preferences… 

4. The Preferences dialog box will appear go to the Raster Manager category and click the Georeference 

tab. In the Default Unit Settings area set the Sister file units and Raster file units to 1, and unit type to 

Survey_Feet, click OK.  
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3.4 Attach Orthoimagery (Raster Manager) 
1. From the primary tool bar, select Raster Manager.  

 
 

2. From the Raster Manager dialog box, navigate to File> Attach> Raster.

 
 

3. Browse to the SID files that were saved, click Open. 
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4. The Raster Attachment Options dialog box will appear. Click Attach.  

 
 

5. From the MicroStation main menu bar, navigate to File > Save Settings. Close this file if you do not 

need to reproject to NAD27 and move on to Section 3.7. 

If it is necessary to reproject to NAD27, continue onto Section 3.5. 
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3.5 Reproject Orthoimagery 
1. Remain in the file that was created in Section 3.1.  From the MicroStation main menu bar navigate to 

Tools> Geographic> Select Geographic Coordinate System.  

 
2. The Geographic Coordinate System toolbox will appear, click the From File button  

 
3. Browse to the folder W:\Workspace\Standards\seed\Geospatial\ and select the seed file 

2D_Poly_27FT.dgn. Click Open. 
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4.  A dialog box will appear, toggle on Reproject the data to the new Geograghic Coordinate System and 

click OK. 

  

5. From the MicroStation main menu bar navigate to File > Save Settings. 
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3.6 Attach Raster Container to the Design File 
In this section users will open or create a new design file and attach the MicroStation file created in Section 3.   

1 .  Use one of the seed files listed below to create the MicroStation file. 

Designer Users: 
W:\Workspace\Standards\seed\CT_Design_3D_V8i.dgn 
W:\Workspace\Standards\seed\CT_Design_2D_V8i.dgn  
 
Survey Users: 
W:\Workspace\Standards\seed\SV_Survey_3D_V8i.dgn 
W:\Workspace\Standards\seed\SV_Survey_2D_V8i.dgn 
 

 
 

2 .  Select References from the primary tool bar:  
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3 .  From the References dialog box, navigate to Tools> Attach… to open the Attach Reference dialog. 

 
 

4 .  Browse to the raster container file and Open. 

5 .  The Reference Attachment Settings dialog will appear. Give the reference a Logical Name. Click OK. 
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6 .  The raster images should appear in the correct location. 
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3.7 Raster Display 
1 .  All the raster files can be turned off with one click on the References dialog box by clicking off the 

display of the reference file that contains all the rasters. 

     
 

2 .  Raster files can be individually turned on and off in the Raster Manager.  On the Raster Manager dialog 

box select the Raster and choose the View you would like to set the display off. 

       



22 
 
 

 Sheet Model Publishing Section 4
Sheet models, not design models, are to be used for publishing PDFs.  Borders shall be placed in sheet models 

only.  Plot drivers have been customized to accommodate WMS rasters.  By using a standard border, the 

publishing task becomes simplified. 

4.1 Create a Sheet Model 
1. Create a new MicroStation design file using the Civil sheet seed file:  

 

2. Reference the 3D Design file (which you created from Section 2) using Live Nesting and a Nesting 

Depth of 1 to include the referenced design file which contains the WMS files. Ensure that Visible 

Edges is set to Dynamic.  
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[Note the hierarchy in the following image:  the active sheet file references a 3D design file which 

references the Ortho design file with attached WMS files]  

 

 

3. Using the CT DOT Sheet Composition tasks, place a Plan Border cell.  Use an active X&Y scale of 1 if 
your desired scale is 40.  [Note:  Network environment cells are based upon 40 scale or 480:1] 
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4. In the example below, an active scale of 5 will yield a 200 scale plot border (5x40 scale=200 scale). 
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5. Set up the Sheet Boundary (transient shape) for the sheet model as shown: 

a. Define Sheet Boundary 

b. Display Sheet Boundary 

c. Move the Sheet Boundary to the lower left border corner 

d. Choose the proper Sheet Boundary Scale if applicable  

 

 

6. See also Section 2.3 Clip WMS Reference File 
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4.2 PDF Publishing 
1. Use the CT Publishing task to select the Contract Sheet Model.  The Print dialog will appear: 

 

2. Published Raster Quality has been preset to 21% to accommodate WMS.  This can be adjusted using 
the Print dialog Settings menu. This quality is a good balance between PDF/plot resolution and the 
time it takes to create the PDF.  NOTE: current processing time is approximately one minute per sheet. 
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 Appendix Section 5

5.1 Adjust Raster Manager Unit Settings 
Your User Preference, Raster Manager default Unit Settings will need to be adjusted at times to account for 

the type of file being used when attaching geospatial raster images.  This needs to be adjusted only if you are 

attaching raster files directly into a dgn file using the Raster Manager. In this workflow we only attach raster’s 

directly to Geospatial files, so the setting should follow row B in the table below.     

1. Navigate to Settings > Design File and make note of your settings. 

  Design File 
Working Units 

User Preference 
Raster Manager 
Georeference 
Sister File: 1 Unit 

User Preference 
Raster Manager 
Georeference 
Raster File 1 Unit 

A Custom Unit File 40_foot_eng .002083333 .002083333 

B Geospatial File Survey Feet 1 1 

2. Navigate to Workspace> Preferences…  

3. The Preferences window will appear. Select the Raster Manager category and click the Georeference 

tab. Set the Sister file and raster file units.  After entering the Unit values, click OK on the Preferences 

Dialog box, and select and File > Save Settings from the MicroStation main menu. 

A B 
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5.2 Reference Exported ProjectWise MicroStation Files  
User may have MicroStation files with aerial photos or USGS maps attached that are housed in ProjectWise 

that need to referenced into a file on the network.  Users will need to extract these files out of ProjectWise 

and copy them to the needed network location. 

3. In ProjectWise Explorer right click on the MicroStation Dgn file(s) that you would like to export and 
select Export. 

4. On the Welcome Dialog box make sure Send to Folder is toggled on and click the Next > button. 

5. On the Define export settings dialog box click Browse. Browse to the needed external network location 
and select OK on the Browse to Folder dialog box.  Click Next> and Finish.  This will export the 
MicroStation file along with all rasters and reference files that are attached.   

   

 

6. DO NOT ATTEMPT TO OPEN THE EXPORTED PROJECTWISE DGN FILE THROUGH ACCOUNTING.  Access 

MicroStation through Accounting and open an existing native network DGN file or create a file from 

the W drive seed files: 

 

Designer Users: 

W:\Workspace\Standards\seed\CT_Design_3D_V8i.dgn 

W:\Workspace\Standards\seed\CT_Design_2D_V8i.dgn  

Survey Users: 

W:\Workspace\Standards\seed\SV_Survey_3D_V8i.dgn 

W:\Workspace\Standards\seed\SV_Survey_2D_V8i.dgn 

 

7. Reference the exported ProjectWise DGN file using a scale of 1 to 1. 
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