System Manager’s Guide

Release 2.12a

June 2013

Last Updated
June 2013
FieldBook and FieldManager are registered trademarks of Info Tech, Inc. and represent products of Info Tech, Inc. and the Michigan Department of Transportation.

FieldNet is a trademark of Info Tech, Inc. and represents a product of Info Tech, Inc.

FieldBuilder and FieldPad are trademarks of Info Tech, Inc. and represent products of Info Tech, Inc. and the Michigan Department of Transportation.

AASHTO Trns•port, the AASHTOWare logo, Trns•port Estimator, the Trns•port Estimator logo, Trns•port Expedite, the Trns•port Expedite logo, Trns•port FieldBook, the Trns•port FieldBook logo, Trns•port FieldBuilder, the Trns•port FieldBuilder logo, Trns•port FieldManager, and the Trns•port FieldManager logo are registered trademarks of AASHTO.

AASHTOWare Project, AASHTOWare Project Estimator, AASHTOWare Project Expedite, AASHTOWare Project FieldManager, AASHTOWare Project FieldBook, AASHTOWare Project FieldBuilder, and AASHTOWare Project FieldNet are trademarks of the American Association of State Highway and Transportation Officials (AASHTO).

Other product names are trademarks or registered trademarks of their respective owners.

Copyright © 2013, Info Tech, Inc. All rights reserved. Printed in the United States of America. This document or parts thereof may not be reproduced in any form without written permission of Info Tech, Inc.
Contents

1. System Management ............................................................................................................... 1-1
   1.1 Maintain Users........................................................................................................... 1-1
      1.1.1 Users List Window Fields........................................................................... 1-1
      1.1.2 Adding and Changing a User................................................................. 1-2
      1.1.3 Setting the User’s Password...................................................................... 1-3
      1.1.4 Deleting a User......................................................................................... 1-4
      1.1.5 Super-Users.............................................................................................. 1-5
   1.2 Security Model ............................................................................................................ 1-6
      1.2.1 Internal Access......................................................................................... 1-6
      1.2.2 External Access....................................................................................... 1-8
   1.3 Modes of Use .......................................................................................................... 1-8
      1.3.1 Single-User Mode .................................................................................. 1-8
      1.3.2 Multi-User Mode..................................................................................... 1-8
   1.4 Web Services ........................................................................................................... 1-8
      1.4.1 Web Services Browsing........................................................................... 1-9
      1.4.2 Saving and Deleting a Web Image......................................................... 1-9
   1.5 Estimator Options .................................................................................................... 1-9
      1.5.1 The General Tab.................................................................................... 1-10
      1.5.2 The Numeric/Rounding Tab .................................................................... 1-12
      1.5.3 The URLs Tab....................................................................................... 1-13
      1.5.4 The Internet Tab.................................................................................... 1-14
      1.5.5 The Proxy Tab...................................................................................... 1-16
      1.5.6 The Tree Labels Tab............................................................................. 1-16
   1.6 Printing in Estimator............................................................................................... 1-18
      1.6.1 Enabling Rich Text Descriptions and Notes in Custom Reports........... 1-20

2. System Overview ................................................................................................................. 2-1
   2.1 Sample Catalog...................................................................................................... 2-1
   2.2 Catalog Access ....................................................................................................... 2-1
   2.3 Check In/Check Out the Current Catalog.......................................................... 2-2
   2.4 Check for Catalog Updates..................................................................................... 2-3
   2.5 Creating and Updating Catalog or Code Table Information........................... 2-5
      2.5.1 Creating a New Catalog........................................................................... 2-5
      2.5.2 Updating Your Catalog or Code Table Information.............................. 2-11
   2.6 Deleting Catalogs and Code Tables ..................................................................... 2-12
   2.7 Catalog Security ..................................................................................................... 2-13

3. System Architecture ............................................................................................................ 3-1
   3.1 Estimator Data Flow............................................................................................... 3-1
3.1.1 Using Estimator With BAMS/DSS ....................................................... 3-1
3.1.2 Using Estimator With PES ................................................................. 3-2
3.1.3 Using Estimator With CES ................................................................. 3-2
3.1.4 Using Estimator With Non-AASHTOWare Project Software .............. 3-2
3.2 Command Line Options ........................................................................... 3-2

4. Working With Catalogs and Code Tables .................................................... 4-1

4.1 Changing Catalog Element Information .................................................... 4-1
  4.1.1 Using the Find Window ........................................................................ 4-2
  4.1.2 Copying the Current Catalog ............................................................... 4-2
4.2 Maintaining the Standard Item Catalog .................................................... 4-3
  4.2.1 Standard Item Catalog Window Fields ................................................. 4-4
  4.2.2 Adding an Item to the Standard Item Catalog ....................................... 4-4
  4.2.3 Changing a Catalog Item .................................................................... 4-5
  4.2.4 Adding Price Bases to the New Item .................................................... 4-6
  4.2.5 Deleting Price Bases From the New Item ............................................. 4-10
  4.2.6 Sorting the Item .................................................................................. 4-10
  4.2.7 Deleting a Catalog Item ..................................................................... 4-10
4.3 Working With Price Basis Catalogs .......................................................... 4-11
  4.3.1 The Cost Sheet Catalog ..................................................................... 4-11
  4.3.2 The Bid History Catalog .................................................................... 4-15
  4.3.3 Reference Prices Catalog .................................................................. 4-19
4.4 Working With Rate Catalogs ...................................................................... 4-22
  4.4.1 Equipment Rate Catalog .................................................................... 4-22
  4.4.2 Labor Rate Catalog ............................................................................ 4-25
  4.4.3 Material Rate Catalog ........................................................................ 4-27
4.5 Working With Code Tables ........................................................................ 4-30
  4.5.1 Working in the Code Table Catalogs ..................................................... 4-31
4.6 Utilizing Scheduled Catalog Imports ....................................................... 4-34

5. Importing and Exporting Data .................................................................... 5-1

5.1 Importing Catalog or Code Table Data .................................................... 5-1
  5.1.1 Importing CESITEM and BIDHIST Files From BAMS/DSS ............... 5-4
  5.1.2 Importing Code Tables to Estimator ................................................... 5-5
5.2 Importing Estimate Data ........................................................................... 5-7
  5.2.1 Importing an Estimate From PES ....................................................... 5-7
  5.2.2 Importing an Estimate From Excel ..................................................... 5-8
  5.2.3 Importing Project Data From Design Systems Using aecXML ......... 5-10
5.3 Exporting Data ......................................................................................... 5-11
  5.3.1 Exporting Catalogs and Code Tables .................................................. 5-11
  5.3.2 Exporting Estimates .......................................................................... 5-14
  5.3.3 Exporting User Information ................................................................. 5-15

Appendix A. Interface File Specifications ...................................................... A-1

A.1 Importing and Exporting a Project to and From Trns•port PES ............... A-1
  A.1.1 Estimate ............................................................................................. A-4
  A.1.2 EstimateGroup .................................................................................. A-5
  A.1.3 EstimateItem ..................................................................................... A-6
A.1.4 EstimateItemReferencePrice ............................................................... A-7
A.2 Importing and Exporting a Project to and From Trns•port CES ............. A-8
A.2.1 Estimate ............................................................................................. A-11
A.2.2 EstimateGroup ................................................................................... A-12
A.2.3 EstimateItem ..................................................................................... A-13
A.2.4 EstimateItemReferencePrice ............................................................. A-14
A.3 Exporting Project File to Trns•port PES Versions 5.4 or Earlier .......... A-15
A.4 Exporting the Load Proposal Prices File to Trns•port PES Versions 5.4 or
Earlier ........................................................................................................... A-17
A.5 Importing Item Data From AASHTOWare Project BAMS/DSS .......... A-18
A.6 Importing Bid History Data (HIREG Data) From AASHTOWare Project
BAMS/DSS .................................................................................................. A-20
A.7 Importing Code Tables From Trns•port CES or Trns•port PES ........... A-25
A.8 Importing Reference Price Data ............................................................ A-26
A.8.1 The CSV File Format ........................................................................ A-26
A.8.2 The XML File Format ....................................................................... A-27
A.9 Importing and Exporting a Catalog Between Copies of AASHTOWare
Project Estimator .......................................................................................... A-29
A.9.1 Catalog .............................................................................................. A-38
A.9.2 MarketAreaTable .............................................................................. A-39
A.9.3 Bid History Catalog ........................................................................... A-40
A.9.4 CatBidHistoryAverageModel ............................................................ A-41
A.9.5 CatalogCodeTableElement .............................................................. A-41
A.9.6 CatalogCodeTables ........................................................................... A-41
A.9.7 CatBidHistoryCoeffSetNode ............................................................. A-42
A.9.8 CatBidHistoryRegModelCoeffSet .................................................... A-42
A.9.9 CatBidHistoryRegressionModel ........................................................ A-43
A.9.10 CatCostSheetEquipmentSet ............................................................ A-43
A.9.11 CatCostSheetEquipmentSetReference ........................................... A-43
A.9.12 CatCostSheetLaborSet .................................................................... A-44
A.9.13 CatCostSheetLaborSetReference .................................................... A-44
A.9.14 CatCostSheetMaterialSet ............................................................... A-44
A.9.15 CatCostSheetMaterialSetReference ............................................... A-45
A.9.16 CatCostSheetReference ................................................................. A-45
A.9.17 CatPriceBasisList ............................................................................ A-46
A.9.18 CostSheetTable ............................................................................... A-46
A.9.19 CostSheetTableElement .................................................................. A-47
A.9.20 COUNTYCODETABLE ................................................................ A-47
A.9.21 EquipmentTable .............................................................................. A-48
A.9.22 EquipmentTableElement .................................................................. A-48
A.9.23 HWYTYPECODETABLE ............................................................. A-48
A.9.24 ItemTableElement .......................................................................... A-49
A.9.25 LaborTable ...................................................................................... A-49
A.9.26 LaborTableElement ......................................................................... A-49
A.9.27 MaterialTable .................................................................................. A-50
A.9.28 MaterialTableElement ..................................................................... A-50
1. System Management

**Note:** For the purpose of this guide, a system manager refers to anyone who is designated as a super-user with estimate owner access and catalog import and edit ability.

The AASHTOWare Project Estimator™ system manager is responsible for maintaining users and their permissions plus setting the default global option, user options, and system options. The system manager is also responsible for maintaining catalog information.

### 1.1 Maintain Users

Each Estimator user has an Estimator user name and a password. Only super-users can edit existing catalog entries; users that have catalog edit privileges can add entries to the catalogs. When you add a user to the Estimator User list, you must specify each of these attributes. To add or delete users, or set user privileges, select Maintain Users from the Tools menu. This opens the Estimator Users window.

The Users list contains the users authorized to run Estimator. New users can be added to the User list, existing users can be deleted from the User list, and any user data can be modified.
1.1.1 Users List Window Fields

Estimator displays information about each user in the User list window as follows:

**User**
Estimator users must have a name Estimator uses to identify them. Users must enter this name when they run Estimator to gain access to the program.

**Real Name**
The Estimator user's real name.

**Active**
If the Active check box is selected, then the user is an active Estimator user. A non-active Estimator user, for example, would be a person who no longer works for the particular agency, but whose username is still needed to access estimates created with that username. An inactive user can not log in to Estimator.

**Super-User**
If the Super-User check box is selected, then the user is designated as a Super-User. The Super-User privileges are explained in Section 1.1.5.

**New Estimate Access**
This field describes the access the user has to new estimates. There are five different types of access:

- **None**: The user cannot access a new estimate at all.
- **Read**: The user can read a new estimate, but cannot edit any part of it.
- **Write**: The user can read and edit a new estimate.
- **User**: The user can read and edit a new estimate, add users to an estimate, and do a variety of other actions in an estimate, much the same as a user with owner access. A user cannot remove an owner from the list of estimate users.
- **Owner**: The user has the same capabilities of a person with user access, but can also add users to the owner level.

**Entire Catalog**
Selecting the Entire Catalog check box gives the user the ability to edit all the contents of the catalogs.
1.1.2 Adding and Changing a User

When you add a user, you must assign that user a user name. The user name can contain letters, numbers, and punctuation. Estimator user names are not case-sensitive.

The ADD button in the Estimator Users window allows the system manager to add users to the User list. New users are created with the default of Active, with no new estimate access, and without the ability to edit or import any catalogs or code tables. You can also click in the empty line below the last user to add a new user.

![Estimator Users Window](image)

Figure 1-2. Add Estimator User Window
The Username field is required. Super-User status, the ability to edit catalogs and code tables, and the catalog import status can be granted or revoked by selecting or clearing the appropriate check boxes.

To change information about a user, highlight that user in the Users list, and make the desired changes. You can not delete yourself or turn off your active flag, but you can change all other user fields.

Once all the edits are made, there still must be at least one active user. If you are no longer a super-user, but at least one other active user is a super-user, and you click APPLY, you will be able to access the User table until you click OK. Make sure your own settings are as you wish before you click OK.

1.1.3 Setting the User’s Password

Each Estimator user name must have a password with which it is associated. Like the user name, the password can contain letters, numbers, and punctuation. The password you initially create for a user is only temporary because the user can change it without your involvement. There is no way to find out what a user’s password is, but as the system manager, you can change it to a new password if necessary. You can add the password or change the password by selecting the CHANGE PASSWORD button.

![Figure 1-3. Estimator Change Password Window](image)

Enter the new password in the New Password field. Retype the password in the Retype Password field to make sure it was typed correctly. Click OK. If you do not set a password for a new user, the password defaults to password.

Caution: Passwords are case-sensitive.

When you create a password for a new Estimator user, avoid anything obvious. Do not make it the same as the user name or the same password for all users. It is important to tell Estimator users to change their passwords right after they first run Estimator. For maximum security, encourage users to be careful about choosing their passwords and to follow these guidelines:

- Never use the same phrase for both the user name and password.
Do not pick a word or phrase that can be easily guessed. Avoid names of a spouse, child, or pet, and avoid phrases associated with your favorite sport or hobby. Do not use a telephone number or social security number.

Mixing letters, digits, and punctuation makes a password harder for others to guess.

Never write the password down.

Although the Estimator user name is not case-sensitive, the password is.

Users can change their own passwords by selecting Change Password from the Tools menu. They must know their password in order to change it.

1.1.4 Deleting a User

The DELETE button allows the system manager to delete a selected user(s) from the User list. You can not delete yourself from the Users list.

To delete a user from the User list, select the user. You can select several users in the User list that are adjacent by pressing the SHIFT key while you select the first and last users with the mouse. You can select users that are not adjacent to each other by pressing the CTRL key while selecting the desired users with the mouse. When the user(s) you want to delete has been selected, click the DELETE button.

1.1.5 Super-Users

Any Estimator user can be designated as a super-user. Super-users have important privileges that are not available to other Estimator users:

- Only super-users can edit the User list.
- A super-user can open any Estimator estimate file and have owner privileges in that file, provided that the estimate matches the agency brand.
- Super-users can import and edit catalogs.

As a system manager, your Estimator user name must have super-user privileges so you can add new Estimator users.

Because super-users can edit the Users list, they can grant themselves any privileges they want. They can also deny anyone else those same privileges. Be extremely careful to whom you grant super-user privileges.
1.2 Security Model

Estimator provides a multi-layer security model to control and authorize access to data used and created by Estimator from internal and external processes.

1.2.1 Internal Access

This section describes the elements of the security model that controls access to entities from within the Estimator software.

Branding

Each agency’s version of Estimator contains a branding identifier (ID) or brand designated by a combination of their agency ID, location, and installation key and then passed through an encryption function. This brand is embedded inside catalogs and estimates created by Estimator. If Estimator tries to load a catalog and the portion of the brand that identifies the agency ID does not match the brand of the Estimator version trying to load it, the load fails and Estimator displays an appropriate error message. The brand is also kept in the User table. Any attempts to run Estimator and log in with a User table that carries a different brand results in failure and an appropriate error message.

User Table

Estimator uses a file to contain user information. The file is created during the installation process. When users run the installation program for the first time on a particular machine, and the type of install is single-user, the installation creates a default User table during a successful installation. For multi-user installations, where the user table must be located on a Web server, the server installation creates a default user table.

If a user runs the installation program on a machine with Estimator already installed and a valid User table is not found in that location, the user is prompted with two choices:

1. Create a new default User table.

2. Re-install the program, which is usually used to repair damaged program files.

The most-recently-used user ID is kept at the machine level. When a user starts Estimator, this user ID appears as the default for log in. If the password in the User table for this user ID is blank, Estimator logs in without prompting the user. Otherwise, Estimator opens a dialog box (containing OK and CANCEL buttons) to prompt the user for user ID and password information. If the user clicks OK without entering an ID and password, an appropriate error message displays. If the user clicks CANCEL, Estimator closes. If the user clicks OK with a user ID and password entered, Estimator verifies that the user ID exists in the User table and that the password is correct. If either is invalid, or the user ID and password match a record in the User table but that user ID is marked
inactive, Estimator responds with an appropriate error message and allow the user to retry; otherwise, Estimator logs in as the indicated user.

The User table contains privilege information about each user, including the following:

- User ID
- User's real name
- Active/inactive flag (inactive users cannot log in)
- Super-user flag
- Privileges for new estimates (none, read, write, user, owner)
- Allow catalog editing flag
- Allow catalog imports flag
- Password

A super-user has several privileges beyond a normal user besides special treatment during security checks at various points in Estimator. Only a super-user can clear a record’s Trnsport flag, edit the User table, and change Estimator’s catalog location. When Estimator verifies user privileges with respect to estimates and catalogs, super-users automatically have full access.

Estimates

Each estimate contains its own user list, which consists of user ID, agency ID, location, and estimate access level (read, write, user, and owner). When a user creates an estimate, the user list in the estimate lists the users that have access to new estimates specified in the Estimator Users list. In addition, Estimator adds the current user ID to the estimate user list if it is not already present and convert it to Owner.

When an estimate is loaded, Estimator compares the current user to the estimate user list. If the current user does not exist in the list, the estimate will not load and Estimator displays an appropriate error message. If the current user exists with read privileges, the estimate will be opened in read-only mode. If the current user exists with write, user, or owner privileges, the estimate is opened in editable mode with only an owner or user able to edit the estimate user list. The user privilege cannot add owners, delete owners, change an owner’s level to below owner, or change a non-owner to an owner.

Catalogs

Catalogs do not contain user-specific information. The ability to load a catalog depends only on the portion of the brand that identifies the agency brand security level. Estimator disables the ability to create a new catalog and check out an existing catalog for users
with a catalog access level of read. If a user with a catalog access level of write attempts
to check out a catalog that carries a different brand, an appropriate error message displays
and the catalog is not checked out.

1.2.2 External Access

The security model controls access to internal entities such as estimates and catalogs and
external entities such as export files from other software. Estimates and catalogs are
encrypted using the standard RC4 encryption algorithm to prevent other programs from
gaining unauthorized access.

1.3 Modes of Use

Estimator is designed to run in two modes: single-user and multi-user.

1.3.1 Single-User Mode

In single-user mode, the catalogs and user list reside in a file on the local computer. The
URLS tab of the Global Options window reflects the location of the catalog on the local
computer.

1.3.2 Multi-User Mode

In multi-user mode, the catalogs and user list reside on a Web server or network location.
During installation of Estimator, the administrator has to setup or configure a Web server
to serve as the Estimator Web server. The URLS tab of the Global Options window
reflects the location of the catalog on a Web server or network location.

1.4 Web Services

The Web Services option enables users to connect to a specified Web site. Web sites that
contain useful estimate pricing information are normally identified; however, any Web
site can be specified. Super-users can identify as many Web sites as desired.

You can associate a Web service with more than one entity by entering the same URL in
the URL field for each service.

Each Web service contains three fields:

- **Name** A value that helps users differentiate services.
- **Entity Type** Any of the supported Estimator entities that can have an associated
  Web service.
URL

The Web service address plus argument parameters. The address and parameters consist of a variable name and an entity field in the form of Name=<%Fieldname%>, where Fieldname would be the name of an Estimator data field and Name would be the argument name passed with the field to the server.

The name of each argument will be user defined. Typically it will be associated with a field of the service’s corresponding entity type. For example, a Web service intended to return content relevant to an estimate item might appear as follows:

http:\stdot.com\itemfolder\script.pl?Amount=<%Quantity%>&Item=<%Itemnumber%>

Presumably this would be a Web service that returned content relevant to an item’s quantity and item code. Using the above syntax you are able to associate arguments with particular element fields. Additionally, constants will also be definable; for example, MyNumber=12 or MyCounty=Suffolk.

As is customary for Web addresses, the server and the parameters are separated by the '?' character and each parameter is separated by the '&' character. Note that the variable name and the actual name of the Estimator field are totally independent; for example, Quant=<%Quantity%>, allowing you to name the parameters the way a preexisting service expects them to be named.

1.4.1 Web Services Browsing

Any detail view for an entity that has one or more associated Web services displays a tab for each associated Web service. Each tab is displayed in the entity's detail window after the NOTES tab. When the user selects a Web service's tab, Estimator navigates to the URL associated with the Web service. The parameters in the URL is updated with actual field values of the Estimator data element.

1.4.2 Saving and Deleting a Web Image

You can save an image of the page the Web service displays. To do this, click the disk icon in the Web service window toolbar. The image is attached to the Estimator element and is saved into the estimate or catalog. The image is displayed in a browser view and is assigned a name of the original web services name and the date the image was saved. The saved image can be removed by pressing the delete button (labeled by a red X icon) in its browser view.

1.5 Estimator Options

You can set options in Estimator to reflect global options. Global options are options set that effect every estimate created on a user’s computer. You can set the defaults for these
options, but Estimator users with User or Owner privileges can change them with the Estimate Options command as they see fit.

1.5.1 The General Tab

The **GENERAL** tab sets the options for the estimate archive and auto-save functions. It also allows you to enter the agency's name and use out of range bid history prices.

![Figure 1-4. The Global Options Window - General Tab](image)

These are the options available on the **GENERAL** tab:

- **Agency Name**: The agency brand for this copy of Estimator. This name appears on printed estimates. Only the system manager can change this option.

- **Auto Save Interval (minutes)**: Estimator has an auto-save feature that automatically saves every open window after the designated time has elapsed. These saved files can then be accessed in case of a power-outage, or if Estimator is shut down in an unconventional way. The Auto Save function is turned off if you set the Auto Save Level to 0.

- **Archive Level**: When you save your estimate, Estimator keeps the former estimate intact in an archive. You can archive up to nine levels.
These files can be accessed in the directory where the estimator.exe file is kept. The Archive function is turned off if you set the Archive Level to 0.

<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Verify Estimates Upon Opening</strong></td>
<td>If this box is selected, the Estimator software runs a verification check on an estimate when it is opened. A message displays only if there are errors in the estimate.</td>
</tr>
<tr>
<td><strong>Estimate Out of Range Bid History Prices</strong></td>
<td>Usually when using a bid history, the outliers of an item occurrence or quantity entered into an estimate (that is, any number that falls below the 5th percentile or above the 95th percentile) is not used in calculating the bid history price. If this option is selected, then the bid history will use all of the item’s occurrences. Only the system manager can change this option.</td>
</tr>
<tr>
<td><strong>Roll Up Item Quantity for Bid History Prices</strong></td>
<td>When bid-based prices are used, the cost of the item usually lowers when a high quantity of an item is purchased. Using a bid-based item price across multiple groups does not give you the advantage of a high quantity purchase. When bid history items match estimate item codes and both estimate items are priced with a single bid history record matching the same item code, you should roll up the quantities bid-based items across multiple. Only the system manager can set this option.</td>
</tr>
<tr>
<td><strong>New Estimate Use only Trns•port items and codes</strong></td>
<td>When adding items and code table values to your estimate, only ones that are compatible with AASHTOWare Project (Trns•port) applications will be available when this option is selected. Only the system manager can set this option.</td>
</tr>
<tr>
<td><strong>Prohibit Duplicate Line Numbers</strong></td>
<td>When copying items from one group to another, if this global option is disabled, the target items will have the same line numbers as the source. Enabling this option forces the target items’ line numbers to increment based upon the agency’s defined line number increment setting.</td>
</tr>
<tr>
<td><strong>Prohibit Multiple Active Price Bases</strong></td>
<td>When this option is enabled, a user may have only one active price basis for an estimate item. If an active price basis already exists and a user adds a new price basis, the first will be toggled inactive and the newly added price basis will become active.</td>
</tr>
<tr>
<td><strong>Require Exports in Upper Case</strong></td>
<td>When this option is selected, any exported data will use entirely upper-cased lettering for compatibility with systems that support it. Mixed casing is still used within the AASHTOWare Project Estimator application.</td>
</tr>
<tr>
<td><strong>Evaluate Formulas When Data Changes</strong></td>
<td>When this option is selected, formulas will be automatically recalculated when a numeric field value that a formula references is changed.</td>
</tr>
</tbody>
</table>
Note: When using the Roll Up Item Quantity for Bid History Prices feature, the application enforces a safety permutation limit to prevent Estimator from responding slowly when the estimate contains numerous alternate items. This safety limit can be modified in the estimator.ini file.

1.5.2 The Numeric/Rounding Tab

The NUMERIC/ROUNDING tab sets how you want the estimate to round its prices, extended amounts, and quantity. It also sets the line and group number starts and increments. Only the system manager can change options on this tab.

These are the options available on the NUMERIC/ROUNDING tab:

**New Estimate Unit Price Rounding Level**
You can choose to round estimate unit prices from between one dollar ($1.00) to thousandths of cents ($0.00001).

**New Estimate Extended Amount Rounding Level**
You can choose to round an estimate’s extended amount from between one dollar ($1.00) to thousandths of cents ($0.00001).

**New Estimate Quantity Rounding Level**
You can choose to round estimate quantities from between one unit to thousandths of unit.

**Line Number Start**
This is the line number that appears when a new item is added to
an estimate.

<table>
<thead>
<tr>
<th>Line Number Increment</th>
<th>This is the amount the line numbers increment when new items are added to an estimate.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group Number Start</td>
<td>The first group in an estimate is given this number when it is created.</td>
</tr>
<tr>
<td>Group Number Increment</td>
<td>Each successive groups are numbered in this increment from the first group.</td>
</tr>
<tr>
<td>Increment Line Number Start by Group Number</td>
<td>Each item is numbered according to the group number, though incrementing accordingly within the group.</td>
</tr>
</tbody>
</table>

### 1.5.3 The URLs Tab

The **URLS** tab contains the paths for your catalog, estimate, template, custom print reports, and cache folders.

![Estimator Options Window - URLs Tab](image)

**Figure 1-6. The Global Options Window - URLs Tab**

Here are the options available on the **URLS** tab:

**Catalog Path (HTTP or file)**

This field displays the location of the Estimator catalogs. This is
the directory Estimator displays when you select Switch Catalog from the Tools menu.

**Estimate Folder**  This is the directory to which new estimates are saved.

**Template Folder**  This is the directory where estimate templates are kept. Only the system manager can change this option.

**Reports Template Folder**  This is the directory where customized print report templates for estimates are kept. Only the system manager can change this option.

Optional report templates can be created with the full version of the Crystal Reports® software and placed in the directory specified in this field. These reports will be available in the Print Options window when you print an estimate.

**Cache Folder**  This is the local directory that Estimator uses for file downloads when your user table or catalogs are stored on a web server.

Only the system manager can change the Template path and the Reports Template path on this tab.

**1.5.4 The Internet Tab**

The **INTERNET** tab allows Estimator to connect to a Web server and look for catalog updates, and download them into the Current Catalog. Any user can change the options on this tab.
These are the options available on the **INTERNET** tab:

**URL**

The Internet site designated by the transportation agency where the catalog updates are located.

**Username**

If the Internet site is secured, the username that will allow you to access the site.

**Password**

If the Internet site is secured, the password that will allow you to access the site.

**Automatically Search for Catalog Updates on Startup**

This option tells Estimator to look for catalog updates each time you start the program. You can also search for catalog updates by selecting **Check for Catalog Updates** from the **Tools** menu.

**Download Folder**

The Download Folder field displays the local directory that Estimator uses for file downloads when you run the Catalog Update command.
1.5.5 The Proxy Tab

The PROXY tab controls the way Estimator connects to the Internet. Any user can change the options on this tab.

![Estimator Options Window - Proxy Tab](image)

Figure 1-8. The Global Options Window - Proxy Tab

These are the options available on the PROXY tab:

- **Direct Connect to the Internet**: This indicates that your computer does not need to go through a proxy server to access the Internet.

- **Use Windows settings to connect to the Internet**: This tells Estimator to check the Windows settings when connecting to the Internet and to use the same settings.

- **Manual, use this proxy server**: Use this option to have Estimator use a proxy server not indicated by your Windows settings. Fill in the proxy server name in the Server field and the port number in the Port field.

1.5.6 The Tree Labels Tab

The TREE LABELS tab allows you to label the different parts of the estimate in the tree view. The labels appear for each element of an estimate. Only the system manager can change these options.
These are the options available on the TREE LABELS tab:

- **Estimate**: The label of the estimate.
- **Group**: The label of the group.
- **Item**: The label of the item.
- **Task List**: The label of the Task List.
- **Ref Price**: The label of the Reference Price.
- **Bid History**: The label of the Bid History.
- **Cost Sheet**: The label of the Cost Sheet.
- **Equipment**: The label of the equipment.
- **Labor**: The label of the labor.
- **Material**: The label of the material.

The question mark (?) box next to each field contains the list of the fields after which the label can be named. For example, for the Estimate field, if you select %1, then the label will be based on the Estimate ID field. If you do not include a %, then the field will always be named after the text.
1.6 Printing in Estimator

Estimator uses the Crystal Reports Viewer to produce a quality printout of the selected estimate or catalog elements. When you print an estimate or parts of a catalog, your agency name will appear on the printed report provided the information has been entered in the Global Options.

The Estimator catalog document typically has all supported entities and may have thousands of records per type. Consequently, you will not be able to print the entire Current Catalog. Instead, the print capabilities are broken into contextual subsets of the catalog. There are two types of reports: detailed for a single catalog element and tabular for multiple catalog elements.

Single Catalog Element Detailed Reports contain these features:

- A detailed printout of a single catalog item and its associated price bases.
- A detailed printout of a single catalog cost sheet and its child labor, equipment, and materials rates.
- A detailed printout of a single catalog bid history element.

The detailed printouts of catalog reference prices, catalog labor/material/equipment rates, and catalog code table entities will be implemented by using each elements' tabular report format with only a single element displayed in the report. This is because these elements have simple data models and the data expressed in the tabular reports for these elements is comprehensive.

Multiple Catalog Elements Tabular Reports contain these features:

- One or more catalog items without associated price bases.
- One or more catalog cost sheets without associated child rate information.
- One or more catalog bid history elements without child regression or average data.
- One or more catalog reference price elements.
- One or more catalog labor elements.
- One or more catalog material elements.
- One or more catalog equipment elements.
- One or more catalog code table elements.

To print a part of the catalog, you must first select what you want to print. To print more than one element in a catalog, you can select those elements by pressing and holding
down the SHIFT key while selecting the first and last element. For elements that are not contiguous, you can select each element individually by pressing and holding down the CTRL key while selecting each individual element.

To print an estimate, open the estimate.

Once you have the estimate open or the desired elements of the catalog selected, select **Print** from the **File** menu. If you are printing an estimate, Estimator displays a Print Options window.

![Figure 1-10. Estimate Print Options](image)

Note: For a detailed explanation about the different estimate print options, please see the *Estimator User's Guide*.

If you are printing a catalog, or after you choose your print options and click OK if you are printing an estimate, Estimator displays a Print window.
Select the options you want for this print job and click OK. Estimator displays a status window and returns you to the estimate or catalog elements when the print job is completed.

1.6.1 Enabling Rich Text Descriptions and Notes in Custom Reports

Custom Crystal reports can be configured to allow rich text options (such as bolding, italics, text alignment, and so on) in certain fields. This can be configured in Crystal Reports Viewer application.

1. Open the .rpt file for the report in the Crystal Reports Viewer application.

2. For each field in the report that is associated with a description or note data in element, do the following:

   A) Right-click on the field in the report.
   
   B) Select Format Field, and then the Paragraph tab.
   
   C) Set the Text Interpretation parameter to RTF Text.

3. Save and close the report.
2. System Overview

Information used in creating estimates is stored in catalogs and code tables. These catalogs contain standard items, prices bases (cost sheets, bid histories, and reference prices), and rates (equipment, labor, and material).

The Code Tables are used to assign values to certain fields. Most fields with a drop down list use a code table value. Most of the fields on the estimate’s header window use code table values, such as Work Type, Season, and County.

Maintaining the catalogs and code tables and keeping them updated is very important to providing accurate estimates. Catalog and code table data can be imported from other sources, or entered manually.

2.1 Sample Catalog

The Estimator software includes a sample catalog that can be used for training or demonstration purposes. It is included on the Estimator disc as an XML file and must be imported into Estimator before it can be used. Please see Chapter 5 for instructions on importing an XML file.

To access the sample catalog once it’s been imported, select Open Catalog or Switch Catalog from the Tools menu. The Estimator software opens the Select Catalog to Open window. Select the sample catalog and click OK.

2.2 Catalog Access

When setting up catalog and code table access, there are different choices to use. The catalogs and code tables can be stored in files on a computer, files accessible from the Internet, or as one file on the Internet.
If the catalogs are set up on a computer, the Catalog Path field on the URLS tab of the Global Options window is set to the catalog directory (c:\estimator\catalogs, for example). If it is set to an HTTP address and there is multiple catalog access, then the Catalog Path field is set to an Internet address. If it is set to an HTTP address for only one catalog, then the Catalog Path field is set to an Internet address that ends in .cat. Catalogs can only be accessed by an Internet address if a Web server is installed on the host computer (please see the Estimator Web Server Installation Guide).

Estimator users can use catalogs stored in a local file or on a Web server, but this location can be changed at any time when an estimate is opened by a user with user or owner access by selecting Estimate Options from the Tools menu and editing the Catalog field. This location can be a directory or an Internet address.

When the user chooses to open or switch to a different catalog, a window lists the catalogs available at the catalog location. After the user selects a catalog and clicks OK, Estimator tries to load that catalog. If the catalog location is a local file, the file will be loaded. If the catalog location is an Internet address, Estimator will compare the time/date stamp of the catalog to any cached copies of the catalog that might be present and the catalog cache will be refreshed if needed. Estimator will then load the catalog from the cache.

2.3 Check In/Check Out the Current Catalog

If you are using Estimator through an HTTP server, then the possibility of two super-users updating the same Catalog at the same time may occur. For this reason, Estimator uses a Check In/Check Out system for editing the current catalog.

When you wish to make changes to a Catalog through an HTTP server, you must first check it out by selecting Check Out Current Catalog from the Tools menu. In effect, this places the Current Catalog on your computer so you can make changes. While the Current Catalog is checked out, other Estimator users are still able to view and use the catalog, but no one else can make changes to it, and opening the catalog results in a read-only current catalog window.

Once the changes to the Catalog are made and saved, you must then check the catalog back in to Estimator. If you do not check the Current Catalog back in to Estimator, then any changes you made to the catalog are only saved on your computer, not in Estimator. Check in the catalog by selecting Check In Current Catalog from the Tools menu. Any changes made to that catalog are now in Estimator.

The next time a user starts Estimator, Estimator gets the latest version of the Current Catalog to use in the estimate as long as the option Automatically Search for Catalog Updates on Startup is selected on the Global Options INTERNET tab. You could notify other Estimator users that the catalog has changed, but it is not necessary, as long as the users restart Estimator at the beginning of each day.
If you make changes to a checked-out catalog, but do not wish to put those changes into Estimator, then you can cancel the check out. This leaves the Current Catalog the exact same way it was before it was checked out. To cancel a checked-out current catalog, select **Cancel Check Out** from the **Tools** menu.

### 2.4 Check for Catalog Updates

If the transportation agency has established a Web site where it will post catalog updates, you can update your catalogs by selecting **Check for Catalog Updates** from the **Tools** menu. Before you use this option, however, the URL of the site has to be entered into the URL field of the **INTERNET** tab of the Global Options window.

Once you select Check for Catalog Updates from the Tools menu, a wizard appears that checks for updated catalogs by comparing the dates of the catalog on the site to your catalog in Estimator.

![Check for Updates Wizard](image)

**Figure 2-1.** Check for Catalog Updates Wizard

Follow the instructions on the wizard to update your catalog. Depending on the security of the Web site, you may need to enter a username and password to access the updates.

The Catalog Update wizard works as follows:

The transportation agency may have set up a feature on the Internet or a Web server that will allow you to download the latest catalogs. In order to use this feature you must have the correct URL in the URL field of the Internet Data Download section of the **INTERNET** tab in the Global Options window. The URL should be a Web server folder similar to:

http:\myserver.com\myfiles\
This folder on the Web server should contain a file created by the transportation agency named 'list.csv'. Each line in that file represents a different file. These different files contain the updated catalogs. The columns are the agency description field, the filename field, the file description field, the datetimestamp field, and the file size field.

STDOT, Items.xml, Item List (Eng), 20021101120910, 6685693
STDOT, BidHistories.xml, BidHistory(English), 20021101120913, 4042221
STDOT, CostSheets.xml, Cost Sheets, 20021101120911, 734261
STDOT, Equipments.xml, Equipment, 20021101120914, 19294
STDOT, Labors.xml, Labor, 20021101120915, 14707
STDOT, Materials.xml, Materials, 20021101120916, 12666
STDOT, test.cat, Test Catalog Download, 20021101120916, 2170

The agency descriptor field (the first field), the file description field (the third field) and the file size field (the last field) are for informational purposes only.

The Filename field contains the name and extension of the file, like Items.xml or hreg.csv. If you ask to get this file, Estimator will append this to the server folder and try to obtain the resulting URL; for example, http:\myserver.com\myfiles\hreg.csv. The accuracy of the filename is extremely important.

The File description field informs you what the file contains; for example, BidHistory(English).

The Datetimestamp field for the file in the format of YYYYMMDDHHMMSS, for example 20021101120916. This field is updated every time the DOT posts a new version of the file. Estimator uses this field to compare you catalogs to what is posted. If the posted catalog is newer than your version, then it downloaded.

The File size field is informational, and contains the size of the file that you are downloading.

When you run the Catalog Update wizard, Estimator obtains the list.csv file, parses it and asks the user which parts of the file they want. Estimator also filters out files the user already has by comparing the timestamp of the user's files to the timestamp of the .csv file. Users select the files they want in the Catalog Update wizard and the catalog is updated by each of the files selected.

- **Note:** This option is also available when you start Estimator. Access the INTERNET tab of the Global Options window and select Automatically Search for Catalog Updates on Startup.
2.5 Creating and Updating Catalog or Code Table Information

The Standard Item Catalog, the three price bases catalogs, the three rate catalogs, and the code tables can all be accessed through the catalogs. You can create new catalogs to hold this information, or update existing catalogs with new information.

2.5.1 Creating a New Catalog

Creating a new catalog allows you to create, set up, and populate an entirely new Estimator Catalog, including code tables. You can create a new catalog using the New Catalog command, or you can create a new catalog using the New Catalog Wizard.

Using the New Catalog Command

To use the New Catalog command, select New Catalog from the Tools menu. Estimator opens the Create a New Catalog window.

![Create New Catalog Window]

Enter the new catalog name in the empty field. The catalog name should reflect information about a catalog - the date of creation, the spec year of the information, and the system of measurement (English or metric). For example, 2002_06_97E would mean a catalog created in June of 2002 for spec year 97 with an English system of measurement.

Once you have entered a catalog name, click OK. After you click OK, the catalog opens to the header window.
Before you can import or manually add catalogs or code tables to the new catalog, the catalog header information must be filled in. Fill in the spec year and a brief description of the Catalog. Once the header information is complete, you are ready to begin entering catalog and code table data. Catalog and code table information can be entered manually, imported from another AASHTOWare Project application, or imported from another data source.

! **Caution:** If an estimate is going to be used in conjunction with another AASHTOWare Project application, then catalog and code table entries should not be manually created.

**Using the New Catalog Wizard**

The New Catalog Wizard walks you through the steps of creating a new catalog, including uploading the files to populate the catalog. You can cancel the catalog creation at any time by clicking CANCEL.

Select **New Catalog Wizard** from the **Tools** menu. Estimator displays the Create New Catalog window.
Enter the new catalog name in the empty field. The catalog name should reflect information about a catalog - the date of creation, the spec year of the information, and the system of measurement (English or metric). For example, 2002_06_97E would mean a catalog created in June of 2002 for spec year 97 with an English system of measurement.

Once you have entered a catalog name, click OK.

- **Note:** Once you click OK after naming your new catalog, Estimator creates the new catalog. If you click CANCEL any time after you click OK, Estimator creates a catalog with no data.

After you click OK, Estimator displays the New Catalog Wizard. Enter a Spec Year and Description of your new catalog and click NEXT.
After you click NEXT, you can choose to the method in which the data will be loaded. After you select the method, click NEXT.

There are two different ways the catalog data can be loaded: From an XML file and from CESITM and HREG files.

*Load New Catalog From XML File*

If your new catalog data is being loaded from an XML file, the Load XML File window appears.
Figure 2-6. New Catalog Wizard - Load XML File

Enter the name of the file in the File field, or click BROWSE to find the file. Once the name is entered, click NEXT. The window appears again. Enter another file name, or click NEXT while the File field is blank to continue to the next window.

The Catalog Complete window appears.

Click DONE to return to your new catalog.

Load New Catalog From CESITM and HIREG Files

If your new catalog data is being loaded from CESITM or HIREG files, the Load Catalog Information window appears.
Enter the spec year for the items in the Spec Year field. Enter the CESITM file name, the HREG file name, and the Code Tables file name in their respective fields or click BROWSE to find the file. You do not have to enter a file name for every field. Once the selected fields have been filled in, click NEXT.

Estimator downloads the file. When it is finished, the Import Results window appears.

Click OK after you read the results of the import. The Catalog Complete window appears.
Click DONE to return to your new catalog.

2.5.2 Updating Your Catalog or Code Table Information

Catalog bid histories and item lists should be updated every month or at a minimum of every quarter. Cost sheets should be updated at a minimum of every year. Code tables need updating less often, for most information will not change.

To update catalog and code table information, make sure the catalog or code table being updated is located in the Current Catalog. Do this by selecting Switch Catalog from the Tools menu. Select the correct catalog in the Select Catalog to Open window, and click OK.

The selected catalog becomes your Current Catalog. You can then update the catalog and code tables by importing or manually changing the catalog and code table entities.
For more information on importing catalogs and code tables to update information, see Chapter 5.

Be careful when importing a catalog, however. When Estimator imports catalog or code table data, the import file merges with the data currently in the Current Catalog. If the import file contains an element with a field already in the catalog or code table, Estimator overwrites the catalog or code table element with the updated information. If the import file contains an element with a field that is not yet in the catalog or code table, Estimator adds that element to the catalog or code table. Fields without corresponding elements in the import file remain the same.

If you have not provided required information, if you are importing a file that requires user interaction, or if there are errors, Estimator will stop the process and prompt you for action or exit the process, depending on the specific circumstances.

### 2.6 Deleting Catalogs and Code Tables

You can not delete specific catalogs or code tables within the Current Catalog. You can delete either individual catalog and code table entries or the entire Current Catalog.

To delete a catalog or code table entry, open the Catalog that contains the entry. Select that entry in either the grid or tree area and choose the **Delete** command from the **Edit** menu. The Delete command names the entity being deleted - for example, if you were to delete a bid-based price, the command would read Delete Bid-based Price. If you were to delete a code table entry, the command would read Delete Code Value.

To delete the entire Catalog, select **Delete Catalog** from the **Tools** menu. The Catalog you are deleting does not have to be the Current Catalog. Estimator displays a Select Catalog to Delete window.

![Select Catalog to Delete](image)

**Figure 2-12. Deleting a Catalog**

Select the catalog to delete and click **OK**, or click **CANCEL** to stop the deletion.
2.7 Catalog Security

When Estimator is installed, it asks for an agency and a location, which have been assigned to the Estimator licensee. These two pieces of information are used to create a brand unique to the agency/location pair. Catalogs and estimates created by a particular installed copy of Estimator are marked with that copy of Estimator’s brand. The brand is used in conjunction with other security measures, such as the global user table, to restrict access to estimates and Catalogs in various ways to ensure that only the proper users have access to particular estimates and Catalogs.

The ways the brand is used includes:

- Catalogs have to have either the exact same brand or same agency and location 00000.

- Estimates ignore the brand if a match is found in the estimate user table for the current user. If no match is found and the current user is a super user, then the brand has to match exactly in order to let that access take place.

Users can schedule catalog imports only if they have Catalog Import rights.
3. System Architecture

Estimator estimates are created using information in the catalogs and code tables. This information can be accessed by the estimate either by a drop down list in the appropriate window, or dragging the information from the catalog into the estimate.

Whenever an item is placed in an estimate, Estimator also brings over any associated elements, such as cost sheets, reference prices, or bid-based prices.

3.1 Estimator Data Flow

Estimator is able to import catalog and item information from AASHTOWare Project BAMS/DSS™, export estimate information for use in Trns•port PES® project and proposals, and interact with Trns•port CES®. Estimator also can export its information in the form of TXT, HTM, CSV, XLS, XLSX, and XML files for use in other applications. Also, Estimator can import TXT, HTM, CSV, XLS, XLSX, and XML files created in other applications.

3.1.1 Using Estimator With BAMS/DSS

AASHTOWare Project BAMS/DSS provides a complete historical database of construction contract information, a set of analysis models, and the capability for ad hoc query and analysis. The BAMS/DSS module provides a fully integrated management decision support system that enables highway agencies to monitor and analyze bidding activity, item price estimates, and vendor activity.

BAMS/DSS models create bid history information and item information for use in Estimator catalogs. Views are created in BAMS/DSS to determine what information will go into the files for Estimator.

For more information on Estimator and BAMS/DSS, please read the BAMS/DSS Interaction Guide.
3.1.2 Using Estimator With PES

Estimates consist of groups and items used in construction. These items typically fall into different estimate categories for funding purposes. If you are using Estimator with PES, you can create the estimate in Estimator, then export it to PES for further refinement. After item and quantity changes, PES can pass the estimate back to Estimator for pricing.

For more information about using Estimator with PES, please read the PES Interaction Guide.

3.1.3 Using Estimator With CES

Estimator helps agencies estimate the cost of a construction project using cost-based, bid-based, quote-based, and ad hoc estimation methods. Estimator automates estimation data gathering.

CES provides state highway agency estimation staff the means by which to produce various types of job estimates such as parametric, cost-based, and bid-based estimates. Predefined and ad hoc formulas can be incorporated in the estimation process, and users can assign funding and program information to CES jobs.

For more information about using Estimator with CES, please read the CES Interaction Guide.

3.1.4 Using Estimator With Non-AASHTOWare Project Software

Estimator works with ease when it interacts with BAMS/DSS, PES, and CES, but its importing and exporting functionality are not limited to those applications. Estimator estimates and Catalogs are exported as XML files and can be imported into other software applications. Additionally, estimates can be exported as TXT, HTM, CSV, XLS or XLSX files.

Estimator is also able to import XML, CSV, XLS, XLSX, and TXT files that are in the proper format. When importing, Estimator reads the incoming file and determines if it is Catalog information or estimate information, and places it accordingly.

3.2 Command Line Options

Estimator supports some command line options. To run these command line options, enter the name of the Estimator executable followed by the parameter and the parameter value. (For example, estimator.exe -user=UserName. You can also use / in place of - before the user, and a : instead of =)

**estimate** The file name of an estimate to load or a file to import.  The
estimate is not loaded until you log in and then it is loaded only if you have permission to open the estimates.

When using this command line option, you do not need the parameter, just the parameter value. (For example, estimator.exe EstimateName.)

-**user=username**  An optional parameter to provide Estimator’s login with the username. This prevents the user from having to enter the username every time he or she runs Estimator. The username should follow -user on the command line. Note that this option poses a security risk.

-**pass=password**  An optional parameter to provide Estimator’s login with the user’s password. This allows the user to not have to enter the password every time he or she logs in. Note that this option poses a security risk.

-**cata=catalog**  An optional parameter to automatically update new catalog information upon logging in to Estimator.

-**p filename.est**  An optional parameter used on a command line to print an estimate on your default printer.

-**pt filename.est printer driver port**  An optional parameter used on a command line to print an estimate on a specific printer.

**Caution:** If you edit a shortcut that you are using to run Estimator (for example, your Start menu shortcut) by providing user and/or password parameters, be aware that you are compromising the security of your Estimator data files. Anyone having access to your computer can log in without providing a username and/or password, and anyone can read your username and password from the shortcut file. Only use these options if you are not concerned with the potential security risk.
4. Working With Catalogs and Code Tables

Highway construction estimation is based on experience. Estimators use a core set of information to develop several different estimates. Estimator catalogs and code tables store core information for use in estimation. The Estimator catalogs and code tables make data readily available through a well-organized, easy-to-use interface. You can quickly use information from the catalogs and code tables in your Estimator estimates.

Information in a catalog can change for a variety of reasons. For example, the minimum wage might increase, which in turn may change the labor rate catalog. A supplier might change its quote for materials, which would change the reference price catalog and the material rate catalog. As a system manager, you are responsible for keeping the information in these catalogs current. Code tables change, but not with the frequency of catalogs. You can keep the catalogs and code tables updated by importing new catalogs and code tables or manually changing the catalog and code table information.

Whether you import a catalog or make manual changes to update it depends on if you are using Trns•port as your data source. If the catalog has already been updated or created in another application, importing the catalog would be more beneficial. For more information on importing in Estimator, please see Chapter 5.

4.1 Changing Catalog Element Information

Change can be made to any of the user-modifiable Catalog information values, including the name of the Catalog and its description. To make these changes, open the desired Catalog, click in the field you wish to change, and enter the new information. Users who have the catalog or code table edit flags set when their user profiles are created can change the catalog or code table names and descriptions, or add entries to the catalog elements for which they have permission.
4.1.1 Using the Find Window

You can use the Find window to find any catalog element in the Standard Item Catalog, the Cost Sheet Catalog, the Bid History Catalog, or the Reference Price Catalog. Only one catalog can be searched at one time.

To use the Find window, have the Current Catalog open and select **Find** from the Tools menu. Choose the specific catalog you wish to search. Estimator opens the Find window for the selected catalog.

![Find Cost Sheet Window](image)

Figure 4-1. Find Cost Sheet Window

Enter your search criteria in the available fields, which will differ depending on which catalog you are searching. The elements that fit the criteria are listed in the Matches list. Select the desired match and click **OK**. Estimator displays the row in the catalog for that element.

If you know the exact content for the field for which you are searching, you can use the Expert Mode checkbox when you conduct your search. The Expert Mode finds only what is entered into the available fields. For example, if you enter Bridge in the Description field, the Expert Mode returns elements whose complete description is the word Bridge. It will not find Bridges, Bridge Repair, New Bridge Construction, or anything similar. Wildcards (*) and ?) can be used both with or without the Expert Mode.

4.1.2 Copying the Current Catalog

You can use the Copy Current Catalog command under the Tools menu to accomplish a few tasks:

- Create archives of the current catalog for future reference
- Create metric unit or English unit specific catalogs by removing irrelevant items and saving the catalog under a different name
• Restore catalogs that may have been corrupted or temporarily changed

When an Estimator catalog window is active, Estimator enables the Copy Current Catalog command on the Tools menu. When you choose Copy Current Catalog, Estimator prompts you for a file name under which Estimator saves the current catalog.

![Copy Current Catalog Window](image)

Figure 4-2. New Copy of the Current Catalog Window

Enter a name in the title field and click OK. Estimator copies the Current Catalog, and the newly copied Catalog becomes the Current Catalog.

### 4.2 Maintaining the Standard Item Catalog

The Standard Item Catalog contains the construction items and pricing information available to estimate the cost of an estimate. Most often, the items used in your estimate originate in the Standard Item Catalog. You can open the Standard Item Catalog and edit the information contained there.

To view the Standard Item Catalog window, first open the Current Catalog. Then click on the Standard Item Catalog from the catalog tree area. Estimator displays the Standard Item Catalog window shown in Figure 4-3.
4.2.1 Standard Item Catalog Window Fields

**Item Number**
The Item Number field is a unique combination of letters, special characters, or numbers assigned to standard items by the agency. They can be up to 13 characters.

**Description**
The Description field includes the name of the item, a brief description of the item, or both. This field can contain up to 120 characters.

**Unit**
The Unit field is a specific unit of measurement that must be provided for each item (for example, HR for time in hours, CY for cubic yards, LF for linear feet, LS for lump sum). This field can be up to four characters.

**Unit System**
The Unit System field indicates whether the item is measured for metric (M), English (E), or None (N).

**Req Supp Desc?**
The Require Supplemental Description field. While a supplemental description is not required in Estimator, it may be required by your agency.

**Trns•port?**
A check in this box indicates the item came from the Trns•port database. Only a super-user can change this field. If this flag is set, the item should not be edited.

4.2.2 Adding an Item to the Standard Item Catalog

When you add a new item to the Standard Item Catalog, you can give it a name and description, and set the unit price and system of measure. You can also add price bases from Estimator’s Price Basis catalogs, create and add a new price bases to the new item,
or both. When more than one price basis is attached to the item being added, you can designate which of the price bases Estimator uses as the active price basis. An item can have one or more active price basis, or none at all.

Estimator enables the Add Item command on the Edit menu when the Standard Item Catalog is the active window and the Standard Item Catalog title is selected. Select **Add Item** from the **Edit** menu to display the Add Catalog Item dialog box shown in Figure 4-4.

![Add Catalog Item Dialog Box](image)

Figure 4-4. Add Catalog Item Dialog Box

You must enter values in the Add Catalog Item dialog box for the Item Code, Item Description, Unit, and Unit System fields. You should also fill in the correct information for the non-required fields. Once the required values are entered, the new item is added to the Standard Item Catalog.

- **Note:** If you can edit the catalog, you can mark any item as a Trns•port item. However, if an item is marked as coming from Trns•port when it has not, any estimate using that item will fail the import to another AASHTOWare Project (Trns•port) application.

### 4.2.3 Changing a Catalog Item

You can change the item code, item description, unit of measure of the selected item, the unit system, or a combination of fields. You can also add additional price bases to the item, delete price bases from the item, or both.

To change a catalog item, select the item from the tree view or click the GO button next to the item in the grid area. Then click in the field that you want to change, and enter the
new value. For fields with a drop down list, click the down arrow next to that field and select the desired value.

4.2.4 Adding Price Bases to the New Item

Select **Edit** to choose the desired price basis to add. Estimator displays the Add Price Basis menu shown in Figure 4-5.

![Figure 4-5. Add Price Basis Menu Options](image)

You can select to add an item Cost Sheet, Reference Price, Bid-Based Price, or Price Basis List by selecting one of these options from the Edit menu. You can also insert these options for already created items. For example, if you wanted to add a reference price, you would select **Add Reference Price** from the **Edit** menu.

Estimator opens a blank window ready to accept information for whichever option you selected. You can see what price basis each item has by clicking the **GO** button next to the item and looking at the grid area.
Figure 4-6. Display of Cost Sheet, Bid-Based Price, and Reference Price Indicators

B Bid-Based Price
R Reference Price
C Cost Sheet

Price Basis List, the I is only visible if the price basis list is selected. It is indicated by a folder icon as well

All the fields of the new price basis are initially empty. It is your responsibility to conform to agency standards imposed by your organization when filling in the price basis values.

**Working With Cost Sheets Attached to a Standard Item Catalog Item**

Select an item in the Standard Item Catalog that has at least one cost sheet attached to it.
Each cost sheet has associated equipment, labor, and material rates. To view these rate catalogs, you must click the GO button in the cost sheet window. This displays the cost sheet in the Cost Sheet catalog. Only the Cost Sheet Name, Quantity per Item Unit, and Active Price Basis fields can be edited when adding a cost sheet to an item. To update information in the rest of the fields, you must access the Cost Sheet Catalog.

**Working With Bid Histories Attached to a Standard Item**

Select an item in the Standard Item Catalog that has at least one bid history attached to it. Click the plus sign in the tree view or the GO button in the grid next to the bid history to view that bid history.

Estimator displays a Bid History Catalog window specific to the item you selected in the Standard Item Catalog.
Only the Bid History ID, Quantity per Item Unit, and Active Price Basis fields can be edited when adding a bid-based price to an item. Other bid history fields can only be updated by importing a new bid history.

**Viewing the Bid History Data Catalog**

Estimator displays a Bid History Catalog window specific to the item you selected in the Standard Item Catalog. In the Item Bid History detail pane, a graphical display of the Bid History with green dots representing data points from the BAMS/DSS HREG model is used to produce the displayed regression curve. The red dots represent outliers that are not used to produce the regression curve. Clicking the data points opens a window displaying the Price, Quantity, Vendor Name and ID, Contract ID, Letting Date, Season, Work Type, Area, and County ID.

**Working With Reference Prices Attached to a Standard Catalog Item**

Select an item in the Standard Item Catalog that has at least one reference price attached to it and select that reference price from the tree view or by clicking the associated GO button. Estimator displays the Reference Price dialog box in the right window pane. (See Figure 4-9.)
Only the Reference Price ID and Active Price Basis fields can be edited when adding a reference price to an item. To update information in the rest of the fields, you must access the Reference Price Catalog.

### 4.2.5 Deleting Price Bases From the New Item

You can delete the cost sheet, reference price, bid-based price, or price bases list from an item by highlighting the price basis you wish to delete and selecting **Delete** from the **Edit** menu. Be careful when you select the price basis - if it is not highlighted, you will delete the entire item instead.

### 4.2.6 Sorting the Item

You cannot select the position in the Standard Item Catalog where Estimator displays the item(s) being added. Estimator automatically places new items into the Standard Item Catalog in a pre-determined (numerical, then alphabetical) order that you cannot modify in the tree area.

You can, however, sort the Standard Item Catalog in the grid area. Select the Standard Item Catalog title in the tree area so the grid area displays in the right pane. Click any of the column headings in the grid area to sort the items by that heading in ascending order; click again to sort in descending order.

### 4.2.7 Deleting a Catalog Item

You can delete items from the Standard Item Catalog.

Select the item you want to delete from the catalog and select **Delete Item** from the **Edit** menu. You can select and delete several consecutive items in the Standard Item Catalog by holding down the **SHIFT** key and selecting the first and last item in the grid area. All
items in between will be selected. You can delete items that are not consecutive by selecting one item in the grid, pressing and holding down the CTRL key, and selecting the other items. Once all the desired items are selected, choose **Delete Item** from the **Edit** menu.

### 4.3 Working With Price Basis Catalogs

Besides the Standard Item Catalog, which houses information you use frequently to build your estimate Item List, Estimator price basis catalogs store the price bases you can attach to estimate items. There are three different price basis catalogs - the Cost Sheet Catalog, Bid History Catalog, and Reference Price Catalog. Like the Standard Item Catalog, you can add, change, and delete price basis records from the individual price basis catalogs.

Remember that you can calculate a value for any field followed by ellipses (…) using the Expression Builder window.

You can view the price basis catalogs at any time after you log on to Estimator by viewing the Current Catalog.

![Figure 4-10. Estimator Catalogs and Code Tables With the Reference Price Catalog Selected](image)

#### 4.3.1 The Cost Sheet Catalog

Estimator's Cost Sheet Catalog contains the cost sheets you can use to estimate the cost of items in an estimate. You can view the Cost Sheet Catalog after you log on to Estimator.

Open the Current Catalog. Select **Cost Sheet Catalog** in the tree area to display the Cost Sheet Catalog window shown in Figure 4-11.
Viewing a Cost Sheet in the Cost Sheet Catalog

The Cost Sheet Catalog window displays specific information about each cost sheet. When the Cost Sheet Catalog window is the active window, click GO to view a cost sheet in its own window or select the cost sheet from the tree area. Estimator displays the selected cost sheet.
Estimator displays these fields of information in the Cost Sheet window. Fill in the desired value in all fields.

**Cost Sheet Name**  
The Name field displays the name of the cost sheet. It can be up to 16 characters.

**Unit**  
The Unit field displays an abbreviation for the unit of measure (CY for cubic yards, LF for linear feet, and so forth) used on the cost sheet. It can be up to four characters.

**Trns•port?**  
A check in this box means the cost sheet is Trns•port compatible.

**Description**  
The Description field provides a brief description of the purpose of the cost sheet.

**Hours/Day**  
The Hours/Day field lists the number of hours per day the cost sheet includes.

**Overtime/Day**  
The Overtime/Day fields list the number of overtime hours that are expected.

**Production Rate**  
The Production Rate field represents the number of units that are produced in one work day for the results of the cost sheet.

**Markup %**  
The Markup field is an optional overall adjustment you can add to the value in the Total field. The markup is always expressed as a percentage of the value in the Total field.

**Labor Overhead %**  
The Labor Overhead field is an optional overhead adjustment that can be added to the labor cost per unit. It is always expressed as a percentage of the labor cost per unit.

**Equipment Overhead %**  
The Equipment Overhead field is an optional overhead adjustment that you can add to the equipment cost per unit. It is always expressed as a percentage of the equipment cost per unit.

**Materials Overhead %**  
The Materials Overhead field is an optional overhead adjustment that can be added to the materials cost per unit. It is always calculated as a percentage of the materials cost per unit.

- **Note:** Estimator does not require you to enter a Cost Sheet Name that conforms to name or code number standards established by your agency. It is your responsibility to conform to any established naming/numbering standards, if they apply.

You can view the Equipment, Labor, and Material Rate catalogs associated with the cost sheet by clicking on the EQUIPMENT, LABOR, and MATERIAL tabs. Clicking the GO button will bring you to the displayed rate catalog. The Rate Catalogs are discussed in Section 4.4.
Adding a Cost Sheet to the Cost Sheet Catalog

Estimator enables the Add Cost Sheet command on the Edit menu when the Cost Sheet Catalog list window is open and the Cost Sheet Catalog title is selected. Select Add Cost Sheet from the Edit menu to display the Add Cost Sheet window shown in Figure 4-13.

You cannot select the position in the Cost Sheet Catalog that the new cost sheet occupies. Estimator places new cost sheets into the Cost Sheet Catalog according to a predetermined (numerically, then alphabetically) sequence.

Changing a Cost Sheet in the Cost Sheet Catalog

Open a specific cost sheet in the Cost Sheet Catalog by either selecting it in the tree area or clicking its GO button in the grid area. Type the new information for the cost sheet in the desired fields.

Deleting a Cost Sheet From the Cost Sheet Catalog

To delete a cost sheet from the Cost Sheet Catalog, select the cost sheet you want to delete from either the tree or grid area. You can select and delete several consecutive cost sheets by holding down the SHIFT key and selecting the first and last cost sheet in the grid area. All cost sheets in between will be selected. You can delete cost sheets that are not consecutive by selecting one cost sheet in the grid, pressing and holding down the CTRL key, and selecting the other cost sheets. Once all the desired cost sheets are selected, choose Delete from the Edit menu.

If the cost sheet from the Cost Sheet catalog is attached at least one item in the Standard Item Catalog, Estimator displays an associated price basis warning window:
Click **YES** to continue with the deletion or **NO** to cancel the action. If you click **YES**, the cost sheet is removed from the Cost Sheet catalog, as well as from the Standard Item catalog as a price basis. Deleting the cost sheet from the catalog does not remove it from an estimate using that cost sheet.

### 4.3.2 The Bid History Catalog

Estimator's Bid History Catalog contains the bid histories you can use to estimate the costs of items in an estimate. You can view the Bid History Catalog at any time after you log on to Estimator.

Open the Current Catalog. Select **Bid History Catalog** in the tree area to display the Bid History window shown in Figure 4-15.

![Figure 4-15. Bid History Catalog Window](image)

**Viewing a Bid History in the Bid History Catalog**

The Bid History Catalog window displays specific information about each bid history. When the Bid History Catalog window is the active window, click **GO** to view a bid
history in its own window or select the bid history from the tree area. Estimator displays the selected bid history.

![Figure 4-16. Viewing the Bid History](image)

**Bid History ID**  The Bid History ID field is a combination of letters, special characters, numbers, or both assigned to standard items by the agency. Because each bid history in the Bid History Catalog provides the bid history data for a specific item in the Standard Item Catalog, the Bid History ID assigned to a specific Standard Item is also assigned to its corresponding bid history. It can be up to 16 characters.

**Max. Quantity**  The highest quantity available for the regression bid history. If the quantity is above this value, Estimator considers it out of range for regression pricing.

**Min. Quantity**  The lowest quantity available for the regression bid history. If the quantity is above this value, Estimator considers it out of range for regression pricing.

**5%ile..95%ile**  The 5%ile...95%ile fields show the average quantity ranges into which the item quantity falls. If the item quantity is below the fifth percentile or above the ninety-fifth percentile, Estimator considers it out of range for average pricing.

You can view the averages or regressions associated with the bid history by clicking on the AVERAGES and REGRESSIONS tabs.
**Viewing the Average Prices and Regression Coefficients**

You can view the weighted average prices for an item that was bid on in previously let estimates (as determined by a bid analysis program such as BAMS/DSS HIREG statistical analysis model).

First, the AVERAGES tab is displayed. This tab shows a list of the average prices for an item used in previously let estimates broken down by estimate location, estimate work type, and quantity of the item in the estimate. Estimator displays the Average Prices window shown in Figure 4-17.

![Figure 4-17. Average Prices Tab](image)

**Viewing the Regression Coefficients Window**

To view the regression coefficients of the bid history, click the REGRESSIONS tab. This displays the coefficients of the formulas Estimator uses to estimate the unit price of the bid item on the basis of the item’s bid history (as determined by a bid analysis program such as the BAMS/DSS HIREG statistical analysis model).
Adding and Changing Bid History Information in the Bid History Catalog

You can not manually add or change a bid history in the Bid History catalog. Bid Histories are created in an analysis program, such as BAMS/DSS, and must be imported into an Estimator catalog.

Deleting a Bid History From the Bid History Catalog

To delete a bid history from the Bid History Catalog, select the bid history you want to delete from either the tree or grid area. You can select and delete several consecutive bid histories by holding down the **SHIFT** key and selecting the first and last bid history in the grid area. All bid histories in between will be selected. You can delete bid histories that are not consecutive by selecting one bid history in the grid, pressing and holding down the **CTRL** key, and selecting the other bid histories. Once all the desired bid histories are selected, choose **Delete** from the **Edit** menu.

If the bid history from the Bid History catalog is attached to at least one item in the Standard Item Catalog, Estimator displays an associated price basis warning window:
Click YES to continue with the deletion or NO to cancel the action. If you click yes, the bid history is removed from the Bid History catalog, as well as from the Standard Item catalog as a price bases. Deleting the bid history from the catalog does not remove it from an estimate using that bid history.

**Caution:** If you mistakenly delete a bid history from the Bid History Catalog, you can only restore the deleted bid history by using the Undo feature or by loading the entire Bid History Catalog into Estimator again.

### 4.3.3 Reference Prices Catalog

Estimator's Reference Price Catalog contains all the reference prices you can use to estimate the costs of items in an estimate. You can view the Reference Price Catalog at any time after you log on to Estimator.

Open the Current Catalog. Select Reference Price Catalog in the tree area to display the Reference Price Catalog window shown in Figure 4-20.

![Figure 4-20. Reference Price Catalog Window](image)

**Viewing a Reference Price in the Reference Price Catalog**

When the Reference Price Catalog window is the active window, click GO to view a reference price in its own window or select the reference price from the tree area. Estimator displays the selected reference price.
The Reference Price ID field is a combination of letters, special characters, numbers, or both assigned to the reference by the agency. It can be up to 16 characters.

The Unit Price field displays the estimated cost of one unit of the estimate item to which the reference price is attached.

Select the Percent of Estimate check box to indicate the reference price be calculated as a percentage of the estimate total. Enter the total percentage in the field that appears if this check box is selected.

The Description field is a text field you use to detail the characteristics of the reference price. For example, this field might contain the name of the outside source from which the reference price was derived, the circumstances under which the reference price is appropriate, the date that the reference price was entered into Estimator, and the name or initials of the estimator who entered the reference price.

Note: Estimator does not require you to enter a Reference Price ID that conforms to name or code number standards established by your agency. It is your responsibility to conform to any established naming/numbering standards, if they apply.

Adding a Reference Price to the Reference Price Catalog

Estimator enables the Add command on the Edit menu when the Reference Price Catalog window is open. Select Add Reference Price from the Edit menu to display the Add to Reference Price Catalog window shown in Figure 4-22.
Enter the reference price in the Unit Price field, and enter a description of the reference price in the Description field. Select the Percent of Estimate field if appropriate. Estimator automatically adds the new reference price to the reference price catalog.

You cannot select the position in the Reference Price Catalog that the new reference price occupies. Estimator places new reference prices into the Reference Price Catalog according to a pre-determined (numerically, then alphabetically) sequence.

**Changing a Reference Price in the Reference Price Catalog**

To change a reference price in the Reference Price catalog, select the desired reference price in the tree area or click the GO button next to the reference price in the grid area. Estimator opens the reference price’s individual window. Click in the field or fields you want to change and enter the new information.

**Deleting a Reference Price From the Reference Price Catalog**

To delete a reference price from the Reference Price Catalog, select the reference price you want to delete from either the tree or grid area. You can select and delete several consecutive reference prices by holding down the SHIFT key and selecting the first and last reference price in the grid area. All reference prices in between will be selected. You can delete reference prices that are not consecutive by selecting one reference price in the grid, pressing and holding down the CTRL key, and selecting the other reference prices. Once all the desired reference prices are selected, choose Delete from the Edit menu.

If the reference price from the Reference Price catalog is attached to one or more items in the Standard Item Catalog, Estimator displays an associated price basis warning window:
Figure 4-23. Delete Associated Price Basis Warning Window

Click YES to continue with the deletion or NO to cancel the action. If you click YES, the reference price is removed from the Reference Price catalog, as well as from the Standard Item catalog as a price bases. Deleting the reference price from the catalog does not remove it from an estimate using that reference price.

4.4 Working With Rate Catalogs

The Cost Sheet Catalog accesses the three rate catalogs to gather information to build the cost sheets.

4.4.1 Equipment Rate Catalog

Estimator’s Equipment Rate Catalog contains all the equipment used to estimate the costs of producing items in an estimate. You can view the Equipment Rate Catalog at any time once you have logged on to Estimator.

Open the Current Catalog. Select Equipment Rate Catalog from the Current Catalog to display the Equipment Rate Catalog window shown in Figure 4-24.
**Equipment Rate Catalog Window Fields**

Estimator displays these fields of information for each piece of equipment listed:

- **Name**
  The Name field contains a unique code of letters, numbers, or both assigned by the agency for each piece of equipment. When new equipment is added to the Equipment Rate Catalog, Estimator does not require you to assign a code number to the equipment that conforms to code numbering standards established by your agency. It is your responsibility to conform to any code numbering standards, if they apply. It can be up to 13 characters.

- **Description**
  The Description field contains a brief description of the piece of equipment. The description is usually (but not always) unique.

- **Rate**
  The Rate field contains the cost of using one piece of the equipment for one hour of usage. The value specified in the Rate field might correspond to the rental cost or the purchase plus maintenance cost of the equipment. In either case, all costs associated with using the equipment are included in this value.

- **Trns•port?**
  A check in this box indicates the equipment rate came from the Trns•port database. Only a super-user can change this field, and if this flag is set, the object cannot be edited.

**Adding Equipment to the Equipment Rate Catalog**

Estimator enables the Add Equipment command on the Edit menu when the Equipment Rate Catalog window is displayed. Select **Add Equipment** from the **Edit** menu to display the Add Equipment Rate Catalog window shown in Figure 4-25.

![Figure 4-25. Add to Equipment Rate Catalog Dialog Box](image)
Type data for the new equipment into the fields displayed in the Add Equipment Rate window. The equipment is automatically added to the catalog.

You cannot select the position in the Equipment Rate Catalog that a new equipment record occupies. Estimator places new equipment records into the Equipment Rate Catalog in a pre-determined order. However, you can click on the column names in the header window to sort the equipment by the column name order. For example, if you click on the Rate column name, the equipment will be sorted according to the rate.

**Changing Equipment in the Equipment Rate Catalog**

To change the information in an entry in the Equipment Rate Catalog, select the equipment by either highlighting it in the left pane or clicking the GO button next to the equipment rate in the right pane from the Current Catalog window. Once the equipment rate is displayed, you can make the changes directly in the equipment window. You can change the value of any field of the selected equipment by entering new information into the appropriate field.

**Deleting Equipment From the Equipment Rate Catalog**

To delete an equipment record from the Equipment Rate Catalog, select the equipment record you want to delete by either highlighting it in the left pane or clicking the GO button next to the equipment in the right pane in the current catalog. When you have selected the record you want to delete, select **Delete Equipment** from the **Edit** menu. You can simultaneously select several equipment record in the Equipment Rate Catalog by holding down the **SHIFT** key and selecting the records in the grid area with the mouse. You can delete equipment records that are not consecutive by selecting one record in the grid, pressing and holding down the **CTRL** key, and selecting the other records. Once all the desired records are selected, choose **Delete Equipment** from the **Edit** menu.

If the equipment is attached to a cost sheet, Estimator displays the Associated Rate Catalog warning window.

![Figure 4-26. Associated Rate Catalog Warning Window](image)

Click **YES** to continue with the deletion or **NO** to cancel the action. If you click **YES**, the equipment rate is removed from the Equipment Rate catalog, as well as from the Cost Sheet catalog as a rate element. Deleting the equipment rate from the catalog does not remove it from an estimate using that equipment rate or cost sheet.
4.4.2 Labor Rate Catalog

Estimator's Labor Rate Catalog contains all the laborers (and the pay rate information for each laborer) you can use to estimate the costs of labor for producing items in an estimate. You can view the Labor Rate Catalog at any time once you have logged on to Estimator.

Open the Current Catalog. Select **Labor Rate Catalog** to display the Labor Rate Catalog window shown in Figure 4-27.

![Labor Rate Catalog Window](image)

Estimator displays these fields of information for each laborer listed.

**Name**

The Name field contains a unique code of letters, numbers, or both for each laborer as assigned by your agency. When a new laborer is added to the Labor Rate Catalog, Estimator does not require you to assign a code number that conforms to agency code numbering standards. It is your responsibility to conform to any standards if they apply. It can be up to 13 characters.

**Description**

The Description field briefly describes the specific laborer. The description is usually (but not always) unique.

**Wage**

The Wage field contains the cost of using one laborer (of the given laborer type) for one hour of work.

**OT Wage**

The OT Wage field contains the cost of using one laborer (of the given laborer type) for one hour of overtime.
A check in this box indicates the labor rate came from the Trns•port database. Only a super-user can change this field, and if this flag is set, the object can not be edited.

**Adding Laborers to the Labor Rate Catalog**

Estimator enables the Add Laborer command on the Edit menu when the Labor Rate Catalog window is open. Select **Add Laborer** from the **Edit** menu to display the Add to Labor Rate Catalog window shown in Figure 4-28.

![Figure 4-28. Add to Labor Rate Catalog Dialog Box](image)

Type the data for new laborer record into the fields displayed in the Add to Labor Rate Catalog dialog box. Estimator automatically adds the laborer to the catalog.

You cannot select the position in the Labor Rate Catalog that a new labor element occupies. Estimator places new laborers into the Labor Rate Catalog in a pre-determined order. However, you can click on the column names to sort the laborer by the column name order. For example, if you click on the Wage column name, the laborer will be sorted according to the wage.
**Changing Laborers in the Labor Rate Catalog**

To change the information in an entry in the Labor Rate Catalog, select the labor record by either highlighting it in the left pane or clicking the **GO** button next to the labor record in the right pane when the Labor Rate Catalog is displayed. Once the labor record is displayed, you can make the changes directly in the labor record window. You can change the value of any field of the selected labor record by entering new information into the appropriate field.

**Deleting Laborers From the Labor Rate Catalog**

To delete labor record from the Labor Rate Catalog, select the labor record you want to delete from the Labor Rate Catalog. When you have selected the labor record you want to delete, select **Delete Laborer** from the **Edit** menu or press the **DELETE** key on the keyboard. You can simultaneously select several labor records in the Labor Rate Catalog by holding down the **SHIFT** key and selecting the records in the grid area with the mouse. You can delete labor records that are not consecutive by selecting one record in the grid, pressing and holding down the **CTRL** key, and selecting the other records. Once all the desired records are selected, choose **Delete Laborer** from the **Edit** menu.

If the labor record is attached to a cost sheet, Estimator displays the Associated Rate Catalog warning window.

![Figure 4-29. Associated Rate Catalog Warning Window](image)

Click **YES** to continue with the deletion or **NO** to cancel the action. If you click **YES**, the labor record is removed from the Labor Rate catalog, as well as from the Cost Sheet catalog as a rate element. Deleting the labor rate from the catalog does not remove it from an estimate using that cost sheet or labor rate.

**4.4.3 Material Rate Catalog**

Estimator's Material Rate Catalog contains the material prices you can use to estimate the costs of items in an estimate. You can view the Material Rate Catalog at any time once you have logged on to Estimator.

Open the Current Catalog. Select **Material Rate Catalog** to display the Material Rate Catalog window shown in Figure 4-30.
Estimator displays these fields of information for each material listed.

**Name**
The Name field contains a unique code of letters, numbers, or both for each material rate as assigned by your agency. When a new material rate is added to the Material Rate Catalog, Estimator does not require you to assign a code number that conforms to agency code numbering standards. It is your responsibility to conform to any standards if they apply. It can be up to 13 characters.

**Description**
The Description field contains a brief description of a material. The description is usually (but not always) unique.

**Unit**
The Unit field contains the unit of measure for which the price of the material is calculated (for example, TON for price per ton, CY for price per cubic yard, GAL for price per gallon).

**Price**
The Price field contains the cost of one unit of the specified material. For example, a unit price of $50.00 means that the material costs $50 per ton if the Unit field value is TON.

**Trns•port?**
A check in this box indicates the material rate came from the Trns•port database. Only a super-user can change this field, and if this flag is set, the object cannot be edited.

### Adding Materials to the Material Rate Catalog

Estimator enables the Add Material command on the Edit menu when the Material Rate Catalog is selected. Select **Add Material** from the **Edit** menu to display the Add to Material Rate Catalog window shown in Figure 4-31.
Type the data for the new material record into the fields displayed in the new Material Rate Catalog window. The material is automatically added to the catalog.

You cannot select the position in the Material Rate Catalog that a new material element occupies. Estimator places new materials into the Material Rate Catalog in a predetermined (numerical, then alphabetical) order. However, you can click on the column names in the header window to sort the materials by the column name order. For example, if you click on the Price column name, the materials will be sorted according to price.

**Changing Materials in the Material Rate Catalog**

To change the information in an entry in the Material Rate Catalog, select the material record by either highlighting it in the tree area or clicking the GO button next to the material record in the grid area. Once the material record is displayed, you can make the changes directly in the material record window. You can change the value of any field of the selected material record by entering new information into the appropriate field.

**Deleting Materials From the Material Rate Catalog**

To delete a material rate from the Material Rate Catalog, select the material you want to delete. When you have selected the material you want to delete, select **Delete Material** from the **Edit** menu or press the DELETE key on the keyboard. You can simultaneously select several materials in the Material Rate Catalog by holding down the SHIFT key and selecting materials in the grid window with the mouse. You can delete materials that are not consecutive by selecting one material in the grid, pressing and holding down the CTRL key, and selecting the other materials. Once all the desired materials are selected, choose **Delete Material** from the **Edit** menu.

If the material is attached to a cost sheet, Estimator displays the Associated Rate Catalog warning window.
Click YES to continue with the deletion or NO to cancel the action. If you click YES, the material is removed from the Material Rate catalog, as well as from the Cost Sheet catalog as a rate element. Deleting the material from the catalog does not remove it from an estimate using that cost sheet or material rate.

4.5 Working With Code Tables

Estimator includes code tables you can use to store work type, season, urban or rural, county, units, highway type, and district information to use in the header of an estimate. You can add, change, and delete code table values from the Code Table Catalogs.

You can view the code tables catalogs at any time after you log on to Estimator. You access the catalogs by selecting View Current Catalog from the Tools menu. The code tables catalogs are listed in the tree area under the rate catalogs.

There are eight types of Code Table catalogs:

- **PWRKTYP** Project (Estimate) Work Type, defines the type of work
being done

**SEASON**  
Season, describes the time of year the work is being done

**URBRUR**  
Urban or Rural, describes the type of setting of the work being done

**COUNTY**  
County, names the primary county in which the work is being done

**UNITS**  
Units of measurement, defines the measurements used by cost sheets, material rate catalogs, and others

**HWYTYPE**  
Highway type, defines the type of highway

**DISTRICT**  
The district where a project or contract is located.

**FORMULAS**  
Formula library to store formulas that can be accessed in the Expression builder for numeric fields.

### 4.5.1 Working in the Code Table Catalogs

Each of the code table catalogs are the same in form, even if they are not the same in content. Each code table catalog entry has three fields - the ID of the entry, a description, and a Trns•port checkbox to mark if the code table entry is compatible for AASHTOWare Project (Trns•port) products. Each is added, changed, and deleted the same way. Each code table also has a NOTES tab for additional information.

All commonly used code table information is stored in the Code Table catalog. Select the desired **Code Table** to display the Code Table in a catalog window similar to Figure 4-24.

![Code Table SEASON Catalog Window](image)

Figure 4-34. Code Table SEASON Catalog Window
**Code Table Catalog Window Fields**

Estimator displays these fields of information for each code table entry listed:

- **Code Value**  The Code Value field contains a unique code of letters, numbers, or both assigned by the agency for each code table catalog. It can be up to eight characters.

- **Description**  The Description field contains a brief description of the code table catalog entry. The description is usually (but not always) unique. It can be up to 40 characters.

- **Trns•port?**  A check in this box indicates the code table came from the Trns•port database. Any user who can add elements to the catalog can change this flag.

**Adding an Element to the Code Table Catalog**

Estimator enables the Add Code Value command on the Edit menu when the Code Table catalog is open. Highlight the desired code table and select Add Code Value from the Edit menu to display the Add Code Value window shown in Figure 4-25.

![Add Code Value to Catalog](image)

**Figure 4-35. Add Code Value to Catalog**

Type data for the new code table value into the fields displayed in the Add Code Table Catalog window.

You cannot select the position of the new value in the Code Table catalog. Estimator places new values into the Code Table catalog in a pre-determined (usually alphabetical) order.
Changing Entries in the Code Table Catalog

You can change a code table entry. Be careful when doing this, however. Estimates that are designated as being Trns•port compatible need to solely contain Trns•port database records. If a code table is designated as coming from the Trns•port database, but it was not created that way, then the estimate using that code table fails any attempt at an import to another AASHTOWare Project (Trns•port) application if the code values do not match.

To edit a code table record, select the record in the desired Code Table catalog.

![Figure 4-36. Code Table Catalog Window](image)

You can change the value of any field of the selected record by entering new information into the appropriate field. You can also update the entire code table by importing code table information from PES and CES.

Deleting an Entry From the Code Table Catalog

To delete a record from the Code Table catalog, select the record you want to delete. You can simultaneously select several consecutive records in the Code Table catalog by holding down the SHIFT key and selecting the records with the mouse in the grid area. You can delete code values that are not consecutive by selecting one record in the grid, pressing and holding down the CTRL key, and selecting the other code values. Once all the desired records are selected, choose Delete Code Value from the Edit menu.
4.6 Utilizing Scheduled Catalog Imports

Scheduled catalog imports allow you to automate catalog imports on a recurring scheduled timeframe. Catalog updates are scheduled through the Catalog Import Scheduler window. Scheduled catalog imports are capable of importing CESITEM.CSV and IBIDHIST.CSV files, as well as Code Table text and Excel files. Only users with import rights are capable of scheduling catalog updates.

Scheduled catalog import logs can be found in the following locations:

- Windows 7 users: C:\ProgramData\Estimator
- Windows XP users: C:\Documents and Settings\All Users\Application Data\Estimator
5. Importing and Exporting Data

This chapter describes the kinds of data Estimator can export and import, the commands used to perform exporting and importing, and the formats of the export and import data files.

Estimator stores each estimate and catalog in separate data files. You can export the entire estimate, the entire catalog, or part of the catalog. When importing, Estimator looks at the data and decides where it best fits, either in an estimate or catalog, and then imports it accordingly.

If you want to share only part of a catalog - for example, you want to share some cost sheets with users in another office - Estimator allows you to export part of the catalog to a data file and the other users can then import that data and merge it with their existing catalog.

Estimator is able to use the XML format for importing catalogs and estimate data. The data format can be complicated and structured in nature and at the same time be open to a person or application that wants to use that format to share data. If users wanted to send data from a software application to Estimator in the XML format, they could, provided that the format was correct.

5.1 Importing Catalog or Code Table Data

Estimator’s data security measures are enforced when you import catalogs or code tables. Estimator imports catalog and code table data only for users that have permission to edit that catalog. Estimator checks the current user’s permissions to see if that user is allowed to change that catalog. If the user is not allowed to change that catalog, Estimator aborts the import with a message explaining the error.
Each catalog import requires a catalog into which the information will load. If there is existing information in the catalog, the elements in the catalog are replaced if a like-named and like-typed entity is imported. Imported elements that do not have a like-named and like-typed entity are added to the catalog, and elements in the catalog that do not have a like-named and like-typed entity are left alone.

There are five basic types of catalog imports in Estimator.

- CESITEM from BAMS/DSS: Imports standard items.
- HIREG from BAMS/DSS: Imports bid history elements.
- Code tables from Trns•port: Imports code tables, selecting only pwrktyp (project work type), season, urbrur (urban class or rural class), county, units, and hwytype (highway type) elements from those code tables.
- Estimator XML Catalog: Imports either a whole catalog or elements of a catalog.
- XLS or XLSX File: You can import catalog data that has been exported into Excel format. See section 5.3.1 Exporting Catalogs and Code Tables and the Exporting the Catalog to Excel subtopic for information on generating an Excel catalog file.

Note: If you delete the Bid History Catalog items before importing data for a new or updated Bid History Catalog, you should also delete the items from the Bid History Data Catalog.

When you are importing new information into a catalog, make sure the default catalog is the catalog into which the information should be imported. To do this, select Switch Catalog from the Tools menu and chose the desired catalog. If you are creating a new catalog, select New Catalog from the Tools menu. You must fill in the header information in a new catalog before Estimator allows you to import.

Once your catalog is selected, select Import from the File menu to display the Import window shown in 5-2.
When the Import window displays, it lists all files in the current directory that have an extension of files that can be imported. Select the file and click OPEN.

If the file you selected was not recognized as a supported Estimator format, Estimator displays a message box that informs you the import was not successfully completed and the file is not a supported import file type (see Figure 5-3).

Estimator also displays an error message if the spec year for the importing catalog was not set.
In most cases, a log file will log the error in a .CSV format file, so it can be viewed, the error fixed, and the file re-imported.

When a catalog or code table import completes successfully, Estimator displays a message window with that information and results of the import.

![Figure 5-5. Successful Import Results Window](image1)

Click **YES** to see the import log. It shows you the error that caused the rejection of each element.

![Figure 5-6. Estimator Import Log](image2)

When Estimator imports catalog data, the import file merges with the data currently in the document. If the import file contains an element with a field already in the catalog, Estimator overwrites the catalog element with the updated information. If the import file contains an element with a field that is not yet in the catalog, Estimator adds that element to the catalog. Fields without corresponding elements in the import file remain the same.

### 5.1.1 Importing CESITEM and BIDHIST Files From BAMS/DSS

After the CESITEM and BIDHIST files have been placed in your Estimator folder, they are ready for import into Estimator.
Do these steps after the CESITEM and BIDHIST files have already been created in BAMS/DSS. For more information, please see the Estimator BAMS/DSS Interaction Guide. These steps are necessary for importing the files and creating a complete item list with an associated bid history information in your catalog:

1. Start Estimator and log onto the system.

2. Select **Import** from the **File** menu. A window appears showing all the data files that are ready for import.

3. Select the CSV file that contains the items downloaded from BAMS/DSS from the CESITM model. This file is typically called CESITEM.CSV.

4. Select **OPEN** to begin the import. When the import completes, click **OK**.

5. Select **Import** from the **File** menu, then select the .CSV file from the HIREG model that was downloaded from BAMS/DSS. This file is typically named IBIDHIST.CSV.

6. Select **OPEN** to begin the import. When the import completes, click **OK**.

### 5.1.2 Importing Code Tables to Estimator

**Importing Code Table Data from PES®/LAS® Software**

Estimator can import the following code tables from PES®/LAS® software:

- `pwrktyp` (project work type),
- `season`,
- `urbrur` (urban class or rural class),
- `county`,
- `units`,
- `hwytype` (highway type).

Use the Run Process function in the appropriate AASHTOWare Project (Trns•port) application to get a CSV file of the particular code table to import. Open Estimator. Make sure the catalog receiving the import is the correct one, and select **Import** from the **File** menu.

Estimator opens the Import window. Select your file and click **OPEN**. Estimator imports the new code tables into the current catalog.
Importing Code Table Data from AASHTOWare Project Preconstruction™ Software

Estimator can import the following code tables from AASHTOWare Project Preconstruction™ software using the Export Reference Data process:

- pwrktyp (project work type)
- season
- urbrur (urban class or rural class)
- county
- units
- hwytype (highway type)

Code tables can be exported from reference tables in AASHTOWare Project Preconstruction software for import into Estimator software using the following:

In AASHTOWare Project Preconstruction:

1. Select **Execute System Interface** from the **Actions** menu.
2. Select the **Export Reference Data** interface.
3. If you wish to export the code tables, ensure that **Ref Code tables** is selected.
4. Click **EXECUTE**.
5. In Estimator software, import the EXPORT_REFCODETABLEVALUE.TXT file as normal. Estimator will convert this data into code tables.

District and fund code tables cannot be imported from PES/LAS software, although the other code tables are available to import.

Importing District and Fund Data from AASHTOWare Project Preconstruction Software

Estimator can import the District and Fund data from AASHTOWare Project Preconstruction™ software using the Export Reference Data to SiteManager process:

In AASHTOWare Project Preconstruction:

1. Select **Execute System Interface** from the **Actions** menu.
2. Select the Export Reference Data to SiteManager interface.
3. If you wish to export District data, ensure that Ref Districts is selected.
4. If you wish to export Fund data, ensure that Ref Funds is selected.

5. Click EXECUTE.

6. In Estimator software, import the SITEMANAGER_REFERENCE.CSV file as normal. Estimator will convert this data into code tables.

5.2 Importing Estimate Data

To import an estimate, select Import from the File menu. Estimator displays the Import window. Select the file you want to import and click OPEN. Most estimate files that you are going to import have a .TXT file extension.

If the estimate imports successfully, Estimator opens the estimate.

5.2.1 Importing an Estimate From PES

You can import PES project or proposal information into an Estimator estimate. Once the project or proposal information has successfully been exported from PES, select Import from the File menu in Estimator. Select the project or proposal from the Import window and click OPEN.

If you are using PES 5.4a or earlier, Estimator displays a Multi-Select Import window.

![Estimator Multi-Select Import Window](image)

Figure 5-7. Estimator Multi-Select Window

Select the projects or proposals you want to import and click OK. Estimator imports the chosen project or proposals and opens them into their own windows.
If you are using PES 5.5a or later, Estimator imports the chosen project or proposal and opens it into its own windows.

You can treat these imported projects and proposals like a normal estimate, but you must use the Save As option when saving them.

For more information, please see the Estimator PES Interaction Guide.

### 5.2.2 Importing an Estimate From Excel

To import an Excel spreadsheet as an estimate, select **Import** from the **File** menu. Estimator displays the Import dialog box.
If the file you want to import is not in this directory, use the Look In field to select the correct directory. Select the file and click OPEN. Estimator displays the Import Spreadsheet Wizard. Estimator detects if the Excel file contains named ranges and the number of worksheets. If both exist, select either Show Worksheets or Show Named Ranges.

If more than one named range or worksheet is associated with your Excel file, Estimator asks which one you want to import. Select either a named range or worksheet to see it displayed in the grid at the bottom of the Import Spreadsheet Wizard window.
Estimator displays the Row and Column it determines contains headings that match the Estimator entities. You can override the selection by typing in alternate Row and Column information. When the worksheet or range you want is selected, and the Row and Column information is correct, click Next. Estimator displays the second page of the Import Wizard.

![Image of Import Spreadsheet Wizard]

Figure 5-11. Second Page of Import Wizard

If the column headings in your Excel file do not match the field names in Estimator, you will have to tell Estimator which columns to use for which fields when importing. For example, in Figure 5-11, the estimate being imported does not have a column named Group or one named Supplemental Description. Therefore, those fields are left blank by the Import Wizard.

To enter the corresponding columns in the Estimator fields, first highlight the name of the column in the left pane. Then click in the corresponding field on the right side. Do this until each field is properly matched.

When all fields for Estimator contain the correct data, click OK. Estimator imports and displays the estimate. Select Verify Estimate from the Edit menu. This shows you what, if any, errors the imported estimate has.

5.2.3 Importing Project Data From Design Systems Using aecXML

Estimator can import project data from external design systems via the aecXML Infrastructure Project.

Make sure that the Current Catalog is the one you want associated with your estimate. Then select Import from the File menu. Estimator displays the Import window. Select the XML file you want to import and click Open. When the estimate imports...
successfully, Estimator opens the project data as an Estimate. Select **Verify Estimate** from the **Edit** menu. This shows you what, if any, errors the imported estimate has.

### 5.3 Exporting Data

To export data from Estimator, you must display the data you want to export in the active window. For example, if you want to export the Standard Item catalog, you must have the Standard Item Catalog window open. When the active window contains the data you want to export, select **Export** from the **File** menu.

#### 5.3.1 Exporting Catalogs and Code Tables

When Estimator exports catalog data, it converts it to an XML file. This is done to alleviate compatibility issues with different types of software. Estimator displays an XML warning.

Exporting an entire Current Catalog can be rather large, so Estimator gives you the option of only exporting part of the Current Catalog. You can export the Standard Item Catalog, any of the price bases or rate catalogs, any of the code tables, or parts of each.

**Exporting the Current Catalog**

If you want to export the entire Current Catalog, open the Current Catalog and select the Current Catalog name in the tree area. This causes a large export, however, and Estimator displays a warning window:

![Export XML Warning Window](image)

Figure 5-12. Export XML Warning Window

Click **YES** to proceed or **NO** to cancel the action. If you click **YES**, Estimator displays the Export As window.
Enter a name for the exporting catalog in the File Name field and click SAVE, or click CANCEL to cancel the export. After you click SAVE, Estimator saves the current catalog as an XML file.

**Exporting Part of a Catalog or Code Table**

To export a part of the catalog - the cost sheets, the bid history catalog, and so on - select that part in the tree area. If you want to export only certain elements of that catalog, select them in the grid area. Estimator gives you the option of exporting child elements as well, like the equipment, labor, and materials for a cost sheet. If you are exporting the Items catalog, Estimator gives you the option of exporting any associated price basis, which has the same name as the item’s code.
If you want to only export the selected records, place a check in the Include Only Selected Elements box. Click OK to start the export or CANCEL to return to the catalog or code table.

After you determine what you want to export, Estimator displays the Export As window (see Figure 5-13). Enter a name for export, or keep the default name. Click SAVE to begin the export or CANCEL to cancel the export. If you continue with the export, Estimator saves the catalog or code table as an XML file.

**Exporting a Single Element**

Estimator allows you to export the entire current catalog, the entire or part of a catalog or code table in the current catalog, or a single element in a catalog or code table.

Select the single element from the desired catalog or code table and select Export from the File menu. If you are exporting an item from the Standard Item Catalog, a window appears asking if you want to include price basis data. Otherwise, Estimator goes directly to the Export As (see Figure 5-13) window.

Enter a name for export, or keep the default name. Click SAVE to begin the export or CANCEL to cancel the export. If you continue with the export, Estimator saves the element as an XML file.

**Exporting Standard Item Catalog Items for Quantity Manager**

If you are working with Quantity Manager, you can export the Standard Item List into a file compatible with Quantity Manager.

Select the item or items you wish to export. Select Export from the File menu. Select Quantity Manager Itemlist from the Save as Type field. Click SAVE.

Estimator creates an XML file ready to be imported into Quantity Manager.

**Exporting the Catalog to Excel**

If you wish to export catalog data to Microsoft Excel, you can do so by selecting an Excel format in the file selection dialog.

Select the single element from the desired catalog or code table, and then select Export from the File menu. If you are exporting an item from the Standard Item Catalog, a window appears asking if you want to include price basis data. Otherwise, Estimator goes directly to the Export As (see Figure 5-13) window.

Enter a name for export or keep the default name. In the Save As Type drop-down menu, select either the Excel 97-2003 Workbook option or the Excel 2007 Workbook option. This saves the catalog data as an XLS or XLSX file. Once it is saved, Excel opens to display the file.
5.3.2 Exporting Estimates

You must open the estimate you wish to export before it can be exported. Once this is done, select Export from the File menu. Estimator displays the same Export As window as catalog exporting, but with additional options for the Save As Type field.

![Figure 5-15. Export Estimate Window](image)

You can chose to export an estimate one of seven ways.

Exporting as an XML Estimate File exports the estimate as an XML file. It can then be imported into PES 5.5a or later, CES 5.1a or later, or another software application, but keep the XML extension.

**Note:** If you are using Estimator 2.5a and PES 5.9a or earlier or CES 5.7a or earlier, the data in the Longitude at Midpoint field, the Latitude at Midpoint field, the District field, and the Federal/State Project Number field will export from Estimator but not import into PES or CES. You can enter the relevant information manually in PES or CES.

Selecting PES Project File or PES Load Proposal Prices File makes the estimate available to use in PES 5.4a or earlier. These options direct Estimator to either export the pricing information contained in the estimate or to not export it.

Exporting to an HTML Report File exports the estimate as an HTML file. The estimate can then be posted on the Internet.

Select CSV file to export the estimate to a CSV (comma-separated value) file. The estimate can then be opened in a program that supports the CSV format.
Users wishing to export the file to use in Excel should choose either the Excel 97-2003 Workbook option or the Excel 2007 Workbook option. This saves the estimate as an XLS or XLSX file. Once it is saved, Excel opens to display the file. Only the Group, Item, Item Unit, Item Description, Item Supplemental Description, Quantity, and Unit Price fields are exported.

**Note:** If a supplemental description is over 40 characters for an item in the estimate you are exporting to PES, PES divides the supplemental description into the Supplement Description 1 field and the Supplemental Description 2 field. Only whole words are saved in each field, so a word in the Supplemental Description 1 field extending beyond the 40 characters would be placed in the Supplemental Description 2 field. If this causes the Supplemental Description 2 field to extend beyond 40 characters, the extra characters will be truncated.

Once you have determined which way you want to export your data, click SAVE, or click CANCEL to not export and return to the estimate. If you click SAVE, Estimator saves the file as the desired file type. For more information, please see the Estimator Interaction Guide.

### 5.3.3 Exporting User Information

You can export information about the Estimator users. The users.bin file contains information about the authorized users and their privileges. This file is encrypted for security purposes and is created and managed solely through the Estimator GUI. However, there is occasional need to be able to work with the data in other systems, hence the ability to export the data.

To export the user data, select **Export Users** from the **Tools** menu. Estimator displays the Export As window. Adjust the File name as desired and click **SAVE** or **CANCEL**. If you click **SAVE**, Estimator saves the file as a Comma Separated Values (.csv) file. The exported data will be in the same order as the fields shown in the Estimator Users window.
Figure 5-16. Export Users Menu Option

Figure 5-17. Estimator Users Menu
Appendix A. Interface File Specifications

This appendix defines the interface files used by AASHTOWare Project Estimator Version 2 or later. The files that are described are those used for:

1. Importing and exporting a project to and from Trns•port PES®
2. Importing and exporting a project to and from Trns•port CES®
3. Exporting a project file to Trns•port PES versions 5.4 or earlier
4. Exporting the load proposal prices file to Trns•port PES versions 5.4 or earlier
5. Importing item data from AASHTOWare Project BAMS/DSS™
6. Importing bid history data (HIREG data) from AASHTOWare Project BAMS/DSS
7. Importing code tables from Trns•port CES or Trns•port PES
8. Importing reference price data
9. Importing and exporting a catalog between copies of AASHTOWare Project Estimator
10. Importing a CSV file as an estimate.

A.1 Importing and Exporting a Project to and From Trns•port PES

A project is imported from and exported to PES in XML format, meeting the following schema:

```xml
<?xml version="1.0" ?>
```
<xs:schema targetNamespace="http://tempuri.org/PES_import.xsd"
  xmlns:msn="http://tempuri.org/PES_import.xsd" xmlns="http://tempuri.org/PES_import.xsd"
  xmlns:xs="http://www.w3.org/2001/XMLSchema">
  <xs:element name="Estimate">
    <xs:element name="EstimateId"/>
    <xs:element name="Description"/>
    <xs:element name="RTF_Description"/>
    <xs:element name="PreparationDate"/>
    <xs:element name="LettingDate"/>
    <xs:element name="EstimateType"/>
    <xs:element name="EstimateTypeDescription"/>
    <xs:element name="WorkType"/>
    <xs:element name="WorkTypeDescription"/>
    <xs:element name="HighwayType"/>
    <xs:element name="HighwayTypeDescription"/>
    <xs:element name="UrbanRuralType"/>
    <xs:element name="UrbanRuralTypeDescription"/>
    <xs:element name="County"/>
    <xs:element name="CountyDescription"/>
    <xs:element name="Season"/>
    <xs:element name="SeasonDescription"/>
    <xs:element name="DistrictNumber"/>
    <xs:element name="DistrictDescription"/>
    <xs:element name="Longitude"/>
    <xs:element name="Latitude"/>
    <xs:element name="FederalStateProjectNumber"/>
    <xs:element name="CheckedBy"/>
    <xs:element name="DateChecked"/>
    <xs:element name="ApprovedBy"/>
    <xs:element name="DateApproved"/>
    <xs:element name="UnitSystem"/>
    <xs:element name="Catalog"/>
    <xs:element name="SpecYear"/>
    <xs:element name="PriceRoundingLevel"/>
    <xs:element name="QuantityRoundingLevel"/>
    <xs:element name="ExtensionRoundingLevel"/>
    <xs:element name="TransportFlag"/>
    <xs:element name="TransportPriceBasesFlag"/>
    <xs:element name="EditPricesOnlyFlag"/>
    <xs:element name="Comment"/>
    <xs:element name="RTF_Comment"/>
    <xs:element name="EstimatedCostUnfinished"/>
    <xs:element name="EstimatedCost"/>
    <xs:element name="ContingencyPercent"/>
    <xs:element name="EstimatedTotalUnfinished"/>
    <xs:element name="EstimatedTotal"/>
    <xs:element name="EstimateMarketAreaMapSet">
      <xs:element name="EstimateMarketAreaMap" maxOccurs="unbounded" />
    </xs:element>
  </xs:element>
</xs:schema>
Pictorially, the schema can be a set of diagrams representing the structure of the XML documents conforming to the schema. These diagrams show the hierarchical structure of the data that reflects the logical structure of the data being transported. The following diagrams represent Estimate data as stored in an XML file.
A.1.1 Estimate
A.1.2 EstimateGroup
A.1.3 EstimateItem
A.1.4 EstimateItemReferencePrice
A.2 Importing and Exporting a Project to and From Transport CES

A project is imported from and exported to CES in XML format, meeting the following schema:

```xml
<?xml version="1.0"?>
<xs:schema targetNamespace="http://tempuri.org/CES_import.xsd"
xmlns:ms xmlns="http://tempuri.org/CES_import.xsd" xmlns:xsi="http://www.w3.org/2001/XMLSchema"
<xs:element name="Estimate">
   <xs:element name="EstimateId"/>
   <xs:element name="Description"/>
   <xs:element name="RTF_Description"/>
   <xs:element name="PreparationDate"/>
   <xs:element name="LettingDate"/>
   <xs:element name="EstimateType"/>
   <xs:element name="EstimateTypeDescription"/>
   <xs:element name="WorkType"/>
   <xs:element name="WorkTypeDescription"/>
   <xs:element name="HighwayType"/>
   <xs:element name="HighwayTypeDescription"/>
   <xs:element name="UrbanRuralType"/>
   <xs:element name="UrbanRuralTypeDescription"/>
   <xs:element name="County"/>
   <xs:element name="CountyDescription"/>
   <xs:element name="Season"/>
   <xs:element name="SeasonDescription"/>
   <xs:element name="DistrictNumber"/>
   <xs:element name="DistrictDescription"/>
   <xs:element name="Longitude"/>
   <xs:element name="Latitude"/>
   <xs:element name="FederalStateProjectNumber"/>
   <xs:element name="CheckedBy"/>
   <xs:element name="ApprovedBy"/>
   <xs:element name="DateApproved"/>
   <xs:element name="UnitSystem"/>
   <xs:element name="Catalog"/>
   <xs:element name="SpecYear"/>
   <xs:element name="PriceRoundingLevel"/>
   <xs:element name="QuantityRoundingLevel"/>
   <xs:element name="ExtensionRoundingLevel"/>
   <xs:element name="PercentageRoundingLevel"/>
   <xs:element name="TrnsportFlag"/>
   <xs:element name="TrnsportPriceBasesFlag"/>
   <xs:element name="EditPricesOnlyFlag"/>
   <xs:element name="Comment"/>
   <xs:element name="RTF_Comment"/>
   <xs:element name="EstimatedCostUnfinished"/>
   <xs:element name="EstimatedCost"/>
```
<xs:element name="ContingencyPercent"/>
<xs:element name="EstimatedTotalUnfinished"/>
<xs:element name="EstimatedTotal"/>
<xs:element name="EstimateMarketAreaMapSet"/>
  <xs:element name="EstimateMarketAreaMap" maxOccurs="unbounded"/>
</xs:element>
<xs:element name="EstimateGroup" maxOccurs="unbounded">
  <xs:element name="GroupNumber"/>
  <xs:element name="Description"/>
  <xs:element name="RTF_Description"/>
  <xs:element name="AlternateCode"/>
  <xs:element name="Comment"/>
  <xs:element name="RTF_Comment"/>
  <xs:element name="UsedInTotal"/>
  <xs:element name="GroupTotalUnfinished"/>
  <xs:element name="GroupTotal"/>
  <xs:element name="EstimateItem" maxOccurs="unbounded">
    <xs:element name="LineNumber"/>
    <xs:element name="ItemCode"/>
    <xs:element name="Description"/>
    <xs:element name="RTF_Description"/>
    <xs:element name="SupplementalDescription"/>
    <xs:element name="RTF_SupplementalDescription"/>
    <xs:element name="RequireSupplementalDescriptionFlag"/>
    <xs:element name="Comment"/>
    <xs:element name="RTF_Comment"/>
    <xs:element name="Units"/>
    <xs:element name="AlternateCode"/>
    <xs:element name="IsAdHocPrice"/>
    <xs:element name="Quantity"/>
    <xs:element name="QuantityFormula"/>
    <xs:element name="UnitPriceUnfinished"/>
    <xs:element name="UnitPrice"/>
    <xs:element name="UnitPriceFormula"/>
    <xs:element name="UsedInTotal"/>
    <xs:element name="ExtendedAmountUnfinished"/>
    <xs:element name="ExtendedAmount"/>
    <xs:element name="EstimateItemReferencePrice" maxOccurs="unbounded">
      <xs:element name="EstimateItemReferencePriceId"/>
      <xs:element name="EstimateItemReferencePriceName"/>
      <xs:element name="EstimateItemReferencePriceDescription"/>
      <xs:element name="EstimateItemReferencePriceRTFDescription"/>
      <xs:element name="EstimateItemReferencePriceUnitPrice"/>
      <xs:element name="EstimateItemReferencePriceUnitPriceFormula"/>
      <xs:element name="ActiveFlag"/>
      <xs:element name="Comment"/>
      <xs:element name="RTF_Comment"/>
    </xs:element>
  </xs:element>
</xs:element>
Pictorially, the schema can be a set of diagrams representing the structure of the XML documents conforming to the schema. These diagrams show the hierarchical structure of the data that reflects the logical structure of the data being transported. The following diagrams represent Estimate data as stored in an XML file.
A.2.1 Estimate
A.2.2 EstimateGroup

```
EstimateGroup
  ├ GroupNumber
  │  └ Description
  │       └ RTF_Description
  │           └ AlternateCode
  │                   └ Comment
  │                           └ RTF_Comment
  └ EstimateItem
      0..∞
```

UsedInTotal

GroupTotalUnfinished

GroupTotal

EstimateItem

0..∞
A.2.3 EstimateItem
A.2.4 EstimateItemReferencePrice
A.3 Exporting Project File to Trnsport PES Versions 5.4 or Earlier

A sample Project File is shown below:

<table>
<thead>
<tr>
<th>Field</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>&quot;PROJECT1&quot;</td>
</tr>
<tr>
<td>2</td>
<td>PCN</td>
</tr>
<tr>
<td>3</td>
<td>SPEC Year</td>
</tr>
<tr>
<td>4</td>
<td>Work Type</td>
</tr>
<tr>
<td>5</td>
<td>District</td>
</tr>
<tr>
<td>6</td>
<td>X coordinate</td>
</tr>
<tr>
<td>7</td>
<td>Y coordinate</td>
</tr>
</tbody>
</table>

The project file is called PJPORT.DAT by default and consists of multiple lines. Each line contains one or more fields, where fields are separated by a single blank.

There are four sections to the file. The first is the single line header and identifies the file as a PES project file and always contains the phrase:

"BAMS Import File,2.1,PES Project"

The next section identifies the Project and consists of three lines containing the following information:

Line 1:
Line 2:

<table>
<thead>
<tr>
<th>Field</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>“PROJECT2”</td>
</tr>
<tr>
<td>2</td>
<td>Project Description</td>
</tr>
</tbody>
</table>

Line 3:

<table>
<thead>
<tr>
<th>Field</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>“PROJECT3”</td>
</tr>
<tr>
<td>2</td>
<td>Project Description 2</td>
</tr>
</tbody>
</table>

After the project description, the catalogs are reported, one line per catalog.

<table>
<thead>
<tr>
<th>Field</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>“ESTCATG1”</td>
</tr>
<tr>
<td>2</td>
<td>Catalog Number</td>
</tr>
<tr>
<td>3</td>
<td>Catalog Description (If catalog descriptions are to be exported)</td>
</tr>
</tbody>
</table>

Following the catalog descriptions, the items are described, two lines per item:

Line 1:

<table>
<thead>
<tr>
<th>Field</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>“ESTITEM1”</td>
</tr>
<tr>
<td>2</td>
<td>Item Line Number</td>
</tr>
<tr>
<td>3</td>
<td>Item Code</td>
</tr>
<tr>
<td>4</td>
<td>Item Quantity</td>
</tr>
<tr>
<td>5</td>
<td>Item Unit Price</td>
</tr>
</tbody>
</table>

Line 2:

<table>
<thead>
<tr>
<th>Field</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>“ESTITEM2”</td>
</tr>
<tr>
<td>2</td>
<td>Item Supplemental Description</td>
</tr>
</tbody>
</table>
A.4 Exporting the Load Proposal Prices File to Transport PES Versions 5.4 or Earlier

A sample Proposal Prices File is shown below:

<table>
<thead>
<tr>
<th>TYP Load Proposal Prices File</th>
<th>V1.0a</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRP TMR6836</td>
<td></td>
</tr>
<tr>
<td>IT1 TMR6836</td>
<td>L 0006 201-00002</td>
</tr>
<tr>
<td>IT1 TMR6836</td>
<td>L 0007 201-00000</td>
</tr>
<tr>
<td>END TMR6836</td>
<td></td>
</tr>
</tbody>
</table>

The project file is called PROPRC.TXT by default and consists of multiple lines. Each line contains one or more fields, where fields are separated by a single blank.

There are four sections to the file. The first is the single line header and identifies the file as a Proposal Prices File and always contains the phrase:

"TYP Load Proposal Prices File" followed by the version of the file definition, "V1.0a".

The next section identifies the Proposal and consists of one line containing the following information:

<table>
<thead>
<tr>
<th>Field</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>&quot;PRP&quot;</td>
</tr>
<tr>
<td>2</td>
<td>The Contract (proposal) ID</td>
</tr>
</tbody>
</table>

After the proposal identification, the item prices are reported, one line per item:

<table>
<thead>
<tr>
<th>Field</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>&quot;IT1&quot;</td>
</tr>
<tr>
<td>2</td>
<td>The Contract (proposal) ID</td>
</tr>
<tr>
<td>3</td>
<td>Item Line Number</td>
</tr>
<tr>
<td>4</td>
<td>Item Code</td>
</tr>
<tr>
<td>5</td>
<td>Item Quantity</td>
</tr>
<tr>
<td>6</td>
<td>Item Unit Price</td>
</tr>
</tbody>
</table>
A.5 Importing Item Data From AASHTOWare Project BAMS/DSS

The item data file output by AASHTOWare Project BAMS/DSS is named CESITEM.CSV.

The file contains an entry for each item. Entries can span lines. A backslash is used to indicate that an entry continues onto the next line. In general, one item’s entry will require four or five lines in the file. The last line of the entry does not end with a backslash.

The first row of the file is a header row that contains:

<table>
<thead>
<tr>
<th>Field</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>DS/Shell Import file</td>
<td>“DS/Shell Import file,” specifies the file type</td>
</tr>
<tr>
<td>2</td>
<td>version</td>
<td>File type version</td>
</tr>
<tr>
<td>3</td>
<td>encoding</td>
<td>“ECSV”</td>
</tr>
</tbody>
</table>

The first entry following the header is a “prototype” entry that contains the field names for each of the fields.

The fields for each item entry are:

<table>
<thead>
<tr>
<th>Field</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Standard-Item</td>
<td>“Standard-Item”, specifies that this is an entry for a standard item</td>
</tr>
<tr>
<td>2</td>
<td>Standard-Item-Number</td>
<td>Item Number</td>
</tr>
<tr>
<td>3</td>
<td>Spec-Year</td>
<td>Item Spec Year</td>
</tr>
<tr>
<td>4</td>
<td>Short-Description</td>
<td>Item Short Description</td>
</tr>
<tr>
<td>5</td>
<td>Long-Description</td>
<td>Item Long Description</td>
</tr>
<tr>
<td>6</td>
<td>Unit</td>
<td>Units</td>
</tr>
<tr>
<td>7</td>
<td>Lump-Sum</td>
<td>Specifies if it is a lump-sum item</td>
</tr>
<tr>
<td>8</td>
<td>Unit-Type</td>
<td>Unit type</td>
</tr>
<tr>
<td>9</td>
<td>Require-Supplemental-Description-Flag</td>
<td>Specifies if the item requires a supplemental description</td>
</tr>
</tbody>
</table>

An example from the top of a cesitem.csv file follows:

```
DS/Shell Import file,1.00,ECSV
Standard-Item,Standard-Item-Number,Spec-Year,\
```
Short-Description,Long-Description,Unit,Lump-Sum,\nUnit-Type,Require-Supplemental-Description-Flag
"STANDARD-ITEM","0 285705","1991",\n"BASE OPTIONAL (BASE GROUP 05) (BASM/DSS)",\n"BASE OPTIONAL (BASE GROUP 05) (BAMS/DSS) \
"",\n"SY","FALSE","E","FALSE"
"STANDARD-ITEM","0 1100","1991",\n"SELECT BEDDING MATERIAL, GRAVEL",\n"SELECT BEDDING MATERIAL, GRAVEL \
"",\n"CY","FALSE","E","FALSE"
"STANDARD-ITEM","0 1101","1991",\n"SELECT BEDDING MATERIAL, SAND",\n"SELECT BEDDING MATERIAL, SAND \
"",\n"CY","FALSE","E","FALSE"
"STANDARD-ITEM","0 1102","1991",\n"EXTRA TRENCH DEPTH",\n"EXTRA TRENCH DEPTH \
"",\n"CY","FALSE","E","FALSE"
A.6 Importing Bid History Data (HIREG Data) From AASHTOWare Project BAMS/DSS

The bid history file output by AASHTOWare Project BAMS/DSS from the HIREG (Historical Item Price Regression) model is named IBIDHIST.CSV.

The bid history file is comprised of several sections, each for a specific type of output from the model. Following is a list of the sections and their values.

<table>
<thead>
<tr>
<th>Section</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>HEADER</td>
<td>A header row is placed in the first line of the bid history file containing information about the model profile.</td>
</tr>
<tr>
<td>AREAS</td>
<td>Contains the county to area mapping.</td>
</tr>
<tr>
<td>STATS</td>
<td>Contains statistical levels calculated for each item or cost group.</td>
</tr>
<tr>
<td>AVERAGES</td>
<td>Contains the results of the average calculations.</td>
</tr>
<tr>
<td>BETAS</td>
<td>Contains the regression coefficients for each of the models generated for the items or cost groups.</td>
</tr>
<tr>
<td>MODELS</td>
<td>Contains the model information for each of the models generated for the items or cost groups.</td>
</tr>
<tr>
<td>ITEMGROUPS</td>
<td>Contains the list of item groups if used in the BAMS/DSS data view.</td>
</tr>
<tr>
<td>ITEMGROUP ITEMS</td>
<td>Contains the item to item group mapping and conversion if item groups were used in the BAMS/DSS data view.</td>
</tr>
</tbody>
</table>

The header section is the first row of the file and contains the following data:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>HEADER</td>
<td>“HEADER”, identifies this as the header row.</td>
</tr>
<tr>
<td>2</td>
<td>VERSION</td>
<td>The version of BAMS/DSS producing the file.</td>
</tr>
<tr>
<td>3</td>
<td>DATETIME</td>
<td>The date and time that the file was created.</td>
</tr>
<tr>
<td>4</td>
<td>MODEL</td>
<td>The name of the model used to generate the data.</td>
</tr>
<tr>
<td>5</td>
<td>PROFILE</td>
<td>The profile in use when the file was created.</td>
</tr>
</tbody>
</table>

The AREAS section follows the header row and consists of one row for each area defined in the model. The first row of the AREAS section contains:
<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>AREAS</td>
<td>&quot;AREAS&quot;, identifies this as the AREAS section.</td>
</tr>
<tr>
<td>2</td>
<td>COUNT</td>
<td>The number of areas, that is, rows, following.</td>
</tr>
</tbody>
</table>

Each row in the AREAS section following the first contains:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>AREA</td>
<td>The numeric area identifier.</td>
</tr>
<tr>
<td>2</td>
<td>COUNTY</td>
<td>The numeric county identifier.</td>
</tr>
</tbody>
</table>

The STATS section follows the AREAS section and contains the univariate statistical levels calculated for each item or cost group for the set of data used by the averages.

The first row of the STATS section contains:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>STATS</td>
<td>&quot;STATS&quot;, identifies this as the STATS section.</td>
</tr>
<tr>
<td>2</td>
<td>COUNT</td>
<td>The number of rows in the section, excluding this row.</td>
</tr>
</tbody>
</table>

Each row in the STATS section following the first contains:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>ISPECYR</td>
<td>The spec year for the item</td>
</tr>
<tr>
<td>2</td>
<td>N</td>
<td>Number of Item Observations</td>
</tr>
<tr>
<td>3</td>
<td>p95</td>
<td>95th Percentile of Item Quantity</td>
</tr>
<tr>
<td>4</td>
<td>q75</td>
<td>75th Percentile of Item Quantity</td>
</tr>
<tr>
<td>5</td>
<td>q50</td>
<td>50th Percentile of Item Quantity</td>
</tr>
<tr>
<td>6</td>
<td>q25</td>
<td>25th Percentile of Item Quantity</td>
</tr>
<tr>
<td>7</td>
<td>p5</td>
<td>5th Percentile of Item Quantity</td>
</tr>
<tr>
<td>8</td>
<td>min_qty</td>
<td>Minimum Item Quantity</td>
</tr>
<tr>
<td>9</td>
<td>min_dat</td>
<td>Minimum Item Date</td>
</tr>
<tr>
<td>10</td>
<td>max_qty</td>
<td>Maximum Item Quantity</td>
</tr>
<tr>
<td>11</td>
<td>max_dat</td>
<td>Maximum Item Date</td>
</tr>
<tr>
<td>12</td>
<td>avg_qty</td>
<td>Average Item Quantity</td>
</tr>
<tr>
<td>13</td>
<td>avg_dat</td>
<td>Average Item Date</td>
</tr>
<tr>
<td>14</td>
<td>item/cost_group</td>
<td>Item Number (or cost group ID)</td>
</tr>
</tbody>
</table>

The AVERAGES section follows the STATS section and contains the statistical levels calculated for each item or cost group.
The first row of the AVERAGES section contains:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>AVERAGES</td>
<td>&quot;AVERAGES&quot;, identifies this as the AVERAGES section.</td>
</tr>
<tr>
<td>2</td>
<td>COUNT</td>
<td>The number of rows in the section, excluding this row.</td>
</tr>
</tbody>
</table>

Each row in the AVERAGES section following the first contains:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>ISPECYR</td>
<td>The spec year for the item</td>
</tr>
<tr>
<td>2</td>
<td>qty_level</td>
<td>Item Quantity Level</td>
</tr>
<tr>
<td>3</td>
<td>cnrpwrk</td>
<td>Contract Type of Work</td>
</tr>
<tr>
<td>4</td>
<td>mkarea</td>
<td>Market Area</td>
</tr>
<tr>
<td>5</td>
<td>season</td>
<td>Season</td>
</tr>
<tr>
<td>6</td>
<td><em>type</em></td>
<td>Subgroup Combination Number</td>
</tr>
<tr>
<td>7</td>
<td><em>freq</em></td>
<td>Number of Observations in the Subgroup Combination</td>
</tr>
<tr>
<td>8</td>
<td>std</td>
<td>Standard Deviation</td>
</tr>
<tr>
<td>9</td>
<td>costvar</td>
<td>Cost Variance</td>
</tr>
<tr>
<td>10</td>
<td>average</td>
<td>Item Average Price</td>
</tr>
<tr>
<td>11</td>
<td>item/cost_group</td>
<td>Item Number (or cost group ID)</td>
</tr>
<tr>
<td>12</td>
<td>cnhwytyp</td>
<td>Highway type, for cost group only</td>
</tr>
</tbody>
</table>

The BETAS section follows the AVERAGES section and contains the regression coefficients for each of the models generated for the items or cost groups.

The first row of the BETAS section contains:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>BETAS</td>
<td>&quot;BETAS&quot;, identifies this as the BETAS section.</td>
</tr>
<tr>
<td>2</td>
<td>COUNT</td>
<td>The number of rows in the section, excluding this row.</td>
</tr>
</tbody>
</table>

Each row in the BETAS section following the first contains:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>ISPECYR</td>
<td>The spec year for the item</td>
</tr>
<tr>
<td>2</td>
<td>mdl</td>
<td>Model Number</td>
</tr>
<tr>
<td>3</td>
<td>varb</td>
<td>Variable Type</td>
</tr>
<tr>
<td>4</td>
<td>num</td>
<td>Regression Number</td>
</tr>
<tr>
<td>5</td>
<td>beta</td>
<td>Regression Coefficient</td>
</tr>
<tr>
<td>6</td>
<td>value</td>
<td>Variable Value</td>
</tr>
</tbody>
</table>
The MODELS section follows the BETAS section and contains the statistical levels calculated for each item or cost group.

The first row of the MODELS section contains:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>MODELS</td>
<td>“MODELS”, identifies this as the MODELS section.</td>
</tr>
<tr>
<td>2</td>
<td>COUNT</td>
<td>The number of rows in the section, excluding this row.</td>
</tr>
</tbody>
</table>

Each row in the MODELS section following the first contains:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>ISPECYR</td>
<td>The spec year for the item</td>
</tr>
<tr>
<td>2</td>
<td>mdl</td>
<td>Model Number</td>
</tr>
<tr>
<td>3</td>
<td>rmse</td>
<td>Root Mean Square for Error</td>
</tr>
<tr>
<td>4</td>
<td>whdavg</td>
<td>Average Weighted by Bid Total</td>
</tr>
<tr>
<td>5</td>
<td>whdstd</td>
<td>Standard Deviation Weighted by Bid Total</td>
</tr>
<tr>
<td>6</td>
<td>b_inter</td>
<td>Intercept Coefficient</td>
</tr>
<tr>
<td>7</td>
<td>b_lnqty</td>
<td>Quantity Coefficient</td>
</tr>
<tr>
<td>8</td>
<td>b_date</td>
<td>Date Coefficient</td>
</tr>
<tr>
<td>9</td>
<td>b_date2</td>
<td>Date Squared Coefficient</td>
</tr>
<tr>
<td>10</td>
<td>c_wt</td>
<td>Work Type Count</td>
</tr>
<tr>
<td>11</td>
<td>c_ar</td>
<td>Area Count</td>
</tr>
<tr>
<td>11</td>
<td>c_se</td>
<td>Season Count</td>
</tr>
<tr>
<td>11</td>
<td>item/cost_group</td>
<td>Item Number (or cost group ID)</td>
</tr>
</tbody>
</table>

The ITEMGROUPS section follows the MODELS section and contains the list of item groups if used in the BAMS/DSS data view.

The first row of the ITEMGROUPS section contains:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>ITEMGROUPS</td>
<td>“ITEMGROUPS”, identifies this as the ITEMGROUPS section.</td>
</tr>
<tr>
<td>2</td>
<td>COUNT</td>
<td>The number of rows in the section, excluding this row.</td>
</tr>
</tbody>
</table>

Each row in the ITEMGROUPS section following the first contains:
The **ITEMGROUPITEMS** section follows the **ITEMGROUPS** section and contains the item to item group mapping and conversion if item groups were used in the BAMS/DSS data view.

The first row of the **ITEMGROUPITEMS** section contains:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>ITEMGROUPITEMS</td>
<td>“ITEMGROUPITEMS”, identifies this as the ITEMGROUPITEMS section.</td>
</tr>
<tr>
<td>2</td>
<td>COUNT</td>
<td>The number of rows in the section, excluding this row.</td>
</tr>
</tbody>
</table>

Each row in the **ITEMGROUPS** section following the first contains:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>itemgroup</td>
<td>The item group id</td>
</tr>
<tr>
<td>2</td>
<td>igspecyr</td>
<td>The spec year for the item group</td>
</tr>
<tr>
<td>3</td>
<td>item</td>
<td>The item id</td>
</tr>
<tr>
<td>4</td>
<td>ispecyr</td>
<td>The spec year for the item</td>
</tr>
<tr>
<td>5</td>
<td>conv2ig</td>
<td>Conversion factor</td>
</tr>
</tbody>
</table>
A.7 Importing Code Tables From Trns•port CES or Trns•port PES

Code tables are imported from CES or PES in a fixed-field format. The format of this file is one row per code table entry and has the form:

<table>
<thead>
<tr>
<th>Columns 1-8</th>
<th>Columns 9-16</th>
<th>Columns 17+</th>
</tr>
</thead>
<tbody>
<tr>
<td>Code Table Name</td>
<td>Code Name</td>
<td>Code value</td>
</tr>
</tbody>
</table>

An example excerpt from an import file follows:

<table>
<thead>
<tr>
<th>ACTSTAT CLOS</th>
<th>Action Completed</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACTSTAT OPEN</td>
<td>Item Still Open</td>
</tr>
<tr>
<td>ACTSTAT PEND</td>
<td>Pending Action</td>
</tr>
<tr>
<td>ACTTYPE AFF</td>
<td>Affidavit</td>
</tr>
<tr>
<td>ACTTYPE BOND</td>
<td>Bond</td>
</tr>
<tr>
<td>ACTTYPE LIEN</td>
<td>Lien</td>
</tr>
<tr>
<td>ADDRTP BID</td>
<td>Bidding Office address</td>
</tr>
<tr>
<td>ADDRTP HOME</td>
<td>Vendor Home Address</td>
</tr>
<tr>
<td>ADDRTP MAIL</td>
<td>Vendor Mailing Address</td>
</tr>
<tr>
<td>ADDRTP OTSH</td>
<td>One Time Shipping Address</td>
</tr>
<tr>
<td>ADJTYP FUEL</td>
<td>Fuel Adjustment (Diesel)</td>
</tr>
<tr>
<td>ADJTYP GASO</td>
<td>Fuel Adjustment (Gasoline)</td>
</tr>
<tr>
<td>ADJTYP N/A</td>
<td>Not Used</td>
</tr>
<tr>
<td>AREAS N/A</td>
<td>Undocumented</td>
</tr>
<tr>
<td>AWARDED 02</td>
<td>Awarded</td>
</tr>
<tr>
<td>AWARDED 03</td>
<td>Executed</td>
</tr>
<tr>
<td>BIDCLS 1</td>
<td>Proposal Form Altered</td>
</tr>
<tr>
<td>BIDCLS 2</td>
<td>Unauthorized Additions</td>
</tr>
<tr>
<td>BIDCLS 3</td>
<td>Unauthorized Deletions</td>
</tr>
<tr>
<td>BIDCLS 4</td>
<td>Unbalanced Bid</td>
</tr>
</tbody>
</table>

...
A.8 Importing Reference Price Data

Estimator supports importing reference price data in both CSV and XML file formats.

A.8.1 The CSV File Format

The reference price file is comprised of a header and a reference price catalog section.

<table>
<thead>
<tr>
<th>HEADER</th>
<th>A header row is placed in the first line of the reference price file</th>
</tr>
</thead>
<tbody>
<tr>
<td>REFCAT</td>
<td>Contains the reference price catalog data.</td>
</tr>
</tbody>
</table>

The header section is the first row of the file and contains the following data:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>HIGHEST</td>
<td>“HIGHEST”</td>
</tr>
<tr>
<td>2</td>
<td>VERSION</td>
<td>“1.03”</td>
</tr>
<tr>
<td>3</td>
<td>FORMAT</td>
<td>“CSV”</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>“CATALOG”</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>“SUPPLEMENT”</td>
</tr>
</tbody>
</table>

The REFCAT section follows the header row and consists of one row for each reference price element. The first row of the REFCAT section contains:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>REFCAT</td>
<td>“REFCAT”, identifies this as the REFCAT section</td>
</tr>
<tr>
<td>2</td>
<td>COUNT</td>
<td>The number of rows in this section, excluding this one.</td>
</tr>
</tbody>
</table>

Each row in the REFCAT section following the first contains:

<table>
<thead>
<tr>
<th>Column</th>
<th>Name</th>
<th>Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>REFCATELEMENT</td>
<td>“REFCATELEMENT”</td>
</tr>
<tr>
<td>2</td>
<td>PRICE</td>
<td>The reference price.</td>
</tr>
<tr>
<td>3</td>
<td>ITEM</td>
<td>The item number.</td>
</tr>
<tr>
<td>4</td>
<td>DESCRIPTION</td>
<td>The item description.</td>
</tr>
</tbody>
</table>
A.8.2 The XML File Format

Reference price data can be transferred in XML, meeting the following schema:

```xml
<?xml version="1.0" encoding="UTF-8"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" elementFormDefault="qualified">
  <xs:element name="Catalog">
    <xs:complexType>
      <xs:sequence>
        <xs:element name="SpecYear"/>
        <xs:element name="Comment"/>
        <xs:element ref="ReferencePriceTable"/>
      </xs:sequence>
    </xs:complexType>
  </xs:element>
  <xs:element name="ReferencePriceTable">
    <xs:complexType>
      <xs:sequence>
        <xs:element name="TableID"/>
        <xs:element name="TableDescription"/>
        <xs:element name="Description"/>
        <xs:element ref="ReferencePriceTableElement" maxOccurs="unbounded"/>
      </xs:sequence>
    </xs:complexType>
  </xs:element>
  <xs:element name="ReferencePriceTableElement">
    <xs:complexType>
      <xs:sequence>
        <xs:element name="CatReferencePriceID"/>
        <xs:element name="CatReferencePriceDescription"/>
        <xs:element name="CatReferencePriceUnitPrice"/>
        <xs:element name="CatItemReferencePricePercent"/>
        <xs:element name="CatItemReferencePricePercentFlag"/>
        <xs:element name="IsTransport"/>
        <xs:element name="Comment"/>
      </xs:sequence>
    </xs:complexType>
  </xs:element>
</xs:schema>
```

Pictorially, the schema can be represented as a set of diagrams representing the structure of the XML documents conforming to the schema. These diagrams show the hierarchical structure of the data that reflects the logical structure of the data being transported. The following diagrams represent reference price data as stored in an XML file.

**Catalog**
A.9 Importing and Exporting a Catalog Between Copies of AASHTOWare Project Estimator

Catalogs are transferred between copies of AASHTOWare Project Estimator as XML files. A catalog contains bid history data, reference price data, cost sheet data, and code tables. The schema of the XML file can be represented visually by the following diagrams.

A Catalog in XML format meets the following schema:

```xml
<?xml version="1.0" encoding="UTF-8"?>
<xs:schema xmlns:xs="http://www.w3.org/2001/XMLSchema" elementFormDefault="qualified">
  <xs:element name="Catalog">
    <xs:complexType>
      <xs:sequence>
        <xs:element name="SpecYear"/>
        <xs:element name="Comment"/>
        <xs:element name="RTF_Comment"/>
        <xs:element ref="MarketAreaTable" maxOccurs="1"/>
        <xs:element ref="BidHistoryTable" maxOccurs="unbounded"/>
        <xs:element ref="CostSheetTable" maxOccurs="unbounded"/>
        <xs:element ref="EquipmentTable" maxOccurs="unbounded"/>
        <xs:element ref="LaborTable" maxOccurs="unbounded"/>
        <xs:element ref="MaterialTable" maxOccurs="unbounded"/>
        <xs:element ref="ReferencePriceTable" maxOccurs="unbounded"/>
        <xs:element ref="StandardItemTable" maxOccurs="unbounded"/>
        <xs:element ref="CatalogCodeTables" maxOccurs="unbounded"/>
      </xs:sequence>
    </xs:complexType>
  </xs:element>
  <xs:element name="MarketAreaTable">
    <xs:complexType>
      <xs:sequence>
        <xs:element name="TableID"/>
        <xs:element name="TableDescription"/>
        <xs:element name="Description"/>
        <xs:element name="RTF_Description"/>
        <xs:element ref="CatalogMarketAreaMap" maxOccurs="unbounded"/>
      </xs:sequence>
    </xs:complexType>
  </xs:element>
  <xs:element name="CatalogMarketAreaMap">
    <xs:complexType>
      <xs:sequence>
        <xs:element name="CatMarketAreaMapID"/>
        <xs:element name="CatMarketAreaMapDescription"/>
        <xs:element name="CatMarketAreaMapRTFDescription"/>
        <xs:element name="CatMarketAreaMapIndex"/>
        <xs:element name="Comment"/>
        <xs:element name="RTF_Comment"/>
        <xs:element ref="CatMarketAreaMapNode" maxOccurs="unbounded"/>
      </xs:sequence>
    </xs:complexType>
  </xs:element>
</xs:schema>
```
<xs:element name="CatBidHistoryTable">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="TableID"/>
      <xs:element name="TableDescription"/>
      <xs:element name="Description"/>
      <xs:element name="RTF_Description"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

<xs:element name="CatBidHistoryTableElement">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CatBidHistoryId"/>
      <xs:element name="CatBidHistoryDescription"/>
      <xs:element name="CatBidHistoryRTFDescription"/>
      <xs:element name="CatBidHistoryMaxQty"/>
      <xs:element name="CatBidHistoryMinQty"/>
      <xs:element name="CatBidHistoryQtyLevel0"/>
      <xs:element name="CatBidHistoryQtyLevel1"/>
      <xs:element name="CatBidHistoryQtyLevel2"/>
      <xs:element name="CatBidHistoryQtyLevel3"/>
      <xs:element name="CatBidHistoryQtyLevel4"/>
      <xs:element name="CatBidHistoryAreaMapIndex" type="xs:boolean"/>
      <xs:element name="IsTransport"/>
      <xs:element name="Comment"/>
      <xs:element name="RTF_Comment"/>
      <xs:element ref="CatBidHistoryAverageModel" maxOccurs="unbounded"/>
      <xs:element ref="CatBidHistoryRegressionModel" maxOccurs="unbounded"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

<xs:element name="CatBidHistoryAverageModel">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CatBidHistoryAvgModelModelNumber"/>
      <xs:element name="CatBidHistoryAvgModelQtyLevel"/>
      <xs:element name="CatBidHistoryAvgModelWorkType"/>
      <xs:element name="CatBidHistoryAvgModelAreaType"/>
      <xs:element name="CatBidHistoryAvgModelSeason"/>
      <xs:element name="CatBidHistoryAvgModelHighwayType"/>
      <xs:element name="CatBidHistoryAvgModelUrbanRuralType"/>
      <xs:element name="CatBidHistoryAvgModelUnitPrice"/>
      <xs:element name="CatBidHistoryAvgModelStandardDeviation"/>
      <xs:element name="CatBidHistoryAvgModelNumberOfObservations"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

<xs:element name="CatBidHistoryRegressionModel">
  <xs:complexType>
  </xs:complexType>
</xs:element>
<xs:sequence>
  <xs:element name="CatBidHistoryRegModelModelNumber"/>
  <xs:element name="CatBidHistoryRegModelStandardDeviation"/>
  <xs:element name="CatBidHistoryRegModelFootMeanSquare"/>
  <xs:element name="CatBidHistoryRegModelInterceptCoeff"/>
  <xs:element name="CatBidHistoryRegModelQtyCoeff"/>
  <xs:element name="CatBidHistoryRegModelDateCoeff"/>
  <xs:element name="CatBidHistoryRegModelDateSquareCoeff"/>
  <xs:element name="CatBidHistoryRegModelWeightedAvg"/>
</xs:sequence>
</xs:complexType>
</xs:element>

<xs:element name="CatBidHistoryRegModelCoeffSet" minOccurs="0" maxOccurs="unbounded">
<xs:element name="CatMaterialElementDescription"/>
<xs:element name="CatMaterialElementUnit"/>
<xs:element name="CatMaterialElementPrice"/>
<xs:element ref="IsTrnsport"/>
<xs:element name="Comment"/>
</xs:sequence>
</xs:complexType>
</xs:element>

<xs:element name="ReferencePriceTable">
<xs:complexType>
<xs:sequence>
<xs:element name="TableID"/>
<xs:element name="TableDescription"/>
<xs:element name="Description"/>
<xs:element ref="ReferencePriceTableElement"/>
</xs:sequence>
</xs:complexType>
</xs:element>

<xs:element name="ReferencePriceTableElement">
<xs:complexType>
<xs:sequence>
<xs:element name="CatReferencePriceID"/>
<xs:element name="CatReferencePriceDescription"/>
<xs:element name="CatReferencePriceUnitPrice"/>
<xs:element name="CatItemReferencePricePercent"/>
<xs:element name="CatItemReferencePricePercentFlag"/>
<xs:element ref="IsTrnsport"/>
<xs:element name="Comment"/>
</xs:sequence>
</xs:complexType>
</xs:element>

<xs:element name="StandardItemTable">
<xs:complexType>
<xs:sequence>
<xs:element ref="TableID"/>
<xs:element name="TableDescription"/>
<xs:element name="Description"/>
<xs:element ref="ItemTableElement" maxOccurs="unbounded"/>
</xs:sequence>
</xs:complexType>
</xs:element>

<xs:element name="ItemTableElement">
<xs:complexType>
<xs:sequence>
<xs:element name="CatitemId"/>
<xs:element name="CatItemDescription"/>
<xs:element name="CatItemUnit"/>
<xs:element ref="CatItemUnitSys"/>
<xs:element name="CatItemRequireSupplementalDescription"/>
<xs:element ref="IsTrnsport"/>
<xs:element name="Comment"/>
<xs:element ref="CatCostSheetReference" minOccurs="0"/>
<xs:element ref="CatReferencePriceReference" minOccurs="0"/>
<xs:element ref="CatBidHistoryReference" minOccurs="0"/>
<xs:element ref="CatPriceBasisList" minOccurs="0"/>
</xs:sequence>
</xs:complexType>
</xs:element>

<xs:element name="CatItemUnitSys">
<xs:simpleType>
<xs:restriction base="xs:string">
  <xs:enumeration value="E"/>
  <xs:enumeration value="M"/>
  <xs:enumeration value="N"/>
</xs:restriction>
</xs:simpleType>
</xs:element>

<xs:element name="CatCostSheetReference">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CatCostSheetReferenceID"/>
      <xs:element name="CatCostSheetReferenceDescription"/>
      <xs:element name="CatCostSheetReferenceQtyPerUnit"/>
      <xs:element name="CatCostSheetReferenceReference"/>
      <xs:element name="IsActive"/>
      <xs:element name="Comment"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

<xs:element name="CatReferencePriceReference">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CatReferencePriceReferenceID"/>
      <xs:element name="CatReferencePriceReferenceDescription"/>
      <xs:element name="CatReferencePriceReferenceQtyPerUnit"/>
      <xs:element name="CatReferencePriceReferenceReference"/>
      <xs:element name="IsActive"/>
      <xs:element name="Comment"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

<xs:element name="CatBidHistoryReference">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CatBidHistoryReferenceID"/>
      <xs:element name="CatBidHistoryReferenceDescription"/>
      <xs:element name="CatBidHistoryReferenceQtyPerUnit"/>
      <xs:element name="CatBidHistoryReferenceReference"/>
      <xs:element name="IsActive"/>
      <xs:element name="Comment"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

<xs:element name="CatPriceBasisList">
  <xs:complexType>
    <xs:sequence>
      <xs:element name="CatItemPriceBasisListId"/>
      <xs:element name="CatItemPriceBasisListDescription"/>
      <xs:element name="IsActive"/>
      <xs:element name="Comment"/>
      <xs:element ref="CatCostSheetReference" minOccurs="0"/>
      <xs:element ref="CatReferencePriceReference" minOccurs="0"/>
      <xs:element ref="CatBidHistoryReference" minOccurs="0"/>
      <xs:element ref="CatPriceBasisList" minOccurs="0"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

<xs:element name="CatalogCodeTables">
  <xs:complexType>
    <xs:sequence>
      <xs:element ref="WORKTYPECODETABLE"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>
<xs:element name="HWYTYPECODETABLE">
  <xs:complexType>
    <xs:sequence>
      <xs:element ref="TableID"/>
      <xs:element name="TableDescription"/>
      <xs:element name="Description"/>
      <xs:element ref="CatalogCodeTableElement" maxOccurs="unbounded"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

<xs:element name="COUNTYCODETABLE">
  <xs:complexType>
    <xs:sequence>
      <xs:element ref="TableID"/>
      <xs:element name="TableDescription"/>
      <xs:element name="Description"/>
      <xs:element ref="CatalogCodeTableElement" maxOccurs="unbounded"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

<xs:element name="SEASONCODETABLE">
  <xs:complexType>
    <xs:sequence>
      <xs:element ref="TableID"/>
      <xs:element name="TableDescription"/>
      <xs:element name="Description"/>
      <xs:element ref="CatalogCodeTableElement" maxOccurs="unbounded"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

<xs:element name="UNITSCODETABLE">
  <xs:complexType>
    <xs:sequence>
      <xs:element ref="TableID"/>
      <xs:element name="TableDescription"/>
      <xs:element name="Description"/>
      <xs:element ref="CatalogCodeTableElement" maxOccurs="unbounded"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>

<xs:element name="URBANRURALCODETABLE">
  <xs:complexType>
    <xs:sequence>
      <xs:element ref="TableID"/>
      <xs:element name="TableDescription"/>
      <xs:element name="Description"/>
      <xs:element ref="CatalogCodeTableElement" maxOccurs="unbounded"/>
    </xs:sequence>
  </xs:complexType>
</xs:element>
Pictorially, the schema can be represented as a set of diagrams representing the structure of the XML documents conforming to the schema. These diagrams show the hierarchical structure of the data that reflects the logical structure of the data being transported. The following diagrams represent catalog data as stored in an XML file.
A.9.1 Catalog

- SpecYear
- Comment
- RTF_Comment
- MarketAreaTable
  - BidHistoryTable
    - 1..∞
  - CostSheetTable
    - 1..∞
- EquipmentTable
  - 1..∞
- LaborTable
  - 1..∞
- MaterialTable
  - 1..∞
- ReferencePriceTable
  - 1..∞
- StandardItemTable
  - 1..∞
- CatalogCodeTables
  - 1..∞
A.9.2 MarketAreaTable
A.9.3 Bid History Catalog
A.9.4 CatBidHistoryAverageModel

A.9.5 CatalogCodeTableElement

A.9.6 CatalogCodeTables
A.9.7 CatBidHistoryCoeffSetNode

A.9.8 CatBidHistoryRegModelCoeffSet
A.9.9 CatBidHistoryRegressionModel

A.9.10 CatCostSheetEquipmentSet

A.9.11 CatCostSheetEquipmentSetReference
A.9.12 CatCostSheetLaborSet

- CatCostSheetLaborSetID
- CatCostSheetLaborSetDescription
- CatCostSheetLaborSetOverhead
- Comment
- CatCostSheetLaborSetReference

A.9.13 CatCostSheetLaborSetReference

- CatCostSheetLaborReferenceID
- CatCostSheetLaborReferenceDescription
- CatCostSheetLaborReferenceQuantity
- CatCostSheetLaborReferenceLastUpdated
- Comment

A.9.14 CatCostSheetMaterialSet

- CatCostSheetMaterialSetID
- CatCostSheetMaterialSetDescription
- CatCostSheetMaterialSetOverhead
- Comment
- CatCostSheetMaterialSetReference
A.9.15 CatCostSheetMaterialSetReference

A.9.16 CatCostSheetReference
A.9.17 CatPriceBasisList

CatPriceBasisList

- CatItemPriceBasisListId
- CatItemPriceBasisListDescription
- IsActive
- Comment
- CatCostSheetReference

A.9.18 CostSheetTable

CostSheetTable

- TableID
- TableDescription
- Description
- CostSheetTableElement
A.9.19 CostSheetTableElement

- CatCostSheetID
- CatCostSheetDesc
- CatCostSheetProductionRate
- CatCostSheetHoursPerDay
- CatCostSheetOvertimeHoursPer...
- CatCostSheetMarkupPercentage
- CatCostSheetUnit
- IsTransport
- Comment
- CatCostSheetEquipmentSet
- CatCostSheetLaborSet
- CatCostSheetMaterialSet

A.9.20 COUNTYCODETABLE

- TableID
- TableDescription
- Description
- CatalogCodeTableElement 1..*
A.9.24 ItemTableElement

A.9.25 LaborTable

A.9.26 LaborTableElement
A.9.27 MaterialTable

A.9.28 MaterialTableElement

A.9.29 ReferencePriceTable

A.9.30 ReferencePriceTableElement
A.9.31 SEASONCODETABLE

A.9.32 StandardItemTable
A.9.33 UNITSCODETABLE

A.9.34 URBANRURALCODETABLE

A.9.35 WORKTYPECODETABLE
A.10 Importing an Estimate as a CSV File

An estimate can be imported from a CSV file. Each field in the estimate needs to be represented in the CSV file and in the listed order to match the data to the correct Estimator field. If you do not have data for a particular field, enter a comma for that field.

**Note:** If using a spreadsheet to create the CSV file, make sure all numbered fields are set to text to maintain leading zeroes.

The Flag placeholder is coded to tell the Estimator software what to expect in the following data.

For example, a CSV file containing item information with no information for the NOTES tab and no supplemental description may look like this:

```
ITEMNAME,5509382,0025,,202-00240,Rem Asphalt Mat (Planning),,SY,aal,6437.000,23.00000,148051.00
```

The following table lists the data for estimate header information.

<table>
<thead>
<tr>
<th>CSV Placeholder</th>
<th>Field in Estimator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>ESTIMATE flag</td>
<td>None, name of estimate</td>
<td>ESTIMATE</td>
</tr>
<tr>
<td>Estimate ID</td>
<td>Estimate ID</td>
<td>2010BJS0827</td>
</tr>
<tr>
<td>Estimate Note</td>
<td>Notes</td>
<td>,</td>
</tr>
<tr>
<td>Estimate Desc</td>
<td>Description</td>
<td>Update highway</td>
</tr>
<tr>
<td></td>
<td></td>
<td>construction</td>
</tr>
<tr>
<td>Estimate Type</td>
<td>Estimate Type (on Page 2)</td>
<td>CREEK</td>
</tr>
<tr>
<td>Estimate Type2</td>
<td>Estimate Type (on Page 2)</td>
<td>pre</td>
</tr>
<tr>
<td>Work Type Code</td>
<td>Work Type</td>
<td>ASPH</td>
</tr>
<tr>
<td>Work Type Desc</td>
<td>Work Type</td>
<td>ASPHALT</td>
</tr>
<tr>
<td>Highway Type Code</td>
<td>Highway Type</td>
<td>INTR</td>
</tr>
<tr>
<td>Highway Type Desc</td>
<td>Highway Type</td>
<td>Interstate</td>
</tr>
<tr>
<td>Urban/Rural Type Code</td>
<td>Urban/Rural Type</td>
<td>U</td>
</tr>
<tr>
<td>Urban/Rural Type Desc</td>
<td>Urban/Rural Type</td>
<td>Urban</td>
</tr>
<tr>
<td>County Code</td>
<td>County</td>
<td>C031</td>
</tr>
<tr>
<td>County Desc</td>
<td>County</td>
<td>CHAFFEE</td>
</tr>
<tr>
<td>Season Code</td>
<td>Season</td>
<td>SUMM</td>
</tr>
<tr>
<td>Season Desc</td>
<td>Season</td>
<td>SUMMER</td>
</tr>
<tr>
<td>Estimated By</td>
<td>Estimated By</td>
<td>James</td>
</tr>
<tr>
<td>Checked By</td>
<td>Checked By</td>
<td>Jim Pattion</td>
</tr>
</tbody>
</table>
Table A-1. Estimate Header Fields

**Note:** Entering data into the Estimated By Date, Base Date, Checked By Date, or Approved By Date of a CSV Estimate file results in an error.

**Note:** Entering data after the Spec Year results in an error.

The Estimate Flag is created by setting bits as shown in the following table and then encoding the resulting number as decimal. Bits are numbered from right to left.

<table>
<thead>
<tr>
<th>Bit</th>
<th>Meaning If True (bit=1)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Edit prices only option is on</td>
</tr>
<tr>
<td>1</td>
<td>Contingency is valid</td>
</tr>
<tr>
<td>2</td>
<td>Total is valid</td>
</tr>
<tr>
<td>3</td>
<td>Ensure Trns•port structure option is on</td>
</tr>
<tr>
<td>4</td>
<td>Ensure Trns•port Price Bases option is on</td>
</tr>
<tr>
<td>5</td>
<td>Is Estimate preparation date valid</td>
</tr>
<tr>
<td>6</td>
<td>Is Estimate checked date valid</td>
</tr>
<tr>
<td>7</td>
<td>Is Estimate approval date valid</td>
</tr>
</tbody>
</table>
The following table lists the data for estimate group information.

<table>
<thead>
<tr>
<th>CSV Placeholder</th>
<th>Field in Estimator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>EST_GROUP</td>
<td>None, name of group</td>
<td>Road Work</td>
</tr>
<tr>
<td>Flag</td>
<td>None</td>
<td>5509121</td>
</tr>
<tr>
<td>Group Number</td>
<td>Group Number</td>
<td>0010</td>
</tr>
<tr>
<td>Group Note</td>
<td>NOTES Tab</td>
<td>Contains all items related to paving</td>
</tr>
<tr>
<td>Group Desc</td>
<td>Group Description</td>
<td>Items related to paving</td>
</tr>
<tr>
<td>Alternate Code</td>
<td>Alt Code</td>
<td>A10</td>
</tr>
<tr>
<td>Group Total</td>
<td>Group Total</td>
<td>0.00</td>
</tr>
</tbody>
</table>

Table A-2. Estimate Group Fields

The Group Flag is created by setting bits as shown in the following table and then encoding the resulting number as decimal. Bits are numbered from right to left.

<table>
<thead>
<tr>
<th>Bit</th>
<th>Meaning If True (bit=1)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Group is used in estimate total</td>
</tr>
</tbody>
</table>

The following table lists the data for estimate item information.

<table>
<thead>
<tr>
<th>CSV Placeholder</th>
<th>Field in Estimator</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>EST_ITEM</td>
<td>None, item name</td>
<td>EST_ITEM</td>
</tr>
<tr>
<td>Flag</td>
<td>None</td>
<td>5509382</td>
</tr>
<tr>
<td>Line Number</td>
<td>Line Number</td>
<td>0025</td>
</tr>
<tr>
<td>Note</td>
<td>NOTES Tab</td>
<td>Use reference price</td>
</tr>
<tr>
<td>Item Number</td>
<td>Item Number</td>
<td>202-00240</td>
</tr>
<tr>
<td>Item Desc</td>
<td>Description</td>
<td>Rem Asphalt Mat</td>
</tr>
<tr>
<td>Supplemental Desc</td>
<td>Supplemental Description</td>
<td>Includes new materials</td>
</tr>
<tr>
<td>Unit</td>
<td>Unit</td>
<td>SY</td>
</tr>
<tr>
<td>Alternate Code</td>
<td>AltCode</td>
<td>aa1</td>
</tr>
<tr>
<td>Quantity</td>
<td>Quantity</td>
<td>23.00000</td>
</tr>
<tr>
<td>Unit Price</td>
<td>Unit Price</td>
<td>6437.000</td>
</tr>
</tbody>
</table>
The Item Flag is created by setting bits as shown in the following table and then encoding the resulting number as decimal. Bits are numbered from right to left.

<table>
<thead>
<tr>
<th>Bit</th>
<th>Meaning If True (bit=1)</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Item requires a supplemental description</td>
</tr>
<tr>
<td>1</td>
<td>Unit price is valid</td>
</tr>
<tr>
<td>2</td>
<td>Quantity is valid</td>
</tr>
<tr>
<td>3</td>
<td>Item is used in group total</td>
</tr>
<tr>
<td>4</td>
<td>Item is ad hoc</td>
</tr>
<tr>
<td>5</td>
<td>Item is a percentage</td>
</tr>
<tr>
<td>6</td>
<td>Item is rolled up</td>
</tr>
<tr>
<td>7</td>
<td>Do not use (set to 0)</td>
</tr>
<tr>
<td>8</td>
<td>Exclude from percentage calculations</td>
</tr>
</tbody>
</table>

When you are finished importing the information, it is a good idea to reprice your estimate.