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Course Overview   
This volume focuses on the OpenRoads Survey tools and covers the post-processing of field data. 
The main topics contained in this volume are the importing and editing of field data once brought 
into a design model and the creation and editing of the Terrain Model. This volume also 
introduces users to the custom CTDOT placement and drawing tools available on the Ribbon (this 
replaces the Custom Tasks used in V8i).  
The underlying configuration that drives the survey engine has changed significantly since 
InRoads V8i SELLECTSeries 2. The Graphical engineering elements have become “intelligent” so 
have survey elements. There are no longer external database files (.dtm or .alg) to keep track of 
and sync with the graphical survey data as the survey information is stored within the graphical 
elements themselves in the design (.dgn) file. The elements keep track of how they were created 
(from what data files), what their terrain attributes are and how to display annotation. Modify the 
element’s terrain attributes and the Terrain Model updates, change its point code and the 
graphics update. This now allows for single file to deliver as a final product (even terrain elements 
are now contained within the DGN file itself).   

MODEL USES   
WHAT IS A TERRAIN MODEL?  
A terrain model is a set of triangles mathematically computed from point data collected from the 
surface being modeled. They are typically used to model highly irregular surfaces, like the surface 
of the earth. A terrain model is created from 3D features such as points, breaklines, and contours. 
Terrain models are also referred to as digital terrain models (DTMs), triangulated irregular 
networks (TINs), or triangulated surfaces. A terrain model is stored as a 3D mesh element in an 
OpenRoads/OpenRail Designer 3D design (.dgn) file, similar to what used to be stored in a GEOPAK 
TIN, InRoads DTM, or MX FIL file. When you select a terrain model in the design file, the Element 
Selection tool recognizes it as a Terrain Model, and the Properties and Explorer Windows will show 
it as a Terrain Model Element. The display of a terrain model in the product is controlled by using a 
Feature Definition and Element Template. Being an element stored in a 3D design file, terrain 
models are easily shared and used by anyone using any DGN based application like 
OpenBuildings Designer (formerly AECOsim Building Designer), OpenPlant Modeler, or MicroStation 
CONNECT Edition.  
  

WORKING DIRECTORY  
Before attempting to open or create DGN files users should make sure the following is in place: 

• CTDOT users should have the CTDOT CONNECT DDE synced through SharePoint with the 
COMPASS Project Synced along with the CAD Configuration. 

• Consultants should have CTDOT DDE properly installed or be syncing to the CTDOT DDE 
SharePoint/COMPASS system. 
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• Make note of the Coordinate System you will be working in. 

There are two Sub-Modules to complete to properly set up the CTDOT CAD Environment:  
• Syncing the SharePoint DDE – This is equivalent to the old network W Drive storage 

location for the CAD Workspace and when synced will show up under the Enterprise 
Icon.  

• Syncing a COMPASS Project – This is equivalent to the old Network P and X Drive Project 
locations and when synced will show up under the Enterprise Icon.  

The COMPASS Project is the working Directory. After Syncing there will be a Design folder 
available that has a sub-folder for each discipline.  

• District Survey will work in the SVY_District folder.  
• Central Survey will work in the SVY_Central folder.  

When a file is ready for designer to reference, a copy of the file will be placed in 
the Active_Survey folder. Central Survey will notify the Design team to let them know it is 
available.  

All edits will be made in the SVY_District or the SVY_Central folders and pushed up 
to Active_Survey as needed.  

SEED FILES  
Seed file is a term for a template. When a user selects File/New, the application makes a copy of 
the selected seed file, puts it in the desired folder, and the dgn is given a new name.  
The CTDOT Survey seed file is set to  
CT_Configuration\Organization\Seed\Survey\CT_SurveySeed.dgn 
This is a file with a 3D Design Model that has been assigned a default Geographic Coordinate 
System (GCS) of NAD 1983 State Plane Connecticut with a North American Vertical Datum of 1988 
to allow interaction with geospatial applications.  
 
For more on Seed files and GSC, please see Volume 2.  
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Exercise 1 – Base Survey File Creation 
In this module you will learn how to access OpenrRoads Designer to create a new DGN file.  

Skills Taught 
• Learn how to access the Application to get the proper workspace to appear. 
• Learn how to create a DGN file from the proper seed file. 
• Learn how to update the Geographic Coordinate System. 

1.1 Startup 

Before attempting to open or create DGN files users should make sure the following is in place: 

1. CTDOT users should have the CTDOT CONNECT DDE synced through SharePoint with the 
COMPASS Project Synced along with the CAD Configuration. 

2. Consultants should have CTDOT DDE properly installed or be syncing to the CTDOT DDE 
SharePoint/COMPASS system. 

3. Make note of the Coordinate System you will be working in. 

4. Log on to the CONNECTION Client. 

Bentley Connect licensing requires users to log into their Bentley account to secure a 
software license. CTDOT users should log in using your CTDOT email address and Bentley 
password.If you do not see the dialog box, select the ˄ icon on the bottom Windows Screen. 
Click on the Connection Client Icon and select Open. 

     
Figure 1 CONNECTION Client System tray 
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5. Launch the Application. 
• Consultants 

Start the software 
 via an appropriate CTDOT DDE icon and skip to step 5. 

 

• CTDOT employees 
On your desktop double click on the  
CAD Accounting Icon. 

 
 
 

 

6. On the CT DOT Accounting Menu there will be several applications to pick. Select Compass 
OpenRoads CE. 

7. In the Run Program field select the needed program, the Available Account (funding 
source) and Resource Type. Click on the Start button to load the program. 

 
Figure 4 CAD Accounting dialog box 

Figure 3 CAD 
Accounting Icon 

Figure 2 ORD 
Icon 
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8. After launching the program, the following a Welcome Screen will appear.   
9. Ensure you are using the Custom Configuration and CT_WorkSpace, then select the 

relevant WorkSet and Role > Survey.  

 
Figure 5 OpenRoads Welcome Splash Screen 

If you do not see the Project Number listed, please request a Compass/CAD Setup using this 
link  New CAD Project Request 

1.2 Create a Design File 

1. Select the New File Icon. In the New dialog box browse to the SVY_District folder. 

2. The Seed file should be set to the Survey Workspace. If this is not the case, click on 
the Browse button to pick the seed file.  

To select a seed file browse to: 
 CT_Configuration\Organization\Seed\Survey\ 
and select: CT_SurveySeed.dgn 

3. In the File name field enter a name for your file using the CTDOT File Naming structure.
 Example: SV_D2_1234_1234_Ground TOPO - Terrain.dgn    

4. Select Save and the new file will open. 

Note: Do not copy DGN files created with V8i SELECTseries or InRoads SS2, SS3, SS4, or SS10 
to the new CTDOT CONNECT Project/WorkSet folders.  

https://ctdotcompass.atlassian.net/servicedesk/customer/portal/8/group/24/create/100
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5. After the DGN file is created open File Explorer and browse to the file, right click and select 
View online. 

  
Figure 6 File Explorer View online tool 

6. The Projects SharePoint site will open, sort by Date, click on the three dots, select More > 
Check Out 

Note: When you are done working on the DGN file, exit the program and go back to 
the SharePoint Site and Check In the file. 

 
Figure 7 SharePoint Check out 
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Exercise 2 – Exploring the Interface 
In this module you will learn how to review and navigate the new CONNECT Edition interface, the 
ribbon tool bars, and review User Preferences. In this module you will also explore the Standard 
Survey Feature Definitions that have been set up for CTDOT. 

Skills Taught 
• To become proficient finding needed tools in ORD. 
• To become familiar with the custom CTDOT Ribbon. 
• To gain a basic understanding how the User Preference Settings work. 
• To become familiar with the CTDOT OpenRoads Survey Standards.  

2.1 The CONNECT EDITION Interface 
1. Continue in the file created in Module 1. On the pull-down menu on the top left next to the 

OpenRoads Icon select Survey, this is the Workflow Pick list. 
ORD and MicroStation CONNECT are ribbon based. The ribbon interface is driven by 
workflow picklists. Different workflows contain different tab options for the ribbon. Each tab 
exposes specific groups and tools.  

 
Figure 8 

2. Select different Tabs and Workflows and notice the Ribbon change. 
These Tab sets replace the Tasks that were available in V8i. In the image below, the Survey 
workflow displays a Drawing tab. The Drawing tab contains the Placement group which 
includes Line and Arc tools. 

 
Figure 9 
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3. In Search, Type in a tool name or a portion of one and a list will pop up, select as needed.   

The Search function is very useful for initially finding dialogs, tools, etc.  

 
Figure 10 
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2.2 User Preferences 
1. User settings have been moved to what is referred to as the Backstage. Access this through 

the main menu: File> Settings> User> Preferences to open the Preferences dialog box. 

 
Figure 11 
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2. On the Preferences dialog box, select View Options. Check on Scroll Bars and turn Off Anti-
alias Lines and Anti-alias Text. 

 
Figure 12 
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3. Explore View Options – Civil to view or change civil preferences. You can display and set 
point label preferences such as Number and Elevation under Survey Decorators.   
 
The intent here is to standardize and automate, these options don't need to be modified but 
it is important to be aware of the settings.  Survey Decorators appear the same size 
regardless of zoom level; however, they will resize according to the size of the view window. 

 

 
Figure 13 

 

 
Figure 14 
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4. With the Preferences dialog still open, explore other Preferences such as Survey Locator. 

5. Save settings if desired by choosing File> Save Settings. 

6. Return to the design file by clicking the back arrow. 

 
Figure 15 

  

2.3 The Survey Ribbon 
Familiarize yourself with the Survey Workflow, ensure that the ribbon Workflow is set to 
the Survey. 
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Figure 16 

1. Open the Details dialog box. 
① Click the Field Book tab [Note that the ribbon groups and tools are quite different from 
the Home tab]. 
② Click Details to toggle Survey Details. 
③ Drag the Details dialog box and dock on the Screen as needed. 

 
Figure 17 

2. You may wish to open the Feature Definition toolbar. 
① Begin by typing feature into the Ribbon Search. 
② Hover over the Feature Definition Toolbar result. 
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③ Note the Survey workflow tip. 

 
Figure 18 

  
Options above are available to either click the ② Feature Definition Toolbar result or to follow 
the ③ interface tip. 

  
3. You can also find this on the Ribbon, ①Survey> ②Geometry> ③General 

Tools> ④Standards. 

 
Figure 19 

4. Dock the resulting Feature Definition Toolbar if desired. 

 
Figure 20 
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2.4 CTDOT OpenRoads Standards 
Default resources are listed in the OpenRoads Standards group Libraries. If they have been 
changed by the user, they will become part of the design file. 
1. From the Explorer interface, select the OpenRoads Standards group, expand Standards, 

and expand Libraries. 
This may take a moment since files need to be cached. 

 
Figure 21 
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2. Explore Standards> Libraries> Feature Symbologies> Feature Symbology Model 

(CV_Survey_Feature_Definitions.dgnlib). 
Note the Symbology names in the right pane.  

 
Figure 22 
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3. Expand Survey Settings to explore Linking Codes, etc.  Please note, there are 2 separate 
sections where Survey Settings will appear.  The greyed-out sections are showing the 
CTDOT preferred settings and cannot be changed. The Survey Settings section below the 
greyed-out section are copied to the DGN file upon creation of a field book. Those settings 
are able to be adjusted for project specific needs.  
[Linking Codes are further discussed in Module 3] 

 
Figure 23 
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2.5 The CTDOT Ribbon 
Tasks are no longer supported in CONNECT; therefore, AEC Applications has customized ORD 
with specific workflows for CTDOT users. The customized workflow is named CTDOT. 
1. On the pull-down menu on the top left next to the OpenRoads Icon select CTDOT, this is the 

Workflow Pick list. 

 
Figure 24 

  
This Workflow contains the Tabs that will be useful for Survey: 

• CTDOT 
• Prop Maps 
• Survey 

 
Figure 25 

2. The CTDOT tab includes a Publishing group. The Publishing group includes Type, 
Color, and Print tools. 

 
Figure 26 
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In this example, the Print tools are expanded. 

 
Figure 27 

For further information on printing and publishing please visit CTDOT CONNECT DDE eBook 
Volume 014 - Publishing and Printing. 

3. Select the Survey tab. The Open tools will open Cell Libraries. The Pull Downs will set 
Element Templates (Color, Weight, Line styles, and Levels) and trigger the Place Line 
command to activate. 

 
Figure 28 

  

https://authoring.ct.gov/dot/~/link.aspx?_id=F8BECC41645A4689AFD69F9B502305E9&_z=z
https://authoring.ct.gov/dot/~/link.aspx?_id=F8BECC41645A4689AFD69F9B502305E9&_z=z
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Exercise 3 – Base Survey File Set up 
Once inside a MicroStation design file, there may be some initial verification/set up that could be 
performed for each file, such as: a default Cell Library, a default Text Style, and Drawing Scale. 

Skills Taught 
• Learn how to open navigate through the interface to Activate a Cell Library, set a Text Style 

and the Drawing Scale. 

• Get familiar with the CTDOT OpenRoads Survey Standards. 

3.1 Activate Cell Library 
From the CTDOT workflow, select the Survey tab, in the Existing Features section select Open 
Features. The Cell Library CTDOT_ORD_Features_Existing.cel will open. 

 
Figure 29 

3.2 Set Text Style 
You may wish to set a default text style of CTDOT_100 for annotation. Note: This is no longer 
critical since ORD decorator text for nodes is now set in preferences. 
Choose Text Styles through Survey> Drawing Production> Text> Text Styles, double click 
the CTDOT_100 Text Style to activate it. 

 
Figure 30 
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3.3 Set the Drawing Scale 
Drawing Scale can be set so that annotation is visually pleasing. It can be changed at any 
time. 
Set the ④ Drawing Scale dialog box through ①Survey> ②Drawing> ③Drawing Scales. 

 

 
Figure 31 
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Exercise 4 – Processing Survey Data 
In this Module, you will learn how to import an ASCII survey data file and edit the imported data. 

Skills Taught 
• Learn how to Import Field Data (ASCII data file). 
• To become familiar with the available tools and dialog boxes. 
• To become proficient editing the imported field data. 

 

4.1 Review and Edit Data Files 
Raw data (usually in the form of *.rw5) and coordinate files (usually in the form of *.txt) should 
be reviewed and can be edited before the import in to OpenRoads. One option is to edit field 
files via a text editor before loading them into the field book. 
Numerical order is irrelevant. The important thing is the order in how link codes define the 
shape. 

 
Figure 32 

   
Additional points (i.e. Stored Points) can be entered, but ensure that they stand out from 
actual shots taken (i.e. Observation Points.) ORD will resolve double link codes by using an 
underbar and number suffix (e.g. 1018_1) so a good practice is to use a letter suffix. 
 

 
Figure 33 
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String Substitutions - ORD no longer uses multiple Linking Codes; however, double coded 
shots such as “st pc” are automatically converted through String Substitutions (e.g. 
“startPC”.) CTDOT has added “pt cl” to simply “cl” behind the scenes. This allows field 
personnel to continue using familiar InRoads coding for the time being. 

  

 
Figure 34 

  

 
Figure 35 

See the next 2 pages for examples of Linking Codes, Substitute Strings, and Control Survey Codes. 
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Figure 36A 

 
Figure 37B 
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Figure 38C 

 
Figure 39D 

For more information on Linking Codes and Control Survey Codes, see Section 4.7.4 of this guide. 
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4.2 Create Field Book 

1. From the Explorer interface, select the Survey group. Note: The model name, “Default” is 
listed as the default under Survey Data – not the design file name. This could be renamed 
to something more relevant such as: Terrain, Ground File, Annotation, etc.  The current 
Survey See File (CT SurveySeed.dgn) will create a Model with the name of Existing Ground 
Survey. 

 
Figure 40 

2. Expand the model tree. 

3. Right-click on Field Books to review the menu options. 

• Create Terrain Model From Field Book Selection Set Depending on your system 
configuration Terrain Models can be created dynamically. The benefit to this is you can 
see how edits affect the Terrain Model in real time (we will use this functionality later in 
this course). Also any additional data collected is added to the Terrain Model 
automatically. If you elect to turn this functionality off however, it’s a simple matter to 
create a Terrain Model using this menu choice. You may also notice that it will use a 
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selection set, this might be highly useful if you need a specialized Terrain Model made 
from certain data types or Feature Codes. 

• New This menu choice creates a new Field Book. As noted before it’s entirely up to you 
how many (or few) Field Books you utilize in your projects. 

• Properties Properties will display all of the properties of a survey feature. 

• Zoom Zoom will allow you to zoom into a specific area of data in your project. Within a 
large project (with several Field Books) it may be beneficial to be able to Zoom into a 
specific data collection session. 

• Isolate and Clear Isolate This will modify the display to highlight specific collection 
sessions. Useful if you have several Field Books. 

4. In the Survey panel, right-click on Field Books and select New... 

5. On the Selecting Settings dialog select Accept. Note that a new drop-down arrow appears 
as a Field Book is added. 

 
Figure 41 

6. Expand Field Books. 

When a new Field Book is created, it will be created under the Field Books folder with a 
default name of Field Book 1. To view the newly created field book you must expand the Field 
Books folder using the drop-down arrow next to Field Books in the Survey pane 

7. Expand the newly created Field Book 1, additional Survey information will appear once data 
has been imported.  

Under Field Books is where the survey data you import is stored. You can create the data 
structure to fit your operational needs. 
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• Do you need a single “Job” where all the collected field data is stored? You can do 
that. 

• Do you need to separate each and every collection into it’s own book? That’s easy as 
well. 

Basically, it is up to you to decide what a “Field Book” contains. 

 
Figure 42 
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4.3 Rename the Field Book 

1. Click Field Book 1 in Explorer to select its properties as shown in the previous image. 

2. Using the Properties (Survey) interface, rename Field Book 1 to something more appropriate 
if desired. 

 

 
Figure 43 
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4.4 Import Field Data 
All project field data should be stored in the COMPASS Project folder. OpenRoads can import 
multiple files at once. The 2 main types of survey data files used at CTDOT are *.rw5 and *.txt. 
RW5 files contain raw survey data meaning setups, backsights, rod heights, angles, and slope 
distances. TXT files contain survey data that has already been reduced in software other than 
OpenRoads into coordinate locations. 

1. From the Explorer Survey group, right click the new field book to Import> File… 

 
Figure 44 

 Browse to the field data folder in your COMPASS Project. If using this as a training document, 
browse to the location of the CTDOT_SURVEY_ALL_DATA.RW5 file (available from CTDOT AEC). 

2. First select a control file if present.  Control is already present in the 
CTDOT_SURVEY_ALL_DATA.RW5 file. 

3. Click OK. Files with an asc extension will not work. 

When importing text files, pick the one of the top 2 options (“…code or …code, code”). 
 

 
Figure 45A 
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4. Continue to import multiple field files to Field Book 1. You can Add them or simply click OK. 

If using this as a training document, the CTDOT_SURVEY_ALL_DATA.RW5 file is the only file to 
be imported. 

At this point it’s important to mention that all of the resulting survey data is contained within 
the DGN file. There are no external files and no need to ensure synchronization between the 
“data” and the resulting graphics or terrain. The resulting graphic elements contain the 
“intelligence” and “know” certain survey properties such as Terrain Model attribute (Spot, 
Break, None) how they should display and other properties that used to be controlled by 
multiple external files. As you will shortly see this is very powerful and makes editing data 
very intuitive and the resulting changes are seen in real-time as the graphics update. 
However, sometimes this does necessitate a different mindset. Such as, to make changes to 
the Terrain Model best practice would be to edit the terrain properties of the point rather 
than the resulting “Triangles”. 

5. Review the imported survey data. Use the Fit View tool to see the results. 

4.5 Address Duplicate Points 
Address duplicate points using the ①“Differences” tab if necessary. 
NOTE: Most of the time selecting the ② “Skip” option will be the correct choice, but this may 
vary depending on the project needs. In this example shown below, the Control file information 
was brought in first and should take precedence. 
③ Apply All. 

 
Figure 46 

The field book tree is now populated. 
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Figure 47 
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4.6 View Options 
 

4.6.1 Examine Survey Features 

In this section, you will examine Survey Features. 
1. Fit View. All Observations and Triangles are displayed by default. 

 

 
Figure 48 
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2. You may toggle off All Observations through Explorer if desired. NOTE: TXT files will not 
have Setups or Observations as those have already been processed in software other 
than OpenRoads. 

 
Figure 49 

3. Zoom into the view. Use Element Selection to click and highlight the Terrain Model outer 
boundary. 

 
Figure 50 
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4. Toggle displays such as Triangles by double clicking the Off or On through Properties. 
The display immediately changes. 

 
Figure 51 



Volume 4 - OpenRoads Designer Survey 

38 
 

4.6.2 Decorations 

In this section, you will become familiar with decorations. Decorations provide surveyors a 
quick display tool to access vital survey point information. They can be utilized during the 
quality control process and differ from the annotation tools which place permanent labels 
in the project. 

1. Change the active tab from Home to Analyze. 

Note the Decorations section of the menu, these tools control the display of survey data 
such as the survey point Names, Field Codes, Elevations, Descriptions, Setups, 
Observations and Icons. All of these tools function as ON/OFF display toggles. 

2. In the Decorations section of the ribbon, left-click on the Names tool and notice that 
the point names disappear. Left-click on Names again and the display returns. 

3. Display the Field Codes and Elevations. 

In the Decorations section of the ribbon, left-click Field Codes to display the feature 
codes. 
Left-click Elevations, to display the elevations of the survey points. 
The display properties of the Decorations can be configured from the Back Stage 
view. 

4. Select File to get to the back stage and then select Settings > User > Preferences > View 
Options - Civil > Survey Decorators. The Colors have been set up to follow standards 
and should not be changed. 

Click OK to accept any changes and return to the drawing view and note the changes. 
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4.7 Process Survey Data 
Be aware that any editing after this point will become self-contained in the MicroStation file, 
and there presently is not an option to export the edited field book from OpenRoads. 

4.7.1 Survey Details Reminder and Usage 

The Survey Details panel will show whatever Point Features or Linear Features are 
highlighted in Explorer.  
 

 
 

Figure 52A 

As Point and Linear Features are chosen in Explorer, the numbers in the bottom left of the 
Survey Details will change to reflect the number of items chosen in Explorer. 
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Figure 53B 

 
The columns can be sorted by various methods and the columns shown can be 
customized as needed to eliminate the display of any redundant or unneeded data. 

 

 
Figure 54C 
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Figure 55D 

1. Display Survey Details if not already shown. 

2. Click All Observations to list them. 

 
Figure 56 
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4.7.2 Review Flags and Messages 

 
Figure 57 

Any Points or Linear Features with incorrect field coding will show in RED in the Explorer 
Dialog.  
 

 
Figure 58 
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1. Before doing any editing of Survey Features, it is a good idea to choose the Set Mark Icon 

from the Quick Access Toolbar.  This will allow undoing of the DGN back to the time of 
clicking the Set Mark Icon. 

2. Click on the “AFG” Point Feature shown in RED. 

3. If necessary, open the Survey Details Panel.  The Survey Details Panel will display any set of 
Point or Linear Features that are highlighted in the Explorer Dialog.  CTRL and SHIFT can be 
used in such selections just like File Explorer in Windows. 

4. Right-click the top of the Field Code Column and choose Replace. 

 
5. Replace the incorrect Field Code of “AFG” with the correct Field Code of “EB”. 
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Figure 59 
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Figure 60 

  



Volume 4 - OpenRoads Designer Survey 

46 
 

4.7.3 Heads-Up Editing 

1. Use Element Selection to select feature. 

2. Hover over the selection for the Heads-up Tools to appear. 

 
Figure 61 

3. Move the cursor over the Heads-up Tools to select a tool. 

Point feature tool choices are as follows: 

 
Figure 62 

1. Properties 
2. New Point Feature 
3. Turn on/off All Annotations 
4. Report 
5. Create Control Point 
6. Edit Observations 
7. Delete 
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Linear feature tool choices are as follows: 

 
Figure 63 

1. Properties 
2. Append Point In Linear Feature 
3. Move Point Along Linear Feature 
4. Insert Point In Linear Feature 
5. Close Linear Feature 
6. Break Linear Feature 
7. Transpose Linear Feature – Changes linestyle direction 
8. Move Linear Feature 
9. Report 
10. Convert to Point List Linear Feature 
11. Manage Point List 
12. Edit Point Features 
13. Delete 

4.  Use the Explorer Dialog in conjunction with the Survey Details Panel to edit any Survey 
Points or Survey Linear Features that need adjusting. 
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4.7.4 Survey Codes 

Linking Codes - Linking Codes is a way to connect features in the field. They are placed 
after Feature Codes. Some have been customized to avoid conflicts with feature codes. 

 
Figure 64 
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Figure 65 

Control Codes - Control Codes can be used to draw additional planimetrics for circles, 
rectangles, and lines; and can also modify a location. 

 
Figure 66 
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You are able to use a JPT code from a line see below. 

 
Figure 67 

 
You are able to use a JPT code from a line but not from a pc see below. 

 
Figure 68 

  
The following demonstrates results from each of these examples: 

 
Figure 69 
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Exercise 5 – Processing Terrain Data 
In this module you will learn how to view element that make up a terrain. You will also learn how to 
edit the terrain, by adding brake lines, void regions and an exterior boundary. 

Skills Taught 
• To become proficient with the terrain viewing and editing tools and option. 
• To become familiar with the CTDOT Standards set up for Terrains. 

  

Terrain Attribute Descriptions 
• Not Set – Not included in the terrain model. 

• Determine By Feature Definition – Whether the feature is included in the terrain model is 
determined by the DTM Attribute that was set when the Feature Definition was created. 

• Do Not Include – Not included in the terrain model. 

• Break Line - Breaks are used to designate linear features such as edges of pavement, ditch 
bottoms, ridges, etc. where an abrupt change of slope occurs. Any longitudinal element 
may be defined as a break line. Triangles will not cross a break line in the terrain model. 

• Soft Break Line - A soft break line is a break line; however, if it crosses a break line, it will not 
affect the triangulation and is ignored. 

• Boundary - The external boundary of the surface. 

• Drape Boundary - A surface boundary that determines its elevations by draping on the 
underlying surface. 

• Void - An area defined by a closed shape that demarcates a region of missing data or 
obscure areas. No point or break data located within the void area is utilized and no 
triangles are created inside the void areas. The Void coordinates are included in the 
triangulation and void lines between successive void coordinates are inserted as drape 
lines on the surface; therefore, they do not change the slope or elevations of the surface. 

• Drape Void - An area defined by a closed shape that demarcates a region of missing data 
or obscure areas. No point or break data located within the void area is utilized and no 
triangles are created inside the void areas. In the drape void, the void coordinates are not 
included in the triangulation. Voids are inserted post triangulation. The void coordinates 
and lines are draped on the terrain model surface. Even though a user must provide an 
elevation for Drape Void vertices, the user elevations are changed to the elevation of the 
terrain model surface at the XY Drape Void coordinate position. 

• Break Void - An area defined by a closed shape that demarcates a region of missing data 
or obscure areas. No point or break data located within the void area is utilized and no 
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triangles are created inside the void areas. It differs from Voids and Drape Voids in that it 
utilizes the vertex elevations of the graphical element, while the void lines between 
successive void coordinates are inserted as break lines; therefore, break voids change the 
slope and elevations of the surface. 

• Island - An area defined by a closed shape that demarcates a region of data wholly within 
a void. Example, islands in the middle of rivers, lakes, etcetera. 

• Contour - Element or set of elements of the same elevation. Contours may be used as 
source data to generate a terrain model or may be computed (drawn based on terrain 
model). Contour interval is the elevation difference between two adjacent contours. 

• Hole - An area defined by a closed shape that demarcates a region where the current 
terrain is ignored, and the underlying terrain is utilized. 

5.1 View Settings: Triangles/Contours 
Breaklines and points can be edited to change their terrain model attributes; however, terrain 
commands such as deleting triangles will not work until Survey Processing Rules are 
deactivated. 
Contour and triangle appearances are set by a template. To change their appearance to the 
familiar orange triangles: 

1. Select the Boundary element using Element Selection. 

2. From the Properties dialog, click Terrain Model: Existing Template. 

3. Choose Template> Existing Terrain> Existing Contours and Triangles. 

 
Figure 70 
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4. CTDOT will add more predefined choices based on District Survey input; however, the 
contour interval in the active file can be changed. Choose Template> Existing Terrain> 
Existing Contours and Triangles> Manage Templates. 

 
Figure 71 

5. Click the active file. 

6. Expand Existing Terrain. 

7. Click Existing Contours and Triangles. 

 
Figure 72 
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8. It the default Minor Interval of “5” is not desirable double click the value of “5” and enter “1” 

 
Figure 73 

If contours do not appear correct, Choose Existing Terrain> Existing Contours and delete. 

 
Figure 74 
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5.2  Inspect Contours 

5.2.1 Top View Hi Spots or Depressions 

1. Visually inspect for abnormalities in top view. 

 
Figure 75 

  
2. Use the tools at the top of the view window to zoom, fit, and pan. 

 
Figure 76 

  
3. Edit features if necessary, through Survey Details. 
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5.2.2 Front View Spikes 

1. Visually inspect for vertical abnormalities in front view. Rotate the view using the View 
Rotation tool. 

 
Figure 77 

2. Render the view through View Attributes. Try different Display Styles such as Smooth: 
Modeling or Thematic: Height. 

 
Figure 78 

  
3. You can also use isometric views for inspection. 

 
Figure 79 
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5.3 Process Terrain Features 

5.3.1 Edit Terrain Model Attributes 

Change the Terrain Model Attributes of an existing feature. In this example, we will modify a 
linear feature since it contains both a line and point elements. 

  
1. Use Element Selection to select a linear feature. 

 
Figure 80 

 
Figure 81 

    
2. Use the Heads-up tool to click Edit Point Features. 

 
Figure 82 

Survey Details now reflects the elements of the selected Linear Feature. 
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Figure 83 

3. Click the Terrain Model Attribute column header. 
4. Right Click to Edit. 

 
Figure 84 

5. Choose the desired property value (in this case, Do Not Include) from the drop-down list 
and click OK. This changes all Point Features that made up the line, but not the Linear 
Feature itself. 
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Figure 85 

6. To change the Terrain Model Attribute of the Linear Feature, use the Properties dialog. 
From Terrain Model Attribute, choose Do Not Include from drop down. 

 
Figure 86 

Triangles no longer include the edited Linear Feature. 



Volume 4 - OpenRoads Designer Survey 

60 
 

 
Figure 87 
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5.4  Add Break Lines 

5.4.1 Add newly drawn 3D Linear Feature 

One way to add a new breakline is to draw a 3D MicroStation line or line string and then 
convert it to a Graphic Linear Feature.  

1. Draw the line or line string that is to be added to the Survey Data as a Graphic Linear 
Feature. 

2. To covert the newly drawn 3D Linear Feature as a Break Line.  Choose Explorer> Survey> 
All Linear Features 

3. Right click to Add Graphic Linear feature. 

 
Figure 88 

4. Select the newly drawn line when prompted. 
5. Accept it and the re-triangulated view automatically refreshes.  
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6. From the model tree, click the newly added line, named Default. This is listed at the 
bottom of All Linear Features. 

 
Figure 89 

7. Change the field code in Survey Details. 

 
Figure 90 

  
8. Change the Terrain Model Attribute to Determine by Feature Definition. 
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5.4.2 Delete Break Lines 

1. To physically delete an existing linear feature. Select the feature using Element Selection. 
2. Select all rows of the feature from Survey Detail to confirm. 
3. Right click Delete selected items.  Note: The deletion of Survey Linear Features (and 

Survey Points) can also be done individually using the Heads-up Tools.  

 
Figure 91 
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5.5 Add or Delete Void Regions 
To add or delete a void region, or to change the Terrain Model Attribute, follow the same 
process for Break Lines. At the beginning of this chapter is a listing of Terrain Model Attributes 
and their descriptions that show after clicking the Properties Icon shown below. 
 

 
Figure 92 

  

5.6 Fix Crossing Break Lines 
Crossing break lines can be checked each time individual raw data file are processed. Choose 
the Report Crossing Features tool. 
①Survey> ②Terrain> ③Analysis> ④Reporting 

 
Figure 93 

 
Figure 94 

5.7 Edit Triangles 
In order to edit triangles, etc., the terrain model must be made editable. This is done by 
deactivating survey processing through the Survey tree - not through the OpenRoads 
Model tree. 
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5.7.1 Deactivate Survey Processing 

1. Choose Explorer> Survey> active model (e.g. NAD 83). 
2. Right click the active modelto Deactivate Survey Processing Rules. 

 
Figure 95 
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5.7.2 Edit Triangle Tools  

1. Use Element Selection to select the Terrain Model. 
2. From the ribbon, choose Survey> Terrain> Edit Model, the Edit Terrain Model tools 

appear. 

 
Figure 96 

  
  

3. Edit Terrain Model choices are as follows: 
  

It is recommended that when using Delete Triangle By Line, the user delete the 
outermost segment of the triangle and begin drawing the line from the outside of the 
perimeter inward. 

 
Figure 97 
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5.8 Create Outer Boundary 
1. The displayed boundary is not really an exterior boundary - it’s merely a perimeter.  Select 

the perimeter to highlight and verify it. 

 
Figure 98 

  
2. Create a graphic element to represent current triangulation limits. From 

the Survey workflow, choose Terrain> Boundary Options> Add Boundary. 
  

 
Figure 99 



Volume 4 - OpenRoads Designer Survey 

68 
 

  
  

• Delete Vertex 
• Delete Edge Triangle 
• Swap Line 
• Insert Vertex 
• Move Vertex 
• Delete Triangle By Line 
• Delete Feature 

3. Select the perimeter when prompted to Locate a Terrain Model. 

 
Figure 100 

  
  

4. Keep the default Method of Extract Graphic. 

 
Figure 101 

  
  

5. Click any blank spot in the view to accept the choice. 
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5.9 Import Boundary 
1. Add the newly created graphic to the Field Book.  Reactivate Survey Processing Rules, 

click Yes to confirm. 
  

 
Figure 102 

  
2. Right click All Linear Features to Add Graphic Linear Feature. 

 
Figure 103 
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3. Select the element when prompted Accept it. 
• Ensure that Survey Details is open 
• Expand All Linear Features 
• Scroll to the bottom of the list and click Default 

 
Figure 104 

4. Survey Details refreshes with the new linear feature.  The default Terrain Model Attribute is 
Break Line. Change Break Line to Boundary. 

 
Figure 105 
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Figure 106 

  
5. Rename the Linear Feature if desired. 



Volume 4 - OpenRoads Designer Survey 

72 
 

Exercise 6 - Drawing Production 
Coming Soon 

Skills Taught 
• Coming Soon 

  
 

6.1 Border and Title Block 
Coming Soon 
 

6.2 Annotation 
Coming Soon 
 

6.3 Cells 
Coming Soon 
 

6.4 Additional Line Work 
Coming Soon 
 

6.5 Grids Ticks and Lines 
Coming Soon 
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Exercise 7 - Deliverables 
Coming Soon 

 Skills Taught 
• Create and understand Null Terrain Model usage. 
• Creation of a Complex Terrain Model that can easily accommodate updated / additional 

survey information. 
• Save the Complex Terrain Model for use by Highways. 

  
 

7.1 Create New 3D File 
 

1. Open OpenRoads using the CTDOT WorkSpace and create a new 3D file using the 
CT_SurveySeed.dgn Seed File.  Create the file in the Active_Survey folder for your project. 
 

7.2 Attach Survey Terrain Model as Reference 
 
1. Attach the Existing Terrain Model as a reference to the file you created in the previous 

section. 
2. Select Home > Primary > Attach Tools > References. 
3. Select Tools > Attach, browse to the location of the Existing Terrain Model file and select the 

file with the Existing Survey Terrain Model. 
4. Select Open to attach the Existing Terrain Model DGN to the newly created 3D DGN. 
5. Set Attachment Method as Coincident World. 

 

7.3 Create Delta Terrain Model 
 
1. Go to Terrain> Create > Additional Methods > Create Delta. 
2. The Create Delta Terrain Model dialog will appear, make changes to as 
3. shown below: 

a. Delta Method: Terrain Model to Plane 
b. Feature Definition: Terrain\Existing\Existing Boundary 
c. Name: SV_D2_1234_1234_Null (or similar name for your purposes) 

4. For Locate First Terrain Model prompt Left-click on the outline of the Existing Terrain 
boundary. 

5. Parameters to Plane > 0.000 
Left-click to accept Enter Plane Parameters: To Plane. The Delta Terrain was created. 
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6. Hit <Esc> to Exit Command. 
7. The boundary of the Delta Terrain will be shown. 
 

7.4 Create New 3D File w/ References 
 
1. Select New File to create a 3D file using the CT_SurveySeed.dgn Seed File.  Create the file in 

the Active_Survey folder for your project. 

 
Figure 107 

2. Once inside the new 3D DGN File, select Home > Primary > Attach Tools > References. 
3. Select Tools > Attach, browse to the location of Existing Terrain Model DGN and select the 

DGN containing the Existing Terrain Model. 
4. Set Attachment Method as Coincident World. 
5. Attach Delta Terrain Model reference file. 
6. Select Tools > Attach, browse to the location of the training files and select the file 

containing the Delta Terrain Model. 
7. Select Open to attach the survey terrain file. 
8. Set Attachment Method as Coincident World. 
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7.5 Create Complex Terrain Model 
1. Go to Terrain> Create > Additional Methods > Create Complex Terrain Model. 
2. The Create Complex Terrain Model dialog will appear, This tool will read both the terrain 

attached as highlighted below: 
 

 
 
 
 

3. Left-click on Existing on the left hand pane. 
4. Left-click on Add > button which you can see in between the two panes. 
5. Now Left-click on Delta Terrain Model on the left hand pane. 
6. Select Current Action: Append. 

NOTE: The Append action defines that if the terrain models overlap the data from both 
terrain models is retained.The Merge action will discard data from the Primary terrain and 
only keep the data from the merged terrain. 

 
7. Left-click on Add > button. 

 
8. Set the Terrain Model Properties as shown below: 

a. Feature Definition: Terrain\Existing\Existing Triangles 
b. Name: Existing Ground 
c. Left-click on Finish button at the end. 

 
9. Edit the complex terrain model as desired and add a boundary if preferred. 
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10. When updated or additional survey data is acquired, the following steps will add the new 
survey data to the complex terrain model: 

a.  Process the new survey data into a terrain model as usual. 
b. Reference the new terrain model into the DGN containing the complex terrain model. 
c. Remove the delta terrain model from the complex terrain model. 
d. Add the new terrain model into the complex terrain model using the Merge option. 

 
 

7.6 Export Graphics File 
Coming Soon 

  

7.7 Drainage Requests 
Coming Soon 
Additional 3D Pipe file 
Copy elements into both exported files 
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7.8 Import (SS2 DTMs) 

This process will be used to convert to an OpenRoads terrain from an old DTM SS2 Survey. The 
designer will request that an existing terrain DGN file be created from Survey using the DTM SS2 
file. Survey will use the ORD Create from File tool to convert the existing DTM to a Terrain. In this 
case the delivered survey information will be in two or more files: the ORD Terrain (from the 
DTM) and the V8i Ground File(s) Topo.  Below are the basic steps: 

1. Create a new 3D Design Model to house the existing Terrain. 

2. In the task menu select the OpenRoads Workflow > Terrain > from File. 

3. Browse to the location of the DTM file to import. 

4. The Import Terrain Model(s) dialog will appear, fill out the fields as shown: 
• Feature definition: Terrain/ Existing Ground 
• Import Options: Import Terrain Only 

5. Click Import. 

6. Repeat for 2nd 

7. Create Complex using merge 

8. (3 results: new + 2 originals) Delete originals 

9. Add feature definition for Existing triangles 

10. Save 

 
Reference (ORD) 
Original is Primary, not updated topo.  Be sure to 1st rename these original terrains: 
General>Name & Feature> Feature Name 

• Open Blank file 
• Reference (orig & updated topo) 
• Create Complex Terrain Model 
• Set Current Action to Merge 
• Load & Set Primary (orig) & Merge (Updated Topo) TM info 
• Set Feature Definition (EX_TERR_Ground) 
• Set name (Existing) 
• Finish 
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Note: If an Import Failed error appears, continue with the following DTM procedure.  

a. Open the DTM using an old version of InRoads. 
b. On the InRoads Explorer dialog box open the DTM. 
c. Right click on the DTM and select Properties. 
d. Toggle on Use Extended Data Checks and Lock Triangulation, click Apply and Close. 
e. Right click on the DTM and select Save. 
f. Right click on the DTM and select Properties. 
g. Toggle off Use Extended Data Checks and Lock Triangulation , click Apply and Close. 
h. Right click on the DTM and select Save. Right click on the DTM and select Close. 
i. Repeat Steps 3 & 4.Select Fit View tool and the terrain should appear in the file. 

 

 
Figure 107 Old InRoads DTM Setting 
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Exercise 8 - Best Practices 
Coming Soon 

Skills Taught 
• Best Practices for Reviewing and Editing Survey Data 

  
 

8.1 Checking for Empty Northing, Easting, and/or Elevations 
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