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Course Overview  
In these exercises you will learn how to create horizontal and vertical alignments.  This guide will 
not document each tool that is available on the OpenRoads interface. See the online help for 
commands not detailed in this document. 

OpenRoads Designer CONNECT Edition Help 
 

Skills Taught 
• CTDOT Alignment and Linear Feature Definitions uses 
• Horizontal Centerline Layout 
• Horizontal Alignment Annotation 
• Vertical Profile Creation 
• Driveways 
• Placement of Non-Centerline Geometry 
• Reporting 

These workflows detail the Centerline “Alignment” layout information that should be contained in 
an alignment base model design file. The alignment base model file will reside within the project 
folder structure the ...\Highways\Base_Models folder. Depending on the complexity of the project 
one or more alignment files can be created.  Horizontal alignments and vertical alignments 
(profiles) are stored in the alignment DGN file(s). References files such as survey and terrain files 
are attached without nesting. 

We will also cover other Geometry Feature Definitions “Linear” that are available with the 
workspace and their uses. 

 
Figure 1 – Geometry Feature Definition Folders 

https://docs.bentley.com/LiveContent/web/OpenRoads%20Designer%20CONNECT-v9/en/GUID-1B18BC16-7361-4DA1-BC57-D8A9EEF3F9E7.html
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Exercise 1 - Getting Started 

1.1 Opening the Application 

Before starting this exercise: 
• The CTDOT CONNECT DDE synced through SharePoint 
• The COMPASS Training Project Synced (i.e. 9999-0001 – Design) 

 
 

1. Launch the Application.  On your desktop double click on the Accounting Icon. 

 
Figure 2 - CTDOT CAD Accounting Icon  

2. On the CTDOT Accounting Menu there will be several applications to pick. In the Run 
Program field select the needed program: 

• Compass OpenRoads CE 
• for the Available Account select OVERHEAD for training proposes.  
• Click on the Start button to load the program. 

Notes for working on actual projects: 
1. CTDOT users should have the CTDOT CONNECT DDE synced through SharePoint with 

the COMPASS Project Synced along with the CAD Configuration.  
2. Consultants should have CTDOT DDE properly installed or be syncing to the CTDOT 

DDE SharePoint/COMPASS system. 
3. Make note of the Coordinate System you will be working in. If you have existing 

survey data, you will need to find out what system is being used (NAD 83/NAVD 88 or 
NAD 27/NAVD 29).  

4. Log on to the CONNECTION Client. Bentley Connect licensing requires users to log into 
their Bentley account to secure a software license. CTDOT users should log in using 
your CTDOT email address and Bentley password. If you do not see the dialog 
box, select the ˄ icon on the bottom Windows Screen. Click on the Connection Client 
Icon and select Open. 
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Figure 3 - CTDOT CAD Account Dialog Box 

3. After launching the program, a Welcome Screen for OpenRoads Designer will appear.  

4. Ensure you are using the Custom Configuration and CT_WorkSpace, then select the 
relevant WorkSet (Training WorkSets start with 9999_0001, select the # that you were 
assigned) and Role.  

5. Select the Browse icon, browse to: 

Highway/Base_Models/HW_CB_0047_0122_ Exercise_1_Alignments.dgn 

 
Figure 4 – OpenRoads Start up Screen 
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6. In the upper left select the OpenRoads Modeling Workflow, and click on the Geometry tab. 

The Geometry Ribbon contains tools that the designer will use to create Horizontal and  
Vertical Geometry and plan elements that are based on Civil Geometry. The OpenRoads 
Geometry commands are selected from the Geometry tab of the OpenRoads 
Modeling workflow. The commands are separated into four main categories: 

• General Tools 
• Horizontal 
• Vertical 
• Common Tools 

 

 
Figure 5 – Geometry Tools 
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1.2 Geometry Feature Definitions 
1. Click on Lines > Lines Between Points 

 
Figure 6 – Geometry Tool Line Between Points 

2. Notice the two folders: 

Alignment – Used for Centerlines and can be annotated with Stationing, PI, PC, PT, Bearing, 
and Curve Data. 

Linear – Typically used for offset Control Lines, XSC Cross Points, Template Breaklines, and 
Pay Items. 

 
Figure 7 - Geometry Feature Definition Folders 
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1.2.1 Alignment Feature Definitions 

 

1.2.1.1 Center Alignment 
Below are the Feature Definitions that will be used to lay out Centerlines: 

Used in an Alignment type design file: HW_CB_1234_1234_Alignments.dgn 

Feature Definition Annotation Group Description 

Alignment\Center CL_Centerline Stationing will be every 50ft. 

Alignment\Centerline – Green CL_Centerline Stationing will be every 50ft. 

Alignment\Centerline – Pink CL_Centerline Stationing will be every 50ft. 

Alignment\Centerline – Small Blue Small CL_Centerline stationing will be every 10 ft. 

Alignment\Driveway Driveway Stationing stationing will be every 10 ft. 

Alignment\Existing Baseline BL_Stationing Stationing will be every 50ft. 

Alignment\Segment – Curve N\A None 

Alignment\ Segment - Line N\A None 

 
Note: When annotating alignments the option to override the assigned Annotation Group 
can be selected. This will be discussed in Exercise 6, there is an annotation group Named 
CL_Centerline Flip that can be used to annotate Right to Left allignments 
 

1.2.1.2 Other Alignments 
These Centerline Feature Definitions are used by other units: 

• Survey  - Alignment\Existing Survey\e_GEOM__BL  
• Hydraulics and Drainage - Alignment\Water Courses\.... 

 
The Preliminary Planning Feature Definitions may be used during scoping, these definitions 
come with  a two lane roadway template already attached: 

• Alignment\Preliminary Planning\2 Lane 
• Alignment\Preliminary Planning\2 Lane BCPC 
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1.2.2 Linear Feature Definitions - Roadway Geometry 

Below are listings of other Feature Definitions available when using the Geometry Tools. 

1.2.2.1 Control Lines 

These Feature Definitions are used as Point Controls for Corridors, Linear and Surface 
Templates. e.g., The Edge of Roadway feature definitions is used to increase or decrease 
the shoulder width. 

Used in a Corridor type design file: HW_CB_1234_1234_Corridor_Route123.dgn 

Feature Definition Additional Information 

Roadway Geometry\Channel Line   

Roadway Geometry\Curb Cut   

Roadway Geometry\Driveway Match Line   

Roadway Geometry\Driveway Ramp Back Line   

Roadway Geometry\Edge of Pavement Line   

Roadway Geometry\Edge of Road Line   

Roadway Geometry\Edge of Truck Apron Line   

Roadway Geometry\Island Curb Line   

Roadway Geometry\Misc Line   

Roadway Geometry\Misc Point Control Line – blue   

Roadway Geometry\Misc Point Control Line – green   

Roadway Geometry\Misc Point Control Line – pink   

Roadway Geometry\Processed Aggregate Perimeter  

Roadway Geometry\Riprap Perimeter  

Roadway Geometry\Seam Line   

Roadway Geometry\Shoulder Line   

Roadway Geometry\Sidewalk Line   

Roadway Geometry\Slope Limit Cut   

Roadway Geometry\Slope Limit Fill   

Roadway Geometry\Slope Limit Line   

Roadway Geometry\Travelway Line   

Roadway Geometry\Yellow Line   
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1.2.2.2 Structure Outlines 
These Feature Definitions are used to Trace over Proposed Structures you may need to tie 
into. 

Used in a Corridor type design file: HW_CB_1234_1234_Corridor_Route123.dgn 

Feature Definition Additional Information 

Structure Outlines\Bridge   

Structure Outlines\Building   

Structure Outlines\Wall   

 

1.2.2.3 Imported Existing 
These Feature Definitions are used to trace over existing feature you would like to see 
annotated on Cross Section Sheets 

Used in the design file: HW_CB_1234_1234_CrossingFeatures_Existing.dgn 

Feature Definition 
XSC Crossing Point 
Annotation 

Imported Existing\Existing BCLC EX. BCLC 

Imported Existing\Existing BCPC EX. BCPC 

Imported Existing\Existing Building EX.  BUILDING 

Imported Existing\Existing Concrete Curb EX CONC. CURB 

Imported Existing\Existing Edge of Road EX. EOR 

Imported Existing\Existing Fence EX FENCE 

Imported Existing\Existing Granite Curb EX. GRANITE CURB 

Imported Existing\Existing Granite Sloped Curb EX GRANITE SLOPED CURB 

Imported Existing\Existing Noise Wall EX. NOISE WALL 

Imported Existing\Existing Road CL EX. CL 

Imported Existing\Existing Stone Wall EX. STONE WLL REMAINS 

Imported Existing\Existing Walk EX. WALK 

Imported Existing\Existing Water Edge EX. WATER EDGE 

Imported Existing\Existing Wetland Limit WETLAND LIMIT 
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1.2.2.4 Existing Right of Way 
These Feature Definitions are used to trace over existing ROW lines you would like to tie in 
to and/or see annotated on Cross Section Sheets. 

Used in the design file: HW_CB_1234_1234_CrossingFeatures_Existing.dgn 

Feature Definition 
XSC Crossing Point 
Annotation 

Right of Way\Existing\Directional N/A 

Right of Way\Existing\Easement Line EX. EASEMENT 

Right of Way\Existing\Interior Non-Access Highway Line EX. HIGHWAY LINE 

Right of Way\Existing\Lease Line N/A 

Right of Way\Existing\Location Survey Highway Line EX. HIGHWAY LINE 

Right of Way\Existing\Lot Line N/A 

Right of Way\Existing\Non-Access Highway Line EX. HIGHWAY LINE 

Right of Way\Existing\Property Line N/A 

Right of Way\Existing\Railroad N/A 

Right of Way\Existing\Release Line N/A 

Right of Way\Existing\State Line N/A 

Right of Way\Existing\Street Line EX. STREET LINE 

Right of Way\Existing\Town Line N/A 

Right of Way\Existing\Unlimited Access Highway Line EX. HIGHWAY LINE 
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1.2.2.5 Proposed Right of Way 
These Feature Definitions are used to place ROW lines you would like to tie in to and/or 
see annotated on Cross Section Sheets. 

Used in the design file: HW_CB_1234_1234_ROW_Proposed.dgn 

Feature Definition 
XSC Crossing Point 
Annotation 

Right of Way\Proposed\Acquisition Line ACQUISITION LINE 

Right of Way\Proposed\Defined Easement Line EASEMENT LINE 

Right of Way\Proposed\DROW Line N/A 

Right of Way\Proposed\Lease Line N/A 

Right of Way\Proposed \Minimum ROW Line N/A 

Right of Way\Proposed\Release Line N/A 

Right of Way\Proposed\Slope Easement N/A 

Right of Way\Proposed\Temporary Work Area Line N/A 

 

1.2.2.6 Watercourses  
These Feature Definitions are used to place water lines you would like to see annotated 
on Cross Section Sheets. 

Used in the design file: HW_CB_1234_1234_CrossingFeatures_Existing.dgn 

Feature Definition 
XSC Crossing Point 
Annotation 

Watercourses\100 Yr Flood 100 YR FLOOD PLAIN 

Watercourses\500 Yr Flood 500 YR FLOOD PLAIN 

Watercourses\High Tide Line HTL 

Watercourses\High Water Line MHW 

Watercourses\Low Water Line MLW 

Watercourses\Ordinary High Water Line OHW 

Watercourses\SCEL S.C.E.L. 

Watercourses\Wetland (Approx) WETLAND LIMIT 
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1.2.1 Linear Feature Definitions - Roadway 2D Pay Items 

These Feature Definitions are used to Place Pay Items in the 2D Master DGN file to assist 
in quantity calculations and call outs. 

Used in the design file: HW_CB_1234_1234_Master_2D_Design.dgn 

 
Figure 8 – Guiderail Pay Items 
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1.2.2 Other Linear Feature Definitions 

These Feature Definitions in the remaining folders are for use in other tools available in the 
application of by other units: 

• Roadway Modeling – used to build Roadway, Liners and Surface Template breakline 
features. 

• Survey Boundary 
• Survey Planimetrics 
• Survey Rules Boundary 
• Subsurface Utilities 
• Site Design 
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1.3 Reference Files 

1. Open the Reference dialog box, notice the following files are attached using no nesting: 
• SV_D1_047_0122_ORD.dgn 
• 4710503.grn 
• 4710504.grn 
• 4710505.grn 

2. Review the files.  

 
Figure 9 - References 
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Exercise 2 – Horizontal Alignment Segments 
This workflow covers the process of creating featured horizontal alignment segments using 
OpenRoads Designer. The alignment segments will be created using the draft lines provided in the 
dataset. In this exercise we will construct featurized tangents and arcs to be used to create a 
Complex Centerline in Exercise 3.  

2.1 MicroStation Construction Lines 

This DGN file contains MicroStation draft lines of the PI Points, Tangents and Curves for the 
alignment. These elements were created using Construction type Element Templates. This 
ensures that construction lines will not be plotted if the design is printed. Below are the steps 
one can take to draw draft lines for project needs, for proposes of this class these elements 
have already been created. 

1. Select File > Open, browse to Highway/Base_Models, select HW_CB_0047_0122_ 
Exercise_2_Alignments.dgn 

2. Go to the CTDOT workflow, in the Attributes group, right click and enable Element Class to 
be displayed on the menu. 

 
Figure 10 – Show Element Class 
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3. Navigate to the element Template Roadway Alignments >  
Center > Centerline – Draft Reference Lines. This will 
trigger the active level and Element Class to update.  

 

 

 

 

 

Notice the change of the class from Primary to 
Construction and the Level is set to Tool_CL_Layout. 

 
Figure 12 – Set to Construction Class 

 
4. The circles were created using the Place Circle tool (CTDOT > Home > Placement > Place 

Circle pull down) with the following parameters: 
Method: Center 
Area: Solid 
Fill Type: None 
Toggle on: Diameter and set to 5 
Follow the Prompts to place the circles. 

 
Figure 13 – Place Circle Tool 

Figure 11 – Set Element 
Template 
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Figure 14 – Place Circle dialog box 

3. Place MicroStation Arcs Between MicroStation Tangents. Begin laying arcs between the 
tangents using the Place Arc tool (CTDOT > Home > Placement > Place Arc Tools pull down) 
with the Start, End, and Mid method. 

• Activate the Tangent Snap by double-clicking it. 
• Click on the tangent behind the arc and then the tangent ahead of the arc. 
• Select CW (clockwise) or CCW (counterclockwise) based on the curve’s direction. 
• Aim for whole-number radii for consistency. In this case, use the predefined radii. 

 
Figure 15 – Place Arc tool 
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Figure 16 – Place Arc dialog box 

 
Curve Number Radius (ft) Length (ft) 

Curve 1 1090 - 
Curve 2 750 - 

Curve 3 (PCC-1) 1151 342.500 
Curve 3 (PCC-2) 1055 516.493 

Curve 4 510 - 
Curve 5 510 - 
Curve 6 1000 - 
Curve 7 2500  - 
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2.2 Existing Terrain Setup and Activation 

1. Select the Existing Ground and ensure it is set as Active. 

2. The terrain can be set active or cleared by hovering over the boundary and from the pop-
up menu selecting the Set Terrain Active or Clear Active. If the Terrain is not active, please 
set it active at this time. 

 
Figure 17 – Set As Active Terrain Model 

3. Click on the terrain boundary and select the “I” 
Information tool. In the popup dialog set the override 
symbology to Yes. Then to help with the horizontal 
alignment creation, you can turn on or off the 
Contours or Triangles as needed. 

 

Figure 18 - Override Symbology 
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2.3 Feature Definitions Toolbar 

Feature Definitions are included in the CTDOT workspace. They are used to control symbology, 
and various other properties that are applied to the geometric elements.  

The feature definitions are used to: 
• Define what the geometric elements actually are. What is being modeled such as curb, 

centerline, edge of pavement, etcetera. 

• Control symbology in various views, including capability to define differing symbology in 
plan, profile, and 3D spaces 

• Define terrain modeling attributes (spot, break line, void, etcetera) 

• Define surface display characteristics annotation 

The Feature Definition Toolbar is a way to easily activate and deactivate the Feature Definition 
settings. Using the Feature Definition Toolbar is not a requirement, but most users will find it 
helpful. It is important to choose the correct Feature Definition when placing elements in the 
design because that Feature Definition will control the properties not only of that element 
during that step but also how it looks and interacts with other design elements in later steps 
during the design process. 

For this section it is only important that the user has gained some basic familiarity with the 
toolbar, the names of the icons and a general sense of how each tool will work. Through use 
and practice the user will quickly understand the best practice for using each of the tools. 

1. If your Feature Definition toolbar is not opened, select the OpenRoads Modeling workflow, 
on the Geometry tab in the General tools section open the Feature Definition Tool Bar. 
After it opens dock the toolbar just below the ribbon. 

 
Figure 19 – Open Feature Definition Tool Bar 
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2. From the Feature Definition Toolbar: 

• select the active Feature Definition, Alignment > Center > Segment – Line 

• Toggle on the first icon to automatically assign the selected feature as the active 
feature as you use various OpenRoads Geometry commands: Use Active Feature 
Definition 

• Deactivate the Chain Command, (If Chain is Activated when placing geometry lines 
then the curser snaps to the last data point but the end and beginning of the line will 
not be ruled to each other.  It is better practice to manually snap as needed. 

 
Figure 20 – Set Feature Definition 

What does Use Active Feature Definition do?  

Selecting the Override Feature Definition icon will force the active tool to use the Feature 
Definition shown in the Feature Definition Toggle Bar. The user will not have to select the 
feature definition when placing the element 

In this example, the Line Between Points command is 
selected. The Feature Definition is defined by the active 
feature (ON) selected in the Feature Definition Toggle 
Bar. Notice the Feature Definitions selection is locked 
out 

 
 

 
 
 
 

Figure 21 – Enter Feature Name 
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In this example, the Line Between Points command is selected. 
The Feature Definition is not defined by the active feature (OFF) 
selected in the Feature Definition Toggle Bar. Notice the Feature 
Definition must be manually selected. 

 
 

 
 
 
 
What do the tools on the right of the Feature Definition selection do? 

 
Figure 23 – other Active Feature Definition tools  

Match Feature 

• Use the Match Feature Definition tool to populate the combo box with the feature definition 
assigned to the selected element. 

• This tool will allow the user to match the Feature Definition of an element in the dgn file and 
if the Override Feature Definition tool is selected then the Feature Definition will be applied 
to the current element being placed. 

Create 3D Automatically 

• The Create 3D Automatically tool will generate 3D model elements for the created 
elements. This tool will be covered in more detail in the Modeling sections and is not used 
for creating Horizontal Alignments. 

Feature Definition Template 

• The Feature Definition Template tool will apply a roadway template to the created element 
automatically. This tool will be covered in more detail in the Modeling sections and is not 
used for creating Horizontal Alignments. 

Chain Tools 

• If Tool Chaining is toggled on, then many tools can automatically determine base elements 
to use during calculations. For example, Arc Between Elements will choose the two most 
recent elements and set them for base elements to construct its fillet 

• If you use chain and move a point it will only move one line and not both. 

Figure 22 - Enter Feature Name 



Volume 3.1 - OpenRoads Designer Alignments 

25 
 

 
Figure 24 – Snapping Options 

Persist Snap 

• If Persist Snap toggled on, persists the snap into the geometry (default is snap on). 

• A persisted snap is a geometric rule that can be stored with the elements. For example 
when placing a line between two points if the user snaps to the mid point of an arc as the 
starting point a rule is created. If the length of the arc changes, and the midpoint shifts, 
then the beginning of the line will shift to remain at the mid point of the arc. This is because 
the Midpoint Snap has be Persisted. 

Rule Deactivation 

• If Rule Deactivation is toggled on, then tools create elements with rules disabled. Snaps are 
not the only type of rules that are created when placing civil elements. Civil rules include 
any geometric constraint that could define the position of the element. Offset from another 
element, taper rate based on another element, length, bearing, radius, skew angle, etc 
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2.4 Horizonal Alignment Segments 
In the following exercises you will learn how to use the various line tools to create ruled 
elements. The purpose of the exercise to become familiar with the tool and how to use it. ORD  
offers the user a significant amount of flexibility when placing ruled geometry. 

1. Go to the OpenRoads Modeling workflow, in the Attributes Group, right click and enable 
Element Class to be displayed on the menu.  Change the Element Class to Primary.  

2. We will now place line segments. Ensure the correct Feature Definition is active. Drop down 
on the Feature Definition Toolbar select Alignment > Center > Segment-Line. Set the 
feature definition ACTIVE. 

 
Figure 25 - Set Feature Definition 
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3. Let’s now explore the Horizontal section and become familiar with the available tools. 

 
Figure 26 – Geometry Tools 

 

Lines 

 

Various line placement tool (By Points, To Elements, From 
Elements, Between Arcs, and Chamfers). 

 

Arcs 

 

Various arc placement tools (By Points, To Elements, From 
Elements, Between Arc, 2 Center and 3 Center and Complex 
Transitions). 

 

Modify 

 

Stationing, Station Equations, working with Civil rules and 
copying civil elements. 

Complex Geometry 

 

Creating and redefining Complex alignments, Best Fit, Offset 
tool (copy parallel) reverse curves, and Create Geometry by 
Template. 
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4. There are also tools in the Common Tools group that are helpful. 

 
Figure 27 – Other Common Geometry tools 

 
Transform Tools Allows you to translate, rotate and scale an element. 

Simplify Geometry  
Allows you removal of intervals and external referencing rules 
for horizontal and vertical geometries. 

Complex Redefine 
Allows you to redefine an existing complex alignment partially 
replaced by new geometry. 

Table Editor Allows you to edit table. 
Event List Allows you to create event point list. 
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2.4.1 Placing Lines 

1. We will now move on to creating geometry. Go to Geometry, drop down on Lines > Line 
Between Points.  

 
Figure 28 – Line Between Points 

2. Use this tool to layout the tangents.  Place tangents sequentially, selecting the as 
follows: 
Line 1:  
Name - CL_Route140_T1  

Note: To streamline naming, copy the name of the 
first tangent and paste it for subsequent tangents, 
updating only the number at the end. There are a 
total of 8 tangents in this alignment. 

Point 1 – Snap to center of first circle 
Point 2 - Snap to center of second circle 

 
 

 

 
Figure 30 - Place Linear Features 

Figure 29 – Enter Feature Name 
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Line 2:  
Name - CL_Route140_T2 
Point 1 – Snap end point of the first ORD Line 
Point 2 - Snap to center of third circle 

 
Figure 31 - Place Linear Features 

Continue creating lines until the end and snap to the last Circle. 

 
Figure 32 - Place Linear Features 
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2.4.2 Placing Curves 

1. Now place the curves, in the drop down on the Feature Definition Toolbar select 
Alignment > Center > Segment-Curve. Set the feature definition ACTIVE. 

 
Figure 33 - Set Feature Definition 

2. Go to the Geometry Tab > Horizontal Group, drop down on Arcs > Arcs Between 
Elements > Simple Arc. Use this tool to layout the curves. 

 
Figure 34 - Simple Arc 

Curve Number Feature Name Radius (ft) Length (ft) 
Curve 1 CL_Route140_C1 1090 - 
Curve 2 CL_Route140_C2 750 - 

Curve 3 (PCC-1) CL_Route140_C3 1151 342.500 
Curve 3 (PCC-2) CL_Route140_C3 1055 516.493 

Curve 4 CL_Route140_C4 510 - 
Curve 5 CL_Route140_C5 510 - 
Curve 6 CL_Route140_C6 1000 - 
Curve 7 CL_Route140_C7 2500  - 
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3. When you get to the Compound Curve. Use the 2 Center Arc tool. Set the parameters as 
shown in the image below to have it lay over the orange draft lines. Name this curve 
CL_Route140_C3. 

 
Figure 35 – 3 Center Arc 

Enter the top Section:  
Trim Extend: Both  PCC-2: Radius: 1055 
 
Enter the Bottom Section: 
Type: Curve   Method: Length 
Length: 342.500  PCC-1: Radius: 1151  
 
Name: CL_Route140_C3 

 
Figure 36 – Compound Curve 
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4. Review the element names by using the Select Element tool and floating the cursor over 
the element as shown below (you do not need to select the element). 

 
Figure 37 – Hover over element 

The Feature Definition and Feature Name for a selected element can be edited in the 
Properties dialog as shown below. 

  
Figure 38 – Edit feature in Properties dialog 
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Exercise 3  - Horizontal Alignment Centerlines 
This workflow covers the process of creating a featured horizontal centerline alignment using 
OpenRoads Designer. This will be complexed alignment segment created using the featurized 
tangents and arcs created in Exercise 1.  

3.1 Create a Horizontal Alignment from Geometry Segments 

1. Select File > Open, browse to Highway/Base_Models, select HW_CB_0047_0122_ 
Exercise_3_Alignments.dgn 

2. Go to level manager and turn off all levels except TOOL_CL_Layout (Tool: Centerline 
layout out reference Lines), turn display off for all references, and delete the draft lines if 
you want. 

3. Now turn all the Levels and Reference Displays back on. 

4. On the Feature Definitions Toolbar set the Feature Definition to Alignment > Center > 
Centerline.  

5. Individual civil geometry elements are connected together as a single entity using 
the Complex By Element command.  Select Geometry Tab > Horizontal Group > Complex 
Geometry dropdown > Complex By Element  to access the command.  

6. Use the Complex by Element Tool to connect all tangents and arcs into a single alignment. 
Name the final alignment CL_Route140. This tool is very similar to the create complex chain 
dialog form MicroStation. There is a manual and an automatic option with a maximum gap. 

7. Manually click the tangents and arcs from left to right, hover over the line, once arrow 
placement is towards the desired direction (forward arrow), click on the element and so on.   

 
Figure 39 – Complex by Element tool 
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In the example above, the Feature Definition is set to Use Active Feature as defined in 
the Feature Definition Toggle Bar.  

When the Method is set to Automatic, the software will automatically select elements to 
make up the complex geometry by searching for elements with endpoints that connect 
within the Maximum Gap value. If a fork is found, where two elements are found within 
the Maximum Gap tolerance, the user is prompted to identify which path to accept to 
compete the operation. 

Be sure to enter a Name for the geometry. 

When locating the starting element an arrow is displayed defining the direction to store the 
element. Complex elements can be stored in the opposite direction than they were 
originally defined by selecting the other end of the graphics.  

 
Figure 40 – Alignment direction arrow 

Note: There are other Centerline feature definitions available for complex designs needing 
to be differentiated by color. 

 
Figure 41 – Center Line Features 
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3.2 Define Start Station for Horizontal Alignment 
When an OpenRoads alignment is stored, the software assumes a beginning station value of 
0+00. The station can be redefined by use of the Start Station command.  The Start 
Station assigns stationing to an element. A station value and a position along the element for 
that station value are assigned. If no station value is assigned, then the beginning station is 
assumed to be zero (0+00.00).   

The command has two parameters: 
• Start Distance The distance along the alignment to assign the Start Station. The 

beginning station is computed based on the Start Distance and the Start Station value. 

• Start Station The station value to be assigned at the Start Distance location. 

1. In the Horizontal toolbar click on the Modify tools – 
select the Start Station tool. 

2. Follow the prompts: Locate Element, select the 
beginning of the alignment. Start Station Position, enter 
0.00 as Start Distance. Enter Starting Station, enter Start 
Station 100+00.00 and click within the view. 

3. Click on the alignment, it will now display the start 
station and the offset. Make sure the entire alignment is 
highlighted, not just a segment of the alignment. 

NOTE: Any changes to the alignment will also update 
the Stationing. 

 

 
Figure 43 – Start station applied 

Figure 42 – Start Station tool 
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3.3  Station Equations 
The station parameters can be edited by selecting the rule in the design file, or from the 
Properties dialog. Add Station Equation - The Add Station Equation command, located below 
the Start Station command, adds parameters for the Ahead Station and Back Station. 
When the command is selected, the user is prompted to select the alignment to assign the 
station equation. 

After the alignment has been selected, the location of the equation can be identified 
graphically, or by keying in the Back Station value. 

 
Figure 44 – Start Equation tool 

The ahead station is stored as a “region” much like the legacy GEOPAK format. When 
the Ahead Station value is entered, it is not necessary to define the region number. 

 
Figure 45 – Start Station applied to alignment 

The station equation value can be reviewed and edited by selecting the element as shown 
below. The parameters can also be edited in the Properties dialog. 
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Exercise 4 - Horizontal Alignment Annotation 
When geometric alignments are placed in the file, the annotation is not automatically generated 
by the software. The user must identify the alignments that are to be annotated either individually, 
by selecting the specific alignments, or by annotating all of the alignments contained in the active 
model, or all models in the active file. 

Annotation commands are selected from the OpenRoads Modeling WorkFlow in the Drawing 
Production tab, as shown below. 

 
Figure 46 – Drawing Production tab 

The Annotate Element command is used to annotate one of more 
selected elements. The command prompts to select the OpenRoads 
element to be annotated. Multiple elements can be selected. Reset 
(right-click) to complete the selection process and initiate the 
annotation placement.  An example of annotation at the beginning 
of an alignment is shown below. 
 

 
Figure 48 – Alignment with station annotation  

Figure 47 – Tool Dialog 
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The Remove Element Annotations command is used to remove the annotation from selected 
elements. When prompted, select the elements to remove the annotation. Reset (right-click) to 
end the selection process and initiate the removal process. 

The Model Annotation command us used to annotate all of the elements in the active model, or 
all models, by selecting a specific Annotation Group. Two options are available as shown below. 

 
Figure 49 – Annotate Model and Remove Model Annotations options 

ANNOTATE MODEL - Select this command to annotate all the elements in a model, or in all 
models, by selecting a specific Annotation Group. When the command is selected, the user is 
prompted as shown below. Issue a data point (left mouse-click) to initiate the process. 

 
Figure 50 – Annotate Model prompt 

  
REMOVE MODEL ANNOTATIONS - Select this command to remove all annotations from the active 
model or all models in the active file. 
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4.1 Annotation Groups 
The following Centerlines have annotation set up to display: 

Feature Definition Annotation Group Description 

Alignment\Center CL_Centerline 
Stationing will 
be every 50ft. 

Alignment\Centerline – Green CL_Centerline 
Stationing will 
be every 50ft. 

Alignment\Centerline – Pink CL_Centerline 
Stationing will 
be every 50ft. 

Alignment\Centerline – Small Blue Small CL_Centerline 
stationing will 
be every 10 ft. 

Alignment\Driveway Driveway Stationing 
stationing will 
be every 10 ft. 

Alignment\Existing Baseline BL_Stationing 
Stationing will 
be every 50ft. 

Alignment\Segment – Curve N\A None 

Alignment\ Segment - Line N\A None 

 

These folders are for use by other Units: 
o Alignment\Existing Survey – for the Survey Unit 
o Alignment\Water Courses – for Hydraulics and Drainage 

The Preliminary Planning Folder has two feature definitions, these are set to Annotate as well as 
automatically place a Roadway Template down the Center. 

 
Note:  

• Segment – Curve and Segment - Line do not have an annotation Group set up and are 
not to be annotated. 

• When annotating alignments the option to override the assigned Annotation Group can 
be selected. This is useful when an alignment runs opposite on right to left. In this case 
the CL Stationing Flip Annotation group should be used.  

 
Figure 52 Override Annotation Group 

Figure 51 – Centerline 
Feature Definition 
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Figure 53 – Centerline Annotation (Left to Right) 

 
Figure 54 – Centerline – Using the Flip Annotation Group (Right to Left) 
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Figure 55 – Centerline – Pink Annotation 

 

 
Figure 56 – Centerline – Green Annotation 



Volume 3.1 - OpenRoads Designer Alignments 

43 
 

 
Figure 57 – Centerline – Small Blue 

 

 
Figure 58 – Driveway Annotation 

 
Figure 59 - Existing Baseline Annotation 
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4.2 Annotate an Alignment 

A Horizontal Alignment needs the following annotation: 
• Stationing 
• PC – Station, Northing, and Easting 
• PI – Station, Northing, and Easting 
• PT – Station, Northing, and Easting  
• Curve Data 

o PI - Station, Northing, and Easting 
o Delta Angle with Direction 
o Radius Length 
o Curve Length 
o Tangent Length 
o Degree of Curve 

• Tangent Bearings 
• Tangent Lengths 

This has been automated; the is information will be displayed in the Alignment Design file by 
using OpenRoads tools. Some adjustments to location of alignment annotation can be made, 
if they overlap each other or other element.  

1. Select File > Open, browse to Highway/Base_Models, select HW_CB_0047_0122_ 
Exercise_4_Alignments.dgn. 

2. Select the OpenRoads Modeling workflow or the OpenRoads Drawing Production workflow. 

3. Click the Annotate Element tool. 

 
Figure 60 - Annotate Element tool 

4. Select the alignment CL_Route140, follow the prompts to display the Annotation, right-click 
to Reset. 
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5. Notice each alignment is now annotated/labeled.  

 
Figure 61 – Annotated Alignment 
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Exercise 5 – Mainline Profile 
Select File > Open, browse to Highway/Base_Models, select HW_CB_0047_0122_ 
Exercise_5_Alignments.dgn 

In this module the creation of a vertical alignment (proposed profile) with the PI method will be 
described. There are several methods to create vertical alignments for more on other methods or 
other alignment tools please see the Bentley's OpenRoads Help – Vertical Geometry. 

OpenRoads Designer stores vertical alignments as a component of the horizontal alignment in the 
same design file as the horizontal geometry. This is true for both existing vertical alignments, 
which are extracted from an OpenRoads Terrain Model, and proposed vertical alignments. 

Although the vertical geometry is stored in the design file, the graphical display of the vertical 
alignment information is not plotted in the design file. Vertical alignments are displayed in a 
profile window for review and editing. 

Vertical geometry tools are accessed from the Geometry tab of the OpenRoads 
Modeling workflow, as shown below. 

 
Figure 62 – Ribbon Access to Vertical geometry tools 

 
Commonly used Vertical Alignment Tools 

 
Figure 63 - Vertical Alignment Tools 

When Complete Set the Vertical Alignment Active. 
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5.1 Getting Familiar with Profiles 

5.1.1 Profile Settings 

The Design File settings contain parameters for formats as you work with vertical 
alignments. Select File > Settings > File > Design File Settings and then click the Civil 
Formatting item from the list on the left of the dialog. The Profile Settings are set to the 
values shown below in the CTDOT seed files. 

 
Figure 64 – Profile settings in Design File 
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5.1.2 Existing Ground Profiles 

Existing ground profiles are extracted along the selected civil geometry element from the 
active terrain model. The active terrain model is set by selecting the terrain element and 
choosing the Set As Active Terrain Model icon as shown below. 

 
Figure 65 – Set active terrain model 

To extract the existing profile, select the alignment graphics and let the cursor rest on the 
graphic element until the pop-up menu appears. Choose the Open Profile Model icon as 
shown below. 

 
Figure 66 – Open Profile Model 

You are prompted to select or open a view window to use for the profile display. Open a 
new view window and then left click in the view window to display the profile. An example 
is shown below. 

 
Figure 67 – Profile view with existing ground 

Note: The profile is displayed in the profile view for review and editing; however, the profile 
is not written to the design file. The selected view window is used as a temporary display of 
all the profiles associated with the selected alignment. The selected view window is not 
specifically associated with an alignment/profile and can be used to display the profiles 
from different geometric alignments as needed. 
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5.1.3 Profile Feature Definitions 

The symbology of vertical geometry is defined by Feature Definitions; however, the feature 
definition for profiles is not assigned by the user. Feature definitions for vertical alignments 
are defined as follows: 

• Existing vertical alignments inherit their display parameters from the feature 
definition that has been assigned to the terrain model that was used to extract the 
profile. 

• Proposed vertical alignments inherit their display parameters from the feature 
definition that has been assigned to the horizontal geometry that the vertical 
geometry is associated with. 

To help differentiate between the tangent lines and vertical curves, proposed profiles are 
defined to display the vertical curves with color 20, and tangent lines with color 1. 

 
Figure 68 - Proposed vertical profile with color coding 
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5.2 Creating Vertical Alignments 

5.2.1 Setup 

1. Assure the Existing Terrain is Active. 

2. Now, we will set up the Views. Right click in View 1, Default and select View Control > 3 
Views Plan/Profile/3D. 

3. Follow the prompts to view the mainline Profile.  In the horizontal view (View 1, Default) 
select the Centerline (the horizontal alignment previously created) in Exercise 3 

 
Figure 69 – 3-view Plan/Profile/3D Layout 

4. If not already docked, from the Geometry ribbon select the General Tools tool and 
select and dock the Design Standards Toolbar and the Feature Definition Toolbar.  

5. From the Feature Definition Toolbar: select the active feature definition for Alignment > 
Center > Segment - Line and Lock the feature definition. 
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5.2.2 Place Tangent Segments 

1. From the Vertical tool group select the Lines – Profile Line Between Points tool. 

 
Figure 70 – Profile Line Between Points tool 

2. In the Line toolbox, the Feature Definition should be set to: Use Active Feature, this 
should be greyed out, and it will set the feature tangent line to the active feature 
definition picked in the previous step. 

Name: CL_Route140_T1 

 
Figure 71 – Name first profile line segment 

Good Practice Tips : Name the lines and curves similar to horizontal alignments, PVI 
stations should be multiples of 5, Parabolic Curves have even length like 100, 500, etc, 
Check town standards and Highway Design Manual for slope min and max.   
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3. In "View 3, Profile – CL_Route140” select the first PI location.  Use the Near Point Snap 
on the green dashed existing ground line to where you would the begin of the existing 
profile (around station 107+50, near the first orange line) 

  
Figure 72 – Start Vertical 

4. Move the courser to pick the next PI points and pick the next orange Dot. Follow the 
prompts to accept. 

 
Figure 73 – Second Point 

5. Delete the first orange Dot. 

6. Use the Lines – Profile Line Between Points tool again and place the second tangent by 
snaping on the first line and then the next orange Dot. 

7. Repeat steps 5 and 6 until the end, the end of the last line should be snapped back to 
the existing ground (use Near Point Snap). 

  
Figure 74 – End Profile 
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5.2.3 Place Vertical Curve Segments 

1. Next the vertical curves will be placed. From the Feature Definition Toolbar: select 
the active feature definition for Alignment > Center > Segment - Curve and Lock the 
feature definition. 

2. Select the Curves – Profile Curve Between Elements – Parabola Between 
Elements tool. Follow the prompts.   

• Locate First Profile Element – click on the first tangent 
• Locate Second Profile Element – click on the second tangent 
• Define the curve by entering the length, L =100 (feet) 
• Accept (left-click) 
• Trim/Extend use the arrow keys to go to Both, Tab key 
• Accept (left-click). 

 
Figure 75 – Profile Curve Between Elements Tool 

3. Repeat these steps for the next curve, using these inputs: 

Length Name 
110 CL_Route140_C1 
350 CL_Route140_C2 
250 CL_Route140_C3 
210 CL_Route140_C4 
450 CL_Route140_C5 
500 CL_Route140_C6 
200 CL_Route140_C7 
200 CL_Route140_C8 
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4. Review the vertical alignment (proposed profile). Make adjustments if 
needed.  Using the Element Selection tool click on the first tangent, depending on 
the rules (relationships) with which the tangent was placed Length, Slope, Station 
and Elevation can be changed. The Length of Curve can be adjusted. 
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5.2.4 Create a Complex Vertical Alignment 

1. Complex the vertical alignment, select Complex Geometry – Profile Complex By 
Elements. From the Feature Definition Toolbar: select the active feature 
definition for Alignment > Center > Centerline and Lock the feature definition. 

2. Set the following: Method to Automatic, Maximum Gap to 0.033. Feature 
Definition: Use Active Feature (greyed out – Feature Definition locked 
previously), Name: enter the alignment name – example: CL_Rt140. Follow the 
prompts. Locate First Element.  Select the beginning of the vertical alignment, 
the entire alignment will highlight. Accept (left-click). 

3. Set the profile active. Using the Element Selection tool, select the profile, from the 
pop-up menu select: Set As Active Profile. This will associate this profile with the 
horizontal alignment, and you can now see the alignment also in the 3D view 
(View 2, Default-3D). Save Settings.  

 
Figure 76 – Create complex vertical alignment 
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Figure 77 – Set profile active to see in the 3d view 

6. The profile in the alignment dgn file is not annotated, for annotation of profiles 
see Volume 13. 

  

https://portal.ct.gov/DOT/Engineering-Applications/CTDOT-CONNECT-DDE-eBook-Volume-013---Contract-Plans-Production/Plan-and-Profile-Sheets#Label%20%E2%80%93%20Profile%20(Vertical%20Alignment)
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Exercise 6 – Intersecting Alignments  
In this exercise the creation of a horizontal and vertical alignments with the PI method will be 
described. There are several methods to create alignments for more on other methods or other 
alignment tools please see Bentley's OpenRoads Help – Horizontal Geometry. 

6.1 Horizontal Alignment of Side Roads 

6.1.1 Complex By PI  

1. Select File > Open, browse to Highway/Base_Models, select HW_CB_0047_0122_ 
Exercise_6a_Alignments.dgn 

2. In the View Window zoom in near the side road draft lines and circles at station 127+00. 

3. Change the Feature Definition to: Alignment > Center > Centerline. 

4. Select the tool Complex By PI. 

 
Figure 78 – Complex by PI tool 

4. Click on the Near Point Snap  

 
Figure 79 – Activate Near Point Snap 
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5. Select the Mainline Route 140 Centerline at the Draft Circle 
Radius at 200’ we will adjust after 
None for back and ahead 
Name: Hopkins_Road_CL 

 
Figure 80 – First PI point placed                                                                               Figure 81 – Place additional PI points 

5. Set Snaps to Center. 

 
Figure 82 – Sets Snaps to Center 

6. Place the second PI point in the center of the Draft Circle to the top left, continue up the 
line to the circle near SNET Pole 2405 and follow the prompts to accept the alignment 
and stop the command. 

7. Set the Begin Station to 600+00. 

 
Figure 83 – Assign begin station 



Volume 3.1 - OpenRoads Designer Alignments 

59 
 

6.1.2  Adjustments to the Horizontal Alignment 

Depending on the Design Intent, the placement and relationship between the elements will 
control how individual elements of the horizontal alignment can be modified. 

For more information on placements and relationship of elements see Bentley's OpenRoads 
Help. 

In the example the PI method was used, this will allow for modifications to the PI locations 
and the radii of curves. 

In the flowing steps you will be making adjustments to the sideroad alignment to see how it 
reacts to the changes. 

1. Using the Element Selection tool click select the PI of the second curve and 
move it to a new location; see the horizontal alignment move. Follow the 
prompts to move the PI to a new location. 

2. Move the Point back to the draft circle.  

3. Now adjust the radius.  Click on alignment, this will activate the radius 
components that can be adjusted. Click on the second radius (orange text) a 
box with the radius will appear, here change the radius to 590. Press Enter.   

 
Figure 84 – Edit curve radius 

 
Figure 85 – New location of alignment 

4. Click on the first curve, enter a new radius of 270 feet. Press Enter.  

These are just a few of the options to control and edit horizontal alignments, 
see Bentley's OpenRoads Help for more detailed edit options. 
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6.2 Override Annotation Group for Right to Left Alignments 
1. Select the alignment Hopkins_Road_CL, follow the prompts from Exercise 4.2 to display the 

Annotation, right-click to Reset. 

2. Zoom in on Hopkins_Road_CL, notice the annotation is upside down, this is because the 
alignment runs right to left. This can be fixed by changing the Annotation Group. 

3. On the Drawing Production tab, select Element Annotation > Remove Element Annotation 
tool.  Click on the Hopkins_Road_CL alignment, follow the prompts to remove the 
annotation, right-click to Reset.  

 
Figure 86 – Remove Element Annotations 

4. Select the Annotate Element tool. 

 
Figure 87 – Annotate Element 

4. On the Annotation Element dialog box, toggle on Override Annotation Group, in the popup 
menu select Plan > Linear > CL Stationing Flip. Follow the prompts and select the 
Hopkins_Road_CL. Notice the stationing is no long upside down. 

 
Figure 88 – Override Annotation Group 
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6.3 Vertical Alignment of Side Roads 

6.3.1 View Profile 

1. Select Hopkins Horizontal Alignment and in the pop-up select Open Profile Model.  

 
Figure 89 – Open Hopkins profile model 

2. Select a View 4, 

 

 
Figure 90 – Set profile to View 4 
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6.3.2 Project Mainline Crossing Points on to Profile 

1. In the Reference dialog box turn on the Route 140 Corridor File 
2. Change Snaps to Key Point 

 
Figure 91 – Enable key points snap 

3. In View 1, Zoom in on the beginning of Hopkins Road 

4. On the Geometry tab in the Vertical section select: Profile Creation > Profile Intercept 
Point 

 
Figure 92 – Profile Intercept Point tool 

5. Follow the prompts in View 1, select the Hopkins Centerline, then select the Shoulder, 
Edge of Road and the Route 140 Centerline. 

6. Right click, Reset to complete. 

 
Figure 93 – Select elements to intercept 
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Figure 94 – Intercepted points in profile view                                                                    

 

Figure 95 – Projected alignment elements shows 

The three points will now be placed in the profile window. 

 
Figure 96 – Projected points on Hopkins profile 
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6.3.3 Create Vertical Alignment 

1. Change the Feature Definition to: Alignment > Center > Centerline  

2. Using the Draft line Element Template, draw a line between the Centerline and Shoulder 
points on the profile. Extend the line out to around 601+20 

 
Figure 97 – Place draft line to being profile 

3. Use the Profile Complex By PI Tool to layout the vertical alignment. 

 
Figure 98 – Profile Complex by PI tool 
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4. In the dialog box enter  
Curve Length 40.00, we will adjust after 
Vertical Curve Type: Parabola 
Name: Hopkins_Road_CL 

 
Figure 99 – Vertical profile name and curve setup 

5. Select the Red Point 
6. Change snaps to Near Point, click near the Orange Line, select toward the right end of 

the line. 

 
Figure 100 – Snap to draft profile 

 
Figure 101 – Place complex element on draft line 
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7. Next place a Data Point near the top of the Profile and select the Existing Ground. Right 
Click to Reset to Complete. 

 
Figure 102 – Snap to existing ground 

 
8. Modify the Vertical Curve to 170. 

 
Figure 103 – Adjust curve length 

9. Try out the Modify > Profile insert Curve tool. Add a curve between the first curve and 
the end of the alignment with a Length of 100. 

 
Figure 104 – Insert new profile curve 
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Figure 105 – New curve segment inserted 

 
Figure 106 – Completed driveway vertical profile 
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Exercise 7 - Geometry Reports 
Several preconfigured reports are provided with the OpenRoads software that can be used to 
review alignment information. 

7.1 Horizontal Reports 

1. Select the Browse icon, browse to Highway/Base_Models, select HW_CB_0047_0122_ 
Exercise_7_Alignments.dgn 

2. Form the OpenRoads workflow, select the Home tab, in the Model Analysis and Reporting 
Section select: Reports > Horizontal Geometry Report. 

 
Figure 107 - Horizontal Geometry Report tool on ribbon 

Additionally, reports can be generated by selecting a civil geometry element and choosing 
the Reports icon from the pop-up menu. 

 
Figure 108 - Horizontal Geometry Report tool on popup menu 
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3. In the pop-up dialog box select: 
Lock to Start 
Lock to End 
No Interval 
No Profile 
Follow the prompts and select a Horizontal 
Alignment, Right Click to reset and complete and 
Click through the heads-up prompts. 

 
 
 
 
 
 
 
 
 
 
 

4. When a report is generated, the default report for the 
element type is displayed. This 
example shows the default report 
for an alignment. 

Several reports are available and 
can be selected from the list at 
left. Depending on the element 
type that the selected report has 
been configured to accept, it may 
not show any information. 

Figure 109 - Horizontal Geometry 
Report dialog box 

Figure 110 - Horizontal Geometry Report Output 
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5. Select Tools > Format Options 

 
Figure 111 – Report Format Options tool drop drop 

In this dialog box the format of the report can be modified as needed. The format options 
are stored as a user setting in the Windows Registry and must be manually set by each 
user on their computer. The settings shown above are recommended for CTDOT projects. 
Changes made to the Format Options dialog are dynamically applied to the current report 
when the dialog is closed.  

6. Click the Close button 

 
Figure 112 – Report Format Options 
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7. Select File > Save as and choose Microsoft Excel (*.xlsx) 

 
Figure 113 – report Save as 

 
Browse to your computer Documents folder and name the file: 
Route_140_Horizontal_Alignment. Click Save. 
Warning – do not attempt to save this directly to you Compass Project as this causes 
issues. 

 
Figure 114 – Save as dialog box 

8. Outside to OpenRoads from your desk top Open File Explorer.  Browse to open the excel file 
that was just created and review.  Close the excel file after your review is complete. This file 
can now be moved to the appropriate folder in your Compass project. 
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7.2 Vertical Reports 
1. In the Profile view select the Vertical Alignment, when the pop-up tool bar appears select 

Profile Report. 
Note: This can also be accessed form the OpenRoads workflow, select the Home tab, in the 
Model Analysis and Reporting Section, select Reports > Horizontal Geometry Report. 

 
Figure 115 – Profile Report popup 

2. Select Tools > Format Options or File > Save as described in the Horizontal Reporting 
section. 

 
Figure 116 – Profile Report output 
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Exercise 8 - Driveways 
There are various way to create a Driveway. For simple Driveway users can use CTDOT provided 
Driveway Civil Cells. For complex Driveway users need to design them. 

In the following exercises you will learn one method to create them. Users will use various tools to 
create Driveway Alignment, Driveway Profile, Driveway Edge etc. Driveway Alignment and Profile 
are similar to Exercise 1, 2, 3 and 4 above. Users will learn that each driveway element is ruled main 
corridor (CL_Route140) so that when the main corridor is updated, Driveway also updates 
automatically.  

8.1 Create the Horizontal Centerline 

1. Select File > Open, browse to Highway/Base_Models, select HW_CB_0047_0122_ 
Exercise_8_Driveways.dgn. Please review the references. 

 
Figure 117- References 

2. In the View window zoom in near station 119+00. 

3. Change the Feature Definition to: Alignment > Center > Driveway. 

 
Figure 118 – Change the Feature Definition 
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4. Select the tool Complex By PI. 

 
Figure 119 – Complex by PI tool 

5. In the dialog box enter Radius = 10’, with no back or forward transition. 

 
Figure 120 – Radius and Feature settings for Driveway centerline 

6. Click on the Near Point Snap, and select the Mainline Centerline, continue placing points 
along the center of the Driveway.  After placement edit as needed. 

 
Figure 121 – Near Point Snap selected 
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Figure 122 – Before and after driveway alignment modifications 

      
Figure 123 Alignment modifications (Left – Move PI, Middle and Right modify Radius) 

7. Edit the Mainline Radius and notice the Driveway stays ruled to the alignment changes. 
Undo the changes and watch the driveway revert back. 
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8.2 Create the Horizontal Driveway Edges 

1. Set the Feature Definition to: Alignment > Linear > Roadway Geometry > Edge of Driveway 
Line.  

 
Figure 124 – Set the feature definition to Edge of Driveway Line 

2. From Geometry Tab > Horizontal group select Offsets and Tapers dropdown > Single Offset 
Entire Element. 

Note: If you are using offset Geometry as a method to adjust template lines in a 
Corridor, Surface Template or Liner Template, that geometry should be placed in the 
corridor DGN file it will be assign to and not in the Alignment DGN file. 

 
Figure 125 – Single Offset Entire Element tool 
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3. Follow the heads-up prompts: 
Locate Element: Driveway Centerline Russo Dwy 
Enter offs.  et: 5 ft 
Mirror: Yes 
Name: E_Dwy1 

 
Figure 126 – Offset geometry with mirror option 

4. Create Driveway Curb Returns.  Go to the Geometry Tab > Horizontal Group, drop down on 
Arcs > Arcs Between Elements > Simple Arc. 

Locate First Element: main Corridor (CL_Route140) EOR_rt 
Locate Second Element: left edge of Driveway E_Dwy1 
Radius: 50 ft 
Trim/Extend: Ahead 

 
Figure 127 – Left driveway curb return using simple arc 
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5. Repeat Step 13 for Right edge of Driveway with following parameters. 

 
Figure 128 - Right driveway curb return using simple arc 



Volume 3.1 - OpenRoads Designer Alignments 

79 
 

8.3 Create the Lip Geometry 
Once the Horizontal Driveway layout is complete, profiles need to be created. The profiles of the 
Driveway should tie to EOR and with a 1 ½” vertical lip. 

1. Create horizontal geometry for the driveway lip. From Geometry Tab > Horizontal group 
select Offsets and Tapers dropdown > Single Offset Partial. 

Offset: - 1 ft (We will change this to -.001, once profile is assigned to this line.) 
Name: Dwy_Lip1 
Locate Element: main Corridor (CL_Route140) EOR_rt 
Start Distance And Offset:  Keypoint Snap to left edge of Driveway E_Dwy3 
End Distance And End Offset:  Keypoint Snap to Right edge of Driveway E_Dwy4 
Mirror : NO 

 
Figure 129 – Single Offset Partial for driveway lip 
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2. Create the profile driveway lip line. From Geometry Tab > Vertical group select, Element 
Profiles dropdown > Profile By Vertical Offset From Element. 

 
Figure 130 – Profile by Vertical Offset from Element 

Slope Style: Constant 
Locate Plan Element to Profile: Dwy_Lip1 
Locate Reference Element: Select main Corridor (CL_Route140) EOR_rt 
Vertical Offset: 0.125 ft (1 ½ in) 

 

 
Figure 131 – Vertical offset set to 0.125 

You can now verify the profile for Dwy_Lip1 by using any View using Open Profile Model 
command.  
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8.4 Create the Driveway Profile 

1. Display the Main Corridor EOR and Driveway Lip in Driveway CL Profile. Open Profile Model for 
Dwy CL (Russo Dwy). From Geometry Tab > Vertical group > Profile Creation dropdown > 
Profile Intersection Point. 

 
Figure 132 – Point Intersection Point tool 

Locate Element to Show Intersection : Russo Dwy  
Locate Element Which Intersects: Dwy_Lip1, EOR_rt ( SHDR_rt and CL_Route140 if needed) 
Reset 

 
Figure 133 – Intersection points added to profile 
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2. Change offset of Dwy_Lip1 to -0.001. EOR and Dwy should match, but if the offset is 0, 
during triangulation there will be vertical face which we want to avoid. 

 
Figure 134 – Dwy_Lip1 offset adjusted to -0.001 

3. Check the profile of Russo Dwy. 
Red Dot: CL_Route140 
Grey Dot: SHDR_rt 
Pink Dot: EOR_rt 
Magenta Dot: Dwy_Lip1 

 
 
 
 
 
 
 
 
 

 
 

1. From Geometry Tab > Vertical group > Lines dropdown > Profile Line Between Points. 

Enter Start Point: Snap to Magenta Dot Dwy_Lip1   

Enter End Point: Snap to Existing ground. (Slope and Limits of Driveway is left to the designer 
to practice) 

2. Activate the Driveway Profile once completed. 

Figure 135 – Intersection points shown 
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Figure 136 – Activate the profile 

3. If CL_Route140 corridor changes, Driveway profile will also automatically update. 
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Exercise 9 – Geometry for XSC Crossing Points 
This exercise will cover the creation of Non-Centerline Geometry such as Flood Lines, Water Marks, 
Wetlands and ROW lines.  There are two tables below listing the Feature Definitions and point 
labels that will appear in Cross Section Sheets for Crossing linear features: 

• Geometry Features create using the Place Geometry Tools 
• Breakline Features that are created from running a roadway template on a corridor, Linear 

Template, or Surface Template. 

Note: This exercise will cover the placement of Geometry Features, the creation of Roadway 
Breadlines will be covered in Volumes 3.2 and 3.3. 

Table 9-1 -Geometry Features for XSC Crossing Points 

Feature Definition XSC Crossing Point Annotation 
Imported Existing\Existing BCLC EX. BCLC 

Imported Existing\Existing BCPC EX. BCPC 

Imported Existing\Existing Building EX. BUILDING 
Imported Existing\Existing Concrete Curb EX CONC. CURB 
Imported Existing\Existing Edge of Road EX. EOR 
Imported Existing\Existing Fence EX FENCE 
Imported Existing\Existing Granite Curb EX. GRANITE CURB 

Imported Existing\Existing Granite Sloped Curb EX GRANITE SLOPED CURB 

Imported Existing\Existing Noise Wall EX. NOISE WALL 
Imported Existing\Existing Road CL EX. CL 
Imported Existing\Ruins EX. RUINS 
Imported Existing\Existing Stone Wall EX. STONE WLL REMAINS 
Imported Existing\Existing Walk EX. WALK 
Right of Way\Existing\Easement Line EX. EASEMENT 
Right of Way\Existing\Interior Non-Access Highway Line EX. HIGHWAY LINE 

Right of Way\Existing\Location Survey Highway Line EX. HIGHWAY LINE 

Right of Way\Existing\Non-Access Highway Line EX. HIGHWAY LINE 

Right of Way\Existing\Street Line EX. STREET LINE 
Right of Way\Existing\Unlimited Access Highway Line EX. HIGHWAY LINE 
Watercourses\100 Yr Flood 100 YR FLOOD PLAIN 

Watercourses\500 Yr Flood 500 YR FLOOD PLAIN 

Watercourses\High Tide Line HTL 
Watercourses\High Water Line MHW 
Watercourses\Low Water Line MLW 
Watercourses\Ordinary High Water Line OHW 
Watercourses\SCEL S.C.E.L. 
Watercourses\Existing Water Edge EX. WATER EDGE 

Watercourses\State Wetland WETLAND LIMIT 
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Watercourses\State Federal Wetland WETLAND LIMIT 

Right of Way\Proposed\Acquisition Line ACQUISITION LINE 
Right of Way\Proposed\Defined Easement Line EASEMENT LINE 
Right of Way\Proposed\DROW Line EASEMENT LINE 
Right of Way\Proposed\Slope Easement EASEMENT LINE 
Right of Way\Proposed\Temporary Work Area Line EASEMENT LINE 

 
Table 9-2 Breakline Features for XSC Crossing Points 

Road CL ”Elevation” 
Shoulder SHDR 
Travelway TRWAY 
Edge of Road EOR 
Walk Concrete EOSW 

 

9.1 Create Line Work 

1. Select the Browse icon, browse to Highway/Base_Models, select HW_CB_0047_0122_ 
Exercise_9_CrossingFeatures_Existing.dgn 

2. In the Plan View set the Existing Ground Active. 

3. In the view window into Stations 114+00 to 120+00. 



Volume 3.1 - OpenRoads Designer Alignments 

86 
 

 
Figure 137 – View of Stations 114+00 to 120+00 

4. Use the MicroStation Copy tool to copy in the two OHW lines from the Reference File. 

Note: For graphics that are just plain lines the Copy command is the desired tool for this.  
For civil features in reference files, it would be better to trace over the line work using the 
Place Line String command. 
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5. Select the two lines. In the Properties dialog, extended section adjust the Line Style 
Parameters to 1.0.  Note: This ground file was created a v8i so the scale needs to be 
adjusted. 

 
Figure 138 – Adjust Line Style Parameters 
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9.2 Create Feature 

1. Set the Feature Definition to Linear > Roadway Geometry > Watercourses > Ordinary 
Highwater Line. 

 
Figure 139 – Select Feature Definition 

2. On the Geometry tab, General Tools section select Set Feature Definition. 

 
Figure 140 - Set Feature Definition Tool 

8. Set the Feature Type to Linear 

 
Figure 141- Set Feature Definition 

9. In the view select the Top Ordinary Highwater Line and follow the prompts to add the 
Feature Definition, repeat to the Bottom Ordinary Highwater Line.  
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9.3 Create Profile 

1. Hover over and select the new Geometry, a menu will pop up, select Open Profile Model, 
select a view. 

 
Figure 142 – Open Profile Model 

2. In the Profile View, hover over the Existing Ground dashed line and select Set As Active 
Profile, this will make the existing ground the profile. 

  
Figure 143 – Set As Active Profile 

3. Repeat for the other line. 
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4. Open a file that has a corresponding Corridor Model Highway > Base_Models > 
HW_CB_0047_0122_Corridor_Route140.dgn and view the dynamic cross sections. Right 
click in View 1, Default and select, View Control > Plan/ XS / 3D. 

 
Figure 144 - Select View Control 

5. Select Ok to create a Dynamic View. 

 
Figure 145 – Select Dynamic XC View 

6. Locate the corridor (not an alignment, the alignment Method will not show the Crossing 
Points), then select the View. 

7. Enter or click to the station 114+20 to view the crossing points.  

 
Figure 146 – Set Station 
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Figure 147 – Dynamic Cross Section showing Crossing Points 

 
8. When you create a file for Cross Section Sheets, these Points will annotate. 

 
Figure 148 – Cross Section Sheet Annotation 
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Dataset Install for Self-Paced Training 
The training data set is stored in SharePoint for those doing self-paced training. 

1. In Microsoft Edge browse to:  DOT CTDOT_DDE - Training Datasets - All Documents 

2. Click on Training Data Sets and select Volume 3_1.  Click on the three dots … and select 
Download. 

 
Figure 149 - DDE SharePoint Page - Download Training Dataset 

3. CTDOT employees - In File Explorer under This PC browse to Downloads and copy the 
Active_Survey, and  Highways folders to your Non-Project Work Area. 

C:\Users\yourname\OneDrive - State of Connecticut\CAD_NonProjects\Design\ 

Consultants or those who would like to work outside of one drive can create a working 
folder on their computer.  

4. When launching the application In CAD Accounting use the Non-Projects option for Run 
Program. 

 
 

https://ctgovexec.sharepoint.com/sites/DOTCTDOT_DDE/Training%20Datasets/Forms/AllItems.aspx?npsAction=createList&viewid=8f89c469%2D37fb%2D4ee2%2Da674%2D12cf04a332b6
https://docs.bentley.com/LiveContent/web/OpenRoads%20Designer%20CONNECT-v9/en/GUID-0EE5C4C5-C12D-4892-A491-0CFCD25BEF50.html
https://docs.bentley.com/LiveContent/web/OpenRoads%20Designer%20CONNECT-v9/en/GUID-0EE5C4C5-C12D-4892-A491-0CFCD25BEF50.html
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Appendix 

Civil Accudraw 

Placing elements in a 2D model is like manual drafting — all elements appear on the same 
plane, the sheet of paper.  

• In 3D, you place elements in space — horizontally (for example, a floor), vertically (for 
example, a wall), or at any other angle or direction (for example, a sloping roof).  

• By default, data points in a 3D model are placed at the view's Active Depth. Where you snap 
a tentative point or place a data point in a blank part of a view, it will be located at the 
active depth. You can, however, snap a tentative point to an existing element at any depth 
in a view. When you accept such tentative points, the data point is placed at the level of the 
snap point. 

Civil AccuDraw and its drawing plane let you place elements away from the active depth. 
Often this improves productivity, since you need not constantly change the active depth. 

Civil Accudraw is activated by selecting the Civil Accudraw icon from the geometry tab as 
shown below. 

 
Figure 150 – Ribbon Location of Civil AccuDraw  

  
The first icon is used to turn Civil AccuDraw on or off. 

 
Figure 151 - Civil AccuDraw Toolbar 
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Civil AccuDraw performs many of the same functions as MicroStation AccuDraw but has 
greatly expanded capabilities for the civil designer. 
Warning: Simultaneous use of Civil AccuDraw and MicroStation AccuDraw will cause 
errors.  Close MicroStation AccuDraw when using Civil AccuDraw. 

Civil AccuDraw Settings  

Civil AccuDraw Settings are accessed by selecting second icon as shown below. 

    
Figure 152 - Civil AccuDraw Settings 

Auto Load – Toggle this option ON to automatically load Civil AccuDraw. 

Floating Origin - CTDOT recommends turning this option off. 
ON: the origin moves to the last point placed. OFF: the origin remains fixed. 

Context Sensitivity - CTDOT recommends turning this option off. 
ON: the compass rotates in response to the context of various tools.  

Smart Key-Ins - 
ON: Civil AccuDraw interprets a number as positive or negative, depending on the 
direction of the pointer from the compass. 

XY ordinates only: Smart Key-ins cause Civil AccuDraw to move the focus to either the x 
or the y field depending on the pointer position.  

Preserve Method Locks - 
ON: the locked values remain locked after switching the ordinate methods.  For example, 
using station-offset ordinates and a lock station of 1+00, switch to distance-direction 
ordinates.  Station 1+00 will remain locked while inputting distance-direction.  The 
resulting effect will be a distance-direction-stationlock.  
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Sticky Z Lock - 
ON: inputs to Z ordinates remain locked (sticky) until they are changed.  This is useful in 
a 3D DGN to control the Z ordinate.  For example, input 100.00 for the Z ordinate and the 
value remains constant until changed.  

OFF: The Z ordinate follows the cursor dynamics.  

This also controls whether the origin for delta Z measurements follows the XY origin or is 
independent of XY.  

ON: the origin for delta Z is completely independent of the XY origin.  For example, the user 
can set the origin for dXdY measurements from point A and set dZ to be measured from a 
second point B.  The Z origin does not change until reset by the user.  The effect will be 
apparent when drawing a linestring.  When drawing a linestring, the dynamic orientation of 
the compass will adjust to align with the most recent line segment.  The Z origin will remain 
fixed wherever the user placed it at in the beginning.  

Note: When Accudraw ordinates are set to X,Y the sticky Z toggle does not apply.  This is 
because, by definition, XY mode is always assumed to be absolute.  

Always Show Compass - 
ON: the compass is always visible.  

OFF: the compass is only visible when the appropriate input is required. 

Civil AccuDraw Tools 

Hold down the second icon to reveal the shortcut menu shown below. 
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Figure 153 - Civil AccuDraw Tools 

  

XY Tool 

When the XY mode is selected and a civil command is active, the coordinates of the 
current cursor position are displayed in a floating dialog as shown below. 

     
Figure 154 - Civil AccuDraw XY Tool 

• The Tab key is used to move through the key-in fields in the dialog. 

• Values entered in the floating dialog are locked when the Enter key is pushed. 

• To unlock a value, tab to the field and push the End key. 

Civil AccuDraw Compass and Curser Input 

When the Always Show Compass setting is toggled on, a compass is displayed at 
AccuDraw’s origin point when Civil AccuDraw is active. 
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The compass is always circular and is marked by a number of tics.  The default is 4 
compass points which can be changed in the settings. 

 
Figure 155 - Civil AccuDraw Compass 

The north arrow on the compass will always point to north as defined by selecting File > 
Settings > File > Design File Settings > Angle Readout. 

If the Civil AccuDraw Settings dialog (shown above) has the Context Sensitive option 
turned on (default), then the compass auto-rotates in a similar fashion to MicroStation 
AccuDraw: 

 
Figure 156 - Civil AccuDraw curser input 

• The Distance-Direction ordinate is used to enter points in polar coordinates as shown 
above. 

• The input for angle and direction fields follows the File > Settings File > Design File 
Settings > Angle Readout settings. 

• Note that rather than direction being shown, the label and value are now an Angle.  This 
is because the context is based on the direction of the preceding line segment rather 
than an absolute direction. 

• The compass can be rotated with the V, B, T, RQ, RE shortcuts.  

• V rotates the drawing plane to align with the view axes. 

• T rotates the drawing plane to align with the axes in a standard Top view. 

• RQ is used to quickly and temporarily rotate the drawing plane. 

• RE rotates the drawing plane to match the orientation of a selected element. 

• Use the T (Top) shortcut or the corresponding drop-down to return to a pure direction.  
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Station Off-set 

The Station-Offset ordinate is used with a reference element to enter information as a 
station and offset relative to a selected element. 

  
Figure 157 - Civil AccuDraw Station Off-Set 

The reference element can be a MicroStation element or an ORD Geometry element. If a 
MicroStation element is selected, the beginning of the element is assumed to be station 
0+00. If a civil element is selected with stationing defined, the station value of the selected 
element is used. 

Take the following steps to select the reference element with the Station-Offset ordinate 
active: 

• Tab to activate the Offset field that is floating on the cursor 
• Enter the letter “O” shortcut to set the origin. You are prompted to select the reference 

element. 

Once selected, data can be entered using station and offset values relative to the reference 
element as shown above. 

Dynamic Tools 

Geometry Rules 
Civil Geometry elements drawn using the OpenRoads tools are “ruled” graphics that behave 
according to the geometric rules that define how the element was placed. 
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Figure 158 – Place Line Dialog 

For example, a line drawn using the Line Between Points command has the following 
rules: Distance and Line Direction as shown below. 

These parameters can be entered in the Tool Settings dialog, shown at right above, or by using 
the parameters floating on the cursor. 

If you use the input field that floats on the cursor, the left and right arrow keys are used to 
switch between multiple parameters. 

When a parameter value is entered, it is locked as shown below. The parameter can be 
unlocked by unchecking the item in the Tool Settings dialog, or by pressing the End key on the 
keyboard while the parameter value on the cursor has the keyboard focus. 

  
Figure 159 – Distance is locked 

After a parameter value has been keyed in, use the left and right arrow keys, or the Tool 
Settings dialog to enter values for the remaining parameters.  

Issue a data point (left-click) to place the element. 

The rules can be reviewed and edited by using the MicroStation Element Selection tool to 
select the element. In the example below, the rules for the selected line are displayed. 
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Figure 160 – Rules displayed 

The rules can be edited by left-clicking on one of the parameters as shown below. 

 
Figure 161 – Rules can be edited as shown 

The rules for the selected element can also be reviewed and edited in the Properties dialog as 
shown below. 

  
Figure 162 – Properties Dialog 

MicroStation’s Manipulate commands (Copy, Scale, Rotate, etc.) cannot be used on ruled 
geometry. The rule must be removed to use these commands. 
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To remove a rule, select the element and let the cursor rest on the selected element until the 
pop-up menu appears. Choose the Rules menu as shown below. 

The following options are provided: 

• Lock - Deactivate Rules 
• Remove Rule 
• Unlock - Activate Referencing Rules 
• Lock - Deactivate Reference Rules 
• Remove Rule 

 
Figure 163 – Rules menu options 

Element Manipulators 
OpenRoads Geometry elements have Manipulators that are displayed in MicroStation when 
an element is selected. These manipulators can be used to edit the selected element 
graphically or by entering a value. 

Clicking on one of the key-point manipulators will display direction arrows to edit the line, as 
shown on the example below. 
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Figure 164 – Key-point manipulator at end of line 

Tip: The size and color of the Manipulator Text can be adjusted in the User Preferences. From 
the MicroStation menu, select File > Settings > User  > Preferences and then choose the View 
Options – Civil item on the left side of the dialog. The Manipulator Size or the Manipulator 
Font Scale parameters can be used to adjust the text size. 

Snaps 
As geometry elements are placed in the design, the elements are “ruled” to one another using 
snaps. 

The most common snap is the Key Point snap. In the example below, the second line was 
placed using a Key Point snap. When the line is selected, the icon for the snap mode that was 
used is displayed. 

If the first line is modified, the second line will maintain its relationship to the first line according 
to the Key Point snap rule.  

 
Figure 165 – Second line maintains its relationship if first is modified 
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Occasionally you may wish to create civil geometry elements that are not “ruled” to other 
elements. Turn off the Persist Snaps icon on the Feature Definition Toggle Bar to place civil 
geometry elements by snapping to other geometry without creating a rule. 

 
Figure 166 – Toggle Persist Snaps icon off 

Design Intent 
As geometric elements are drawn in MicroStation using the OpenRoads Horizontal Geometry 
tools, the software retains information about not only what element was drawn, but how it was 
drawn. This is referred to as the Design Intent. 

In the example below, the horizontal line was drawn first. The second line was drawn using 
the Perpendicular snap to draw the line at a perpendicular form the horizontal line to a 
specific ending point. 

 
Figure 167 – Perpendicular line drawn  

If the horizontal line is modified by changing the direction of the line, the design intent for the 
perpendicular line is preserved. The Perpendicular rule, and the ending location are preserved 
as shown below.  
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Figure 168 – Perpendicular rule intact even if original line modified 

  

Editing Dynamic Text 
When a civil geometry element is selected, and the various rules are displayed, some rules are 
shown in grey and cannot be edited by left-clicking on the text. To edit these rules, you must 
select the underlying geometry directly. 

 
Figure 169 – Greyed out text cannot be edited 

   

Take the following steps to select the underlying element. 

Use the MicroStation Element Selection tool to select the geometry element • Right-click on the 
element that you wish to edit. 

The underlying element is selected, and the associated rules can be edited as shown below. 
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Figure 170 – Right clicking on the element allows you to edit it 

Deactivating Rules 
Geometry elements that have active rules can be selected, edited, and deleted at any time. 
Deactivating the rules will lock the element in place so that it cannot be edited or deleted 
unless the rules are reactivated. This is useful to lock an alignment in place once the design 
has been completed. 

 
Figure 171 – Locking and Unlocking Options for geometry lines 

To deactivate the rules on a given element, select the element and let the cursor rest on the 
element until the pop-up menu appears. Choose the Lock – Deactivate Rule option as shown 
below. 

Design Standards 

Design Standards are used to monitor various alignment parameters on OpenRoads geometry 
elements. The standards are stored in DGN Libraries in the following location: 

...\CT_Configuration\Organization-Civil\_CT_Civil Standards - Imperial\Dgnlib\Design 
Standards 

The design standards can be used for two purposes: 
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• Provide default values for element creation tools such as radius of a curve for a selected 
CTDOT standard. 

• Check and report on the compliance of a geometric element with the design standard 
that has been assigned to the element. 

When a design standard is violated, the user is notified in two ways: 

• An icon is displayed on the graphics to indicate that there is a problem. 

• The Civil Message Center reports any errors. 

The Design Standards Toolbar allows you to select and apply a design standard. From the 
OpenRoads Modeling Geometry tab, select Standards > Design Standards Toolbar to access 
the dialog shown below. Design Standards can also be applied to an element after it has been 
created by using the Set Design Standard icon on the Design Standards Toolbar. 

 
Figure 172 – Design Standards Toolbar 

The toolbar contains a drop-down list to select the design standards and the design speed. 
The vertical design standard, displayed in the drop-down menu to the right, is automatically 
set when the horizontal design standards is selected. 

There are two icons located to the left of the drop-down menus. The first, Set Design Standard, 
is used to apply the current design standard to selected geometric elements. The 
second, Toggle Active Design Standard, is used to set the selected design standards active for 
relevant commands. 
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Figure 173 – Toggle Active Design Standard 

Annotation Groups 
Alignment elements are assigned a Feature Definition, which controls the symbology of the 
element (level, color, line style, and line weight) as well as the annotation properties of the 
element. The CTDOT Standards include feature definitions for alignments, which can be 
reviewed from the Project Explorer dialog, as shown below. 

There are several levels of configuration that has been set to get the annotation to display to 
CTDOT standards.  

   

Figure 174 – CTDOT alignment feature definitions 



Volume 3.1 - OpenRoads Designer Alignments 

108 
 

 
Figure 175 – Centerline feature definition properties 

 

 
Figure 176 – Centerline feature defaults and templates  
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Figure 177 – Centerline Stationing Annotation Group settings 

 

 
Figure 178 – Centerline Vertical Annotation and profile settings 
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Figure 179 – Profile annotation settings for vertical elements 

Note: the alignment feature definition controls the symbology and annotation settings for 
both the horizontal geometry and the proposed vertical alignment. 
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