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Course Overview  
In this volume you will learn how to set up the project framework for Design file referencing. You 
will also get a quick start look a navigating the OpenRoads interface.  This guide will not document 
each tool that is available on the OpenRoads interface. See the online help for commands not 
detailed in this document. 
 

OpenRoads Designer CONNECT Edition Help 
 

Skills Taught 
• Proper procedure for opening a DGN file 
• Project Roadway Template Library Creation 
• Design File Referencing Framework 
• Navigating the Interface 

o Working with 2D and 3D Models 
o View Controls 
o Viewing Display Styles 
o Analyzing Civil Data 
o Using Element Selection 
o Viewing Tooltips 
o Selecting a Feature to Review and Edit Geometry 
o Adjusting Manipulators and Other Settings 
o Using the Civil Context Menu 
o On-screen Heads-Up Prompts 
o Using Explorer and Properties 

 
DGN File uses: 
Exercise 1 – Highway\Base_Models\HW_CB_0047_0122_Corridor_Hopkins.dgn 
Exercise 2 - Highway\Base_Models\HW_CB_0047_0122_Corridor_Hopkins.dgn 
Exercise 4 - Highway\Base_Models\HW_CB_0047_0122_Corridor_Route140.dgn 
Exercise 5 - Highway\Base_Models\HW_CB_0047_0122_Alignment_Hopkins.dgn 
Exercise 6 - Highway\Base_Models\HW_CB_0047_0122_Alignment_Hopkins.dgn 
Exercise 7.1 & 7.2 - Highway\Base_Models\HW_CB_0047_0122_Alignment_Route140.dgn 
Exercise 7.3 to 7.6 - Highway\Misc\HW_NC_0047_0122_Element_Manipulators.dgn 
 
 
 
 

https://docs.bentley.com/LiveContent/web/OpenRoads%20Designer%20CONNECT-v9/en/GUID-1B18BC16-7361-4DA1-BC57-D8A9EEF3F9E7.html
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Exercise 1 - Best Practices 
This section outlines recommended best practices for the effective use of OpenRoads Designer. 
Note that most of the following are not requirements, they are rules of thumb that when applied 
consistently, these guidelines will enhance software stability, improve design efficiency, and 
support a more streamlined user experience. 

For clarification or additional guidance, please contact the AEC team though our Support Portal. 

1  Store All Contract Sheets in the Correct Location 

2  Adopt Project Discipline Seed Creation Procedures 

3 ABC Use Simple File and Model Naming 

4  Adopt a Federated File Structure 

5  Avoid Live Nesting 

6  Understand the Corridor Template Point Constraints – Hierarchy of Control 

7  Streamline Batch Publishing Operations 

1.1 Storage  

Store All files in the Correct Location 

• All Base Models (ie. Alignment a & Corridor DGN files) must be created and stored within the 
discipline-specific Base_Models folder. 

…\Highways\Base_Models 
 

• All Contract Sheets must be created and stored within the discipline-specific 
Contract_Plans folder.  

…\Highways\Contract_Plans 
 

 

https://ctdotcompass.atlassian.net/servicedesk/customer/portal/8/group/24/create/99
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1.2 Design Seed 

Adopt Project Discipline Seed Creation Procedures 

It is best practice for all design work to be done in a 2D design seed. Despite the last sentence 
above, this is not optional. The only proposed information that should be generated in a 3D 
seed is a proposed terrain model. It should be noted that Vertical Geometry and Corridor 
models will generate and attach a 3D model when that represents the design data shown in 
the 2D model. 

a. Confirm and Document the Project Coordinate System 
• Before creating any DGN files in the project container, verify the horizontal and vertical 

datums being used (e.g., NAD 83 / NAVD 88 or NAD 27 / NAVD 29). 

• Check all existing survey data for coordinate system metadata. 

• If uncertain, consult the Central Survey Unit before proceeding. 

b. Create a 2D Discipline Seed File 
• Create the 2D Discipline Seed file and store it in the root of the discipline folder (e.g., 

Highway). 

• Reference all needed existing survey models directly using no nesting. 

Use this seed file when creating all Contract Plan DGN files. 
Note: This may have already been done during Preliminary Design. It is good practice to 
verify that the seed file has been correctly set up if it was created by someone else. 

Exercise 2 will walk you through using the correct Seed file. 

1.3 File Naming 

ABC    Use Simple File and Model Naming 

a. File Naming 
Use only Letters (A–Z, a–z), Number (0–9) and Underbars (no spaces) 
HW_CP_1234_1234_Highway_Plans.dgn 

b. File and Folder Naming 
Avoid: 
• Long Paths - Windows has a character limit for the length of a path and file name 
• Excessively nested Folders 
• problematic characters: # % & * ? / \ < > | : " ; , ~ ^ ! @ $` 
• Using your name  
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c. Model Naming 

• Stick to letters (A–Z), numbers (0–9), underscores (_), and hyphens (-), Spaces are 
ok. 

• No symbols, or accented characters. 
• Start model names with a letter, not a number or symbol. 
• Keep names short and descriptive 

 

1.4 File Federation 

    Adopt a Federated File Structure 

When organizing project files in OpenRoads Designer, it is recommended to adopt a federated 
file structure. This approach ensures that each major design component is stored in its own 
dedicated file, rather than combining multiple elements into a single file. 
• Alignments: Each alignment should be stored in a separate file. 
• Corridors: Each corridor should be stored in its own file. 
• Superelevation: Each superelevation definition should be stored in its own file. 
• Other Components: Apply the same principle to other design elements (e.g., terrain 

models, drainage, utilities). 

Issues that may arise from improper File and Folder Naming: 
• File access errors – OpenRoads may fail to open DGN files if the path contains 

unsupported characters. 
• Version control conflicts – Systems like SharePoint, or network drives may reject 

files with certain characters. 
• Batch processing issues – Scripts, macros, or batch plotting routines can fail if 

filenames contain unusual characters. 

Issues that may arise from improper model naming 
Reference  
• Models with spaces or symbols (# % & *) may fail to attach as references in other 

DGN files. 
• Scripts that automatically attach DGN references often cannot parse special 

characters, causing workflow errors. 
• Models with leading numbers can sometimes sort incorrectly, causing wrong 

references to be picked up in batch jobs. 
Display & View Issues 

• OpenRoads may fail to generate views or sheets if the model name has 
unusual characters. 

• Plotting routines may skip models or produce errors in PDF/plot output. 
Automation & Scripting Errors 

• Custom VBA, Key-in, or Batch scripts can fail because the script parser cannot 
handle spaces or symbols. 
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Benefits of a Federated Structure: 

• Greater Stability: Reduces file corruption risks by limiting complexity within individual files. 

• Simplified Data Recovery: Easier to isolate and restore specific design elements if issues 
occur. 

• Improved Productivity: Multiple engineers can work simultaneously on different aspects of 
the project (e.g., one on geometry, another on corridors). 

• Clearer Organization: Enhances project transparency and makes navigation more 
intuitive. 
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1.5 Live Nesting 
Avoid Live Nesting 

1.5.1 What is Live Nesting? 

Live nesting is a feature in reference file management that allows users to attach multiple 
references simultaneously. It functions hierarchically, like a tree, where each level of nesting 
includes the references attached to the previous level. 

When you attach a reference file with live nesting enabled, the references within that file 
are also attached to the active design file. The depth of nesting determines how many 
layers of references are included: 

• Nesting Level 1: References directly attached to the selected file are included. 
• Nesting Level 2: References attached to those references are also included. 

For example, if both Reference 1 and Reference 2 (see Figure 1) have nesting set to level 1, a 
total of six files may be attached. If nesting is set to level 2, the number of attached files 
could increase to 18. These numbers are illustrative and will vary depending on the actual 
reference structure. 

 
Figure 1 - Live Nesting Diagram 
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1.5.2 Issues with Live Nesting 

Use Live Nesting cautiously and, in most cases, avoid it altogether. Excessive nesting can 
introduce the following issues: 

• File instability 
• Excessive lag when opening files 
• Slow panning, zooming, and plotting 
• Increased risk of file corruption or crashes 

Using Live Nesting can lead to recursive references, where a file is inadvertently referenced 
into itself. 

Example: 
A highway designer is working in corridor model files. After completing work in the mainline 
corridor file, the designer moves on to ramp modeling and references the mainline corridor 
into the ramp corridor file. While working in the ramp file designer realizes that the shoulder 
pavement needs to be turned off where the ramp pavement ties in and switches back to 
the mainline corridor file to make the change. While in the mainline corridor file, the 
designer references the ramp corridor file with Live Nesting = 1. By doing so, the mainline 
corridor is unintentionally referenced back into itself through live nesting. 

Warning: This condition may not appear immediately harmful; however, on projects with 
multiple users, it can lead to significant issues over time. Many CTDOT support tickets and 
file stability issues have been resolved simply by avoiding live nesting. 

 
Figure 2 - Live Nesting example 

When producing sheets in OpenRoads Designer, follow the best practices outlined in 
Volume 13, Section 4.1.1, with particular attention to Section 4.1.1.4 – No Nesting References. 
Direct referencing helps prevent unintended file attachments and provides greater control, 
performance, and stability in sheet files. 
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1.6 Hierarchy of Controlling Template Point Constraints 

  Understand the Corridor Template Point Constraints – Hierarchy of Control 

There are a few options for controlling and manipulating the points in a corridor’s template 
drop.  Each method serves a purpose, with different levels of control and computational 
demand. For example, point controls will override and require much more processing power 
than a parametric constraint. See Volume 3.2: Corridor Modeling for more information 
regarding corridor manipulation. The methods of controlling templates are listed in 
descending order based on level of control: 

1. Point Controls (Highest Priority) 
2. Horizontal Feature Constraints 
3. Parametric Constraints 
4. Point Constraint (Lowest Priority) 

1.7 Batch Plotting 

Streamline Batch Publishing Operations 

When creating psets for batch plotting sheets, create a blank dgn file that is specifically used 
for creating and editing pset files. 

• There should be nothing in this file. 

• Store this file in the …Highways/Contract_Plans folder or wherever you store the pset 
file. 
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Exercise 2  - Create a Project Discipline 2D Seed 
Before starting this exercise: 

• The CTDOT CONNECT DDE synced through SharePoint 
• The COMPASS Training Project Synced (i.e. 9999-0001 – Design) 
• Dataset Volume_3_0 should be installed into your training WorkSet. 

 
In this section we will be creating a Project Discipline Seed that will be used to create a 
Highway Design Files. 

2.1 Check the Existing Survey Coordinate System 
In this section we will open a file read only to check the Geospatial Header. 

1. Log on to the CONNECTION Client. 
Bentley Connect licensing requires users to log into their Bentley account to secure a 
software license. CTDOT users should log in using your CTDOT email address and Bentley 
password. If you do not see the dialog box, select the ˄ icon on the bottom Windows Screen. 
Click on the Connection Client Icon and select Open. Bentley Log in  

     
Figure 3 - CONNECTION Client System tray and Log in 

Notes for working on actual projects: 
1. CTDOT users should have the CTDOT CONNECT DDE synced through SharePoint with the 

COMPASS Project Synced along with the CAD Configuration.  
2. Consultants should have CTDOT DDE properly installed or be syncing to the CTDOT DDE 

SharePoint/COMPASS system. 
3. Make note of the Coordinate System you will be working in. If you have existing survey 

data, you will need to find out what system is being used (NAD 83/NAVD 88 or NAD 
27/NAVD 29).  
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2. Launch the Application 

CTDOT employees - On your desktop double click on 
the CAD Accounting Icon. 

 
Note: Consultants, Start the software via an 
appropriate CTDOT DDE icon and skip to step 5. 

 
 

3. On the Accounting Menu, the following will appear on the first use of the menu. 

a. Find your Windows User at Work user log in name from dropdown list and select it. 

b. If it is not in the list enter it in the blank field below the drop-down list. Un-sure of your 
user log in name, open File Explorer D:\Users\... and find your name.  If the Username is 
rejected, then: 
• non-DOT employee, and you have permission from that user, please select 

that existing username from the dropdown list to use as proxy. 

• DOT employee, please contact dot.helpdesk@ct.gov to add your name to the CAD 
Accounting PC name table. 

d. Find your Computer Name at Work from dropdown list and select it. 
• If it is not in the list enter it in the blank field below the drop-down list. Un-sure of 

your computer name go to your Desktop and double click on the WorkStation 
Information Icon.  Make note of the Computer Name:  

• If the Computer Name is rejected, then: 
o the computer is a non-DOT one, or one not on the DOT network, please select 

an existing computer name from the dropdown list to use as proxy. 

the computer is a DOT PC, please contact Desktop Support to add the PC to 
the CAD Accounting PC name table. 

Figure 4 - CAD 
Accounting Icon 

mailto:dot.helpdesk@ct.gov
mailto:dot.helpdesk@ct.gov
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e. Back on the Configure Windows User and Computer Name dialog box click Save. 

 
Figure 5 - CAD Accounting Initial Setup 

4. On the CTDOT Accounting Menu there will be several applications to pick. In the Run 
Program field select the needed program: 
• Compass OpenRoads CE 
• for the Available Account select OVERHEAD for training proposes.  
• Click on the Start button to load the program. 

Note: Non-Projects OpenRoads CE will default to your personal synced State of 
Connecticut OneDrive location and the Synced State of Connecticut DDE SharePoint 
Workspace. 

 
Figure 6 - CAD Accounting dialog box   
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5. After launching the program, the following will appear. 

   
Figure 7 - OpenX Splash Screen 

6. Ensure you are using the Custom Configuration and CT_WorkSpace, then select the 
relevant WorkSet and Role.  

 

 
Figure 8 - OpenBridge Modeler Splash Screen 

 
7. Select the Browse, browse to your project …\Active_Survey\and select SV_XX_0154-

0128_Westbrook_ORD.dgn. Click the Open down arrow and select Open Read-Only.   

 
Figure 9 - Open Read-Only 

Notes for working on actual projects: 
If you do not see the Project Number listed, please request a Compass/CAD Setup 
using this link  New CAD Project Request 

https://ctdotcompass.atlassian.net/servicedesk/customer/portal/8/group/24/create/100
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2.2 Review the Geographic Coordinate System 

The Geographic Coordinate System (GCS) lets the software know where the project is located 
geographically and what coordinate system needs to be defined for the project. The GCS is 
typically defined in the seed file provided by most agencies or surveyors. In this section, you 
will learn how to review the Geographic Coordinate System defined for your project.  Volume 2 
goes into great depths on this subject. 

1. Open the Existing Ground Survey model and review the Geographic Coordinate System. 
Select Utilities > Geographic > Coordinate System. 

 
Figure 10 - Coordinate System  

2. The following toolbox will appear. As you can see, it displays the current Geographic 
Coordinate System that has been defined for this file and project. 

 
Figure 11 – Active Coordinate System 

3. Close the Geographic Coordinate System toolbox. 

Note, in the lower right corner of the screen that there is a Geographic Coordinate 
System icon with a check mark. This informs the user that a Geographic Coordinate 
System has been defined in this file. 

 
Figure 12 – Design Model has Coordinate System 
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4. Open the Annotation model and review the Title Block notes. Make note of the NAD and 
NAVD year.  If there is inconstancy between the current Geographic Coordinate System set 
in the file and the  Title Block text, reach out to Central Survey for clarification. 

5. Close OpenRoads. 

 
Figure 13 – Survey Title Block 

2.3 Create DGN File 

We will now create a 2D File using the proper seed file with the required Datum as determined 
above. 

1. Open ORD on the New dialog select a location for your project seed file …Highway\ and 
name your file HW_2D_ProjectSeed.dgn.  Browse to select a 2D Seed, in the case the 
default file will work. 

 \Organization\Seed\Road\Seed2D - CT RoadDesign.dgn 

2. We will now import the GeoSpatial Header for the Survey File. Select Utilities > Coordinate 
System 

3. On the Geographic Coordinate System dialog select From File.  Browse to the location of 
the Survey File.   
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Figure 14 - From File 

4. On the Select Models dialog select the Existing Ground Survey model and Click OK.  The 
Geographic Coordinate System dialog will update to match the Survey file. 

 
Figure 15 - Select Model 

5. Reference all existing survey models.  Make sure to use direct references for each model. Do 
not use nested references. 

6. Save Settings 

7. Now create a New file using the Project Discipline Seed.  When the file opens Set the 
Terrain Active, this will prompt a 3D Model to be created in the file. 
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Exercise 3 – Review a Corridor Model File 
Now we will open a DGN File with Corridor Graphics and Reverence files already in place. 

1. Select File > Open, browse to the Highway\Base_Models and select 
HW_CB_0047_0122_Corridor_Hopkins.dgn 

2. Review the attached Reference Files.  Each Default model is referenced separately, and no 
nesting is being used. 

 
Figure 16 - References 

 
Figure 17 – Reference Settings 
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1. The 3D Design Model is an old Ground File created in V8i; it is also referenced in using no 
nesting. 

2. The Default-3D Model got automatically created when the Existing Survey Terrain was set 
active.  This Prompted the Reference to automatically nest other 3D Models for this 
Reference instance only. 
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Exercise 4 - Project Template Library  
Templates are used to define the typical section for each alignment. Multiple templates can be 
used to define different typical section designs, or the template geometry can be modified using 
a variety of corridor editing tools. 

CTDOT provides a sample template library in the following folder: 
...CT_Configuration\Organization-BIM\_CT_Civil Standards\Template Library\ 
CV_ORDTypicals.itl 

A blank ITL file can be found by default in the highway design folder  
…Highways/Eng_Data/Project_Typicals.itl. 

Required individual templates will be copied over from 
CV_ORDTypicals.itl to Project_Typicals.itl using the Template Library Organizer. 

Please note: Any other disciplines modeling a corridor can copy a blank ITL 
from …CT_Configuration\Organization-BIM\_CT_Civil Standards\Template Library\ 
Project_Typicals.itl and paste the file into the discipline-specific folder for engineering data: 

Discipline project location of ITL: 
• Bridge/Eng_Data/ 
• Envir/Eng_Data/ 
• F_Civil/Eng_Data/ 
• Geotech/Eng_Data/ 
• Hwy_Man/Eng_Data/ 
• Hwy_Ops/Eng_Data/ 
• Hydro/Eng_Data/ 
• Illumination/Eng_Data/ 
• Landscape/Eng_Data/ 
• Public_Trans/Eng_Data/ 
• R_Catenary/Eng_Data/ 
• R_Signals/Eng_Data/ 
• R_Track/Eng_Data/ 
• Traffic/Eng_Data/ 
• SVY_District_Eng_Data/ 
• PMaps/ 
• SVY_Central/ 
• SVY_Consultant/ 

Warning: 
Do not change the name or path of the 
Project_Typical.itl file.  
 
If this file name gets modified after Templates are 
placed in a Corridor the Synchronize with 
Library tool will not be able to update itl edited 
templates. 
 
This path is also set as a variable used across all 
projects so your file will always be read in. 
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1. Select OpenRoads Modeling > Corridors > Template > Create Template 

 
Figure 18 Create Template Tool 

2. The Template Library will open to …Highways/Eng_Data/Project_Typicals.itl. 

 
Figure 19 Project Typical File 

a. If the template library is pointing to a random place or file, go to file explorer and 
copy …CT_Configuration\Organization-BIM\_CT_Civil Standards\Template Library\ 
Project_Typicals.itl and paste the file into …Highways/Eng_Data/ 

Please note: Any other disciplines modeling a corridor can copy a blank ITL 
from …CT_Configuration\Organization-BIM\_CT_Civil Standards\Template Library\ 
Project_Typicals.itl and paste the file into the discipline-specific folder for engineering 
data: 

b. Now back in the Create Template select File > Open and open the .itl file you just copied 
to your project. 

3. In the Create Template Dialog Box select Tools > Template Library Organizer… 

 
Figure 20 Template Library Organizer Pull Down Tool 
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4. Select Browse… 

 
Figure 21 Template Library Organizer Browse Buton 

5. Select …CT_Configuration\Organization-BIM\_CT_Civil Standards\Template Library\  
CV_ORDTypicals.itl and click Open. 

6. Expand the right hand Available in folders and copy the needed Templates to the Project 
Library on the left-hand Available in. 

7. When complete click OK. 

 
Figure 22 Template Library Organizer Dialog Box 
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Exercise 5 – Design File Referencing Framework 
Below is an example of common DGN files used to design different aspects of a roadway project. 
Information here includes file uses and what files need to be referenced.  Projects often have 
different needs based on its complexity this set up can be used as a baseline.  Larger projects 
may need several Alignment DGN files so different staff members can work on different areas of 
the project at the same time. Drainage and Utilities DGN files may need to be broken up for the 
same reason as well as size limitation. 

File names should:  
be short and concise have no spaces have no characters other than underbars 

X - Incorrect: HW CB 1234 1234 Corridor Route # 123 in the Town of Newington, Connecticut.dgn 
√- Correct: HW_CB_1234_1234_Corridor_Route123.dgn 

For further information on file naming go to Volume 16, Appendix 4. 

 
Figure 23 – Base Models Folder 
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5.1 Contract Base Model DGN Files 
Base Model DGN files will have a description after the project number: 

• Type - indicates the type of information contained in the file, i.e. Alignments, Terrain, 
Corridor… 

• Location (optional) - Location indicates graphical features are specific to a road or 
area of the design i.e. Route123, MainStreet, SchoolDrive, OnRamp123…) 

• Status (optional)  – Status indicated Proposed, Stage or Existing. 

Note: These base model files start out with just a 2D Model, when the existing terrain is 
referenced in and made Active a 3D model gets automatically created in the file. This 
prompts the new 3D model to be Referenced into the 2D Model and automatically nest other 
3D Models for this Reference instance only (see exercise 1). 

5.1.1 Centerline Alignments 

The option to separate centerline alignment files for each roadway or to have all of them in 
one file is at the discretion of the design team. 

One DGN file option: 
HW_CB_1234_1234_Alignments.dgn • Horizontal centerline alignments 

• Vertical centerline alignments Referenced to Default Model (No Nesting) 
Existing Survey Terrain Model (dgn) 
Existing Survey 2D Model(s) (dgn) 
HW_CB_1234_1234_Corridor_Route123.dgn 

Multiple DGN files option: 
HW_CB_1234_1234_Alignment_Route123.dgn • Horizontal centerline alignments 

• Vertical centerline alignments 
 

*For the mainline (Route123) alignment file 
there is typically no corridor file that needs 
to be referenced in. The corridor file is 
needed only on secondary roadways or 
alignments that rely on the proposed work 
of another corridor to develop the 
horizontal and vertical alignments. 

Referenced to Default Model (No Nesting) 
Existing Survey Terrain Model (dgn) 
Existing Survey 2D Model(s) (dgn) 

HW_CB_1234_1234_Alignment_SideRoad1.dgn 
HW_CB_1234_1234_Alignment_SideRoad2.dgn 
Referenced to Default Model (No Nesting) 

Existing Survey Terrain Model (dgn) 
    Existing Survey 2D Model(s) (dgn) 
    HW_CB_1234_1234_Corridor_Route123.dgn 

HW_CB_1234_1234_Alignment_Route123.dgn 



Volume 3.0 - OpenRoads Designer Getting Started 

25 
 

5.1.2 Other Geometry 

HW_CB_1234_1234_ROW_Proposed.dgn Proposed Acquisition Lines, 
Easements, and DROW. Referenced to Default Model (No Nesting) 

Existing Survey Terrain Model (dgn) 
Existing Survey 2D Model(s) (dgn) 
HW_CB_1234_1234_Alignments.dgn 
HW_CB_1234_1234_Corridor_Route123.dgn 
HW_CB_1234_1234_Corridor_SideRoad1.dgn 
HW_CB_1234_1234_Corridor_SideRoad2.dgn 

HW_CB_1234_1234_PointControls.dgn  

Referenced to Default Model (No Nesting) 
As needed 

HW_CB_1234_1234_CrossSectionFeatures_Existing.dgn • Geometry for Crossing points on 
Cross Sections 
o ROW Lines 
o Waterlines (i.e. Inland 

wetland, flood…) 

Referenced to Default Model (No Nesting) 
Existing Survey Terrain Model (dgn) 
Existing Survey 2D Model(s) (dgn) 

    HW_CB_1234_1234_Alignments.dgn 

5.1.3 Superelevation 

HW_CB_1234_1234_Superelevation_Route123.dgn Calculated Superelevation Sections 
and Lanes Referenced to Default Model (No Nesting) 

HW_CB_1234_1234_Alignments.dgn  

5.1.4 Roadway Corridors 

HW_CB_1234_1234_Corridor_Route123.dgn • Corridors 
o Template Drops 
o Components 
o Features 
o Point Controls 
o Key Stations 
o Secondary Alignments 
o End Condition Exceptions 
o Parametric Constraints 
o Target Aliases 

• Point Control Geometry 
• Surface templates 
• Liner Templates 
• Driveway 

o Centerlines and Corridors 
o Surface Templates 
o Match Lines 
o Pavement Edge Geometry 
o Linear templates 

Referenced to Default Model (No Nesting) 
Existing Survey Terrain Model (dgn) 
Existing Survey 2D Model(s) (dgn) 
HW_CB_1234_1234_Alignments.dgn  
HW_CB_1234_1234_ROW_Proposed.dgn 
HW_CB_1234_1234_PointControls.dgn 
HW_CB_1234_1234_CrossSectionFeatures_Existing.dgn 
HW_CB_1234_1234_Corridor_SideRoad1.dgn 
HW_CB_1234_1234_Corridor_SideRoad2.dgn 

HW_CB_1234_1234_Corridor_SideRoad1.dgn 
HW_CB_1234_1234_Corridor_SideRoad2.dgn  
Referenced to Default Model (No Nesting)) 

Existing Survey Terrain Model (dgn) 
Existing Survey 2D Model(s) (dgn) 
HW_CB_1234_1234_Alignments.dgn  
HW_CB_1234_1234_ROW_Proposed.dgn 
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HW_CB_1234_1234_PointControls.dgn 
HW_CB_1234_1234_CossSectionFeatures_Existing.dgn 

o Civil Cells 
 

  HW_CB_1234_1234_Corridor_Route123.dgn 

5.1.5 Stormwater Drainage 

HW_CB_1234_1234_Drainage.dgn 
Other naming options: 
HW_CB_1234_1234_Drainage_Proposed.dgn 
HW_CB_1234_1234_Drainage_Existing.dgn 

• Drainage Areas 
• Nodes 

o Catch Basins 
o End Walls 
o Culvert Ends 
o Manholes 

• Pipes 
• Utilities 
*For proposed drainage, complex terrain is 
typically created from finished grade terrain, 
existing survey terrain, and lidar terrain. For 
existing drainage, complex terrain is typically 
created from existing survey terrain and lidar 
terrain 

Referenced to Default Model (No Nesting) 
Existing Survey Terrain Model (dgn) 
Existing Survey 2D Model(s) (dgn) 
HW_CB_1234_1234_Alignments.dgn  
HW_CB_1234_1234_ROW_Proposed.dgn 
HW_CB_1234_1234_Corridor_Route123.dgn 
HW_CB_1234_1234_Corridor_SideRoad1.dgn 
HW_CB_1234_1234_Corridor_SideRoad2.dgn 
*HW_NC_1234_1234_DrainageComplexTerrain.dgn 

5.1.6 Master 2D Line Work 

HW_CB_1234_1234_Master_2D_Design.dgn These are to be 2D Line work used to produce 
Plan Sheets 
• Edge of Road 
• Smoothed out Cut and Fill lines 
• Sedimentation Control Lines 
• Guiderail 

Referenced to Default Model (No Nesting) 
Existing Survey Terrain Model (dgn) 
Existing Survey 2D Model(s) (dgn) 
HW_CB_1234_1234_Alignments.dgn  
HW_CB_1234_1234_ROW_Proposed.dgn 
HW_CB_1234_1234_Drainage.dgn 
HW_CB_1234_1234_Corridor_Route123.dgn 
HW_CB_1234_1234_Corridor_SideRoad1.dgn 
HW_CB_1234_1234_Corridor_SideRoad2.dgn 

5.1.7 Master 3D Design 

HW_CB_1234_1234_Master_3D_Design.dgn This file is only to have Reference Files 
attached, there is to be no actual graphics 
in this file. 

Referenced to Default Model (No Nesting) 
Existing Survey Terrain Model(s) (dgn) 
Existing Survey 2D Model(s) (dgn) 
HW_CB_1234_1234_Alignments.dgn  
HW_CB_1234_1234_Master_2D_Design.dgn 
HW_CB_1234_1234_ROW_Proposed.dgn 
HW_CB_1234_1234_Drainage.dgn 
HW_CB_1234_1234_Terrain_Project_FG.dgn 
HW_CB_1234_1234_Corridor_Route123.dgn 
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HW_CB_1234_1234_Corridor_SideRoad1.dgn 
HW_CB_1234_1234_Corridor_SideRoad2.dgn 
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5.2 Proposed Terrain Model Files 
Proposed terrain model files are created using a 3D Seed file. See Volume 2 for more 
information. 
Terrain DGN files will have a description after the project number: 

• Type – is Terrain 

• Location - indicates the specifics to a road or area of the design i.e. Route123, 
MainStreet, SchoolDrive, OnRamp123…).  Project indicates it encompasses all the Terrains 
complexed into one. 

• Layer  – indicates the vertical information location.  Example top is the FG = Finished 
Grade.  There may be subgrades , rock, unsuitable material, or staging terrains needed 
as well. 

Finished Grade (FG) Terrains 
HW_CB_1234_1234_Terrain_Route123_FG.dgn These Terrains will be created using 

Graphical Filters to include all the features in 
each model including: 
• Corridors 
• Surface templates 
• Liner Templates 

Referenced to Default Model (No Nesting) 
HW_CB_1234_1234_Corridor_Route123.dgn 
Existing Survey Terrain Model (dgn) 

HW_CB_1234_1234_Terrain_SideRoad1_FG.dgn 
Referenced to Default Model (No Nesting) 

HW_CB_1234_1234_Corridor_SideRoad1.dgn 
Existing Survey Terrain Model (dgn) 

HW_CB_1234_1234_Terrain_SideRoad2_FG.dgn 
Referenced to Default Model (No Nesting) 

HW_CB_1234_1234_Corridor_SideRoad2.dgn 
Existing Survey Terrain Model (dgn) 

 

Complexed Finished Grade (FG) Terrain of entire project  
HW_CB_1234_1234_Terrain_Project_FG.dgn This file is only to have Reference files 

attached, there is to be no actual graphics in 
this file. A Complex Terrain will be created 
from all the terrains created above. 

Referenced to Default Model (No Nesting) 
HW_CB_1234_1234_Terrain_Route123.dgn 
HW_CB_1234_1234_Terrain_SideRoad1.dgn 
HW_CB_1234_1234_Terrain_SideRoad2.dgn 
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5.3 Contract Sheet Model DGN Files 
This section covers the reference files need to produce Plan, Profile and Cross Section Sheets.  
Specifics on other sheet types can be found in Volume 13. 

5.3.1 Plans 

HW_CP_1234_1234_Highway_Plans.dgn When referencing order is important. Always 

reference in survey files first so they show up at 

the bottom of everything else. The sequence can 

be updated, but sometimes the program has a 

glitch and does not cooperate with that function.  

For the plan view of the subset this is important 

to have everything appear in the correct order. 

 

Referenced to Default Model (No Nesting) 
Existing Survey 2D Model(s) (dgn) 
Existing Survey Terrain Model (dgn) 
HW_CB_1234_1234_Alignments.dgn  

Corridors as needed: 
HW_CB_1234_1234_Corridor_Route123.dgn 
HW_CB_1234_1234_Corridor_SideRoad1.dgn 
HW_CB_1234_1234_Corridor_SideRoad2.dgn 
HW_CB_1234_1234_Drainage.dgn 
HW_CB_1234_1234_Master_2D_Design.dgn 
HW_CB_1234_1234_ROW_Proposed.dgn 

5.3.2 Profiles 

HW_CP_1234_1234_Profiles.dgn  
Referenced to Default Model (No Nesting) 

HW_CB_1234_1234_Alignments.dgn  
HW_CB_1234_1234_Drainage.dgn 
Existing Survey Terrain Model (dgn) 

5.3.3 Cross Sections 

HW_CP_1234_1234_XSC_Route123.dgn 
HW_CP_1234_1234_XSC_SideRoad1.dgn 
HW_CP_1234_1234_XSC_ SideRoad2.dgn 

 

Referenced to Default Model (No Nesting) 
HW_CB_1234_1234_Alignments.dgn  
HW_CB_1234_1234_ROW_Proposed.dgn 
HW_CB_1234_1234_CrossSectionFeatures_Existing.dgn 
HW_CB_1234_1234_Drainage.dgn 
HW_CB_1234_1234_Corridor_Route123.dgn 
HW_CB_1234_1234_Corridor_SideRoad1.dgn 
HW_CB_1234_1234_Corridor_SideRoad2.dgn 
Existing Survey Terrain Model (dgn) 
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Exercise 6 - General Tools and Interface 

6.1 Ribbons 
Tools can be accessed a variety of ways, including the Ribbon, Search and Context Sensitive 
Menus. Ribbons are arranged by Workflows, which are selected from a pull-down in the upper 
left corner of the software. 

6.1.1 OpenRoads Modeling Ribbon 

1. Go to File Open and browse to Highway\Base_Models, open the file 
HW_CB_0047_0122_Corridor_Route140.dgn 

2. Activate the OpenRoads Modeling workflow, use the pick list in the upper left corner if 
it is not already active. 

 
Figure 24 – OpenRoads Modeling Workflow 

The ribbon menu will reflect the OpenRoads Modeling tools. The tools are organized into 
categories on the ribbon tabs. 

• Home - Common tools such as Attributes, Explorer, Attach Reference Tools, Models 
and Level Display. 

• Terrain - Terrain modeling tools. 
• Geometry - Civil AccuDraw and geometry tools. 
• Site Layout - Parking, pad, pathway, vertical geometry and grading site design tools  
• Corridors - Superelevation and corridor modeling tools. 
• Model Detailing - Civil Cells and 3D tools (Linear Templates, Surface Templates, etc.). 
• Drawing Production - Saved views, notes, text, annotations, and plans production 

(cross section, plan, and profile) tools. 
• Drawing - Commonly used MicroStation drawing tools. 
• View - Commonly used view control tools. 

A Search Ribbon tool is also available at the right side of the title bar. Use it to find tools 
across the multiple ribbons. When you are not sure where to find a tool, simply type the 
command in the Search Ribbon field and a search will be performed across all ribbon 
menus. 
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6.1.2 CTDOT Highway Ribbon 

The Highway tab on the CTDOT workflow will be used to place 2D Linear Elements, 
Shapes and Cells.   

 

 
Figure 25 – CTDOT Highway Ribbon 
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6.2 Models and Views 

The software often requires multiple models and views in one file. Understanding how to work 
with models and views is an essential skill for anyone working with the software. If you are 
opening a file with civil data in it, expect to see multiple models and views. Multiple models are 
used to create and manage horizontal, vertical, 3D and cross section data: 

• 2D Model is used for Horizontal Geometry.  
• Profile Model is used for Vertical Geometry. 
• 3D Model is used for 3D Geometry, Corridors, Survey Data and Terrain Models.  
• Cross Section Model is used for Cross Sections. 

“Real World” Civil Engineering starts with a horizontal plane and a set of engineering rules. 
Vertical design follows the horizontal paths and follows a different path when it comes to rules. 
For example, horizontal geometry typically uses circular arcs, vertical geometry commonly 
uses parabolas. Combine the two geometries to get 3D results. 

Some OpenRoads dgn’s have a single 2D or 3D models, but many design files have Multiple 
Models. 

The old InRoads software used an “external” proprietary file (.alg) to store geometry data. 
OpenRoads Designer exclusively uses the .dgn format (no external files) to store geometry 
data, the software stores geometry types in different models within a .dgn file. 

• Horizontal Geometry is stored in the default 2D Model. 

• Vertical Geometry is stored in a Profile Model view and associated to the horizontal 
geometry. 

Note: If a horizontal element has vertical information - one or more Profiles - then it “owns” a 
single Profile Model containing all its profile information. Profile Models are visible only by 
using the View Profile Model tool). 

Many design files contain a 2D and 3D Model, typically named Default and Default-3D, 
respectively. 3D Elements are created, managed and stored in the default 3D Model. 
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6.2.1 View Control 

Most Design Files contain a 2D and 3D Model, often named Default and Default-3D. 2D 
Elements such are horizontal geometry are created, stored and managed in a 2D Model. 3D 
Elements are created, managed and stored in the default 3D Model. In this section, you will 
learn how to review the 2D and 3D models. 

In OpenRoads Designer CONNECT Edition, an enhanced right-click view control option has 
been added. 

• Enables quick display of multiple views in one model including plan, 3D, dynamic 
profiles, dynamic cross sections and superelevation. 

• The “1 View” option will reset a view back to default if accidently set to a dynamic cross 
section or profile view. 

• When selecting a dynamic profile or cross section view, the grid will be turned on for the 
view.  

• Right Click in the View 1 Window and select the desired preset View Control window set-
up.  
 

1. Open the Models dialog. Click OpenRoads Modeling > Home > Primary > Models. 
• This file has a 2D Model named Default. 

• There is always one Active Model. It is indicated by the green highlight. 

• Recall, when we attached our project design files the existing ground terrain model 
was a 3D file and all other files were 2D files. Whenever you attach a 3D terrain model 
file to a new 2D file for the first time it is a best practice to set the terrain model as the 
active terrain. Doing so will automatically create a 3D model in the active file if one 
does not already exist. 

2. Locate Terrain Model to see if it’s been Set Active: Select the existing terrain model 
boundary. Notice the Terrain Model has been previously set active so a 3D Model has 
already been created for this file. 

 
Figure 26 - Active Terrain 
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3. Now, let’s review the 2D/3D Models and the 2D/3D Views. 
a. Right-click in View 1 and hold down the right mouse button. A menu will appear with 

commonly used commands as well as special view controls.  

b. Click on the 2 Views Plan/3D item. 
• View 1 and View 2 will appear tiled (side by side). 
• View 1 is the Default 2D model view and View 2 is the Default-3D model view. 

 
Figure 27 - View Controls 

c. Select the Fit View tool and click in each view to fit the view. The Zoom in as needed. 

 
Figure 28 - View Windows 
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d. Click on each of the Title Bars of the open Views to make them active.  
• The Model dialog will reflect the Active Model, updating as each view is clicked.  

• Note the View Title Bar lists the view number, the name of the model it is viewing 
and the model 2D or 3D status via an icon for 2D or 3D. 

 
Figure 29 – Active Model 

e. After Selecting the desired tool select Save Settings. 

6.2.2 Views and View Groups 

The software supports up to eight simultaneous view windows. The View Controls and 
behavior will differ depending on the model type, but any view can view any model. In this 
section, you will learn how to work with multiple views. 
1. Working with multiple views. 

• The current file should have multiple Views open. It is important to know which of the 
open views is the active view. 

• Views can be opened or closed from the View Toggles from the Manage View 
Groups toolbar. In the CTDOT WorkSpace, it is docked in the lower left corner. 

 
Figure 30 – View Toggles 

• The OpenRoads Modeling Workflow View tab also has the same View Toggles 
available. 

 
Figure 31 – View Tab 
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a. Click on any of the 8 View Toggles.  
Notice that Views Open or Close at your touch. They will open in different positions 
and may or may not show any graphics. 

b. Close all the Views except for Views 1 and 2.  
Any of eight available Views can view any model in the .DGN file. Each view is 
independently customizable in representation and perspective. Views can have 
different attributes enabled and levels can be turned on and off independently from 
other views. 

2. Review Model views using the View Groups 
View Groups allow managing multiple views with their varied models and settings. At the 
left side of the status bar on the bottom, a pull-down lists the pre-defined Models. Multi-
Model Views is generally the default view group most useful for civil design projects: both 
2D and 3D models will be shown with this setting. 
a. From the View Groups list, select the Default view group. 

b. Select the Default-3D Views 

c. Select the Multi-Model Views to return to the 2D and 3D model view setup. 

 
Figure 32 – View Groups 
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6.2.3 Multi-Model View 

Using the View Control tools creates a Multi-Model View. This can also be done manually. 
Open two views, on the View Attributes dialog box set View 1 to Default and View 2 to 
Default-3D. The active model will display both models in two separate views. Issue a Save 
Settings before moving on.   

 
Figure 33 – View Attributes 
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6.2.4 Profile Models and Cross Section Models 

So far, we have discussed 2D and 3D models. Now let’s look at Profile Models and Cross 
Section Models. Profile Models are used to display and create profile data and Cross  

Set up Model views for Plan, Profile, Cross Section and 3D Model. 

1. Right-click in View 1 and hold down the right mouse 
button. 

2. Click on the 4 Views Plan/Profile/XS/3D item. 

3. Follow the on-screen prompts: 
• Select OK to create a Dynamic Profile View. 

• Locate Plan Element: In View 1, select the Route 140 
alignment. 

 
Figure 35 – Select Alignment 

• Select or Open View: Click in View 5 

• Select OK to create Dynamic Cross Sections 

• Select the 140 Corridor in View 1. 

Note: You can also select the alignment the but with this option you will not see the 
crossing point annotations.  

 
Figure 36 – Select Corridor 

• Select or Open View: Click in View 7. Press <ESC> to exit the command. 
 

Figure 34 - 4 Views Plan/Profile/XS/3D 
item Tool 
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Figure 37 – Top Image XSC from Corridor / Botton Image XSC from Alignment 

Notice we have 2 new model views that appear: A Profile Model view and a Cross Section 
Model view. Profile Models and Cross Section models are special models only to view 
profiles and cross sections.  

 
Figure 38 - 4 Views Plan/Profile/XS/3D item. 
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A Profile Model is used to create, edit and view vertical geometry. The Profile Model View 
has some unique characteristics: 
• A Profile Model corresponds to one and only one horizontal alignment. 

• A Profile Model can display multiple profiles but only one can be active at any given 
time. 

• Associated horizontal geometry name is in the title bar of the view. 

• Elevation labels on left edge of the view and Station labels along bottom of the view. 

• This is a true profile space whose coordinates are station, elevation instead of X,Y. 

• The background colors indicate curvature of the horizontal alignment. 
o Normal background = straight 
o Cyan background = curve 
o Magenta background = spiral 

• When using the vertical commands, the cursor gives simultaneous feedback of location 
both in plan and profile. 

 
Figure 39 – Profile View 
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A Cross Section Model is used to display the dynamic cross section views. The dynamic 
cross sections are “live” references taken directly from the 3D model.  

The Cross Section Model view has some unique characteristics: 
• Associated horizontal geometry or corridor name is in the title bar of the view. 

• Elevation labels on left edge of the view and Offset labels along bottom of the view. 

• Cross section station navigator tool at the top of the view window. 

• This is a true cross section space whose coordinates are station, offset and elevation. 

 
Figure 40 – Cross Section View 
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6.2.5 View Controls 

In this section, you will learn how to use the view controls to zoom, pan, and fit views. Profile 
and Cross Section Model views have additional view controls such as Horizontal and 
Vertical Exaggeration. Horizontal and Vertical Exaggeration is often desirable when viewing 
vertical geometry and cross sections. 

6.2.5.1 Regular Model  
Views, by default, have a View Control toolbar located at the top of each view window. 
The exact tool layout varies by the type of Model that the View is displaying: 2D, 3D, Profile, 
Cross Section, etc. 

 
Figure 41 – View Controls 

The images shown above are the 2D, 3D, Profile and Cross Section view controls. 
• Hovering over an icon will display its name. 

• Note that view tools remain active until you right-click to exit them or until you click 
another tool. 

1. Practice using Zoom In and Zoom Out in the 2D and 3D Views. 
a. Left-click in the 2D or 3D View. 

b. Select the Zoom In button to zoom in. 

c. Select the Zoom Out button to out. 

d. Select Fit View. 

e. Click in the 2D or 3D View to set the focal point. 

f. Use the mouse wheel to Zoom In and Zoom out of the view. 

2. Practice using the Pan tool. 
a. In 2D or 3D, select the Pan tool. 

b. Left-press, pan to the left, right, up and down. 

c. Fit the view when done. 
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6.2.5.2 Profile Model 

1. Review and change the default Profile Model Exaggeration.  
a. In the Profile Model view, select the View Attributes. 

 
Figure 42 – View Attributes 

b. Navigate to Civil > Exaggeration. Notice the 
default vertical exaggeration is set to 10. 

c. From the drop-down list. Set the Exaggeration to 
20.  This option exaggerates the view vertically 
by a factor of 20.  

 

Horizontal exaggeration and vertical exaggeration can 
also be achieved using the mouse wheel. 
2. Let’s look at how to change horizontal and vertical 

exaggeration using the mouse wheel. 

a. Click in the Profile Model view. 

b. Position your cursor somewhere in the middle of 
the view to set the focal point. 

c. Use your mouse wheel to zoom in and out. Note 
this functions the same as it does in the 2D and 
3D views. 

d. Press <Ctrl> and use the mouse wheel to adjust 
the horizontal exaggeration. 

e. Press <Shift> and hold then use the mouse 
wheel to adjust the vertical exaggeration. 

 Figure 43 – Profile View Attribute 
Vertical Exaggeration 
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6.2.5.3 Cross Section Model 

The cross section view controls function in a similar manner as the profile view controls. 

1. Now let’s learn how to navigate to a single station. 
a. Select the drop-down arrow next to the station, a key-in window will appear. Type in 

109+40 and press <Enter>. 

b. The cross section view will now advance to station 109+40. 

 
Figure 44 – Enter Cross Section Station 

2. Review and change the Cross Section Model Exaggeration.  
a. In the station field enter 109+40 

b. In the Cross Section Model view, select the View Attributes. 

b. Navigate to Civil > Exaggeration tab. Notice the default exaggeration is set to 1. 

c. From the drop-down list. Set the Exaggeration to 2. 

 
Figure 45 – Cross Section Vertical Exaggeration 
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3. Horizontal and Vertical Exaggeration can also be set using the mouse wheel. Let’s look 
at how to change horizontal and vertical exaggeration. 
a. Click in the Cross Section view. 

b. Position your cursor somewhere in the middle of the view to set the focal point. 

b. Use your mouse wheel to zoom in and zoom out. Note this functions the same as it 
does in the 2D and 3D views. 

c. Press <Ctrl> and use the mouse wheel to adjust the horizontal exaggeration. 

d. Press <Shift> and use the mouse wheel to adjust the vertical exaggeration. 

4. Review the Cross Section View Properties. 
a. Select the View Properties drop-down list. 

Cross Section View Properties feature additional options for viewing the cross 
sections as you navigate the cross sections. Here you will see options to: 
• Fit Section - Fits the full width of the cross section into view. 
• Center Backbone - Centers the view around the cross section backbone. 
• Center on Current Offsets - Centers and holds the current view. 

 
Figure 46 – Cross Section View Properties 
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5. Navigate Cross Sections by Station 
a. Using the cross section navigator buttons at the top of the view select the First 

Station button. This will move the current cross section station to the first cross 
section.  

b. Use the Next Station button to advance the cross sections to the next station. 
Notice as you advance from station to station the cross section view is slightly 
zoomed out to fit the full width of the cross section. This is an example of the View 
Properties being set to Fit Section.  

Note: If you are viewing the Cross Section View from the Alignment it will advance 
to the set interval usually 50’, if the Cross Section View was set up from the Corridor 
it will advance by the cut interval density. 

 
Figure 47 – First, Advance & Last Station Navigation 

6. Sometimes it’s necessary to zoom into a specific focal point on the cross sections and 
navigate the cross sections zoomed and centered around this point. Let’s take a look at 
how to accomplish this. 
a. Set the cross section View Properties to Center on Current Offsets. 

b. Place your cursor near the top of the cross section pavement at the zero offset. 

c. Using your mouse wheel, Zoom In so until the side slopes fit within the view window. 

d. Use the Next Station and Previous Station buttons to navigate through the cross 
sections. Notice the cross sections will remain zoomed and centered around the 
focal point. 

7. Right-click in the cross section view to access other useful cross section tools such as 
Place Horizontal Temporary Dimensions, Place Vertical Temporary Dimensions and 
Locate Station By Datapoint. 

 
Figure 48 - Right-click in the cross section view 
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6.2.6 Rotating 3D Views 

This section will explore the View Rotation tool. It behaves differently depending on whether 
the view is looking at a 2D or 3D model. 
1. Rotate the 3D View to Top View. 

In the View 3 (3D View) View Control toolbar, left-press (a long left-click) on the View 
Rotation tool and select Top View from the list.   The view will now be rotated to Top 
View. 

2. Rotate the 3D View to Isometric View. 
In the View 2 (3D View) View Control toolbar, left-press (a long left-click) on the View 
Rotation tool and select Isometric View from the list. The view will now be rotated to 
Isometric View. 

 
Figure 49 – Rotate View 
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Views can be rotated dynamically by using the Rotate View tool with  
the Dynamic method tool setting. 

3. Rotate the View Dynamically. 
a. In View 2, left-press on the View Rotation tool and select Rotate View. 
b. In the Tool Settings dialog, ensure the method is set to Dynamic.  
c. Rotate View 2 by clicking the left mouse button and moving the cursor. Click when 

rotated to your liking.  

Note: You can click to initiate the rotation or click-drag to rotate dynamically. You 
can Snap to an object to make it the center of rotation. 

d. Reset (Right-click) to end the command. 

 
Figure 50 – Dynamic View Rotation 

4. In the View Control toolbox click View Previous to return to previous rotations. 

 
Figure 51 – View Previous 
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5. Rotate View 3 in 2D. 
a. For 2D rotation, there are fewer options: Dynamic, 2 Points or Unrotated.  

b. In View 1, click the View Rotation tool. 

c. Experiment with rotating this view. 

d. When done, use the Unrotated Method to return to a normal “North Up” rotation. 

e. From the Quick Access Toolbar select Save Settings.  The next time the file is opened 
the views will be arranged as they were when a Save Settings was last applied. 

 
Figure 52 – 2 Points View Rotation 
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6.2.7 View Display Styles 

Display Styles allow you to provide instant rendering of that data from wireframe to 
photorealistic Display Styles. Below shows the 3D model displayed 3 different ways (Upper 
left is Wireframe, lower left is Transparent, upper right is Smooth). In this section, you will 
learn how to change the 3D model display using Display Styles. 

The data in a view can be displayed in many ways: from linework-only (Wireframe) to 
photorealistic rendering (Smooth). 

You can change the Display Style to predefined modes via the view toolbar. 

Note: Display Styles are generally used more in 3D Models.  Illustration > Ignore Lighting is 
very useful. It provides a realistic look without having to adjust lighting. It still shows 
linework, which allows visual evaluation of engineering. For example, the lines shown at 
corridor template drops allow you to immediately confirm template spacing. Other 
realistic Display Styles, such as Smooth and Transparent rely on the View’s Lighting value. 
You’ll likely want to brighten the view by moving the slider to the right. 

Experiment with changing different Display Styles (Wireframe, Transparent, Illustration). 

 
Figure 53 – View Display Styles 
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1. In the 3D View, left-press on the Display Style List and pick Wireframe. 

 
Figure 54 – View Frame View Style 

2. Review the other Display Styles: Smooth and Transparent. 

3. Adjust the lighting if necessary, using Adjust View Brightness tool. 

 
Figure 55 – Adjust Lighting 

4. Set the 3D Model Display Style Illustration: Ignore Lighting. 
 



Volume 3.0 - OpenRoads Designer Getting Started 

52 
 

6.2.8 Analyzing Civil Data 

Knowing how to analyze civil data and information is an important skill needed for 
designing and reviewing projects. In this section, you will learn how to review coordinates 
and how to get station/offset/elevation information from civil elements. 

1. Review Coordinates 2D. 
a. In the lower right section of the Status Bar, right-click the Show/Hide tools area. 

b. Toggle ON the Running Coordinates. Notice the XY coordinates now appear in the 
lower right section of the Status Bar. 

b. Click in View 1 and move your cursor around. 

c. Review the Running Coordinates in the status bar. 

d. Snap to the beginning point of the Route 140 alignment.  

e. Review the XY coordinates. 

2. Review Coordinates in 3D. 
a. Click in View 3, Default-3D and move your cursor around. 

b. Review the Running Coordinates in the Status Bar. 

c. Snap to the beginning point of the London Rd. alignment feature in the 3D Model. 

d. Review the XYZ coordinates. 

 
Figure 56 – View Running Coordinates 
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3. Review Offsets and Elevations in Cross Section View. 
a. Click in the Cross Section View and move the cursor around. Notice how the running 

coordinates display offset and elevation in the Status Bar. 

b. Using the station navigation tools at the top of the view window, navigate to station 
109+40.00. 

c. Snap to the centerline point (zero offset) and review the offset/elevation. 

d. Snap to other points on the cross section and review the offset and elevation 
information. 

 
Figure 57 – Cross Section off Set and Elevation 

4. Use the Analyze Point tool to get station/offset/elevation information. 
a. Select Home > Model Analysis and Reporting > Civil Analysis > Analyze Point. 

b. Locate Element to Analyze Point: Select the Rout 140 alignment. 

c. Move your cursor along the horizontal alignment and note the 
station/offset/elevation information is being displayed dynamically as you move 
your cursor. 

d. Click in View 5 Profile Model and move your cursor along the profile. Note the 
station/elevation values and the vertical tracking bar in the profile view. Also, note 
that as you are tracking along the profile a crosshair graphic moves along the 
relative location in View 1. 
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As you can see this tool is useful for getting station/offset/elevation information from 
civil elements. 

 
Figure 58 - Analyze Point 
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Exercise 7 - Element Properties and Explorer 

7.1 Opening and Reviewing Properties 
The Properties tool is used to get detailed information about an element. Properties work 
similarly to manipulators in that they display the design intent and rule data as well as 
other detailed information. Most data in the property pane can be edited to change the 
element definition. In most Workflows, the Properties tool is available in the Home tab and 
Primary group. In this section, you will learn how to use the Properties tool to review an 
element’s properties. 

1. Go to File Open and browse to Highway\Base_Models, open the file 
HW_CB_0047_0122_Alignment_Hopkins.dgn 

2. Open and dock the Properties dialog. 
a. Click on Home > Primary > Properties. 

b. To dock the dialog, drag it by the title bar to a “docking glyph ”. 

Note: New and experienced users want fast access to it. Experienced users 
generally have it docked but collapsed. This way, the dialog is never more than a 
mouse movement and a single click away. 

c. Once you find a setting that you like, you can save by clicking the Save Settings 
tool. 

 
Figure 59 – Docking Properties 
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3. Review the properties of an element. 
a. Click the Element Selection tool. 

b. Click on the Hopkins Road Alignment. Review the Properties dialog. 
• The dialog has a top panel that contains an object tree view - an expandable 

hierarchy that shows the parent, children, and dependencies of the graphic. 

• Clicking on an element in the top panel will highlight it in the drawing if 
applicable. Right clicking objects provide context menu items. 

• The bottom panel contains the element properties, grouped by Expandable 
and Collapsible Groups. 

• Gray text is read-only. Other text may be editable or have a pull-down for item 
selection. 

 
Figure 60 – Arc Property Information 

3. Try using the spacebar to activate the popup shortcut menu. You can get directly to 
the Properties tool via the Primary button. 
a. Press <Spacebar>, a popup menu will appear. 

b. Select the Primary button, from here you can select Properties. 

 
Figure 61 – Popup tool shortcut 

4. Close the Properties panel. 
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7.2 Open the Explorer 

The Explorer is an essential tool when working with the software. The Explorer dialog allows 
you to manage and control project content. It is a single interface that provides browsing 
function for Items, OpenRoads Model, Sheet Index, OpenRoads Standards, Drainage and 
Utilities Model and Survey. One of the key tools in Explorer is the OpenRoads Model which is 
used to manage and organize civil project data that is stored in the design. In this section, 
you will learn how to open Explorer and review the layout. 

1. Open the Explorer and review the tools. 
a. From the ribbon menu click Home > Primary > Explorer.  

 
Figure 62 – Explorer tool 
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b. Expand and review each group by pressing the panel’s down arrow. 

• The Groups may be organized by Panel or by Tab: 

• If you want to change its looks or behavior, go to File > Settings > User and click 
Explorer Settings.  

File - Displays data related to dgn file such as Display styles, element template, 
text styles, levels, models and so on. 

Items - Displays non-graphical business data in a DGN file in hierarchical order.  

OpenRoads Model - Displays civil objects stored in the design file, objects such as 
Alignments, Terrain Models, Corridors, and so on. 

Sheet Index - Allows you to manage sheet indexing. A sheet index is an organizes 
and named collection of sheet models from one or more design files.  

OpenRoads Standards - Used to create, edit or review horizontal and vertical 
geometry design standards, feature information, civil cells, annotation, and 
graphical filters.  

Drainage and Utilities Model - Displays all the drainage and utilities data stored 
in the design file. 

Survey - Displays all survey data that is stored in the design file. 

 
Figure 63 – Explorer Settings 
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7.3 Explore the OpenRoads Model 
The OpenRoads Model group displays civil content in categories such as Alignments, 
Terrain Models, Corridors, and so on. Expanding each category lists items within that 
category or further sub-categories. It is usually a good idea to have the OpenRoads Model 
open so that you can clearly see the civil data stored in the design file. In this section, you 
will learn how to review Alignments using the OpenRoads Model. 

1. Review the Alignments via Explorer. 
a. Click on OpenRoads Model. 

b. Click the small arrow next to Alignments to expand the list to the Alignment Feature 
Definitions used in the Active Design file. 

b. Click the small arrow next to Centerline to expand the list. 

c. Click on a Feature to highlight it in the View. Select Complex Element: CL_Hopkins 
Road, observe that the Hopkins alignment is selected and highlighted in View 1 (or 
any 2D model). This is an example of how Explorer can be used to locate and select 
an alignment in the design file. 

 
Figure 64 – Select Alignment 
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Notice the bottom portion of the OpenRoads Model panel shows the other civil data that is 
referenced into this design file. 

2. Access tools via the right-click menu. 
a. Fit the View 

b. Right-click on Complex Element: CL_Hopkins Road to review other tools related to 
the alignment. Different object types offer different tools. 

c. Click Zoom to this will center the alignment in the active 2D View. 

b. Experiment with using the Isolate tool to isolate the Hopkins Road alignment. Notice 
how isolate turns everything off except the isolated alignment. Select Clear Isolate 
when done. Left-click in the view to de-select the alignment. 

 
Figure 65 – Zoom to 
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Exercise 8 - Element Display 

8.1 Reference File Display 

1. Go to File Open and browse to Highway\Base_Models, open the file 
HW_CB_0047_0122_Alignment_Hopkins.dgn 

2. Turn Off reference files. 
a. Click Home > Primary > Attach Tools > References. 
b. The References dialog opens. You use this dialog to attach/detach and manage 

reference files. 
c. Data Point in View 1 to make it the active View.  In the References dialog, select 

4710503.dgn 
d. Hold down <Shift> and select 4710505.dgn, the other references will be selected. 
e. Toggle OFF the display of the selected references by clicking the Display button 
f. Toggle them back ON and then close the References dialog. 

 
Figure 66 – References Dialog Box 
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8.2 Level Display 
1. Turn on and Off Levels 

a. Click Home > Primary > Level Display. 
b. Sort by used 
c. Click on the opened file and notice the levels 

• Teal will be the active level 

 
Figure 67 – Level Display 

2. Double Click on Align_Centerline to make it active 
3. Click though the tree of References and notice the on/off status of the levels 

• Blue Will be on 
• White will be off 

 
Figure 68 – Reference File Level Display 
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8.3 Element Selection 

The Element Selection tool is a core tool. It is used to select a single element or multiple 
elements. In this section, you will learn how to use the Element Selection tool. 

1. Practice using the Element Selection tool. 
a. Select the Element Selection tool and left-click the Route 140 

alignment to select it. 
• When the element is selected it will highlight in the view. 
• Selected element(s) are considered to be a Selection Set. 

 

 

b. Notice in the status bar the Active Selection Set indicator reflects how many elements 
are in the selection set (in this case only 1). 

The Status Bar features the “prompt” on the left side of the status bar. The text in the 
prompt lets the user know what the current tool is and what to do next. In the example 
shown, the active tool is Element Selection, and the prompt is Identify element to add to 
set. 

 
Figure 70 - Bottom Menu Information 

c. Set the Element Selection mode to Add. 

 
Figure 71 – Add Elements to Selection 

d. Select the Hopkins Road alignment near the end of 140. This element will be added to 
the selection set. 

 
Figure 72 – Bottom Menu Information 

Figure 69 – Element 
Selection 
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e. Select the Clear button to de-select the elements. 

 
Figure 73 - Clear 

f. Select the Select All button. All elements in the active model (not in reference files) will 
be selected and highlight. 

 
Figure 74 – Select All 

g. Select Clear to de-select all elements. 

This will reset the Element Selection mode back to the default mode of Individual and 
New. 

Tips: 

• When the Element Selection tool is active, the Tool Settings dialog has options for the 
selection Method (Individual, Block, Shape, Circle and Line) and Mode (New, Add, 
Subtract, Invert, Clear and Select All). Extended settings can be accessed via the drop 
arrow to select elements by MicroStation attributes like level, color, line style, etc. 

• Multiple elements can be selected by a window selection by dragging the cursor, left-
to-right for ‘inside’ the window, right-to-left for ‘inside and overlapping’ the window. The 
<Ctrl> key can be pressed to add or remove elements from the selection set. 

• Sometimes multiple elements lie within the location area of the cursor. Right-clicking 
(reset button) will cycle through elements that lie in the tolerance circle.  

• Selected element(s) are considered to be a Selection Set. To clear a Selection Set, click 
in an area where no elements are located (‘in space’) or by clicking the Clear mode 
button in the Tool Settings dialog. 
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2. Another Dialog Box that is helpful is Select By Attributes. This can be found on the CTDOT 
Workflow.  Home > Selection > Select By Attributes. 

 
Figure 75 – Select by Attributes 
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Exercise 9 - Explore Civil Elements and Features 

9.1 Tooltips 
All civil data (terrain, geometry, corridors, etc.) is stored and managed in the .DGN file. A major 
component of the civil data is the Feature Definition which controls the name and symbology 
of civil graphical elements. A civil graphical element is known as a Feature, and a primary 
property of the Feature is the Feature Definition. When you hover your cursor over civil data in 
the .DGN file a tooltip with important information about the Feature will be displayed (Feature 
Type, Feature Name, Feature Definition, Level, etc.).  
 
In this section, you will learn how to get information from the tooltips. 

1. Go to File Open and browse to Highway\Base_Models, open the file 
HW_CB_0047_0122_Alignment_Route140.dgn 

2. Review 2D and 3D Features using via the tooltips. 
a. Click the Element Selection tool.  
b. Make sure the 2D view is active by left-clicking in View 1. 
c. Hover your cursor over the Route 140 alignment in the active view to see a tooltip. 

• Tooltips are pervasive throughout Bentley software. They almost always show the 
object Type and the Level it is on.  

• We can see that this element is a Feature with a name of CL_Route140 and a Feature 
Definition of Alignment\Center\Centerline.  

• You can also see that this is a Complex Element on the Level ALIGN_Centerline. 
• You can see that the name of the Active Profile is CL_Route140. 
• A primary property of horizontal geometry is the Active Profile. A horizontal alignment 

can have multiple vertical alignments but only ONE can be active at a given time. 

 
Figure 76 – Tool Tips 
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9.2 Adjusting Manipulators and other Settings 
The manipulators and other design file settings can be edited to suit your preferences in the 
BackStage. In this section, you will learn how to adjust the size and color of the manipulators 
and also how to adjust the formatting and accuracy of geometry. 

1. Change the size and color of the manipulators. 

a. Activate the BackStage by clicking File in the ribbon menu. 

b. Select Settings > User > Preferences 

c. Click on View Options - Civil. The Manipulator Settings group is used to adjust how the 
Heads Up Display looks. 

d. Change the Manipulator Size to 20.0 

e. Change the Normal Color [255,0,255] 

f. Change the Manipulator Font to Tahoma. 

g. Click OK to save any changes. 

h. Click the arrow in the upper left corner to return to the main ribbon interface. 

 
Figure 77 – Manipular Settings 

i. In View 1, select the Route140 alignment and notice the manipulator sizes, colors and 
text font have now changed.  
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j. The formatting and accuracy of the geometry values and the station formatting and 
precision set per file.  CTDOT has preset this according to our standards. 

• The linear geometry formatting and accuracy is defined in Design File Settings > 
Working Units.  

• The angular formatting and accuracy are defined in Design File Settings > Angular 
Readout.  

• Station formatting and precision is set in Design File Settings > Civil Formatting. 

2. These can be viewed in the BackStage view. 

a. Select Settings > File > Design File Settings to access the Design File Settings dialog. 

b. Select Working Units, notice the accuracy 

c. Select Angular Readout, notice the accuracy 

d. Select Civil Formatting, , notice the formatting and accuracy 

e. Click OK to complete. 

b. Press <ESC> to return to the main screen. 

 
Figure 78 – Design File Formatting 
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9.3 Selecting a Feature to Review and Edit Geometry 
Selecting (single click on) a Feature displays editable text and element manipulators. It allows 
you to see geometry values, relationships and other properties instantly. Different controls 
show up depending on the tools used to create the Feature. You can instantly infer the Design  
Intent with which it was created. It is also a very robust editing interface. 

1. Go to File Open and browse to Highway\Misc, open the file HW_NC_0047_0122_ 
Element_Manipulators.dgn 

2. Review geometry manipulators, rules and relationships. 
a. Continuing with the Element Selection tool click on the CL_Mainline, CL_SideRoad 

alignments and the ROW_Line Geometry. Notice drag handle arrows, editable text 
manipulators, snap indicators, etc. are displayed for each element clicked. 

b. Click on arrows and circles to move, click on text to key in new values. The arrows and 
circles are known as Drag handles and the editable text is known as Text manipulators. 

 
Figure 79 - Element Manipulators 
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Manipulators are presented as follows:  
Text manipulators - These can be clicked to make them editable, which lets you type in 
new values. Examples of this are the distance and direction text manipulators in the 
previous image.  
Drag handles - These are handles that you can click and drag to redefine the element.  

• An arrow shaped drag handle - redefines the point with one or more directions 
constrained. In the previous example, the parallel arrows (that are parallel to the 
line) are constrained to change the distance only; the arrows that are perpendicular 
to the line are constrained to change the direction only. 

• A circular shaped drag handle - moves the points without constraint.  
• Interval drag handle (not shown) - This type of drag handle is present any time one 

of the MicroStation Modify commands are used on a civil element. This drag handle 
is used to change the location of the interval end point. 

 
Figure 80 - Handlers 

Snap icons - If a point was created by a snap, the manipulator is shown as a circle with the 
appropriate snap icon next to it.  

• Hovering over the end point reveals the drag handles, which can then be used 
normally as described above. Utilizing a revealed handle removes the snap and 
applies a new constraint to the point.  

 
Figure 81v – Snap Icons 

Civil AccuDraw constraint - A point that was created with a Civil AccuDraw constraint will 
show the appropriate Civil AccuDraw information in the form of text manipulators. Hovering 
over the point will reveal the drag handles which can then be used normally as described 
above. Utilizing a revealed handle removes the AccuDraw constraint and applies a new 
constraint to the point. 
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9.4 Civil Context Menu 

The Civil Context Menu is a shortcut menu to other tools that can be used with a selected 
element. In this section, you will learn how to access  

the Civil Context Menu. 

1. Access and review the Civil Context Menu. 

a. Click on the 2D View to ensure it is active. 

b. Click on the long alignment named CL_SideRoad so that it is selected. 

c. Leave the cursor on (or move the cursor back to) the selected feature. A semi-
transparent Civil Context Menu appears. 

Tip: If the cursor is on a manipulator, it thinks you want to use the manipulator rather 
than use the Civil Context Menu. You will need to hover over the feature in an area free of 
controls and manipulators. Zooming in closer may help. 

 
Figure 82 - Civil Context Menu 

d. Move the cursor into the Civil Context Menu. It will lose its transparency; you will be able 
select a tool. 
• Tools available depend on the Feature Type. 

• Note that all tools shown in the Civil Context Menus are available from a Ribbon 
location as well. 

e. Click Properties tool.  A “temporary dialog” with some editable fields.  

 
Figure 83 - Civil Context Menu 
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f. Move the cursor onto the dialog to keep it visible and review the Properties. 

g. Change the Feature Name to DOT_ParkingLot. Any field that is gray cannot be edited or 
changed. 

Note: There is a glitch with OpenRoads, when you change the name of an alignment 
the whole line becomes red instead of the standard Red Lines and Pink Curves.  To fix 
this temporarily change the Feature Definition to Centerline - Green and then back to 
Centerline. 

 
Figure 84 - Civil Context Menu Information 
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9.5 On-Screen Heads up Prompts 

All civil tools display on-screen heads-up prompts, which accept the inputs needed to create 
each element or object. Dynamic feedback is displayed while you are creating elements. It is 
another way of providing useful information while maintaining focus on the work. In this 
section, we will explore some of the on-screen prompts when creating elements. 

Review on-screen heads-up prompts. 

1. Place New Geometry 
a. Select Geometry > Horizontal > Lines > Line Between Points 

b. In the toolbox settings dialog set the Feature Definition to Alignment > Centerline > 
Driveway. 

c. The Name field is automatically populated with the default name DCL. 

d. Follow the on-screen heads-up prompts attached to your cursor: 
Enter Start Point: Left-click anywhere in View 1. 
End Point: Distance: Key in 500 and press <Enter> to lock the value. 
Use the left or right arrow key to navigate to the Direction field. 
Key in N83:00:00:E and press <Enter> to lock the value. 

e. Left-click to complete the command. 

 
Figure 85 - On-screen heads-up prompts 

As you can see information can be entered directly from the on-screen heads-up prompts 
attached to your cursor. You will also notice the toolbox settings dialog will appear when you 
choose a tool or command. You have the option of using the toolbox settings dialog or  
the heads-up on-screen prompts to enter values. 
Important information when working with on-screen prompts: 

• <Enter> or <Tab> is used to lock values. <End> is used to unlock values. 

• The left and right arrows are used to navigate to other fields in the command.  

• <ESC> can be used to exit out of a tool or command completely. Right Click or Reset can 
be used to cancel a command. 

• Left-click is used to advance to the next on-screen prompt in most tools. 
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2. Edit Geometry 
When any element created by a Civil Geometry tool is selected, certain manipulators are 
displayed dynamically. These manipulators vary by element type. 
a. Select the ROW line and select to edit -35’ offset 
b. Enter: -40 
c. Notice the line offset adjust to the new value 

   
Figure 86 - Manipulators and Handlers 
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9.6 Civil Message Center 
The Civil Message Center Provides feedback on a variety of issues that can affect the design 
process, such as errors in constructions and design standards that have been violated. 
 
1. To access the Civil Massage Center select Geometry > General Tools > Standards > Civil 

Message Center. 

 
Figure 87 - Civil Message Center 

 



Volume 3.0 - OpenRoads Designer Getting Started 

76 
 

Dataset Install for Self-Paced Training 
The training data set is stored in SharePoint for those doing self-paced training. 

1. In Microsoft Edge browse to:  DOT CTDOT_DDE - Training Datasets - All Documents 

2. Click on Training Data Sets and select Volume 3_0.  Click on the three dots … and select 
Download. 

 
Figure 88 - DDE SharePoint Page - Download Training Dataset 

3. CTDOT employees - In File Explorer under This PC browse to Downloads and copy the 
Active_Survey, Highways\Base Models folders to your Non-Project Work Area. 

C:\Users\yourname\OneDrive - State of Connecticut\CAD_NonProjects\Design\ 

Consultants or those who would like to work outside of one drive can create a working 
folder on their computer.  

4. When launching the application In CAD Accounting use the Non-Projects option for Run 
Program. 

https://ctgovexec.sharepoint.com/sites/DOTCTDOT_DDE/Training%20Datasets/Forms/AllItems.aspx?npsAction=createList&viewid=8f89c469%2D37fb%2D4ee2%2Da674%2D12cf04a332b6
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