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Course Overview 
This course teaches how to efficiently modify and use existing templates, such as those delivered 
in the Workspace, for your project situations. You will learn how to manage template libraries and 
edit templates to satisfy project specifications.  

Skills Taught  
Learn how to: 

• use the Template Library Organizer to copy templates from the standards template library 
to the project template library 

• assemble a template from pavement, curbing, and end condition components 

• edit roadway templates 

 

DGN File uses: 
Exercise 1 – Highway\Base_Models\HW_CB_0047_0122_Corridor_Route140.dgn 
Exercise 2 – Highway\Base_Models\HW_CB_0047_0122_Corridor_Route140.dgn 
Exercise 3 – Highway\Base_Models\HW_CB_0047_0122_Corridor_Route140.dgn 
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Exercise 1 – Getting Started 

1.1 Introduction 

Templates are made up of components which in turn are defined by points. One or more 
components combine to create a template. Components can be closed shapes such as an 
asphalt layer, or they can be open shapes such as cut and fill slopes. Examples of components 
include curbing, sidewalks, asphalt layers, aggregate layers, median barriers, or the side slopes 
to be used when in cut and fill areas. 

 
Figure 1 – Points and Components 

Templates represent cross sectional geometry. A 3D model is created by extruding the 
template along a 3D geometric path. As the template is extruded the template points 
connect longitudinally to create 3D surfaces and meshes.  Templates can be used along a 
road or rail centerline and profile grade line using Corridor tools to model a roadway but 
they can also be applied along any 3D geometry using the Apply Linear Template tool.  For 
example, a curb template can be applied around a traffic island.  Templates are stored in a 
Template Library File, which has the file extension .itl. 

The Create Template command generates the transverse geometry that is the central to 
roadway design. A template is comprised of a series of points and components that 
represent breakline features that are later processed using the Roadway Designer 
command. Roadway features that have been processed are saved to the design surface. 
Templates are stored in a template library (*.itl). In simple terms, the template is a “smart” 
typical section that you “push” along an alignment to create the proposed 3D model.  
Template tools can be accessed by selecting Corridors > Template > Create Template.  

 
Figure 2 – Corridor Tools 
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Figure 3 – 3D View 

 

 
Figure 4 - Example of a template for a 2-Lane undivided highway 
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1.1.1 CTDOT Point Names 

An example of the standard point names with suffixes are listed below: 
Point Name Description 
EOR Edge of Road on Top Surface 
EOR_b Edge of Road on Pavement Base Course 
EOR_sb  Edge of Road on Subbase 
EOR_sg  Edge of Road at Subgrade 
EOR_pa Edge of Road on Processed Aggregate 

List of Point Name (prefixes): 
Prefix Point Name Description 
BCLC Bituminous Concrete Lip Curbing 
BCPC Bituminous Concrete Park Curbing 
BOC Back of Curb 
CC Concrete Curb 
CL  Centerline 
CPC  Concrete Park Curb 
CUT  Cut Slope Limit 
DNC  Do Not Include 
EOR  Edge of Road 
FILL  Fill Slope Limit 
GC  Granite Curb 
GSC  Granite Slope Curb 
SHDR  Shoulder 
SNOW  Snow Shelf 
TRWY Travelway 
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1.1.2 CTDOT Component Names and Features 

When creating new Components in the Template Library the Mesh Feature 
Definitions defined in CV_Highway_Features_Levels_ElemTemp.dgnlib should be used.  

The component feature definitions can be reviewed by browsing to the following folder in 
the Civil Standards tab: Libraries > Feature Definitions > Mesh  

 
Figure 5 - Component Names 
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Component Names and Features can be reviewed and edited by double-clicking on a 
component to open the Component Properties dialog. 

 
Figure 6 - Component Properties 
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1.2 Opening the Application 

Before starting this exercise: 
1. The CTDOT CONNECT DDE synced through SharePoint 
2. The COMPASS Training Project Synced (i.e. 9999-0001 – Design) 

 
3. Launch the Application.  On your desktop double click on the Accounting Icon. 

 
Figure 7 - CTDOT CAD Accounting Icon  

4. On the CTDOT Accounting Menu there will be several applications to pick. In the Run 
Program field select the needed program: 

• Compass OpenRoads CE 
• for the Available Account select OVERHEAD for training proposes.  
• Click on the Start button to load the program. 

Notes for working on actual projects: 
1. CTDOT users should have the CTDOT CONNECT DDE synced through SharePoint with 

the COMPASS Project Synced along with the CAD Configuration.  
2. Consultants should have CTDOT DDE properly installed or be syncing to the CTDOT 

DDE SharePoint/COMPASS system. 
3. Make note of the Coordinate System you will be working in. If you have existing 

survey data, you will need to find out what system is being used (NAD 83/NAVD 88 or 
NAD 27/NAVD 29).  

4. Log on to the CONNECTION Client. Bentley Connect licensing requires users to log into 
their Bentley account to secure a software license. CTDOT users should log in using 
your CTDOT email address and Bentley password. If you do not see the dialog 
box, select the ˄ icon on the bottom Windows Screen. Click on the Connection Client 
Icon and select Open. 
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Figure 8 - CTDOT CAD Account Dialog Box 

5. After launching the program, a Welcome Screen for OpenRoads Designer will appear.  

6. Ensure you are using the Custom Configuration and CT_WorkSpace, then select the 
relevant WorkSet (Training WorkSets start with 9999_0001, select the # that you were 
assigned) and Role.  

7. Browse to: Highway\Base_Models\HW_CB_0047_0122_ Corridor_Route140.dgn 

 
Figure 9 – OpenRoads Start up Screen 
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8. In the upper left select the OpenRoads Modeling Workflow, and click on the Corridors tab. 
The commands are separated into five main categories: 

• Create 
• Edit 
• Miscellaneous 
• Superelevation 
• Review 

 
Figure 10 – Corridor Tools 
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1.3 Setting up the Project Roadway Templates  
Templates are used to define the typical section for each alignment. Multiple templates can be 
used to define different typical section designs, or the template geometry can be modified 
using a variety of corridor editing tools. 

CTDOT provides a sample template library in the following folder: 
...CT_Configuration\Organization-BIM\_CT_Civil Standards\Template 
Library\CV_ORDTypicals.itl 

A blank ITL file can be found by default in the highway design folder  
…Highways/Eng_Data/Project_Typicals.itl. 

Required individual templates will be copied over from 
CV_ORDTypicals.itl to Project_Typicals.itl using the Template Library Organizer. 

Please note: Any other disciplines modeling a corridor can copy a blank ITL 
from …CT_Configuration\Organization-BIM\_CT_Civil Standards\Template 
Library\Project_Typicals.itl and paste the file into the discipline-specific folder for 
engineering data: 

Discipline project location of ITL: 
• Bridge/Eng_Data/ 
• Envir/Eng_Data/ 
• F_Civil/Eng_Data/ 
• Geotech/Eng_Data/ 
• Hwy_Man/Eng_Data/ 
• Hwy_Ops/Eng_Data/ 
• Hydro/Eng_Data/ 
• Illumination/Eng_Data/ 
• Landscape/Eng_Data/ 
• Public_Trans/Eng_Data/ 
• R_Catenary/Eng_Data/ 
• R_Signals/Eng_Data/ 
• R_Track/Eng_Data/ 
• Traffic/Eng_Data/ 
• SVY_District/_Eng_Data/ 
• PMaps/ 
• SVY_Central/ 
• SVY_Consultant/ 

Warning: 
Do not change the name or path of the 
Project_Typical.itl file.  
 
If this file name gets modified after Templates are 
placed in a Corridor the Synchronize with 
Library tool will not be able to update itl edited 
templates. 
 
This path is also set as a variable used across all 
projects so your file will always be read in. 
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1. Select OpenRoads Modeling > Corridors > Template > Create Template 

 
Figure 11 Create Template Tool 

2. The Template Library will open to …Highways/Eng_Data/Project_Typicals.itl. 

 
Figure 12 Project Typicals File 

If the template library is pointing to a random place or file please do the following.  

a. Go to file explorer and copy …DOT CTDOT_DDE – 
Connect\CT_Configuration\Organization-BIM\_CT_Civil Standards\Template 
Library\Project_Typicals.itl 

b. Paste the file into …Highways/Eng_Data/ 

c. Any other disciplines modeling a corridor can copy a blank ITL 
from …CT_Configuration\Organization-BIM\_CT_Civil Standards\Template 
Library\Project_Typicals.itl and paste the file into the discipline-specific folder for 
engineering data: 

d. Now back in the Create Template select File > Open and open the .itl file you just copied 
to your project. 
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1.4 Copy Typical Sections Templates into Project Library 

Sometimes you will need to copy templates from one template library to another. A common 
use of this is to copy templates from your CTDOT standards template library (which is read 
only) to your project template library where you can edit the templates as necessary. 

In this section, we will use the Template Library Organizer to copy existing templates from the 
CTDOT template library into the project template library so we can then include the curbs on 
our template. 

1. In the Create Template dialog box select Tools > Template Library Organizer… 

This dialog allows dragging and dropping of templates and folders between the active 
template library and another template source. The active template library (our standards 
library that loaded automatically when we restarted the software) is displayed on the left. 

 
Figure 13 - Template Library Organizer Pull Down Tool 

2. Select Browse… 

 
Figure 14 - Template Library Organizer Browse Button 

3. Browse to …CT_Configuration\Organization-BIM\_CT_Civil Standards\Template 
Library\ CV_ORDTypicals.itl and click Open. 

The template library you opened is shown on the right side of the window. The active 
template library is shown on the left side of the window. 

4. Expand the right hand Available in folders and to view HWY Typical Sections 

5. Drag 2ln_HMA_BCPC and 2ln_HMA_NC from the right to the Project Library folder on the 
left. 

You have now copied over two roadway templates. You can also copy an entire folder and 
all of its contents from one template library to another by dragging a folder over. 

6. When complete click OK. 
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• The templates and components are organized in the template library using a folder 
structure much like files are stored on your computer. The template folder tree appears 
on the left side of the dialog. 

• To navigate the folder structure, double-click the folders you want to open or close. The 
organization of the folder structure is user-definable. The folder structure also supports 
common Windows functions, such as drag and drop, cut and paste, etc. Most 
commonly-used commands can be accessed by right-clicking on the folder and 
template names.  

• Double-clicking a template name sets it as the active template. The Active Template is 
signified by a red box around the template icon. The Active Template is also displayed in 
the center of the dialog box. 

 
Figure 15 - Template Library Organizer Dialog Box 

7. Save the template library. 
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1.5 Point Names and Features 

CTDOT’s template library is supplied with many template components defined that can be 
used as the starting point for creating and editing templates for a project. The folders in this 
library contain various Components and End Conditions that can be used to create completed 
templates. These components use CTDOT Standard Point Names, Component Names and 
Feature Definitions. If a user decides to create templates from scratch, it's important to 
remember that each point and component in the template is assigned a Name and a Feature 
Definition. It is imperative to ensure that the points and components are named and assigned 
features consistent with CTDOT standards.  

Feature definitions for template points and components are defined in 
CV_Highway_Features_Levels_ElemTemp.dgnlib, which is attached by a configuration 
variable. As the template is applied to the corridor, 3D line strings are drawn in the design file 
by connecting the points from template drop to template drop by their Name. The symbology 
of these line strings is controlled by the Feature Definition that is assigned to each point. The 
CTDOT CONNECT DDE includes a multitude Feature Definitions that can be used for template 
points. 

The point feature definitions can be reviewed by browsing to the following folder in the Civil 
Standards tab:  Libraries > Feature Definitions > Linear > Roadway Modeling > Template 
Library 

The component feature definitions can be reviewed by browsing to the following folder in the 
Civil Standards tab:  Libraries > Feature Definitions > Mesh > … 

Templates are defined by inserting Points, Components.  

1. To view a standard Roadway Template double-click Project Library  to expand the folder. 

2. Double-click on the 2ln_HMA_NC template to make it active and editable.  The template is 
now displayed. This template is made up of pavement and base components for the 
pavement and shoulders. The side slopes are made up of end condition components which 
are used to tie down to an existing terrain model. 

 
Figure 16 – Open Roadway Template 
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3. In the Template Display Window click on the Point EOR_lt. In the Point Properties notice the 
Feature Definition. Review the other settings and Close the box. 

Template Points - The points of a template represent breakline features that will be 
created when the template is processed using the Roadway Designer command. Points 
have a name and feature style; there is no limit to the number of points in a template. Once 
processed in Roadway Designer as features, they are saved to the design surface. 

 
Figure 17 – Point Properties 

4. In the Template Display Window click on the Top Component HMA_S5. In the Component 
Properties notice the Feature Definition. Review the other settings and Close the box. 

Template Components - A component is a set of points that define an open or closed 
shape. Each component, whether open or closed, can represent a different material or area 
of interest. Components are named and have an assigned feature style. There are 6 types 
of components created in InRoads: Simple, Constrained, Unconstrained, Null Point, End 
Condition, and Overlay/Stripping. 
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Figure 18 – Component Properties 
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1.6 Change the Widths and Slopes of a Pavement Section 
In this section, we will review the widths and slopes of a pavement section in an existing 
template. We also will change the width and slope of the Edge of Pavement (SHDR_rt) using 
two methods. The first is to directly edit the point. The second method we will edit the 
Parametric Constraint so all points update at once. 

1. Double-click Project Library  to expand the folder. 

2. Double-click on the 2ln_HMA_NC template to make it active and editable. 

The template is now displayed. This template is made up of pavement and base 
components. The side slopes are made up of end condition components which are used to 
tie down to an existing terrain model. 

Templates utilize constraints to define the relationship between template points such as 
the distance or slope between two points. Each point can have up to two constraints which 
is considered a fully constrained point. A fully constrained points position is fixed relative to 
its parent point(s). A point with one or zero constraints is free to move in one or more 
directions. 

In the image below, the CL point is unconstrained (green) and the SHDR_rt point is fully 
constrained (red). The SHDR_rt point is located 12 feet from the CL (parent) and at a slope 
of -1.5% from the CL (parent). In this example, the parent is the same for both constraints 
but that is not a requirement. 

 
Figure 19 – Point Constraints 
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The number of constraints a point has is easily identifiable in the interface by the color of 
the plus sign that represents the point. 

• + Red = Fully constrained point with two constraints 

• + Yellow = Partially constrained point with one constraint 

• + Green = Unconstrained point with zero constraint 

The sign of constraint values is also important. 

• The distance is positive if the parent has a lower X or Y value than the child. 

• The distance is negative if the parent has a higher X or Y value than the child.  

• The sign of the component slope is based on the mathematical slope. 

 
Figure 20 

3. Review the SHDR_rt template point properties. 

a. Using the wheel mouse button Zoom in so the SHDR_rt point is easily visible. You can 
also use the zoom buttons at the bottom of the template display window. 

b. Double-click on the SHDR_rt point.  

c. The Point Properties dialog appears. At the bottom of the dialog are the constraints that 
define how the SHDR_rt point is geometrically constrained to the CL point. 
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Figure 21 – Point Properties 

4. Change the point using the direct method. 

a. If the Point Properties dialog is closed, Double Click on the SHDR_rt point. 

b. Change the Horizontal constraint value (representing pavement width) to 11 feet 

c. Select, Apply. 

d. The SHDR_rt point is moved to be 11 feet from the CL point. The points below SHDR_rt 
also adjusted because they are constrained to be at a 0 horizontal offset from the 
SHDR_rt point. 

e. Use the zoom tools at the bottom of the template window to adjust the display if 
necessary. 

f. Type -2.0% for the Slope constraint value.  

g. Select, Apply. 

The points below SHDR_rt also adjusted because they are constrained to be at a 0 
horizontal offset and fixed vertical offset from the SHDR_rt point. 

h. Close the Point Properties dialog. 
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5. Change another point using the direct method. 

a. Double Click on the CL_sg point. 

b. Change the Vertical constraint value (representing pavement depth) to -1.5 

c. Click Apply. 

d. Close the Point Properties dialog. 

e. Zoom out to view the full pavement width. 

The subbase depth updated but only for this single point. We could edit the other points at 
the bottom of the pavement layer but that would be time consuming and there is a more 
efficient method using Parametric Constraints. This vertical constraint uses the Label 
named Subbase Depth. All of the subgrade points use this same label. The label is defined 
in the Point Properties window. 

 
Figure 22 – Depth Constraint 

6. Undo the previous change to the pavement depth. 
Select the Undo icon at the bottom of the Create Template window (not the 
MicroStation/CAD tools Undo) to undo changing the pavement depth. 

 
Figure 23 – Undo icon 
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7. Change the concrete subbase depth by adjusting the Subbase Depth Parametric 
Constraint. 

The values in the Label fields are Parametric Labels or Parametric Constraints. These labels 
allow the same values to easily be defined across multiple points. In addition, these values 
can be changed as the template is being extruded resulting in variable thicknesses, slopes, 
offset distances, etc. 

a. Select the Active Template tab on the bottom left side of the Create Template dialog. 
The Active Template view replaces the tree view of the template library with a list of the 
elements and values in the active template. 

b. Expand the Parametric Constraints list. 
The Parametric Constraints group lists the predefined constraint value “Labels”. These 
values can be set here as a constant for all templates in this template library.  

Parametric Constraints can also be changed at runtime as the template is dropped 
along a corridor. Every corridor has the ability to set any of the templates values 
station-by-station using the Corridor’s Parametric Constraints functionality (visit the 
learn.bentley.com for additional training on using templates to model a corridor). 

c. Double-click on the Subbase Depth parametric constraint. Notice the default value. 
The Edit Default Parametric Value dialog opens, and the point(s) constrained by the 
value are highlighted. There should be 5 points highlighted. 

d. Change the Subbase Depth default value to -1.5.  

e. Select OK and observe the changed depth across the entire template. 

f. Save the template library. 

 
Figure 24 - Parametric Constraints 
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Exercise 2 - Assemble a Template from Components 
In this section, we will create a new template by assembling existing components already in the 
template library. 

Basic Steps 
While the process to create templates will have many variables, the general procedure to create 
templates is summarized below: 
1. Copy the needed CTDOT Standard Roadway Templates to the Project's Master 

Library. Templates can be copied from one library to another by selecting Tools > Template 
Library Organizer from the Create Templates dialog. 

2. Create a new template or copy a template. 

3. Drag and drop template backbones or individual components into the active template. 

4. Create/edit the components as necessary. 

5. Merge components as desired. 

6. Add Parametric Constraints Labels 

7. Review the point names and point name overrides. Assure Left and Right are properly set. 

8. Review the component names and component name overrides. 

9. Test the template behavior. 

10. Save the template library. 
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2.1 Copy over Template Components 
In this section, we will set up the template options to be able to efficiently assemble 
components. 

1. Select OpenRoads Modeling > Corridors > Template > Create Template 

2. Open the Template Library Organizer. 

3. Create a folder names Exercises. 

4. Browse to open the CTDOT standard library and copy over to the following to the new 
Exercise 2 folder: 
HWY End Conditions\Cut_for_Curb 
HWY End Conditions\Cut_for_Ditch 
HWY End Conditions\Fill 
HWY Mics Components\HMA\1Ln 
HWY Mics Components\HMA\1Ln_BCPC 

 
Figure 25 – Template Library Organizer 

5. Click OK, the Template Library Organizer will close. 

6. Save the template library. 
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2.2 Setup Template Options 

1. Open the Dynamic Settings by clicking the icon at the bottom of the template window or 
selecting Tools > Dynamic Settings. 

• The Dynamic Settings dialog has many inputs and controls you will use when 
creating and editing templates. 

• The current cursor position is shown at the top left corner. 

2. Define the Step Options 

The step options setup a snap grid in the templates window making it easier to drag and 
drop components and points accurately. These values can be adjusted at anytime. 

a. Set the Step Options X value to 1.0.  

b. Set the Step Options Y value to 1.0. 

3. Apply Affixes checkbox should be enabled.  

 
Figure 26 – Dynamic Settings 
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2.3 Create and Assemble a New Template 

2.3.1 Assemble the Backbone 

In this section, you will create a new template by dragging and dropping existing 
components onto the new template to define concrete pavement and aggregate base 
layers for one lane of concrete pavement and a shoulder which will function as a bike lane. 
1. Select the Library tab on the left side of the Create Template dialog. 

The Library view replaces the active template view. 

2. Right-click on the Project Library and select New > Template. 

 
Figure 27 – New Template 

3. Type the name Route 123.  

The new template is made active and editable in the template window. If it is not, 
Double Click on Route 123. 

4. Add the right side of the road. 

a. Single click on the 1Ln template the Exercise 2 folder. 

Important: Do not right-click or double-click; we want the Route 123 template to 
remain Active. 
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The Preview window in the lower left shows the 1Ln template and its attachment point 
(blue box). If a different attachment point is desired, click on the new point in the 
Preview window. 

 
Figure 28 – Template Preview 
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b. Select and drag the 1Ln template into the template window. Before dropping Right-
Click and select reflect.  This will swap to template to drop on the right. 

c. Drag the template to the 0,0 point (the origin). Use the Dynamic Settings dialog to 
see precisely when you are located at (0,0). 

Position can be verified by holding the cursor over the point. If you “missed” you can  

• Move the point to the origin  

• Move the template origin to the point via the Change Template Origin tool 
which can be reached by right-clicking in the Edit Template window. 

 
Figure 29 – Drag in Template 
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5. Adjust the window limits as necessary to see the component. (fit view.) 

6. Add left side of the road, this time dragging in 1Ln_BCPC and turning off reflect.  

 
Figure 30 – Pre-Merged Template 

7. Click on Subbase layer in the Component Properties dialog remove _rt from the 
Component name. Click Apply and Close. 

8. Repeat for HMA_S1 and HMA_S5. 

 
Figure 31 – Update Component Name 

9. Select File > Save to save the template library. 
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2.3.2 Merge the Backbone 

1. Merge common pavement components into a single pavement component. 

At the centerline where the two mirrored templates come together there are two 
components that define the pavement layer. Sometimes it is desirable to merge these 
into a single component. 

a. Zoom to see the CL where the surface components come together. 

b. Right-click on the shared boundary between the left and right top pavement layer, 
click Merge Components. 

The components now become one. 

c. Repeat the Merge process for the sublayer components. 

 
Figure 32 – Merge Template 

2. Select File > Save to save the template library. 
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2.3.3 Add Parametric Constraints 

1. Add the Parametric Constraints to each sublayer 
on the backbone. 
 
Click on each CL sublayer point, in the Point 
Properties enter: 
CL_sg = Label: Subbase Depth 
CL_sb = Label: Pavement Sublayer Depth 
CL_hm = Label: Pavement Top Depth 

 
 
 
 
 

2. These Labels are now a pick lists, click on the other sublayer points and update the label. 
Click Apply and Next to update save each Point update. 

Subbase Depth SHDR_sg_rt 
SHDR_sg_lt 

EOR_sg_rt 
EOR_sg_lt 

BOC_sg_lt 

Pavement Sublayer Depth SHDR _sb_rt 
SHDR_sb_lt 

EOR_sb_rt 
EOR_sb_lt 

BOC_sb_lt 

Pavement Top Depth SHDR_hm_rt 
SHDR_hm_lt 

EOR_hm_rt 
EOR_hm_lt 

BOC_hm_lt 

 
Figure 34 – Point Properties Label Pick List 

3. Click Close on the Point Properties dialog. 

4. Select File > Save to save the template library. 

Figure 33 - Point Properties fill in Label 
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2.3.4 Add End Condition to the Template 

End conditions are open components that seek and target existing and proposed terrains 
and corridor features. In this section, you will add an end condition to seek intersection with 
the existing ground at different slopes depending on the depth of cut or fill. 

1. The Route 123 Template should be active. 

2. Expand the Exercises folder. 

3. Drag and drop: 
Cut_for_Curb to Snow_c_lt 

Fill to Snow_f_lt 

4. With reflect on Drag and drop 
Cut_for_Ditch to Snow_f_rt 

Fill to Snow_f_rt 

 
Figure 35 - Drag in End Conditions 
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5. Test the End Conditions. 

a. Select the Test button to open the Test End Conditions dialog. 

b. Select OK when the Warning appears telling you there are conflicts. It turns out that 
two (or more) components share the same Priority Value and the software does not 
know what the designer’s priorities are. We will fix this. 

 
Figure 36 - End Condition Priority Warning 

c. In the Test End Conditions dialog, Select Check Priorities. The End Condition 
Priorities dialog shows that there is a conflict at the SNOW_rt. Select SNOW_rt and 
click Edit. 

 
Figure 37 - Check Priority 

 
Figure 38 – End Condition Priorities 
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d. Change the Priority values to match the image below. 

Change Ditch_rt to Priority 5 

e. Click OK. 

 
Figure 39 - Fix Priorities 

f. The End Condition Priorities dialog now shows no conflicts. Close it. 

g. Select the Draw button. Drag the cursor up and down. Observe which end condition 
component finds the Active Terrain Model surface (the horizontal line represents 
the simulated terrain model as you move your cursor). 

h. Verify that the solution sequence is correct. Slopes will solve in order from flattest to 
steepest. 

i. Close the Test dialog. 

6. Click on CUT3_lt, notice the Use Feature Name Override is on and set to CUT_lt and 
Close. 

Click on CUT3_rt, notice the Use Feature Name Override is on and set to CUT_rt and 
Close. 

It is important that each end condition point override is set correctly, or you will get flip 
flopping linear feature after running your corridor. 

7. Notice Red text indicates “Use Feature Name Override” is set to Active and white Text 
does not use the override. 

 
Figure 40 – Red text vs White Text 

8. Save the template library. 
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Exercise 3 - Edit a Template 

3.1 Assemble the Backbone 

1. Copy over the Granite Curbing Component from the workspace. 
a. In the Template Library Organizer browse to …\CT_Configuration\Organization-

BIM\_CT_Civil Standards\Template Library\CV_ORDTypicals.itl. copy over HWY Misc 
Components/HMA/GC from the workspace library  

b. Paste it in the Exercises folder. 

2.   Copy the needed template. 
a. In the Project Library right-click the 2ln_HMA_NC and click Copy. 

b. Right-click the Project Library folder and click Paste. 

c. Right-click the new 2ln_HMA_NC1 template 

d. Select Rename and enter 2ln_HMA_GC_NC. 

e. Double-click 2ln_HMA_GC_NC to active and make it editable. 

3.   Delete the existing left end conditions. 
a. Right-click in a clear area of the edit view in the Create Template dialog and select 

Delete Components. 

b. Hold down the left mouse button and drag the cursor over the all the Left End Condition 
components. Release the mouse button when you are through. 

• The lower left corner of the Create Template dialog prompts you to drag the 
cursor over any components you want to delete. 

• This method can also be used to delete closed components. 

  
Figure 41 - Delete Components Tool                                                   Figure 42 - Delete Components 
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4.   Add the Granite Curbing Component. 
a. Drag Exercises/GC into 2ln_HMA_GC_NC 
b. Drop it on the point EOR_lt 

 
Figure 43 – Drag in Curbing Component 

5.   Adjust the subbase depth and parent points so they line up. 
a. Click on EOR_sg1_lt and right click, select Delete Both Constraints. The point symbol will 

turn from Red to Green, allowing you now to move it as required. 

 
Figure 44 – Delete Point Constraints 
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b. Right click on EOR_sg1_lt and select Move Point, move it to snap on EOR_sg_lt, note 
the other points that move with it. 

 
Figure 45 

c. Double click on BOC_sg_lt and change Constraint 2 Vertical Parent to EOR_sg_lt. 

 
Figure 46 – Move Point and update date parent constraint 



Volume 3.2  - OpenRoads Designer Roadway Modeling 

39 
 

3.2 Make Adjustment to the Backbone 
1.   Check and fix Point Connectivity. 

a. Right click in the template window and select Check Point Connectivity 

 
Figure 47 - Check Point Connectivity 

b. Click OK to .005. This will check and prompt you to delete a point within a .005 tolerance 
of another. 

 
Figure 48 - Check Point Connectivity Tolerance 

c. Delete point EOR_sg1_lt 

 
Figure 49 – Delete Duplicate Point 
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2.   Merge the two Subbase components. 
To merge these two components, we will need to add another common point to the 
Subbase Components.  

a. Right click near the vertical line between the two subbase components and select Insert 
Point. 

 
Figure 50 – Insert Point 

b. Select Subbase. 

 
Figure 51 – Select Component 

c. Add the new point and place it on top of GCS3_lt. 

 
Figure 52 – Add new point 
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e. Right-click and select Finish to disable adding any more points. 

 
Figure 53 – Finish adding points 

3.   Repeat the Check Point Connectivity process and delete _lt, this will make it so GC3_lt is 
part of both Subbase components. This is needed to allow the merging of the Subbase 
components. 

4.   Now you can merge the components. Select near the vertical line separating the two 
subbase components and select Merge Components. 

 
Figure 54 – Merge Components 
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5.   Double click on the newly formed component and check the name, it should be Subbase, 
update if needed, click Apply and Close. 

 
Figure 55 – Check Component name 
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3.3 Add End Conditions 

1. Expand the Exercises folder. 

Drag and drop: 

Cut_for_Curb to Snow_c_lt 

Fill to Snow_f_lt 

 
Figure 56 – Drag in End Conditions 

3.   Test for End Conditions Priorities and fix as required. 

4.   Save the template library. 
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 Appendix 

3.4 Create Template Menu Commands 
The dialog is split into several areas. Each area is briefly described below. 

• File - The File menu contains familiar commands for creating new Templates and new 
folders within the template library, as well as commands to save and open template 
libraries. 

• Edit - The Edit menu contains commands used when editing templates such as Undo, Redo, 
Cut, Copy, Paste, etc… 

• Add - The Add menu contains commands to add points and components to the active 
template. 

• Tools - The Tools menu contains various tools for template creation. The Options and 
Dynamic Settings menu items are described on the following page. 

 
Figure 57 - Create Template tools list 
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3.4.1 Options… Dialog 

Tools > Options… displays the Template Options dialog which allows you to specify naming 
and step options for the current template. Use the Dynamic Settings dialog, detailed on the 
following page, to toggle these settings on/off as you design the template. 

 
Figure 58 - Template Options 

Naming Options 
Component Seed Name 

• From Feature Definition indicates, when selected, the component name is derived from 
the style specified when the component is created. 

• Specify indicates, when selected, the component name is specified in the field. 

• Point Seed Name allows you to specify the seed name for point in the current template. 
Since point names must be unique, the seed name is appended with a different number 
each time a point is created. 

Apply Affixes 

Indicates, when on, that affixes are applied. 

• Left Prefix/Suffix specifies which prefix/suffix should be added to a point or component 
when the value is on the left of 0.0 (absolute). 

• Right Prefix/Suffix specifies which prefix/suffix should be added to a point or component 
when the value is on the right of 0.0 (absolute). 

Step Options 

These options are used to specify precision step input for components and points. These 
values can also be accessed from the Dynamic Settings dialog. 
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• X Step specifies the step increment for the X distance from the dynamic origin. If this 
value is non-zero, then the cursor moves to the horizontal increments of the specified 
value as measured from the dynamic origin. 

• Y Step specifies the step increment for the Y distance from the dynamic origin. If this 
value is non-zero, then the cursor moves in vertical increments of the specified value as 
measured from the dynamic origin. 

• Slope - specifies the step increment for slope from the dynamic origin. If this value is not 
0, then the cursor moves in slope increments of the dynamic origin. Slope is applicable 
only when the dynamic settings are in horizontal/slope mode. 
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3.4.2 Dynamic Settings Dialog 

Tools > Dynamic Settings… displays the Dynamic Settings dialog, which is used for 
precision input of template components and to assign point names and styles when 
defining components. 

 
Figure 59-  Dynamic Settings 

X:Y/X:Slope toggles between X,Y step lock and X/Slope step lock. 

X Value displays the current X distance from the dynamic origin. 

X Step specifies the step increment. If this value is non-zero, then the cursor moves in 
horizontal increments of the specified value as measured from the dynamic origin. 

Y value displays the current Y distance from the dynamic origin. 

Y Step specifies the step increment. If this value is non-zero, then the cursor moves in 
vertical increments of the specified value as measured from the dynamic origin. 

Point Name specifies the name of the point to be placed. 

Apply Affixes specifies, when selected, that point name affixes (prefix or suffix) are to be 
applied to the point name when placing points. The Affixes are defined on the Template 
Options dialog. The Key-in pull down is used to specify the type of key in to be performed. 
• XY = key in absolute coordinates. 

• DL = key in delta coordinates from last point placed (defaults to the dynamic origin if it 
is the first point of a component. 

• HS = key in horizontal delta distance and slope from last point placed. 

• VS = key in vertical delta distance and slope from last point placed. 

• OL = key in delta coordinates from dynamic origin. 

• OS = key in horizontal delta distance and slope from dynamic origin. 

Set Dynamic Origin sets the location of the dynamic origin. 
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3.5 Template Library 
On the left side of the Create Template dialog is the Template Library area which contains a 
Windows-like folder structure. This area is used to manage the content of the current template 
library. Two tabs are supported for the Template Library area as described below. 

3.5.1 Folders and Template list 

When the Library tab is selected, the Template Library displays the contents of the current 
template library in a familiar Windows folder structure as shown at right. The Template 
Library area also supports common Windows functions like drag, drop, cut, paste, etc.. 

• When a template is selected from the list, the Preview window is used to display a 
preview of the template. 

• Double-click the template name to set it as the active template. 

 
Figure 60 - Roadway Template 
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3.5.2 Active Template 

When this tab is selected, the Template Library area displays the contents of the active 
template as shown at right. The Active Template option is used to review and edit template 
points, components, and parameters in a table format. 

 
Figure 61 - Active Template  

3.5.3 Creating New Folders and Templates 

Templates can be organized into folders in the Project Library. The Project Templates folder 
is intended to be used to create new folders and templates for a specific project. 

• To create a new folder, right click on the Project Templates folder and choose the New > 
Folder option. 

• To create a new template, right click on the folder and choose the New > 
Template option. 

• You can also cut, copy and paste templates from the HWY folders to the desired Project 
Library folder. 
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3.5.4 Current Library 

The right side of the Create Template dialog is used to display and edit the current 
template. 

 
Figure 62 - Figure Current Library 

Name - Shows the name of the current template. 

Description - Allows you to review/edit the current template description. 

Display - 

Components/Constraints - This option is used to set the display mode of the 
template. If Components is selected, then the template components are displayed. If 
Constraints is selected, then the point constraints for the template are displayed. 
Template points are always displayed. 

Display Point Names - Toggle this option on to display the template point names. 

Display All Components - When this option is checked on, any components that are 
“hidden” are displayed with dashed lines. 

Current Template Window - The Current Template Window is used to display and 
edit the current template. The window uses its own graphics engine and is not a 
MicroStation view.  
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A magenta-colored box is used to designate the origin of the template. 

 
Figure 63 - Origin of the template 

At the bottom of the Current Template Window are view commands similar to the 
MicroStation view commands. The two buttons that look like MicroStation View Previous and 
View Next commands are undo and redo commands used on template operations. The 
CTRL-Z keyboard shortcut can also be used to undo the last template operation. 

Within the Current Template Window, you can right-click to access commonly used 
template functions. You can also double click template components for editing purposes.  

 
Figure 64 - Current Template Window 

Mouse Wheel Functions - The mouse wheel has the following functions when creating 
templates: 

• Scroll the wheel to zoom in or out in the template window. 
• Hold down the Shift key while scrolling the mouse wheel to zoom in or out in the 

vertical direction only. 
• Hold down the Ctrl key while scrolling the mouse wheel to zoom in or out in the 

horizontal direction only. 
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Point Properties - Features can be reviewed and assigned in a variety of ways. 
• The Name and Feature Definition can easily be edited the Point Properties dialog 

which is accessed by double-clicking the point in the Current Template window. 

 
Figure 65 - Point Properties 

• The Dynamic Settings dialog can be used to define the Point Name that will be 
assigned to points as they are created. The Point Name field can be used to key-in a 
name for the point or to select a name from a predefined list as shown at right. It is 
recommended that you use the point names from this list when designing your 
templates. When a point name is selected from the list, the Point Style, which is the 
Feature Definition, is automatically set to the appropriate value. The Point Style list 
contains a list of all the Feature Definitions available in the CTDOT DDE. 

 
Figure 66-  Point Name 
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3.6 Template Points 

When the template is processed using the corridor modeling command, the points of a 
template are connected to form breakline features. Each point will be connected longitudinally 
to the next template drop location to form 3D longitudinal breakline surface features. The 
breaklines are drawn using the symbology defined with the Feature Definition that is assigned 
to each point. 

Since the template points are connected to generate the completed surface, establishing a 
standard name for template features that are used on each template is very important to the 
quality of the proposed design surface. For example, if a Shoulder point is named SHDR_lt on 
the first template, and it is named Shoulder_Left on the next, the software will not 
automatically connect these points to generate the breakline feature. Following a point 
naming convention is important to obtain the best results with Corridor Modeling. 

It is equally important to ensure that the feature definition assigned to points is consistent from 
template to template. 

Each template point name must be unique to the template. The software automatically 
appends a number to the point name if the same name is used during template creation. 

There is no limit to the number of points in a template.  

3.6.1 The Point Properties Dialog 

The Point Properties dialog is used to review and edit various properties associated with 
the template points, including the definition of the point constraints. To access the Point 
Properties dialog, in the Create Template dialog double-click on the point in the Current 
Template window. The Point Properties dialog, shown below, is opened. 

 
Figure 67 - Point Properties 
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The dialog contains the following options: 
Name displays the point name. The point name can be keyed-in or selected from the drop-
down list. If the point name is selected from the list, the corresponding Feature Definition is 
automatically assigned. Point names must be unique to the template. 

Use Feature Name Override displays the name of the feature that will be created in the 
surface to correspond to the point. This field is optional. If it is blank, then the point name will 
be used as the feature name. 
• The option is intended primarily for end condition components to create connectivity 

from one station to the next when the template end conditions change. For example, if 
you want all surface tie-in points to belong to one feature, then set the feature name of 
all the ending end condition points on each side of the template to the same name (i.e. 
all Cut and Fill end points on the right would be given the feature name R-Tie and all the 
ones on the left would be given the feature name L-Tie). 

• If the point has a Feature Name Override defined, the point name is displayed in red in 
the Template window. 

Feature Definition is used to define the feature definition of the point. If no style is specified, 
then it comes from the first component of which the point is a member. 

Superelevation Flag is used to identify the point as a candidate to be used for assigning 
superelevation control lines. This option should only be toggled on for pavement points on 
the surface of the pavement. 

Alternate Surface allows you to specify the name of an alternate surface for a point. You 
may choose multiple alternate surface names. Select from the list of available surfaces in the 
active template. 

Member Of indicates in which components the point is included. 

Constraints - The Constraints portion of the Point Properties dialog allows you to review/edit 
the constraints on a point. 
• Type specifies the constraint type: None, Horizontal, Vertical, Slope, Vector-Offset, Project 

to Surface, Project to Design, Horizontal Maximum, Horizontal Minimum, Vertical 
Maximum, Vertical Minimum, Angle Distance. The constraints are described in more 
detail below. 

• Setting up the appropriate constraint types is critical to achieve the desired results when 
pavement layers, superelevation, and transitioning are introduced to the design. 

• Label displays the optional label for the constraint. Constraints that are labeled can have 
their value changed during design processing. The same label name can be assigned to 
more than one constraint and more than one point. See Section 10.4 for details. 
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• Horizontal Feature Constraint is used to allow a point to target elements in the design file 
that are defined with the specified Feature Definition within a specific Range. Use of this 
option is not recommended.  

3.6.2 Point Constraints 

Point constraints are used to manage the behavior of points in a template. They are used 
so that if a point is moved in a template, either by the user editing the template or by the 
application of a horizontal or vertical control during design processing, all the points related 
to the point being moved behave in a rational and predictable manner. 

For example, when a Simple component is inserted into the active template, it is comprised 
of four points which are connected to define the component as shown in the example 
below. 

 
Figure 68 - Point Constraints 

The constraints for all the points in a template can be displayed by choosing the Display 
Constraints option on the Create Template dialog. 

 
Figure 69 - Display Constraints option 

Three of the four points are constrained with relation to the insertion point. If the original 
insertion point is moved, the other three points move in relation to the first point. 
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• A point can have at most two constraints. If two constraints are defined, the point is 
said to be “fully constrained”. A point that is fully constrained is represented by a red 
plus sign. In the example above, points 2, 3, and 4 are fully constrained. 

• A point that is partially constrained, meaning that it has only one constraint on it, is 
shown as a yellow plus sign. 

• An unconstrained point is shown as a green plus sign. 

Point constraints are two-dimensional and one-way. Two-dimensional means that the 
constraints can only affect the points offset and elevation (x and y coordinates in the 
cross-section view). One-way means there is a child-parent relationship between points. 
In other words, if point 2 is constrained by point 1, point 1 is said to be the parent of point 2 
and moving point 1 will affect point 2, but you cannot move point 2 to affect point 1. The 
example below shows a sample of this where the blue arrow indicates a parent/child 
relationship from point 1 to point 2: 

 
Figure 70 - Point Constraints 

Constraints are displayed as blue lines between the parent and the child point. At the 
midpoint of the constraint line, there is a short white line designating the constraint type as 
follows:  

• Horizontal line = Horizontal Constraint 
• Vertical line = Vertical Constraint 
• Sloped line = Slope Constraint 

Multiple lines will be shown for points with two constraints. 

Floating the cursor over a point will temporarily display an arrow designating the direction 
of the constraint (the arrow points to the child point) and a pop-up menu displaying 
information about the point. 
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3.7 Point Constraint Types 

Horizontal - The child point remains at the given horizontal distance from the parent point.  
• In the example above, point B has been constrained to point A with one constraint as 

shown below. 

• If point A is moved horizontally, point B will maintain its relative distance from point A. 

• If point A is moved vertically, point B is unaffected.  

Vertical - The child point remains at the given vertical distance from the parent point. 
• In the example above, point B has been constrained to point A with one constraint as 

shown below. 

• If point A is moved horizontally, point B is unaffected. 

• If point A is moved vertically, point B will maintain its vertical relationship to point A.  

Slope - The child point will maintain the given slope from the parent point. 
• In the example above, point C has been defined with a Horizontal and a Slope constraint 

as shown below: 

• Slope constraints are absolute. Slopes going from lower-left to upper-right are positive 
regardless of whether the child point is to the left or right of the parent. 

• Slope constraints can also have Rollover Values assigned to them. Rollover values are 
used to set the slope constraint based on variety of high side and low side slope 
parameters. A Reference Point is specified which defines the controlling slope to the 
parent point. 

• The example above documents the Rollover Values can as defined in CTDOT’s example 
templates for the shoulder break point behavior. See the online help for more 
information on the available parameters.  

Horizontal Maximum - The child point has two parent points and remains at the given 
horizontal distance from the parent point that is farthest to the right (has the maximum 
horizontal or X value).  

Horizontal Minimum - The child point has two parent points and remains at the given 
horizontal distance from the parent point that is farthest to the left (has the minimum 
horizontal or X value).  

Vertical Maximum - The child point has two parent points and remains at the given vertical 
distance from the parent point that is highest (has the maximum vertical or Y value).  

Vertical Minimum - The child point has two parent points and remains at the given vertical 
distance from the parent point that is lowest (has the minimum vertical or Y value).  
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Vector Offset - The child point has two parent points and will be projected onto the vector 
defined by the two parents. If the offset is not zero, then the child point will maintain a 
perpendicular offset from the parent vector at the specified offset value. Negative values 
indicate an offset to the left of the vector defined by the parent points. Positive values indicate 
an offset to the right.  

Project to Surface - This constraint must be used in conjunction with one of the previously 
define constraints. The other constraint will define the projection direction. The child point will 
then be projected to the surface with the name or parametric label given when the design is 
processed. If the surface does not exist, or no solution is found, then the point will remain where 
it is placed in the template.  

Project to Design - This constraint is like the Project to Surface, except that the point is 
projected to the design surface of the template. A projection value is given to indicate whether 
the projection is to be to the left or to the right. The point must also be constrained by one of 
the previous constraints, excluding the Project to Surface, so that a direction for the projection 
may be determined. A negative value limits the projection to the left of 0; a positive value limits 
the projection to the right. A value of 0 will seek to the left and to the right of 0 to project the 
point. If no solution is found, then the point will remain where it is placed in the template.  

Angle Distance - This constraint takes two parent points, a distance, and an angle. The 
selected point is then fully constrained to the location defined by the first parent, and the angle 
from the first parent relative to the vector defined by the two parent points. This constraint 
creates a rigid-body rotation. When selected, no other constraint types are available. 
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3.7.1 Editing Points with the Left Active Template Window 

In addition to the Point Properties dialog, points can be edited from a pop-up menu that is 
accessed by right-clicking on a point in the Active Template window. The menu is shown 
below. 

 

Figure 71 - Editing Points with the Left Active Template Window 
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3.7.2 Null Points 

A null point is a template point that is purposely not related to any particular component. 
It’s most often used as a reference for controlling other points. To create a null point, right-
click in the current template window and select Add New Component > Null Point, or 
select Add > Null Point from the pull-down menu of the Create Template dialog to initiate 
the command. 

 
Figure 72 - Null Points 

  

3.7.3 Testing Point Controls  

The behavior of fully constrained points can be tested by right-clicking on the point and 
selecting Test Point Controls as shown below. Select the desired option to test the behavior 
of a template as the point is moved either horizontally, vertically, or both at the same time. 

 
Figure 73 - Testing Point Controls 
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3.8  Template Components 
A component is a set of points that define an open or closed shape. Each component, whether 
open or closed, can represent a different material or area of interest. Components are named 
and have an assigned feature style. Component types are described below: 
Simple Components - A simple component typically represents a section of pavement. It’s a 
closed parallelogram (4 constrained points) that is defined by the slope and thickness. 

 
Figure 74 - Template Components 



Volume 3.2  - OpenRoads Designer Roadway Modeling 

62 
 

Constrained Components - A constrained component consists of points that are all restricted 
to the movement of the first point. A constrained point is typically used to manage the 
behavior of other points in the template. When a point (parent) is moved, any constrained 
point (child) also moves. This restriction only affects the offset and elevation (x,y) of the 
restrained point and the relationship is unidirectional (movement of child point does not move 
the parent point).  Fully constrained points are displayed with a red + symbol. 

 
Figure 75 - Constrained Components 

Unconstrained Components - An unconstrained component is open or closed-shaped with 
no movement restrictions. Moving one point has no impact on the other points that make up 
the component. 

Null Point - A null point is a template point that is purposely not related to a specific 
component. It’s most often used as a reference for controlling other points. 
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End Condition - An end condition is a special open-shaped component that targets a surface, 
an elevation, or an alignment. End conditions are typically used to define cut and fill slope 
solutions. 

 
Figure 76 - End Condition 

Overlay/Stripping Components - A specialized component type that is used for defining 
pavement planning and overlay materials.  
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3.8.1 Creating Template Components 

CTDOT provides an example template library that contains several commonly used 
components. These components can be used to build templates. It may also be necessary 
to make specialized components to meet specific project requirements. 

To create a simple component, right-click in the active template window and select Add 
New Component > Simple, or select Add > Simple from the pull-down menu of the Create 
Template dialog to initiate the command. 

  
Figure 77 - Creating Template Components 

As new components are created, the Current Component portion of the Create Templates 
dialog is used to define the Name, Style, and any other relevant parameters for the 
component type being created. A simple component consists of four points defined 
by Slope, Thickness, and Width.  The top points are constrained 
by Horizontal and Slope constraints. The lower points are constrained to the points directly 
above them by a Horizontal and Vertical constraint. 

Define the Name, Slope, Thickness, Width, and Feature of the component before placing 
the component in the template. 

The Feature is used to set the symbology for the graphics drawn to represent the 
component in the 3D model. 

The Dynamic Settings dialog is used to facilitate component placement. The point names 
are derived from the Point Name selected in the Dynamic Settings dialog. Each point is 
appended with a number that is incremented. The points are assigned the Point 
Style feature that is active in the Dynamic Settings dialog. 

Point names and the feature that is assigned to each point should be reviewed and edited 
after the component is placed. 
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In the example below, a simple component is created representing a single lane of 
pavement. 

 
Figure 78 - Dynamic Settings 

Before placing the component in the template, various options are available to control how 
the template is placed by right-clicking in the template window to reveal the menu shown 
below. 

 
Figure 79 - template placed by right-clicking 

• Change placement Point can be used to change which component point is used as the 
point placed at the point you specify. Each time this command is selected, the 
placement point will move in a clockwise direction to the next point in the component. 

• Mirror will create the original component as well as a mirrored component reflected 
horizontally about the template origin. 

• Reflect will create a single component reflected about the template origin. 
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• The Mirror and Reflect options are toggles that are turned on or off and remain active. 
The on/off status of the Mirror and Reflect options is displayed at the bottom right 
corner of the Create Templates dialog. 

• Select Set Dynamic Origin to set the location of the dynamic origin. The dynamic origin 
is indicated by the purple box in the template display window.   

Creating Constrained and Unconstrained Components 

Constrained or Unconstrained components can be used to create any open or closed 
shapes in the template such as curbing, median barriers, retaining walls, or complex 
pavement situations such as the shoulder break on the high side of superelevation. 

Constrained Components 

To create a constrained component, right-click in the current template window and 
select Add New Component > Constrained, or select Add > Constrained from the pull-
down menu of the Create Template dialog to initiate the command.  When constrained 
components are created, both horizontal and vertical constraints are applied to each 
point. 

Unconstrained Components 

To create an unconstrained component, right-click in the current template window and 
select Add New Component > Unconstrained, or select Add > Unconstrained from the 
pull-down menu of the Create Template dialog to initiate the command. When 
unconstrained components are created, no constraints are applied. This option is useful 
when you wish to define constraints other than Horizontal and Vertical constraints. 
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Dynamic Settings 
The Dynamic Settings dialog can be for precision input when creating the component. In 
the example below, point EOR will be created at a defined horizontal distance and slope 
from point CL using a horizontal distance of 12 and a slope of -1.5% by using 
the hs=12 option with a value of 12, -1.5%. Use the Enter key to execute the command. 

 

 
Figure 80 - Dynamic Settings 

 
Right-click in the current template window at any time during the component creation 
process to access the menu shown below: 

 
Figure 81 - Right-click Menu 

• Select Finish when you have completed creation of the component. 

• Components can be created as open or closed shapes. To toggle on/off the option 
to placed closed shapes, select Closed Shape. 



Volume 3.2  - OpenRoads Designer Roadway Modeling 

68 
 

• Select Mirror to create two components at the same time. The second component is 
a mirror image of the one you are defining. The component is mirrored about a 
vertical line passing through the Dynamic Origin location. 

• Select Undo Last to undo the last point that was added to the component. 

• Select Cancel to terminate the component creation process. 

• Select Set Dynamic Origin to specify the location of the dynamic origin. 

3.8.2 Drag and Drop Component Operations 

A previously created template component can be included in the active template by use of 
drag and drop operations. Select a previously drawn component from the active template 
library and drag the component into the Current Template window. The component 
dynamically floats on the cursor. Release the mouse button to drop the component at the 
desired location. 

While dragging the component in the Current Template window, right-click anywhere in 
the Current Template window to access the placement options discussed previously 
(Mirror, Reflect, etc…)    

When connecting two components by dragging a component into the active template, the 
connecting point will change to a white colored plus sign prior to placing the component to 
indicate that the points are coincident. The point name from the previously placed 
component will be retained. Point names can be edited at any time during the template 
creation process. 

1. In the example below, a new blank template is created New Template1, this will be built 
with a left template having one lane and a right template having 2 lanes. 

2. The Left side of the road is placed by dragging in the 1Ln_BCPC component. It is 
dropped with Apply Affixes at the origin in the active template. 

3. The right side of the road is then placed with the Mirror option is turned on, with Apply 
Affixes also toggled on, 2Ln_BCPC component is also dropped at the origin. 
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Figure 82 - Create Template Drag Over 

 

 
Figure 83 - Create Template Drag In 

 

 
Figure 84 - Create Template Drop  
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3.8.3 Affixes 

The Apply Affixes option is used to add a user defined prefix or suffix to the point name. In 
the example below a simple component was added with the Mirror option toggled on (as 
the component is being placed, right-click to reveal a menu to choose the Mirror option). 
The prefix of “lt-“ is applied to the points on the left side of the template. The prefix of “rt-“ is 
applied to the points on the right side of the template. 

 
Figure 85 - Apply Affixes 

The affixes are defined in the Template Options dialog. 

Tip: As a rule, affixes should not be applied to templates that contain individual 
components that will be used as “building blocks” for complete roadway templates. This is 
because the component maybe used on either the left or right side of the template. 
Affixes should always be applied when creating completed templates for use with 
Roadway Designer. 

Note that all the points of the component are named using the currently defined Point 
Name. After the component is placed, it is necessary to rename the points and assigned 
feature definitions to ensure that the points and 3D line strings are drawn using the 
appropriate standards. This can be done by double-clicking on each point to access 
the Point Properties dialog shown below. 

The Name can be typed in or selected from the drop-down list. If the Name is selected 
from the list, the associated Feature Definition is automatically defined. The Point 
Properties dialog is covered later in this document. 

 
Figure 86 - Point Properties 
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3.8.4 Merge Components 

Deletes all the shared point line segments of two overlapping components and merge 
them into the selected component. The second component is deleted. Access this 
command with a right-click over a location that is above line segments from two 
overlapping components. The dialog appears only when 2 or more components share a 
common line. 

 
Figure 87 - Merge Components 
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3.8.1 Component Editing 

The properties of the component can be edited by double-clicking on the component. The 
Component Properties dialog is opened.  

 
Figure 88 - Component Editing 

Name - Specifies the name of the current component. Select a different component using 
the locate button. 

Use Name Override - The name override is used to specify the name used by the software 
to connect components from one template drop location to the next. 

The option is intended to create connectivity from one station to the next when the 
template components change. For example, a template may contain more than one 
solution for a fill condition as shown below. 

Two end conditions are defined for the fill slopes named R-FILL2 and R-FILL3. When the 
templates are processed, the software will evaluate each template drop location to 
determine whether the R-FILL2 or the R-FILL3 component is used. 3D Mesh elements are 
created by connect all the components by the name of the component. All the 
components named R-FILL2 will be connected to create 3D Mesh element, and all of the 
components named R-FILL3 will be connected to create another mesh element. This leaves 
a gap in components at the locations where the fill slope transitions from 3:1 to 2:1 since the 
components named R-FILL3 will not be connected to the components named R-FILL2. The 
solution is to assign the same Override Name for each component. 

Description - Specifies an optional description of the component. 
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Feature Definition - Specifies the feature style of the component. This option is used for 
display and also to define the component’s material. CTDOT has defined a specific group of 
styles to be used for components prefixed with the word “Component”. When the 
components are plotted in MicroStation, either as a 3D model, or as cross sections, the 
symbology defined by the selected Style is used.  Care should be taken to select the 
appropriate style for each template component. 

Parent Component - Specifies the parent component. If a component has a parent 
component, then it is only displayed if the parent component is displayed. The parent 
component can be either a non-end condition component, or an end condition 
component. Specify the component or identify it using the locate button. 

The Active Template listing can also be used to display and edit the parent child 
relationship between points and components. In the example at right, the 
Components category is open to show the parent/child relationship between 
the components in the tree. Drag and drop operations can be used to move one 
component under another. 

Note: The component names are listed alphabetically, not from top to bottom as 
drawn in the template. 

Exclude from Top/Bottom Mesh - Specifies that the component will be excluded from the 
top and bottom mesh elements that are created in the corridor modeling process. 

Close Shape - This option is only available for non-End Condition components. Only closed 
shapes can be used to compute component quantities. 

In this example the components were merged so the Name needs to be edited to remove 
the _lt suffix. 

       
Figure 89 - Close Shape 
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3.8.2 End Conditions 

An end condition is a special open-shaped component that targets a surface, a feature of 
a surface, an elevation, or an alignment. End Conditions are commonly used for cut and fill 
definitions. End Conditions are added to the end of simple, constrained, or unconstrained 
components. 

To create an end condition, right-click in the template window and select Add New 
Component > End Condition, or select Add > End Condition from the Create 
Template dialog’s pull-down menu. 

 
Figure 90 - End Conditions 

When adding an end condition to the current template, the Current Component portion of 
the Create Template dialog displays the following options: 

 
Figure 91 - Current Component 
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The Name field is used to specify the user defined name for the component. 

The Feature Definition is used to set the feature definition for the component. 

Target Type specifies the type of target the End Condition is seeking. Targets include: 

• Terrain Model – Seeks an OpenRoads Terrain Model. 
• Elevation – Seeks a particular elevation. 
• Linear Horizontal/Vertical/Both – Seeks the intersection with a particular linear 

element selected from a list. 
• Feature Definition Horizontal/Vertical/Both – Seeks the intersection with a particular 

feature type. 

Horizontal Offset specifies a horizontal offset from the target. This option only applies if the 
target is a horizontal target or has a horizontal aspect. 

Vertical Offset specifies a vertical offset from the target. Applies only if the target is a 
vertical target or has a vertical aspect. For an elevation target, specify the elevation here. 

Priority specifies the order in which end conditions are attempted in seeking a solution. 
Where more than one End Condition starts at the same point, this value determines the 
order in which End Conditions are attempted to find a solution. Lower numbers, which have 
a higher priority, are attempted first. 

Benching Checkbox indicates, when on, the set of segments of the End Condition are 
repeated until a solution is found. 

Benching Count indicates the maximum number of times that benching should occur. If 
this value is 0, then the repeat count is unlimited, and the benching End Condition must 
find its target for it to be valid. If any other number is entered, then if the benching is 
repeated for the specified count and if the target is not reached, the benching End 
Condition will still be considered successful if an End Condition attached to the end of the 
benching End Condition is successful. 

From Datum indicates, when on, the benching will use a datum elevation and step 
elevation to set the benching rather than using the End Condition segments as they are 
defined. 

Datum Elevation specifies the elevation that represents the basis for the step elevation. 
Datum + Current bench elevation = n * Step Elevation. 

Step Elevation specifies the increment for benching when a datum is being used. Each 
bench elevation is always located at the end of the first segment (or the second point) of 
the benching End Condition. 

Rounding Length specifies the length used to round the end condition. When this value is 
something other than 0.0, 4 additional points are added to the end of the end condition 
using a parabolic formula to smooth out the transition of the intersection of the end 
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condition with the surface. This rounding effect is only applied when the target is a terrain 
model or an elevation. Any other end conditions attached to the end of this one is 
attached to the end of the rounded section. 

End Condition Priority 

The end condition priority value is used when more than one end condition is defined 
starting at the same point. A simple end condition consisting of two fill lines is shown in the 
example below. 

 
Figure 92 - End Condition Priority 

When the end condition is processed in corridor modeling, each end condition will be 
tested in the order specified by the user. The order is determined by the Priority value 
entered by the user during the end condition creation. The most desirable solution, and the 
first condition to be tested, is given a priority value of 1. 
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Double-clicking on a component will open the Component Properties dialog shown below. 
If the component is an end condition, the End Condition Properties are displayed. 
The Priority is set as shown below. 

 
Figure 93 - End Condition Properties 

The properties for point CUT_rt2 were defined as shown Below. Check for Interception is 
toggled on, and End Condition is Infinite is toggled off. The point is defined with a 25% 
Slope for a horizontal distance of 45.0’ from the snow shelf.  
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The properties for the point CUT_rt3 were defined to specify a 2:1 slope with the End 
Condition is Infinite option toggled on. The priority for the end condition component 
Cut3_rt is set to a value of 8. 

With these settings, the end condition CUT_rt2 (Priority=7) will be tested before CUT_rt3 
(Priority=8) for an interception with the surface within the horizontal distance of 45.0’. If an 
interception is found within the vertical distance, the end condition is used for the cross 
section and a point will be placed at the interception. 

If no interception is found within 45.0’ horizontally from the snow shelf, the condition fails 
and the software will test the next end condition, CUT_rt3, which has a Priority value of 8. 
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Since End Condition is Infinite is toggled on for point CUT_rt3, the solution will solve for an 
interception with the surface regardless of the vertical constraint definition. 

       
Figure 94 - Point Property End Condition is Infinite 
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Testing End Conditions  
End conditions can be tested in the Create Template dialog before processing the template 
with corridor modeling. Testing simulates how the end condition will behave when the 
corridor is processed. 
This is extremely useful for complex end condition definitions with multiple solutions. To test 
the end condition, select the Test command, located below the Current Template window. 
The Test End Conditions dialog is opened. 

 
Figure 95 - Testing End Conditions 

The software will check for conflicts in the priorities defined in the template before opening 
the Test End Condition dialog. If conflicts exist, a warning is issued. 

The dialog displays the current template. Non-solved end conditions, and their child 
components, are displayed in dashed lines. Normal components and solved end conditions 
are displayed as solid lines. 

To test the end condition, select one of the available targets and then select the Draw 
button. Move your cursor over to the testing window. The end conditions will change from a 
dotted line to a solid line indicating the solution for the target interception. 

Failure Report activates the Results dialog. When you fail to get a solution on one or both 
sides, the results show which components failed and which end condition start points were 
not solved. 



Volume 3.2  - OpenRoads Designer Roadway Modeling 

81 
 

Check Priorities tests the template for priority conflicts. When conflicts exist, a message is 
displayed indicating there are end conditions that start from the same point and have the 
same priorities. The End Condition Priority Conflicts dialog is displayed. If no conflicts exist, a 
message box indicating no conflicts is displayed. 

Available Targets lists all of the targets applicable to the current template. You can select 
the desired target and draw it in the display. 

Use Surface Slope specifies the slope of the surface that is being placed. This is useful in 
certain instances where an end condition intersects a surface more than once, such as a 
ditch profile. 

Draw draws the selected target. Surfaces and elevations are drawn as horizontal lines. 
Features and alignments are drawn as a “+” mark. As you draw a target, the display 
dynamically updates to show the solution(s). 

Reset clears all the drawn targets. 

Display Rules list the display rules for the current template. Left-click the Value to toggle 
between True and False. Press the Reset button to restore the original Display 
Rules values.  

 
Figure 96 - Display Rules 

If at any time user need to modify the values user can do it here. 
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