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The purpose of this manual is to introduce CTDOT users to  Bentley InRoads V8i SELECTSeries 4 (SS4) using 

OpenRoads technology. This manual assumes users will have previous training on, and a working knowledge 

of, ProjectWise, MicroStation and InRoads. AEC Applications provides an OpenRoads Workspace through the 

use of both ProjectWise and a network solution. These workspaces provide the standardization users will need 

to prepare their design. This manual was initially written only for OpenRoads pilot projects in the ProjectWise 

document management system environment through the use of a Managed Workspaces. Since the initial 

testing we decided to also pilot a network solution . Throughout this manual you will see the ProjectWise 

folder structure listed, for network pilots please substitute the network path as shown below.  

ProjectWise Workspace Location: 

pw:\\ctdot.projectwiseonline.com:CTDOT\Documents\05.0 - Workspace Resources\ 3_Workspace_V8i\ 

Network Workspace Location:  

W:\ 3_Workspace_V8i\ 

 

ProjectWise Project Location: 

pw:\\ctdot.projectwiseonline.com:CTDOT\Documents\01.0 - Projects - Active\ 

Network Project Location: 

X:\SS4_Pilots 

 

Bentley ProjectWise (PW) is a collaborative environment which allows all parties involved in the project to 

use live data and to make real time decisions. It also allows CAD support to immediately update or edit any 

necessary Workspace resource.  All CTDOT employees should have a ProjectWise account.  If you do not, or if 

you experience difficulties logging in, please contact Julie Annino via email:  Julie.Annino@ct.gov 

When starting a new OpenRoads Project do not copy over or open any DGN files that were used on an old 

project, these files do not use the correct  settings.  You may reference them in as needed but using them 

and running OpenRoads will cause problems.  

  Introduction  

mailto:Julie.Annino@ct.gov
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Online Training can be found on Bentley’s LEARNserver Website. Select the Orange Find Training button and 

in the Enter Product Name field type in InRoads.  Look for the learning paths in the list that say OpenRoads 

and explore.  Starting with the InRoads V8i SS3 release, and continuing with SS4, Bentley began 

incorporating what they call OpenRoads technology, to integrate more functionality of InRoads into the 

MicroStation interface, moving the commands from the InRoads Explorer menus to the MS Tasks dialog under 

Civil Tools. This produces significant differences in some SS4 workflows from SS2 workflows, and some new 

features are available in SS4 that did not exist in the InRoads V8i SS2 version.  

https://learn.bentley.com/app/Public
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Civil Tools Workflows versus InRoads Explorer  
In InRoads V8i SS4, you use workflows and commands under Mic roStation Tasks > Civil Tools to perform 

many of the functions that were previously initiated using InRoads Explorer.  In this manual you will also use 

Legacy Tools and Workflows.  The term legacy refers to tools and workflows in SS4 that still use the InRoads 

Explorer menus (File, Surface, Geometry, Drainage, Evaluation, Drafting, Quantities, Tools). Legacy 

procedures will be much the same in SS4 as in SS2, with minor changes that are ca lled out. 

1.1.1 Civil Tools  
Workflows for which you now use MicroStation Tasks>Civil Tools include:  

  General Geometry 

  Horizontal Geometry 

  Vertical Geometry 

  Terrain Models 

(alternatives to Surface .dtm files)  

  Corridor Modeling:  

o  Create Corridor 

(formerly under Modeler>Roadway Designer)  

o  Create Cross Sections 

(formerly under Evaluation>Cross Section)  

o  Annotate Cross Sections 

(formerly under Evaluation>Cross Section)  

o  End Area Volumes 

(formerly under Evaluation>Volumes)  

  Civil Cells  

  Survey 

NOTE: that there is no replacement for the Storm and Sanitary Add-In in SS4. For that functionality you 

must use InRoads V8i SS2. A different Bentley product runs in SS4 named Subsurface Util ity Engineering, 

which includes Subsurface Utility Design and Analysis . SUE/SUDA workflow can be found on CTDOT’s  

website. 
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1.1.2 Legacy Tools and “Native” Data Types  
Some workflows still require InRoads Explorer commands, used in the same manner as in SS2. The CTDOT 

configuration of InRoads V8i SS4 is set to open the InRoads Explorer window upon launching the application. 

In this manual and elsewhere, you will see the term legacy used to refer to design approaches that stil l rely 

on the InRoads Explorer interface. Some of these are listed below.  

  Create and Annotate Profiles  

  Drainage Annotation  

  Display of Horizontal and Vertical Alignments  

  Vertical Alignment Annotation  

The term “native” refers to data types, such as styles, used by legacy tools. These data types are stored in 

standalone files (e.g., .dtm, .alg, .xin), rather than being included in the .dgn.  
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Known Issues  

1.2.1 General 
  Slower Launch and Exit  

InRoads V8i SS4 is slower to launch and exit than InRoads V8i SS2.  Part of the reason for the slowness is 

that the Civil Model must be scanned to display the civil data. Another reason is the SS4 interface must 

always consider which tasks to display based upon the dimensionality of the active model in the .dgn (2D 

or 3D).  In the course of designing a roadway, you will change the active model from 2D to 3D, and back 

again - many times.    

  Slower Model Changes  

Each time the model dimensionality changes,  the interface must reload.  Also, each time you change 

models, the civil data has to be gathered from the active model and its references.  Changing models 

takes time.    

  Input While Command Active Can Cause a Crash  

If you provide input (click the mouse) before InRoads is ready, you will cause a crash. Some of the 

InRoads V8i SS4 commands do not display a progress bar, so it is difficult to determine when a command 

has finished and InRoads is ready.  

  Running two applications at the Same time 

Do not run InRoads SS4 and SS2 at the same time. This could lead to issues with your user preference 

files.  

  AutoTurn 

When using AutoTURN create a new 2D MicroStation file and reference in your OpenRoads file.  Do not use 

AutoTURN in your OpenRoads Modeling File.   

  Auto Annotation Stationing Disappears  

When using the CTDOT feature definition, which is set to auto annotate stationing, you may notice that the 

stationing has vanished.  This is a temporary display issue; the graphics are still in the file.  If you fit the 

view, you may see the stationing displayed miles away to the upper right. To fix this display problem, exit 
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InRoads and re-open the .dgn file containing the geometry.  You may need to slightly adjust the geometry 

using the manipulators to force the auto annotation to update.  

  CTRL + Z 

Do not use Ctrl + z to undo an action will occasionally change your views and windows and not undo 

your action. 

1.2.2 Crashes 
  What Does a Crash Look Like?  

Three signs of a crash:  

o  The application may freeze and display “(Not Respond ing)” in the title bar  

o  The mouse cursor may turn into the spinning refresh wheel and stay that way for more than 20 

seconds  

o  (After a while) Microsoft, MicroStation or InRoads produces a Problem Notification dialog.  

o  If you experience any of these signs, look around the interface - if you have a progress bar in the 

lower right corner, InRoads may just be busy executing your command.  

  How to Avoid a Crash  

If you have just executed a command or changed the active model, and you are not sure if InRoads is 

ready for more input - move the mouse cursor over the buttons on the task menu.  If the buttons highlight 

yellow and you see tool tips, InRoads is ready for you to click the mouse.  

  How to Recover From a Crash  

Locate the InRoads icon on the taskbar, right-click on it and choose "Close window".  You should then be 

able to relaunch InRoads. Although it also works to cancel the operation of InRoads through Problem 

Notification dialogs, this method can take a lot of time.   
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The steps in this chapter will only have to be done at the initial startup and then again if a user gets upgraded software, they 

receive a new computer, or their computer has to be re-imaged. While the several of the steps in Chapter 3 will need to be 

completed for every new project a user works on.  If the OpenRoads SS4 Pilot Project you are working on was moved out of 

ProjectWise to the X drive you should still complete all the steps in this chapter. 

Verify Software Installations  

Verify that the required software has been installed on your computer by navigating to the Windows Start Menu and typing 

Programs into the search field. Select Show which programs are installed on your computer from the search results.  This will 

open the Control Panel’s Programs and Features which lists the names and versions of the installed programs. 

The required software applications are as follows:  

ProjectWise Explorer  

MicroStation V8i (SELECTseries 4)  

Bentley InRoads Suite V8i (SELECTseries 4)  

 

Create a ProjectWise Desktop Shortcut 

1.  Select All Programs > Bentley > ProjectWise.   

2.  Right click on ProjectWise Explorer and select Send to > Desktop. 

 

 Set Up 
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Log in to ProjectWise 

1. Double click on the newly created ProjectWise Explorer Icon as 
shown above. 

2. From the ProjectWise Explorer main menu, select Datasource > 
Log in… 

3. Enter your User Name and Password then select the Log in button. 

4. Browse to locate your Project under  
Documents\01.0 - Projects – Active 

5. Become familiar with the new project folder structure, it is quite 
different than how the X drive was structured. Two important 

folders will be the Highway and Survey folders. 
330_Design_Data\Highways 
500_Pre_Design\03_Central_Survey 

 

 

 

 

 

Adjust ProjectWise Explorer Settings 
 
1. If the Interface and View are not displayed, navigate 

through the main menu select View > Toolbar and 
toggle them on. 
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2. ProjectWise Explorer has Interfaces and Views 
to display certain attributes.  

Ensure that:  
Interface is set to CTDOT_Doc_Code  
View is set to Document 

 

 

3. On the ProjectWise pull down menu select Tools > 
Options, Select the Settings tab and uncheck Use 
URN Links.  Click Apply and OK.  
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Configure ProjectWise Open With  

User Program Associations must be removed in order for MicroStation platforms and user workspaces to function properly.   

1.  From the ProjectWise Explorer main menu, select 

Tools > Associations > Programs  

 

 

 

2.  From the Program Associations dialog box, change 

Select an association view to User associations.  

Scroll down to MicroStation.   

 

3.  Expand the MicroStation tree to display Open, 

Viewer, & Markup.  If the MicroStation icon is just a 

generic icon that looks like a notepad, skip the 

remaining part of this step. 

4.  Expand MicroStation > Open and right click on the 

line containing \ustation.exe. Choose Unassociate 

and OK.   

5.  Repeat for each \ustation.exe instance under Open.  

Disregard Viewer and Markup. 

Note: In this case, MicroStation has its own unique 

icon displayed. (This is not the case for other 

programs such as MrSid and Outlook Message.)  

This indicates that there are User associations 

activated which must be removed. 
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Set up Your User Preferences 

1. Open Windows Explorer, select Organize > Folder and search options.  Under 

Hidden files and folders toggle on Show hidden files, folders and drives. The Hide 

extensions for known file types box should be unchecked. Select Apply to Folders. 

 

 

 

 

 

 

 

 

2. In Windows Explorer browse to: 

D:\Users\Richardeh\AppData\Local\Bentley\MicroStation\8.11\irRFESEEaUk…,  

Delete all of the files and folders under the irRFESEEaUK… folder.  
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3. On your desktop create a folder named PW Export. 

4. In ProjectWise browse to 05.0 – Workspace 
Resources\3_Workspace_V8i\_Export\. Right click on the 

_Export folder and select Export… 

5. Choose Send to Folder and select Next>. 

 

 

 

 

 

 

6. Browse to an export folder created in step 1 and accept to 
overwrite any outdated files if prompted, and Finish. 
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7. On your desk top open the folder _Export folder\View Options – Civil and copy CT_Civil_pw.ucf and 
CT_MSTA_PW to C:\Bentley_V8i\Worksapce\Users. 
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8. Again go to the _Export folder on your desktop, double click on _Civil_Options_Prefs_Setup.bat to automatically populate 
the civil folder with default preferences for Civil Options. 
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If the OpenRoads SS4 Pilot Project you are working on was moved out of ProjectWise to the X drive you will skip Step 1. 

Complete either Step 3 for ProjectWise or Step 4 for the Network. 

Verify Correct Project Workspace 
 

1.  Locate the Workspace location.  You will no longer be connected to the old workspace on the W drive, instead you will find 

the workspace at this location in ProjectWise, Documents\05.0 - Workspace Resources\3_Workspace_V8i. 

2.  Check to make sure your project is configured to the correct workspace.  In ProjectWise explorer right click on the project 

folder and choose Properties.  All projects using OpenRoads SS4 should use the following Blocks shown in the image 
below.  ProjectWise Configuration Settings Blocks (CSBs) are attached to projects so that CAD workspaces are read when 
a MicroStation design file is opened.  

3.  If you do not see the correct blocks please contact AEC applications and they will reset them.  Users do not have access to 
do this. 

4.  Click OK to close the box. 

 Project Start up 
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Copy Resource Files from the Workspace to your project 

The ITL and XIN will need to be copied over from the workspace to your project discipline folder 

1. Browse to  

In ProjectWise 05.0 - Workspace Resources\3_Workspace_V8i\Civil_Standards\data\feature_definitions\Civil_Feaures.xin 

For Network ProjectsW:\3_Workspace_V8i\Civil_Standards\data\feature_definitions\Civil_Feaures.xin 

 

Right Click and Select Copy.  Browse to your projects discipline folder right click and select Paste.  When the Document Wizard 

appears select No Wizard and click the OK button. 

2. Browse to 

In ProjectWise 05.0 - Workspace Resources\3_Workspace_V8i\Civil_Standards\data\template_library\OpenRoads_Typicals.itl 

For Network ProjectsW:\3_Workspace_V8i\Civil_Standards\data\\template_library\OpenRoads_Typicals.itl 

 

Right Click and Select Copy.  Browse to your projects discipline folder right click and select Paste.  When the Document Wizard 

appears select No Wizard and click the OK button. 
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Create and Open a MicroStation DGN File in PW 
 

 

1. Select the project subfolder that you wish to work in. 
Example: 01.0 - Projects - Active\1234-1234\300_Design_Data\Highway\ 

2. From the main menu, select Document>New > Document….  

3. In the Select a Wizard Dialog Box, select Advanced Wizard then OK. 

4. On the Advanced Document Creation Wizard Welcome dialog box Select 

Next>. 

NOTE: Seed File Usage 

 Use a 2D DGN seed file to start your Design Modeling (OpenRoads will automatically create a 3D model as your design 
progresses). 

 Survey will use one of the 3d DGN seed file to house the Existing Terrain. 
 DO NOT Drag and drop DGNs and Point Cloud files in from an eternal location.  These files have different working units 

and will not scale properly if opened in the ProjectWise environment. 
 Always start with new clean seed files. 
Geospatial OpenRoads seed files 

\Documents\05.0 – Workspace Resources\3_Workspace_V8i\Civil_Standards\seed\ 
2D_OpenRoads_DesignSeed_83.dgn 

2D_OpenRoads_DesignSeed_27.dgn 
3D_OpenRoads_DesignSeed_83.dgn 
3D_OpenRoads_DesignSeed_27.dgn 

FAQs - NAD & NGVD 
http://www.ngs.noaa.gov/faq.shtml#WhatNAD 
 

http://www.ngs.noaa.gov/faq.shtml#WhatNAD
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5. When prompted to Select Target Folder, verify that you are pointed to 
the correct folder and select Next>. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

6. From the Select a Template options, toggle on Use 
ProjectWise as a template and click the Select… button.  If 

this is not your first time creating a MicroStation file in 
ProjectWise, you may elect to toggle on Select from recent 
used templates and use a previously selected seed file 
stored in your file history and skip to the next step. 
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7. A Select Template Document dialog box will appear.  Browse to the seed files location:  
…05.0 - Workspace Resources\3_Workspace_V8i \Civil_Standards\seed\  
 
Choose the 2D seed file that corresponds to your survey NAD year 1983 or 1927. 

2D_OpenRoads_DesignSeed_83.dgn 

or 

2D_OpenRoads_DesignSeed_27.dgn 

 
Select the Open button.  The template is now populated for Advanced Document Creation.  Select Next. 

8. Select the fields to Define Document Attributes as shown.  Tab 

to accept each field.  The document file name will be built from 

these fields.  Be sure to enter a Label and Description.   These 

fields will be displayed and used for searching rather than the 

file name.  Select Next. 

9. On the Document Properties Dialog Box select Next>. 

10. On the Create a Document Dialog box select Next >. 

11. Click Finish to Close.  The new file will now appear in 
ProjectWise. 

12. To Update the ProjectWise Explorer Document View data point 

in the view and then select F5 on the keyboard.  This will 

refresh Label and Description. 

13. In ProjectWise Explorer browse to your discipline folder and 

locate the DGN file you wish to open, right click on the DGN file 

and select Open With. By default MicroStation DGN files will 

open with MicroStation only (i.e. no InRoads nor OpenRoads) if 

double clicked on, so selecting open with is imperative if you 

want to run OpenRoads. 
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14. In the Open document with dialog box locate the Description column and select OpenRoads SS4 and click OK.  This will 

use OpenRoads SS4 if it is installed and also complete CTDOT configurations.  The Managed Workspace will now begin to 

cache on your computer’s hard Drive. 
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Create and Open a MicroStation DGN File on the Network 
1.  Create a desktop shortcut by right clicking the program from the start menu > All Programs> Bentley > 

InRoads Group V8i (SELECTseries 4) > Send to > desktop (create shortcut). 

 

2.  Edit the shortcut properties target by copying and pasting this:   

C:\Bentley_V8i\MicroStation\ustation.exe -wc\\DOT SDCENG07V\CTDOT_Workspace$\CTDOT_startup_V8i_SS4.cfg 

 

3.  Double Click on the Icon to open the application, hit the cancel 

button when the ProjectWise log in appears.  
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4.  Use ct_civil_pw for a User and do not pick a project.  
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5.  Browse to your project folder under the X:\SS4_Pilots folder and create or open a file.  

 

NOTE: Seed File Usage 

 Use a 2D DGN seed file to start your Design Modeling (OpenRoads will automatically create a 3D model as your design 
progresses). 

 Survey will use one of the 3d DGN seed file to house the Existing Terrain. 

 DO NOT Drag and drop DGNs and Point Cloud files in from an eternal location.  These files have different working units 
and will not scale properly if opened in the ProjectWise environment. 

 Always start with new clean seed files. 
Geospatial OpenRoads seed files 

W:\3_Workspace_V8i\Civil_Standards\seed\ 

2D_OpenRoads_DesignSeed_83.dgn 
2D_OpenRoads_DesignSeed_27.dgn 

3D_OpenRoads_DesignSeed_83.dgn 
3D_OpenRoads_DesignSeed_27.dgn 

FAQs - NAD & NGVD 

http://www.ngs.noaa.gov/faq.shtml#WhatNAD 
 

http://www.ngs.noaa.gov/faq.shtml#WhatNAD
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Ensure your User Preferences are working properly 

1. Now that your MicroStation File is opened you should check to make sure 
your User Preferences are properly set.  On the MicroStation pull down 
menu select Workspace > Preferences. It should be named CT_CIVIL_PW 

 
 

 
 
 

 
 

 
 

 
 
 

 
 

 
 

2. Ensure that all MicroStation Project Explorer settings for Browsers are set to 

True by selecting Settings > Project Explorer from the MicroStation 

menu. 
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3. At the bottom of the Right side of you screen check for docking of the Tasks, 

Project Explorer and Element Information Tabs. You can move and doc them as 

desired. 

 

 

 

4. If the these menu are not visible you can manually turn them on using the 

MicroStation pull down menu. 

For the Tasks select Tools > Tasks. 

For Element Information select Element > Information. 

For the Project Explorer select File > Project Explorer. 

 

 

 

 

 

 

 

5. Locate the Bentley Online Help Videos, On the Project Explorer there is a Tab 

named Links. Click on the down arrow and select Bentley Online. This will 
directly link you to Bentley’s help and Training Videos. 
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Set up Project Defaults 
 

1. If the InRoads explorer dialog box is not visible you will 
need to open it. On the MicroStation pull down menu select 

Applications > InRoads > Tools >Show/Hide.  

2. On the InRoads Main menu select File > Project Defaults.  
Select the New button and type the desired configuration 
name. 

3. In the Preference (*.xin) field browse the XIN file that was 

copied to your discipline folder. 

4. Copy that same path (not the file) in to the Default 

Directory Path for the Geometry Project (*.alg) and the 
Template Libraries (*.itl). 

5. Click Apply and Close. 

6. Open Project Defaults again and select Highway as your 
Preferred Preference.  
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Obtain an Existing Terrain 
The concept of 2D and 3D files is very important when using OpenRoads. The existing terrain will be created using a seed file 

with a 3D model while the proposed design will be created using seed file with a 2D model.  Keep in mind when using OpenRoads 

to design the MicroStation file with the 2D model will automatically create a 3D model, so you will be working with one file that 

had two models.  Most of the work a designer does will be utilizing the 2D Model and the 3D Model will get propagated 

automatically. The 3D views are mostly used for checking the model and visualization.  Below are three methods for creating an 

existing Terrain.  

- Create from Fieldbook 

- Create from File DTM  

- Create from Point Cloud (See the Earth Exploration Toolset workflow located on the CTDOT’s OpenRoads website)  

4.1.1 Create from Fieldbook 
This will be done with new survey data where a DTM does not exist yet.  The Survey Unit will use OpenRoads to process the 

fieldbook instead of InRoads SS2. Please see the OpenRoads Survey Workflow for further information on this process. 

 Existing Terrain 

http://www.ct.gov/dot/cwp/view.asp?a=3194&Q=575828
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4.1.2 Create From DTM File 
Request an existing terrain DGN file from Survey.  In OpenRoads Survey will use the Create from File tool to convert the existing 

DTM to a Terrain.  Below are the steps they will use. 

1.  Create a new 3D Design Model.  

2.  Open the file and in the task menu select Civil Tools\Terrain Model\ Create 

from File tool. 

3.  The Select Files to Import dialog will appear. Browse to the location of the 

DTM file to import, highlight it and click OK.  

 

 

 

4.  Another dialog box should appear.  Fill out the fields as 

shown.  

Feature definition: Meshes/EX_TERR_Ground 

Import Options: Import Terrain Only 

Click Import.     
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5.  If an Import Failed error appears the following 

procedure must be done to the DTM. 

 

 

 

 

 

 

A. On the InRoads Explorer dialog box open the DTM.   

B. Right click on the DTM and select Properties. 

C. Toggle on Use Extended Data Checks and Lock Triangulation, click Apply and Close.   

D. Right click on the DTM and select Save. 

E. Right click on the DTM and select Properties. 

F. Toggle off Use Extended Data Checks and Lock Triangulation, click Apply and Close. 

G. Right click on the DTM and select Save. 

H. Right click on the DTM and select Close. 
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6.  Go back and do #3 & 4.  Select Fit View tool and the terrain should appear in the file. 
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Reference in the Existing Terrain 
1. If you have not done so already create a 2D design file as shown in Chapter 3, Step 3 and right click and select Open With, 

select the OpenRoads SS4 option. 

2. Once in the file go to the Reference tool and open the references dialog box. 

 

 

 

 

 

 

 

3. In the references dialog click the Attach Reference button. 

 

 

 

 

 

 

 

 

 

 

 

 

 

4. In the Attach Reference dialog box browse to the needed DGN terrain file.  If Survey created it, the file will be in the 

500_Pre_Design\03_Central_Survey folder.  Highlight it and click OK. 

 



 

36 

 

5. In the Reference Attachment Settings Dialog Box give the file a 

logical name, set the options as shown.  Be sure that the Nested 

Attachments is set to No Nesting and click Ok. 
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6. Go to your main view and click Fit View. The 

terrain should be displayed.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7. To change the display of the view select the 

Element Selection Tool and click and hover 

over the terrain border (edge) to get the 

context menu to appear. Click the Properties 

button.  
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8. In the Override Symbology field select Yes to be able to change the 

display of features in the terrain model. 

9. Now select Off for all of the fields you would like to display off such as 

flow arrows, low points etc. 

10. The terrain model should now display with symbology turned off or on 

depending on your selected settings.  

 

 

 

 

 

 

 

 

11. Now hover over the terrain model edge again to get the context menu 

to appear. Click the Set As Active Terrain Model button. If you have 

a file with the Ground features attach it as well.  If you select F10 

your reference file colors will appear dithered out. 
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View the 3D Features 
The quickest way to do this is to select F9 on your Key board, but it is important to understand how this all happens.  Follow the 

instructions below to view your 2D features and 3D features in the same DGN file. 

1. Open another view window. In this window open View Attributes  and select the default-3D model from the model field. 

2. To make it a bit easier to see, in the display style field select Smooth Modeling from the dropdown list 

3. Click the Fit View button in your view containing the default model and your view containing the default-3D model. Use the 

Rotate View command see your terrain in 3D. Most of the modeling will be completed in the 2D window, the 3D view is 

useful for evaluating changes to the design visually.  
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Geometry Set Up 
1. To set the Annotation Scale, go to Settings > Drawing Scale.  Toggle Annotation Scale On and set it to 1” = 40 ‘. 

   

 

 

 

 

 

 

 

 

 

2. On the tasks menu under Civil Tools > General Geometry and turn on the Feature Definition Toggle Bar (if it is not already 

on). 

  

 Geometry 
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3. On the task menu under civil tools > general 

geometry and turn on the Civil Accudraw toggle 

bar (but do not turn Civil Accudraw on yet). 

 

 

 

 

 

 

 

 

 

4. Set the feature definition to GEOM_CL and make 

sure the Use Active Feature Definition button is on.  

 

 

5. Review the horizontal alignment tools. 
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Importing Geometry from an InRoads ALG file 
1.  If you have multiple vertical alignments on one horizontal you will 

need to open the ALG before importing it into OpenRoads.  Make the 

option that you would like to import is active for each horizontal with 

more than one option. 

2.  Select the Task on the General Geometry tools set and select the 

Import Geometry Icon. 

3.  Browse to the location of the ALG file. Click Cancel on the first dialog 

box if the file is located outside of ProjectWise. 

4.  The Alignment will come in default grey with no Feature Definition.  

Select each alignment and set the Feature Definition, for Roadway 

Centerlines they should be set to Geometry Centerline/GEOM_CL 
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Creating Horizontal Geometry from PI’s 
 

 

If you use the Complex By PI method the alignment will be one element rather than multiple pieces, use the 

Feature Style Geometry Centerline/GEOM_CL.  This style will appear with stationing turned on.   

 

 

 

To add PI’s after laying out the initial alignment use the tool Horizontal 

Insert Fillet 
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Creating Horizontal Geometry from Elements 
If you choose to use the Geometry from Elements tools you will need to use Complex By Elements after to create a single 

alignment. The issue with this method is if stationing is part of the feature definition 

annotation (as seen in GEOM_CL) the old stationing for the individual elements will display 

in addition to the new stationing for the complex element. To solve this issue the user can 

use a different feature definition for the initial layout and then set the GEOM_CL feature 

definition before using the Complex By Elements command.  

 

If using the Automatic method select the first element in the alignment and indicate the 

direction see the Pink Arrow below, the rest of the alignment should select automatically. 

Click to accept the complex.  

If using the Manual method, select each individual element in the alignment indicate the 

direction see the Pink Arrow (from start location to end). Right click to finish and accept the 

complex. 
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Civil Accudraw 
The process for laying out side road elements is similar to main alignments but for added functionality/ intelligence to the 

elements the Civil Accudraw feature will be used.  

 

 

When using Civil Accudraw keep in mind which snaps are used and which fields are locked when placing the geometry, both will 

determine how the second alignment interacts with the first when it is adjusted. 

For the regular snaps here are a few examples: 

Perpendicular snap will keep the alignment attached to the first at a right angle, if no station is entered in the process it will 

move around the alignment.  

Key Point snap: this will make an element tied to the element that is selected, for example if I draw one line and key point snap 

my second alignment to this item, no matter where I move the first end point the start point of the line attached will follow.  

Civil Accudraw “snaps” explained: 

 Distance-Direction: a feature end point is located based on a given distance and direction  

 Distance Direction Unlinked: 

 Distance- Distance: feature is dependent on two defined distances, usually from a specific feature.  

 XY: feature is defined and tied to a specific XY location 

 Delta XY: feature is defined and tied to a specific point given a X and or Y offset from the given point 

 Station-Offset: feature is defined by a start specified by a station and offset from a given feature, and then has an end point 

defined by station offset or some other snap type depending on the requirement of the designer 

 Delta Station Offset: feature is defined by an offset from a chosen Station-Offset as above.   

Note: Make sure you turn off regular Accudraw when using Civil Accudraw.  
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Creating Side Road Alignments with Design Intent 
Try the following method to lock the Secondary alignment to the Main alignment. 

1.  Toggle on Civil Accudraw and set the Civil 

Accudraw snap type to Station-Offset. 

2.  Select a geometry tool: Line, Arc, Complex By PI, 

etc. A heads up menu should appear when the 

cursor is on the screen, prompting for a station.  

3.  Key in the letter O. A prompt to select a 

reference element should appear. Left click the 

Main alignment.  
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4.  The stationing in the heads up prompt will now be stationing 

specific to the reference element, i.e. if the stationing runs from 

1+00 to 3+00 those will be available, or 500+00 to 600+00 if the 

stationing was set differently. Key in a station on the element and 

hit enter. A small lock icon should appear to the right of the 

station field. 

 

 

 

 

 

5.  The cursor should now be in the offset field. Key in 0 (zero) and 

hit Enter. The lock icon should appear to the right of this field as 

well. A small blue crosshair should now be at the intersection of 

the station chosen and offset distance. This ensures that the start 

of the secondary alignment will begin at the intersection of the 

main alignment. Left Click to accept the start point. 
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Renaming Alignments 
Geometry should be named when created; in the case of complex geometry the final complex 

element should be named. Individual components of a complex element can be named as well. 

Proper naming makes finding geometry in the Project Explorer much easier down the road.  

There are multiple methods for naming elements.  

1. During element creation:  

During element creation a dialog box will appear, a name can be entered into the Name 

field for each element created. This works for single elements and complex elements.  

 

2. Heads up menu:  

Left click the element and hover over it. 

A heads up menu should appear. Select 

the Properties command. A properties 

table will appear, change the name in 

the Feature Name field. 

 

 

3. Project Explorer: 

Go to the Project Explorer> Civil Model tab and 

right click on the element name. Select Properties 

from the dropdown menu. A properties table will 

appear, change the name in the Feature Name field. 
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Creating Vertical Geometry 

5.8.1 Displaying the Existing Ground 
1. Open the profile view for the selected alignment.   In Tasks> Civil Tools> Vertical Geometry select the Open Profile Model 

command. A prompt will then ask the user to Locate Plan Element, Left click to select the Element. 
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2. A prompt to Select or Open View will appear. Select an unused view 

from the view groups box.  

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Once the view opens, left click inside the view. 

An X and Y axis should appear in the profile 

view and the alignment will be highlighted blue 

with chevrons in the plan view. This indicates 

which alignment is in the active profile view. 
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4. Display the existing surface on the profile model.  Select the 

ground terrain model and hover to get the context menu to 

appear. Click the Set Active Terrain model command.  The 

terrain profile should appear in the profile view.  
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5.8.2 Creating a proposed Profile 

This example will show how to create a very simple proposed profile. See the Bentley tutorials for more a detailed explanation of 

the vertical geometry tools.  

1. Go to Tasks> Civil Tools> Vertical Geometry and select the Profile Line 

Between Points command. 

  

 

 

 

 

 

 

 

 

2. The Profile Line Between Points dialog box will appear. Fill in the Name field 

(something that will help identify the profile later). 
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3. A prompt to Pick Profile View will appear, left click in the view window 

with the active profile (the one that has the existing ground 

displayed). Ther Enter Start Point prompt will appear. In the profile 

view select your starting point, a blue perpendicular line in the Plan 

view shows represents the location of the start point. (In this example 

the end point of the exisitng ground was selected to tie the proposed 

alignment in with the existing ground.)  
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4. The next prompt is Enter End Point. In profile 

view select the end point, it will also be 

displayed in plan view with a perpendicular line.  

 

 

 

 

 

 

 

 

 

 

 

 

 

5. The feature definition can be changed to make it 

easier to distinguish profile alternatives.  
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6. Add curves into the profile.  Go to Tasks> Civil Tools> 

Vertical Geometry and select the Profile Insert Curve 

command. 

  

 

 

 

 

 

 

7. A Locate Tangent to Insert Curve prompt will appear. Left 

click to select the profile line.  

 

 

 

 

 

 

 

 

 

8. The next prompt is Locate Vertex. Left click to select a 

vertex point for the curve.  
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9. It will now prompt for a Through Point. Make sure the 

Vertical Curve Parameter box is unchecked. Select a 

through point on the profile screen or by entering in a 

vertical curve parameter or length and left clicking 

through the heads up fields to accept. The proposed 

profile should now be displayed. 
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5.8.3 Vertical Alignment Alternatives 
Multiple profile alternatives can be created on the same plan element. In this example there are two proposed profiles. It is here 

that properly naming elements is especially important. When selecting alternatives or comparing alignments, properly named 

elements will be much easier to identify in the project explorer, as well as identifying element dependencies. 
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What’s Different in New CTDOT ITL? 
The Template Library will look very similar to what you were used to with InRoads SS2. The following changes to the points and 

components in the SS4 template library allow more functionality when assigning superelevation to a corridor and when creating 

terrain models using graphical filters. 

 Superelevation flags  

 Rollover locks  

 RDWY-Subgrade, -Base, and -Rock feature definitions assigned to points below finish grade  

There are also a few additional styles for points that are only found in SS4.  

Superelevation Flags  

In SS4, superelevation flags are set on component template points at the finish grade from the center line out to the 

travel lane.   

Rollover Locks  

You will need to set locks on Rollover Values for points in your assembled templates that are at the finish grade, but 

outside the edge of the traveled way.  

 Template Library 
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Working with the Template Library 
 

1. To open the Template library in the Workspace go to Tasks > Civil Tools > Cooridor Modeling > Create Template or select 

F12. The Create Template Dialog Box will open and the Template Library file on the Workspace will be pointed to as read 

only.  

 

2. If you would like to make modifications to the Templates select File > Open and open the Template Library file that you 

copied over in the getting started section on this manual.  Click on the ITL and select Open. 

 

 

 

 



 

60 

 

3. Use the Project Library Folders as your working area by copying the needed pre-designed 

templates down from the top folders.  This way you always have a fresh copy to use as 

your build you specific project templates. 

If you are going to build your own templates or modify the one supplied you will need to 

have a vast understanding of which feature styles to use and what settings are specific to 

different point and component types. Browse to the template HWY Typical Section > 

2ln_PS5_BCPC.  Double click on the different points, closed shapes and end conditions.   

Take note of the following settings. 

A. Feature Styles 

B. Feature Name Overrides 

C. Superelevation Flags (new for OpenRoads) 

This template is a two lane road with bituminous concrete curbing using the pavement 

structure #5.  Pavement Structures are found Appendix B of The State of Connecticut 

MTG Pavement Design Catalog. 

 

http://www.ct.gov/dot/lib/dot/documents/dpavement/mtg_pavement_design.pdf
http://www.ct.gov/dot/lib/dot/documents/dpavement/mtg_pavement_design.pdf
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A. FEATURE STYLES 

Point Feature Suffix…. 

On the top surface BKLN_ 

Below the top surface BKLN_Sublayer 

 

    
 

Components Suffix… 

Material_ 
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B. FEATURE NAME OVERRIDES 

Points on end conditions 

Make sure to Use Feature Name Overrides on Cuts, Fills and the Snow shelfs. 

 

End conditions components 

In the end condition components, the "Use Name Override" needs to be set for like slopes.  For example, you have 

4 possible ditch backslopes where only one at a time can solve.  Setting the feature name override in the 

component properties assures the model stitching using the same component name.  This is similar to what you 

have done correctly in the point properties for the point feature override. 
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C. Superelevation Flags 
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Design Stages 
Before creating a corridor it’s important to understand the Project Settings for Design 

Stages.  A design Stage is selected when first creating a corridor and it modified as 

the design progresses from conceptual to Final design.  Design staging helps users to 

optimize their computers processing speeds by the managing corridor modeling 

details to only what is needed for the stage they are in. 

Select the Project Explorer, Civil Standard Tab.  Under Libraries select 

Project_Settings.dgnlib\Coordor Design Stages.  Study at the Properties presets for 

each stage. 

 Corridor Modeling 
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7.1.1 Template Management 
Manages the template drops on a straight piece of road.   

(Template Drop Interval Multiplier)   X     (Drop Interval)  

        

      Design Stage                          Create Template Drop Dialog Box 

Conceptual Design Stage -       5 X 10 = Template drop created every 50’ 

Design Design Stage-              2 X 10 = Template drop created every 20’ 

Final & Publish Design Stages - 1 X 10 = Template drop created every 10’ 
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7.1.2 Include Critical Sections 
Manages the template drops at critical sections.  Publish is set to true for all fields,  

this level of accuracy will not be needed in Conceptual and Design Stages in turn some 

of these are set to false. 

   

 

 

 

 

7.1.3 Display settings 
Display Settings point to the look and feel of the graphical 

representation of the corridor, these are displayed as construction 

classes as they is not a real world features.  Users can easily turn 

these off by deselecting Constructions in Veiw Attributes. 
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7.1.4 Output Settings 
All the base Design Stages are set the same (Conceptual, Design, Final 

& Publish Design) for the Output Settings. 

There are separate stages set up for the output of different Mesh 

surfaces if needed. 
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7.1.5 Updating the Design Stage 

1. Left-click on the corridor (tip: click on a handle, or confirm from the pop up upon clicking that you have selected a corridor).  

2. From the context-sensitive commands, select Properties (the left-most icon).  

3. In the properties table that opens, use the dropdown to select a Design Stage.  

4. After making the selection, WAIT until the properties box goes away. It can take a while for the model to update, and making 

another selection while it is processing might cause the application to crash. 
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 Corridor Modeling 
Corridors and models are no longer created in the Roadway Designer; they are created directly 

in the MicroStation Screen. The prerequisite for creating a corridor is to have a civil geometry 

horizontal alignment with a vertical profile, either loaded or referenced.  

When you create a corridor, a 3D model is automatically created and attached to the 2D 

model.  

7.2.1 Creating a Corridor 
1. Go to Tasks> Civil Tools> Corridor Modeling and select the Create Corridor Command.  

2. The Create Corridor dialog box will appear as well as a prompt to Locate Corridor Baseline. 

Enter in a name in the Corridor Name field, select a Design Stage and select the plan 

element for the corridor.  
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3. A prompt to Locate Profile Element will appear. Select the alignment in Profile view, select a profile from the dropdown menu 

in the dialog box, or right click to select the active profile. By selecting the Active Profile option the user can easily switch 

between profile alternatives and see how this affects the corridor model.  

 

 

 

 

 

 

 

 

 

 

 

4. Enter a Corridor Name and left click to accept.  A corridor 

feature should now be displayed around the alignment (the 

shape may be a different color depending on which design 

stage was selected when creating the corridor.  
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5. The Select a Template prompt will appear, click the ellipses button or 

Alt+Down to browse the templates. Select a template and Click OK. 

 

 

6. Left click to accept and apply the template, follow the prompts for Start Station, End Station, Drop Interval, Minimum 

Transition, Maximum Transition, and Description.   The components of the model should be displayed in plan view was well as 

the 3D model if it is open.   

 

NOTE: If you right clicked off to cancel the command after the corridor 

was created you will need to select the Create Template Drop Icon to 

continue.  Follow the prompts to select a template. 
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Superelevation  
Superelevation is calculated and created differently in OpenRoads than InRoads, it uses SRL and SEP files instead of SUP files. 

Much of the application is done graphically using the heads up menus rather than the templates.  

In InRoads V8i SS4, the superelevation may be created in an entirely separate, 2D .dgn file and is not required to be in the same 

model as the corridor. The superelevation uses the referenced in horizontal alignment geometry to define sections and lanes, and 

to calculate transitions. When the superelevation is assigned to a corridor, it creates point controls on every point in the 

templates that are marked with the superelevation flag.  

Designers may also create point controls using features or feature definitions from a 3D terrain model referenced into a 2D 

corridor. See the workflow Using DTM Features as Targets for Point Controls in SS4. 

 

At this point the user should already have the following items: 

 Terrain file (existing ground surface) 

 Centerline geometry (horizontal alignment) 

 Profile geometry 

 Corridor 

 Template drop(s) 

 

Quick Step Preview:  

STEP 1.  Create Superelevation Sections 

STEP 2.  Create superelevation Lanes  

STEP 3.  Calculate Superelevation 

STEP 4.  Assign Superelevation to Corridor 
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7.3.1 Step 1 - Create Superelevation Sections 
1.  Open the Level Manager and set the level CORR_Superelevation active.   

2.  The Superelevation tools are located under Tasks > Civil Tools > Corridor 

Modeling. Select Create Superelevation Sections and follow the prompts. 

 

 

 

 

  

3.  Give the Section a Name and specify the Minimum Tangent Length. 

 

 

 

 

   

4.  Data point the centerline alignment and left click to accept. 

5.  Another dialogue box should appear, select the Start and End Stations and 

click through to accept.  

 

 

Note: If you do not want to have multiple superelevation sections 

created set the Minimum Tangent Length to a very large number. This 

will force the product to create only one superelevation section for 

your entire corridor. The only reason you may want multiple sections 

is if your design speed changes within the limits of your corridor. 
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6.  A green outline will appear around the Superelevation section that was 

just created 

 

   

7.3.2 Step 2 - Create superelevation Lanes 
1.  The next superelevation task will automatically start, Create Superelevation Lanes. This step needs to be done twice, once for 

the left lane and once for the right lane. For roads with more than 

two lanes additional super lanes will be required. In this example a 

two lane road is used.  

2.  Give a meaningful name to the lane. 

3.  Select which side of the centerline the lane is on. 

4.  Determine the inside edge offset (in the case of a two lane road 

each lane would have an offset of 0. For a multilane road the inside 

edge offset would be the width from the edge of the lane to the 

centerline.  

5.  In this example the normal cross slope is 1.5% because it is a two 

lane road, for a 4 lane road the outermost lanes would have a 

normal cross slope of 2%. See the HDM for more information on 

lane cross slopes. 

6.  Repeat process for each lane (in this example the create super 

elevation lane command was done twice, once for the left, once for 

the right) 
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7.3.3 Step 3 - Calculate Superelevation 
Once the lanes are created, right click to reset and move on to the next tool. The calculate superelevation dialogue should 

appear automatically.  

1.  Browse to the superelevation resource files and select File of Type. The SEP or SRL format can be used, each has multiple 

AASHTO years, select the most recent year.  

 

 

 

 

 

 

 

 

 

2.  The next dialogue box to appear will depend on which file type was selected for calculation. For the SEP file method, the 

dialogue box will ask for the following fields. Data point through the fields to accept the entries.  

a. E selection, CTDOT uses an e max of 6% for rural 

roads and 4% urban roads. 

b. L selection 

c. Design speed 

d. Transition ID 

e. Number of lanes 

f. facility 
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7.3.4 Step 4 - Assign Superelevation to Corridor 
The next step is to assign the superelevationto the corridor.  

1.  Click the Assign Superelevation to Corridor Command  

2.  When prompted, select the super sections.  

3.  When prompted, select the corridor.  

4.  The associate superelevation window should appear. Check over the points to make sure there are no errors and that the 

superelevation points and pivot points make sense, SHDR_lt with the left super lane and SHDR_rt with the right super lane.   
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5.  Click OK, The Superelevation graphics should appear.  The normal crown, reverse crown, and full super points should appear 

with labels as shown below. 

 
To get a thematic visualization of the super grade changes toggle on the fill button in the view attributes window.  
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Modeling Intersections  
Side alignments are modeled a bit differently because the main line is constraining how the side road behaves. The side road 

alignments and corridors have to be adjusted to meet into the new proposed mainline.   

7.4.1 Creating the Side Road Alignment 
1. Follow the steps in section 3 to create the side road horizontal alignment and 

vertical profile window.  

2. Display the points on the main line which cross the side road alignment. Go to 

Tasks> Civil Tools> Vertical Geometry and select the Profile Intersection Point 

command. 
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3.  The prompt Locate Element to Show Intersection will appear. 

Select the side road alignment. 

 

 

 

 

 

 

 

4.  Another prompt will appear asking to Locate Element 

Which Intersects. This is asking which element crossing 

points the user wants to appear on the profile. In this 

example the Main Road alignment, shoulder line, and 

edge of road elements were selected. When finished 

selecting elements, right click to complete the selection. 

 

5.  The crossing points should now be displayed in the 

profile view. Fit view may be needed to locate the 

points, and the colors/ line weight may need to be 

changed to make them more visible.  
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6.  Hovering over a point in profile view will tell the 

designer what feature the point is representing as 

well as geometric information. 

 

 

 

 

 

 

 

 

 

7.  Create profile elements for the side road alignment.  

To maintain the side slope of the road, the side road 

alignment will need to match in to the main line. The 

points displayed earlier will help the designer achieve 

this. Select the Profile Line Between Points command 

and connect the crossing points. In the example 

shown the top vertical alignment is only connected to 

one crossing point. The lower alignment is connected 

to all three of the crossing points. The Profile 

Complex By Elements command can connect 

individual elements to create a single profile. * 

Remember to use meaningful names when creating 

profiles.  
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8.  This example shows the difference 

between the models using the top 

profile and the bottom profile.  

 

 



 

82 

 

 

7.4.2 Creating the Side Road Corridor 
1. Create the Side Road Corridor. Now that the profile is complete, a corresponding corridor needs to be created. *Remember to 

name the corridor correctly to avoid confusion later.  

2. Attach a template to the corridor. The designer can edit the corridor as needed and create alignment elements for the 

corridors and adjust the template drops as needed, or they can use a civil cell.  
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Civil Cells 
There are many different types of civil cells that help automate design tasks. Civil cells use reference elements for placement, 

meaning you can use the same civil cell in many locations and it will change based on the reference elements used to place it. 

Civil cells can be edited after placement as well has “dropped” to allow the designer to use pieces of a civil cell if necessary.  

1.  To place a civil cell go to Tasks> Civil Tools> Civil Cells and 

select the Place Civil Cell command.  

2.  The Place Civil Cell dialog box will appear, click the ellipses 

button to browse available civil cells. When selecting a civil cell 

preview will be shown to the right of the selection. Click OK.                           
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3.  The prompts that appear with each civil cell vary based 

on what type of civil cell is being placed or what the 

creator of the civil cell labeled the references as. The 

reference prompts are usually intuitive, so be sure to 

read the prompt.  In the example the prompts indicate 

two reference elements are needed, one for the Side 

Road Center Line and one for the Main Line Edge of 

Road.   
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4.  Elements of the civil cell should now appear on the screen, if there 

are alternative configurations you can view them at this point by 

selecting elements, or you can right click to move to the next step. 

 

 

 

 

 

5.  The next prompt will ask for the user to Select Corridors To Be 

Clipped.  

 

6.  Left click to accept civil cell placement.  The corridor template 

graphics are visible on the main line. This will be edited in the next 

section. 

7.  Adjusting corridors.  Corridors have an outline around them 

identifying the limits of the corridor; this is similar to the outline in 

the Roadway designer from SS2.  

8. Adjusting a corridor using properties. The heads up menu will 

appear if the corridor element is clicked and hovered over. From 

the menu, the designer can open the properties and change the 

start/ end range of the corridor.  The limits should change 

graphically.  

NOTE: this prompt will only appear if a clipping boundary was 

added to the civil cell when it was created. In this example the 

main line corridor and the side road corridors were selected. 

Right click to move on once the corridors (if any) have been 

selected.  
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9. Adjusting a corridor using handles. The designer can also adjust a 

corridor using handles. The lines perpendicular to the corridor 

graphic are the handles. When selecting a corridor graphic small 

blue numbers will appear at key points. Clicking on them will give 

you the ability to edit the number and adjust the value. There are 

also small blue arrows at some locations. These can be dragged to 

adjust the corridor dynamically instead, as well as snapped to 

certain locations if the element is snappable.  

10. In this example, the side road corridor has been adjusted to the 

back of the civil cell corridor graphic. The side road surface is no 

longer breaking through the main line.  

11. Editing geometric elements. Depending how an element is 

created, the designer can edit and adjust elements without 

disrupting and breaking apart the model. Many elements which 

selected will have blue handles appear as well as blue numbers. If 

there is a handle and number it means the element was created 

using design constraints. Many handles can be adjusted 

dynamically or the numbers can be entered manually. In some 

cases the changes may break an element but the undo command 

is useful when trying to edit elements.  
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12. In this example there are three stages shown. The plan 

view, cross section view and 3D view are all visible. The 

first picture is the original model, the second had the 

alignment straightened and the third shows the radii of 

the intersection increased. Only elements in the 2D view 

were changed. The OpenRoads software automatically 

adjusts dependent 2D geometry, cross sections, profiles, 

and 3D models. This means less work for the designer as 

profiles, cross sections and 3D models do not need to be 

re-run each time a design change is made, all of these 

elements adjust automatically.   

NOTE: because of the changes the program needs to 

make to the model, when changing element values, 

allow the program to catch up and display the changes 

before moving on to the next edit.   
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Within InRoads SS4 the majority of the plan production is done using the native tools and native file formats. In order to 

facilitate the usefulness of these tools, this section will focus on moving the OpenRoads data (Geometry and Terrains) back to 

the native data formats. These files can then be used to create plan sheets and profile sheets.  Ultimately, OpenRoads Designer 

CONNECT Edition will have a new set of fully-integrated plan production tools. Today, however, along with the OpenRoads tools, 

the native tools are also available in the SELECTseries 4 versions. 

In this exercise, you will learn how to export an OpenRoads terrain model and Geometry to the native InRoads file formats (dtm 

and alg).  You will need to convert your geometry back to an ALG file type to be able to use the InRoads SS4 Plan and Profile 

Generator. You will also need to convert your top proposed surface back to a DTM.   If you do not have an existing DTM your 

terrain will need to be converted back to a DTM as well. 

If you chose to hide the InRoads dialog box you will need to open it again.  On the 

MicroStation top menu bar go to  

Applications > InRoads Group > Tools > Explorer Show/Hide 

 

 Plans Production 
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Exporting Data 

8.1.1 Export to an ALG 
1. In InRoads Explorer select the Geometry tab, right click on 

Geometry Project and select New.  Type in a name in the Name 

field and click Apply and Close. 

 

 

 

 

 

 

 

 

 

2. Right click on the new Geometry Project and select Save As.  If 

you completed Step 6 in Chapter 3 you will see your project 

path on the top portion of the Save As dialog box.  The Internal 

name you gave will be filled in the File name field.  Select Save 

and Cancel. 
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3. Before exporting to the new ALG file make sure all horizontal and vertical 

alignments have feature names. 

A. Click on the horizontal alignment in check Element information locate the 

Feature Name field.  If it is blank give it a name. 

B. Click on the vertical alignment in check Element information locate the Feature 

Name field.  If it is blank give it a name. 

 

 

 

 

 

 

4. Now you are ready to complete the export on the Task menu. On the task menu 

select the Export to Native tool. Follow the prompts and select the Horizontal 

alignments you wish to export.  It is not required to select the vertical alignment 

because they are children of the Horizontal and will automatically export with the 

Horizontal.  

 If you do try and select the verticals MicroStation will lock up and you will 

be kicked out of the application. 

 Check the InRoads Dialog box and confirm everything came over. 

 If you do not see a vertical appear in the alg it’s because a Feature Name is 

missing (go back and do step 3) 
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8.1.2 Export to an Existing DTM 
If there is not an existing DTM, designers will need to call Central Surveys and ask 

them to do the following in OpenRoads. 

1.  Select on Terrain Model on the task menu and select the Export to File icon.  In the 

Export Terrain pick box select: 

Select Terrain: Existing 

Export Format: InRoads DTM (.dtm) 

2.  Place the DTM in the ProjectWise project folder under 

\500_Pre_Design\03_Central_Survey\ 

 

 

 

8.1.3 Export to a Proposed DTM 
1.  Open your main design File. 

2.  Change the corridor’s Design Stage to display the top mesh. 

a. In View 1, select the corridor. (Use the handles if necessary) 

b. From the context menu, select Properties 

c. Change the Design Stage to Publish Top Mesh. 

d. The corridor model changes to display a mesh of the proposed top surface. 

After creating the top mesh along the corridor, we will create a new dgn in which the 

proposed terrain model will be stored. The main corridor will be referenced into the new 

file to be utilized in terrain creation. 
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3.  Create a new 3D dgn to store the proposed terrain from the corridor and open 

it. 

4.  Reference the Main Design File into the Proposed Terrain File. Set Live Nesting 

to 2. 

5.  Create a terrain model from the mesh. 

a. On the task menu, open the Terrain Model toolbox. 

b. Select the Create from Elements tool. 

c. First, on the Create Terrain Model dialog box... 

 Set the Feature Definition to TERR_Contours 

 Name the terrain Proposed Terrain. 

 

d. Then, following the prompts, locate the elements to add and select the 

mesh element. 

e. Click Reset when done. 

f. Set the feature type to Break Line. 

g. For the Edge Option, select Max Triangle Length 

h. Set the Max Side Length to 5.  The terrain model is created. 

i. Turn off the display of the main file and review the terrain model. Do not 

detach the reference file. 

NOTE: This terrain model is linked or “ruled” to the corridor 

model in the main file. The terrain model will update when 

modifications to the corridor are made. If the referenced corridor 

is detached, the link between the terrain and the corridor will be 

broken. 
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8.  Export the Proposed Terrain Model to its native file format.  The 

plan production tools rely on the native file format, therefore we 

will now export the proposed terrain model to its native file 

format. 

a. Select the Proposed Terrain element in the file. 

b. From the context menu, select the Export Terrain Model 

tool. 

c. Select the DTM file format. 

d. Click Save.  The terrain is saved into the selected native 

file format. 
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Geo-Referenced Plan Cut Sheets 
A Geo-Referenced Plan Cut Sheet is composed of a MicroStation sheet model with the existing ground survey file(s) and the 

proposed design file(s) referenced in geospatially correct. Designers can use InRoads – Plan and Profile Generator to create plan 

cut sheets or can create plan sheets using just MicroStation tools. Option 2 using the InRoads Plan and Profile Generator is 

recommended if the project is long, requiring a large number of sheets.  Option 1 maybe a better choice for smaller projects.   

Regardless of the method used to create the sheets the following should be adhered to: 

 The MicroStation view will be rotated, not the reference files.  

 Use the MicroStation Tasks for CT DOT Sheet Composition. 

 Only one border cell is in each sheet model file (Plan Sheet) 

 Call outs for pay items, beginning and end of project, limits of construction will be in the sheet model file.  

 General notes, ROW legend and construction notes for small projects are usually included on the first plan sheet model. 

For larger projects a separate sheet may be required for the notes and legend.  
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8.2.1 Option 1 - MicroStation Plan Sheet Creation 

Attach Reference Files  

1. In ProjectWise use the Advanced Wizard to create and open a new MicroStation dgn file, use one of the following 

ProjectWise seed files:  

05.0 - Workspace Resources\3_Workspace_V8i\Civil_Standards\seed\2D_OpenRoads_SheetSeed_83.dgn 

 or 

05.0 - Workspace Resources\3_Workspace_V8i\Civil_Standards\seed\2D_OpenRoads_SheetSeed_27.dgn 

 

 

 

 

 

 

 

 

 

2. If you are already in MicroStation the new file will 

automatically open after completing the Wizard, if you 

are creating a file from ProjectWise Explorer you need 

to do an Open With and in the Open document with 

dialog box select MicroStation SS4 OpenRoadsSS4 and 

Click OK. 
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3. Reference in the required Proposed and Existing MicroStation Dgn files 

a. Select the required model. 

b. Type in logical names such as 2D Highway or SWW Survey. 

 

 

 

 

 

 

c. Change the Nesting Attachment Setting as needed. 

d. Select Coincident, Detail Scale 1:1, and True Scale OFF. Click OK 

 

4. In your MicroStation view window click on Fit View. Double-check that the 

survey ground file came in at the correct location, zoom to a coordinate 

grid cross and snap to it, the XY-axis in the MicroStation command window 

should display the same numbers as the northing and easting of the 

coordinate grid cross. If something is incorrect check the Scale of your 

reference file(s), it should be 1:1. If it is not, select the reference file(s) 

and change the scale to 1 to 1. 

 

Note: The SWW Screening code (Screen With Weights) is used to 

screen existing survey files. The weights of the line styles within 

that file will be maintained, but the color will be muted. If you 

want to screen multiple files, type in SWW1… SWW 2 and so on.  
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5. Open Level Display, The Level Display box will show you the active and inactive levels 

for the selected view (active view window); select the All Used Levels display filter. In 

each reference file click on the levels you want to turn off. You can also right click and 

use Off By Level and pick the lines / points of a particular level to turn off the level in 

the view window. You can turn off the levels in just one view or in all open views. 

 

 

 

6. Click on the Reference File icon. Select Settings > Update Sequence. 

Using the Update Sequence Tools move the files either up or down to the 

desired location(s). The Active Design File should be the last file in the 

update sequence, meaning this is the last layer the printer prints.  

Sequence order for Highway Plan sheets: Survey, Design, Active File. 

    

 

 

 

7. On the MicroStation menu bar click File > Save Settings to save all the 

settings you changed, such as all the levels you turned off in the 

reference files and in what view. 
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Place the Border and Clip the Reference files Boundaries  

The plan border cell and transient shape (sheet boundary) are used to define the 

layout of the paper for plotting a sheet model and are set to fit onto standard 

paper sizes (print/pdf sizes).  This workspace uses a plan sheet size of 22” x 34” 

(ANSI D), this is the actual paper size. 

1. On the MicroStation main Menu bar select Settings > Drawing Scale.  

Choose 1’=40” 

 

2. On CT DOT Sheet Composition task menu.  Select the Borders task and 

click Contract Border. The Place Active Cell command with the Active Cell: 

BDR_Plan is activated.  Place the plan border cell in your plan sheet model 

where you want it. Follow the command prompts to rotate and place the 

border. 
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3. Rotate the MicroStation window view. Click on the Rotate View 

icon located on the top or bottom of your view window. Set the 

method to  2 Points.  

4. Copy the North Arrow from the Survey Ground file into your sheet 

model (this is the only item/cell you will copy from the survey file).  

5. If you are unable to fit the entire design within one border, 

additional plan sheet models need to be created. Place match 

mark lines at full stations where the sheets will be split. Match 

mark lines are perpendicular to the baseline/centerline. On the CT 

Sheet Composition Task under Contract Sheet Annotation select 

Match Mark Line. 

6. On the CT Sheet Composition Task under Borders select Create 

Clipping Shape; this activates the Place Shape command.  Place a 

shape around the reference elements you want within your 

clipping boundary. 

7. In the references dialog box select all of the 

reference files you want to clip. Select Clip Boundary 

on the References dialog box and select.  Choose the 

Method: Element. Data point on the shape (clipping 

boundary shape).  

8. Fit View. Save Settings.  
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Placing the Transient Shape  

1. Click on the Models Icon.  

 

 

 

2. In the Models dialog box click the Define Sheet Boundary icon. 

3. In MicroStation window click on Fit View to locate the transient shape (cut 

sheet border definition shape). 

 

 

 

 

4. On the Sheet boundary dialog box click Move, click over 

the transient shape and move it to the desired location. 

Click to place it at the new location, right-click to 

release the move command. If you need to rotate the 

transient shape, click Rotate on the Sheet Boundary 

dialog box, follow the MicroStation command prompts 

(right bottom) to rotate the transient shape. 

 

 

 

5. Fit View and Save Settings.  
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Border Title Block Information 

1.  The plan sheet’s title block needs to updated and have only the correct designation levels turned on for Design Phase and 

Scale. 

     

2.  Use the Edit Text tool to update the title blocks , Project Title, Town(s), Project #(s),Drawing Title, Drawing # 
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Contract Sheet Annotation  

All annotation such as: call outs, labels, notes and dimensions are placed in the sheet models. 

It is important that the correct tasks and levels are used. 

1.  Click on CT DOT Sheet Composition. 

2.  Click on the Contract Sheet Annotation task group. 

3.  Associate the note with the item on the cut sheet, turn on Association Lock and then 

toggle on Association on the Place Note command. With association turned on, the notes 

can be moved and the terminator will stay/remain at the pay item where it was originally 

placed. This helps when it becomes necessary to relocate a call out. 
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8.2.2 Option 2 - InRoads Plan and Profile Generator 
1.  Open your main modeling DGN file.   

2.  Make sure the ALG and Proposed and Existing DTM’s are 

opened. 

3.  To generate plan sheets select Drafting > Plan and Profile 

Generator on the InRoads Dialog Box. 

4.  Select the Highway Preference and select each tab to edit as 

necessary (AT THIS POINT DO NOT CLICK ON THE PROFILE 

CONTROLS TAB, this will mess up your settings “INROADS 

GLITCH”) 

 

 

 

5.  On the Main Tab select the Horizontal Alignment. 
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6.  On the Plan Controls select and browse to the needed Model Files… 

 

 

 

 

 

 

 

 

 

 

7.  On the Borders and Titles Tab the following should be set. Cell toggled 

on and is set to B-Contract. Retain Cell Levels for Each Sheet is on and 

the Scale is set to 480. 
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8.  On the Sheet Layout Tab 

a. Select to pick a Host File, this will be the name of the newly 

created Plan Sheet DGN files.  

b. In the Save As dialog box direct your files to be created in the 

correct ProjectWise folder by clicking on the Change button.    

c. Give your Document a Name, File Name and a description and click 

Save. 

 

 

 

 

 

 

 

 

 

 

d. Select to pick a Seed File.   

Browse to: 

05.0 - Workspace Resources\3_Workspace_V8i\Civil_Standards\seed\2D_OpenRoads_SheetSeed_83.dgn 

 or 

05.0 - Workspace Resources\3_Workspace_V8i\Civil_Standards\seed\2D_OpenRoads_SheetSeed_27.dgn 
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7 .  On the View Layout Tab the Scale should be set to 1 = 40.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

8 .  Select the Match Line tab and assure that the Match lines are set to 

level ANNOT_Sheet_Match_Mark. 
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9.  Click Apply on the Plan and Profile Generator and plan cut 

sheets will be produced 

10.  Open each file and modify the Model Properties.  Open the 

Models Dialog box, right click on the Sheet Model and select 

Properties, 

 

 

 

11.  In the Models Properties Dialog Box change annotation scale to 1”=40’.  

Click the OK Button. 
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12.  Back on the Models Dialog box select the Define Sheet Boundary Icon. 

Adjust the Models Sheet Boundary to line up with the Border. You will 

need to use both the rotate and move tools to accomplish this. 

 

 

  

 

 

 

 

 

 

13.  On the MicroStation top menu bar select Settings > Drawing Scale and assure the the 

Lock Auxiliary Coordinate System is NOT on. 

14.  On the MicroStation top menu bar select File > Save Settings. 
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  Profile Cut Sheets 

8.3.1 Option 1 - MicroStation Profile Sheet Creation with InRoads Grid 

Place Profile Grids 

1.  In ProjectWise use the Advanced Wizard to create and open a new MicroStation dgn file. Use the Multi Model ProjectWise seed 

file, this will house 2D Design Model for the Profile Grids and several sheet models for each grid: 

05.0 - Workspace Resources\3_Workspace_V8i\Civil_Standards\seed\2D_MultiModelSeed.dgn 

  

2.  If you are already in MicroStation the new file will 

automatically open after completing the Wizard, if you are 

creating a file from ProjectWise Explorer you need to do an 

Open With and in the Open document with dialog box 

select MicroStation SS4 OpenRoadsSS4 and click OK. 

 

 

 

 

 

3.  When the file opens you will need to start off in the 2D 

Design Model. 
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4.  Make sure the ALG and Proposed and Existing DTM’s are opened.  Use the InRoads dialog box to view the active Horizontal 

Alignment and Stationing. (When viewing the Stationing set the GOEM_CL preference active). 
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5.  Create profile separate grids to match the Plan Sheet Stationing.  On the InRoads dialog box select Evaluation > Create 

Profile. Select the Highway Preference and toggle on the Existing Surface.  
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6.  These grids will be placed on a sheet so you will need to adjust the Control settings to ensure both the horizontal and vertical 

limits will fit inside each Border.  Click on the controls folder and set the Station to line up with the matching Plan Sheet.  

Optional Elevation Settings:  

 Control the exact elevations, under the Elevation section toggle on the Use and set as needed. 

 The window Clearances can also be adjusted.  

7.  Click Apply and follow the prompts to place each grid. 

   

                 Plan Sheet 1 = Profile Sheet 1                                 Plan Sheet 2 – Profile Sheet 2 

 

8.  View the Vertical Alignment. On the InRoads dialog box select Geometry > Active Vertical. 
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9.  View the Vertical Annotation. On the InRoads dialog box select Geometry > Vertical Annotation. On the View Vertical 

Annotation dialog box select the Highway Preference and click Apply.  Profile 1 will update.  Select the next Profile Set and 

click Apply.  Do this for each profile. 
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Create Profile Sheet Models 

1.  In the same DGN file open the 2D_Sheet Model.  

      

    

2.  Rename the Sheet Model’s Name and Description to correspond with the matching Plan Sheet. 
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3.  Reference in the main Profile 2D_Design model using the top view orientation. Data Point on near the middle of the border.  

After the File is attached move is as needed and clip the boundary. 
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4.  Make a copy of the first profile sheet model to house the next profile sheet.  

   

5.  Open the new sheet. Select Reference file and Delete Clip Boundary. Move the reference file so the next profile is centered 

over the border and re-clip the Boundary 
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8.3.2 Option 2 - InRoads Plan and Profile Generator 
1 .  Create a 2D Design Model DGN File to house the Profile Grids.  Make sure the ALG and 

Proposed and Existing DTM’s are opened. 

2 .  To generate profile sheets Select Drafting > Plan and Profile Generator on the InRoads 

Dialog Box 

3.  Load the Profile Generator Format Preference. Select each tab to edit as necessary 

(CLICK ON THE PROFILE CONTROLS TAB LAST. This needs to be done this way to work 

around an “INROADS GLITCH”) 

 

4.  On the Main Tab select the Horizontal Alignment. 
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5.  On the Borders and Titles Tab the following should be set. Cell toggled on and 

is set to B-Contract. Retain Cell Levels for Each Sheet is on and the Scale is set 

to 480. 

 

 

 

 

 

 

 

 

 

 

6.  On the Sheet Layout Tab 

e. Select to pick a Host File, this will be the name of the newly created 

Profile Sheet DGN files.  

f. In the Save As dialog box direct your files to be created in the correct 

ProjectWise folder by clicking on the Change button.    

g. Give your Document a Name, File Name and a description and click 

Save. 

h. Select to pick a Seed File.   

Browse to 05.0 - Workspace 

Resources\3_Workspace_V8i\Civil_Standards\seed\2D_SheetSeed.dgn 
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10.  On the View Layout Tab the Scale should be set to 1 = 40.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7 .  On the Profiles Controls tab 

8 .  Click Apply on the Plan and Profile Generator and data point in the DGN to 

select the starting point for the profile grids.  This file will be automatically 

referenced into the profile cut sheets.  

9 .  Open the profile grid layout dgn. Using the InRoads dialog box view and 

annotate the vertical alignment.  

Geometry > View Geomentry > Active Vertical 

Geometry > View Geomentry >Vertical Annotation 
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15.  Open each file and modify the Model Properties.  Open the 

Models Dialog box, right click on the Sheet Model and select 

Properties, 

 

 

 

16.  In the Models Properties Dialog Box change annotation scale to 

1”=40’.  Click the OK Button. 
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17.  Back on the Models Dialog box select the Define Sheet Boundary Icon. 

Adjust the Models Sheet Boundary to line up with the Border.  

 

 

  

 

 

 

 

 

 

18.  On the MicroStation top menu bar select Settings > Drawing Scale and assure the the 

Lock Auxiliary Coordinate System is NOT on. 

19.  On the MicroStation top menu bar select File > Save Settings. 

 

 



 

122 

 

Cross Sections 

8.4.1 Crossing Points on Cross Sections 
The following Features have been set up to show crossing points on 

cross sections.   

Boundary  Ex is t ing  Fences  Ex is t ing  St ructures  Ex is t ing  Walks  

BND_Acqu is i t ion  EX_BARR_FEBRD Board  EX_STRUCT_BLDG Bui ld ing  EX_WALK_BC Bi tuminous Concrete  

BND_Construct ion  EX_BARR_FECHLK Chain L ink  EX_STRUCT_BLDGC  Bu i ld ing  (c losed)  EX_WALK_BK Br ick  

BND_Easement  EX_BARR_FEPICK P icket  EX_STRUCT_RUINS  Ru ins  EX_WALK_BL U Blue Stone 

BND_Min imum EX_BARR_FEPIPE P ipe  EX_STRUCT_WALLNB Noise Bar r ier  Wal l  EX_WALK_G Gran i te  

BND_Release  EX_BARR_FEVARL V irg in ia  EX_STRUCT_WALLST  Stone Wal l  EX_WALK_STEPC Concrete Step  

   EX_WALK_STEPW  Wood Steps  

    

 

Ex is t ing  Boundary  Ex is t ing  Break l ines  Ex is t ing  Hydraul ics  

EX_BND_Easement  EX_BKLN_CLINE Center l ine   EX_HYDRA_100FLOOD 100 Year F lood L ine  

EX_BND_Hwy_Int_NonAccess  EX_BKLN_CRBBCL BCLC EX_HYDRA_500FLOOD 500 Year F lood L ine  

EX_BND_Locat ionSurvey  EX_BKLN_CRBBCP BCPC EX_HYDRA_EDGEMAR Edge of  Marsh  

EX_BND_NonAccess  EX_BKLN_CRBCON  Concrete Curb  EX_HYDRA_EDGEWTR Edge of  Water  

EX_BND_Unl imAccess  EX_BKLN_CRBGR Gran i te  Curb  EX_HYDRA_INWETF Edge of  Wet lands  

EX_BND_Minimum EX_BKLN_CRBGRS  Grani te  S loped Curb  EX_HYDRA_SCEL St ream Channel  Enc.  L ine  

EX_BND_Stree t  EX_BKLN_ERDBIT  B i tuminous Edge of  Road    EX_HYDRA_STREAM St ream 

 EX_BKLN_ERDCON  Concrete Edge o f  Road  EX_HYDRA_SWAMP Swamp 

 EX_BKLN_ERDDRT Earth  Edge of  Road   

 EX_BKLN_ERDGRV  Gravel  Edge o f  Road   
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If you copied the XIN to your project before 3/14/2018, you will need to re-copy in the most recent XIN 

version.  Adjustments have been made in Named Symbology Manager and the Style Manager to enable the crossing features to 

show on the cross Sections. 

     

 

 

 

 

 

 

It is also important to be in a new MicroStation file as the Element Templates and Feature Definitions have been updated on 

3/14/2018.  The Element Templates point to the correct Cells and the Feature Definitions point to the correct Element 

Templates. 
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The workflow below will step through the process of creating a Proposed Right of Way line that will show up on the cross 
section sheets as crossing points.  The same steps can be used to create existing ROW lines and Feature that can also be 

shown as point features on cross sections.  

1.  Create a new file using a CTDOT 2d Seed file to house the right a way lines and existing features you need crossing points 

for, we will call this the Controls File. 

\05.0 - Workspace Resources\3_Workspace_V8i\Civil_Standards\seed\2D_OpenRoads_DesignSeed_83.dgn 

or 

\05.0 - Workspace Resources\3_Workspace_V8i\Civil_Standards\seed\2D_OpenRoads_DesignSeed_27.dgn 

 

3. Reference in the Existing and Proposed MicroStation Design Files. 

4. Reference in the Existing DGN Terrain file(s). 

5. Use MicroStation to place a line. 

6. Under General Geometry, select the Set Feature Definition tool. 

 

 

7. Select Boundary > BND_Acquistion.  Follow the Prompts to assign a feature 

Definition to a MicroStation Graphic.  
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8. Select on the vertical Geometry task select Open Profile Model.  

Follow the prompts to display a Profile Window of the existing ground 

under the Right of Way line. 

 

 

 

 

 

9. Hover over the Existing Ground in the Profile window and 

select Set As Active Profile. 

 

10.Open the Main Modeling File and Reference in the Controls 

file. 

 



 

126 

 

8.4.2 Create a Cross Section DGN and Reference the Design 
Before moving on to create a new file for your cross sections you will need to verify a couple things in your main design files. The 

existing ground reference file’s display must be turned on in the 3D Model. All the proposed and existing levels, features and 

components you need displayed in the cross sections need to be on as well. To create cross sections you will need to use Nested 

Attachments - Live Nesting to attach the main design model to the blank cross section file.    

2.  Create a new file using a CTDOT 2d Seed file and attribute as shown. 

\05.0 - Workspace Resources\3_Workspace_V8i\Civil_Standards\seed\2D_OpenRoads_DesignSeed_83.dgn 

or 

\05.0 - Workspace Resources\3_Workspace_V8i\Civil_Standards\seed\2D_OpenRoads_DesignSeed_27.dgn 

 

3.  In the MicroStation pull down menu choose File > 
References. 

4.  In the References dialog menu choose Tools > Attach.  
Select the file in your main modeling file. 

5.  Leave the Attachment Method set to Interactive.   

6.  Select Open to activate the Reference Attachment 

Settings dialog. 
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7.  Populate the Reference Attachment Settings listed below. 

Orientation: Coincident ‐ World 

Nested Attachments: Live Nesting 

Nesting Depth: 2 

Hint: Live nesting will automatically give access to the 3D model as well as the existing terrain dgn file. 

8.  Select OK to attach the reference file. 

9.  Fit View to review the project location. 

Hint: Pressing the F8 Function Key will toggle black background to white and toggle on the level override symbology. This 

is setup as part of the Bentley-Civil workspace. Pressing F8 again will revert back to original settings. 

10.  Open the Level Display Dialog, Enable the Target Tree, and verify all levels are enabled. 

Hint: Turning off a level at this stage will also turn it off in the created cross section Design Model. For a component to be 

displayed in the proposed cross section Design Model, the level must be turned on in the 3D model before creating the 

sections. 

*If any level settings are changed, select File > Save Settings so the changes will be remembered when cross sections are 

created. 
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8.4.3 Create the Proposed Cross Sections 
 

1.  From inside the newly created cross section dgn file open the 

3D model and select the ground terrain model and hover to 

get the context menu to appear. Click the Set As Active 

Terrain model command.  

 

 

 

 

 

 

  

2.  From inside the newly created cross section dgn file open the 2D 

model and select Settings > Design File, Change Station Settings 

to a precision of 0.  
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3.  Select the Create Cross Sections tool from the Corridor Modeling task menu. 

4.  Following the heads-up prompt, locate the alignment by selecting the red centerline 

alignment. 

5.  Select Preferences button from the bottom of the Create Cross Section dialog. 

6.  In the Preferences dialog select the preference named Highway. 

7.  Select Load. 

Preferences are predefined settings stored in the active XIN 

settings file. These preferences will be used for creating, 

annotating and computing end area volumes on proposed 

cross sections. 

7.  Close the Preferences dialog. 

8.  Under Model type in a name 

9.  Select Apply to create the cross sections into a new DGN 

Drawing Model. 

It will take a few moments for the cross sections to be 

created. A status bar appears in the lower right corner 

showing the progress. 

10.  Close the Create Cross Section dialog. 

 

 

    



 

130 

 

8.4.4 Viewing the Cross Sections 
1.  Select the Cross Section Viewer tool from the Corridor 

Modeling task menu.  

2.  Verify the Cross Section Model setting is set the correct Cross 

Section Model. 

3.  Set the Zoom Factor to 0.75. 

4.  Set the Movie Mode Time to 1.0 sec. 

5.  Select Run to automatically scan through the cross sections. 

6.  Hit the Esc key on your keyboard to exit the movie mode. 

7.  Select a Cross Section station by clicking on it in the 

list and notice how the view updates to the selected 

cross section station value. 

8.  Press the Up and Down Arrow keys on your keyboard 

to step through the Cross sections in the list. 

9.  Close the Cross Section Viewer application. 

 

 

 

NOTE: that the Cross Sections are displaying an ‘X’ at each of the 

Crossing Features such as Centerline and Edge of Pavement. The 

Features must be displayed for them to be annotated, and are a 

construction class so they can easily be turn off in View Attributes. 
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8.4.5 Annotating the Proposed Cross Sections 
1.  Select the Cross Sections tool from the Corridor Modeling task menu. 

2.  Select Preferences. 

3.  Select the preference entitled Highway. 

4.  Select Load, to utilize the selected preferences in the previous step. 

5.  Close the Preferences selection dialog. 

 In the Annotate Cross Section dialog, set the 

General settings. Make sure the correct Cross 

Section Model and Surface you would like to 

annotate is active. 

 Select a Cross Section Model 

 Select a Surface 

 Ensure that the Location is set to Object. 
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6.  To annotate the point features. Select the Segments Folder and turn 

off Include Segments. 

7.  Select the Features > Annotate folder and Highlight the Features you 

would light to annotate.  Click Apply. 
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8.  Select the Features Folder and turn off Include Features. 

 

 

 

 

 

 

9.  Select the Segments Folder and turn on Include Segments.  Select the 

Segments> Annotate folder and Highlight the Segment you would light to 

annotate.  Click Apply for each segment. 
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10.  To turn off the X on the crossing Features select View Attributes and turn of Constructions. 
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