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       Up and Running 
with Excel    

        T  his chapter introduces  Microsoft Excel,  the offi  cial number cruncher of 
Offi  ce 365. The purpose of Excel is to track, analyze, and tabulate  numbers. 
Use the program to project profi ts and losses, formulate a budget, or  analyze 

Elvis sightings in North America. Doing the setup work takes time, but after you 
enter the numbers and tell Excel how to tabulate them, you’re on Easy Street. 
Excel does the math for you. All you have to do is kick off  your shoes, sit back, and 
see how the numbers stack up. 

 This chapter explains what a workbook and a worksheet is, and how rows and 
columns on a worksheet determine where cell addresses are. You also discover 
tips and tricks for entering data quickly in a worksheet and how to construct 
 data-validation rules to make sure that data is entered accurately.  

  Creating a New Excel Workbook 
Workbook  is the Excel term for the fi les you create with Excel. When you create 
a workbook, you are given the choice of creating a blank workbook or creating a 
workbook from a template. 

Chapter 1

 IN THIS CHAPTER 

 »     Creating an Excel workbook  

 »   Entering text as well as numeric, 
date, and time data  

 »   Using the AutoFill command to enter 
lists and serial data  

 »   Setting up data-validation rules    
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A template is a preformatted workbook designed for a specific purpose, such as 
budgeting, tracking inventories, or tracking purchase orders. Creating a work-
book from a template is mighty convenient if you happen to find a template that 
suits your purposes, but in my experience, you almost always have to start from a 
generic, blank workbook because your data is your own. You need a workbook that 
you create yourself, not one created from a template by someone else.

To create a workbook, begin by going to the File tab and choosing New. You see 
the New window, shown in Figure 1-1. This window offers templates for creating 
workbooks and the means to search for templates online.

Use these techniques in the New window to choose a template and create a 
workbook:

»» Choose the blank workbook template. Choose Blank Workbook to create a 
plain template.

Press Ctrl+N to create a new, blank workbook without opening the New 
window.

FIGURE 1-1:  
Create a 

workbook by 
starting in the 
New window.
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»» Choose a template. Select a template to examine it in a preview window 
(refer to Figure 1-1). If you like what you see, click the Create button in the 
preview window to create a document from the template.

»» Search online for a template. Enter a search term in the Search box 
and click the Start Searching button (or click a suggested search term). 
New templates appear in the New window. Click a template to preview 
it (see Figure 1-1). Click the Create button in the preview window to create 
a document from the template.

Book 1, Chapter 1 explains how to save files after you create them, as well as how 
to open a file, including an Excel workbook.

Getting Acquainted with Excel
If you’ve spent any time in an Office application, much of the Excel screen may 
look familiar to you. The buttons on the Home tab — the Bold and the Align but-
tons, for example — work the same in Excel as they do in Word. The Font and Font 
Size drop-down lists work the same as well. Any command in Excel that has to do 
with formatting text and numbers works the same in Excel and Word.

As mentioned earlier, an Excel file is a workbook. Each workbook comprises one or 
more worksheets. A worksheet, also known as a spreadsheet, is a table into which 
you enter data and data labels. Figure  1-2 shows a worksheet with data about 
rainfall in different counties.

A worksheet works like an accountant’s ledger — only it’s much easier to use. Notice 
how the worksheet is divided by gridlines into columns (A, B, C, and so on) and rows 
(1, 2, 3, and so on). The rectangles where columns and rows intersect are cells, and 
each cell can hold one data item, a formula for calculating data, or nothing at all.

Each cell has a different cell address. In Figure 1-2, cell B7 holds 13, the number of 
inches of rain that fell in Sonoma County in the winter. Meanwhile, as the Formula bar 
at the top of the screen shows, cell F7, the active cell, holds the formula =B7+C7+D7+E7, 
the sum of the numbers in cells — you guessed it — B7, C7, D7, and E7.

The beauty of Excel is that the program does all the calculations and recalcula-
tions for you after you enter the data. If I were to change the number in cell B7, 
Excel would instantly recalculate the total amount of rainfall in Sonoma County in 
cell F7. People like myself who struggled in math class will be glad to know that you 
don’t have to worry about the math because Excel does it for you. All you have to do 
is make sure that the data and the formulas are entered correctly.
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After you enter and label the data, enter the formulas, and turn your worksheet 
into a little masterpiece, you can start analyzing the data. For example, you can 
generate charts like the one in Figure 1-3. Do you notice any similarities between 
the worksheet in Figure 1-2 and the chart in Figure 1-3? The chart is fashioned 
from data in the worksheet, and it took me about half a minute to create that chart. 
(Book 8, Chapter 1 explains how to create charts in Excel, Word, and PowerPoint.)

FIGURE 1-2:  
The Excel screen.

FIGURE 1-3:  
A chart generated 

from the data in 
Figure 1-2.
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Rows, columns, and cell addresses
Not that anyone needs them all, but an Excel worksheet has numerous columns 
and more than 1 million rows. The rows are numbered, and columns are labeled A 
to Z, then AA to AZ, then BA to BZ, and so on. The important thing to remember is 
that each cell has an address whose name comes from a column letter and a row 
number. The first cell in row 1 is A1, the second is B1, and so on. You need to enter 
cell addresses in formulas to tell Excel which numbers to compute.

To find a cell’s address, either make note of which column and row it lies in or 
click the cell and glance at the Formula bar (refer to Figure 1-2). The left side of 
the Formula bar lists the address of the active cell, the cell that is selected in the 
worksheet. In Figure 1-2, cell F7 is the active cell.

Workbooks and worksheets
By default, each workbook includes one worksheet, called Sheet1, but you can add 
more worksheets (and rename worksheets, too). Think of a workbook as a stack 
of worksheets. Besides calculating the numbers in cells across the rows or down 
the columns of a worksheet, you can make calculations throughout a workbook 
by using numbers from different worksheets in a calculation. Chapter 2 of this 
minibook explains how to add worksheets, rename worksheets, and do all else 
that pertains to them.

Entering Data in a Worksheet
Entering data in a worksheet is an irksome activity. Fortunately, Excel offers a 
few shortcuts to take the sting out of it. These pages explain how to enter data 
in a worksheet, what the different types of data are, and how to enter text labels, 
numbers, dates, and times.

The basics of entering data
What you can enter in a worksheet cell falls into four categories:

»» Text

»» A value (numeric, date, or time)

»» A logical value (True or False)

»» A formula that returns a value, logical value, or text
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Still, no matter what type of data you’re entering, the basic steps are the same:

1.	 Click the cell where you want to enter the data or text label.

As shown in Figure 1-4, a square appears around the cell to tell you that the cell 
you clicked is now the active cell. Glance at the left side of the Formula bar if 
you’re not sure of the address of the cell you’re about to enter data in. The 
Formula bar lists the cell address.

2.	 Type the data in the cell.

If you find typing in the Formula bar easier, click and start typing there.

3.	 Press the Enter key to enter the number or label.

Besides pressing the Enter key, you can also press an arrow key (←, ↑, →, ↓), 
press Tab, click the Enter button (the check mark) on the Formula bar, or click 
elsewhere on the worksheet.

If you change your mind about entering data, click the Cancel button or press 
Esc to delete what you entered and start over. The Cancel button (an X) is 
located on the Formula bar next to the Enter button (a check mark) and the 
Insert Function button (labeled fx).

FIGURE 1-4:  
Entering data.
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Chapter  3 of this minibook explains how to enter logical values and formulas. 
The next several pages describe how to enter text labels, numeric values, date 
values, and time values.

Entering text labels
Sometimes a text entry is too long to fit in a cell. How Excel accommodates text 
entries that are too wide depends on whether data is in the cell to the right of the 
one you entered the text in:

»» If the cell to the right is empty, Excel lets the text spill into the next cell.

»» If the cell to the right contains data, the entry gets cut off. Nevertheless, the 
text you entered is in the cell. Nothing gets lost when it can’t be displayed 
onscreen. You just can’t see the text or numbers except by glancing at the 
Formula bar, where the contents of the active cell can be seen in their entirety.

Use these techniques to solve the problem of text that doesn’t fit in a cell:

»» Widen the column to allow room for more text.

»» Shorten the text entry.

»» Reorient the text (Chapter 4 of this minibook explains how to do it).

»» Wrap the contents of the cell. Wrapping means to run the text down to the 
next line, much the same way as the text in a paragraph runs to the next line 
when it reaches the right margin. Excel makes rows taller to accommodate 
wrapped text in a cell. To wrap text in cells, select the cells, go to the Home 
tab, and click the Wrap Text button (found in the Alignment group).

Entering numeric values
When a number is too large to fit in a cell, Excel displays pounds signs (###) 
instead of a number or displays the number in scientific notation (8.78979E+15). 
You can always glance at the Formula bar, however, to find out the number in 
the active cell. As well, you can always widen the column to display the entire 
number.

To enter a fraction in a cell, enter a 0 or a whole number, a blank space, and 
the fraction. For example, to enter 3⁄8, type a 0, press the spacebar, and type 
3/8. To enter 53⁄8, type 5, press the spacebar, and type 3/8. For its purposes, 
Excel converts fractions to decimal numbers, as you can see by looking in the 
Formula bar after you enter a fraction. For example, 53⁄8 displays as 5.375 in 
the Formula bar.
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Here’s a little trick for entering numbers with decimals quickly in all the Excel 
files you work on. To spare yourself the trouble of pressing the period key (.), 
you can tell Excel to enter the period automatically. Instead of entering 12.45, for 
example, you can simply enter 1245. Excel enters the period for you: 12.45. To per-
form this trick, go to the File tab, choose Options, visit the Advanced category in 
the Excel Options dialog box, click the Automatically Insert a Decimal Point check 
box, and in the Places text box, enter the number of decimal places you want for 
numbers. Deselect this option when you want to go back to entering numbers the 
normal way.

Entering date and time values
Dates and times can be used in calculations, but entering a date or time value in 
a cell can be problematic because these values must be entered in such a way that 
Excel can recognize them as dates or times, not text.

Not that you necessarily need to know it, but Excel converts dates and times to 
serial values for the purpose of being able to use dates and times in calculations. 
For example, July 31, 2004, is the number 38199. July 31, 2004, at noon is 38199.5. 
These serial values represent the number of whole days since January 1, 1900. The 
portion of the serial value to the right of the decimal point is the time, represented 
as a portion of a full day.

Entering date values
You can enter a date value in a cell in just about any format you choose, and Excel 
understands that you’re entering a date. For example, enter a date in any of the 
following formats and you’ll be all right:

m/d/yy 7/31/19

m-d-yyyy 7-31-2019

d-mmm-yy 31-Jul-19

Here are some basic things to remember about entering dates:

»» Date formats: You can quickly apply a format to dates by selecting cells and 
using one of these techniques:

•	 On the Home tab, open the Number Format drop-down list and choose 
Short Date (m/d/yyyy; 7/31/2016) or Long Date (day of the week, month, day, 
year; Wednesday, July 31, 2016), as shown in Figure 1-5.
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•	 On the Home tab, click the Number group button to open the Number tab 
of the Format Cells dialog box. As shown in Figure 1-5, choose the Date 
category and then choose a date format.

»» Current date: Press Ctrl+; (semicolon) to enter the current date.

»» Current year’s date: If you don’t enter the year as part of the date, Excel 
assumes that the date you entered is in the current year. For example, if you 
enter a date in the m/d (7/31) format during the year 2019, Excel enters the 
date as 7/31/19. As long as the date you want to enter is the current year, 
you can save a little time when entering dates by not entering the year 
because Excel enters it for you.

»» Dates on the Formula bar: No matter which format you use for dates, dates 
are displayed in the Formula bar in the format that Excel prefers for dates: 
m/d/yyyy (7/31/2019). How dates are displayed in the worksheet is up to you.

»» Twentieth and twenty-first century two-digit years: When it comes to 
entering two-digit years in dates, the digits 30 through 99 belong to the 
twentieth century (1930–1999), but the digits 00 through 29 belong to the 
twenty-first century (2000–2029). For example, 7/31/13 refers to July 31, 2013, 
not July 31, 1910. To enter a date in 1929 or earlier, enter four digits instead 
of two to describe the year: 7-31-1929. To enter a date in 2030 or later, enter 
four digits instead of two: 7-31-2030.

FIGURE 1-5:  
Format dates and 

numbers on the 
Number Format 

drop-down list 
or Format Cells 

dialog box.
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»» Dates in formulas: To enter a date directly in a formula, enclose the date 
in quotation marks. (Make sure that the cell where the formula is entered 
has been given the Number format, not the Date format.) For example, the 
formula =TODAY()-“1/1/2019” calculates the number of days that have elapsed 
since January 1, 2019. Formulas are the subject of Chapter 3 of this minibook.

Entering time values
Excel recognizes time values that you enter in the following ways:

h:mm AM/PM 3:31 AM

h:mm:ss AM/PM 3:31:45 PM

Here are some things to remember when entering time values:

»» Use colons: Separate hours, minutes, and seconds with a colon (:).

»» Time formats: To change to the h:mm:ss AM/PM time format, select the cells, 
go to the Home tab, open the Number Format drop-down list, and choose 
Time (see Figure 1-5). You can also change time formats by clicking the 
Number group button on the Home tab and selecting a time format on the 
Number tab of the Format Cells dialog box.

»» AM or PM time designations: Unless you enter AM or PM with the time, 
Excel assumes that you’re operating on military time. For example, 3:30 is 
considered 3:30 a.m.; 15:30 is 3:30 p.m. Don’t enter periods after the letters 
am or pm (don’t enter a.m. or p.m.).

»» Current time: Press Ctrl+Shift+; (semicolon) to enter the current time.

»» Times on the Formula bar: On the Formula bar, times are displayed in this 
format: hours:minutes:seconds, followed by the letters AM or PM. However, the 
time format used in cells is up to you.

Combining date and time values
You can combine dates and time values by entering the date, a blank space, and 
the time:

»» 7/31/13 3:31 am

»» 7-31-13 3:31:45 pm
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Quickly Entering Lists and Serial Data 
with the AutoFill Command

Data that falls into the “serial” category — month names, days of the week, and 
consecutive numbers and dates, for example — can be entered quickly with the 
AutoFill command. Believe it or not, Excel recognizes certain kinds of serial data 
and enters it for you as part of the AutoFill feature. Instead of laboriously enter-
ing this data one piece at a time, you can enter it all at one time by dragging the 
mouse. Follow these steps to “autofill” cells:

1.	 Click the cell that is to be first in the series.

For example, if you intend to list the days of the week in consecutive cells, click 
where the first day is to go.

ENTERING DATA WITH FLASH FILL
Don’t look now, but Excel is peering over your shoulder to see whether it can enter data 
for you with Flash Fill, a mechanism whereby Excel recognizes the data you want to 
enter and offers to enter it on your behalf. When Excel recognizes a pattern in the data 
and thinks it can fill in a column for you, a ghostly image of the data Excel wants to enter 
appears in the column. Press Enter if you want to enter this data.

After you press Enter, the Flash Fill Options button appears. Click it to open a menu with 
options for Undoing Flash Fill and selecting cells.

Flash Fill is useful for cleaning up worksheets with data that you imported from a 
comma- or tab-delimited file. Often this data arrives in a mishmash with data from dif-
ferent categories in the same column.
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2.	 Enter the first number, date, or list item in the series.

3.	 Move to the adjacent cell and enter the second number, date, or list item 
in the series.

If you want to enter the same number or piece of text in adjacent cells, taking 
this step isn’t necessary, but Excel needs the first and second items in the 
case of serial dates and numbers so that it can tell how much to increase or 
decrease the given amount or time period in each cell. For example, entering 5 
and 10 tells Excel to increase the number by 5 each time so that the next serial 
entry is 15.

4.	 Select the cell or cells you just entered data in.

To select a single cell, click it; to select two, drag over the cells. Chapter 2 of this 
minibook describes all the ways to select cells in a worksheet.

5.	 Click the AutoFill handle and start dragging in the direction in which you 
want the data series to appear on your worksheet.

The AutoFill handle is the little green square in the lower-right corner of the cell 
or block of cells you selected. As you drag, the serial data appears in a pop-up 
box, as shown in Figure 1-6.

The AutoFill Options button appears after you enter the serial data. Click it and 
choose an option if you want to copy cells or fill the cells without carrying along 
their formats.

FIGURE 1-6:  
Entering serial 
data and text.



U
p 

an
d 

Ru
nn

in
g 

w
it

h 
Ex

ce
l

0004373550.INDD 243	 Trim size: 7.375 in × 9.25 in� May 17, 2019 8:18 AM

CHAPTER 1  Up and Running with Excel      243

CREATING YOUR OWN AUTOFILL LIST
As you probably know, Excel is capable of completing lists on its own with the AutoFill 
feature. You can enter the days of the week or month names simply by entering one 
day or month and dragging the AutoFill handle to enter the others. Here’s some good 
news: The AutoFill command can also reproduce the names of your coworkers, the 
roster of a softball team, street names, or any other list that you care to enter quickly 
and repeatedly in a worksheet.

Follow these steps to enter items for a list so that you can enter them in the future by 
dragging the AutoFill handle:

1.	 If you’ve already entered items for the list on your worksheet, select the items.

If you haven’t entered the items yet, skip to Step 2.

2.	 On the File tab, choose Options to open the Excel Options dialog box.

3.	 Go to the Advanced category.

4.	 Click the Edit Custom Lists button (you have to scroll down to find it).

You see the Custom Lists dialog box.

5.	 In the List Entries box, do one of the following:

If you selected the items in Step 1, click the Import button. The items you selected 
appear in the List Entries box.

If you need to enter items for the list, enter them in the List Entries box, with one 
item on each line.

6.	 Click the Add button.

7.	 Click OK.
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To enter the same number or text in several empty cells, drag over the cells to 
select them or select each cell by holding down the Ctrl key as you click. Then type 
a number or some text and press Ctrl+Enter.

Formatting Numbers, Dates,  
and Time Values

When you enter a number that Excel recognizes as belonging to one of its formats, 
Excel assigns the number format automatically. Enter 45%, for example, and 
Excel assigns the Percentage number format. Enter $4.25, and Excel assigns the 
Currency number format. Besides assigning formats by hand, however, you can 
assign them to cells from the get-go and spare yourself the trouble of entering 
dollar signs, commas, percent signs, and other extraneous punctuation. All you 
have to do is enter the raw numbers. Excel does the window dressing for you.

Excel offers five number-formatting buttons on the Home tab. Select cells with 
numbers in them and click one of these buttons to change how numbers are 
formatted:

»» Accounting Number Format: Places a dollar sign before the number and 
gives it two decimal places. You can open the drop-down list on this button 
and choose a currency symbol apart from the dollar sign.

»» Percent Style: Places a percent sign after the number and converts the 
number to a percentage.

»» Comma Style: Places commas in the number.

»» Increase Decimal: Increases the number of decimal places by one.

»» Decrease Decimal: Decreases the number of decimal places by one.

To choose among many formats and to format dates and time values as well as 
numbers, go to the Home tab, click the Number group button, and make selections 
on the Number tab of the Format Cells dialog box. Figure 1-7 shows this dialog 
box. Choose a category and select options to describe how you want numbers or 
text to appear.

To strip formats from the data in cells, select the cells, go to the Home tab, click 
the Clear button, and choose Clear Formats.



U
p 

an
d 

Ru
nn

in
g 

w
it

h 
Ex

ce
l

0004373550.INDD 245	 Trim size: 7.375 in × 9.25 in� May 17, 2019 8:18 AM

CHAPTER 1  Up and Running with Excel      245

Entering ZIP codes can be problematic because Excel strips the initial zero from 
the number if it begins with a zero. To get around this problem, visit the Number 
tab of the Format Cells dialog box (see Figure 1-7), choose Special in the Category 
list, and select a ZIP code option.

Establishing Data-Validation Rules
By nature, people are prone to enter data incorrectly because the task of entering 
data is so dull. This is why data-validation rules are invaluable. A data-validation 
rule is a rule concerning what kind of data can be entered in a cell. When you 
select a cell that has been given a rule, an input message tells you what to enter, 
as shown in Figure 1-8. And if you enter the data incorrectly, an error alert tells 
you as much, also shown in Figure 1-8.

Data-validation rules are an excellent defense against sloppy data entry and that 
itchy feeling you get when you’re in the middle of an irksome task. In a cell that 
records date entries, you can require dates to fall in a certain time frame. In a 
cell that records text entries, you can choose an item from a list instead of typing 
it yourself. In a cell that records numeric entries, you can require the number 
to fall within a certain range. Table 1-1 describes the different categories of data-
validation rules.

FIGURE 1-7:  
The Number 

category of the 
Format Cells 

dialog box.
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FIGURE 1-8:  
A data-validation 

rule in action.

TABLE 1-1	 Data-Validation Rule Categories
Rule What Can Be Entered

Any Value Anything whatsoever. This is the default setting.

Whole Number Whole numbers (no decimal points allowed). Choose an operator from the Data drop-
down list and values to describe the range of numbers that can be entered.

Decimal Same as the Whole Number rule except numbers with decimal points are permitted.

List Items from a list. Enter the list items in cells on a worksheet, either the one you’re working 
in or another. Then reopen the Data Validation dialog box, click the Range Selector button 
(you can find it on the right side of the Source text box), and select the cells that hold the 
list. The list items appear in a drop-down list on the worksheet.

Date Date values. Choose an operator from the Data drop-down list and values to describe the 
date range. Earlier in this chapter, “Entering date and time values” describes the correct 
way to enter date values.

Time Time values. Choose an operator from the Data drop-down list and values to describe the 
date and time range. Earlier in this chapter, “Entering date and time values” describes the 
correct way to enter a combination of date and time values.

Text Length A certain number of characters. Choose an operator from the Data drop-down list and 
values to describe how many characters can be entered.

Custom A logical value (True or False). Enter a formula that describes what constitutes a true or 
false data entry.
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Follow these steps to establish a data-validation rule:

1.	 Select the cell or cells that need a rule.

2.	 On the Data tab, click the Data Validation button.

As shown in Figure 1-9, you see the Settings tab of the Data Validation dia-
log box.

3.	 On the Allow drop-down list, choose the category of rule you want.

Table 1-1, earlier in this chapter, describes these categories.

4.	 Enter the criteria for the rule.

What the criteria is depends on what rule category you’re working in. Table 1-1 
describes how to enter the criteria for rules in each category. You can refer to 
cells in the worksheet by selecting them. To do that, either select them directly 
or click the Range Selector button and then select them.

5.	 On the Input Message tab, enter a title and input message.

You can see a title (“Quit Sluffing Off”) and input message (“Enter a number 
between 24,000 and 32,000”) in Figure 1-8. The title appears in boldface. Briefly 
describe what kind of data belongs in the cell or cells you selected.

FIGURE 1-9:  
Creating a  

data-validation 
rule.



0004373550.INDD 248	 Trim size: 7.375 in × 9.25 in� May 17, 2019 8:18 AM

248      BOOK 3  Excel 365

6.	 On the Error Alert tab, choose a style for the symbol in the Message Alert 
dialog box, enter a title for the dialog box, and enter a warning message.

In the error message in Figure 1-8, shown previously, the Stop symbol was 
chosen. The title you enter appears across the top of the dialog box, and the 
message appears beside the symbol.

7.	 Click OK.

To remove data-validation rules from cells, select the cells, go to the Data tab, 
click the Data Validation button, and on the Settings tab of the Data Validation 
dialog box, click the Clear All button, and click OK.
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       Refi ning Your Worksheet    

        T  his chapter delves into the workaday world of worksheets (say that three 
times fast). It explains how to edit worksheet data and move quickly here 
and there in a worksheet. For the purposes of collaboration, you fi nd out 

how to make notes and comments on worksheets. You also discover techniques for 
entering data quickly, selecting cells, and copying and moving data in cells. This 
chapter describes how to move, delete, and rename worksheets as well as protect 
them from being edited or altered.  

  Editing Worksheet Data 
 Not everyone enters data correctly the fi rst time. To edit data you entered in a cell, 
do one of the following:

 » Double-click the cell.  Doing so places the cursor squarely in the cell, where 
you can start deleting or entering numbers and text. 

 »   Click the cell and press F2.  This technique also lands the cursor in the cell. 

 » Click the cell you want to edit.  With this technique, you edit the data on the 
Formula bar.   

Chapter 2

 IN THIS CHAPTER 

 »     Changing worksheet data  

 »   Making notes and commenting on 
a worksheet  

 »   Copying and moving data  

 »   Hiding and protecting worksheets 
so that they can’t be altered    
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If nothing happens when you double-click, or if pressing F2 lands the cursor in 
the Formula bar rather than a cell, somebody has been fooling with the Options 
settings. On the File tab, choose Options, select the Advanced category in the Excel 
Options dialog box, and select the Allow Editing Directly in Cells check box.

Moving around in a Worksheet
Going from place to place gets progressively more difficult as a worksheet gets 
larger. Luckily for you, Excel offers keyboard shortcuts for jumping around. 
Table 2-1 describes these keyboard shortcuts.

As well as pressing keys, you can use the following techniques to get from place 
to place in a worksheet:

»» Scroll bars: Use the vertical and horizontal scroll bars to move to different 
areas. Drag the scroll box to cover long distances. To cover long distances very 
quickly, hold down the Shift key as you drag the scroll box on the vertical 
scroll bar.

»» Scroll wheel on the mouse: If your mouse is equipped with a scroll wheel, 
turn the wheel to quickly scroll up and down.

»» Name box: Enter a cell address in the Name box and press Enter to go to the 
cell. The Name box is found to the left of the Formula bar.

TABLE 2-1	 Keyboard Shortcuts for Getting around in Worksheets
Press. . . To Move the Selection. . .

Home To column A

Ctrl+Home To cell A1, the first cell in the worksheet

Ctrl+End To the last cell in the last row with data in it

←, →, ↑, ↓ To the next cell

Ctrl+←, →, ↑, ↓ In one direction toward the nearest cell with data in it or to 
the first or last cell in the column or row

PgUp or PgDn Up or down one screen’s worth of rows

Ctrl+PgUp or Ctrl+PgDn Backward or forward through the workbook, from worksheet 
to worksheet
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»» The Go To command: On the Home tab, click the Find & Select button and 
choose Go To on the drop-down list (or press Ctrl+G or F5). You see the Go To 
dialog box. Enter a cell address in the Reference box and click OK. Cell 
addresses you’ve already visited with the Go To command are already listed in 
the dialog box. Click the Special button to open the Go To Special dialog box 
and visit a formula, comment, or other esoteric item.

»» The Find command: On the Home tab, click the Find & Select button and 
choose Find on the drop-down list (or press Ctrl+F). Enter the data you seek in 
the Find What box and click the Find Next button. Click the Find All button to 
find all instances of the item you’re looking for. A list of the items appears at 
the bottom of the dialog box; click an item to go to it.

To scroll to the active cell if you no longer see it onscreen, press Ctrl+Backspace.

Getting a Better Look at the Worksheet
Especially when you’re entering data, it pays to get a good look at the worksheet. 
You need to know which column and row you’re entering data in. These pages 
explain techniques for changing your view of a worksheet so that you always know 
where you are. Read on to discover how to freeze, split, and hide columns and 
rows. (On the subject of changing views, Book 1, Chapter 3 explains an essential 
technique for changing views: zooming in and zooming out.)

Freezing and splitting columns and rows
Sometimes your adventures in a worksheet take you to a faraway cell address, 
such as X31 or C39. Out there in the wilderness, it’s hard to tell where to enter data 
because you can’t see the data labels in the first column or first row that tell you 
where to enter data on the worksheet.

To see one part of a worksheet no matter how far you stray from it, you can split 
the worksheet or freeze columns and rows onscreen. In Figure  2-1, I split the 
worksheet so that column A (Property) always appears onscreen, no matter how 
far I scroll to the right; similarly, row 1 (Property, Rent, Management Fees, and 
so on) also appears at the top of the worksheet no matter how far I scroll down. 
Notice how the row numbers and column letters are interrupted in Figure 2-1. 
Because I split the screen, I always know what data to enter in a cell because I can 
clearly see property names in the first column and the column headings along the 
top of the worksheet.
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Freezing columns or rows on a worksheet works much like splitting except that 
lines instead of gray bars appear onscreen to show which columns and rows are 
frozen, and you can’t adjust where the split occurs by dragging the boundary 
where the worksheet is split.

Giving the Split or Freeze Panes command
Follow these steps to split or freeze columns and rows onscreen:

1.	 Click the cell that is directly below the row you want to freeze or split 
and is in the column to the right of the column that you want to freeze 
or split.

In other words, click where you want the split to occur.

2.	 On the View tab, split or freeze the columns and rows.

Go to the View tab and use one of these techniques:

•	 Splitting: Click the Split button and then click and drag the split bars to 
split the screen horizontally or vertically (refer to Figure 2-1). The other 
way to split a worksheet is to grab hold of a split bar, the little division 
markers directly above the vertical scroll bar and directly to the right of 
the horizontal scroll bar (in the lower-right corner of your screen). You 
can tell where split bars are because the pointer turns into a double 
arrow when it’s over a split bar.

FIGURE 2-1:  
Splitting a 

worksheet.
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•	 Freezing: Click the Freeze Panes button and choose one of three Freeze 
options on the drop-down list. The second and third options, respectively, 
freeze the top row or first column. The first option, Freeze Panes, freezes 
the column(s) to the left and the row(s) above the cell you selected in 
Step 1.

Bars or lines appear onscreen to show which row(s) and column(s) have been 
frozen or split. Move where you will in the worksheet. The column(s) and row(s) 
you froze or split stay onscreen.

Unsplitting and unfreezing
Use one of these techniques to keep your worksheet from splitting or freezing to 
death:

»» Unsplitting: Click the Split button again; double-click one of the split bars to 
remove it; or drag a split bar into the top or left side of the worksheet window.

»» Unfreezing: On the View tab, click the Freeze Panes button and choose 
Unfreeze Panes on the drop-down list.

Hiding columns and rows
Another way to take the clutter out of a worksheet is to temporarily hide columns 
and rows:

»» Hiding columns or rows: Drag over the column letters or row numbers of 
the columns or rows that you want to hide. Dragging this way selects entire 
columns or rows. Then press Ctrl+0 (zero) to hide the columns or Ctrl+9 to 
hide the rows. You can also go to the Home tab, click the Format button, 
choose Hide & Unhide, and choose Hide Columns or Hide Rows.

»» Unhiding columns and rows: Select columns to the right and left of the 
hidden columns, or select rows above and below the hidden rows. To select 
columns or rows, drag over their letters or numbers. Then go to the Home 
tab, click the Format button, choose Hide & Unhide, and choose Unhide 
Columns or Unhide Rows.

It’s easy to forget where you hid columns or rows. To make sure all columns and 
rows in your worksheet are displayed, click the Select All button (or press Ctrl+A) 
to select your entire worksheet. Then go to the Home tab, click the Format button 
and choose Hide & Unhide ➪   Unhide Columns; click the Format button again and 
choose Hide & Unhide ➪   Unhide Rows.
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Notes for Documenting Your Worksheet
It may happen that you return to your worksheet days or months from now and 
discover to your dismay that you don’t know why certain numbers or formulas are 
there. For that matter, someone else may inherit your worksheet and be mystified 
as to what the heck is going on. To take the mystery out of a worksheet, document 
it by entering notes here and there.

A note is a little explanation that describes part of a worksheet. Each note is con-
nected to a cell. You can tell where a note is because a small red triangle appears 
in the upper-right corner of cells to which notes are attached. Move the pointer 

YOUR OWN CUSTOMIZED VIEWS
After you go to the trouble of freezing the screen or zooming in to a position you’re 
comfortable with, you may as well save your view of the screen as a customized view. 
That way, you can call upon the customized view whenever you need it. View settings, 
the window size, the position of the grid onscreen, and cells that are selected can all be 
saved in a customized view.

Follow these steps to create a customized view:

1.	 On the View tab, click the Custom Views button.

You see the Custom Views dialog box. It lists views you’ve already created, if you’ve 
created any.

2.	 Click the Add button.

The Add View dialog box appears.

3.	 Enter a name for the view and click OK.

To switch to a customized view, click the Custom Views button, select a view in the 
Custom Views dialog box, and click the Show button.
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over one of these triangles and you see the pop-up box, a note, and the name of 
the person who entered the note, as shown in Figure 2-2. Click the Notes button 
on the Review tab and choose Show All Notes to see every note in a worksheet.

Starting on the Review tab, follow these instructions to handle notes:

»» Entering a note: Click the cell that deserves a note, click the Notes button, 
and choose the New Note on the drop-down list (refer to Figure 2-2). Enter 
your note in the pop-up box. Click in a different cell when you finish entering 
your note.

»» Reading a note: Move the pointer over the small red triangle and read the 
note in the pop-up box (refer to Figure 2-2). You can also right-click a cell and 
choose Show/Hide Note.

»» Showing and hiding notes: Click the Notes button and choose Show All 
Notes on the drop-down list to see or hide all the notes in a worksheet. To 
show or hide an individual note, right-click its cell and choose Show/Hide 
Note.

»» Finding notes: Click the Notes button and then choose the Previous Note or 
Next Note on the drop-down list to go from note to note.

FIGURE 2-2:  
Notes explain 
what’s what in 

a worksheet.
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»» Editing a note: Select the cell with the comment, click the Notes button, and 
choose Edit Note. You can also right-click the cell and choose Edit Note.

»» Deleting notes: Right-click the cell with the note and choose Delete Note. To 
delete several notes, select them by Ctrl+clicking and then right-click and 
choose Delete Note.

If your name doesn’t appear in the pop-up box after you enter a note and you want 
it to appear there, go to the File tab, choose Options, select the General category 
in the Excel Options dialog box, and enter your name in the User Name text box.

Comments for Collaborating with 
Others on a Workbook

When constructing a workbook is a team affair, consider writing comments to 
discuss with team members how to make the workbook better. Comments are 
meant for workbooks being shared on OneDrive (Book 10, Chapter 2 describes file 
sharing on OneDrive). Each comment is attached to a cell. You can tell where a 
comment is because a purple comment icon appears in the upper-right corner of 
cells that have been commented on. Write comments to suggest ways to make a 
workbook better and to reply to others’ suggestions.

Starting on the Review tab, follow these instructions to comment on a workbook 
you share with others on OneDrive:

»» Entering a comment: Click the cell that needs a comment and then click the 
New Comment button. A pop-up box appears for entering a comment. Enter 
your comment and click the Post button to post it on OneDrive where others 
can see it. To edit a comment you made, click its icon, click the Edit button in 
the pop-up box, and make your edits.

»» Displaying a single comment: Click the purple icon in the cell where the 
comment is to see the comment in a pop-up box.

»» Displaying all comments: Click the Show Comments button on the Review 
tab or the Comments button in the upper-right corner of the screen. The 
Comments pane opens, as shown in Figure 2-3. From there you can read, 
reply to, and enter comments.

»» Replying to a comment: Display the comment and enter your replay in the 
Reply text box. Click the Post button when you finish replying.
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»» Going from comment to comment: Click the Previous Comment or Next 
Comment button. You can also scroll through comments in the Comments 
pane.

»» Deleting comments: Select the cell with the comment and click the Delete 
button on the Review tab. To delete a comment and all its replies, display it in 
the Comments pane, click the More Thread Actions button, and choose Delete 
Thread.

Selecting Cells in a Worksheet
To format, copy, move, delete, and format numbers and words in a worksheet, you 
have to select the cells in which the numbers and words are found. Here are ways 
to select cells and the data inside them:

»» A block of cells: Drag diagonally across the worksheet from one corner of the 
block of cells to the opposite corner. You can also click in one corner and 
Shift+click the opposite corner.

»» Adjacent cells in a row or column: Drag across the cells.

»» Cells in various places: While holding down the Ctrl key, click different cells.

FIGURE 2-3:  
Click the 

Comments or 
Show Comments 

button to read 
comments.
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»» A row or rows: Click a row number to select an entire row. Click and drag 
down the row numbers to select several adjacent rows.

»» A column or columns: Click a column letter to select an entire column. 
Click and drag across letters to select adjacent columns.

»» Entire worksheet: Click the Select All button, the square to the left of 
the column letters and above the row numbers; press Ctrl+A; or press 
Ctrl+Shift+Spacebar.

Press Ctrl+Spacebar to select the column that the active cell is in; press 
Shift+Spacebar to select the row where the active cell is.

You can enter the same data item in several different cells by selecting cells and 
then entering the data in one cell and pressing Ctrl+Enter. This technique comes 
in very handy, for example, when you want to enter a placeholder zero (0) in 
several different cells.

Deleting, Copying, and Moving Data
In the course of putting together a worksheet, it is sometimes necessary to delete, 
copy, and move cell contents. Here are instructions for doing these chores:

»» Deleting cell contents: Select the cells and then press the Delete key; on the 
Home tab, click the Clear button and choose Clear Contents; or right-click and 
choose Clear Contents.

»» Copying and moving cell contents: Select the cells and use one of these 
techniques:

•	 Cut or Copy and Paste commands: When you paste the data, click where 
you want the first cell of the block of cells you’re copying or moving to go. 
(Book 1, Chapter 2 explains copying and moving data in detail.) Be careful 
not to overwrite cells with data in them when you copy or move data. After 
you paste data, you see the Paste Options button. Click this button and 
choose an option from the drop-down list to format the data in different 
ways.

•	 Drag and drop: Move the pointer to the edge of the cell block, click when 
you see the four-headed arrow, and start dragging. Hold down the Ctrl key 
to copy the data.
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Handling the Worksheets in a Workbook
A workbook can hold more than one worksheet. Keeping more than one work-
sheet in the same workbook has advantages. For example, in a workbook that 
tracks monthly income from rental properties, you can record monthly income on 
12 worksheets, 1 for each month. By constructing formulas that calculate income 
data across the 12 worksheets, you can track annual income from the properties.

As Figure  2-4 shows, Excel places a tab at the bottom of the screen for each 
worksheet in a workbook. Initially, worksheets are named Sheet1, Sheet2, and 
so on as you add them, but you can rename worksheets. Click a tab to go from 
worksheet to worksheet. Right-click a tab to open a shortcut menu with com-
mands for handling worksheets.

Follow these instructions to move among, add, delete, rename, and change the 
order of worksheets:

»» Inserting a new worksheet: Click the New Sheet button (you can find it in 
the lower-left corner of the screen to the right of the worksheet tab); press 
Shift+F11; or on the Home tab, open the drop-down list on the Insert button 
and choose Insert Sheet.

»» Moving among worksheets: To go from one worksheet to another, click a 
worksheet tab along the bottom of the screen. If you can’t see a tab, click one 
of the scroll arrows to the left of the worksheet tabs.

FIGURE 2-4:  
You can have 

multiple 
worksheets in a 

workbook.
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»» Renaming a worksheet: Right-click the worksheet tab, choose Rename on 
the shortcut menu, type a new name, and press Enter. You can also go to the 
Home tab, click the Format button, choose Rename Sheet on the drop-down 
list, and enter a new name. Spaces are allowed in names, and names can be 
31 characters long. Brackets ([]) are allowed in names, but you can’t use these 
symbols: / \ : ? and *.

»» Selecting worksheets: Click the worksheet’s tab to select it. To select several 
worksheets, Ctrl+click their tabs or click the first tab and then Shift+click the 
last tab in the set. To select all the worksheets, right-click a tab and choose 
Select All Sheets on the shortcut menu.

»» Rearranging worksheets: Drag the worksheet tab to a new location. As 
you drag, a tiny black arrow and a page icon appear to show you where the 
worksheet will land after you release the mouse button. You can also select a 
sheet, go to the Home tab, click the Format button, and choose Move or Copy 
Sheet on the drop-down list. The Move or Copy dialog box appears, as shown 
in Figure 2-5. Select the sheet in the Before Sheet list where you want the 
worksheet to go and click OK.

»» Deleting a worksheet: Select the sheet, and on the Home tab, open the 
drop-down list on the Delete button and choose Delete Sheet. You can also 
right-click a worksheet tab and choose Delete. Be careful, because you can’t 
restore your deleted worksheet by pressing the Undo button.

»» Copying a worksheet: Select the sheet, hold down the Ctrl key, and drag 
the worksheet tab to a new location.

»» Moving a worksheet to another workbook: Make sure that the other 
workbook is open, open the drop-down list on the Format button, and 
choose Move or Copy Sheet. Then select the other workbook’s name in 
the Move or Copy dialog box and click OK.

»» Color-coding a worksheet: Right-click a worksheet tab and choose Tab Color. 
Then select a color in the submenu, or choose More Colors and select a color 
in the Colors dialog box.

FIGURE 2-5:  
Besides dragging 
it, you can move 

a worksheet 
by using this 

dialog box.
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You can change the size of columns or apply numeric formats to the same addresses 
in different worksheets by selecting all the sheets first and then formatting one 
worksheet. The formats apply to all the worksheets that you select. Being able to 
format several different worksheets simultaneously comes in handy, for exam-
ple, when your workbook tracks monthly data and each worksheet pertains to one 
month. Another way to handle worksheets with similar data is to create the first 
worksheet and copy it to the second, third, and fourth worksheets with the Copy 
and Paste commands.

Keeping Others from Tampering 
with Worksheets

People with savvy and foresight sometimes set up workbooks so that one 
worksheet holds raw data and the other worksheets hold formulas that calculate 
the raw data. This technique prevents others from tampering with the raw data. 
Furthermore, if the worksheet with raw data is hidden, the chance that it will be 
tampered with is lower; and if the worksheet is protected, people can’t tamper 
with it unless they have a password. These pages explain how to hide a worksheet 
so that others are less likely to find it. I also tell you how to protect a worksheet 
from being edited.

Hiding a worksheet
Follow these instructions to hide and unhide worksheets:

»» Hiding a worksheet: Right-click the worksheet’s tab and choose Hide 
on the shortcut menu. You can also go to the Home tab, click the Format 
button, and choose Hide &Unhide ➪   Hide Sheet.

»» Unhiding a worksheet: Right-click any worksheet tab and choose 
Unhide; or go to the Home tab, click the Format button, and choose 
Hide & Unhide ➪   Unhide Sheet. Then, in the Unhide dialog box, select the 
sheet you want to unhide and click OK.

Protecting a worksheet
Protecting a worksheet means to restrict others from changing it — from format-
ting it, inserting new rows and columns, or deleting rows and columns, among 
other tasks. You can also prevent any editorial changes whatsoever from being 
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made to a worksheet. Follow these steps to protect a worksheet from tampering 
by others:

1.	 Select the worksheet that needs protection.

2.	 On the Review tab, click the Protect Sheet button.

You see the Protect Sheet dialog box, shown in Figure 2-6. You can also open 
this dialog box by going to the Home tab, clicking the Format button, and 
choosing Protect Sheet.

3.	 Enter a password in the Password to Unprotect Sheet box if you want 
only people with the password to be able to unprotect the worksheet 
after you protect it.

4.	 On the Allow All Users of This Worksheet To list, select the check box next 
to the name of each task that you want to permit others to do.

For example, select the Format Cells check box if you want others to be able to 
format cells.

Deselect the Select Locked Cells check box to prevent any changes from being 
made to the worksheet. By default, all worksheet cells are locked, and by 
preventing others from selecting locked cells, you effectively prevent them 
from editing any cells.

5.	 Click OK.

If you entered a password in Step 3, you must enter it again in the Confirm 
Password dialog box and click OK.

To unprotect a worksheet that you protected, go to the Review tab and click the 
Unprotect Sheet button. You must enter a password if you elected to require others 
to have a password before they can unprotect a worksheet.

FIGURE 2-6:  
Select what you 
want others to 
be able to do.
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       Formulas and Functions 
for Crunching Numbers    

        F  ormulas are where it’s at as far as Excel is concerned. After you know how to 
construct formulas, and constructing them is pretty easy, you can put Excel 
to work. You can make the numbers speak to you. You can turn a bunch of 

unruly numbers into meaningful fi gures and statistics. 

 This chapter explains what a formula is, how to enter a formula, and how to 
enter a formula quickly. You also discover how to copy formulas from cell to cell 
and how to keep formula errors from creeping into your workbooks. Finally, this 
chapter explains how to make use of the hundred or so functions that Excel off ers.  

  How Formulas Work 
 A  formula,  you may recall from the sleepy hours you spent in math class, is a way 
to calculate numbers. For example, 2+3=5 is a formula. When you enter a formula 
in a cell, Excel computes the formula and displays its results in the cell. Click in 
cell A3 and enter  =2+3 , for example, and Excel displays the number 5 in cell A3. 

Chapter 3

 IN THIS CHAPTER 

 »     Constructing a formula  

 »   Copying formulas to other columns 
and rows  

 »   Preventing errors in formulas  

 »   Using functions in formulas    
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Referring to cells in formulas
As well as numbers, Excel formulas can refer to the contents of different cells. 
When a formula refers to a cell, the number in the cell is used to compute the 
formula. In Figure 3-1, for example, cell A1 contains the number 2; cell A2 contains 
the number 3; and cell A3 contains the formula =A1+A2. As shown in cell A3, the 
result of the formula is 5. If I change the number in cell A1 from 2 to 3, the result 
of the formula in cell A3 (=A1+A2) becomes 6, not 5. When a formula refers to a 
cell and the number in the cell changes, the result of the formula changes as well.

To see the value of using cell references in formulas, consider the worksheet 
shown in Figure 3-2. The purpose of this worksheet is to track the budget of a 
school’s Parent Teacher Association (PTA):

»» Column C, Actual Income, lists income from different sources.

»» Column D, Projected Income, shows what the PTA members thought income 
from these sources would be.

»» Column E, Over/Under Budget, shows how actual income compares to 
projected income from the different sources.

As the figures in the Actual Income column (column C) are updated, figures in the 
Over/Under Budget column (column E) and the Total Income row (row 8) change 
instantaneously. These figures change instantaneously because the formulas refer 
to the numbers in cells, not to unchanging numbers (known as constants).

FIGURE 3-1:  
A simple formula.
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Figure  3-3 shows the formulas used to calculate the data in the worksheet in 
Figure  3-2. In column E, formulas deduct the numbers in column D from the 
numbers in column C to show where the PTA over- or under-budgeted for the 
different sources of income. In row 8, you can see how the SUM function is used 
to total cells in rows 3 through 7. The end of this chapter explains how to use 
functions in formulas.

Excel is remarkably good about updating cell references in formulas when you 
move cells. To see how good Excel is, consider what happens to cell addresses in 
formulas when you delete a row in a worksheet. If a formula refers to cell C1 but 
you delete row B, row C becomes row B and the value in cell C1 changes addresses 
from C1 to B1. You would think that references in formulas to cell C1 would be out 
of date, but you would be wrong. Excel automatically adjusts all formulas that 
refer to cell C1. Those formulas now refer to cell B1 instead.

FIGURE 3-2:  
Using formulas in 

a worksheet.

FIGURE 3-3:  
The formulas 

used to generate 
the numbers in 

Figure 3-2.
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In case you’re curious, you can display formulas in worksheet cells instead of the 
results of formulas, as was done in Figure 3-3, by pressing Ctrl+’ (apostrophe) or 
clicking the Show Formulas button on the Formulas tab. (You may have to click 
the Formula Auditing button first, depending on the size of your screen.) Click the 
Show Formulas button a second time to see formula results again.

Referring to formula results in formulas
Besides referring to cells with numbers in them, you can refer to formula results 
in a cell. Consider the worksheet shown in Figure 3-4. The purpose of this work-
sheet is to track scoring by the players on a basketball team over three games:

FIGURE 3-4:  
Using formula 

results as other 
formulas.
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»» The Totals column (column E) shows the total points each player scored in 
the three games.

»» The Average column (column F), using the formula results in the Totals 
column, determines how much each player has scored on average. The 
Average column does that by dividing the results in column E by 3, the 
number of games played.

In this case, Excel uses the results of the total-calculation formulas in column E 
to compute average points per game in column F.

Operators in formulas
Addition, subtraction, and division aren’t the only operators you can use in formu-
las. Table 3-1 explains the arithmetic operators you can use and the key you press 
to enter each operator. In the table, operators are listed in the order of precedence 
(see the “The order of precedence” sidebar for an explanation of precedence).

TABLE 3-1	 Arithmetic Operators for Use in Formulas
Precedence Operator Example Formula Returns

1 % (Percent) =50% 50 percent, or 0.5

2 ^ (Exponentiation) =50^2, 50 to the second power, or 2500

3 * (Multiplication) =E2*4 The value in cell E2 multiplied by 4

3 / (Division) =E2/3 The value in cell E2 divided by 3

4 + (Addition) =F1+F2+F3, The sum of the values in those cells

4 – (Subtraction) =G5–8, The value in cell G5 minus 8

5 & (Concatenation) ="Part No. "&D4 The text Part No. and the value in cell D4

6 = (Equal to) =C5=4, If the value in cell C5 is equal to 4, returns 
TRUE; returns FALSE otherwise

6 <> (Not equal to) =F3<>9 If the value in cell F3 is not equal to 9, returns 
TRUE; returns FALSE otherwise

6 < (Less than) =B9<E11 If the value in cell B9 is less than the 
value in cell E11, returns TRUE; returns 
FALSE otherwise

6 <= (Less than 
or equal to)

=A4<=9 If the value in cell A4 is less than or equal to 9, 
returns TRUE; returns FALSE otherwise

(continued)
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Another way to compute a formula is to make use of a function. As “Working with 
Functions” explains, later in this chapter, a function is a built-in formula that 
comes with Excel. SUM, for example, adds the numbers in cells. AVERAGE finds the 
average of different numbers.

Precedence Operator Example Formula Returns

6 > (Greater than) =E8>14 If the value in cell E8 is greater than 14, 
returns TRUE; returns FALSE otherwise

6 >= (Greater than 
or equal to)

=C3>=D3 If the value in cell C3 is greater than or equal 
to the value in cell D3, returns TRUE; returns 
FALSE otherwise

TABLE 3-1 (continued)

THE ORDER OF PRECEDENCE
When a formula includes more than one operator, the order in which the operators 
appear in the formula matters a lot. Consider this formula:

=2+3*4

Does this formula result in 14 (2+[3*4]) or 20 ([2+3]*4)? The answer is 14 because Excel 
performs multiplication before addition in formulas. In other words, multiplication takes 
precedence over addition.

The order in which calculations are made in a formula that includes different operators 
is called the order of precedence. Be sure to remember the order of precedence when 
you construct complex formulas with more than one operator:

1.	 Percent (%)

2.	 Exponentiation (^)

3.	 Multiplication (*) and division (/); leftmost operations are calculated first

4.	 Addition (+) and subtraction (-); leftmost operations are calculated first

5.	 Concatenation (&)

6.	 Comparison (<, <=, >,>=, and <>)

To get around the order-of-precedence problem, enclose parts of formulas in parenthe-
ses. Operations in parentheses are calculated before all other parts of a formula. For 
example, the formula =2+3*4 equals 20 when it is written this way: =(2+3)*4.
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The Basics of Entering a Formula
No matter what kind of formula you enter, and no matter how complex the formula 
is, follow these basic steps to enter it:

1.	 Click the cell where you want to enter the formula.

2.	 Click in the Formula bar if you want to enter the data there rather than 
the cell.

3.	 Enter the equals sign (=).

You must be sure to enter the equals sign before you enter a formula. Without 
it, Excel thinks you’re entering text or a number, not a formula.

4.	 Enter the formula.

For example, enter =B1*.06. Make sure that you enter all cell addresses 
correctly. By the way, you can enter lowercase letters in cell references. Excel 
changes them to uppercase after you finish entering the formula. The next 
section in this chapter explains how to enter cell addresses quickly in formulas.

5.	 Press Enter or click the Enter button (the check mark on the 
Formula bar).

The result of the formula appears in the cell.

Speed Techniques for Entering Formulas
Entering formulas and making sure that all cell references are correct is a tedious 
activity, but fortunately for you, Excel offers a few techniques to make entering 
formulas easier. Read on to find out how ranges make entering cell references 
easier and how you can enter cell references in formulas by pointing and clicking. 
You also find instructions here for copying formulas.

Clicking cells to enter cell references
The hardest part about entering a formula is entering the cell references correctly. 
You have to squint to see which row and column the cell you want to refer to is in. 
You have to carefully type the right column letter and row number. However, instead 
of typing a cell reference, you can click the cell you want to refer to in a formula.
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In the course of entering a formula, simply click the cell on your worksheet that 
you want to reference. As shown in Figure 3-5, shimmering marquee lights appear 
around the cell that you clicked so that you can clearly see which cell you’re 
referring to. The cell’s reference address, meanwhile, appears in the Formula bar. 
In Figure 3-5, I clicked cell F3 instead of entering its reference address on the 
Formula bar. The reference F3 appears on the Formula bar, and the marquee lights 
appear around cell F3.

Get in the habit of pointing and clicking cells to enter cell references in formulas. 
Clicking cells is easier than typing cell addresses, and the cell references are 
entered more accurately.

Entering a cell range
A cell range is a line or block of cells in a worksheet. Instead of typing cell refer-
ence addresses one at a time, you can simply select cells on your worksheet. In 
Figure 3-6, I selected cells C3, D3, E3, and F3 to form cell range C3:F3. This spares 
me the trouble of entering one at a time the cell addresses that I want in the range. 
The formula in Figure 3-6 uses the SUM function to total the numeric values in cell 
range C3:F3. Notice the marquee lights around the range C3:F3. The lights show 
precisely which range you’re selecting. Cell ranges come in especially handy where 
functions are concerned (see “Working with Functions,” later in this chapter).

To identify a cell range, Excel lists the outermost cells in the range and places a 
colon (:) between cell addresses:

FIGURE 3-5:  
Clicking to enter a 

cell reference.
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»» A cell range comprising cells A1, A2, A3, and A4 is listed this way: A1:A4.

»» A cell range comprising a block of cells from A1 to D4 is listed this way: A1:D4.

You can enter cell ranges on your own without selecting cells. To do so, type the 
first cell in the range, enter a colon (:), and type the last cell.

Naming cell ranges so that you  
can use them in formulas
Whether you type cell addresses yourself or drag across cells to enter a cell range, 
entering cell address references is a chore. Entering =C1+C2+C3+C4, for example, 
can cause a finger cramp; entering =SUM(C1:C4) is no piece of cake, either.

To take the tedium out of entering cell ranges in formulas, you can name cell 
ranges. Then, to enter a cell range in a formula, all you have to do is select a name 
in the Paste Name dialog box or click the Use in Formula button on the Formulas 
tab, as shown in Figure 3-7. Naming cell ranges has an added benefit: You can 
choose a name from the Name Box drop-down list and go directly to the cell range 
whose name you choose, as shown in Figure 3-7.

Naming cell ranges has one disadvantage, and it’s a big one. Excel doesn’t adjust 
cell references when you copy a formula with a range name from one cell to 
another. A range name always refers to the same set of cells. Later in this chapter, 
“Copying Formulas from Cell to Cell” explains how to copy formulas.

FIGURE 3-6:  
Using a cell range 

in a formula.
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Creating a cell range name
Follow these steps to create a cell range name:

1.	 Select the cells that you want to name.

2.	 On the Formulas tab, click the Define Name button.

You see the New Name dialog box.

3.	 Enter a descriptive name in the Name box.

Names can’t begin with a number or include blank spaces.

4.	 On the Scope drop-down list, choose Workbook or a worksheet name.

Choose a worksheet name if you intend to use the range name you’re creating 
only in formulas that you construct in a single worksheet. If your formulas will 
refer to cell range addresses in different worksheets, choose Workbook so that 
you can use the range name wherever you go in your workbook.

5.	 Enter a comment to describe the range name, if you want.

Enter a comment if doing so will help you remember where the cells you’re 
naming are located or what type of information they hold. As I explain shortly, 
you can read comments in the Name Manager dialog box, the place where you 
go to edit and delete range names.

6.	 Click OK.

FIGURE 3-7:  
Choosing a 
named cell  

range.
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In case you’re in a hurry, here’s a fast way to enter a cell range name: Select the 
cells for the range, click in the Name Box (you can find it on the left side of the  
Formula bar, as shown in Figure  3-7), enter a name for the range, and press  
the Enter key.

Entering a range name as part of a formula
To include a cell range name in a formula, click in the Formula bar where you want 
to enter the range name and then use one of these techniques to enter the name:

»» On the Formulas tab, click the Use in Formula button and choose a cell range 
name on the drop-down list (refer to Figure 3-7).

»» Press F3 or click the Use in Formula button and choose Paste Names on the 
drop-down list. You see the Paste Name dialog box (refer to Figure 3-7). Select 
a cell range name and click OK.

Quickly traveling to a cell range that you named
To go quickly to a cell range you named, open the drop-down list on the Name Box 
and choose a name (refer to Figure 3-7). The Name Box drop-down list is located 
on the left side of the Formula bar.

To make this trick work, the cursor can’t be in the Formula bar. The Name Box 
drop-down list isn’t available when you’re constructing a formula.

Managing cell range names
To rename, edit, or delete cell range names, go to the Formulas tab and click 
the Name Manager button. You see the Name Manager dialog box, as shown 
in Figure 3-8. This dialog box lists names, cell values in names, the worksheet 
on which the range name is found, and whether the range name can be applied 
throughout a workbook or only in one worksheet. To rename, edit, or delete a cell 
range name, select it in the dialog box and use these techniques:

»» Renaming: Click the Edit button and enter a new name in the Edit Name 
dialog box.

»» Reassigning cells: To assign different cells to a range name, click the Edit 
button. You see the Edit Name dialog box. To enter a new range of cells, either 
enter the cells’ addresses in the Refers To text box or click the Range Selector 
button (it’s to the right of the text box), drag across the cells on your work-
sheet that you want for the cell range, and click the Cell Selector button again 
to return to the Edit Name dialog box.

»» Deleting: Click the Delete button and click OK in the confirmation box.
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Referring to cells in different worksheets
Excel gives you the opportunity to use data from different worksheets in a for-
mula. If one worksheet lists sales figures from January and the next lists sales 
figures from February, you can construct a “grand total” formula in either work-
sheet to tabulate sales in the two-month period. A reference to a cell on a different 
worksheet is called a 3D reference.

Construct the formula as you normally would, but when you want to refer to a cell or 
cell range in a different worksheet, click a worksheet tab to move to the other work-
sheet and select the cell or range of cells there. Without returning to the original 
worksheet, complete your formula in the Formula bar and press Enter. Excel returns 
you to the original worksheet, where you can see the results of your formula.

The only odd thing about constructing formulas across worksheets is the cell 
references. As a glance at the Formula bar tells you, cell addresses in cross- 
worksheet formulas list the sheet name and an exclamation point (!) as well as the 
cell address itself. For example, this formula in Sheet 1 adds the number in cell A4 
to the numbers in cells D5 and E5 in Sheet 2:

=A4+Sheet2!D5+Sheet2!E5

This formula in Sheet 2 multiplies the number in cell E18 by the number in cell 
C15 in Worksheet 1:

=E18*Sheet1!C15

FIGURE 3-8:  
The Name 

Manager 
dialog box.
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This formula in Sheet 2 finds the average of the numbers in the cell range C7:F7 in 
Sheet 1:

=AVERAGE(Sheet1!C7:F7)

Copying Formulas from Cell to Cell
Often in worksheets, you use the same formula across a row or down a column, 
but different cell references are used. For example, in the worksheet shown in 
Figure  3-9, column F totals the rainfall figures in rows 7 through 11. To enter 
formulas for totaling the rainfall figures in column F, you could laboriously enter 
formulas in cells F7, F8, F9, F10, and F11. But a faster way is to enter the formula 
once in cell F7 and then copy the formula in F7 down the column to cells F8, F9, 
F10, and F11.

When you copy a formula to a new cell, Excel adjusts the cell references in the 
formula so that the formula works in the cells to which it has been copied. 
Astounding! Opportunities to copy formulas abound on most worksheets. And 
copying formulas is the fastest and safest way to enter formulas in a worksheet.

Follow these steps to copy a formula:

1.	 Select the cell with the formula you want to copy down a column or 
across a row.

2.	 Drag the AutoFill handle across the cells to which you want to copy the 
formula.

This is the same AutoFill handle you drag to enter serial data (see Chapter 1 of 
this minibook about entering lists and serial data with the AutoFill command). 
The AutoFill handle is the small green square in the lower-right corner of the 
cell. When you move the mouse pointer over it, it changes to a black cross. 
Figure 3-9 shows a formula being copied.

3.	 Release the mouse button.

If I were you, I would click in the cells to which you copied the formula and 
glance at the Formula bar to make sure that the formula was copied correctly. 
I’d bet you it was.

You can also copy formulas with the Copy and Paste commands. Just make sure 
that cell references refer correctly to the surrounding cells.
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Detecting and Correcting  
Errors in Formulas

It happens. Everyone makes an error from time to time when entering formulas in 
cells. Especially in a worksheet in which formula results are calculated into other 
formulas, a single error in one formula can spread like a virus and cause miscal-
culations throughout a worksheet. To prevent that calamity, Excel offers several 
ways to correct errors in formulas. You can correct them one at a time, run the 
error checker, and trace cell references, as the following pages explain.

FIGURE 3-9:  
Copying a 

formula.
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By the way, if you want to see formulas in cells instead of formula results, go to 
the Formulas tab and click the Show Formulas button or press Ctrl+’ (apostrophe). 
Sometimes seeing formulas this way helps to detect formula errors.

Correcting errors one at a time
When Excel detects what it thinks is a formula that has been entered incorrectly, a 
small green triangle appears in the upper-left corner of the cell where you entered 
the formula. And if the error is especially egregious, an error message, a cryptic 
three- or four-letter display preceded by a pound sign (#), appears in the cell. 
Table 3-2 explains common error messages.

To find out more about a formula error and perhaps correct it, select the cell with 
the green triangle and click the Error button. This small button appears beside 
a cell with a formula error after you click the cell, as shown in Figure 3-10. The 
drop-down list on the Error button offers opportunities for correcting formula 
errors and finding out more about them.

Running the error checker
Another way to tackle formula errors is to run the error checker. When the checker 
encounters what it thinks is an error, the Error Checking dialog box tells you what 
the error is, as shown in Figure 3-10.

TABLE 3-2	 Common Formula Error Messages
Message What Went Wrong

#DIV/0! You tried to divide a number by a zero (0) or an empty cell.

#NAME You used a cell range name in the formula, but the name isn’t defined. Sometimes this error 
occurs because you type the name incorrectly. (Earlier in this chapter, “Naming cell ranges so 
that you can use them in formulas” explains how to name cell ranges.)

#N/A The formula refers to an empty cell, so no data is available for computing the formula. 
Sometimes people enter N/A in a cell as a placeholder to signal the fact that data isn’t entered 
yet. Revise the formula or enter a number or formula in the empty cells.

#NULL The formula refers to a cell range that Excel can’t understand. Make sure that the range is 
entered correctly.

#NUM An argument you use in your formula is invalid.

#REF The cell or range of cells that the formula refers to isn’t there.

#VALUE The formula includes a function that was used incorrectly, takes an invalid argument, or is 
misspelled. Make sure that the function uses the right argument and is spelled correctly.
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To run the error checker, go to the Formulas tab and click the Error Checking 
button (you may have to click the Formula Auditing button first, depending on the 
size of your screen).

If you see clearly what the error is, click the Edit in Formula Bar button, repair the 
error in the Formula bar, and click the Resume button in the dialog box (you find 
this button at the top of the dialog box). If the error isn’t one that really needs 
correcting, either click the Ignore Error button or click the Next button to send the 
error checker in search of the next error in your worksheet.

Tracing cell references
In a complex worksheet in which formulas are piled on top of one another and the 
results of some formulas are computed into other formulas, it helps to be able to 
trace cell references. By tracing cell references, you can see how the data in a cell 
figures into a formula in another cell; or, if the cell contains a formula, you can see 
which cells the formula gathers data from to make its computation. You can get a 
better idea of how your worksheet is constructed, and in so doing, find structural 
errors more easily.

Figure 3-11 shows how cell tracers describe the relationships between cells. A cell 
tracer is a blue arrow that shows the relationships between cells used in formulas. 
You can trace two types of relationships:

FIGURE 3-10:  
Ways to detect 

and correct 
errors.
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»» Tracing precedents: Select a cell with a formula in it and trace the formula’s 
precedents to find out which cells are computed to produce the results of the 
formula. Trace precedents when you want to find out where a formula gets 
its computation data. Cell tracer arrows point from the referenced cells to the 
cell with the formula results in it.

To trace precedents, go to the Formulas tab and click the Trace Precedents 
button. (You may have to click the Formula Auditing button first, depending 
on the size of your screen.)

»» Tracing dependents: Select a cell and trace its dependents to find out which 
cells contain formulas that use data from the cell you selected. Cell tracer 
arrows point from the cell you selected to cells with formula results in them. 
Trace dependents when you want to find out how the data in a cell contrib-
utes to formulas elsewhere in the worksheet. The cell you select can contain 
a constant value or a formula in its own right (and contribute its results to 
another formula).

To trace dependents, go to the Formulas tab and click the Trace Dependents 
button (you may have to click the Formula Auditing button first, depending on 
the size of your screen).

To remove the cell tracer arrows from a worksheet, go to the Formulas tab and 
click the Remove Arrows button. You can open the drop-down list on this button 
and choose Remove Precedent Arrows or Remove Dependent Arrows to remove 
only cell-precedent or cell-dependent tracer arrows.

FIGURE 3-11:  
Tracing the 

relationships 
between cells.
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Working with Functions
A function is a canned formula that comes with Excel. Excel offers hundreds of 
functions, some of which are very obscure and fit for use only by rocket scien-
tists or securities analysts. Other functions are very practical. For example, you 
can use the SUM function to quickly total the numbers in a range of cells. Rather 
than enter =C2+C3+C4+C5 on the Formula bar, you can enter =SUM(C2:C5), which 
tells Excel to total the numbers in cells C2, C3, C4, and C5. To obtain the product 
of the number in cell G4 and .06, you can use the PRODUCT function and enter 
=PRODUCT(G4,.06) on the Formula bar.

These pages explain how to use functions in formulas. You discover how to con-
struct the arguments, enter function names, and get Excel’s help with entering 
functions. Later in this chapter, “A Look at Some Very Useful Functions” exam-
ines how to use specific functions in formulas.

To get an idea of the numerous functions that Excel offers, go to the Formulas tab 
and click the Insert Function button. You see the Insert Function dialog box, shown in 
Figure 3-12. (Later in this chapter, I show you how this dialog box can help with using 
functions in formulas.) Choose a function category in the dialog box, choose a func-
tion name, and read the description. You can click the Help on This Function link to 
go online to a web page with a thorough description of the function and how it’s used.

FIGURE 3-12:  
The Insert 

Function 
dialog box.
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Using arguments in functions
Every function takes one or more arguments. Arguments are the cell references 
or numbers, enclosed in parentheses, that the function acts upon. For example, 
=AVERAGE(B1:B4) returns the average of the numbers in the cell range B1 through 
B4; =PRODUCT(6.5,C4) returns the product of multiplying the number 6.5 by the 
number in cell C4. When a function requires more than one argument, enter a 
comma between the arguments (enter a comma without a space).

Entering a function in a formula
To enter a function in a formula, you can enter the function name by typing it in 
the Formula bar, or you can rely on Excel to enter it for you. Enter function names 
yourself if you’re well acquainted with a function and comfortable using it.

No matter how you want to enter a function as part of a formula, start this way:

1.	 Select the cell where you want to enter the formula.

2.	 In the Formula bar, type an equals sign (=).

Please, please, please be sure to start every formula by entering an equals 
sign (=). Without it, Excel thinks you’re entering text or a number in the cell.

3.	 Start constructing your formula, and when you come to the place where 
you want to enter the function, type the function’s name or call upon 
Excel to help you enter the function and its arguments.

The upcoming section, “Manually entering a function” shows how to type in the 
function yourself; “Getting Excel’s help to enter a function” shows how to get 
Excel to do the work.

If you enter the function on your own, it’s up to you to type the arguments 
correctly; if you get Excel’s help, you also get help with entering the cell 
references for the arguments.

Manually entering a function
Be sure to enclose the function’s argument or arguments in parentheses. Don’t 
enter a space between the function’s name and the first parenthesis. Likewise, don’t 
enter a comma and a space between arguments; enter a comma, nothing more:

=SUM(F11,F14,23)

You can enter function names in lowercase. Excel converts function names to 
uppercase after you click the Enter button or press Enter to complete the formula. 
Entering function names in lowercase is recommended because doing so gives 
you a chance to find out whether you entered a function name correctly. If Excel 
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doesn’t convert your function name to uppercase, you made a typing error when 
you entered the function name.

Getting Excel’s help to enter a function
Besides entering a function by typing it, you can do it by way of the Function 
Arguments dialog box, as shown in Figure  3-13. The beauty of using this dia-
log box is that it warns you if you enter arguments incorrectly. What’s more, the 
Function Arguments dialog box shows you the results of the formula as you con-
struct it so that you can tell whether you’re using the function correctly.

Follow these steps to get Excel’s help with entering a function as part of a formula:

1.	 On the Formulas tab, tell Excel which function you want to use.

You can do that with one of these techniques:

•	 Click a Function Library button. Click the button whose name describes 
what kind of function you want and choose the function’s name on the 
drop-down list. You can click the Financial, Logical, Text, Date & Time, 
Lookup & Reference, Math & Trig, or More Functions buttons.

•	 Click the Recently Used button. Click this button and choose the name of 
a function you used recently.

•	 Click the Insert Function button. Clicking this button opens the Insert 
Function dialog box (refer to Figure 3-12). Find and choose the name of a 
function. You can search for functions or choose a category and then scroll 
the names until you find the function you want.

FIGURE 3-13:  
The Function 

Arguments 
dialog box.
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You see the Function Arguments dialog box (refer to Figure 3-13). It offers 
boxes for entering arguments for the function to compute.

2.	 Enter arguments in the spaces provided by the Function Arguments 
dialog box.

To enter cell references or ranges, you can click or select cells in your work-
sheet. If necessary, click the Range Selector button (you can find it to the right 
of an argument text box) to shrink the Function Arguments dialog box and get 
a better look at your worksheet.

3.	 Click OK when you finish entering arguments for your function.

I hope you didn’t have to argue too strenuously with the Function Arguments 
dialog box.

QUICKLY ENTERING A FORMULA 
AND FUNCTION
Excel offers the AutoSum button and Quick Analysis button for quickly entering 
formulas that include a function.

Click the cell where you want the results of your formula to appear and try these 
techniques for constructing formulas with the AutoSum button:

•	On the Home or Formulas tab, click the AutoSum button to total nearby cells.

•	On the Home or Formulas tab, open the drop-down list on the AutoSum button 
and choose Sum, Average, Count Numbers, Max, or Min. Respectively, these 
functions total, average, obtain the number of, obtain the highest value in, or 
obtain the lowest value in nearby cells.

Excel takes an educated guess as to which cells need totaling, averaging, or whatever, 
and quickly enters a formula for you.

Use the Quick Analysis button to construct a formula with the SUM, AVERAGE, or COUNT 
function, or one of their variations:

1.	 Select the cells that will be used as arguments by the function.

The Quick Analysis button appears.

2.	 Click the Quick Analysis button.

3.	 Choose Totals in the pop-up window.

(continued)
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A Look at Some Very Useful Functions
Starting with Table 3-3, the remainder of this chapter looks into functions that I 
consider especially useful or interesting. After you spend some time constructing 
formulas, you’ll come up with your own list of useful or interesting functions.

TABLE 3-3	 Common Functions and Their Use
Function Returns

AVERAGE(number1,number2,. . .) The average of the numbers in the cells listed in the arguments

COUNT(value1,value2,. . .) The number of cells that contain the numbers listed in the arguments

MAX(number1,number2,. . .) The largest value in the cells listed in the arguments

MIN(number1,number2,. . .) The smallest value in the cells listed in the arguments

PRODUCT(number1,number2,. . .) The product of multiplying the cells listed in the arguments

STDEV(number1,number2,. . .) An estimate of standard deviation based on the sample cells listed in 
the argument

STDEVP(number1,number2,. . .) An estimate of standard deviation based on the entire sample cells listed 
in the arguments

SUM(number1,number2,. . .) The total of the numbers in the arguments

VAR(number1,number2,. . .) An estimate of the variance based on the sample cells listed in 
the arguments

VARP(number1,number2,. . .) A variance calculation based on all cells listed in the arguments

4.	 Move the pointer over the various functions and glance at your worksheet to 
see the results of your formulas.

5.	 Select a function.

(continued)
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AVERAGE for averaging data
Might as well start with an easy one. The AVERAGE function averages the values in 
a cell range. In Figure 3-14, for example, AVERAGE is used to compute the average 
rainfall in a three-month period in three different counties.

Use AVERAGE as follows:

AVERAGE(cell range)

Excel ignores empty cells and logical values in the cell range; cells with 0 are 
computed.

COUNT and COUNTIF for  
tabulating data items
Use COUNT, a statistical function, to count how many cells have data in them. 
Numbers and dates, not text entries, are counted. The COUNT function is useful 
for tabulating how many data items are in a range. In the spreadsheet at the top 
of Figure 3-15, for example, COUNT is used to compute the number of mountains 
listed in the data:

COUNT(C5:C9)

Use COUNT as follows:

COUNT(cell range)

FIGURE 3-14:  
Using AVERAGE 
to find average 

rainfall data.
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Similar to COUNT is the COUNTIF function. It counts how many cells in a cell 
range have a specific value. To use COUNTIF, enter the cell range and a criterion 
in the argument, as follows. If the criterion is a text value, enclose it in quotation 
marks.

COUNTIF(cell range, criterion)

At the bottom of Figure 3-15, the formula determines how many of the mountains 
in the data are in Nepal:

=COUNTIF(D5:D9,"Nepal")

FIGURE 3-15:  
The COUNT 
(above) and 

COUNTIF (below) 
function at work.
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CONCATENATE for combining values
CONCATENATE, a text function, is useful for combining values from different cells 
into a single cell. In the spreadsheet at the top of Figure 3-16, for example, values 
from three columns are combined in a fourth column to list peoples’ names in 
their entirety.

Use CONCATENATE as follows:

CONCATENATE(text1,text2,text3...)

To include blank spaces in the text you’re combining, enclose a blank space between 
quotation marks as an argument. Moreover, you can include original text in the 
concatenation formula as long as you enclose it in quotation marks and enter it 
as a separate argument. In Figure 3-16, I had to include a period after the middle 
initial, so in the formula, I entered a period in quotation marks as an argument:

=CONCATENATE(C3," ",D3,"."," ",B3)

In the spreadsheet shown at the bottom of Figure 3-16, I used the CONCATENATE 
function to write sentences (“John Q. Munoz lives in Boston.”). I included the 
words “lives in” in the formula, as follows:

=CONCATENATE(C11," ",D11,"."," ",B11," ","lives in"," ",E11,".")

FIGURE 3-16:  
Use the 

CONCATENATE 
function to 

combine values 
from cells.
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PMT for calculating how  
much you can borrow
If you’re looking to buy a house, a car, or another expensive item for which you 
have to borrow money, the question to ask yourself is: How much can I borrow 
and make the monthly payment on the loan without stressing my budget unnec-
essarily? Can you safely make a monthly payment of $1,000, $1,500, $2,000? How 
much you can afford to pay each month to service a loan determines how much 
you can realistically borrow.

Use the PMT (payment) function to explore how much you can borrow given 
different interest rates and different amounts. PMT determines how much you 
have to pay annually on different loans. After you determine how much you have 
to pay annually, you can divide this amount by 12 to see how much you have to 
pay monthly.

Use the PMT function as follows to determine how much you pay annually for a 
loan:

PMT(interest rate, number of payments, amount of loan)

As shown in Figure 3-17, set up a worksheet with five columns to explore loan 
scenarios:

»» Interest rate (column A): Because the interest rate on loans is expressed as 
a percentage, format this column to accept numbers as percentages (click the 
Percent Style button on the Home tab).

»» No. of payments (column B): Typically, loan payments are made monthly. 
For a 30-year home loan mortgage, enter 360 in this column (12 months × 
30 years); for a 15-year mortgage, enter 180 (12 months × 15 years). Enter the 
total number of loan payments you will make during the life of the loan.

»» Amount of loan (column C): Enter the amount of the loan.

»» Annual payment (column D): Enter a formula with the PMT function in this 
column to determine how much you have to pay annually for the loan. In 
Figure 3-17, the formula is

=PMT(A3,B3,C3)

»» Monthly payment (column E): Divide the annual payment in column D by 
12 to determine the monthly payment:

=D3/12
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After you set up the worksheet, you can start playing with different loan 
scenarios — different interest rates and amounts — to find out how much you 
can comfortably borrow and comfortably pay each month to pay back the loan.

IF for identifying data
The IF function examines data and returns a value based on criteria you enter. 
Use the IF function to locate data that meets a certain threshold. In the worksheet 
shown in Figure 3-18, for example, the IF function is used to identify teams that 
are eligible for the playoffs. To be eligible, a team must have won more than six 
games. The IF function identifies whether a team has won more than six games 
and, in the Playoffs column, enters the word Yes or No accordingly.

FIGURE 3-17:  
Exploring loan 
scenarios with 

the PMT function.

FIGURE 3-18:  
Exploring data 

with the IF 
function.
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Use the IF function as follows:

IF(logical true-false test, value if true, value if false)

Instructing Excel to enter a value if the logical true-false test comes up false is 
optional; you must supply a value to enter if the test is true. Enclose the value in 
quotation marks if it is a text value such as the word Yes or No.

In Figure 3-18, the formula for determining whether a team made the playoffs is 
as follows:

=IF(C3>6,"Yes","No")

If the false “No” value was absent from the formula, teams that didn’t make the 
playoffs would not show a value in the Playoffs column; these teams’ Playoffs 
column would be empty.

LEFT, MID, and RIGHT for cleaning up data
Sometimes when you import data from another software application, especially if 
it’s a database application, the data arrives with unneeded characters. You can use 
the LEFT, MID, RIGHT, and TRIM functions to remove these characters:

»» LEFT returns the leftmost characters in a cell to the number of characters you 
specify. For example, in a cell with CA_State, this formula returns CA, the two 
leftmost characters in the text:

=LEFT(A1,2)

»» MID returns the middle characters in a cell starting at a position you specify 
to the number of characters you specify. For example, in a cell with http://
www.dummies.com, this formula uses MID to remove the extraneous seven 
characters at the beginning of the URL and get www.dummies.com:

=MID(A1,7,50)

»» RIGHT returns the rightmost characters in a cell to the number of characters 
you specify. For example, in a cell containing the words Vitamin B1, this 
formula returns B1, the two rightmost characters in the name of the vitamin:

=RIGHT(A1,2)

»» TRIM, except for single spaces between words, removes all blank spaces from 
inside a cell. Use TRIM to remove leading and trailing spaces. This formula 
removes unwanted spaces from the data in cell A1:

=TRIM(A1)
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PROPER for capitalizing words
The PROPER function makes the first letter of each word in a cell uppercase. As are 
LEFT and RIGHT, it is useful for cleaning up data you imported from elsewhere. 
Use PROPER as follows:

PROPER(cell address)

LARGE and SMALL for comparing values
Use the LARGE and SMALL functions, as well as their cousins MIN, MAX, and 
RANK, to find out where a value stands in a list of values. For example, use LARGE 
to locate the ninth oldest man in a list, or MAX to find the oldest man. Use MIN to 
find the smallest city by population in a list, or SMALL to find the fourth smallest. 
The RANK function finds the rank of a value in a list of values.

Use these functions as follows:

»» MIN returns the smallest value in a list of values. For the argument, enter a 
cell range or cell array. In the worksheet shown in Figure 3-19, the following 
formula finds the fewest number of fish caught at any lake on any day:

=MIN(C3:G7)

»» SMALL returns the nth smallest value in a list of values. This function takes 
two arguments: first, the cell range or cell array, and next, the position, 
expressed as a number, from the smallest of all values in the range or 
array. In the worksheet shown in Figure 3-19, this formula finds the 
second smallest number of fish caught in any lake:

=SMALL(C3:G7,2)

»» MAX returns the largest value in a list of values. Enter a cell range or cell array 
as the argument. In the worksheet shown in Figure 3-19, this formula finds the 
most number of fish caught in any lake:

=MAX(C3:G7)

»» LARGE returns the nth largest value in a list of values. This function takes 
two arguments: first, the cell range or cell array, and next, the position, 
expressed as a number, from the largest of all values in the range or array. 
In the worksheet shown in Figure 3-19, this formula finds the second largest 
number of fish caught in any lake:

=LARGE(C3:G7,2)
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»» RANK returns the rank of a value in a list of values. This function takes three 
arguments:

•	 The cell with the value used for ranking

•	 The cell range or cell array with the comparison values for determin-
ing rank

•	 Whether to rank in order from top to bottom (enter 0 for descending) or 
bottom to top (enter 1 for ascending)

In the worksheet shown in Figure 3-19, this formula ranks the total number of 
fish caught in Lake Temescal against the total number of fish caught in all five 
lakes:

=RANK(H3,H3:H7,0)

NETWORKDAY and TODAY for  
measuring time in days
Excel offers a couple of date functions for scheduling, project planning, and mea-
suring time periods in days.

FIGURE 3-19:  
Using functions 

to compare 
values.
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NETWORKDAYS measures the number of workdays between two dates (the func-
tion excludes Saturdays and Sundays from its calculations). Use this function for 
scheduling purposes to determine the number of workdays needed to complete a 
project. Use NETWORKDAYS as follows:

NETWORKDAYS(start date, end date)

TODAY gives you today’s date, whatever it happens to be. Use this function to 
compute today’s date in a formula. The TODAY function takes no arguments and 
is entered like so, parentheses included:

TODAY()

To measure the number of days between two dates, use the minus operator and 
subtract the latest date from the earlier one. For example, this formula measures 
the number of days between 1/1/2019 and 6/1/2019:

="6/1/2019"-"1/1/2019"

The dates are enclosed in quotation marks to make Excel recognize them as dates. 
Make sure that the cell where the formula is located is formatted to show num-
bers, not dates.

LEN for Counting Characters in Cells
Use the LEN (length) function to obtain the number of characters in a cell. This 
function is useful for making sure that characters remain under a certain limit. 
The LEN function counts blank spaces as well as characters. Use the LEN function 
as follows:

LEN(cell address)
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       Making a Worksheet 
Easier to Read and 
Understand    

        T  his short and pithy chapter explains how to dress a worksheet in its Sunday 
best in case you want to print and present it to others. It explains how to 
align numbers and text, insert rows and columns, and change the size of 

rows and columns. You fi nd out how to decorate a worksheet with colors and 
 borders as well as create and apply styles to make formatting tasks go more 
quickly. Finally, this chapter describes everything you need to know before you 
print a worksheet, including how to make it fi t on one page and repeat row labels 
and column names on all pages.  

  Laying Out a Worksheet 
 Especially if you intend to print your worksheet, you may as well make it look 
sharp. And you can do a number of things to make worksheets easier to read 
and understand. You can change character fonts. You can draw borders around 
or shade important cells. You can also format the numbers so that readers know, 

Chapter 4

 IN THIS CHAPTER 

 »     Aligning numbers and text  

 »   Applying cell styles to data in cells  

 »   Splashing color on a worksheet  

 »   Preparing a worksheet before you 
print it    
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for example, whether they’re staring at dollar figures or percentages. This part 
of Chapter 4 is dedicated to the proposition that a worksheet doesn’t have to look 
drab and solemn.

Aligning numbers and text  
in columns and rows
To start with, numbers in worksheets are right aligned in cells, and text is left 
aligned. Numbers and text sit squarely on the bottom of cells. You can, however, 
change the way that data is aligned. For example, you can make data float at the 
top of cells rather than rest at the bottom, and you can center or justify data in 
cells. Figure 4-1 illustrates different ways to align text and numbers. How text is 
aligned helps people make sense of your worksheets. In Figure 4-1, for example, 
Income and Expenses are left-aligned so that they stand out and clarify what the 
right-aligned column labels below are all about.

Select the cells whose alignment needs changing and follow these instructions to 
realign data in the cells:

»» Changing the horizontal (side-to-side) alignment: On the Home tab, click 
the Align Left, Center, or Align Right button. You can also click the Alignment 
group button, and on the Alignment tab of the Format Cells dialog box, 

FIGURE 4-1:  
Ways to 

align data.
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choose an option on the Horizontal drop-down list. Figure 4-2 shows the 
Format Cells dialog box.

»» Changing the vertical (top-to-bottom) alignment: On the Home tab, 
click the Top Align, Middle Align, or Bottom Align button. You can also click 
the Alignment group button to open the Format Cells dialog box (refer to 
Figure 4-2) and choose an option on the Vertical drop-down list. The Justify 
option makes all the letters or numbers fit in a cell, even if it means wrapping 
text to two or more lines.

»» Reorienting the cells: On the Home tab, click the Orientation button and 
choose an option on the drop-down list. (For Figure 4-2, I chose the Angle 
Counterclockwise option.) You can also click the Alignment group button, 
and on the Alignment tab of the Format Cells dialog box (refer to Figure 4-2), 
drag the diamond in the Orientation box or enter a number in the Degrees 
text box.

Changing the orientation of text in cells is an elegant solution to the problem of 
keeping a worksheet from getting too wide. Numbers are usually a few characters 
wide, but heading labels can be much wider than that. By changing the orienta-
tion of a heading label, you make columns narrower and keep worksheets from 
growing too wide to fit on the screen or page.

FIGURE 4-2:  
The Alignment 

tab of the Format 
Cells dialog box.
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Inserting and deleting rows and columns
At some point, everybody has to insert new columns and rows and delete ones 
that are no longer needed. Make sure before you delete a row or column that you 
don’t delete data that you really need. Do the following to insert and delete rows 
and columns:

»» Deleting rows or columns: Drag across the row numbers or column letters 
of the rows or columns you want to delete; then right-click and choose Delete, 
or, on the Home tab, open the drop-down list on the Delete button and select 
Delete Sheet Rows or Delete Sheet Columns.

»» Inserting rows: Select the row below the row you want to insert; then, on 
the Home tab, open the drop-down list on the Insert button and choose Insert 
Sheet Rows, or right-click the row you selected and choose Insert on the 
shortcut menu. For example, to insert a new row above row 11, select the 
current row 11 before choosing Insert Sheet Rows. You can insert more than 
one row at a time by selecting more than one row before giving the Insert 
Sheet Rows command.

MERGING AND CENTERING TEXT  
ACROSS SEVERAL CELLS
In the illustration shown here, “Sales Totals by Regional Office” is centered across four 
different cells. Normally, text is left aligned, but if you want to center it across several 
cells, drag across the cells to select them, go to the Home tab, and click the Merge & 
Center button. Merging and centering allows you to display text across several columns.

To “unmerge and uncenter” cells, select the text that you merged and centered, open 
the drop-down list on the Merge & Center button, and choose Unmerge Cells. You 
can also deselect the Merge Cells check box in the Format Cells dialog box (refer to 
Figure 4-2).
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»» Inserting columns: Select the column to the right of where you want the 
new column to be; then, on the Home tab, open the drop-down list on the 
Insert button and choose Insert Sheet Columns, or right-click the column you 
selected and choose Insert on the shortcut menu. You can insert more than 
one column this way by selecting more than one column before giving the 
Insert command.

A fast way to insert several rows or columns is to insert one and keep pressing F4 
(the Repeat command) until you insert all the rows or columns you need.

After you insert rows or columns, the Insert Options button appears. Click it and 
choose an option from the drop-down list if you want your new row or column to 
have the same or different formats as the row or column you selected to start the 
Insert operation.

To insert more than one row or column at a time, select more than one row num-
ber or column letter before giving the Insert command.

Changing the size of columns and rows
By default, columns are 8.43 characters wide. To make columns wider, you have 
to widen them yourself. Rows are 15 points high, but Excel makes them higher 
when you enter letters or numbers that are taller than 15 points (72 points equal 
one inch). Excel offers a bunch of different ways to change the size of columns 
and rows. You can start on the Home tab and choose options on the Format button 
drop-down list, as shown in Figure 4-3, or you can rely on your wits and change 
sizes manually by dragging or double-clicking the boundaries between row 
numbers or column letters.

Before you change the size of columns or rows, select them (Chapter 2 of this 
minibook explains how). Click or drag across row numbers to select rows; click or 
drag across column letters to select columns.

Adjusting the height of rows
Here are ways to change the height of rows:

»» One at a time: Move the mouse pointer onto the boundary between row 
numbers and, when the pointer changes to a cross, drag the boundary 
between rows up or down. A pop-up box tells you how tall the row will be 
after you release the mouse button.
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»» Several at a time: Select several rows and drag the boundary between one 
of the rows. When you do so, all rows change height. You can also go to the 
Home tab, click the Format button, choose Row Height, and enter a measure-
ment in the Row Height dialog box.

»» Tall as the tallest entry: To make a row as tall as its tallest cell entry, double-
click the border below a row number (after you’ve selected a row) or go to the 
Home tab, click the Format button, and choose AutoFit Row Height.

Adjusting the width of columns
Here are ways to make columns wider or narrower:

»» One at a time: Move the mouse pointer onto the boundary between column 
letters, and when the pointer changes to a cross, drag the border between the 
columns. A pop-up box tells you what size the column is.

»» Several at a time: Select several columns and drag the boundary between 
one of the columns; all columns adjust to the same width. You can also go to 
the Home tab, click the Format button, choose Column Width, and enter a 
measurement in the Column Width dialog box.

»» As wide as their entries: To make columns as wide as their widest entries, 
select the columns, go to the Home tab, click the Format button, and choose 

FIGURE 4-3:  
Ways to 

change the size 
of columns 

and rows.
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AutoFit Column Width on the drop-down list. You can also double-click the 
right border of a column letter. By “auto-fitting” columns, you can be certain 
that the data in each cell in a column appears onscreen.

To change the 8.43-character standard width for columns in a worksheet, go to 
the Home tab, click the Format button, choose Default Width on the drop-down 
list, and enter a new measurement in the Standard Width dialog box.

Decorating a Worksheet with  
Borders and Colors

The job of gridlines is simply to help you line up numbers and letters in cells. By 
default, gridlines aren’t printed, and because gridlines aren’t printed, drawing 
borders on worksheets is absolutely necessary if you intend to print your work-
sheet. Use borders to steer the reader’s eye to the most important parts of your 
worksheet — the totals, column labels, and heading labels. You can also decorate 
worksheets with colors. This part of the chapter explains how to put borders and 
colors on worksheets.

Cell styles for quickly formatting 
a worksheet
A style is a collection of formats — boldface text, a background color, or a border 
around cells — that can be applied all at one time to cells without having to visit a 
bunch of different dialog boxes or give a bunch of different commands. Styles save 
time. If you find yourself choosing the same formatting commands time and time 
again, consider creating a style. That way, you can apply all the formats simulta-
neously and go to lunch earlier. Excel comes with many built-in styles, and you 
can create styles of your own, as the following pages explain.

Applying a built-in cell style
By way of the Cell Styles gallery on the Home tab, you can choose from any num-
ber of attractive styles for cells in a worksheet. Excel offers styles for titles and 
headings, styles for calling attention to what kind of data is in cells, and styles to 
accent cells. Follow these steps to reformat cells by choosing a cell style:

1.	 Select the cells that need a new look.

2.	 On the Home tab, click the Cell Styles button.

As shown in Figure 4-4, the Cell Styles gallery opens.
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3.	 Select a cell style.

The Cell Styles gallery is divided into categories. Find a style that suits your 
purposes.

To remove a style from cells, select the cells, open the Cell Styles gallery, and 
choose Normal. (You find Normal in the “Good, Bad and Neutral” category.)

Creating your own cell style
The names of cell styles you create on your own are placed at the top of the Cell 
Styles gallery under the Custom heading. Create a cell style if you’re the creative 
type or if no built-in style meets your high standards. Follow these steps to create 
a cell style:

1.	 Apply the formatting commands you want for your style to a single cell.

For example, left-align cell data. Or apply a fill color to the cells (see “Decorating 
worksheets with colors,” later in this chapter). Or change fonts and font sizes. 
Knock yourself out. Choose all the formatting commands you want for your 
new style.

2.	 On the Home tab, click the Cell Styles button to open the Cell Styles 
gallery.

Depending on the size of your screen, you may have to click the Styles button 
and then click the More button first.

3.	 Choose New Cell Style at the bottom of the gallery.

You see the Style dialog box shown in Figure 4-5. It lists formatting specifica-
tions that you chose for the cell you selected in Step 1. If these specifications 
aren’t what you’re after, or if you want to change a specification, you can click 
the Format button and construct your new style in the Format Cells dialog box.

FIGURE 4-4:  
Choosing a new 

style from the 
Cell Styles gallery.
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4.	 Enter a descriptive name for your style in the Style Name text box.

5.	 Click OK.

Next time you open the Cell Styles gallery, you see the name of your style at 
the top under Custom.

To remove a style you created from the Cell Styles gallery, right-click its name in 
the gallery and choose Delete on the shortcut menu.

Formatting cells with table styles
Especially if your worksheet data is arranged neatly into columns and rows so that 
it looks like a conventional table, one of the easiest ways to decorate cells is to take 
advantage of table styles. Excel offers many preformatted table styles that you can 
apply to columns and rows on a worksheet.

Follow these steps to experiment with table styles:

1.	 Select the cells you want to format as a table.

2.	 On the Home tab, click the Format As Table button and select a table 
style in the gallery.

The Format As Table dialog box appears.

3.	 If the cells you want to format include headers, the labels at the top of 
column rows that describe the data in the columns below, select the My 
Table Has Headers check box.

FIGURE 4-5:  
Creating a new 

style for the Cell 
Styles gallery.
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4.	 Click OK in the Format As Table dialog box.

You can go to the (Table Tools) Design tab to refine your table. Choose a 
different table style in the gallery if you don’t care for the style you chose.

To remove a table style from cells, select the cells, go to the (Table Tools) Design 
tab, and choose Clear in the Table Styles gallery.

As Chapter 5 of this minibook explains, choosing the Format As Table command 
can be a way to filter and sort table data. This is why the Format As Table command 
places filter buttons in the first row of tables. To remove these filter buttons, 
deselect the Filter Button check box on the (Table Tools) Design tab.

Slapping borders on worksheet cells
Put borders on worksheet cells to box in cells, draw lines beneath cells, or draw 
lines along the side of cells. Borders can direct people who review your worksheet 
to its important parts. Typically, for example, a line appears above the Totals row 
of a worksheet to separate the Totals row from the rows above and help readers 
locate cumulative totals.

To draw borders on a worksheet, start by selecting the cells around which or 
through which you want to place borders. Then do one of the following to draw 
the borders:

»» Borders button: On the Home tab, open the drop-down list on the Borders 
button (it’s in the Font group) and choose a border, as shown in Figure 4-6.

»» Drawing: On the Home tab, open the drop-down list on the Borders button 
and choose Draw Border or Draw Border Grid. Then drag on the screen to 
draw the borders. Press Esc when you finish drawing.

»» Format Cells dialog box: On the Home tab, click the Format button and 
choose Format Cells, or choose More Borders on the Borders button drop-
down list. The Format Cells dialog box opens, as shown in Figure 4-7. On the 
Border tab, select a border style and either click in the Border box to tell Excel 
where to draw the border or click a Presets button. The Border tab offers 
different lines for borders and colors for borderlines as well.

To remove the border from cells, select the cells, open the drop-down list on the 
Borders button, and choose No Border.
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FIGURE 4-6:  
Drawing a 

border with  
the Borders 

button.

FIGURE 4-7:  
Go to the Format 

Cells dialog box 
to apply color 
(left) or draw 

borders (right).
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Decorating worksheets with colors
Apply background colors to cells to make them stand out or help the people who 
review your worksheets understand how they are laid out. Select the cells that need 
a background color and use these techniques to splash color on your worksheet:

»» On the Home tab, click the Format button and choose Format Cells on the 
drop-down list. You see the Format Cells dialog box. On the Fill tab, select a 
color and click OK. Figure 4-7 shows what the Fill tab looks like.

»» On the Home tab, open the drop-down list on the Fill Color button and 
select a color.

Getting Ready to Print a Worksheet
Printing a worksheet isn’t simply a matter of giving the Print command. A work-
sheet is a vast piece of computerized sprawl. Most worksheets don’t fit neatly on a 
single page. If you simply click the Print button to print your worksheet, you wind 
up with page breaks in unexpected places, both on the right side of the page and 
the bottom. Read on to discover how to set up a worksheet so that the people you 
hand it to can read and understand it.

Making a worksheet fit on a page
Unless you tell it otherwise, Excel prints everything from cell A1 to the last cell 
with data in it in the southeast corner of the worksheet. Usually, it isn’t necessary 
to print all those cells because some of them are blank. And printing an entire 
worksheet often means breaking the page up in all kinds of awkward places. To 
keep that from happening, following are some techniques for making a worksheet 
fit tidily on one or two pages.

As you experiment with the techniques described here, switch occasionally to 
Page Layout view. In this view, you get a better idea of what your worksheet will 
look like when you print it. To switch to Page Layout view, click the Page Layout 
button on the status bar or View tab.

Printing part of a worksheet
To print part of a worksheet, select the cells you want to print, go to the Page 
Layout tab, click the Print Area button, and choose Set Print Area on the drop-
down list. This command tells Excel to print only the cells you selected. On the 
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worksheet, a box appears around cells in the print area. To remove the box from 
your worksheet, click the Print Area button and choose Clear Print Area on the 
drop-down list.

Printing a landscape worksheet
If your worksheet is too wide to fit on one page, try turning the page on its side 
and printing in landscape mode. In landscape mode, pages are wider than they are 
tall. Landscape mode is often the easiest way to fit a worksheet on a page.

To make yours a landscape worksheet instead of a portrait worksheet, go to the 
Page Layout tab, click the Orientation button, and choose Landscape on the drop-
down list.

Seeing and adjusting the page breaks
Reading a worksheet is extremely difficult when it’s broken awkwardly across 
pages. Where one page ends and the next begins is a page break. Use these tech-
niques to see where page breaks occur, adjust the position of page breaks, and 
insert and remove page breaks:

»» Viewing where page breaks occur: Click the Page Break Preview button on 
the status bar or View tab. As shown in Figure 4-8, you switch to Page Break 
Preview view. In this view, page numbers appear clearly on the worksheet 
and dashed lines show you where Excel wants to break the pages.

»» Adjusting page break positions: In Page Break Preview view, drag a dashed 
line to adjust the position of a page break. After you drag a dashed line, it 
ceases being a default page break and becomes a manual page break. Manual 
page breaks are marked by solid lines, not dashed lines (see Figure 4-8). You 
can drag them, too. Excel shrinks the numbers and letters on your worksheet 
if you try to squeeze too much data on a worksheet by dragging a page break.

»» Inserting a page break: Select the cell directly below where you want the 
horizontal break to occur and directly to the right of where you want the 
vertical break to be, go to the Page Layout tab, click the Breaks button, 
and choose Insert Page Break. Drag a page break to adjust its position.

»» Removing a page break: Select a cell directly below or directly to the right 
of the page break, go to the Page Layout tab, click the Breaks button, and 
choose Remove Page Break.

»» Removing all manual page breaks: To remove all manual page breaks 
you inserted, go to the Page Layout tab, click the Breaks button, and choose 
Reset All Page Breaks.
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Switch to Page Layout or Normal view after you’re done fooling with page breaks. 
You can clearly see page breaks in Page Layout view. In Normal view, page breaks 
are marked by a dotted line.

“Scaling to fit” a worksheet
To scale the numbers and letters in a worksheet and make them a bit smaller so 
that they fit on a page, you can experiment with the Scale to Fit options. These 
options are located on the Page Layout tab. Starting in Page Layout view, go to 
the Page Layout tab and test-drive these options to make your worksheet fit on a 
single page or a certain number of pages:

»» Scaling by width: Open the Width drop-down list and choose an option to 
make your worksheet fit across one or more pages. Choose the 1 Page option, 
for example, to squeeze a worksheet horizontally so that it fits on one page.

»» Scaling by height: Open the Height drop-down list and choose an option to 
make your worksheet fit across a select number of pages. For example, 
choose the 2 Pages option to shrink a worksheet vertically so that it fits on two 
pages.

»» Scaling by percentage: Enter a percentage measurement in the Scale box to 
shrink a worksheet vertically and horizontally. To scale this way, you must 
choose Automatic in the Width and Height drop-down lists.

FIGURE 4-8:  
Deciding where 

pages break.
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You can also fit a worksheet on a select number of pages by going to the Page 
Setup dialog, box shown in Figure 4-9. With this technique, you get a chance to 
“print-preview” your worksheet and get a better look at it after you change the 
scale. On the Page Layout tab, click the Page Setup group button to open the Page 
Setup dialog box. On the Page tab of the dialog box, select the Fit To option button 
and enter the ideal number of pages you want for your worksheet in the Page(s) 
Wide By and Tall text boxes. Excel shrinks the data as much as is necessary to 
make it fit on the number of pages you asked for. Click the Print Preview button to 
preview your worksheet in the Print window and find out whether shrinking your 
worksheet this way helps.

Adjusting the margins
Another way to stuff all the data onto one page is to narrow the margins a bit. Go 
to the Page Layout tab and use either of these techniques to adjust the size of the 
margins:

»» Click the Margins button and choose Narrow on the drop-down list.

»» Click the Page Setup group button, and on the Margins tab of the Page Setup 
dialog box, change the size of the margins, as shown in Figure 4-9. By clicking 
the Print Preview button, you can preview your worksheet in the Print window 

FIGURE 4-9:  
The Page (left) 

and Margins tab 
(right) of the Page 
Setup dialog box.
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and adjust margins there by dragging them. Select the Show Margins button 
to display the margins. (This little button is in the lower-right corner of the 
Print window.)

Making a worksheet more presentable
Before you print a worksheet, visit the Page Setup dialog box and see what you can 
do to make your worksheet easier for others to read and understand. To open the 
Page Setup dialog box, go to the Page Layout tab and click the Page Setup group 
button. Here are your options:

»» Including page numbers on worksheets: On the Page tab of the Page Setup 
dialog box (refer to Figure 4-9), enter 1 in the First Page Number text box. 
Then, on the Header/Footer tab, open the Header or Footer drop-down list 
and choose an option that includes a page number. Choosing the Page 1 of ? 
option, for example, enters the page number and the total number of pages 
in the worksheet in your header or footer.

»» Putting headers and footers on pages: On the Header/Footer tab of the 
Page Setup dialog box, choose options from the Header and Footer drop-
down lists. You can find options for listing the file name, page numbers, the 
date, and your name. By clicking the Custom Header or Custom Footer 
button, you can open the Header or Footer dialog box and construct a 
header or footer there. Figure 4-10 shows the Footer dialog box.

»» Centering worksheet data on the page: On the Margins tab of the page 
Setup dialog box, select Horizontally or Vertically to center the worksheet 
relative to the top or bottom or sides of the page. You can select both check 
boxes. The preview screen shows what your choices mean in real terms.

FIGURE 4-10:  
Constructing a 

fancy footer.
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»» Printing gridlines, column letters, and row numbers: By default, the 
gridlines, column letters, and row numbers that you know and love in a 
worksheet aren’t printed, but you can print them by going to the Sheet tab of 
the Page Setup dialog box and selecting the Gridlines check box as well as the 
Row and Column Headings check box.

Repeating row and column  
headings on each page
If your worksheet is a big one that stretches beyond one page, you owe it to the 
people who view your worksheet to repeat row and column headings from page 
to page. Without these headings, no one can tell what the data in the worksheet 
means. Follow these steps to repeat row and column headings from page to page:

1.	 On the Page Layout tab, click the Print Titles button.

You see the Sheet tab of the Page Setup dialog box.

2.	 Select the Row and Column Headings check box.

You can find this check box under Print.

3.	 To repeat rows, click the Range Selector button next to the Rows to 
Repeat at Top text box; to repeat columns, click the Range Selector 
button next to the Columns to Repeat at Left text box.

These buttons are located on the right side of the dialog box. The dialog box 
shrinks so that you can get a better look at your worksheet.

4.	 Select the row or column with the labels or names you need.

As long as they’re next to each other, you can select more than one row or 
column by dragging over the row numbers or column letters.

5.	 Click the Range Selector button to enlarge the dialog box and see it again.

The text box now lists a cell range address.

6.	 Repeat Steps 3 through 5 to select column or row headings.

7.	 Click OK to close the Page Setup dialog box.

If I were you, I would click the Print Preview button in the Page Setup dialog 
box first to make sure that row and column headings are indeed repeating 
from page to page.

To remove row and column headings, return to the Sheet tab of the Page Setup 
dialog box and delete the cell references in the Rows to Repeat at Top text box 
and the Columns to Repeat at Left text box. You can also press Ctrl+F3 and delete 
Print_Titles in the Name Manager dialog box.
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       Advanced Techniques 
for Analyzing Data    

        T  his chapter off ers a handful of tricks for analyzing the data that you so 
carefully and lovingly enter in a worksheet. Delve into this chapter to fi nd 
out what sparklines are and how to manage, sort, and fi lter data in lists. 

You also discover how conditional formats can help data stand out, how the Goal 
Seek command can help you target values in diff erent kinds of analyses, and how 
you can map out diff erent scenarios with data by using one- and two-input data 
tables. Finally, this chapter explains how a PivotTable can help turn an indiscrim-
inate list into a meaningful source of information.  

  Seeing What the Sparklines Say 
 Maybe the easiest way to analyze information in a worksheet is to see what the 
sparklines say. Figure   5-1   shows examples of sparklines. In the form of a tiny line 
or bar chart, sparklines tell you about the data in a row or column. 

Chapter 5

 IN THIS CHAPTER 

 »     Using conditional formats to call 
attention to data  

 »   Sorting and fi ltering information in a 
worksheet list  

 »   Performing what-if analyses with 
data tables  

 »   Examining data with a PivotTable    
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Follow these steps to create a sparkline chart:

1.	 Select the cell where you want the chart to appear.

2.	 On the Insert tab, click the Line, Column, or Win/Loss button.

The Create Sparklines dialog box appears.

3.	 Drag in a row or column of your worksheet to select the cells with the 
data you want to analyze.

4.	 Click OK in the Create Sparklines dialog box.

To change the look of a sparkline chart, go to the (Sparkline Tools) Design tab. 
There you will find commands for changing the color of the line or bars, choosing 
a different sparkline type, and doing one or two other things to pass the time on a 
rainy day. Click the Clear button to remove a sparkline chart.

You can also create a sparkline chart with the Quick Analysis button. Drag over the 
cells with the data you want to analyze. When the Quick Analysis button appears, 
click it, choose Sparklines in the pop-up window, and then choose Line, Column, 
or Win/Loss.

Conditional Formats for Calling 
Attention to Data

A conditional format is one that applies when data meets certain conditions. To 
call attention to numbers greater than 10,000, for example, you can tell Excel to 

FIGURE 5-1:  
Sparklines in 

action (top 
to bottom): 

Column, Line, 
and Win/Loss.
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highlight those numbers automatically. To highlight negative numbers, you can 
tell Excel to display them in bright red. Conditional formats help you analyze and 
understand data better.

Select the cells that are candidates for conditional formatting and follow these 
steps to tell Excel when and how to format the cells:

1.	 On the Home tab, click the Conditional Formatting button (you may have 
to click the Styles button first, depending on the size of your screen).

2.	 Choose Highlight Cells Rules or Top/Bottom Rules on the drop-down list.

You see a submenu with choices about establishing the rule for whether values 
in the cells are highlighted or otherwise made more prominent:

•	 Highlight Cells Rules: These rules are for calling attention to data if it falls 
in a numerical or date range, or it’s greater or lesser than a specific value. 
For example, you can highlight cells that are greater than 400.

•	 Top/Bottom Rules: These rules are for calling attention to data if it falls 
within a percentage range relative to all the cells you selected. For exam-
ple, you can highlight cells with data that falls in the bottom 10-percent 
range.

3.	 Choose an option on the submenu.

You see a dialog box similar to the ones in Figure 5-2.

4.	 On the left side of the dialog box, establish the rule for flagging data.

5.	 On the With drop-down list, choose how you want to call attention to the 
data.

For example, you can display the data in red or yellow. You can choose Custom 
Format on the drop-down list to open the Format Cells dialog box and choose 
a font style or color for the text.

6.	 Click OK.

To remove conditional formats, select the cells with the formats, go to the Home 
tab, click the Conditional Formatting button, and choose Clear Rules➪    Clear Rules 
from Selected Cells.

You can also establish conditional formats by selecting cells and pressing Ctrl+Q 
or clicking the Quick Analysis button (which appears next to cells after you select 
them). In the pop-up window, choose Formatting and then click Greater Than or 
Top 10% to create a highlight-cell or top/bottom rule.
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Managing Information in Lists
Although Excel is a spreadsheet program, many people use it to keep and maintain 
lists, such as the list shown in Figure 5-3. Addresses, inventories, and employee 
data are examples of information that typically is kept in lists. These pages explain 
how to sort and filter a list to make it yield more information. Sort a list to put it 
in alphabetical or numeric order; filter a list to isolate the information you need.

FIGURE 5-2:  
Establishing a 

condition format 
for data.

FIGURE 5-3:  
A list in a 

worksheet.
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Before you attempt a sort or filter operation, use the Format As Table command 
to capture the data you want to sort or filter in a list. Chapter 4 of this mini-
book explains how to format cells so that they form a table. (Hint: Select the cells, 
click the Format As Table button on the Home tab, and select a table style in the 
gallery.)

Sorting a list
Sorting means to rearrange the rows in a list on the basis of data in one or more 
columns. Sort a list on the Last Name column, for example, to arrange the list in 
alphabetical order by last name. Sort a list on the ZIP Code column to arrange the 
rows in numerical order by ZIP code. Sort a list on the Birthday column to arrange 
it chronologically from earliest born to latest born.

Here are all the ways to sort a list:

»» Sorting on a single column: Click any cell in the column you want to use as 
the basis for the sort. For example, to sort item numbers from smallest to 
largest, click in the Item Number column. Then use one of these techniques to 
conduct the sort operation:

•	 On the Data tab, click the Sort Smallest to Largest or Sort Largest to 
Smallest button. These buttons are located in the Sort & Filter group.

•	 Open the drop-down menu on the column heading and choose Sort 
Smallest to Largest or Sort Largest to Smallest on the drop-down menu 
(see Figure 5-3). Click the Filter button on the Data tab if you don’t see the 
drop-down menus.

»» Sorting on more than one column: Click the Sort button on the Data tab. 
You see the Sort dialog box, as shown in Figure 5-4. Choose which columns 
you want to sort with and the order in which you want to sort. To add a 
second or third column for sorting, click the Add Level button.

FIGURE 5-4:  
Sort to arrange 
the list data in 

different ways.
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Filtering a list
Filtering means to scour a worksheet list for certain kinds of data. To filter, you 
tell Excel what kind of data you’re looking for, and the program assembles rows 
with that data to the exclusion of rows that don’t have the data. You end up with 
a shorter list with only the rows that match your filter criteria. Filtering is similar 
to using the Find command except that you get more than one row in the results 
of the filtering operation. For example, in a list of addresses, you can filter for 
addresses in California. In a price list, you can filter for items that fall within a 
certain price range.

To filter data, your list needs column headers, the descriptive labels in the first 
row that describe what is in the columns below. Excel needs column headers to 
identify and be able to filter the data in the rows. Each column header must have 
a different name.

To filter a list, start by going to the Data tab and clicking the Filter button. 
As shown in Figure 5-5, a drop-down list appears beside each column header.

Your next task is to open a drop-down list in the column that holds the criteria 
you want to use to filter the list. For example, if you want to filter the list to show 
items that cost more than $100, open the Cost column drop-down list; if you want 

FIGURE 5-5:  
Filter a worksheet 

to isolate data.
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to filter the list so that only the names of employees who make less than $30,000 
annually appear, open the Salary drop-down list.

After you open the correct column drop-down list, tell Excel how you want to 
filter the list:

»» Filter by exclusion: On the drop-down list, deselect the Select All check box 
and then select the check box next to each item you don’t want to filter out. 
For example, to filter an Address list for addresses in Boston, Chicago, and 
Miami, deselect the Select All check box and then select the check boxes next 
to Boston, Chicago, and Miami on the drop-down list. Your filter operation 
turns up only addresses in those three cities.

»» Filter with criteria: On the drop-down list, choose Number Filters, and then 
choose a filter operation on the submenu (or simply choose Custom Filter). 
You see the Custom AutoFilter dialog box.

Choose an operator (equals, is greater than, or another) from the drop-down 
list, and either enter or choose a target criterion from the list on the right 
side of the dialog box. You can search by more than one criterion. Select the 
And option button if a row must meet both criteria to be selected, or select 
the Or option button if a row can meet either criterion to be selected.

Click the OK button on the column’s drop-down list or the Custom AutoFilter dia-
log box to filter your list.

To see all the data in the list again — to unfilter the list — click the Clear button 
on the Data tab.

Forecasting with the Goal Seek Command
In a conventional formula, you provide the raw data, and Excel produces the 
results. With the Goal Seek command, you declare what you want the results to 
be, and Excel tells you the raw data that you need to produce those results. The 
Goal Seek command is useful in analyses when you want the outcome to be a cer-
tain way and you need to know which raw numbers will produce the outcome that 
you want.

Figure 5-6 shows a worksheet designed to find out the monthly payment on a 
mortgage. With the PMT function, the worksheet determines that the monthly 
payment on a $250,000 loan with an interest rate of 6.5 percent and to be paid over 
a 30-year period is $1,580.17. Suppose, however, that the person who calculated 
this monthly payment determined that he or she could pay more than $1,580.17 
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per month. Suppose that the person could pay $1,750 or $2,000 per month. Instead 
of an outcome of $1,580.17, the person wants to know how much he or she could 
borrow if monthly payments — the outcome of the formula — were increased to 
$1,750 or $2,000.

To make determinations such as these, you can use the Goal Seek command. 
This command lets you experiment with the arguments in a formula to achieve  
the results you want. In the case of the worksheet in Figure 5-6, you can use the 
Goal Seek command to change the argument in cell C3, the total amount you can 
borrow, given the outcome you want in cell C6, $1,750 or $2,000, the monthly 
payment on the total amount.

Follow these steps to use the Goal Seek command to change the inputs in a formula 
to achieve the results you want:

1.	 Select the cell with the formula whose arguments you want to 
experiment with.

2.	 On the Data tab, click the What-If Analysis button and choose Goal 
Seek on the drop-down list.

You see the Goal Seek dialog box, shown in Figure 5-6. The address of the cell 
you selected in Step 1 appears in the Set Cell box.

FIGURE 5-6:  
Experimenting 

with the Goal 
Seek command.
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3.	 In the To Value text box, enter the target results you want from the 
formula.

In the example in Figure 5-6, you enter -1750 or -2000, the monthly payment 
you can afford for the 30-year mortgage.

4.	 In the By Changing Cell text box, enter the address of the cell whose 
value is unknown.

To enter a cell address, go outside the Goal Seek dialog box and click a cell on 
your worksheet. In Figure 5-6, you select the address of the cell that shows the 
total amount you want to borrow.

5.	 Click OK.

The Goal Seek Status dialog box appears, as shown in Figure 5-6. It lists the 
target value that you entered in Step 3.

6.	 Click OK.

On your worksheet, the cell with the argument you wanted to alter now shows 
the target you’re seeking. In the case of the example worksheet in Figure 5-6, 
you can borrow $316,422 at 6.5 percent, not $250,000, by raising your monthly 
mortgage payments from $1,580.17 to $2,000.

Performing What-If Analyses  
with Data Tables

For something a little more sophisticated than the Goal Seek command (which 
I describe in the preceding section), try performing what-if analyses with data 
tables. With this technique, you change the data in input cells and observe what 
effect changing the data has on the results of a formula. The difference between 
the Goal Seek command and a data table is that with a data table, you can experi-
ment simultaneously with many different input cells and in so doing experiment 
with many different scenarios.

Using a one-input table for analysis
In a one-input table, you find out what the different results of a formula would be 
if you changed one input cell in the formula. In Figure 5-7, that input cell is the 
interest rate on a loan. The purpose of this data table is to find out how monthly 
payments on a $250,000, 30-year mortgage are different, given different interest 
rates. The interest rate in cell B4 is the input cell.
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Follow these steps to create a one-input table:

1.	 On your worksheet, enter values that you want to substitute for the 
value in the input cell.

To make the input table work, you have to enter the substitute values in the 
right location:

•	 In a column: Enter the values in the column starting one cell below and 
one cell to the left of the cell where the formula is located. In Figure 5-7, for 
example, the formula is in cell E4 and the values are in the cell range 
D5:D15.

•	 In a row: Enter the values in the row starting one cell above and one cell to 
the right of the cell where the formula is.

2.	 Select the block of cells with the formula and substitute values.

Select a rectangle of cells that encompasses the formula cell, the cell beside it, 
all the substitute values, and the empty cells where the new calculations will 
soon appear.

•	 In a column: Select the formula cell, the cell to its left, all the substitute-
value cells, and the cells below the formula cell.

•	 In a row: Select the formula cell, the cell above it, the substitute values in 
the cells directly to the right, and the now-empty cells where the new 
calculations will appear.

FIGURE 5-7:  
A one-input  
data table.
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3.	 On the Data tab, click the What-If Analysis button and choose Data Table 
on the drop-down list.

You see the Data Table dialog box (refer to Figure 5-7).

4.	 In the Row Input Cell or Column Input Cell text box, enter the address of 
the cell where the input value is located.

To enter this cell address, go outside the Data Table dialog box and click the 
cell. The input value is the value you’re experimenting with in your analysis. In 
the case of the worksheet shown in Figure 5-7, the input value is located in cell 
B4, the cell that holds the interest rate.

If the new calculations appear in rows, enter the address of the input cell in the 
Row Input Cell text box; if the calculations appear in columns (refer to Figure 5-7), 
enter the input cell address in the Column Input Cell text box.

5.	 Click OK.

Excel performs the calculations and fills in the table.

To generate the one-input table, Excel constructs an array formula with the TABLE 
function. If you change the cell references in the first row or plug in different val-
ues in the first column, Excel updates the one-input table automatically.

Using a two-input table for analysis
In a two-input table, you can experiment with two input cells rather than one. 
Getting back to the example of the loan payment in Figure 5-7, you can calculate 
not only how loan payments change as interest rates change but also how pay-
ments change if the life of the loan changes. Figure 5-8 shows a two-input table 
for examining monthly loan payments given different interest rates and two dif-
ferent terms for the loan: 15 years (180 months) and 30 years (360 months).

Follow these steps to create a two-input data table:

1.	 Enter one set of substitute values below the formula in the same column 
as the formula.

In Figure 5-8, different interest rates are entered in the cell range D5:D15.

2.	 Enter the second set of substitute values in the row to the right of the 
formula.

In Figure 5-8, 180 and 360 are entered. These numbers represent the number 
of months of the life of the loan.
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3.	 Select the formula and all substitute values.

Do this correctly and you select three columns, including the formula, the 
substitute values below it, and the two columns to the right of the formula. 
You select a big block of cells (the range D4:F15, in this example).

4.	 On the Data tab, click the What-If Analysis button and choose Data Table 
on the drop-down list.

The Data Table dialog box appears (refer to Figure 5-8).

5.	 In the Row Input Cell text box, enter the address of the cell referred to in 
the original formula where substitute values to the right of the formula 
can be plugged in.

Enter the cell address by going outside the dialog box and selecting a cell. In 
Figure 5-8, for example, the rows to the right of the formula are for length-of- 
loan substitute values. Therefore, I select cell B5, the cell referred to in the 
original formula where the length of the loan is listed.

6.	 In the Column Input Cell text box, enter the address of the cell referred to 
in the original formula where substitute values below the formula are.

In Figure 5-8, the substitute values below the formula cell are interest rates. 
Therefore, I select cell B4, the cell referred to in the original formula where the 
interest rate is entered.

FIGURE 5-8:  
A two-input 
data table.
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7.	 Click OK.

Excel performs the calculations and fills in the table.

Analyzing Data with PivotTables
PivotTables give you the opportunity to reorganize data in a long worksheet list 
and in so doing analyze the data in new ways. You can display data such that you 
focus on one aspect of the list. You can turn the list inside out and perhaps dis-
cover things you didn’t know before.

When you create a PivotTable, what you really do is turn a multicolumn list into a 
table for the purpose of analysis. For example, the four-column list in Figure 5-9 
records items purchased in two grocery stores over a four-week period. The four 
columns are

»» Item: The items purchased

»» Store: The grocery store (Safepath or Wholewallet) where the items were 
purchased

»» Cost: The cost of the items

»» Week: When the items were purchased (Week 1, 2, 3, or 4)

This raw list doesn’t reveal anything; it’s hardly more than a data dump. How-
ever, as Figure 5-9 shows, by turning the list into PivotTables, you can tease the 
list to find out, among other things:

»» How much was spent item by item in each grocery store, with the total spent 
for each item (Sum of Cost by Item and Store)

»» How much was spent on each item (Sum of Cost by Item)

»» How much was spent at each grocery store (Sum of Cost by Store)

»» How much was spent each week (Sum of Cost by Week)

Make sure that the list you want to analyze with a PivotTable has column headers. 
Column headers are the descriptive labels that appear across the top of columns 
in a list. Excel needs column headers to construct PivotTables.
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Getting a PivotTable recommendation 
from Excel
The easiest way to create a PivotTable is to let Excel do the work. Follow these steps:

1.	 Select a cell anywhere in your data list.

2.	 On the Insert tab, click the Recommended PivotTables button.

The Recommended PivotTables dialog box appears, as shown in Figure 5-10. 
This dialog box presents a number of PivotTables.

3.	 Scroll the list of PivotTables on the left side of the dialog box, selecting 
each one and examining it on the right side of the dialog box.

4.	 Select a PivotTable and click OK.

The PivotTable appears on a new worksheet.

Creating a PivotTable from scratch
Follow these steps to create a PivotTable on your own:

1.	 Select a cell anywhere in your data list.

2.	 On the Insert tab, click the PivotTable button.

FIGURE 5-9:  
A raw 

multicolumn 
list (left) turned 
into meaningful 

PivotTables 
(right).
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Excel selects what it believes is your entire list, and you see the Create 
PivotTable dialog box. If the list isn’t correctly selected, click outside the dialog 
box and select the data you want to analyze.

3.	 Choose the New Worksheet option and click OK.

You can choose the Existing Worksheet option and select cells on your 
worksheet to show Excel where you want to place the PivotTable, but in my 
experience, creating it on a new worksheet and moving it later is the easier way 
to go.

The (PivotTable Tools) Analyze tab and PivotTable Fields task pane appear, as 
shown in Figure 5-11. The task pane lists the names of fields, or column 
headings, from your table.

4.	 In the PivotTable Fields task pane, drag field names into the four areas 
(Filters, Columns, Rows, and Values) to construct your PivotTable.

As you construct your table, you see it take shape onscreen. You can drag fields 
in and out of areas as you please. Drag one field name into each of these areas:

•	 Rows: The field whose data you want to analyze.

•	 Columns: The field by which you want to measure and compare data.

FIGURE 5-10:  
These PivotTables 

come highly 
recommended.
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•	 Values: The field with the values used for comparison.

•	 Filters (optional): A field you want to use to sort table data. (This field’s 
name appears in the upper-left corner of the PivotTable. You can open its 
drop-down list to sort the table; see “Sorting a list,” earlier in this chapter.)

Putting the finishing touches  
on a PivotTable
Go to the (PivotTable Tools) Design tab to put the finishing touches on a PivotTable:

»» Grand Totals: Excel totals columns and rows in PivotTables. If you prefer not 
to see these “grand totals,” click the Grand Totals button and choose an option 
to remove them from rows, columns, or both.

»» Report Layout: Click the Report Layout button and choose a PivotTable 
layout on the drop-down list.

»» PivotTable Styles: Choose a PivotTable style to breathe a little color into your 
PivotTable.

To construct a chart from a PivotTable, go to the (PivotTable Tools) Analyze 
tab and click the PivotChart button. The Insert Chart dialog box opens. Book 8, 
Chapter 1 explains how to navigate this dialog box.

FIGURE 5-11:  
Constructing a 

PivotTable on the 
(PivotTable Tools) 

Analyze tab.


