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Preface 

Overview 

The goals of the CTDOT InRoads V8i Guide are: 

 To provide detailed instructions and technical support on the methods and standards used by 
CTDOT with Bentley InRoads V8i and beyond.    

 To provide assistance for locating InRoads resource files within CTDOT’s Digital Design 
Environment (DDE).  

 To aid in the creation of high-value electronic data.  

The CTDOT InRoads Survey V8i Guide will identify standard resource files, configurations, and CAD 
functions used in the creation high value data.   

The material covered in this guide does not replace the need for other references and training regarding 
InRoads software.  Additional publications and training may be needed for further clarification of CAD 
procedures and functions.  The intent of this guide is not to prevent or limit individual initiatives and 
engineering judgment. Rather, it is meant to document standard digital design procedures currently in 
practice at CTDOT.    

The information provided in this guide is subject to change as technology and experience warrant.  
Therefore, this guide will be updated as major revisions in design software and CTDOT DDE policies 
occur.   

 

Distribution 

This manual, in its entirety, may be freely copied and distributed for the purpose of providing a 
consistent guide to InRoads Design requirements of the Connecticut Department of Transportation.  The 
CTDOT InRoads Survey V8i Guide is available on the web.  

 

Trademarks 

“MicroStation” and “InRoads”, are registered trademarks of Bentley Systems, Incorporated.  Other trade 
names, computer protocols, and file formats mentioned in this manual are the trademarks of their 
respective owners.  In no event will the appearance of any graphic, description of a graphic, picture, 
screen display, or any other method of conveying meaning, be considered to impair the rights of the 
respective owners. 
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Prerequisites 

The required prerequisites for installing and using InRoads V8i are listed below.   

 MicroStation V8i SS 2 Version 08.11.07.492 or higher, 

 MicroStation V8i SS 3 Version 08.11.09.397 or higher, 

 InRoads V8i SS2 Version 08.11.07.428 or higher, 

 This is not configured to work with OpenRoads  (InRoads V8i SS 3) 

 

Online Application Help 

As mentioned earlier, this manual is not intended to be a sole source of information for the InRoads 
user.  InRoads software has extensive online help available through Help on the InRoads Menu Bar.  
Additionally, when using the different InRoads dialog boxes, each box has a Help button.  These buttons 
link directly to information specific to the InRoads process being performed.  It is generally expected 
that new or even seasoned InRoads users will need to reference the online help regularly.  The best 
solution to a problem usually requires testing and selecting from multiple options.   Practice and 
experience using InRoads is the key to becoming a proficient InRoads user.  Also, InRoads Help contains 
a media library with video presentations and examples of standard workflows.  

In addition, there are other outside InRoads learning resources for CTDOT users.  CTDOT employees can 
access the internet for help and training on the Bentley Learning Web site: 
 http://www.bentley.com/en-US/Training/, or call Bentley directly at 1-800-778-4277 only for  
SELECTservices or all others call 1-800-BENTLEY.  To access these learning resources from Bentley 
Systems, Inc., CTDOT employees should contact AEC Applications to have a Bentley SELECT-ID issued to 
them. However, Consultant Engineering firms need to purchase their own training subscriptions directly 
through Bentley.   

CTDOT ACE Applications has setup InRoads preferences and standardized CTDOT InRoads practices in an 
effort make using InRoads as productive as possible.  If you have questions regarding this manual or the 
CTDOT InRoads preference files, please contact: 

Elaine Richard  Gabriele Hallock Samantha Scharpf 

Phone: 860-594-3278 Phone: 860-594-3244 Phone: 860-594-2902 
Elaine.Richard@ct.gov Gabriele.Hallock@ct.gov Samantha.F.Scharpf@ct.gov 

 

 

http://www.bentley.com/en-US/Training/
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Section 1  Orientation to InRoads 

InRoads Survey provides a vehicle for data transfer and reduction from total stations, GPS, and other raw 
data sources. It includes a complete set of tools for adjustments, data analysis and editing of raw input 
data. Also included are tools for coordinate geometry and DTM display. InRoads Survey allows you to save 
data in geometry and DTM file types for further usage by other applications within the InRoads product 
group. InRoads Survey has resource files that have been configured with CTDOT standards.   

MicroStation is the platform application which allows InRoads data to be displayed.  MicroStation and 
InRoads applications both work together to provide users with CAD functions.  For example, InRoads uses 
MicroStation files to display CAD graphics for a DTM.  This guide will outline the InRoads commands that 
are available to view, display and present InRoads design data in CAD files.   

1.1 InRoads File Types 

The InRoads road design process uses several different file types.  All InRoads data is stored in external 
files. The CAD file is used to view a graphical representation of the design data, but the graphics files do not 
store the InRoads Data. For example, if the graphics that represent the horizontal alignment are deleted, 
the InRoads geometry file is not modified. 

The following InRoads resource files have been configured for the V8i Environment: 

Preference File (*.xin) - This file contains the control settings of all the dialog boxes within InRoads. The 
settings for surface, geometry and survey tools have all been confined to one .xin file, replacing the 
previous two .ini files, .fxp and .fwf files.  This is the main source of standardization where all InRoads 
design and graphical output are configured to meet CTDOT standards.   

Template Library (*.itl) – This file contains a storage area for typical sections. A template is comprised of a 
series of points and components that represent breakline features.  These are processed later using the 
Roadway Designer command.  Roadway features that have been processed are then saved to the design 
surface. CTDOT has two standard .itl files; one for roadway use and the other for airport taxiway and 
runway uses. 

Style Sheet (*.xsl) - All style sheets have been provided by Bentley and are located on the local hard drive, 
in the Inroads directory under Civil/XML Data.  The View XML Reports command allows users to select an 
.xsl style sheet, which specifies the exact information to pull from the .xml file and how to format it. To 
further clarify, the .xml file contains raw or computed data; the .xsl file specifies how to format the data 
into a report. 

Drafting Notes (*.dft) - This file is used to enhance the production of final drawings. Use the commands 
across the design session to place intelligent annotation notes on features and geometry, in the plan, 
profile, and cross section views, as well as at the intersection of two alignments.  

Pay Items (*.mdb) - This file is used with Quantity Manager.  Quantity formulas and CTDOT pay items are 
stored in this Microsoft Access database. 

Drainage Structures (*.dat) - This file is used with InRoads Storm and Sanitary.  This file has been 
configured with CTDOT standard drainage structure information, including sizes, shapes, materials, and 
many other parameters.  

Rainfall Table (*.idf) - This file is used with InRoads Storm and Sanitary.  This file contains a table of 
Rainfall/Time of Concentration data that conforms to CTDOT drainage standards. 



 S E C T I O N  1  O R I E N T A T I O N  T O  I N R O A D S  

12 

The following InRoads files need to be created for the project design: 

Projects (*.rwk) - This file contains directory and file information for loading and saving InRoads data files.  
Once the project file is open, all of the specific project files are also opened.   

Roadway Design (*.ird) - This file contains roadway model definitions. This file stores station and typical 
section information used by the Roadway Modeler command to create surface models along alignments.  
The Roadway Design (*.ird) is also the storage location for the superelevation design data. 

Surfaces (*.dtm) - A Digital Terrain Model (DTM) file is a surface where existing ground and design terrain 
surface models are stored. 

Geometry Projects (*.alg) – This file contains coordinate geometry and alignment information for a specific 
geometric project. 

Survey Data (*.fwd) – This InRoads Survey Fieldbook data file is created by importing survey data from a 
field data collector.   

XML Data (*.xml) - The XML Reports command, available as an application add-in under Tools on the pull 
down menu, generates XML data files. The XML files are not reports, but contain data that can be 
formatted into reports by using the View XML Reports command.  XML data files are ASCII files that are not 
formatted as a report for direct viewing. A report is the output generated when users display data from an 
XML file using the View XML Reports command.  

Quantity Manager (*.mdb) – This file contains a database of quantity information for a project. 

Drainage (*.sdb) – This InRoads Storm and Sanitary file is where the project storm drainage design 
information is stored.  This includes type and locations for catch basins, manholes and pipes. 

1.2 Resource File Storage Location 

The latest versions of all V8i resource files will be kept in the workspace under InRoads_V8i _RSC.  Before 
starting an InRoads project copy the InRoads_V8i _RSC folder from the workspace to the C drive.  Resource 
files for Surveys are copied to the local hard drive to improve the processing performance of the data.  The 
INI’s, FWF and FXP files for older level structures have all been converted to XIN files in both English and 
metric units.  These files can be found in the J_Environment and SE_Environment folders.  The newest V8 
level structure resource files will be found in the folder V8_Environment. 

1.3 Project Defaults 

An organized work environment along with a standardized file management system provides a consistent 
way to maintain digital design data.  These measures decrease the chance that users will create and/or 
work with incorrect InRoads files.  File management also eliminates the creation of multiple copies of the 
same file.  Therefore, a standardized file management system greatly increases productivity by ensuring 
the availability of correct InRoads files and eliminating duplicate files.     

By setting up the project defaults and creating a project file, users can quickly load all files needed for 
project design.  Additionally, the project file helps coworkers load and analyze current design data.  The 
Project Defaults command is used to open resource files including the preferences file (.xin) and drafting 
file.  This command is also used to set up default directories for all file types that can be accessed through 
the File/Open and File/Save As dialog boxes. These include Project (.rwk), Surface (.dtm), Geometry (.alg) 
and Survey Data (.fwd).  All other files, which are opened or saved throughout the InRoads program, use 
the Project Default Directory setting. The project default file directories are stored in the computer’s 
registry on the local hard drive.  
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1.4 Lab 1 Start up 

A. Open Windows Explorer and Browse to the CTDOT V8i workspace, copy the Folder 
InRoads_V8i_RSC (W:\Workspace\InRoads_V8i_RSC) to your computer 
C:\Bentley_V8i\Civil\InRoads Group V8.11. 

B. Click on the Accounting icon located on your desktop, see Figure 1-1. 

 

Figure 1-1 Accounting icon 

 

C. Follow the steps in Figure 1-2.  Within the Accounting Menu select Run Program (1), choose the 
MicroStation V8i D1/2/3 or 4 whichever is your District number. Select a project number from 
Available Accounts (2) and then highlight it within the Frequently Used Accounts.  Select the 
correct Resource Type (3) and click on the Start (4) button.  

 

Figure 1-2 CTDOT Accounting Menu 
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D. The first time into MicroStation V8i the “out of the box” MicroStation Manager Interface will 
appear. Select the Interface pull down first, pick New (Figure 1-3) and type in your user name 

(Figure 1-4). It must match your computer login exactly and it is case sensitive.  

Click the OK button. 

 

Figure 1-3 MicroStation Open File Dialog Box 

 

Figure 1-4 MicroStation Create User Interface Dialog Box 

 

E. Select the User pull down second, pick New and type in your user name, again it must match your 
Windows computer login exactly and it is case sensitive. This will create your user configuration 
file (.ucf). Click the OK button. 
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F. In the Project drop down select one of your projects.  Browse to any .dgn file, open the file and 
then immediately exit out of MicroStation.  The next time you go into MicroStation you should see 
the CTDOT MicroStation Interface. 

G. On the Accounting dialog box start up MicroStation again using the settings in Figure 1-2.  In the 
bottom right corner of the MicroStation Manager, select the project number. Browse to the Survey 
folder and select the “New File” icon to create a new MicroStation file see Figure 1-5.   

 

Figure 1-5 MicroStation Open File Dialog Box, Create New File 

H. In the New dialog box select ‘Browse’ to select a seed file, go to (your Districts 
CTDOT_V8_Workspace drive), as example:  
W:\CTDOT_Standards\Workspace\Standards\seed\SV_Design_Civil_3D_V8i.dgn and select Open 
as in Figure 1-6.  Back in the ‘New’ dialog box type in a file name (see Appendix ‘C’: File Naming 
Conventions; DDE Guide) and select the Save button.   

 

Figure 1-6 MicroStation Select Seed File Dialog Box 

 

I. In the ‘File Open’ dialog box select the file that was just created and select the Open button.  
MicroStation will open.  

http://www.ct.gov/dot/lib/dot/documents/deng/CTDOT_DDE_Guide.pdf
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J. On the MicroStation top pull down menu select Applications > InRoads Group > Activate InRoads 
Suite and InRoads will open. 

   

Figure 1-7 Activate InRoads Suite & Open Project Defaults… 

 

K. From the InRoads main menu bar select File > Project Defaults.  The Set Project Defaults dialog box 
will appear.  Click Import…  
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L. The Open dialog box will appear, browse to C:\Bentley_V8i\Civil\InRoads Group 
V8.11\InRoads_V8i_RSC. Double click Survey_V8i.reg.   

M. For the Configuration Name select the required corresponding level structure, for class 
Survey_SE_English.  Click Apply and Close on the Set Project Defaults dialog box. 

 

Figure 1-8 Configuration Names 

N. Complete this step only if you are using the V8 level structure.  From the InRoads Menu Bar 
“reselect” File > Project Defaults.  At the bottom of the dialog box select Survey for the Preferred 
Preference (Figure 1-9).  Click Apply and Close.   

 

Figure 1-9 InRoads Set Project Defaults Dialog Box 

 

O. On the MicroStation main menu select Element > Cells.  On the Cell Library Dialog box select File > 
Attach File… > Attach Cell Library. Browse to C:\Bentley_V8i\Civil\InRoads Group 
V8.11\InRoads_V8i_RSC\V8_Environment\cell and select SV_V8_LEVELS_40e.cel, double-click or 
click Open.  If you are working with SE or J levels pick the corresponding Environment and select 
the cell library in that folder.  Close the cell library box. 

P. From the InRoads Menu Bar select File > Project Options….  At the bottom select Preferences… 
Make sure Survey is loaded. 
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Section 2  Survey Electronic Data 

Reduction Workflow 

2.1 Lab 2 Importing the Traverse 

A. On the InRoads Interface right click next to Help and select Locks. 

B. On the InRoads Interface right click next to Help and select Customize... 

C. On the Customize dialog box (Figure 2-1) toggle on Survey and View Survey Data and click 
Close. 

 

Figure 2-1 InRoads Customize Dialog Box 
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D. From the InRoads main menu bar select File > Import > Survey Data.  The Import dialog box 
shown in Figure 2-2 will appear. 

E. Browse to the project being used. 
(e.g.999_Student##_2007\Survey\_Eng_Data\InRoads_Traverse\).  Change Files of type to TDS 
(*>rw5), data point on Trav.rw5 and select Import.  This will make the screen flash and data 
will be read. After the flash select Close. 

 

Figure 2-2 InRoads Import Dialog Box 
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F. Use the MicroStation Fit View command as shown in Figure 2-3.  Notice the Traverse Points are 
displayed. 

 

Figure 2-3 MicroStation View of Traverse Points 

G. From the InRoads main menu bar select Survey > Network Symbology, check the boxes for 
Line Traverse and Line Single Route, and then click Apply and Close. 

 

Figure 2-4 InRoads Network Symbology Dialog Box 
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H. From the InRoads main menu bar select Survey > View Survey Data > Network.  This will 
display the Traverse lines between the points as shown in Figure 2-5 

 

Figure 2-5 MicroStation View of Traverse Lines 
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2.2 Traverse Adjustments 

The Route command initiates a route for adjustments (route begins at the selected station) activates the 
Build Single Route command, which allows you to choose a single route through your survey data. After 
you choose the route, the Survey > Network command is automatically activated, and the selected route is 
loaded into the Network dialog box, allowing you to perform adjustments on the selected route.  

Choosing the Route command not only activates the Build Single Route dialog box but also turns on the 
View Survey Data > Network command, which displays network graphics as defined on the Network 
Symbology dialog box (under Survey > Network Symbology). 

If the Report lock is on when you activate the Route command, InRoads Survey generates a report 
containing the following information: 

 The number of control points (fixed points) in the route. 

 Whether the route has horizontal position control, horizontal angle control, or vertical position 
control. 

 Whether the route is closed or open. 

 The unadjusted area and length of the route. 

Highlight Stations (command on popup menu) provides an indication in graphics of the station that is 
selected in the Stations list. The selected station is indicated by a magenta square containing an X. 

A Highlight Observations command is available on the popup menu from the Observations list. However, 
you can run only one of these commands at once so that there is no confusion about whether a highlighted 
point is a station or an observation. 

Edit Style (command on popup menu) displays the Edit style dialog box, which lets you edit the survey style 
associated with the station that is selected in the Stations list. Edit Style is available only when a single 
station is selected in the Stations list. 

If a point is dual coded, the popup menu allows you to choose the particular style you want to edit. 



 S E C T I O N  2  S U R V E Y  E L E C T R O N I C  D A T A  R E D U C T I O N  W O R K F L O W  

23 

 

2.3 Lab 3 Adjusting the Traverse using Least Squares 

A. From the InRoads main menu bar select Survey > Fieldbook Data  

B. In the Stations portion of the Fieldbook Data dialog box (Figure 2-6) right click on the first 
station 49. A menu will appear then slide down and select Route.... 

 

Figure 2-6 InRoads Fieldbook Dialog Box 
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C. The Build Single Route box, Figure 2-7, will appear and show you the data for the traverse.  
Notice that the fixed points are symbolized with a triangle and the computed points are circles.  
Click OK.  

 

Figure 2-7 InRoads Build Single Route Dialog Box 

D. This brings the Network data into the Network - Single Route dialog box (Figure 2-8). Data 

point on the Least Squares button.    

 

Figure 2-8 InRoads Network - Single Route Dialog Box 
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E. Match the dialog with the one shown in Figure 2-9 and select Adjust. 

 

Figure 2-9 InRoads Least Squares Adjustment Dialog Box 

F. To view a report click on Report….  In the report browser select the LeastSquares.xsl report. 
Check the adjustments and see if everything is adjusted correctly.  

 

Figure 2-10 Bentley InRoads Report Browser 

G. After review close the report browser and the Least Squares Adjustment Dialog will still be 
available. 

H. Select the Accept on the Least Squares Adjustment Dialog Box; this will bring the adjusted data 
forward.  Notice the xyz values change based on the adjustment. 

Note: Even after we accept the Network we could still return to the adjustment commands and start again. 
InRoads will retain the original data information so that the Network can be recomputed anytime. 
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I. Now we still need to bring the adjusted data forward one more time. Even though we have 
accepted the data for the adjustment we still need to bring it forward to the fieldbook. Select 

the Network to Fieldbook Icon   on the Network – Single Route Dialog box.  This brings the 
adjusted data into the fieldbook.  The traverse points are now fixed. 

 

Figure 2-11 InRoads Adjusted Data on the Network - Single Route Dialog Box 

 

 

 

 



 S E C T I O N  2  S U R V E Y  E L E C T R O N I C  D A T A  R E D U C T I O N  W O R K F L O W  

27 

 

Figure 2-12 Adjusted Data in the InRoads Fieldbook 

Status indicates the relevant status code(s) for each station.  

The status codes are: 

N - The point has notes. 

E - The point has been edited. 

F - The point is a keyed-in (fixed) coordinate. 

A - The point has attributes. 

V - At least one of the attributes has a value. 

I - An inserted point 

C - An adjusted point. 
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2.4 Lab 4 Processing the Survey Data 

A. In MicroStation first make sure you have the correct cell library loaded from your C: drive and 
have the True Scale on by selecting Location Survey > True Scale Cells from the bar menu at 
the top.  Having the correct cell library open will dramatically reduce the amount of time it 
takes for the field data to load and appear on the screen.  

B. On the InRoads Menu  bar click on Tools > Survey Options… on the Import dialog box (Figure 
2-14).  The Survey Options dialog box will appear (Figure 2-13), in the File Options portion 
toggle on Resolve Code Errors and Log Code Errors. Click OK. 

 

Figure 2-13 InRoads Survey Options Dialog Box 

 

C. From the InRoads main menu bar select File > Import > Survey Data. The Import dialog box 
shown in Figure 2-14 will appear. 

D. Browse to the project being used. 
(e.g.999_Student##_2007\Survey\_Eng_Data\InRoads_Field\).  Change Files of Type to Group 
of files (*.*).  You can select a text file with all of the RWS files listed and click Import.  If you 
want to load files one at a time then change Files of Type to TDS(*.rw5) and double click each 
file or data point on each file and select Import.   



 S E C T I O N  2  S U R V E Y  E L E C T R O N I C  D A T A  R E D U C T I O N  W O R K F L O W  

29 

 

Figure 2-14 InRoads Import Dialog Box 

 

 

 

 

 

 

 

 

 

E. Click on Close on the Import dialog box (Figure 2-14).  The Resolve Code Error dialog box will 
appear (Figure 2-15).  Select Ignore All. This will process the data and allow the user to fix the 
code errors later.  After a few seconds the view will appear as shown in Figure 2-16. 
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Figure 2-15 InRoads Resolve Code Errors Dialog Box 

 

Figure 2-16 MicroStation View of InRoads Fieldbook Data 
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2.5 Point Codes 

Each station or observation in the field book is assigned a point code. The point code consists of two parts, 
an alpha/numeric code and a control code. By assigning an alpha/numeric code to a particular station or 
observation, that point will be associated to one or more styles listed in the Style Manager. By assigning a 
control code to a station or observation the construction of the planimetric graphics (arcs and line 
segments) related to that point are determined. The process of combining alpha/numeric codes with 
control codes is called point coding.  Surveyors typically record point codes in the field. In InRoads Survey, 
the point codes are activated from the Field book Data dialog box by right-clicking in the Stations list or the 
Observations list. The alpha/numeric codes and control codes embedded in the field book data, act in 
concert to define the construction and symbology of planimetric figures. 

Control codes describe geometric relationships among stations/observations in the field book. There are 15 
control codes in InRoads Survey.  Control Codes entered incorrectly in the field can to be edited and fixed 
in the Field book. 

 Feature Description Control Code 

Start Start a line ST 

Close Close an object CL 

Point of Curvature Start a curve PC 

Point of Tangency End a curve PT 

Exclude from 
Triangulation 

No DTM information DNC 

Random Random point type in surfaces generated by Survey Data to Survey RND 

Rectangle Form a rectangle based on two shot points and a taped distance RECT 

Close Rectangle Close a rectangle based on three shot points CLSR 

Nontangent Curve Use in conjunction with the PC and PT to specify a nontangent 
curve 

NT 

Join Point Join to a specified point number JPT 

Join Nearest Code Join to the nearest previously shot specified code JNC 

Distance Form a closed or open shape based on two shot points and taped 
distances 

DIST 

Template Set up a template to run multiple linear features TMPL 

Cross Section Code Cross section code XS 
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Add to Adjustment Set Defines a foresight unknown point to be included with adjustments 
data 

ADJ 

Extend Arc Closes an arc with another arc based on three field points, creating 
a circle 

EXTARC 

 Planimetric figures in InRoads Survey are graphical representations of objects with linear characteristics 
(for example, the edge of pavement, the centerline of a roadway, a guardrail). The style used for existing 
bituminous concrete lip curbing named CRBBCL as shown in Figure 2-17 has been created with an Alpha 
Code BC and a Numeric Code 104.  To begin a planimetric figure on a particular station or observation a 
code plus the designated start control code: <Feature Code> + <Start Control Code> must be specified.   To 
start Bituminous Concrete Lip Curbing the Alpha Code BC ST or Numeric Code 104 ST is used. Any 
subsequent station or observation containing the code BC or 104 is included in the planimetric figure until 
another ST code is encountered.   The following point codes might model a small portion off a simple 
roadway.  Notice in Figure 2-18 that two BCLC planimetric figures are being constructed concurrently. 
Manholes are not typically part of a planimetric figure because they are usually single shot points that have 
cells or attribution representation, so the Storm Manhole point has no start code. 

 

Figure 2-17 Edit Style Dialog Box 

  

Notice in Figure 2-18 that two BCLC planimetric figures are being constructed. Catch basins are not typically 
part of a planimetric figure because they are usually single shot points that have cells or attribution 
representation, so this point has no start code. 
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Figure 2-18 Planimetric Figure Using Numeric Codes 



 S E C T I O N  2  S U R V E Y  E L E C T R O N I C  D A T A  R E D U C T I O N  W O R K F L O W  

34 

 

2.6 Style Manager and Alpha/Numeric codes 

The XIN file allows the user to create a feature usable by all areas of the product. The XIN is a combination 
of the InRoads 8.5 Feature Style Manager, Geometry Style Manager and Feature Table into a single Style 
Manager.  

Survey point data is typically composed of two key aspects:  

 Point location (Northing, Easting and Elevation) 

 Physical characteristics of the object being recorded (Style Manager).  

Each Survey Style has been predefined with CTDOT standard properties including: 

 Named Symbology (color, line weight, line style, cell, text size and font) 

 Codes - Alpha Codes and a Numeric Code.  

 Custom Operations  

A style is associated with a particular station or observation in the fieldbook only when the appropriate 
alpha/numeric code is used and the CTDOT XIN is loaded.   A point entered in the field with the incorrect 
code will not have the correct style or have no style associated to it when it is imported into the InRoads 
Fieldbook.   

The object's physical characteristics are modeled in the style. In other words, styles define symbology (and 
more) for representing various real-world objects. 

Example – Suppose a utility pole was shot at a certain point. The surveyor wishes to place a cell to 
represent the utility pole in the CAD file at the point location. A style has been created that controls which 
cell is placed at the point, the cell scale, rotation of the cell, level of the cell, and so on. 

Example – Suppose a series of points representing an edge of pavement has been collected. A style has 
been created that controls the color and line style of the graphics representing the edge of pavement. 

The previous examples contain what are considered generic properties (cell, line style, level, color, and so 
on). The surveyor often records more specific physical characteristics, and the style can model these 
specific characteristics using attributes and custom operations, as in the following example. 

Example – Suppose a manhole was shot at a certain point. In addition to a cell at the point, the surveyor 
records an ID number of the manhole, as well as incoming and outgoing invert elevation. A style has been 
made that controls the cell, and also recognizes three specific attributes (manhole ID number, invert in, 
and invert out). Then using custom operations in InRoads Survey (discussed in a later section), data related 
to the three attributes can be displayed for each manhole shot. 

Associating stations/observations with styles is part of the process called point coding which is discussed in 
Section 2 
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2.7 Fieldbook Data 

This command lets you manage your field data. You can add, edit, delete, and find stations and 
observations with the resizable Fieldbook Data dialog box. The Stations list contains occupied stations. 
Selecting a station in the Stations list affects the Observations list. The Observations list contains 
observations that were shot from the station points.  

 

Stations List 

Station Name indicates the name of the occupied station. Stations are listed in the order in which they 
were gathered in the field.  

Northing indicates the northing coordinate for each station. 

Easting indicates the easting coordinate for each station. 

Elevation indicates the elevation for each station. 

Code indicates the control code associated with each station. 

Status indicates the relevant status code(s) for each station. The status codes are: 

N The point has notes. 

E The point has been edited. 

F The point is a keyed-in (fixed) coordinate. 

A The point has attributes. 

V At least one of the attributes has a value. 

I An inserted point. 

C An adjusted point. 

Backsight Point indicates the name of the backsight point for the selected station. 

Backsight Direction indicates the backsight direction from either a north or south azimuth  

Instrument Height indicates the instrument height for each station. 

Notes indicates notes for the selected station. 

Attributes indicates attributes for the selected station. 

 

Observations List 

Point Name indicates the name of the observation.  When you open or import a survey data file, if a fixed 
point is encountered that has the same name but different coordinates from a previously encountered 
fixed point, the name of the second occurrence of the point is assigned a suffix of _1. The suffix for each 
subsequent occurrence is incremented (_2, _3, and so on). 

Northing indicates the northing coordinate for each point. 

Easting indicates the easting coordinate for each point. 

Elevation indicates the elevation for each point. 

Code indicates the feature code(s) associated with each observation. 
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Status indicates the relevant status code(s) for each observation. The status codes are: 

N The point has notes. 

E The point has been edited. 

F The point is a keyed-in (fixed) coordinate. 

A The point has attributes. 

V At least one of the attributes has a value. 

I An inserted point. 

C An adjusted point. 

Horizontal Observation indicates the horizontal angle for each observed point. 

Vertical Observation indicates the vertical angle for each observed point. 

Slope Distance indicates the slope distance to each observed point. 

Target Height indicates the height of the prism above the observed point. 

Notes indicates notes for the selected observation. 

Attributes indicates attributes for the selected observation. 
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2.8 Lab 5 Chainage 

The Observations area of the fieldbook dialog box provides a convenient way of locating the observations 
that constitute a particular planimetric figure.  The Chainage parameter lists the feature codes associated 
with the observation that is selected in the Observations list. If an observation is dual-coded, the Chainage 
parameter lists each of the feature codes for the observation. (If multiple observations are selected, the 
Chainage parameter lists the feature codes from only the first of the selected observations.).  

 

Figure 2-19 Chainage 

To step through the observations related to a particular planimetric figure: 

 Select an observation that is part of the planimetric figure. You can use the Select Figure button at 
the top of the dialog box or the Select Observation button to the right of the Observations list. 

 Make sure that the feature code that you are interested in is set in the Chainage parameter. 

 Use the arrow buttons to move to the first (|<), previous (<), next(>), and last (>|) observations in 
the figure. 

 You may want to select the Highlight Observations option, available by right-clicking on an 
observation in the Observations list. When the Highlight Observations option is selected, as you 
step through each point in a figure the current point is indicated in graphics by a magenta square 
containing an X. 

 As you move from point to point using Chainage, if a point does not fall within the graphics view, 
the command automatically centers the point. 

 You can use Chainage along with the Edit Observation dialog box to easily edit each of the points 
involved in a planimetric figure, even if the points are scattered throughout the Observations list. 
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For example, after using the Edit Observation dialog box to edit the first point in your planimetric, 
you could use the arrow buttons to move to the next observation in the figure. The Edit 
Observation dialog box is instantly updated with the information for the next point in the figure. 
Repeating these steps (edit the point, move to the next one), you can quickly edit each of the 
points in the figure. 
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Section 3  Fieldbook Editing 

3.1 Lab 6 Fixing Code Errors 

A. The first Code error we will fix is the code error that was reported as we processed the data. 
From the InRoads main menu bar select Survey  > Find Point in View command 

B. When the Find Point in View dialog appears enter the point number: 2941 (Pt # observed when 
the code errors were reported.) radius: 2.000 (feet) and click Apply.  This will center the point 
to the screen and everything that is within a 2 foot radius.  

C. Turn on the point numbers, from the InRoads main menu bar select Survey > View Survey Data 
> Names or select the View Names tool as shown on Figure 3-1. 

 

Figure 3-1 InRoadsView Survey Data Toolbar 

Notice there is no symbology for point 2941 (Figure 3-2) this is because the code was entered incorrectly in 
the field. 

 

Figure 3-2 MicroStation View of Point 2941 

 

 

D. From the InRoads main menu bar select Survey > Fieldbook Data or select the Fieldbook Data 
tool as shown on Figure 3-3. 
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Figure 3-3 InRoads Survey Toolbox 

E. After the Fieldbook Data dialog box appears select the selector button  from the 
Observations area this will cause the dialog to minimize and InRoads will prompt you to 
identify a point 2941 in the MicroStation view. The minimized dialog might be covering the 
prompt just move it out of the way. 

F. The Fieldbook Data dialog will display again with the point 2941 selected. Notice that the code 
is red. This indicates that there is a code error and the system does not recognize the code that 
was used in the field.  Right Click on the hi-lighted line in the Observations area (as shown in 
Figure 3-4) and select Edit. 

 

Figure 3-4 InRoads Fieldbook Data Dialog Box - Fixing Code Errors 
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Figure 3-5 InRoads Edit Observation Dialog Box 

G. Enter 999 not 333 as the code click Apply on the Edit Observation Dialog Box (Figure 3-5), this 
will execute the command.  Notice (Figure 3-6) the point now has the correct symbol for the 
point. 

 

Figure 3-6 MicroStation View of Updated Point 2941 
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3.2 Lab 7 Fixing Point Codes 

A. Turn off the point numbers, from the InRoads main menu bar select Survey > View Survey Data > 
Names or select the View Names tool as shown on Figure 3-1. 

B. From the InRoads main menu bar select Survey > Fit View. This will fit the dynamic survey data 
display to your screen. 

C. Turn on the point numbers, from the InRoads main menu bar select Survey > View Survey Data > 
Names or select the View Names tool as shown on Figure 3-1. 

D. The view shows a blue line from one end of the data to the other; this is not right. With the 
MicroStation Window tool, select the area in on the lower end of the line as shown in Figure 3-7. 

 

Figure 3-7 MicroStation View of needed window area 

E. From the InRoads main menu bar select Survey > Fieldbook Data. 

F. After the Fieldbook Data dialog appears select the selector button  from the Observation 
section.  This will cause the dialog to minimize and InRoads will prompt you to Identify Point in the 
lower left hand corner of the screen.  

G. Select point 4287 in the view.  
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H. The Fieldbook Data dialog will display again with the point 4287 selected. Notice that the code is 
118 and that the second point of this chain has ST after it. After some trial and error we find that 
the ST should have been applied to the first point on this chain.  

 

Figure 3-8 InRoads Fieldbook Dialog Box - code edit 

I. Right Click on the blue bar for point 4287and select Edit. 

 

Figure 3-9 InRoads Edit Observation Dialog Box 
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J. Add ST to the code line and click Apply then select the next button this will take you to the next 
point where you will remove the ST and Apply. Notice Figure 3-10 the long line is gone and the 
channel is now displayed correctly. 

 

Figure 3-10 MicroStation View of corrected data 

Complete Steps I. and J. for the following survey point numbers: 

Point Number From To 

299 999 999 ST 

2297 delete  

2021 999 999 ST 

495 102 102 CL 

2486 205 205 ST 

3089 104 104 PC 

1092 102 102 CL 

1032 104 104 ST 

5425 999 999 ST 

2642 delete  

7210 117 117 ST 

5317 delete  

3120 999 999 ST 

3123 999 999 CL 

2298 102 102 ST 
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K. After all the data has been adjusted or at the end of each day you will want to save the Survey 
Data.  From the InRoads main menu bar select File > Save As.  

L. The Save As dialog appears Figure 3-11, select the Save as type: (*.fwd) and enter a file name then 
click Save.  This saves the data to a file and the next day you will load the .fwd and either continue 
with the edit process or import more field data or both. Remember to save the .fwd when ever 
exiting InRoads Survey. 

 

Figure 3-11 InRoads Save As Dialog Box 
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3.3 Lab 8 Fixing a Closed Shape 

A. From the InRoads main menu bar select Survey > Find Point in View... 

B. We will be working around point 1051; it’s a building corner. Enter the Point Name: 1051 and 
Radius: 10 (feet) and click Apply. 

C. Turn on the Point Name display.  From the InRoads main menu bar select Survey > View Survey 
Data > Names. 

D. Zoom in a little using Find Point in View... again. This time use a 2 foot radius.  

 

Figure 3-12 MicroStation View of Point 1051 

 Notice in this view (Figure 3-12) the lines taking off from points 1048 and 1051. Use 
 MicroStation tools to zoom out so see how the lines are not connecting correctly. The  fieldbook 
data will need to be adjusted so 1051 will close on 1048. 

E. From the InRoads main menu bar select Survey > Fieldbook Data... 

M. From the Observation section of the dialog select   and data point 1051 in the view. The dialog 
will reappear and point 1051 should be highlighted. Notice that 1051 has CL Code but point 1048 
has no ST to start this shape. Right click on point 1048 and select edit. Add the Code ST and this will 
fix the problem. 
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Figure 3-13 MicroStation View 
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3.4 Lab 9 Adjusting PC’ and PT’s,  

A. From the InRoads main menu bar select Survey > Find Point in View.  Enter Point Name: 211 and 
Radius: 12, Click Apply.  The MicroStation view shown in Figure 3-14 will appear. 

 

Figure 3-14 MicroStation View 

B. Turn on the display of Point Names. Enter the following edits to the island.  The graphics should 
reflect the line work shown in Figure 3-15. 

 Point 113 add PT 

 Point 114 add PC 

 Point 116 add PT 

 Point 119 add PC 

 Point 121 add PT 

 Point 122 add PC 

 Point 125 add PT 

 Point 127 add PC 

 Point 130 add PT 

 Point 131 add PC 

 Point 133 add PT 

Point 2730 add PC 

Point 2733 add PT 
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Figure 3-15 MicroStation View 
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Section 4  Surface and Ground File 

Creation 

4.1 Lab 10 Write Survey Data to Graphics 

A.  Now we will want to save the graphics to a design file. From the InRoads main menu bar select 
Survey > View Survey Data > Write Survey Data to Graphics. 

 

Figure 4-1 InRoads Write Survey to Graphics Dialog Box 

B. In the dialog box select the fields for Planimetrics, Names, Codes, Elevations and Notes.  Click Apply 
and then Close.  This will write the graphics to the design file. 

C. From the InRoads main menu bar select Survey > View Survey Data, turn off Planimetrics and 
Names. 
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4.2 Lab 11 Survey Data to Surface 

A. From the InRoads main menu bar select Survey > Survey Data to Surface.  For Surface Name input 
existing.  Adjust the setting to match Figure 4-2 and click OK.  

 

Figure 4-2 InRoads Survey Data To Surface Dialog Box 

B. Turn on Extended Data Checks.  In the Results area click the More… 

 

Figure 4-3 InRoads Triangulate Surface Dialog Box 
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C. On the Main Tab change Preference to Survey. 

 

Figure 4-4 InRoads Surface Properties Dialog Box Main Tab 
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D. On the Advanced tab change Cross Section and Profile Symbology to EXISTING. 

 

Figure 4-5 InRoads Surface Properties Dialog Box Advanced tab 

E. Click Apply then Close on the Surface Properties dialog box and Close. 

F. On the Triangulate Surface Dialog box click Apply and Close. 

G. Save your field book.  File > Save > Survey Data. 
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4.3 Lab 12 Surface Editing 

A. Start by closing your field book, any changes made to the features in the existing surface will be 
saved in the DTM (Digital Terrain Model) and not the field book.  In the survey tab right-click on the 
Fieldbook > Close. 

B. In MicroStation select Edit > Select by Attributes 

C. Select all Types except Cell, Text and Text Node for Levels.  

 

Figure 4-6 Select by Attributes Dialog Box 

D. Select Execute. 

E. Select the MicroStation tool Delete. 

F. Select Cell for Types and select all Levels except SV_NODES_ACTIVE_POINT. 

G. Select Execute. 

H. Select the MicroStation tool Delete and close the dialog box. 
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Figure 4-7 Select By Warning 

I. A warning will come up; just select the Cancel button. 

J. On the InRoads Main Menu select Surface > Update 3-D/Plan Surface Display. 

K. Select the existing surface, within the Features: window right-click and Select All. 

L. Click Refresh All and Close. 

 

Figure 4-8  Update 3-D/Plan Surface Display 
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M. Go to Surface > Utilities > Resolve Crossing Segments, this tool shows you where there are 
crossing segments that need to be fixed and can be used to fix them. 

 

Figure 4-9 Crossing Segments Tool 

N. For Mode select Interactive and click Apply.  This will bring up a list of all of the crossing segments.  
Click on one of the listed segments and the view will center on the crossing segment and highlight 
it with an X. 
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Figure 4-10 View Crossing Segments 

 

 

Figure 4-11 MicroStation View indicating a Crossing Segment 
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O. From the InRoads main menu bar select Surface > Edit Surface > Edit Feature Point…  

 

Figure 4-12 Edit Feature Point Tool 

P. This tool allows you to edit the features in your surface. Below Figure 4-14 shows two features 
crossing themselves, first use the target button within the Edit Feature point box to identify the 
features 

 

Figure 4-13 Edit Feature Point Dialog Box 
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Figure 4-14 MicroStation View 

Q. Select the feature you wish to move.  

 

Figure 4-15 MicroStation View 

R. When the target shows up on the features you wish to move, then pick the Northing, Easting 
button to move the feature. The northing, easting and elevation can be adjusted together by 
picking the biggest target button. 

 

Figure 4-16 Edit Feature Point Dialog Box 

S. When this feature is moved, the correction will be saved in the DTM and not the field book. 
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4.4 Lab 13 Deleting Triangles 

A. Select Surface > View Surface > Triangles, click Apply and Close. 

B. Select Surface > Edit Surface > Delete Triangle.  

 

Figure 4-17 Delete Triangle Dialog Box 

C. Click Apply and data point to create a line over the triangles you would like to delete. 

D. Select Surface > View Surface > Perimeter, click Apply and Close. 

E. Use MicroStation Tools to manipulate the Perimeter shape. Select the perimeter. 

F. In Inroads select File > Import > Surface.  Modify the dialog box as shown below.  Click Apply 
and select the Perimeter graphics. 

 

Figure 4-18 Import Surface Dialog Box 

G. Select Surface > View Surface > Triangles.  Click Apply and select Yes to re-triangulate. Close 
the dialog box. 
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H. Select File > Save As.  Save the edited surface. 

 

4.5 Lab 14 Checking the Contours 

A. From the InRoads main menu bar select Surface > View Surface > Contours…and click Apply. 

 

Figure 4-19 InRoads View Contours Dialog Box 

 

 

Figure 4-20 MicroStation View of Existing Contours 
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Section 5  Horizontal Alignments 

This chapter will discuss various horizontal alignment commands that are available in InRoads. In this 
section, users will create horizontal alignments and annotate the alignments to CTDOT standards.  
Horizontal alignment data and vertical alignment data is stored in the Geometry Project. The process of 
creating a Geometry Project and naming a Horizontal Geometry is explained below.  One horizontal 
alignment can reference several vertical alignment options. But only one alignment, the active alignment, 
can be manipulated within a project at a single time.  

5.1 Lab 15 Start Up  

5.1.1 Opening Files 

A. On the InRoads Main Menu select File > Close > All.  In MicroStation browse to 
X:\999_Student##_2007\Survey and open the file SV_Geometry.dgn. 

B. On the InRoads Main Menu click to File > Open.  Change the Files of type to *.dtm.  Browse to the 
project’s survey folder, select SV_Final.dtm and SV_Surface.dtm click Open for each and then 
Cancel.  

C. Select File > Project Options.  Select the Units and Format Tab and change Station to ss+ss.ss.  
Select Preferences and save the survey preference. Close. 

5.1.2 Surface Properties 

Surfaces have default properties and should be modified to display correctly in profile and cross section.   

A. In MicroStation open the Level Manager.  Select Levels > Import.  

 

Figure 5-1 Importing Levels 

B. Browse to the Workspace path Highways_Workspace\Standards\dgnlib and double click on 
HW_Levels.dgnlib.  
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Figure 5-2 Browsing for Highway Levels  

C. In the Level/filter Import dialog box click to select all and then click the OK button.  This will import 
all the Highway Design Levels. 

D. From the InRoads workspace bar windows, select the Surface tab.  

E. Right click over the existing surface and select Properties.   

F. On the Advanced Tab, write down the name of the Cross Section Symbology and Profile 
Symbology.  It should be named existing, be case sensitive. 

G. Go to Tools > Named Symbology Manager.  If  ‘existing’ is not there, copy the Symbology EXISTING 
and name it lower case existing.  
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H. On the Advanced Tab, reselect existing for Cross Section Symbology and Profile Symbology.  The 
symbology square will turn green. Click Apply.  

 

Figure 5-3 InRoads Surface Properties Dialog Box 

I. Change the surface to Final. 

J. For Cross Section Symbology select P_SURF_DESIGN.  Check on the Use Features Only box. 

K. Change Profiles Symbology to P_SURF_DESIGN.  The symbology square will turn orange. 

L. Click Apply and Close. 
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5.2 Lab 16 Creating Horizontal Alignments 

5.2.1 Naming the Geometry 

A. Click to File > New to create a name for the geometry project.  This command does not create an 
actual file it only creates an internal name for the Geometry Project.   

B. Click on the Geometry tab and type Geometry_Project in the name box. Click Apply  

      

Figure 5-4 InRoads New Dialog Box & Geometry Tab 

C. Change Type to Horizontal Alignment and type PI_Method in the name box.  set  Style: BL, Curve 
Definition: Arc, Click Apply 

D. Change Type to Vertical Alignment and type PI_Method_1. Style:  BL, Curve Definition: Parabolic 
Click Apply 

E. Keep Type at Vertical Alignment and type PI_Method_2.  Style: BL Curve Definition: Parabolic, Click 
Apply.  

F. Create and Save the .alg (Geometry Project) file.  Click to File > Save > Geometry Project on the 
InRoads Menu Bar. Click on the geometry name to save in the Active space and then the File name 
will appear in the File Name Box. Click Save, and then after the file is saved, click Cancel.   
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G. Save files in the RWK (Project).  Click to File > Save As on the InRoads Main Menu.  Change Save as 
type to Projects (*.rwk). Click the Options (…) button on the lower right corner of the Save As 
dialog box.  The Project Options dialog box will appear (fig. 5-5).  Check Add and Update and click 
on each file under file name for all the files listed under each tab. 

 

Figure 5-5 InRoads Project Options Dialog Box 

H. Click the OK button and the Project Options dialog box will close. 
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I. On the Save As dialog box data point in the File name field and type in the name of the file e.g. 
Project_File.  Click the Save button and then click Cancel.   

 

Figure 5-6 InRoads Save As Projects Dialog Box 
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5.2.2 Using Horizontal Alignment Tools 

A. Click on Tools > Customize.  On the Toolbars Tab, toggle to the Horizontal Curve Set, Vertical 
Curve Set and Locks. Click on Close and dock them in a logical place on the InRoads Dialog box.  
Figure 5-7 shows the different horizontal design tools available on the toolbar.   

 

 

Figure 5-7 InRoads Horizontal Curve Set Toolbar 
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5.2.3 Importing a Linestring 

Before importing a linestring we have to create a linestring using MicroStation tools.  Use the alignment 
data below to create the linestring. 

 

 

A. Click on File > Import > Geometry. 

 

Figure 5-8 Import Geometry Tool 
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B. Type Linestring in the Name box.  Style:  BL, Curve Definition: Arc, for the Target Geometry Project 
select Geometry_Project, then click Apply. 

 

 Figure 5-9 InRoads Import Geometry Dialog Box 

C. You will now be prompted to pick an element from the graphics.  Select the thick red line on the 
side road shown in Figure 5-10.  Then click again to accept. 
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Figure 5-10 Location of Linestring to Import 

 

5.2.4 PI Method 

A. On the Locks toolbar, toggle Pen/Pencil to Pencil.  Toggle on Report and Station locks and set the 
Point/Element toggle to No snap. 

B. In MicroStation Turn OFF the survey original ground reference file and window to the beginning of 
the project. 

C. To modify an alignment, it must be made the active alignment. Select the Geometry > Active 
Geometry.  Change the Type field to Horizontal Alignment.  Select the alignment PI_Method from 
the available list, and then click Apply. This will make the alignment PI_Method active for editing.  
Click Close. Another method is to right click in the Alignment to be activated in the workspace bar 
and choose Set Active. 

D. Select Geometry > Horizontal Curve Set > Add PI. 

E. For setting the first PI location data point on the top most red active point in the MicroStation file. 
Read the MicroStation prompts at the bottom left corner of the application as you data point. Each 
point will require two data points one to identify the location and another to accept the location.   

F. After accepting PI 1, users will automatically be asked to select the next point.  A dynamic display 
of the geometry tangent should follow the curser to the next point.  Select the next red active point 
near the second stream crossing.   

G. Continue to work along the project by selecting the last two red active points. 
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H. It a good practice to delete the graphics generated after creating geometry, and then redisplay the 
alignment elements.  This will ensure that the saved alignment is the same as what is shown on the 

screen.  Do not assume that the graphical elements shown on the screen are the same as 
what is in memory.  If uncertain, redisplay the alignment elements.  To redisplay the 
geometry, Select > Geometry > View Geometry > Active Horizontal. 

I. The process for creating the horizontal geometry can be iterative.  In some cases, the POB of the 
alignment then the POE (Point of Ending) are placed before any other PI points.  The sequence for 
placing points does not matter.  Try the tools below, place points where they seem reasonable, 
then insert and move points to get the desired alignment. 

 Insert PI - Use this command to insert a PI between two existing PI locations. Select Geometry 
> Horizontal Curve Set > Insert PI (read and follow the MicroStation command line readout). 

 Move PI - Use this command to move a PI that existing in the active alignment.  Select 
Geometry > Horizontal Curve Set > Move PI. 

 Delete PI - Use this command to delete a PI that exists in the active alignment.  Select 
Geometry > Horizontal Curve Set > Delete PI.  

J. When done trying out the commands in Step I, revise the alignment back to the red active points.   

K. Redisplay the geometry, select Geometry > View Geometry > Active Horizontal. 

 

5.2.5 Defining Curve Sets 

When a PI is placed, there is no curve associated with it; rather it is just a straight element. When the PIs 
are in place, the curve can be added. To place a curve set between two straight elements, use the Define 
Curve command. 

A. Select Geometry > Horizontal Curve Set > Define Curve.  The Define Horizontal Curve Set dialog 
box appears and the first horizontal PI is listed in the dialog box. 
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B. There are several options on the Define Horizontal Curve Set dialog box.  Figure 5-11 shows this 
box, and at the bottom notice the Next >, Last, and Select curve navigation buttons.  If users click 
the Next > button, all of the PI points will be displayed for the alignment. With the MicroStation 
view, each PI tangent set is highlighted as each curve becomes the active curve.   

 

Figure 5-11 InRoads Define Horizontal Curve Set 

C. In the bottom portion of the Define Horizontal Curve Set dialog box, above the curve navigation 
buttons, is the Define By: option.   Select the Radius option. 

D. Set the Leading Transition to Clothoid, enter 0 in the key-in field, and TAB to the next field. 

E. Set the Curve Set Type to SCS.  Go to the First curve set in the horizontal alignment.  Notice that 
the curve radius is set to 0.00 if it has not been changed.  Enter in a 500 foot curve radius for the 



 S E C T I O N  6  P R O F I L E S  A N D  V E R T I C A L  A L I G N M E N T S  

74 

project.  Click the TAB key to enter the data.  Then click the Apply button.    The curve should 
dynamically display the curve radius on the screen.  If the radius is too large, the software will not 
accept it and will notify the user for a solution overlap.   

F. Click Next. This will set the dialog box to the next PI.  Select Radius 1 and key in 500. Click Apply 
and Close. 

G. Delete the graphics again and redisplay the alignment once more, select Geometry > View 
Geometry > Active Horizontal. 

H. Save the edited geometry by selecting File > Save > Project. This will save the all the files added to 
the RWK file. 

5.2.6 Define Stationing 

A. Select Geometry > Horizontal Curve Set > Stationing. 

B. In the Stationing dialog select the Horizontal Alignment “PI_Method”. 

C. In the Starting Station field, enter the stationing value for the alignment (e.g. 10+00).  It is not 
required to type the (+). 

D. Vertical Alignments options should be set to Maintain Station Difference unless specifically 
attempting to shift alignment stationing. 

E. Click Apply and Close. 

 

5.3 Lab 17 Stationing and Annotation 

5.3.1 Display Stationing 

A. Click Geometry > View Geometry > Stationing to display the stations, major ticks, minor ticks, PC & 
PT cardinal leaders. 

B. Expand the View Stationing folder. Click on General and for Horizontal alignment select: 
PI_Method.  The correct Symbology boxes should already be checked off.   

C. Click Apply and Close.    
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5.3.2 Display Bearings 

A. Click Geometry > View Geometry > Horizontal Annotation  

B. Click on the pick button and data point on the alignment to annotate.  The alignment name should 
now appear in the Horizontal Alignments field.  

C. Click Apply to add the bearings and click CLOSE.    

 

Figure 5-12 InRoads View Horizontal Annotation Dialog Box 
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5.3.3 Display Curve Data 

A. Click Geometry > View Geometry > Curve Set Annotation. Click on the pick button and data point 
on the alignment that you want to annotate.  The alignment name should then appear in the 
Horizontal Alignment field.  

B. Click Apply and Close.  

 

Figure 5-13 Curve Set Annotation 
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5.3.4 Display Intersection Coordinates 

 

A. Click Drafting > Place Alignment Intersecting Note  

B. Click on the Plan folder to expand the list of plan notes. 

C. Select the note Intersection Alignment Annotation. 

D. Toggle OFF the Rotate option. 

E. Click Apply. 

F. Identify the first horizontal alignment by data pointing on it. 

G. Click again to accept it. 

H. Identify the second horizontal alignment by data pointing on it. 

I. Click again to accept it. 

J. Data point in the “quadrant” or corner of the intersection to place the leader and text for the 
intersection alignment information to be placed. 

K. The text will now be interactive with the cursor.  Click again to place the graphics at the desired 
location.   Figure 5-14 displays a section of an annotated Alignment Intersection. 

 

Figure 5-14 Annotated Alignment Intersection 
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Section 6  Profiles and Vertical 

Alignments 

This section will focus on the basic InRoads tools used to layout vertical control geometry.  Vertical 
geometry is the defined vertical data at or relative to the horizontal control geometry.  For example, the 
vertical geometry defines the grade of the roadway and the vertical curves.  In order to layout and design 
the vertical geometry, a profile generated along a defined horizontal geometry is needed.   

6.1 Lab 18 Working with Profiles 

6.1.1 Placing a Profile Window 

A. Go to Evaluation > Profile> Create Profile. 

B. Click on Source and select Alignment. Make sure that PI_Method is the alignment listed.  The 
Create data field should be set to Window and Data. 

C. Click on General, the Set Name data field should be set to PI_Method.  In the Surfaces area, toggle 
on the existing surface. In the Exaggeration area, set the Vertical exaggeration to 10.000 and the 
Horizontal exaggeration to 1.000. 

D. Select Include. Make sure that Crossing Features and Projected Features are not checked.   

E. Click on the Details folder and for Title Text: input PI_Method 

F. In MicroStation, rotate the view to TOP, and then fit the view.  Click the Apply button and data 
point to a blank area in the MicroStation View.  This will place a profile window. Click Close. 

 

Figure 6-1 Create Profile Dialog Box 
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6.1.2 Updating a Profile Display 

The steps below will result in the projected feature being deleted from the profile. 

A. Select Evaluation > Profile > Update Profile. 

B. In the Profile Set data field, select the profile set.  It is possible that the profile set name is 
PI_Method _1, because each time a new profile is created, a new profile set is also created. Select 
the most recently created set. 

C. In the Mode section, toggle on Display On. Select Final. In the Surfaces section, Click Apply. 

 

Figure 6-2 Update Profile 

 

D. Try to figure out how to turn the Final surface back off. 
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6.2 Lab 19 Working with Vertical Alignments 

6.2.1 Creating a Vertical Alignment 

Lab 14 of this manual explains the process for creating and naming a Vertical Geometry.  At this point, 
there should be an empty vertical geometry.  This had been created and named as a child of the Horizontal 
geometry which was used to create the profile. 

A. Using the View [Zoom] command, set the MicroStation view so that only the profile is showing. 

B. Make sure that the Pen/Pencil mode is set to Pencil and PI_Method is active for the Horizontal and 
PI_Method_1 is active for the vertical. 

C. Select Geometry > Vertical Curve Set > Dynamic Settings. 

The Dynamics Settings dialog box can be used to set a delta station, elevation, or grade on vertical 
elements. If a section were toggled on, that parameter would be set. This does not need to be used 
when creating or modifying a vertical alignment, but it is a helpful tool. Example:  If the Grade section 
of the dialog box was toggled on, and a grade of 1.00% was entered in the dialog box, then as the user 
moves the cursor across the profile, the tangent line following the cursor would snap to the even 1% 
grades (-5.0%, -4.0%, -3.0%, etc.). Select Geometry > Vertical Curve Set > Add PI.  Tentative to the 
intersection of station 11+00 and the existing surface in the profile window and data point to accept.  

 

Figure 6-3 InRoads Dynamics Settings Dialog Box 

D. Click on the Key Point Snap in MicroStation. Continue down the profile placing PVI’s and accept 
each input. Read and follow the MicroStation command prompt to accept (data point) the PVI 
location.  Try using the Dynamic settings. 

E. Try the Move and Delete Vertical PI tools.   

Notice that as the cursor moves, the tangent line follows it. The message “Out of Range” means that the 
cursor is located such that the vertical alignment overlaps itself. If the message “Profile not found” appears, 
this means the cursor is no longer in the profile window.  

6.2.2 Defining Vertical Curves 

Now the vertical curves can be set. The Define Vertical Curve command works just like the Define 
Horizontal Curve.  The Define Vertical Curve command finds the first PVI or curve set on an alignment. 

A. Select Geometry > Vertical Curve Set > Define Curve.  

B. In the Vertical Curve section of the Define Vertical Curve dialog box, set Calculate By to 
Length of Curve and enter a Length.  Click Apply. The vertical alignment display is updated 
with the vertical curve definition. 
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Figure 6-4 InRoads Define Vertical Curve Set Dialog Box 

C. Click Next and add a length and click Apply.  

D. Click Next and add a length and click Apply.  Continue for each PVI.  

E. Close the dialog box and Save the Project. 

6.2.3 Annotating a Vertical Alignment 

Vertical Geometry Annotation is the annotation of vertical elements in a profile.   

A. Select Geometry > View Geometry > Vertical Annotation.  Select the correct Horizontal 
Alignment and Vertical Alignment.  

B. Select the Profile Set. Do not turn on any of the Limits.  Click Apply.  The vertical alignment is 
annotated. Click Close. 
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Section 7  Cross Sections Creation 

7.1 Lab 20 Placing Cross Sections 

7.1.1 Creating Working Cross Sections 

A. Select Evaluation > Cross Section > Cross Sections…  

B. Open the Create Cross Section folder.   

 

Figure 7-1 InRoads Create Cross Section Dialog Box 

C. Click on the existing and Final surfaces. 

D. Make sure Interval is set to 50. 

E. Click Apply and data point in the file where to place the cross sections. 
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7.1.2 Generating End-Area Volumes 

A. In the Cross Sections box.  Select the folder End-Area Volumes.  

 

Figure 7-2 InRoads End-Area Volumes Dialog Box 

B. Select the name of the cross section set that was just created (PI_Method).  A rectangle is displayed 
around the cross section set in the design file.  It may be necessary to zoom out to see it. 

C. For the general tab, make sure the existing and Final surfaces are checked on.  Make sure Create XML 
Report is checked on, click Apply.   
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Figure 7-3 InRoads Report Browser Basic End Area Report 

D. View the cross sections that have been created.  The shaded area represents fill and cut sections.   
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7.1.3  Generating Cross Section Sheets 

The typical final cross section sets are cut perpendicular to the mainline horizontal alignment.  Final cut 
sheets can be created using the command Create Cross Sections. This command is used to extract cross 
sections along the active horizontal alignment.  Multiple cross sections are extracted and displayed with 
the CTDOT standard cell border.    

A. From the InRoads main menu select Evaluation > Cross Section > Cross Sections…  

B. Open the Create Cross Section folder.   

C. Load the InRoads Preference Survey Xsc Bdr Format.   

D. In the General settings, toggle on the surfaces Final and existing. 

 

Figure 7-4 InRoads Create Cross Section Dialog Box - General Folder 

 

E. Select the Layout folder, mode should be set to Sheet.  

F. Select Sheet Border and for the cell name should be set to BDR_XSC_HW. 
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Figure 7-5 InRoads Create Cross Section - Sheet Border Folder 

 

G. Select Include and un-check all the options.   

H. Select Apply and follow the prompts.  Click Close. 

I. On the MicroStation Menu Bar select Location Survey > True Scale Cells. 

J. On the MicroStation Menu Bar select Element > Cells. Select File > Attach File…and browse to 
W:\Highways_Workspace\Standards\cell\ HW_Existing_Features.cel. Select Open. 

K. Bring the cross section at station 24+00 to view.  On InRoads Menu Bar go to Evaluation > Cross 
Section > Update Cross Section.  Select Mode: Display On, select Crossing Features, Surface: existing, 
right click in Feature and choose Select All.  

L.  Select Apply and review what displayed on the cross section. 

M. Bring the cross section at station 24+00 to view.  Go to Evaluation > Cross Section .  Open the Update 
Cross Section folder.  Select Display On, Projected Features, existing, right click in Feature and choose 
Select All.  

N. For Bandwidth select redefine.  Enter 25 for both Ahead and Back. 

O. Select Apply and review what displayed on the cross section. 
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Figure 7-6 InRoads Update Cross Section Dialog Box
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7.2 Lab 21 Using Cogo Points to Create a Surface 

 

A. Select Geometry > COGO Points > New.  Change Define by to Station/Offset, Horizontal Alignment 
to PI_Method and select the Style APOINT. 

 

  

Figure 7-7 New Cogo Point 

B. Enter the following for Offset  and Elevation 
 

Station Offset Elevation 

15+00 20 240 

 10 241.5 

 0 242 

 -10 241.5 

 -20 239 

15+50 20 238 

 10 239.5 

 0 240 

 -10 239.5 

 -20 237 

16+00 20 236 

 10 237.5 

 0 238 

 -10 237.5 

 -20 235 
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C. In MicroStation turn off the reference file and the alignment levels. 
D. Back in InRoads select File > Import > Surface.   

 

Figure 7-8 Import Surface from Graphics 

E. For Surface type Grading.  Make sure Load From is set to Fence and Elevations is set to Use 
Element Elevations. Enter SPOT in the Seed Name, select SPOT as the Feature Style and set Point 
Type to Random.  Place a fence around the 15 spot shots and click the Apply button.  In the 
MicroStation window it should say Import Complete.  Click Close. 

F. Select Surface > View Surface > Contours, select the Grading surface and click Apply button. 
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Figure 7-9 View Contours 

G. Select Evaluation > Cross Section > Cross Sections...  Display the Grading surface on Cross Section 
at Station 15+00 to 16+00. 

 

Figure 7-10 Create Cross Section 
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H. Select Surface > Surface Properties.  On the Advanced tab change the symbology to Existing and 
click Apply. 

 

Figure 7-11 Surface Properties 
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J. Update the surfaces on the Cross Sections to display the new symbology.  Select Evaluation > Cross 
Section > Update Cross Section. 

 

Figure 7-12 Update Cross Section 

 

K. At station 15+00 use MicroStation with AccuDraw to raise the centerline elevation one foot.  Select 
the MicroStation Modify Command and select the point to be modified.  Select Evaluation > Cross 
Section > Cross Section to Surface.  Now redisplay the contours and they should change. 
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Figure 7-13 Cross Section to Surface
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Section 8  Misc Tools 

8.1 Lab 22 Placing a Grid 

A. Select Drafting > Place Coordinate Grid. 

 

Figure 8-1 InRoads Place Grid Command 

B. Using MicroStation place a fence or a shape and toggle on the corresponding Bounded by see 
Figure 8-2. 

 

Figure 8-2 InRoads Place Grid Dialog Box 

C. Select the Preferences Button.  To use a Survey Westerly Grid Mark data point on it and select 
Load and Close. 
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Figure 8-3 InRoads Preferences Dialog Box 

D. In the Place Coordinate Grid box click Apply and follow the prompts. Click Close. 

8.2 Lab 23 Working with Scales 

The XIN has been defaulted to use 40 scale units.  Preferences for 20, 80, and 100 have been configured.  
To change the scale, follow this workflow.  This procedure must be completed before an InRoads Fieldbook 
is created. 

A. Select the Location Survey Menu Bar located next to the main MicroStation tools.  Select Set Scale 
factors and select the desired scale. As shown in Figure 8-4. 

 

Figure 8-4 MicroStation Menu Pull Down Tool 
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B. On the InRoads menu select File > Project Options.  Select the Preferences button and load the 
desired scale see Figure 8-5. 

 

Figure 8-5 InRoads Preference Dialog Box 

C. On the InRoads menu select Tools > Survey Options.  Select the Preferences button and load the 
desired scale. 

 

Figure 8-6 Survey Options setting scale factor 
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Appendix A  InRoads Custom 

Operations 
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Appendix B  Using The Survey 

Menu Bar 

The Menu Bar replaced what used to be called the Bar Menu.  It is located along the top on the 
MicroStation Menu. 

 

Before starting to work you will need to set True Scale on, select a Scale Factor and attach a Cell Library.  
This can all be down for the Survey Menu Bar. 

Select True Scale Cells                    Select a Scale                                Attach the Correct Cell Library 

             

Now you are ready to place cells and text and draw lines.  
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