
Published Date: January 16, 2026 

 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 

 
 

CONNECTICUT DEPARTMENT OF TRANSPORTATION 

DIGITAL DESIGN  

ENVIRONMENT GUIDE 

CONNECT EDITION 
 
 

Volume 3.3 – 
OpenRoads Designer  

Corridor Modeling 



Volume 3.3  - OpenRoads Designer Roadway Modeling 

1 
 

Table of Contents 
 
Table of Contents ............................................................................................................................................... 1 

Course Overview ................................................................................................................................................ 3 

Exercise 1 – Getting Started ................................................................................................................................ 4 

1.1 Introduction ........................................................................................................................................ 4 

1.2 Opening the Application ...................................................................................................................... 6 

Exercise 2 - Create Corridor and Assign Template Drop ...................................................................................... 10 

2.1 Create a Corridor for Route 140 ......................................................................................................... 10 

2.2 Review the Corridor in 2D view ........................................................................................................... 13 

2.3 Review the 3D Corridor Model ........................................................................................................... 14 

2.4 Dynamic Cross Sections ................................................................................................................... 16 

2.5 Place Horizontal Temporary Dimensions ............................................................................................ 17 

Exercise 3 - Superelevation ............................................................................................................................... 19 

3.1 Overview ........................................................................................................................................... 19 

3.1.1 Superelevation Overview and Terminology ..................................................................................... 19 

3.1.2 Superelevation General Workflow .................................................................................................. 20 

3.2 Create Superelevation 2 Lane Road ................................................................................................... 20 

3.2.1 Create Superelevation Sections and Lanes .................................................................................... 20 

3.2.2 Create Superelevation Report and Review Transitions .................................................................... 25 

3.2.3 `Create and Review the Superelevation Diagram ........................................................................... 26 

3.2.4 Assign Superelevation to Corridor .................................................................................................. 27 

3.2.5 Review Superelevation on the Cross Sections ................................................................................ 28 

3.3 Create Superelevation 4 lane Road .................................................................................................... 29 

3.3.1 Create Superelevation Sections and Lanes .................................................................................... 29 

3.3.2 Create Superelevation Report and Review Transitions .................................................................... 32 

3.3.3 Create and Review the Superelevation Diagram ............................................................................. 32 

3.3.4 Assign Superelevation to Corridor .................................................................................................. 32 

3.3.5 Review Superelevation on the Cross Sections ................................................................................ 33 

Appendix .......................................................................................................................................................... 34 

3.1 Corridor Creation .............................................................................................................................. 34 

3.2 Corridor Editing ................................................................................................................................. 39 

3.2.1 Corridor Properties ........................................................................................................................ 39 



Volume 3.3  - OpenRoads Designer Roadway Modeling 

2 
 

3.2.2 Corridor Views .............................................................................................................................. 40 

3.2.3 Reports ......................................................................................................................................... 41 

3.2.4 Corridor Overlay ............................................................................................................................ 42 

3.2.5 Corridor References ...................................................................................................................... 42 

3.2.6 Corridor Creation Tools ................................................................................................................. 43 

3.2.7 Processing Order for Point Overrides ............................................................................................. 46 

3.3 Template Drops ................................................................................................................................ 47 

3.3.1 Create Template Drop ................................................................................................................... 47 

3.3.2 Edit the Template Range ................................................................................................................ 48 

3.3.3 Template Drop Context Menu ........................................................................................................ 48 

3.3.4 Create Corridor and Apply Template Drop ...................................................................................... 50 

3.3.5 Display Dynamic Cross Sections ................................................................................................... 56 

3.3.6 Modify Corridor ............................................................................................................................. 57 

3.3.7 Copy and Replace Template Drop .................................................................................................. 58 

3.3.8 Add Corridor Objects ..................................................................................................................... 61 

3.3.9 Create Parametric Constraint ........................................................................................................ 62 

3.3.10 Create Point Control .................................................................................................................. 65 

3.4 Applying Superelevation .................................................................................................................... 70 

3.4.1 Create Superelevation Sections ..................................................................................................... 70 

3.4.2 Assign Superelevation to Corridor .................................................................................................. 71 

3.4.3 Adding Additional Lanes ................................................................................................................ 72 

3.5 Placing Linear Templates................................................................................................................... 73 

3.5.1 Apply Linear Templates ................................................................................................................. 74 

3.5.2 Edit Linear Templates .................................................................................................................... 79 

3.6 Placing Surface Templates ................................................................................................................ 87 

3.6.1 Apply Surface Templates ............................................................................................................... 88 

3.6.2 Edit Surface Templates .................................................................................................................. 92 

 



Volume 3.3  - OpenRoads Designer Roadway Modeling 

3 
 

Course Overview 
This module will instruct users on how to create and edit roadway templates & Corridors. 

Skills Taught  
Learn how to: 
• create and manipulate a Corridor. 
• Assign template drops. 
• apply the superelevation transitions to your corridor 
• create, edit and review superelevation 
• add multiple templates drops as you encounter intersections, driveways and turn lanes. 
• use Horizontal and Vertical Geometry tools to create 2D and 3D geometric elements to lay out 

a complex intersection. 
• Tools and techniques will be taught to accurately model a complex intersection in 3D. You will learn 

how to: 
o use Linear Templates to create the side slope grading along the curb returns. 
o use Surface Templates to apply material thickness to the pavement surface. 
o create a Finished Grade Terrain Model using Graphical Filters. Export Finished Grade Terrain 

Model to LandXML format. 
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Exercise 1 – Getting Started 

1.1 Introduction 

Corridor Modeling allows the user to create a dynamic, intelligent and powerful 3D model of 
their design. The 3D model is then used to create cross sections, terrain models and generate 
corridor quantities. A corridor is created first in 2D by assigning a horizontal and vertical 
alignment to the corridor and then assigning a template to the corridor at a defined interval 
along the horizontal alignment. Once the template is assigned to the corridor a 3D model is 
created.  

A template represents the transverse geometry or typical section along the corridor. 
Templates are made up of points and components and are stored in a template library. When 
a corridor is processed the template points create 3D linear features (edge of pavement, 
shoulder, curb, sidewalk, cut/fill lines etc.) along the corridor and the template components 
create the 3D material meshes (i.e. pavement, shoulder, curb & gutter, sidewalk, side slope 
grading etc.) along the corridor. 
The Corridor Modeling toolset is a group of commands used to create 3D designs that 
represent a new roadway or other types of surfaces. Designers work primarily in 2D files and 
OpenRoads tools automatically generate the 3D model. Tools for the design, creation, 
modification, management, and report functions are provided. The tools are accessed by 
choosing the Corridors tab from the OpenRoads modeling workflow as shown below. 

 
Figure 1 Corridors Tab 

The 3D model will be generated from the 2D base model design file for CTDOT projects. It is 
recommended that users take a federated approach to store each corridor model in its own 
design file for  projects that have several alignments and sites.Projects will use multiple files for 
the geometry, terrain, superelevation, and the 3D model. All these files can reference one 
another to present a complete model of the project. 

Each road within the project is used to define a 3D corridor model representing the proposed 
design. A corridor consists of an alignment, profile, and a template defining the initial roadway 
typical section. Multiple templates may be applied within a corridor to better define the 
roadway. Additionally, transitions and other modifications to the template can be defined 
using various modification tools. As changes are made, the 3D corridor model is automatically 
updated. 
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Corridor Model 3D Graphics 
When a corridor is processed, the 3D model is generated in a separate MicroStation model 
named “Default-3D”. The corridor graphics consist of 3D line strings and 3D surfaces for each 
design component. The example below shows a portion of the pavement for a corridor with the 
individual pavement layers that were generated for the 3D model as well as a portion of the 
side slope. 

   
Figure 2 3D Graphics  

When the template is processed, the template points are connected between template “drop” 
locations to form the longitudinal break lines that are used to create the proposed surface. An 
example of the longitudinal break lines plotted from a 3-dimensional design surface is shown 
below. 

   
Figure 3 Template Points longitudinal break lines 

Only the top template points are used to create the proposed surface mesh. Points below the 
surface are excluded from the proposed design surface. 

The sub-surfaces can be included in the proposed cross sections as “components” or 
alternate surfaces. These components can be used for volume calculations. In addition to the 
3D graphics, the corridor modeling process draws 2D plan view graphics. These graphics can 
be used to generate the plan sheets for the project. An example of the 2D plan-view graphics 
drawn as part of the corridor modeling process for the curbing, shoulders, snow shelves, and fill 
limits is shown below. 
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Figure 4 Corridor 2D Graphics 

Corridor Modeling Workflow 

1. Create a 2D dgn file (all corridor information is stored in a dgn file).  
Corridors always start in 2D. The 3D model is generated automatically. 

2. Attach existing terrain model dgn as a reference file. 
3. Activate terrain model if working on end conditions/grading. 
4. Attach geometry dgn as a reference (horizontal and vertical geometry are required to 

create a corridor). 
5. Create a corridor. 
6. Add a template drop(s) to the corridor. 
7. Assign horizontal and vertical controls to adjust template points (as needed). 
8. Assign superelevation (as needed). 
9. Review the 3D model. 
10. Review the dynamic cross sections. 

1.2 Opening the Application 

Before starting this exercise: 
1. The CTDOT CONNECT DDE synced through SharePoint 
2. The COMPASS Training Project Synced (i.e. 9999-0001 – Design) 
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3. Launch the Application.  On your desktop double click on the Accounting Icon. 

 
Figure 5 5- CTDOT CAD Accounting Icon  

4. On the CTDOT Accounting Menu there will be several applications to pick. In the Run 
Program field select the needed program: 

• Compass OpenRoads CE 
• for the Available Account select OVERHEAD for training proposes.  
• Click on the Start button to load the program. 

Notes for working on actual projects: 
1. CTDOT users should have the CTDOT CONNECT DDE synced through SharePoint with 

the COMPASS Project Synced along with the CAD Configuration.  
2. Consultants should have CTDOT DDE properly installed or be syncing to the CTDOT 

DDE SharePoint/COMPASS system. 
3. Make note of the Coordinate System you will be working in. If you have existing 

survey data, you will need to find out what system is being used (NAD 83/NAVD 88 or 
NAD 27/NAVD 29).  

4. Log on to the CONNECTION Client. Bentley Connect licensing requires users to log into 
their Bentley account to secure a software license. CTDOT users should log in using 
your CTDOT email address and Bentley password. If you do not see the dialog 
box, select the ˄ icon on the bottom Windows Screen. Click on the Connection Client 
Icon and select Open. 
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Figure 6 6- CTDOT CAD Account Dialog Box 

5. After launching the program, a Welcome Screen for OpenRoads Designer will appear.  

6. Ensure you are using the Custom Configuration and CT_WorkSpace, then select the 
relevant WorkSet (Training WorkSets start with 9999_0001, select the # that you were 
assigned) and Role.  

7. Select the Browse icon, browse to: Highway/Base_Models/ 

Open the file named HW_CB_0047_0122_Exercise_1_ Corridor_Route140.dgn 

 
Figure 7 7– OpenRoads Start up Screen 
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8. In the upper left select the OpenRoads Modeling Workflow, and click on the Corridors tab. 
The commands are separated into five main categories: 

• Create 
• Edit 
• Miscellaneous 
• Superelevation 
• Review 

 
Figure 8 8– Corridor Tools 

This file will contain a corridor base model design file for a project. Base model files will reside 
within the project folder structure the ...\Highways\Base_Models folder. Depending on the 
complexity of the project one or more corridor base model files will be created.  References 
files such as alignments, survey and terrain files are attached without nesting. 
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Exercise 2 - Create Corridor and Assign Template 
Drop 

In this section, you will create a corridor along Route 140 using the template created in the 
previous DDE Exercise. Stay in the Exercise 1 file. 

2.1 Create a Corridor for Route 140 

1.   Click anywhere in View 1 to make it active. Hold right click, view control, and “2 views 
Plan/Profile”. Click the Route 140 alignment and open the profile in view 2. Hide the survey 
files to make the selection easier. 

2.   Go to the OpenRoads Modeling workflow, Corridors, and New Corridor and select the Route 
140 centerline geometry. 

 
3.   Set the Feature Definition to Final in the Create Corridor dialog. Feature Definitions for 

Corridors, control the accuracy and display settings of the Corridor. In this course you are 
going to use Final but other Feature Definitions are available. In the Name field key in: 
CL_Route140 (The name may already be present from when you selected the centerline 
geometry, if so, skip this). 

 
4.   Once you have the feature definition and name set, left click the profile in the profile view 

and click to accept and create the corridor. Once the Corridor is created the Create 
Template Drop tool will appear automatically and the heads-up display will be prompting 
you to select a template. The Create Template Drop tool is used to assign a template(s) to 
the corridor at a defined interval along the roadway alignment. 
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5.   Following the heads up prompts, press ALT and the Down Arrow on your keyboard to browse 
the templates in the template library. The Pick Template window will appear. In the Pick 
Template window, click the + to expand the template library folders. Select Templates and 
click the + to expand the folder. 

 

 
 
 

6.   Now Select 2ln_HMA_NC 
Select OK and Left click to accept. 

Following the heads up prompts (after each prompt, Left click to accept values and 
move to next prompt): 
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• Start Station: Press ALT to lock to Start 

• End Station: 146+00.00 

• Drop Interval: 10 

The template drop has been assigned and the corridor is now created. 

Notice there are now corridor elements drawn in the 2D and 3D views. The Corridor Object is 
created in the 2D view and the Corridor Model is created in the 3D view. 

7.   Turn off the display of the 3D model reference in the 2D view. 

a. Select the References tool (Home > Primary > Attach Tools > References) 

b. Select the Corridor-Route140.dgn  Notice the Default-3D name in the model column. 
c. Click the Display Reference icon at the bottom of the window to turn off the file. 

d. Close the References window. 
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2.2 Review the Corridor in 2D view 

In View 1 notice there is a 2D closed shape that is drawn along the corridor, this is  

the Corridor Object. The Corridor Object has properties of the corridor assigned to it  

that can be adjusted as needed. 

1.   To access the corridor properties, go to ORD Modeling, Edits, and Corridor Object tool. 

Notice in View 1, the closed dashed shape drawn along the corridor. This shape represents 
the Template Drop along the corridor. It has the properties of the template drop assigned to 
it that you can adjust as needed. 

 

 
2.   Review Template Drop Properties. 

a. To access the Template Drop Properties, go to ORD Modeling, Corridors, and Edit 
Template Drop.  

b. Hover your cursor over the boundary for a few seconds. A context sensitive toolbar will 
appear, giving you access to other template tools. 

c. Select the Template Properties icon on the toolbar to review the properties of the 
template drop. 

If you need to make changes to the template drop, the adjustments can simply be 
made in the dialog. 
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2.3 Review the 3D Corridor Model 
The corridor modeling process builds the 3D Model of the corridor by default. Generally, you will 
be working in the Default 2D model most of the time. In this section you learn how to review the 
3D model view. 

1. Hold right click, hit view control and open the 2 Views Plan/3D view. Click anywhere in View 
2 Default 3-D to make it active. 

2. Select Fit View  

3. Select the Zoom In tool at the top of the view window to zoom in closer to the 3D Model. 

4. Select the View Rotation tool at the top of the view window. 

5. Left click and hold the left mouse button to begin view rotation. Slowly move your mouse up 
and down or side to side to rotate the view. 

6. Release the left mouse button and Right click to reset. 
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7. Use the wheel mouse button to zoom in and zoom out to review the 3D model. 
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2.4 Dynamic Cross Sections 

In this section, you will learn to view cross sections using the Dynamic Cross Sections tool. 
Cross sections are created directly from the 3D Model and can be viewed with the Dynamic 
Cross Sections tool. The interval of the cross sections is based on the template drop interval 
and any critical sections defined in the corridor feature definition. Dynamic Cross Sections are 
always created perpendicular to the alignment that is being used with the Corridor. 

1.   Go back to View 1. Select the Element Selection tool. 

2.   From the ribbon menu select Corridors > Review > Dynamic Sections > Open Cross Section 
View tool. 

 
3.   In View 1, Locate and select the Route 140 Corridor. Set these as the parameters in the pop 

up dialogue. 

  
4.   Open View 7 by selecting the view 7 button from the bottom of the screen. View 7 window 

will appear. 

5.   Click in View 7, a cross section should now appear. 

Note that Dynamic Cross Sections are displayed in specially defined cross section model 
views. Any view can be defined to display the dynamic cross sections.  

6.   In the upper left portion of the window select the down arrow next to View Properties. 

7.   Set the Vertical Exaggeration to 5. 
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8.   Navigate through the cross sections by pressing the single right arrow to move to the next 
cross section. 

Experiment with navigating the cross sections forward and backward using the left and 
right arrows. Also, notice in plan view that a light blue line is displayed showing the current 
location the cross section is being displayed at. 

2.5 Place Horizontal Temporary Dimensions 

1.   Left-click in the cross section view and hold down your right mouse button and select Place 
Horizontal Temporary Dimension. 

Place dimension on the right side of the cross section: 

a. Select the CL point. 

b. Select the EOP_R point. 

c. Select a height anywhere on the cross section. 

A temporary dimension line will be placed showing the width and slope. 

Place temporary dimension line on the left side of the cross section: 

d. Select CL point. 

e. Select EOP_L point. 

f. Select a height anywhere on the cross section. 
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2.   Navigate through the cross section. 

3.   Remove the dimensions: 

a. Select Corridors > Review > Dynamic Sections > Remove All Temporary Dimensions 

b. Left-click in the cross section view. 
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Exercise 3  - Superelevation 

3.1 Overview 

In this exercise, you will learn how to create superelevation for Route 140 using the 
superelevation tools.  

Superelevation is the rotation of the pavement on the approach to and through a horizontal 
curve. Superelevation tools compute how the road will transition from normal cross slope to a 
fully superelevated section and back again. 

3.1.1 Superelevation Overview and Terminology 

Superelevation is the rotation of the pavement on the approach to and through a horizontal 
curve. Superelevation calculations are used to determine how the roadway pavement will 
transitionfrom normal cross slope to a fully superelevated section and back again. 

The concept of superelevation is simple but many agencies and countries apply 
superelevation to their projects differently. Before getting started with superelevation a few 
basic terms need reviewing: 

Maximum Superelevation Rate (emax): Based on local conditions, this is the maximum 
cross slope allowed for any curve for a given design speed. 

Superelevation Rate (e): Indicates the design cross slope used for a given design speed, 
horizontal curve radius and emax. 

Pivot Point (or Point of Rotation): Determines the point on the cross section that the 
superelevated lanes rotate about.  

Relative Gradient (G): The slope of the edge of pavement relative to the axis of rotation. 
Used to determine the superelevation runoff length. 

Runoff Length (Lr): Length required to transition a 0% cross slope to full superelevation. 

Tangent Runout Length (Lt): Length required to transition from normal crown to 0% cross 
slope. 

Location of Superelevation: Generally a certain percentage of the Runoff Length (Lr) or 
Total Length (Lr + Lt) is placed on the horizontal curve. 

Adjustment Factors for Number of Lanes rotated (bw): Used to reduce the length of 
transition when multiple lanes are rotated to reduce excessively long transition lengths. 

Superelevation XML Preferences (or Rules File): OpenRoads Designer uses an XML-
formatted rules file to calculate various aspects of superelevation. The XML preferences file 
can calculate superelevation rates for each curve of an alignment and the transition 
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lengths needed to rotate the road from normal crown cross slope(s) to full superelevation 
cross slope. 

Superelevation Section: Defines the limits of superelevation for a curve or set of curves. The 
section(s) are created based on the minimum tangent between curves. 

Superelevation Lanes: Defines the number of pavement lanes and the width of the 
pavement lanes that superelevation calculations will be applied to. 

 

3.1.2 Superelevation General Workflow 

The typical steps for creating superelevation is as follows: 

1.   Create a 2D dgn file where the superelevation data will be stored  
TIP: A best practice is to create superelevation data in its own 2D dgn file. 

2.   Attach horizontal geometry reference file (Horizontal geometry is required to create 
superelevation). 

3.   Create the superelevation section(s).  
4.   Define the superelevation lanes.  
5.   Calculate superelevation transitions and cross slopes.  
6.   Review and edit as needed. 
7.   Assign superelevation to a corridor. 

3.2 Create Superelevation 2 Lane Road 
 

3.2.1 Create Superelevation Sections and Lanes 

1.   Open Exercise_3_Superelevation_Route140.dgn, the geometry file is already attached 
as reference file. You need the geometry file in order to create superelevation. 

2.   From the ribbon menu select Corridors > Superelevation > Create > Create 
Superelevation Sections tool. 

 
Set the Feature Definition to Superelevation and key-in SE in the Name field. 
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3.   Follow the heads up prompts (key in the values listed below and Left click to accept and 
move to the next prompt): 

a. Name: Section 1 

b. Locate Corridor or Alignment: Select the Route 140 horizontal alignment. 

c. Start Station: Press ALT to Lock To Start 

d. End Station: 128+00 

e. Minimum Tangent Length: 10000 

The Minimum Tangent Length value is the determining factor on how superelevation 
sections are defined between curves along an alignment. Setting the value to 0.0 will 
typically create multiple superelevation sections for each curve along the horizontal 
alignment. Setting the minimum tangent length to a very large number will force 
only one superelevation section to be created along the entire length of the 
alignment. 

f. Lane Creation Method: Manual 
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4.   Create Left Pavement Lane (continue following the heads up prompts). 

a. Enter Lane Name: LT Lane 

b. Type: Primary 

c. Side of Centerline: Left 

d. Inside Edge Offset: 0 

e. Width: 12  

f. Normal Cross Slope: -2.0% 

 
5.   Create Right Pavement Lane (continue to follow the heads up prompts). 

a. Enter Lane Name: RT Lane 

b. Type: Primary 

c. Side of Centerline: Right 

d. Inside Edge Offset: 0 
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e. Width: 12  

f. Normal Cross Slope: -2.0% 

g. Right click or Reset to complete. 

TIP: Lanes can also be created automatically using the Template method. The 
template method allows you to select a template from the template library to define 
the lane width and normal cross slope. 

 
6.   Calculate Superelevation Transitions (continue to follow the heads-up prompts). 

a. Select Rules File: Press ALT and the Down Arrow on the keyboard to select 
AASHTO_2018_with_October_2019_Errata_imperial.xml  

[AASHTO_2018_with_October_2019_Errata_imperial.xml], browse to 
C:\Users\gaddit\State of Connecticut\DOT CTDOT_DDE - 
CONNECT\CT_Configuration\Organization-BIM\_CT_Civil 
Standards\Superelevation 

In this example the eMax is calculated using the Values in the AASHTO 
Superelevation Speed Tables for a Design speed of 50 mph [80 kph] and emax of 
6%. 

b. e Selection: 6% 

c. L Selection: Speed Table 

d. Design Speed: 45 

e. Pivot Method: Crown 

f. Open Editor: No 
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The Superelevation Section and Lanes are now displayed in View 1. 

Upon completion, the superelevation section, lanes and transitions will be created 
along the alignment.  

• The superelevation section is represented by a 2D closed shape drawn along the 
alignment. 

• The superelevation lanes are drawn with rainbow-like colors that indicate various 
cross slopes.  

• The superelevation transitions are assigned to the superelevation lanes. 

 
7.   Review the superelevation section properties. 

a. Select the superelevation shape. 

b. Hover your cursor over the superelevation section shape until the context sensitive 
menu appears. 
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c. Select the superelevation properties tool. 

d. Review the superelevation properties. 

8.   Review the right lane superelevation transitions 

a. Select the right superelevation lane. Notice the stations and cross slopes now 
appear.  

b. Right click to de-select. Or Left click anywhere in the view to de-select. 

9.   Review the left lane superelevation transitions. 

a. Select the left superelevation lane. Again, review the stations and cross slope 
information. 

b. Right click to de-select. Or Left click anywhere in the view to de-select. 

TIP: To edit the station or cross slope, simply click on the station text or cross slope 
text and enter a new value in the edit field. Stationing can also be changed 
dynamically by selecting the wedge shape and dragging it to the desired station. 

The wedge shape also serves as a slope indicator showing the direction of the 
cross slope. 

The stationing and decimal place settings can be adjusted under File > Settings > 
File > Design File Settings, the Civil Formatting category listing has options for 
controlling display of element handlers. These settings are not unique to 
superelevation; the same settings are used throughout the Civil products. 

The superelevation lane fill settings can be adjusted under File > Settings > User > 
Preferences > View Options - Civil, Superelevation Settings listing has options for 
the superelevation fill.  

Like many tools in the software, the Superelevation tools are “rule based”. When 
superelevation sections and lanes are created, rules and relationships are 
established that associate the superelevation sections and lanes to the horizontal 
geometry. If the horizontal geometry were to change, the superelevation sections 
and lanes would change and follow the new geometry. 

Since superelevation depends on the horizontal geometry reference file, you 
should never detach the horizontal geometry file. Doing so will break any rules 
and relationship that exist between the horizontal geometry and the 
superelevation data. 

3.2.2 Create Superelevation Report and Review Transitions 

In this section, you will learn to create the superelevation report and review the 
superelevation transitions. 
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1.   Select the Element Selection tool. 

2.   From the ribbon menu select Corridors > Superelevation > Superelevation Report 

 
3.   Select the superelevation section and Right click to accept it. 

4.   Review the superelevation information in the report and close the window when finished. 

If you need to adjust the Station and Cross Slope format, go to Tools > Format Options. 

 

3.2.3 `Create and Review the Superelevation Diagram 

In addition to reviewing superelevation transitions via the superelevation lanes and via the 
superelevation report, the software also provides  

the ability to view an editable superelevation control line diagram in a superelevation 
model view. In this section you learn how to create the superelevation model view and 
review the superelevation control lines.. 

1.   Select the superelevation section. 

Hover your cursor over the superelevation section shape until the context sensitive 
menu appears. 

Select the Open SuperElevation Model tool. 

Open View 8 by selecting the view 8 button from the bottom of the screen.  

View 8 will appear displaying the superelevation control line diagram. 

Once the superelevation model view is open you will notice 2 superelevation control 
lines displayed in the view window. The control lines represent the superelevation 
transitions for the left and right lanes of the corridor. Each control line is created from the 
superelevation lane information and is “ruled” to each superelevation lane. Thus, 
changing the superelevation control lines will adjust the superelevation lane stations 
and slopes. Each control line can be graphically edited or reviewed by simply selecting it 
and editing the station and slope values. 

2.   Select one of the superelevation control lines in View 8. Notice graphical manipulators 
and dynamic text appear indicating the Stations and Slopes of the transitions. The 
stations and slopes can be edited by simply selecting the values and entering new 
values 
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3.   Left click in View 8 to de-select the superelevation control line. 

Another thing to note is the shaded bands in the superelevation view window. Each 
shaded band indicates where a horizontal curve is located along the horizontal 
alignment. Also, the view is dynamic and the view exaggeration can be adjusted via the 
View Attributes. 

3.2.4 Assign Superelevation to Corridor 

In order to assign superelevation to a corridor the superelevation needs to be created in the 
corridor design file or attached as a reference file. Since you created the superelevation in 
a separate dgn file you will now learn how to attach it as a reference file and assign it to the  

corridor. 

a. Open HW_CB_0047_0122_Exercise_3_Corridor_Route140 

b. Click in View 1 to make sure it is the active view and Fit the view if necessary. 

c. Attach Superelevation.dgn to Corridor.dgn 

a. From the ribbon menu select Home > Primary > Attach Tools > References 

b. Select Attach Reference  

c. Select the file HW_CB_0047_0122_Exercise_3_Superelevation_Route140_Done. 
Set Attachment method to Coincident World. 

d. Select Open to attach the file. 

d. From the ribbon menu select Corridors > Superelevation > Calculate > Assign to 
Corridor 

 
a. Select superelevation section shape and Right click to accept it. 

b. Select the Corridor. 

c. Review the Associate Superelevation window and press OK 

This dialog shows the two template points that define each superelevation lane and 
which of those points the lane pivots about.  
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The template used for this project has the point CL defined as the superelevation pivot 
point and the points EOP_L and EOP_R as the points to be superelevated. 

d. Right click to complete the process. 

Now that the superelevation has been assigned to the corridor, the pavement will be 
superelevated based on the information in the superelevation file.  

Also, be aware that when the superelevation file is assigned to the corridor it is now 
“ruled” or associated to the corridor. If the superelevation file is updated the corridor 
will also update. 

3.2.5 Review Superelevation on the Cross Sections 

Review the cross sections to make sure the superelevation has been applied correctly. 
1.   Select the Element Selection tool. 
2.   From the ribbon menu select Corridors > Review > Dynamic Sections > Open Cross 

Section View tool. 
3.   Locate and select the Corridor. 
4.   Open View 7 by selecting the view 7 button from the bottom of the screen. View 7 

window will appear. 
5.   Click in View 7, a cross section should now appear. 

Note, the magenta boxes that appear at the left and right edge of pavement point 
locations on the cross sections. These boxes indicate a superelevation point control has 
been created and assigned to the corridor. 
Continually pressing the right arrow key at the top of the cross section view window 
moves to the next cross section station. 

6.   Press the right arrow to review the cross sections. As you are moving from cross section 
to cross section notice how the pavement cross slope is now being superelevated 
where necessary. 

7.   To review a specific cross section along the corridor, Right Click in the cross section view 
window. Select Locate Station Via Datapoint and follow the heads up prompts: 
a. Left click in the plan view or cross section view 
b. Station: 54+60 [5+140], Left click to accept. The cross section should now move to 

station 54+60 [5+140] 
Alternatively, selecting the down arrow next to the station field will allow you to enter a 
specific station to move to. 
As you can see the cross sections are now superelevated but how do you know what the 
cross slopes are? To display and review the cross slopes you will use the Place Horizontal 
Temporary Dimension Line tool. 

8.   Label the cross slopes. 
a. Left-click in the cross section view and hold down your right mouse button and 

select Place Horizontal Temporary Dimension. 
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b. Place dimension on the right side of the cross section: 
• Pick the CL point. 
• Pick the EOP_R point. 
• Pick a height anywhere on the cross section. 
A temporary dimension line will be placed showing the width and slope. 

c. Place temporary dimension line on the left side of the cross section: 
• Pick CL point. 
• Pick EOP_L point. 
• Pick a height anywhere on the cross section. 

9.   Navigate through the cross sections and notice how the slopes change based on the 
superelevation that has been applied. 

10.   Remove the dimensions: 
a. Select Corridors > Review > Dynamic Sections > Remove Temporary Dimensions 
b. Left-click in the cross section view. 

11.   Review the Superelevation Point Controls that were assigned to the corridor. 
a. Select the Element Selection tool. 
b. Left click in View 1 
c. Select the Corridors > Edit > Corridor Objects tool. 
d. Select the Corridor. 
e. Select Point Control on the left side of the dialog. Review the Superelevation Point 

Control properties. Note that Superelevation Point Controls are created and defined 
as a Vertical point control. 

f. Close the Corridor Objects window. 

3.3  Create Superelevation 4 lane Road 

3.3.1 Create Superelevation Sections and Lanes 

10.   Open Exercise_4_Superelevation_Route140.dgn, the geometry file is already 
attached as reference file. You need the geometry file in order to create superelevation. 

11.   From the ribbon menu select Corridors > Superelevation > Create > Create 
Superelevation Sections tool. 

Set the Feature Definition to Superelevation and key-in SE in the Name field. 

12.   Follow the heads up prompts (key in the values listed below and Left click to accept 
and move to the next prompt): 

a. Name: Section 1 

b. Locate Corridor or Alignment: Select the Route 140 horizontal alignment. 

c. Start Station: Press ALT to Lock To Start 
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d. End Station: 128+00 

e. Minimum Tangent Length: 10000 

The Minimum Tangent Length value is the determining factor on how superelevation 
sections are defined between curves along an alignment. Setting the value to 0.0 
will typically create multiple superelevation sections for each curve along the 
horizontal alignment. Setting the minimum tangent length to a very large number 
will force only one superelevation section to be created along the entire length of 
the alignment. 

f. Lane Creation Method: Manual 

13.   Create Left Pavement Lane (continue following the heads up prompts). 

a. Enter Lane Name: LT Lane 

b. Type: Primary 

c. Side of Centerline: Left 

d. Inside Edge Offset: 0 

e. Width: 12  

f. Normal Cross Slope: -2.0% 

14.   Create Right Pavement Lane (continue to follow the heads up prompts). 

a. Enter Lane Name: RT Lane 

b. Type: Primary 

c. Side of Centerline: Right 

d. Inside Edge Offset: 0 

e. Width: 12  

f. Normal Cross Slope: -2.0% 

g. Right click or Reset to complete. 

TIP: Lanes can also be created automatically using the Template method. The 
template method allows you to select a template from the template library to 
define the lane width and normal cross slope. 

15.   Calculate Superelevation Transitions (continue to follow the heads-up prompts). 

a. Select Rules File: Press ALT and the Down Arrow on the keyboard to select 
AASHTO_2011_imperial.xml  



Volume 3.3  - OpenRoads Designer Roadway Modeling 

31 
 

[AASHTO_2011_metric.xml], browse to c:\Bentley Training\QuickStart for Corridor 
Modeling-Road or other folder where you unzipped the dataset files to locate this 
file. 

In this example the eMax is calculated using the Values in the AASHTO 
Superelevation Speed Tables for a Design speed of 50 mph [80 kph] and emax of 
6%. 

b. e Selection: 6% 

c. L Selection: Speed Table 

d. Design Speed: 45 

e. Pivot Method: Crown 

f. Open Editor: No 

The Superelevation Section and Lanes are now displayed in View 1. 

Upon completion, the superelevation section, lanes and transitions will be created 
along the alignment.  

• The superelevation section is represented by a 2D closed shape drawn along the 
alignment. 

• The superelevation lanes are drawn with rainbow-like colors that indicate various 
cross slopes.  

• The superelevation transitions are assigned to the superelevation lanes. 

16.   Review the superelevation section properties. 

a. Select the superelevation shape. 

b. Hover your cursor over the superelevation section shape until the context sensitive 
menu appears. 

c. Select the superelevation properties tool. 

d. Review the superelevation properties. 

17.   Review the right lane superelevation transitions 

a. Select the right superelevation lane. Notice the stations and cross slopes now 
appear.  

b. Right click to de-select. Or Left click anywhere in the view to de-select. 

18.   Review the left lane superelevation transitions. 

a. Select the left superelevation lane. Again, review the stations and cross slope 
information. 
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b. Right click to de-select. Or Left click anywhere in the view to de-select. 

TIP: To edit the station or cross slope, simply click on the station text or cross 
slope text and enter a new value in the edit field. Stationing can also be changed 
dynamically by selecting the wedge shape and dragging it to the desired 
station. 

The wedge shape also serves as a slope indicator showing the direction of the 
cross slope. 

The stationing and decimal place settings can be adjusted under File > Settings > 
File > Design File Settings, the Civil Formatting category listing has options for 
controlling display of element handlers. These settings are not unique to 
superelevation; the same settings are used throughout the Civil products. 

The superelevation lane fill settings can be adjusted under File > Settings > User > 
Preferences > View Options - Civil, Superelevation Settings listing has options for 
the superelevation fill.  

Like many tools in the software, the Superelevation tools are “rule based”. When 
superelevation sections and lanes are created, rules and relationships are 
established that associate the superelevation sections and lanes to the 
horizontal geometry. If the horizontal geometry were to change, the 
superelevation sections and lanes would change and follow the new geometry. 

Since superelevation depends on the horizontal geometry reference file, you 
should never detach the horizontal geometry file. Doing so will break any rules 
and relationship that exist between the horizontal geometry and the 
superelevation data. 

 
 

3.3.2 Create Superelevation Report and Review Transitions 

 
 

3.3.3 Create and Review the Superelevation Diagram 

 
 

3.3.4 Assign Superelevation to Corridor 
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3.3.5 Review Superelevation on the Cross Sections 
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Appendix 

3.1  Corridor Creation 

A corridor model is created by applying a template to selected horizontal and vertical 
geometry. 

Corridor models are created by choosing the New Corridor command from the Corridors tab, 
or by selecting an alignment and choosing the Create Corridor command from the pop-up 
menu. When the command is selected, the software will step you through a series of prompts. 
These prompts appear on the cursor and can also be defined using the Tool Settings dialog. 

 
Figure 9 New Corridor Creation 

You are prompted to define the following parameters: 

Locate Profile – Reset For Active Profile - Select the profile name from the drop-down list or 
issue a reset button to accept the Active Profile that is defined for the Horizontal Alignment. 

Corridor Name - Define the name for the corridor. It is recommended that you use same name 
as the horizontal alignment. 

Design Stage - Design stages are used to define a variety of parameters to control the 
template drop interval as well as which elements are drawn in the 3D model (3D line strings, 3D 
components, surface meshes, etc). The design stages are defined in 
CV_Highway_Features_Levels_ElemTemp.dgnlib which is attached by a configuration 
variable. 

The design stages can be reviewed in the Civil Standards tab of the Project Explorer dialog as 
shown below. 
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Figure 10 Design stages in Project Explorer 

The design stage can be changed at any time throughout the corridor modeling process. 

Each design stage is defined to provide more detailed information as you work from 
conceptual design for the final design. The settings for each design stage are defined in the 
CTHDOT standards and vary for each design stage. 

Template Drop Interval Multiplier - When templates are applied to the horizontal and 
vertical geometry, the user is prompted to enter a template drop interval. CTDOT 
recommends an interval of 5. The Template Drop Interval Multiplier parameter is used to 
specify a multiplier, which is applied to the initial template drop interval, to determine the 
actual interval of each template drop location according to the selected design stage. This 
is useful to speed up processing for early design stages where less detailed information is 
required. The CTDOT design stages have been defined with the multiplier values shown in 
the table below.  

Design Stage 
Template Drop 
Interval Multiplier 

Conceptual 5 

Design 2 

Final 1 
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After defining the Profile, Corridor Name, and Design Stage, you are prompted to define 
the Template Drop information as shown below. 

 
Figure 11 Template Drop Information Dialog Box 

The parameters can be defined in the Create Template Drop window, as shown at above, 
or by dialogs floating on the cursor that will step you through the parameters. 

Each parameter is defined below: 

Lock to Start - Toggle this option on to lock the start of the corridor to the start of the 
horizontal alignment. 

Start - Define the Start station for the corridor. 

Lock to End -Toggle this option on to lock the end of the corridor to the end of the horizontal 
alignment. 

End - Define the end station for the Corridor. 

Drop Interval - This parameter is used to define the interval that the template will be 
applied to the corridor. We recommend a Drop Interval of 5 for CTDOT projects. 

Minimum Transition Before Drop / Minimum Transition After Drop - If they are non-zero, 
then a transition drop is created at the beginning/end of the template drop with a length 
greater than or equal to the value entered. The actual length is determined by how far it is 
between the new drop and the drop before/after the new drop. If there isn't enough space 
to meet the minimum, then the previous/next drop is shortened to accommodate the 
transition. If there is no previous/next drop, then no transition drop is created. 

Template - Define the template from the library to be applied to the alignment and profile. 
The … button to the right of the template name is used to browse the template library to 
choose the desired template. 

After defining the Create Template Drop parameters, the template is applied to the 
selected horizontal and vertical alignments to create the corridor. A 3-Dimensional model 
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named Design-3D is automatically created in the active design file and referenced to the 
active model. 

Note: The referenced graphics are not always desirable and can be turned off using the 
MicroStation Reference Attachment tools. 

Different views can be displayed by holding down the right-mouse button in the 
MicroStation view until the pop-up menu appears, and then choose the desired layout. 

 
Figure 12 Setting up the Muli-Model View 

 
Figure 13 Setting up the Muli-Model View Windows 
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In addition to the 3d graphics, 2d graphics are drawn in the active model as described below: 

• 2-Dimensional graphics are drawn in the active model as defined by the features assigned 
to the individual points in the template. The CTDOT feature definitions that are assigned to 
points on the surface of the template, such as the edge of pavement, shoulder, or ditches, 
are the only template features that draw these 2D plan graphics. 

• Graphics representing the length of the corridor model and the template drop range are 
created in the active model. This graphic includes several “handles” at intervals along the 
length of the corridor that can be easily selected to identify the corridor model as shown 
below. 

 
Figure 14 Corridor Handles and Template Ranges 

• The corridor is added to the OpenRoads Model, which can be reviewed in the Project 
Explorer dialog. 

 
Figure 15 OpenRoads Model Check in Project Explorer 
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3.2 Corridor Editing 
Select one of the corridor handles, as shown below, to access a menu of common corridor 
commands. 

 

Figure 16 Corridor Editing Tools 

The commands in the menu are grouped as follows: 
• Properties 
• Corridor Views 
• Reports 
• Corridor Overlay 
• Corridor References 
• Corridor Creation Tools 
• Lock – Deactivate Rule 
• Zoom To 
• Delete  

3.2.1 Corridor Properties 

The corridor parameters can also be edited in the Properties dialog when a corridor 
is selected. 

 

 
Figure 17 Properties dialog 
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3.2.2 Corridor Views 

The Corridor Views icon has two commands, Open Profile Model and Open Cross Section 
Model. The Open Cross Section Model command is used to create a dynamic cross section 
view to review the model by scrolling through cross sections. 

 
Figure 18 Open Profile Model and Open Cross Section Model Tools 

When selected, you are prompted to Open or Select View for the cross-section display. In 
the example below, View 2 was selected to display the dynamic cross sections. 

 

Figure 19 Cross Section View 

This dynamic view is a temporary display of the cross sections. The sections are not written 
to the design file using this command. 

The View Properties contains parameters for adjusting the cross section display, as shown 
at below. 

 
Figure 20 Dynamic Settings 
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Hold down the right mouse button in the cross section view to access the pop-up menu 
shown at right. Five additional commands relevant to cross sections are available. See the 
online help for additional information. 

 
Figure 21 Place Horizontal Temporary Dimension 

3.2.3 Reports 

The Reports icon provides access to the following four reports: 

 
Figure 22 Report Tool 

• Corridor Component Quantities 
• Design Input Report 
• Results Report 
• Milling Report 

The Corridor Component Quantities report is used to generate a quick cost estimate for 
the selected corridor by assigning a unit cost for each component in the corridor 
templates. 
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Figure 23 Corridor Component Quantities 

3.2.4 Corridor Overlay 

The Corridor Overlay Vertical Adjustment command determines the ideal PGL point based 
on the input criteria and the distance from the top of the template to the existing 
ground. See the online help for additional information. 

 
Figure 24 Corridor Overlay Vertical Adjustment  

3.2.5 Corridor References 

The following four Corridor References commands are available: 

 
Figure 25 Corridor References 

Add Corridor Reference - This tool is used to add graphical elements to the corridor 
processing. This must be done when a Feature is targeted in the template definition. This 
enables the software to process only the identified elements which speeds up processing. 
For example, if the template targets a right-of-way line, the right-of-way lines must be 
included as a Corridor Reference for the template to find the lines. 

Remove Corridor Reference - This tool is used to remove graphical elements from the 
corridor processing. 
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Add Clipping Reference - This command is used to remove areas of overlap when working 
with multiple corridors. For example, in a corridor intersected by a crossing roadway, 
clipping is used to remove overlapping features within the intersection. 

Remove Clipping Reference - This tool is used to remove any clipping references defied for 
a corridor. 

3.2.6 Corridor Creation Tools 

The Corridor Creation Tools menu contains commonly used corridor commands. 

 
Figure 26 Corridor Commands Tools 

Corridor Objects - This option is a one-stop shop to view, create, and edit corridor objects. 
Most of the options contained in the Corridor Creation Tools can be accessed from this 
dialog as shown below. 

 
Figure 27 Corridor Objects 
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Create Template Drop - This tool is used to create a new template drop location on the 
corridor. 

Create Transition - A transition is created between templates of different names, as 
templates generally don't instantaneously change from one template to another. This tool 
creates the transition by selecting the two templates drops which are adjacent to it. Once 
the transition location is created, it is up the user to define how the transition is applied. See 
the online help for more information. 

Create Secondary Alignment - Secondary alignments are used to modify the direction of 
cross section processing. By default, at any given station, the cross section is created 
orthogonal to the main alignment. If a secondary alignment exists, then that portion of the 
cross section which lies outside the secondary alignment will be orthogonal to the 
secondary alignment instead of the main alignment. See the online help for more 
information. 

Define Target Aliasing - Target aliasing allows you to target other corridor surfaces or 
features or to set up a prioritized target list for end condition solutions on surfaces, features 
and alignments. See the online help for more information. 

Create Parametric Constraint - Parametric constraints can be used to change one or 
more labeled constraint values of a template while the template is being processed in the 
corridor modeler. See the online help for more information. 

Create End Condition Exception - End Condition Exceptions are used to modify the 
behavior of an end condition solution without requiring the use of additional template 
drops. When an end condition exception is added, it must be edited to change its behavior. 
End condition exceptions come in two classes: 

• Overrides allow you to replace or override the template drop end conditions on the 
left or right of the backbone. When you choose this option, you must edit the override 
to set up the new end condition. When the override exception is edited, the Create 
Template dialog is displayed allowing you to edit the end-condition. 

• End condition Transitions are used where the end condition may change suddenly 
due to changes in the existing surface or other reasons, and you want the transition 
to be smooth over a specified station range rather than a sudden change over a 
short length. 

 
Figure 28 Transitions 



Volume 3.3  - OpenRoads Designer Roadway Modeling 

45 
 

Create Point Control - Point controls are used to override the normal locations of one or 
more points and or components in a cross section. Examples of this include lane widening, 
staying within the right-of-way, or maintaining a slope for a ditch. 

 
Figure 29 Create Point Control 

Create Curve Widening - Curve widening is used to automatically create and apply 
horizontal controls to widen lane and/or edge of pavement lines around curves, moving 
them further away from the centerline at each curve of the controlling alignment. The tool is 
used in conjunction with an ASCII file (*.wid) which contains parameters to definethe 
widening. CTDOT does not provide curve widening tables currently. Use point controls to 
manually assign the station ranges and offsets for curve widening. 

Key Station - This command is used to add stations that are not coincident to the template 
interval to the corridor processing. For example, a key station can be added at a drive or 
culvert location to ensure the template is processed at that station. 

Assign Superelevation to Corridor - Superelevation is covered in another section of this 
training.  

The last four tools on the bar are described below: 

 
Figure 30 Corridor Editing Tools 
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Process Corridor - Select this icon to reprocess the corridor.  

Lock - Deactivate Rule - This command can be used to temporarily deactivate processing 
rules on the corridor. This is useful when making edits so that the corridor does not 
automatically update as the edits are made. Once the edits have been completed, the 
rules can be turned back on, and the corridor reprocessed.  

Zoom To - Select the command to zoom to the full extents of the corridor.  

Delete - Select this command to delete the corridor. 

3.2.7 Processing Order for Point Overrides 

There are several ways in the corridor processing to override the template definition for 
various constraints using Parametric Constraints, Point Controls, and Horizontal Feature 
Constraints. 

This is generally the order in which OpenRoads solves the location of points and 
components at each template drop: 

1. Template is dropped, and points are placed according to the point constraints stored 
in the template. 

2. Parametric constraints are applied as defined in the template, and in the corridor. 

3. Horizontal Feature constraints are applied to move points if the feature is found in the 
specified range. 

4. Point controls are applied to the assigned points, overriding the corresponding 
constraint, and all points that are constrained back to the point-controlled point will 
be recalculated. 

5. Component display rules are solved based on the current position of all points. 

6. End conditions are solved by extending designated segments along the specified 
slope to seek their targets. 
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3.3 Template Drops 

3.3.1 Create Template Drop 

The Create Template Drop tool is used to define what the cross sections of the roadway 
look like for that portion of the road based on user-defined station range. 

You can access this tool from the following: Ribbon: Corridors > Create > New Template 
Drop 

 

Figure 31 Create Template Drop 

The Create Template Drop tool defines what the cross sections of the roadway look like for 
that portion of the road based on user-defined station range. A project may comprise a 
single template drop or multiple template drops. Often, transitions are used between two 
template drops, rather than an abrupt change from one template to another. 

Before selecting the New Template Drop tool make sure the desired Template Library is 
connected, browse to select the needed library if it is not opened and close the Create 
Template Dialog box. 

After selecting the New Template Tool, follow the prompts to select the wanted Corridor. The 
Select Template pop-up will appear, follow the prompts to select the needed roadway 
template. 

 

Figure 32 Selected Template Name 

 
Figure 33 Pick Template 
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Careful consideration should be given for the Drop Interval used for a corridor, although it 
can be changed at any time. It specifies the distance between each processing of the 
template (in master units). Generally, this value is equal to or less than (but still a multiple) 
of the desired interval for the final cross sections, since cross section stations should be 
coincident with processing stations. It is not necessary to set the interval so small that it 
encompasses all desired cross section stations, as stations with particular project interest 
can be added to the model with the use of the Key Station tool. If the model is to be used in 
construction, the smaller the interval, the more detailed the model, but will require more 
processing time. 

Minimum Transition Before Drop and Minimum Transition After Drop are inputs in the Create 
Template Drop tool. If they are non-zero, then a transition drop is created at the 
beginning/end of the template drop with a length greater than or equal to the value 
entered. The actual length is determined by how far it is between the new drop and the 
drop before/after the new drop. If there isn't enough space to meet the minimum, then the 
previous/next drop is shortened to accommodate the transition. If there is no previous/next 
drop, then no transition drop is created. 

After completing the prompts, the corridor is automatically processed and can be viewed 
in both 2D and 3D views. The corridor can be rendered, if desired. 

3.3.2 Edit the Template Range 

When the template range graphic is selected, the range can be edited by accessing rule 
that defines the template drop location. 

        

Figure 34 Edit the Template Range 

The template range can be edited by selecting the station and editing the value of by 
selecting the arrow icon to dynamically mode the start (or end) of the template range. 

3.3.3 Template Drop Context Menu 

Select the template range graphic and let the cursor rest on the element to access the 
pop-up menu shown below. 

   

Figure 35 Template Drop Context Menu 
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The following commands are available: 
• Properties 
• Edit Template Drop 
• Copy Template Drop 
• Synchronize with Library 
• Delete 

Properties 
Pop-up display includes access to modify the Interval, Template Name, Description and 
Station range. 

   

Figure 36 Properties 
Edit Template Drop 
When a template is applied to generate the corridor, the template definition is copied into 
the design file. The template definition can be edited in the design file, independent of the 
definition that is stored in the template library .itl file. Use this command to edit the 
template definition as applied to the corridor, not the template as defined in the library. 

Note: When the command is selected, the Editing Roadway Designer Template 
Drop dialog is opened. This tool is useful when you wish to make local changes to 
the corridor without editing the template library definition. For consistency, CTDOT 
recommends making all changes to the template library and then using 
the Synchronize with Library command to apply the changes made in the library to 
the corridor model. 

Copy Template Drop 
This tool is used to copy a template drop to a new station range along the alignment by 
defining the beginning and ending station for the new template drop range. 

Synchronize with Library 
Select this tool to synchronize the local copy of the template that has been applied to the 
corridor with any changes that have been made to the template in the library .itl file. 

Note: Synchronizing the template with the library will override and changes that 
may have been made to the corridor’s template definition by using the Edit 
Template Drop command. For consistency, CTDOT recommends making changes to 
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the template library and using the Synchronize with Library command to apply 
template changes to the corridor. 

Delete 
Deletes the template drop. 

3.3.4 Create Corridor and Apply Template Drop 

Corridors represents one or more Templates being dropped along 3D Baseline to create a 
3D Model. This module will instruct to Creating Corridor and Applying Template Drops. 

If not already open, Open the previously created project Corridor Model file,  

HW_CB_1234_1234_RoadwayModel.dgn and Load the Template Library for the project.  

Activate the OpenRoads Modeling workflow from the pick list next to Quick access toolbar 
in the upper left corner if it is not already active. The ribbon menu will reflect 
the OpenRoads Modeling tools. 

1. From the ribbon, select Corridors Tab. 
2. From the Create Group Select New Corridor. 

 
Figure 37 New Corridor 

3. Create Corridor dialog will open. 
a. Select Feature Definition > Final (user can choose desired featured definition from the 

list) 
  

 
Figure 38 Corridor Feature Definition 
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b. Follow the prompts: 
c. Locate Corridor Baseline, select the Horizontal Alignment (The program will 

automatically generate or pick up the name of the selected alignment i.e. RTE1)  

 
Figure 39 Locate Corridor Baseline 

  
d. Locate Profile-Reset For Active Profile, right-click to accept the Active profile 

associated with the Horizontal Alignment. 

 
Figure 40 Locate Profile-Reset For Active Profile 

e. Corridor Name> Feature: Name, left-click to accept the Active name RTE1 or 
rename as desired then accept to create Corridor. 
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Figure 41 Corridor Feature: Name 

f. Closed shape called Corridor Object is drawn along the alignment in 2D view. 
g. Create Template Drop dialog will appear (skip to next Step) 

• If the Create Template Drop do not appear, it denotes that user have exited 
from the command and the plan will be like below. 

 
Figure 42 No Template Drop Created 

• Corridor is created but there is no template applied to it. In order to apply the 
template(s) to the newly created corridor at a defined interval along the 
alignment, From Corridors Tab Ribbon then From the Create Group 
Select New Template Drop. 
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Figure 43 New Template Drop 

• On Locate Corridor prompt, select the newly created corridor then follow the 
next steps below. 

 

 
Figure 44 Locate Corridor 

4. Follow prompts after Create Template Drop dialog opens.  
a. Click the browse button next to Template label to open Template library 

or click the Alt and Down to open Template library. 

 
Figure 45 Select Template 

b. This opens the Pick Template dialog. Select the desired template prepared for the 
project and review. For this example, choose HWY Typical Sections > 
2ln_HMA_BCPC and click OK.  
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Figure 46 Pick Template 

• Template - HWY Typical Sections > 2ln_HMA_BCPC, left-click to accept 
the 2ln_HMA_BCPC. 

• Parameters: Start - 10+00 (Click Alt to Lock to Start or type specific Station), left-
click to accept . 

• Parameters: End - 27+36.69 (Click Alt to Lock to End or type specific Station), left-
click to accept. 

• Parameters: Drop Interval -  10 (as desired), left-click to accept. 

• right-click to exit command. New corridor with template drops associated with it 
is created. 

 
Figure 47 
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Figure 48 2D and 3D Views 

 
5. Additional corridors can be created for the side roads following the steps described above. 
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3.3.5 Display Dynamic Cross Sections 

Once Corridor is created, the cross sections can be created directly from the 3D Model and 
can be viewed with Dynamic Cross Sections tool. The interval of cross sections is based on 
the template drop interval. Dynamic Cross Sections are always created perpendicular to 
the alignment of the Corridor used. 

1. Activate the OpenRoads Modeling workflow from the pick list next to Quick access 
toolbar in the upper left corner if it is not already active.  From the ribbon, 
select Corridors Tab. 

From the Review Group Select Dynamic Sections > Open Cross Section View. 

 
Figure 49 Corridors Tab 

2. Follow the prompts. 

a. Locate Corridor or Alignment: Select RTE1 Corridor. 

b. Select or Open view: Open View 4 by selecting the view 4 button from the bottom of 
the screen. 

c. Click inside View 4 window, a cross section will appear. 

 
Figure 50 Cross Section Viewer 
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d. In the upper left portion of window, select the drop-down arrow next to View 
Properties. Here the view properties of the Cross Section view can be changed as 
needed. 

e. User can press single left or right arrow to move to the previous or next cross section, 
respectively. 

 
Figure 51 Cross Section Viewer Set View Properties 

3.3.6 Modify Corridor  

 
Figure 52 Corridor Handles and Objects 
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3.3.7 Copy and Replace Template Drop 

This module instructs users how to copy and edit or replace existing Template in design file. 

1. Load Corridor (Roadway Model) file and Load the Template Library for the project.  

2. Activate the OpenRoads Modeling workflow from the pick list next to Quick access 
toolbar in the upper left corner if it is not already active. The ribbon menu will reflect 
the OpenRoads Modeling tools. 

3. The Corridor file contains corridor RTE1 with template drop 2ln_HMA_BCPC from Sta. 
10+00 to Sta. 16+00. When the Template Drop Range of Template Drop graphic is 
selected, range can be edited as needed. The range can also be edited form the 
properties window by changing Start and End Station. 

4. Copy Template Drop. Select 2ln_HMA_BCPC Template Drop and let the cursor rest on 
the element to access the context sensitive pop-up menu. Select Copy Template Drop. 

 
Figure 53 Copy and Replace Template Drop 

Follow the prompts.mLocate Corridor: Select RTE1 Corridor. 

• Start Station: 13+00, left-click to accept. 
• End Station: 16+00 (Click Alt to Lock to End or type specific Station), left-click to 

accept. 
• Corridor processes with new Template Drop. 

5. Change or swap newly copied Template Drop. Replace template 2ln_HMA_BCPC with 
template 2ln_PS5_Curb_SW_Both. 

a. Select 2ln_HMA_BCPC Template Drop and let the cursor rest on the element to 
access the context sensitive pop-up menu. Select Properties. 
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Figure 54 Properites 

b. Click the Browse button in the right side of the Template Name label. This opens 
the Pick Template dialog. 

 
Figure 55 Browse to Select Template 

c. Select the desired template prepared for the project and review. For this example, 
choose 2ln_PS5_Curb_SW_Both (roadway with curb and sidewalk at both sides) 
and Click OK. 

 
Figure 56 Select Template 

d. The Corridor processes with new Template Drop. Notice the change in 3D view. 
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Figure 57 3D Model 
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3.3.8 Add Corridor Objects 

Corridor Objects dialog is a summary of all corridor modeling objects and used to manage 
data. Clicking on the various categories located on the left side of the dialog displays the 
appropriate data in the center section. These data may be edited as needed, either from 
center section or from right side of the dialog. 

1. Select Corridor Handles of RTE1 Corridor and let the cursor rest on the element to 
access the context sensitive pop-up menu. Select Corridor Creation Tools > Corridor 
Objects. 

 
Figure 58 Corridor Objects Tools 

2. Corridor Objects Window opens. In this window user can define or edit 
various categories. Select Template Drop, notice two Template Drop is applied to 
the RTE1 Corridor. Here Template Drop can be replaced or the station can be edited 
easily. 

 
Figure 59 Corridor Objects Dialog Box 
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3.3.9 Create Parametric Constraint 

Create Parametric Constraints tool allow user to override template point constraint values. 
The Create Parametric Constraints tool gives users the ability to vary pavement thickness, 
curb height, ditch widths, slopes, etc between any station range along a corridor. This 
module will show to override the subgrade depth of roadway structure from 1 foot to 6 
inches using Create Parametric Constraints tool 

a. Modify subgrade depth in a Template Drop named 2ln_HMA_BCPC 
a. The constraint labels are created and assigned to template point(s). Looking 

into 2ln_HMA_BCPC Template Drop, Bottom of the subgrade layer has Constraint 
Label named as Subgrade_Depth under Vertical Type Constraint. Here points 
BOC_sg, EOR_sg, SHDR_sg and CL_sg are all assigned Subgrade_Depth label. 

  

 
Figure 60 Point Properties Dialog Box 
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b. Select Corridor Handles of RTE1 Corridor and let the cursor rest on the element to 
access the context sensitive pop-up menu. Select Corridor Creation Tools > Create 
Parametric Constraint. 

 
Figure 61 Create Parametric Constraint 

c. Create Parametric Constraint window will appear. Follow the prompts. 

 
Figure 62 Create Parametric Constraint Parameters 

• Start Station: 10+00, (Click Alt to Lock to Start or type specific Station), left-
click to accept. 

• End Station: 13+00 (Click Alt to Lock to End or type specific Station), left-click to 
accept. 

• Constraint Label: In the Create Parametric Constraints dialog, press the down 
arrow to display the list of available Constraint Labels that you can adjust and 
select Subgrade_Depth. Default value for Subgrade_Depth is currently set to -
1.000, left-click to accept 

• Start Value: -0.500, , left-click to accept. 

• End Value: -0.500, , left-click to accept. 

• The Corridor processes with new value. Notice the change in 3D view. 
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Figure 63 Original Depth 1 foot 

 
Figure 64 Updated Depth 6 inches 

d. Review the dynamic cross section there are green boxes that appear along the 
bottom of the section. The green boxes indicate the locations where 
the Subgrade_Depth was adjusted. 

  

 
Figure 65 Cross Section Viewer Updated Depth 

e. Review the Parametric Constraint with Corridor Objects tool. 

 
Figure 66 Parametric Constraint Dialog Box 

If at any time user need to modify the values user can do it here. 
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3.3.10 Create Point Control 

Create Point Control tool allow user to assign Point Control to Corridor which forces the 
cross-section template point to follow other information than what is set in the template. 
Point controls override the default location of template points. In this module user will 
create point controls for the right edge of road point: EOR_rt in 2ln_HMA_BCPC Template 
drop. Using Create Point Control tool shoulder will be tapered from 1 foot to 4 feet. 

1. The Corridor file contains corridor RTE1 with template drop 2ln_HMA_BCPC from Sta 
11+00 to Sta. 15+00. 

2. New EOR_rt geometric element is drawn from Sta. 11+00 to Sta. 11+50 making shoulder 
width 1 foot and 4 feet, respectively. 

 
Figure 67 2D View Liner Feature Names 

 
Figure 68 Cross Section Point Feature Names 
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Figure 69 3D View 

3. Create point control for point EOR_rt to follow the New EOR_rt geometric element 
1. Select Corridor Handles of RTE1 Corridor and let the cursor rest on the element to 

access the context sensitive pop-up menu. Select Corridor Creation Tools > Create 
Point Control. 

  

 
Figure 70 Create Point Control 
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b. Create Point Control window will appear. Follow the prompts (after each prompt, left-
click to accept values and move to next prompt): 

 
Figure 71 Create Point Control 

• Start Station: 11+00 
• End Station: 11+50 
•  Control Description: EOR_rt Control (name as needed) 
•  Locate Point: EOR_rt (Select EOR_rt element in View 1 or from cross section 

view) 
• Mode: Horizontal 
• Control Type: Linear Geometry 
• Locate Plan or Profile Element: Select New EOR_rt geometric element 

(dashed blue line) 
• Use as Secondary Alignment: Yes 
• Priority: 1 
• Start Offset: 0.000 
• Stop Offset: 0.000 
• The Corridor processes and updates as per the point control. 



Volume 3.3  - OpenRoads Designer Roadway Modeling 

68 
 

c. Review point control in plan view, cross section view and 3D view. 
• In plan view notice that EOR_rt linear feature now follows the New EOR_rt 

geometric element (blue cyan line). 

 
Figure 72 2D View Right Edge of Road 

• In cross section view notice there is magenta box at EOR_rt point. This indicates 
that there is a point control to this point. 

 
Figure 73 Cross Section View Point names 

• Review 3D view, Right Edge of Road is tapered. 

 
Figure 74 3D View 
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d. Review the Point Control with the Corridor Objects tool. 

 
Figure 75 Corridor Objects Dialog Box 
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3.4 Applying Superelevation 

The Superelevation tools calculate the amount of cross slope or “bank” that should be 
provided on a horizontal curve to counterbalance, in combination with side friction, the 
centrifugal force of a vehicle traversing the curve. These tools also compute the superelevation 
transition length which is the distance required to transition the roadway from a normal crown 
section to full superelevation. The superelevation transition length is the sum of the tangent 
runout (TR) and superelevation runoff (L) distances.  

Pavement slopes are initially defined in the template.Superelevation is created and applied 
after the corridor is defined and the template drops have been assigned. This section will detail 
how superelevation is computed with OpenRoads as well as how to accurately model the 
shoulder break for the high side of Superelevation. 

Superelevation calculations should be applied as defined in Chapter 8 of the Connecticut 
Department of Transportation Highway Design Manual.    

The Superelevation tools are located in the Corridors tab, as shown below. 

 
Figure 76 Superelevation Tools 

The following tools are available: 
• Create Superelevation Sections 
• Create Superelevation Lanes 
• Create Superelevation Lanes by Road Template 
• Calculate Superelevation 
• Edit Superelevation rule File 
• Import Superelevation 
• Assign to Corridor 
• Insert Station Cross-Slope 
• Superelevation Editor 
• Superelevation Report 
• Open Superelevation View 

3.4.1 Create Superelevation Sections 

Superelevation Sections for each alignment are normally placed in a separate design file 
with the Centerlines referenced in. The Create Superelevation tool creates a superelevation 
section for the specified station range on the centerline to demarcate a stretch of roadway 
for superelevation calculations. 

https://portal.ct.gov/-/media/DOT/documents/dpublications/highway/coverpdf.pdf?la=en&hash=D6D6BF8ED48D268F897192281CDC975C
https://portal.ct.gov/-/media/DOT/documents/dpublications/highway/coverpdf.pdf?la=en&hash=D6D6BF8ED48D268F897192281CDC975C
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In this tool the Civil horizontal geometry element is identified, and station limits of the 
superelevation are defined. Station limits are useful if the horizontal alignment is 
substantially longer than the project limits. The section is drawn using the selected Feature 
Definition.   

 
Figure 77 Create Superelevation Sections 

The CTDOT XML-formatted rules file containing the superelevation standards/parameters is 
located in the following location: 

...\State of Connecticut\DOT CTDOT_DDE - CONNECT\CT_Configuration\Organization-
Civil\_CT_Civil Standards - Imperial\Superelevation  

3.4.2 Assign Superelevation to Corridor 

After the superelevation values have been computed, the next step in the process is to 
assign the superelevation sections to a corridor. 

Before assigning the superelevation to the corridor, it is necessary to do the following: 

• Attach the reference file containing the superelevation sections to the corridor 
model. 

• Verify that the template being used in the corridor has the Superelevation Flag set for 
all pavement points used as candidate superelevation points. This flag is used for 
automatically setting the point controls. 
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Figure 78 Superelevation Flag set for on template Points 

The Assign Superelevation to Corridor tool applies the cross slopes defined on 
superelevation lanes to the corridor so the superelevated pavement is reflected in the 
corridor model. 

 
Figure 79 Assign Superelevation to Corridor 

3.4.3 Adding Additional Lanes 

Additional lanes can be added to an existing superelevation section by use of the Create 
Superelevation Lanes command. 

 
Figure 80 Create Superelevation Lanes 
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3.5 Placing Linear Templates 
Templates represent typical cross-sectional geometry. Templates consist of points and 
components. Templates can be placed along any 3D line string using the Apply Linear 
Template tool. For example, a slope treatment template can be placed along a road corridor 
hinge point. A Template consisting of pavement lane, curb and side treatment can be placed 
along a pavement sawcut line. Applying a Linear Template is quick and easy, but it has its 
limitations during adjustments. Applying and editing Linear Template is less powerful 
compared to Placing and editing Corridors.  

LINEAR TEMPLATES 
Linear Templates can be placed along a civil geometry element without a defined corridor. The 
"Apply Linear Template" tool will apply a template to a selected civil geometry element that has 
a profile associated with it. Most templates can be treated as linear templates like shoulder, 
curb, etc. and don’t need a defined corridor to be placed. Once you have the profiled linear 
element (3D geometry), templates can be placed. After placing the template, a corridor for the 
linear template will be automatically generated. This corridor and linear template can be edited 
as needed. 

The Apply Linear Template tool can be found on the OpenRoads Modeling workflow Ribbon: 

Model Detailing Tab > 3D Tools Group > Apply Linear Template 

 
Figure 81 Apply Linear Template 

Apply Linear Template will activate the Pick Template dialog then inserts the chosen template 
into the drawing relative to the selected linear element. 

The Connecticut DOT has provided range of Linear Templates within its workspace. See figure 
below. 
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Figure 82 Available Linear Templates 

3.5.1 Apply Linear Templates 

This module instructs users how to place a linear template in a design file for a project. When 
placing linear templates, a corridor is not needed, linear templates can be applied to 3D 
elements. 

1. Load Corridor (Roadway Model) file and Load the Template Library for the project.  

2. Activate the OpenRoads Modeling workflow from the pick list next to Quick access toolbar 
in the upper left corner if it is not already active. The ribbon menu will reflect 
the OpenRoads Modeling tools. 

3. The Corridor file contains corridor RTE1 with template drop 2Ln_HMA.  The template drop 
applied only has two lane roadway surfaces without slope treatment. 

 
Figure 83 Apply Linear Templates 
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Figure 84 Template Library 

4. Slope Treatment Linear Template can be applied to the edge of the road (EOR_lt and 
EOR_rt) as it is a 3D element with active profile. 

5. Constructions option can be turned ON or OFF in the View Attributes window. 

6. From Model Detailing tab within the 3D Tools Group select:  Apply Linear Template. 

  
Figure 85 Apply Linear Template Tool 

7. Apply Linear Template dialog will open. Fill as below and then follow the prompts. 
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Figure 86 Browse to Select Template 

a. Locate Element To Apply Template, click on the Left Edge of Roadway (EOR_lt) 

 
Figure 87 Locate Element To Apply Template 
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b. Click the browse button next to Template label to open Template library 
or click the Alt and Down to open Template library. 

 
Figure 88 Selected Template 

c. This opens the Pick Template dialog. Select the desired template prepared for the 
project and review. For this example, choose Project Library>Linear Templates>BCLC-
w-cut-fill and click OK.  

 
Figure 89 Pick Template 
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• Template - Project Library > Linear Template s> BCLC-w-cut-fill, left-click to 
accept the BCLC-w-cut-fill 

• Start - 0+00 (Click Alt to Lock to Start or type specific Station), left-click to accept. 
(This is same as 11+00 of RTE1 Baseline) 

• End - 3+00 (Click Alt to Lock to End or type specific Station), left-click to accept. 
(This is same as 14+00 of RTE1 Baseline) 

NOTE: Station entered here is the station related to EOR not the Base Line 
Station. 

• Select Side-Reflect Option Mirror-<Alt> Down To Select, hover mouse right side 
of EOR_lt or as needed, left-click to accept. 

 
Figure 90 Select Side-Reflect Option Mirror-<Alt> Down To Select 

• Exterior Corner Sweep Angle - 05° 00’00” (Default value, change as needed), left-
click to accept. 

• Description -  BCLC_Grading_LT,  left-click to accept. 

• Right-click to exit command. Curb and Slope Treatment is generated at the Left 
Edge or Road. Corridor for the applied Linear template is automatically generated 
by the software. 

 
Figure 91 2D and 3D View of Liner Template 
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d. The newly applied Linear Template can be reviewed from Explorer Window > 
OpenRoads Model. 

 
Figure 92 Explorer Window 

8. Follow the same steps and Apply Linear Template at the Right Edge of Road. 

3.5.2 Edit Linear Templates 

Linear Templates can be edited as normal Templates, but it has its limitations. All the Corridor 
Parameter that can be edited for the Linear Template is less than that of Corridor. This 
module instructs users how to edit or replace an existing Linear Template in the design file. 
When placing a linear template, a corridor is not needed, it can be applied to a 3D element. 

1. We are using a Corridor (Roadway Model) file that is used in above module. 

2. An applied Linear Template cannot be copied, so it needs to be reapplied as needed. To 
show contrast, in the current file the  

• Linear Templates>BCLC-w-cut-fill (curb with slope treatment is applied 
at RTE1 Sta. 10+00 to Sta. 14+00)  

• Linear Templates>BCLC-w base (only curb is applied at RTE1 Sta. 14+00 to Sta. 
27+00) are applied at the left side of the Edge of Road. 
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When the template range of the Linear Template graphic is selected, the range can 
be edited as needed. The range can also be edited from the properties window by 
changing Start and End Station. 

 
Figure 93 Edit Linear Templates 
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3. Change or swap the type of Linear Template,  the BCLC-w-cut-fill to the cut-
fill template. 

a. Select: BCLC-w-cut-fill template and let the cursor rest on the element to access 
the context sensitive pop-up menu. Select Properties. 

 
Figure 94 Properties 

 

 
Figure 95 Browse to select Template 

a. Click the Browse button in the right side of the Template Name label. This opens 
the Pick Template dialog. 
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b. Select the desired template prepared for the project and review. For this example, 
choose Linear Templates>cut-fill (grading only no curb) and Click OK. 

 
Figure 96 Select Tempale 

c. The linear template processes with the new template. Notice the change in 3D view. 

 
Figure 97 3D View 
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6. Edit linear template elements or parameters. 
a. Select: cut-fill template and let the cursor rest on the element to access the context 

sensitive pop-up menu. Select Edit Template Drop. 

 
Figure 98 Edit Template Drop 

b. Editing Roadway Designer Template Drop Window appears along with the existing 
template used at the template window i.e. Linear Template>cut-fill 

 
Figure 99 Editing Roadway Designer Template Drop Window 
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c. The Template can be edited in various ways and reviewed. For this example, Slope 
and Horizontal Distance of Snow shelf can be changed. 

d. Double click on SNOW_c point. 

e. In the Point Properties dialog, change Slope Value as desired under Constraint 1 and 
change Horizontal Value as desired under Constraint 2 and click Apply, and Close. 

 
Figure 100 Point Properties 

f. Click OK to close the Editing Roadway Designer Template Drop dialog.  The linear 
template processes with the new value.  Notice the change in slope and width of the 
snow shelf. 

g. Other points or parameters of the Linear Template can be edited. 
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7. Edit the Corridor of a Linear Template.  Select the Corridor Handles of the cut-fill template 
and let the cursor rest on the element to access the context sensitive pop-up menu. Select 
the Corridor Creation Tools > Corridor Objects. 

 
Figure 101 Corridor Handles 

a. Corridor Objects Window will open. In this window the user can define four parameters 
as Parametric Constraint, Point Control, External Reference, and Clipping Reference. 

 
Figure 102 Corridor Objects Window 
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b. Corridor edits for Linear Templates is less powerful compared to Placing and 
editing Corridors (shown below). 

 
Figure 103 Corridor Objects External Reference 
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3.6 Placing Surface Templates 

Terrain Models either existing or proposed do not have depth or material associated with them. 
A Surface Template is made up of various components and each component can be of various 
depth and is applied to a terrain model. Components for a surface template are closed shapes 
such as asphalt layer, aggregate layer, grass layer etc. The "Apply Surface Template" tool will 
apply a selected surface template from the template library to a terrain.   

The Apply Surface Template tool can be found on the OpenRoads Modeling workflow Ribbon: 

Model Detailing Tab > 3D Tools Group > Apply Surface Template 

 
Figure 104 Apply Surface Template 

Apply Surface Template will activate Pick Template dialog, then insert the chosen surface 
template into the drawing relative to a terrain model. 

The Connecticut DOT has provided range of Surface Templates within its workspace. See figure 
below. 

 
Figure 105 CTDOT Surface Templates 
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3.6.1  Apply Surface Templates 

Surface Templates is a closed shaped component of a Template. A Surface Templates can 
be applied to a terrain using the Apply Surface Template tool. Surface Templates are used 
to apply material thickness to the terrain surface. A Surface Template can be of a single 
component or composed of different components. 

This module instructs users how to place a surface template in a design file for a project. 
For placing surface template, a terrain is needed. 

1. Open the Corridor (Roadway Model) file and the Template Library for the project.  

2. Activate the OpenRoads Modeling workflow from the pick list next to Quick access 
toolbar in the upper left corner if it is not already active. The ribbon menu will reflect 
the OpenRoads Modeling tools. 

3. The Corridor file contains Roadway corridor RTE1 with a roadway template drop. 
Around Sta. 15+85, a driveway is designed. We need to create a Terrain and apply 
a Surface Template to the Driveway in order to make it complete. 

NOTE: Driveway Civil Cells can be placed and edited as needed at this location 

 
Figure 106 2D and 3D View 
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4. Create a Terrain out of the driveway components. Make sure that all the Driveway 
components have active profiles. 
a. From the Terrain Tab Ribbon and within the Create Group, select From Elements. 

 
Figure 107 Create Terrain From Elements 

b. The Create Terrain dialog will open and then follow the prompts. 
c. Set the following on the dialog box: 

• Feature Definition: Design Top (User can change as required) 
• Name: P_DRV (or as required) 

 
Figure 108 Create Terrain Dialog 

d. Follow the prompts. 

 
Figure 109 From Element graphical Features 
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• Locate Element to Add: Select all the sides of the Driveway (Front and sides of 
Driveway). 

• Locate Next Element to Add: Right-click or reset. 

• Feature Type: Boundary 

• Edge Method: None 

• Left-click to complete 

e. The Add/Remove Terrain Model Features dialog will open. Follow prompts.  Right-
click to rest if there are no features to add or remove. 

 
Figure 110 Parameters 

• Locate Element to Add: Select Driveway Shelf 

• Locate Next Element to Add: Right-click or reset 

• Feature Type: Break Line 

• Locate Element to Add: Right-click or reset 

• Right-click again to complete. 

The P_DRV Terrain is created as shown in 3D view. 

 
Figure 111 3D View 
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6. Apply the driveway surface template to P_DRV terrain 
a. From the Model Detailing Tab Ribbon and within the 3D Tools Group select:  Surface 

Templates > Apply Surface Template. 

 
Figure 112 Apply Surface Template 

b. The Apply Surface Template dialog will open, follow the prompts. 

 
Figure 113 Browse to select Surface Template 

c. Set the following on the dialog box: 
Feature Definition: Enable Linear Features 

Name: P_DRV Main (or as required) 

d. Follow the prompts. 
Locate a Terrain Model: Select P_DRV terrain (It is easier to select in 3D view) 

Apply External Clip Boundary: No 

Select Template: click the browse button next to Template label 

The Pick Template dialog box will open, select HWY Surface Templates\Bituminous 
Residential Driveway 

 
Figure 114 Select Surface Template 
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Click OK to close Pick Template dialog. 

Left-click to complete selection. 

Data Point to accept selection: Left-click to complete 

 
Figure 115 P_DRV Main surface template is created as shown in 3D view 

7. Designers can create separate Terrains and apply Surface Templates to Driveway 
Shelf and Driveway Main separately. This is up to the Designers. 

  

  

3.6.2 Edit Surface Templates 

Surface Templates can be swapped or edited as per the project requirement. This module 
instructs users how to edit the Surface Template applied in a design file for a project. 

1. Open the Corridor (Roadway Model) file and the Template Library for the project. In 
this file a Commercial Driveway Civil Cell is placed, and we will be editing the Surface 
Template applied to the Driveway. The Driveway consists of two separate Terrains 
(Driveway Shelf and Driveway Main) and the Bituminous Commercial 
Driveway Template is applied to both Terrains. 

2. Click and select a Driveway Main Surface Template (1-P_DRV Main Surface 
Template) in the 3D View. 
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Figure 116 select Surface Template 

a. Open the Properties dialog and expand the Mesh Template group.  The current 
template is HWY Surface Templates> Bituminous Commercial Driveway. 

b. Click the Browse button at right side of the Template Name label. This opens the Pick 
Template dialog. 

 
Figure 117 Browse to Select Surface Template 

 

Alternatively, Select Driveway Main Surface Template (1-P_DRV Main Surface 
Template) in the 3D View and let the cursor rest on the surface to access the context 
sensitive pop-up menu. 
Select Properties. Quick Properties opens, Click  Browse button at right side of 
the Template Name label. This opens the Pick Template dialog. 

    
Figure 118 Properties                                      Figure 119 Browse to Select 

 
c. Select the desired template prepared for the project and review. For this example, 

choose HWY Surface Templates> HMA_Pavement_Structure, Click OK. 
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Figure 120 Select Template 

The surface template processes with the new Template. Notice the change in the 3D 
view. The surface updated from 2 layers to 3 layers of pavement. 

 
Figure 121 
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3. The User can edit the pavement thickness.  Click and rest cursor (hover) over the Driveway 
Main Surface Template (1-P_DRV Main Surface Template) in the 3D View.  From 
the Context Tool Bar, select Edit An Applied Surface Template.  

 
Figure 122 Select Edit on an Applied Template 

a. In the Editing Roadway Designer Template Drop dialog, the pavement thickness can be 
edited.  For this example, EOR_sg_lt and EOR_sg_rt points depth will be changed from 1’ 
to 1.33’.  Double click on EOR_sg_lt point. 

 
Figure 123 Edite Template Drop 
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b. In the Point Properties dialog, change Vertical Value from -1 to -1.333 under Constraint 
2 and click Apply then click Close. 

 

Figure 124 Point Properties 

c. Double click on EOR_sg_rt point.  In the Point Properties dialog, change Vertical Value 
from -1 to -1.333 under Constraint 2 and click Apply then click Close. 

d. Click OK to close the Editing Roadway Designer Template Drop dialog.  The Depth of the 
bottom layer of the surface template is updated to the new value. You can see the 
change in the 3D view. 
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