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Course Overview 
This module will instruct users on how to create and edit roadway templates & Corridors. 

Skills Taught  
Learn how to: 

• copy standard roadway templates into a project 
• create and edit roadway templates 

 

Introduction 
Templates are made up of components which in turn are defined by points. One or more 
components combine to create a template. Components can be closed shapes such as an 
asphalt layer, or they can be open shapes such as cut and fill slopes. Examples of components 
include curbing, sidewalks, asphalt layers, aggregate layers, median barriers, or the side slopes to 
be used when in cut and fill areas. 

Templates represent cross sectional geometry. A 3D model is created by extruding the template 
along a 3D geometric path. As the template is extruded the template points connect 
longitudinally to create 3D surfaces and meshes.  Templates can be used along a road or rail 
centerline and profile grade line using Corridor tools to model a roadway but they can also be 
applied along any 3D geometry using the Apply Linear Template tool.  For example, a curb 
template can be applied around a traffic island.  Templates are stored in a Template Library File, 
which has the file extension .itl. 

The Create Template command generates the transverse geometry that is the central to roadway 
design. A template is comprised of a series of points and components that represent breakline 
features that are later processed using the Roadway Designer command. Roadway features that 
have been processed are saved to the design surface. Templates are stored in a template library 
(*.itl). In simple terms, the template is a “smart” typical section that you “push” along an 
alignment to create the proposed 3D model.  Template tools can be accessed by 
selecting Corridors > Template > Create Template  

 
Figure 1 Example of a template for a 2-Lane undivided highway 
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Exercise 1 Base Model Creation 
This section instructs users how to create a corridor base model design file for a project. Base 
model files will reside within the project folder structure the ...\Highways\Base_Models folder. 
Depending on the complexity of the project one or more base model files can be created.  
References files such as alignments, survey and terrain files are attached without nesting. 

1.1 Startup 
Before attempting to open or create DGN files users should make sure the following is in place: 

1. CTDOT users should have the CTDOT CONNECT DDE synced through SharePoint with the 
COMPASS Project Synced along with the CAD Configuration. 

2. Consultants should have CTDOT DDE properly installed or be syncing to the CTDOT DDE 
SharePoint/COMPASS system. 

3. Make note of the Coordinate System you will be working in. If you have existing survey data, 
you will need to find out what system is being used (NAD 83/NAVD 88 or NAD 27/NAVD 29).  

4. Log on to the CONNECTION Client. Bentley Connect licensing requires users to log into their 
Bentley account to secure a software license. CTDOT users should log in using your CTDOT 
email address and Bentley password.If you do not see the dialog box, select the ˄ icon on 
the bottom Windows Screen. Click on the Connection Client Icon and select Open. 

     
Figure 2 CONNECTION Client System tray 
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5. Launch the Application. 
• CTDOT employees 

On your desktop double click on the CAD Accounting icon. 
• Consultants 

Start the software via an appropriate CTDOT DDE icon 
6. On the CT DOT Accounting Menu there will be select Compass OpenRoads CE 

In the Run Program field select the needed program, the Available Account (funding 
source) and Resource Type. Click on the Start button to load the program. 

 
Figure 3 CAD Accounting dialog box   
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7. After launching the program, a Welcome Screen for OpenRoads Designer will appear.   

8. Select Custom Configuration, using the small drop-down arrows select the 
Workspace CT_Workspace, the needed WorkSet and Role. 

Note: For CTDOT Synced Projects - If you do not see the Project Number listed, please 
request a Compass/CAD Setup using this link  New CAD Project Request 

 
Figure 4 

https://ctdotcompass.atlassian.net/servicedesk/customer/portal/8/group/24/create/100
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1.2 Creating a New File 

1. Select the New File icon. Create a DGN file from the civil 2D seed and save it to the 
Base_Models folder. Use the file-naming conventions as described in Volume 16. 

Example: HW_1234_1234_CorridorRoute123.dgn 

2. On the New dialog box click the Browse button to select to select the proper seed file. 
…CT_Configuration\Organization\Seed\Road 

If the survey was done in an old Datum, use the corresponding 2D Seed File in this 
folder: …CT_Configuration\Organization\Seed\GCS\ 

 
Figure 5 New File 

Warning: Do not copy DGN files created with V8i SELECTseries or InRoads SS2, SS3, SS4, 
or SS10 to the new CTDOT CONNECT Project/WorkSet folders.  
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3. After the DGN file is created open File Explorer and browse to the file, right click hold and 
select View online. 

  
Figure 6 File Explorer View online tool 

4. The Projects SharePoint site will open, sort by Date, click on the three dots, select More > 
Check Out.  

Note: When you are done working on the DGN file, exit the program and go back to 
the SharePoint Site and Check In the file. 

 
Figure 7 SharePoint Check out 
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Exercise 2 Utilizing the CTDOT Template Library 

2.1 Setting up the Project Roadway Templates  
Templates are used to define the typical section for each alignment. Multiple templates can be 
used to define different typical section designs, or the template geometry can be modified 
using a variety of corridor editing tools. 

CTDOT provides a sample template library in the following folder: 
...CT_Configuration\Organization-BIM\_CT_Civil Standards\Template 
Library\CV_ORDTypicals.itl 

A blank ITL file can be found by default in the highway design folder  
…Highways/Eng_Data/Project_Typicals.itl. 

Required individual templates will be copied over from 
CV_ORDTypicals.itl to Project_Typicals.itl using the Template Library Organizer. 

Please note: Any other disciplines modeling a corridor can copy a blank ITL 
from …CT_Configuration\Organization-BIM\_CT_Civil Standards\Template 
Library\Project_Typicals.itl and paste the file into the discipline-specific folder for 
engineering data: 

Discipline project location of ITL: 
• Bridge/Eng_Data/ 
• Envir/Eng_Data/ 
• F_Civil/Eng_Data/ 
• Geotech/Eng_Data/ 
• Hwy_Man/Eng_Data/ 
• Hwy_Ops/Eng_Data/ 
• Hydro/Eng_Data/ 
• Illumination/Eng_Data/ 
• Landscape/Eng_Data/ 
• Public_Trans/Eng_Data/ 
• R_Catenary/Eng_Data/ 
• R_Signals/Eng_Data/ 
• R_Track/Eng_Data/ 
• Traffic/Eng_Data/ 
• SVY_District/_Eng_Data/ 
• PMaps/ 
• SVY_Central/ 
• SVY_Consultant/ 

Warning: 
Do not change the name or path of the 
Project_Typical.itl file.  
 
If this file name gets modified after Templates are 
placed in a Corridor the Synchronize with 
Library tool will not be able to update itl edited 
templates. 
 
This path is also set as a variable used across all 
projects so your file will always be read in. 



Volume 3.2  - OpenRoads Designer Roadway Modeling 

10 
 

1. Select OpenRoads Modeling > Corridors > Template > Create Template 

 
Figure 8 Create Template Tool 

2. The Template Library will open to …Highways/Eng_Data/Project_Typicals.itl. 

 
Figure 9 Project Typicasl File 

a. If the template library is pointing to a random place or file, go to file explorer and 
copy …CT_Configuration\Organization-BIM\_CT_Civil Standards\Template 
Library\Project_Typicals.itl and paste the file into …Highways/Eng_Data/ 

Please note: Any other disciplines modeling a corridor can copy a blank ITL 
from …CT_Configuration\Organization-BIM\_CT_Civil Standards\Template 
Library\Project_Typicals.itl and paste the file into the discipline-specific folder for 
engineering data: 

b. Now back in the Create Template select File > Open and open the .itl file you just copied 
to your project. 

3. In the Create Template Dialog Box select Tools > Template Library Organizer… 

 
Figure 10 Template Library Organizer Pull Down Tool 
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4. Select Browse… 

 
Figure 11 Template Library Organizer Browse Butoon 

5. Select …CT_Configuration\Organization-BIM\_CT_Civil Standards\Template 
Library\OpenSite Templates Imperial.itl and click Open. 

6. Expand the right hand Available in folders and copy the needed Templates to the Project 
Library on the left hand Available in. 

7. When complete click OK. 

 
Figure 12 Template Library Organizer Dialog Box 
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2.2 Point Names and Features 

CTDOT’s template library is supplied with many template components defined that can be 
used as the starting point for creating and editing templates for a project. The folders in this 
library contain various Components and End Conditions that can be used to create completed 
templates. These components use CTDOT Standard Point Names, Component Names and 
Feature Definitions. If a user decides to create templates from scratch, it's important to 
remember that each point and component in the template is assigned a Name and a Feature 
Definition. It is imperative to ensure that the points and components are named and assigned 
features consistent with CTDOT standards.  

Feature definitions for template points and components are defined in 
CV_Highway_Features_Levels_ElemTemp.dgnlib, which is attached by a configuration 
variable. As the template is applied to the corridor, 3D line strings are drawn in the design file 
by connecting the points from template drop to template drop by their Name. The symbology 
of these line strings is controlled by the Feature Definition that is assigned to each point. The 
CTDOT CONNECT DDE includes a multitude Feature Definitions that can be used for template 
points. 

The point feature definitions can be reviewed by browsing to the following folder in the Civil 
Standards tab:  Libraries > Feature Definitions > Linear > Roadway Modeling > Template 
Library 

Templates are defined by inserting Points, Components. 

Template Points - The points of a template represent breakline features that will be created 
when the template is processed using the Roadway Designer command. Points have a name 
and feature style; there is no limit to the number of points in a template. Once processed in 
Roadway Designer as features, they are saved to the design surface. 

Template Components - A component is a set of points that define an open or closed shape. 
Each component, whether open or closed, can represent a different material or area of 
interest. Components are named and have an assigned feature style. There are 6 types of 
components created in InRoads: Simple, Constrained, Unconstrained, Null Point, End Condition, 
and Overlay/Stripping. 
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Exercise 3 Creating Templates 
Templates are created and edited in the template library by choosing Template > Create 
Template from the Corridors tab.  

 
Figure 13 Create Template Tool 

Basic Steps 
While the process to create templates will have many variables, the general procedure to create 
templates is summarized below: 
1. Copy the needed CTDOT Standard Roadway Templates to the Project's Master 

Library. Templates can be copied from one library to another by selecting Tools > Template 
Library Organizer from the Create Templates dialog. 

2. Create a new template or copy a template. 

3. Drag and drop template 
backbones or individual 
components into the active 
template. 

4. Create/edit the components as 
necessary. 

5. Merge components as desired. 

6. Review the point names and 
point name overrides. 

7. Review the component names 
and component name 
overrides. 

8. Test the template behavior. 

9. Save the template library. 

 
  

 

Figure 14 Create Template Dialog Box 
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3.1 Menu Commands 
The dialog is split into several areas. Each area is briefly described below. 

File - The File menu contains familiar commands for creating new Templates and new folders 
within the template library, as well as commands to save and open template libraries, 

Edit - The Edit menu contains commands used when editing templates such as Undo, Redo, 
Cut, Copy, Paste, etc… 

Add - The Add menu contains commands to add points and components to the active 
template. 

Tools - The Tools menu contains various tools for template creation. The Options and Dynamic 
Settings menu items are described on the following page. 

 
Figure 15 Create Template tools list 

3.1.1 Options… Dialog 

Tools > Options… displays the Template Options dialog which allows you to specify naming 
and step options for the current template. Use the Dynamic Settings dialog, detailed on the 
following page, to toggle these settings on/off as you design the template. 

 
Figure 16 Template Options 
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Naming Options 
Component Seed Name 

• From Feature Definition indicates, when selected, the component name is derived from 
the style specified when the component is created. 

• Specify indicates, when selected, the component name is specified in the field. 

• Point Seed Name allows you to specify the seed name for point in the current template. 
Since point names must be unique, the seed name is appended with a different number 
each time a point is created. 

Apply Affixes 

Indicates, when on, that affixes are applied. 

• Left Prefix/Suffix specifies which prefix/suffix should be added to a point or component 
when the value is on the left of 0.0 (absolute). 

• Right Prefix/Suffix specifies which prefix/suffix should be added to a point or component 
when the value is on the right of 0.0 (absolute). 

Step Options 

These options are used to specify precision step input for components and points. These 
values can also be accessed from the Dynamic Settings dialog. 
• X Step specifies the step increment for the X distance from the dynamic origin. If this 

value is non-zero, then the cursor moves to the horizontal increments of the specified 
value as measured from the dynamic origin. 

• Y Step specifies the step increment for the Y distance from the dynamic origin. If this 
value is non-zero, then the cursor moves in vertical increments of the specified value as 
measured from the dynamic origin. 

• Slope - specifies the step increment for slope from the dynamic origin. If this value is not 
0, then the cursor moves in slope increments of the dynamic origin. Slope is applicable 
only when the dynamic settings are in horizontal/slope mode. 
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3.1.2 Dynamic Settings Dialog 

Tools > Dynamic Settings… displays the Dynamic Settings dialog, which is used for 
precision input of template components and to assign point names and styles when 
defining components. 

 
Figure 17 Dynamic Settings 

X:Y/X:Slope toggles between X,Y step lock and X/Slope step lock. 

X Value displays the current X distance from the dynamic origin. 

X Step specifies the step increment. If this value is non-zero, then the cursor moves in 
horizontal increments of the specified value as measured from the dynamic origin. 

Y value displays the current Y distance from the dynamic origin. 

Y Step specifies the step increment. If this value is non-zero, then the cursor moves in 
vertical increments of the specified value as measured from the dynamic origin. 

Point Name specifies the name of the point to be placed. 

Apply Affixes specifies, when selected, that point name affixes (prefix or suffix) are to be 
applied to the point name when placing points. The Affixes are defined on the Template 
Options dialog. The Key-in pull down is used to specify the type of key in to be performed. 
• XY = key in absolute coordinates. 

• DL = key in delta coordinates from last point placed (defaults to the dynamic origin if it 
is the first point of a component. 

• HS = key in horizontal delta distance and slope from last point placed. 

• VS = key in vertical delta distance and slope from last point placed. 

• OL = key in delta coordinates from dynamic origin. 

• OS = key in horizontal delta distance and slope from dynamic origin. 

Set Dynamic Origin sets the location of the dynamic origin. 
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3.2 Template Library 
On the left side of the Create Template dialog is the Template Library area which contains a 
Windows-like folder structure. This area is used to manage the content of the current template 
library. Two tabs are supported for the Template Library area as described below. 

3.2.1 Folders and Template list 

When the Library tab is selected, the Template Library displays the contents of the current 
template library in a familiar Windows folder structure as shown at right. The Template 
Library area also supports common Windows functions like drag, drop, cut, paste, etc.. 

• When a template is selected from the list, the Preview window is used to display a 
preview of the template. 

• Double-click the template name to set it as the active template. 

 
Figure 18 Roadway Template 
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3.2.2 Active Template 

When this tab is selected, the Template Library area displays the contents of the active 
template as shown at right. The Active Template option is used to review and edit template 
points, components, and parameters in a table format. 

 
Figure 19 Active Template  

3.2.3 Creating New Folders and Templates 

Templates can be organized into folders in the Project Library. The Project Templates folder 
is intended to be used to create new folders and templates for a specific project. 

• To create a new folder, right click on the Project Templates folder and choose the New > 
Folder option. 

• To create a new template, right click on the folder and choose the New > 
Template option. 

• You can also cut, copy and paste templates from the HWY folders to the desired Project 
Library folder. 
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3.2.4 Current Library 

The right side of the Create Template dialog is used to display and edit the current 
template. 

 
Figure Current Library 

Name - Shows the name of the current template. 

Description - Allows you to review/edit the current template description. 

Display - 

Components/Constraints - This option is used to set the display mode of the 
template. If Components is selected, then the template components are displayed. If 
Constraints is selected, then the point constraints for the template are displayed. 
Template points are always displayed. 

Display Point Names - Toggle this option on to display the template point names. 

Display All Components - When this option is checked on, any components that are 
“hidden” are displayed with dashed lines. 

Current Template Window - The Current Template Window is used to display and 
edit the current template. The window uses its own graphics engine and is not a 
MicroStation view.  
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A magenta-colored box is used to designate the origin of the template. 

 
Figure 20 Origin of the template 

At the bottom of the Current Template Window are view commands similar to the 
MicroStation view commands. The two buttons that look like MicroStation View Previous and 
View Next commands are undo and redo commands used on template operations. The 
CTRL-Z keyboard shortcut can also be used to undo the last template operation. 

Within the Current Template Window, you can right-click to access commonly used 
template functions. You can also double click template components for editing purposes.  

 
Figure 21 Current Template Window 

Mouse Wheel Functions - The mouse wheel has the following functions when creating 
templates: 

• Scroll the wheel to zoom in or out in the template window. 
• Hold down the Shift key while scrolling the mouse wheel to zoom in or out in the 

vertical direction only. 
• Hold down the Ctrl key while scrolling the mouse wheel to zoom in or out in the 

horizontal direction only. 
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Point Properties - Features can be reviewed and assigned in a variety of ways. 
• The Name and Feature Definition can easily be edited the Point Properties dialog 

which is accessed by double-clicking the point in the Current Template window. 

 
Figure 22 Point Properties 

• The Dynamic Settings dialog can be used to define the Point Name that will be 
assigned to points as they are created. The Point Name field can be used to key-in a 
name for the point or to select a name from a predefined list as shown at right. It is 
recommended that you use the point names from this list when designing your 
templates. When a point name is selected from the list, the Point Style, which is the 
Feature Definition, is automatically set to the appropriate value. The Point Style list 
contains a list of all the Feature Definitions available in the CTDOT DDE. 

 
Figure 23 Point Name 
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3.2.5 CTDOT Point Names 

An example of the standard point names with suffixes are listed below: 
Point Name Description 
EOR Edge of Road on Top Surface 
EOR_b Edge of Road on Pavement Base Course 
EOR_sb  Edge of Road on Subbase 
EOR_sg  Edge of Road at Subgrade 
EOR_pa Edge of Road on Processed Aggregate 

List of Point Name (prefixes): 
Prefix Point 
Name 

Description 

BCLC Bituminous Concrete Lip Curbing 
BCPC Bituminous Concrete Park Curbing 
BOC Back of Curb 
CC Concrete Curb 
CL  Centerline 
CPC  Concrete Park Curb 
CUT  Cut Slope Limit 
DNC  Do Not Include 
EOR  Edge of Road 
FILL  Fill Slope Limit 
GC  Granite Curb 
GSC  Granite Slope Curb 
SHDR  Shoulder 
SNOW  Snow Shelf 
TRWY  Travelway 
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3.2.6 CTDOT Component Names and Features 

When creating new Components in the Template Library the Mesh Feature 
Definitions defined in CV_Highway_Features_Levels_ElemTemp.dgnlib should be used.  

The component feature definitions can be reviewed by browsing to the following folder in 
the Civil Standards tab: Libraries > Feature Definitions > Mesh  

 
Figure 24 Component Names 
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Component Names and Features can be reviewed and edited by double-clicking on a 
component to open the Component Properties dialog. 

 
Figure 25 Component Properties 
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3.3 Template Points 

When the template is processed using the corridor modeling command, the points of a 
template are connected to form breakline features. Each point will be connected longitudinally 
to the next template drop location to form 3D longitudinal breakline surface features. The 
breaklines are drawn using the symbology defined with the Feature Definition that is assigned 
to each point. 

Since the template points are connected to generate the completed surface, establishing a 
standard name for template features that are used on each template is very important to the 
quality of the proposed design surface. For example, if a Shoulder point is named SHDR_lt on 
the first template, and it is named Shoulder_Left on the next, the software will not 
automatically connect these points to generate the breakline feature. Following a point 
naming convention is important to obtain the best results with Corridor Modeling. 

It is equally important to ensure that the feature definition assigned to points is consistent from 
template to template. 

Each template point name must be unique to the template. The software automatically 
appends a number to the point name if the same name is used during template creation. 

There is no limit to the number of points in a template.  

3.3.1 The Point Properties Dialog 

The Point Properties dialog is used to review and edit various properties associated with 
the template points, including the definition of the point constraints. To access the Point 
Properties dialog, in the Create Template dialog double-click on the point in the Current 
Template window. The Point Properties dialog, shown below, is opened. 

 
Figure 26 Point Properties 
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The dialog contains the following options: 
Name displays the point name. The point name can be keyed-in or selected from the drop-
down list. If the point name is selected from the list, the corresponding Feature Definition is 
automatically assigned. Point names must be unique to the template. 

Use Feature Name Override displays the name of the feature that will be created in the 
surface to correspond to the point. This field is optional. If it is blank, then the point name will 
be used as the feature name. 
• The option is intended primarily for end condition components to create connectivity 

from one station to the next when the template end conditions change. For example, if 
you want all surface tie-in points to belong to one feature, then set the feature name of 
all the ending end condition points on each side of the template to the same name (i.e. 
all Cut and Fill end points on the right would be given the feature name R-Tie and all the 
ones on the left would be given the feature name L-Tie). 

• If the point has a Feature Name Override defined, the point name is displayed in red in 
the Template window. 

Feature Definition is used to define the feature definition of the point. If no style is specified, 
then it comes from the first component of which the point is a member. 

Superelevation Flag is used to identify the point as a candidate to be used for assigning 
superelevation control lines. This option should only be toggled on for pavement points on 
the surface of the pavement. 

Alternate Surface allows you to specify the name of an alternate surface for a point. You 
may choose multiple alternate surface names. Select from the list of available surfaces in the 
active template. 

Member Of indicates in which components the point is included. 

Constraints - The Constraints portion of the Point Properties dialog allows you to review/edit 
the constraints on a point. 
• Type specifies the constraint type: None, Horizontal, Vertical, Slope, Vector-Offset, Project 

to Surface, Project to Design, Horizontal Maximum, Horizontal Minimum, Vertical 
Maximum, Vertical Minimum, Angle Distance. The constraints are described in more 
detail below. 

• Setting up the appropriate constraint types is critical to achieve the desired results when 
pavement layers, superelevation, and transitioning are introduced to the design. 

• Label displays the optional label for the constraint. Constraints that are labeled can have 
their value changed during design processing. The same label name can be assigned to 
more than one constraint and more than one point. See Section 10.4 for details. 
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• Horizontal Feature Constraint is used to allow a point to target elements in the design file 
that are defined with the specified Feature Definition within a specific Range. Use of this 
option is not recommended.  

3.3.2 Point Constraints 

Point constraints are used to manage the behavior of points in a template. They are used 
so that if a point is moved in a template, either by the user editing the template or by the 
application of a horizontal or vertical control during design processing, all the points related 
to the point being moved behave in a rational and predictable manner. 

For example, when a Simple component is inserted into the active template, it is comprised 
of four points which are connected to define the component as shown in the example 
below. 

 
Figure 27 Point Constraints 

The constraints for all the points in a template can be displayed by choosing the Display 
Constraints option on the Create Template dialog. 

 
Figure 28 Display Constraints option 

Three of the four points are constrained with relation to the insertion point. If the original 
insertion point is moved, the other three points move in relation to the first point. 
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• A point can have at most two constraints. If two constraints are defined, the point is 
said to be “fully constrained”. A point that is fully constrained is represented by a red 
plus sign. In the example above, points 2, 3, and 4 are fully constrained. 

• A point that is partially constrained, meaning that it has only one constraint on it, is 
shown as a yellow plus sign. 

• An unconstrained point is shown as a green plus sign. 

Point constraints are two-dimensional and one-way. Two-dimensional means that the 
constraints can only affect the points offset and elevation (x and y coordinates in the 
cross-section view). One-way means there is a child-parent relationship between points. 
In other words, if point 2 is constrained by point 1, point 1 is said to be the parent of point 2 
and moving point 1 will affect point 2, but you cannot move point 2 to affect point 1. The 
example below shows a sample of this where the blue arrow indicates a parent/child 
relationship from point 1 to point 2: 

 
Figure 29 Point Constraints 

Constraints are displayed as blue lines between the parent and the child point. At the 
midpoint of the constraint line, there is a short white line designating the constraint type as 
follows:  

• Horizontal line = Horizontal Constraint 
• Vertical line = Vertical Constraint 
• Sloped line = Slope Constraint 

Multiple lines will be shown for points with two constraints. 

Floating the cursor over a point will temporarily display an arrow designating the direction 
of the constraint (the arrow points to the child point) and a pop-up menu displaying 
information about the point. 
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3.4 Point Constraint Types 

Horizontal - The child point remains at the given horizontal distance from the parent point.  
• In the example above, point B has been constrained to point A with one constraint as 

shown below. 

• If point A is moved horizontally, point B will maintain its relative distance from point A. 

• If point A is moved vertically, point B is unaffected.  

Vertical - The child point remains at the given vertical distance from the parent point. 
• In the example above, point B has been constrained to point A with one constraint as 

shown below. 

• If point A is moved horizontally, point B is unaffected. 

• If point A is moved vertically, point B will maintain its vertical relationship to point A.  

Slope - The child point will maintain the given slope from the parent point. 
• In the example above, point C has been defined with a Horizontal and a Slope constraint 

as shown below: 

• Slope constraints are absolute. Slopes going from lower-left to upper-right are positive 
regardless of whether the child point is to the left or right of the parent. 

• Slope constraints can also have Rollover Values assigned to them. Rollover values are 
used to set the slope constraint based on variety of high side and low side slope 
parameters. A Reference Point is specified which defines the controlling slope to the 
parent point. 

• The example above documents the Rollover Values can as defined in CTDOT’s example 
templates for the shoulder break point behavior. See the online help for more 
information on the available parameters.  

Horizontal Maximum - The child point has two parent points and remains at the given 
horizontal distance from the parent point that is farthest to the right (has the maximum 
horizontal or X value).  

Horizontal Minimum - The child point has two parent points and remains at the given 
horizontal distance from the parent point that is farthest to the left (has the minimum 
horizontal or X value).  

Vertical Maximum - The child point has two parent points and remains at the given vertical 
distance from the parent point that is highest (has the maximum vertical or Y value).  

Vertical Minimum - The child point has two parent points and remains at the given vertical 
distance from the parent point that is lowest (has the minimum vertical or Y value).  
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Vector Offset - The child point has two parent points and will be projected onto the vector 
defined by the two parents. If the offset is not zero, then the child point will maintain a 
perpendicular offset from the parent vector at the specified offset value. Negative values 
indicate an offset to the left of the vector defined by the parent points. Positive values indicate 
an offset to the right.  

Project to Surface - This constraint must be used in conjunction with one of the previously 
define constraints. The other constraint will define the projection direction. The child point will 
then be projected to the surface with the name or parametric label given when the design is 
processed. If the surface does not exist, or no solution is found, then the point will remain where 
it is placed in the template.  

Project to Design - This constraint is like the Project to Surface, except that the point is 
projected to the design surface of the template. A projection value is given to indicate whether 
the projection is to be to the left or to the right. The point must also be constrained by one of 
the previous constraints, excluding the Project to Surface, so that a direction for the projection 
may be determined. A negative value limits the projection to the left of 0; a positive value limits 
the projection to the right. A value of 0 will seek to the left and to the right of 0 to project the 
point. If no solution is found, then the point will remain where it is placed in the template.  

Angle Distance - This constraint takes two parent points, a distance, and an angle. The 
selected point is then fully constrained to the location defined by the first parent, and the angle 
from the first parent relative to the vector defined by the two parent points. This constraint 
creates a rigid-body rotation. When selected, no other constraint types are available. 
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3.4.1 Editing Points with the Left Active Template Window 

In addition to the Point Properties dialog, points can be edited from a pop-up menu that is 
accessed by right-clicking on a point in the Active Template window. The menu is shown 
below. 

 

Figure 30 Editing Points with the Left Active Template Window 
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3.4.2 Null Points 

A null point is a template point that is purposely not related to any particular component. 
It’s most often used as a reference for controlling other points. To create a null point, right-
click in the current template window and select Add New Component > Null Point, or 
select Add > Null Point from the pull-down menu of the Create Template dialog to initiate 
the command. 

 
Figure 31 Null Points 

  

3.4.3 Testing Point Controls  

The behavior of fully constrained points can be tested by right-clicking on the point and 
selecting Test Point Controls as shown below. Select the desired option to test the behavior 
of a template as the point is moved either horizontally, vertically, or both at the same time. 

 
Figure 32 Testing Point Controls 
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3.5  Template Components 
A component is a set of points that define an open or closed shape. Each component, whether 
open or closed, can represent a different material or area of interest. Components are named 
and have an assigned feature style. Component types are described below: 
Simple Components - A simple component typically represents a section of pavement. It’s a 
closed parallelogram (4 constrained points) that is defined by the slope and thickness. 

 

Figure 33 Template Components 
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Constrained Components - A constrained component consists of points that are all restricted 
to the movement of the first point. A constrained point is typically used to manage the 
behavior of other points in the template. When a point (parent) is moved, any constrained 
point (child) also moves. This restriction only affects the offset and elevation (x,y) of the 
restrained point and the relationship is unidirectional (movement of child point does not move 
the parent point).  Fully constrained points are displayed with a red + symbol. 

 

Figure 34 Constrained Components 

Unconstrained Components - An unconstrained component is open or closed-shaped with 
no movement restrictions. Moving one point has no impact on the other points that make up 
the component. 

Null Point - A null point is a template point that is purposely not related to a specific 
component. It’s most often used as a reference for controlling other points. 
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End Condition - An end condition is a special open-shaped component that targets a surface, 
an elevation, or an alignment. End conditions are typically used to define cut and fill slope 
solutions. 

 

Figure 35 End Condition 

Overlay/Stripping Components - A specialized component type that is used for defining 
pavement planning and overlay materials.  
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3.5.1 Creating Template Components 

CTDOT provides an example template library that contains several commonly used 
components. These components can be used to build templates. It may also be necessary 
to make specialized components to meet specific project requirements. 

To create a simple component, right-click in the active template window and select Add 
New Component > Simple, or select Add > Simple from the pull-down menu of the Create 
Template dialog to initiate the command. 

  

Figure 36 Creating Template Components 

As new components are created, the Current Component portion of the Create Templates 
dialog is used to define the Name, Style, and any other relevant parameters for the 
component type being created. A simple component consists of four points defined 
by Slope, Thickness, and Width.  The top points are constrained 
by Horizontal and Slope constraints. The lower points are constrained to the points directly 
above them by a Horizontal and Vertical constraint. 

Define the Name, Slope, Thickness, Width, and Feature of the component before placing 
the component in the template. 

The Feature is used to set the symbology for the graphics drawn to represent the 
component in the 3D model. 

The Dynamic Settings dialog is used to facilitate component placement. The point names 
are derived from the Point Name selected in the Dynamic Settings dialog. Each point is 
appended with a number that is incremented. The points are assigned the Point 
Style feature that is active in the Dynamic Settings dialog. 

Point names and the feature that is assigned to each point should be reviewed and edited 
after the component is placed. 
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In the example below, a simple component is created representing a single lane of 
pavement. 

 

Figure 37 Dynamic Settings 

Before placing the component in the template, various options are available to control how 
the template is placed by right-clicking in the template window to reveal the menu shown 
below. 

 
Figure 38 template placed by right-clicking 

• Change placement Point can be used to change which component point is used as the 
point placed at the point you specify. Each time this command is selected, the 
placement point will move in a clockwise direction to the next point in the component. 

• Mirror will create the original component as well as a mirrored component reflected 
horizontally about the template origin. 

• Reflect will create a single component reflected about the template origin. 
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• The Mirror and Reflect options are toggles that are turned on or off and remain active. 
The on/off status of the Mirror and Reflect options is displayed at the bottom right 
corner of the Create Templates dialog. 

• Select Set Dynamic Origin to set the location of the dynamic origin. The dynamic origin 
is indicated by the purple box in the template display window.   

Creating Constrained and Unconstrained Components 

Constrained or Unconstrained components can be used to create any open or closed 
shapes in the template such as curbing, median barriers, retaining walls, or complex 
pavement situations such as the shoulder break on the high side of superelevation. 

Constrained Components 

To create a constrained component, right-click in the current template window and 
select Add New Component > Constrained, or select Add > Constrained from the pull-
down menu of the Create Template dialog to initiate the command.  When constrained 
components are created, both horizontal and vertical constraints are applied to each 
point. 

Unconstrained Components 

To create an unconstrained component, right-click in the current template window and 
select Add New Component > Unconstrained, or select Add > Unconstrained from the 
pull-down menu of the Create Template dialog to initiate the command. When 
unconstrained components are created, no constraints are applied. This option is useful 
when you wish to define constraints other than Horizontal and Vertical constraints. 
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Dynamic Settings 
The Dynamic Settings dialog can be for precision input when creating the component. In 
the example below, point EOR will be created at a defined horizontal distance and slope 
from point CL using a horizontal distance of 12 and a slope of -1.5% by using 
the hs=12 option with a value of 12, -1.5%. Use the Enter key to execute the command. 

 

 
Figure 39 Dynamic Settings 

 
Right-click in the current template window at any time during the component creation 
process to access the menu shown below: 

 
Figure 40 Right-click Menu 

• Select Finish when you have completed creation of the component. 

• Components can be created as open or closed shapes. To toggle on/off the option 
to placed closed shapes, select Closed Shape. 
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• Select Mirror to create two components at the same time. The second component is 
a mirror image of the one you are defining. The component is mirrored about a 
vertical line passing through the Dynamic Origin location. 

• Select Undo Last to undo the last point that was added to the component. 

• Select Cancel to terminate the component creation process. 

• Select Set Dynamic Origin to specify the location of the dynamic origin. 

3.5.2 Drag and Drop Component Operations 

A previously created template component can be included in the active template by use of 
drag and drop operations. Select a previously drawn component from the active template 
library and drag the component into the Current Template window. The component 
dynamically floats on the cursor. Release the mouse button to drop the component at the 
desired location. 

While dragging the component in the Current Template window, right-click anywhere in 
the Current Template window to access the placement options discussed previously 
(Mirror, Reflect, etc…)    

When connecting two components by dragging a component into the active template, the 
connecting point will change to a white colored plus sign prior to placing the component to 
indicate that the points are coincident. The point name from the previously placed 
component will be retained. Point names can be edited at any time during the template 
creation process. 

1. In the example below, a new blank template is created New Template1, this will be built 
with a left template having one lane and a right template having 2 lanes. 

2. The Left side of the road is placed by dragging in the 1Ln_BCPC component. It is 
dropped with Apply Affixes at the origin in the active template. 

3. The right side of the road is then placed with the Mirror option is turned on, with Apply 
Affixes also toggled on, 2Ln_BCPC component is also dropped at the origin. 
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Figure 41 Create Template Drag Over 

 

 
Figure 42 Create Template Drag In 

 

 
Figure 43 Create Template Drop  
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3.5.3 Affixes 

The Apply Affixes option is used to add a user defined prefix or suffix to the point name. In 
the example below a simple component was added with the Mirror option toggled on (as 
the component is being placed, right-click to reveal a menu to choose the Mirror option). 
The prefix of “lt-“ is applied to the points on the left side of the template. The prefix of “rt-“ is 
applied to the points on the right side of the template. 

 
Figure 44 Apply Affixes 

The affixes are defined in the Template Options dialog. 

Tip: As a rule, affixes should not be applied to templates that contain individual 
components that will be used as “building blocks” for complete roadway templates. This is 
because the component maybe used on either the left or right side of the template. 
Affixes should always be applied when creating completed templates for use with 
Roadway Designer. 

Note that all the points of the component are named using the currently defined Point 
Name. After the component is placed, it is necessary to rename the points and assigned 
feature definitions to ensure that the points and 3D line strings are drawn using the 
appropriate standards. This can be done by double-clicking on each point to access 
the Point Properties dialog shown below. 

The Name can be typed in or selected from the drop-down list. If the Name is selected 
from the list, the associated Feature Definition is automatically defined. The Point 
Properties dialog is covered later in this document. 

 
Figure 45 Point Properties 
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3.5.4 Merge Components 

Deletes all the shared point line segments of two overlapping components and merge 
them into the selected component. The second component is deleted. Access this 
command with a right-click over a location that is above line segments from two 
overlapping components. The dialog appears only when 2 or more components share a 
common line. 

 
Figure 46 Merge Components 
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3.5.1 Component Editing 

The properties of the component can be edited by double-clicking on the component. The 
Component Properties dialog is opened.  

 
Figure 47 Component Editing 

Name - Specifies the name of the current component. Select a different component using 
the locate button. 

Use Name Override - The name override is used to specify the name used by the software 
to connect components from one template drop location to the next. 

The option is intended to create connectivity from one station to the next when the 
template components change. For example, a template may contain more than one 
solution for a fill condition as shown below. 

Two end conditions are defined for the fill slopes named R-FILL2 and R-FILL3. When the 
templates are processed, the software will evaluate each template drop location to 
determine whether the R-FILL2 or the R-FILL3 component is used. 3D Mesh elements are 
created by connect all the components by the name of the component. All the 
components named R-FILL2 will be connected to create 3D Mesh element, and all of the 
components named R-FILL3 will be connected to create another mesh element. This leaves 
a gap in components at the locations where the fill slope transitions from 3:1 to 2:1 since the 
components named R-FILL3 will not be connected to the components named R-FILL2. The 
solution is to assign the same Override Name for each component. 

Description - Specifies an optional description of the component. 
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Feature Definition - Specifies the feature style of the component. This option is used for 
display and also to define the component’s material. CTDOT has defined a specific group of 
styles to be used for components prefixed with the word “Component”. When the 
components are plotted in MicroStation, either as a 3D model, or as cross sections, the 
symbology defined by the selected Style is used.  Care should be taken to select the 
appropriate style for each template component. 

Parent Component - Specifies the parent component. If a component has a parent 
component, then it is only displayed if the parent component is displayed. The parent 
component can be either a non-end condition component, or an end condition 
component. Specify the component or identify it using the locate button. 

The Active Template listing can also be used to display and edit the parent child 
relationship between points and components. In the example at right, the 
Components category is open to show the parent/child relationship between 
the components in the tree. Drag and drop operations can be used to move one 
component under another. 

Note: The component names are listed alphabetically, not from top to bottom as 
drawn in the template. 

Exclude from Top/Bottom Mesh - Specifies that the component will be excluded from the 
top and bottom mesh elements that are created in the corridor modeling process. 

Close Shape - This option is only available for non-End Condition components. Only closed 
shapes can be used to compute component quantities. 

In this example the components were merged so the Name needs to be edited to remove 
the _lt suffix. 

       
Figure 48 Close Shape 

     



Volume 3.2  - OpenRoads Designer Roadway Modeling 

46 
 

3.5.2 End Conditions 

An end condition is a special open-shaped component that targets a surface, a feature of 
a surface, an elevation, or an alignment. End Conditions are commonly used for cut and fill 
definitions. End Conditions are added to the end of simple, constrained, or unconstrained 
components. 

To create an end condition, right-click in the template window and select Add New 
Component > End Condition, or select Add > End Condition from the Create 
Template dialog’s pull-down menu. 

 
Figure 49 End Conditions 

When adding an end condition to the current template, the Current Component portion of 
the Create Template dialog displays the following options: 

 
Figure 50 Current Component 
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The Name field is used to specify the user defined name for the component. 

The Feature Definition is used to set the feature definition for the component. 

Target Type specifies the type of target the End Condition is seeking. Targets include: 

• Terrain Model – Seeks an OpenRoads Terrain Model. 
• Elevation – Seeks a particular elevation. 
• Linear Horizontal/Vertical/Both – Seeks the intersection with a particular linear 

element selected from a list. 
• Feature Definition Horizontal/Vertical/Both – Seeks the intersection with a particular 

feature type. 

Horizontal Offset specifies a horizontal offset from the target. This option only applies if the 
target is a horizontal target or has a horizontal aspect. 

Vertical Offset specifies a vertical offset from the target. Applies only if the target is a 
vertical target or has a vertical aspect. For an elevation target, specify the elevation here. 

Priority specifies the order in which end conditions are attempted in seeking a solution. 
Where more than one End Condition starts at the same point, this value determines the 
order in which End Conditions are attempted to find a solution. Lower numbers, which have 
a higher priority, are attempted first. 

Benching Checkbox indicates, when on, the set of segments of the End Condition are 
repeated until a solution is found. 

Benching Count indicates the maximum number of times that benching should occur. If 
this value is 0, then the repeat count is unlimited, and the benching End Condition must 
find its target for it to be valid. If any other number is entered, then if the benching is 
repeated for the specified count and if the target is not reached, the benching End 
Condition will still be considered successful if an End Condition attached to the end of the 
benching End Condition is successful. 

From Datum indicates, when on, the benching will use a datum elevation and step 
elevation to set the benching rather than using the End Condition segments as they are 
defined. 

Datum Elevation specifies the elevation that represents the basis for the step elevation. 
Datum + Current bench elevation = n * Step Elevation. 

Step Elevation specifies the increment for benching when a datum is being used. Each 
bench elevation is always located at the end of the first segment (or the second point) of 
the benching End Condition. 

Rounding Length specifies the length used to round the end condition. When this value is 
something other than 0.0, 4 additional points are added to the end of the end condition 
using a parabolic formula to smooth out the transition of the intersection of the end 
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condition with the surface. This rounding effect is only applied when the target is a terrain 
model or an elevation. Any other end conditions attached to the end of this one is 
attached to the end of the rounded section. 

End Condition Priority 

The end condition priority value is used when more than one end condition is defined 
starting at the same point. A simple end condition consisting of two fill lines is shown in the 
example below. 

 
Figure 51 End Condition Priority 

When the end condition is processed in corridor modeling, each end condition will be 
tested in the order specified by the user. The order is determined by the Priority value 
entered by the user during the end condition creation. The most desirable solution, and the 
first condition to be tested, is given a priority value of 1. 
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Double-clicking on a component will open the Component Properties dialog shown below. 
If the component is an end condition, the End Condition Properties are displayed. 
The Priority is set as shown below. 

 
Figure 52 End Condition Properties 

The properties for point CUT_rt2 were defined as shown Below. Check for Interception is 
toggled on, and End Condition is Infinite is toggled off. The point is defined with a 25% 
Slope for a horizontal distance of 45.0’ from the snow shelf.  
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The properties for the point CUT_rt3 were defined to specify a 2:1 slope with the End 
Condition is Infinite option toggled on. The priority for the end condition component 
Cut3_rt is set to a value of 8. 

With these settings, the end condition CUT_rt2 (Priority=7) will be tested before CUT_rt3 
(Priority=8) for an interception with the surface within the horizontal distance of 45.0’. If an 
interception is found within the vertical distance, the end condition is used for the cross 
section and a point will be placed at the interception. 

If no interception is found within 45.0’ horizontally from the snow shelf, the condition fails 
and the software will test the next end condition, CUT_rt3, which has a Priority value of 8. 
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Since End Condition is Infinite is toggled on for point CUT_rt3, the solution will solve for an 
interception with the surface regardless of the vertical constraint definition. 

       
Figure 53 Point Property End Condition is Infinite 
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Testing End Conditions  
End conditions can be tested in the Create Template dialog before processing the template 
with corridor modeling. Testing simulates how the end condition will behave when the 
corridor is processed. 
This is extremely useful for complex end condition definitions with multiple solutions. To test 
the end condition, select the Test command, located below the Current Template window. 
The Test End Conditions dialog is opened. 

 
Figure 54 Testing End Conditions 

The software will check for conflicts in the priorities defined in the template before opening 
the Test End Condition dialog. If conflicts exist, a warning is issued. 

The dialog displays the current template. Non-solved end conditions, and their child 
components, are displayed in dashed lines. Normal components and solved end conditions 
are displayed as solid lines. 

To test the end condition, select one of the available targets and then select the Draw 
button. Move your cursor over to the testing window. The end conditions will change from a 
dotted line to a solid line indicating the solution for the target interception. 

Failure Report activates the Results dialog. When you fail to get a solution on one or both 
sides, the results show which components failed and which end condition start points were 
not solved. 
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Check Priorities tests the template for priority conflicts. When conflicts exist, a message is 
displayed indicating there are end conditions that start from the same point and have the 
same priorities. The End Condition Priority Conflicts dialog is displayed. If no conflicts exist, a 
message box indicating no conflicts is displayed. 

Available Targets lists all of the targets applicable to the current template. You can select 
the desired target and draw it in the display. 

Use Surface Slope specifies the slope of the surface that is being placed. This is useful in 
certain instances where an end condition intersects a surface more than once, such as a 
ditch profile. 

Draw draws the selected target. Surfaces and elevations are drawn as horizontal lines. 
Features and alignments are drawn as a “+” mark. As you draw a target, the display 
dynamically updates to show the solution(s). 

Reset clears all the drawn targets. 

Display Rules list the display rules for the current template. Left-click the Value to toggle 
between True and False. Press the Reset button to restore the original Display 
Rules values.  

 
Figure 55 Display Rules 

If at any time user need to modify the values user can do it here. 
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