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Exercise 1 – Cross Sections for Import to HEC-RAS 
This exercise will instruct users to create cross sections data using OpenRoads Designer (ORD) for 
import to the HEC-RAS software.  

Skills Taught:  
• Learn how to use ORD to create cross section data for import to HEC-RAS. 
• Become familiar with the workflows and tools used in ORD for developing the required data 

for import to HEC_RAS. 

Introduction: 
OpenRoads Designers creates and uses information from the 3D surface models (Terrain) 
information.  For most hydraulic designs, the survey terrain model (existing terrain) requested by 
the design lead unit will be adequate.  If additional survey is needed this should be requested by 
H&D engineers from Surveys.  In some instances, the highway design model or the bridge design 
model will also be needed to create a proposed terrain model.  All terrains should be merged 
including the existing terrain into one terrain for best results of proposed conditions.  For Help with 
merging terrains please see OpenRoads Designer CE - Help. 

You will be using OpenRoads Designer tools and MicroStation tools to create the cross-section 
data for import to HEC_RAS. 

Note: This guide will not instruct you how to use HEC-RAS or how to manipulate the HEC-RAS 
data.  For instruction on HEC-RAS please see Help within the HEC-RAS program. 

1.1 Create a New File 
Before attempting to open or create DGN files users should make sure the following is in place: 

• The CTDOT CONNECT DDE is synced through SharePoint 
• The COMPASS Project is synced through COMPASS (SharePoint) 

1. Launch the Application. 

• Consultants - via the appropriate CTDOT DDE icon 
• CTDOT employees - On your desktop double click on the CAD Accounting icon 

2. After launching the program, a Welcome Screen will appear.  Ensure you are using 
the Custom Configuration and CT_WorkSpace, then select the 
relevant WorkSet and Role.  similar. 
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Figure 1 OpenBridge Modeler Splash Screen 

If you do not see the Project Number listed, please request a Compass/CAD Setup using this 
link  New CAD Project Request 

3. Browse to open a New File.  Browse to …\Hydro\Base_Models\   

4. Name your file, the file name should follow the Civil Design CAD File Naming 
Conventions:         

• Discipline Designator (HD for Hydraulics and Drainage) 
• Data Category (NC) 
• Project Number (1234_1234) 
• Description (HEC_RAS_MDL) 

File Name should read: HD_NC_1234-1234_HEC-RAS_MDL.dgn 

https://ctdotcompass.atlassian.net/servicedesk/customer/portal/8/group/24/create/100
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5. On the New dialog box click the Browse button to select the proper seed file.  

...\CT_Configuration\Organization\Seed\Road\Seed2D – CT RoadDesign.dgn 

6. Click on Save and the file will open. 

 
Figure 2 Create File 

7. After the DGN file is created open File Explorer and browse to the file, right click and select 
View online. 

 
Figure 3 File Explorer View online tool 
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8. The Projects SharePoint site will open, sort by Date, click on the three dots, select More > 
Check Out 

 
Figure 4 SharePoint Check out 

9. Select the OpenRoads Modeling workflow from the workflow drop-down. 

10. Select from the Home tab,  Primary group, Attach Tools > References.  Click on the Attach 
References tool and reference in the survey file (this should also contain the terrain 
model) from the Active_Survey folder. With older surveys you may need to reference in 
the terrain also. 

11. Make the terrain Active. 

 
Figure 5 Set Terrain Active 
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12. If the contours are not shown, click on the Properties icon to activate Properties box. 

13. Set the Override Symbology to Yes, this allows you to turn the Major and Minor Contours to 
On or Off, as well as Triangles, Flow Arrows, Breaklines etc. 

 

Figure 6 Turn on Contours 

1.2  Create Stream Centerline 
Next the user will use the Geometry tools to create the Stream Centerline going from 
downstream to upstream. 
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Figure 7 

1. Click on the Geometry tab,  Horizontal group,  Lines > Line Between Points. 

2. In the Line toolbox, select the Feature Definition: Centerline – Green, Name leave: CL 

 

Figure 8 

 

Figure 9 

Note: Open the Feature Definition Toolbar (Geometry tab,  General Tools group,  Standards 
> Feature Definition Toolbar) activate the Use Active Feature Definition toggle, select the 
feature definition and toggle on the Chain Commands (this will make it easier to draw the 
centerline of the stream). 
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Figure 10 Feature Definition Toolbar 

3. Enter the Start Point: click to the center of the stream (downstream) as the starting point of 
the stream centerline.  Move the cursor upstream to the next location of the stream, doing 
so until the end of the stream or where cross sections are no longer needed.  Right-
Click when at the end.  Select the Element Selection tool to get totally out of the command 
completely. 

 

Figure 11 Enter Start Point 

4. Next, the individual lines will need to be complexed.  Still in the Geometry Tab > 
Horizontal Group> click on the small down arrow for Complex Geometry and 
select Complex By Element.  

Set the Complex Geometry toolbox to: 

• Method: Automatic, 
• Maximum Gap: 0.033, 
• Feature Definition: Centerline – Green (if not using the Feature Definition toolbar) 

Name: CL-Stream (or to the stream name). 

5. Click to the first line just placed, see the highlighted arrow pointing upstream (click 
closer to the start to move the arrow into the right direction).  When all lines are 
automatically highlighted, click to Accept.  The centerline of the stream is now 
complete. 
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Figure 12 Locate and Accept 

6. To show stationing for the stream centerline, follow these steps:  Geometry Tab > 
Horizontal Group > Modify > Start Station.  

Command Prompts (Head-up Prompts): 

Locate Element: tentative snap to the beginning of the Stream CL and left-click 
to Accept.  The next prompts are: 

• Start Station Position: 0.000. Accept 
• Enter Starting Station: 100+00 (desired starting station) Accept. 

Select the Element Selection tool, click on the centerline, the beginning of the alignment 
should now read the beginning stationing, example 100+00.00. 
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Figure 13 Select Start Station  

6. The alignment can be annotated by clicking on the Drawing 
Production Tab >Annotation Group > Element Annotation > Annotate 
Element and click on the alignment.  

Stationing will show with stationing, PC and PT stations, bearings on, turn off levels as 
needed to just show the Stationing. 

Note:  Stationing is depending on the feature definition for the centerline.  The Centerline 
– Green alignment will have stationing every 50 feet, with the full stationing showing at 
100 feet.  Centerline – Small Blue will have stationing every five feet and full stationing 
showing at 10 feet.  Pick the stationing that best fits your need. 
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1.3  Draw Bank and Overbank 

1. Turn ON the major and minor contours if turned OFF. 

2. Next the bank and overbank lines need to be drawn, for this MicroStation Drawing tools will 
be used.  

3. Change the Active Workflow from OpenRoads Modeling to CTDOT and click on the Home tab.  

4. From the Attributes group, click on the down arrow within the Active Level.  

5. Next click on the Filters…, select: 

6. “_Hydraulics [CTDOT_Tools_Levels_ElemTemp_Text_Dim_Favorites]” Filter  

7. Click OK.  

8. From the Hydraulics levels: 

WATER_L_Chnl_Bnk (Water Courses: Left Channel Bank) for the Left Bank and Left 
Overbank or 

WATER_R_Chnl_Bnk (Water Courses: Right Channel Bank) for the Right Bank and Right 
Overbank. 

9. Double-click on either of the levels to make one of them active, 
example: WATER_L_Chnl_Bnk. 

 
Figure 14 Select Level 

10. Select the Place SmartLine command from the “Placement” tools, 
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11. Turn ON: Join Elements, Rotate AccuDraw and Start in line mode. 

 
Figure 15 Place Smart Line 

12. Starting downstream going upstream, place a continuous line for the left channel bank 
- left-click where the channel bank line is.  Repeat for the left channel overbank. 

13. Now double-click on the opposite level, example: WATER_R_Chnl_Bnk and repeat both 
steps, first draw a Smartline from downstream to upstream for the bank and then for the 
overbank. 

 

Figure 16 Bank and Stream Lines 
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1.4  Draw Cross Section Lines 

1. Turn OFF the display of the survey reference file, to see the stream and bank lines better. 

2. Change the level to WATER_Misc (Water Courses: Miscellaneous features & lines). 

3. Use the Place SmartLine command to place cross section lines where you want cross 
sections to be created for HEC_RAS import.  

 
Figure 17 Cross Section Lines 

Important Note:  It is vital to draw the lines from left bank to right bank for the import to 
HEC_RAS to work.  This may not be necessary in later versions of ORD (current version: 
OpenRoads Designer CONNECT Edition – 2021 Release 2 – Version 10.10.21.04). 

4. When finished select the Element Selection tool.  You can use this to make adjustments to 
the lines as needed. 

5. Note: Even though the Stream-CL and banks are drawn from downstream to upstream, the 
Hydraulic sections are always oriented looking downstream. 
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1.5  Use Analysis Hydraulic Tool to Create HEC-RAS data 
1. Next go back to the OpenRoads Modeling Workflow, select the Terrain tab, and locate 

the Analysis group.  There click on the down arrow for the Hydraulic tools and select 
the Create HEC_RAS Data. 

 

Figure 18 Hydraulic tools 

2. Follow the command prompts or the heads-up prompts. 

 

Figure 19 Locate First Line 

3. Locate First Section Line, left-click on the first cross section line; 

4. Locate Next Section Line – Reset To Complete, left-click on the next line and so on until the 
last line is selected (in example a total of 4 cross section lines) then right-click to complete 
the selection (Reset to Complete). 
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Figure 20 Select Line 

5. Select Terrain Or Reset To Use Active Terrain.  Either select the terrain or right-click to use the 
active terrain. 
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Figure 21 Select Terrain 

6. Locate Reference Line – select the CL Stream alignment created in previous steps. 

 

Figure 22 Locate Reference Lines 

7. Next the left channel overbank and channel bank will be selected, then the right channel 
bank and channel overbank. 

8. Locate Left Bank Over – select the left channel overbank, 

9. Locate Left Bank – select the left channel bank, 
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10. Locate Right Bank – select the right channel bank and 

11. Locate Right Bank Over – select the right channel overbank. 

 

Figure 23 Locate banks 

12. After you select the right channel overbank, the Create HEC-RAS Data menu comes 
up.  Select the …\1234-1234 - Design\Hydro\Eng_Data folder and Save the file.  

13. Note: ORD will automatically name the file, you can edit as needed. 
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Figure 24 Create HEC-RAS Data 

14. This completes the steps in OpenRoads Designer.  You can Close ORD if you want. 
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1.6  Import OpenRoads Data to HEC_RAS 

1. It will probably be more efficient to edit channel banks and River Station names within 
HEC_RAS rather than rerunning the OpenRoads workflow.  Use the File Explorer to create 
a New Folder for the HEC_RAS data files: 

…\1234-1234 - Design\Hydro\Eng_Data\HEC_RAS_DATA 

2. Open HEC-RAS from your desktop, Double-Click on the icon to open HEC_RAS. 

 
Figure 25 HEC-RAS icon 

 
Figure 26 HEC RAS Dialog Box 

3. Click on File > New Project. Type in a logical name as Title, example: 

HD_1234_1234_HEC-RAS 

this populates the File Name box with the project extension, example: 

HD_1234_1234_HEC-RAS.prj. 

4. Browse to your project directory’s HEC-RAS folder.  Change the drive location to your project 
file location: 

…\1234-1234 - Design\Hydro\Eng_Data. 
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Figure 27 

5. Click OK to create the project and folder.  

6. A warning message may come up: 

 
Figure 28 

7. Click OK. 
8. Click on View/Edit Geometric Data (OR click on Edit > Geometric Data), a new box 

opens: Geometric Data 
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Figure 29 

9. Click on  File > Import Geometric Data > GIS Format 
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Figure 30 

10. Browse to the ORD.geo file created using ORD Hydraulic tools, example: 

11. HD_1234-1234-HEC-RAS-MDL-EX.ego. 

12. Click OK.   The Import Geometric Data box opens.  

 
Figure 31 
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13. Make sure Import data as is set to: ON for US Customary units. You can step through 
the NEXT buttons and/or you can Click On: Finished - Import Data. 

 
Figure 32 

14. In the Geometric Data box, you will see the stream and the cross-section lines from the 
OpenRoads.geo file. 
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Figure 33 

15. Click on the Cross-Section icon and the Cross Section Data box opens. Work the data as 
needed. 
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Figure 34 
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Exercise 2 - Location Plans 
COMING SOON 
 
 



Volume 15 – Miscellaneous Workflows 

27 
 

Exercise 3 - Permit Plates 
COMING SOON 
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Revisions 
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