CT DOT StormCAD V8i with MicroStation V8i Start-up Workflow
Thanks!

Thanks go to all that contributed to the creation of this document, especially to Nick Langer for his drainage expertise and to Charles Grillo for his review of this workflow. It is greatly appreciated.

Gabriele Hallock
# Table of Contents

Section 1  Getting Started........................................................................................................4

1.1 Starting StormCAD V8i Integrated with MicroStation .................................................6

1.1.1 Use the Correct MicroStation User Configuration File ............................................6

1.1.2 Start StormCAD & Create MicroStation File ..........................................................7

Section 2  Create new StormCAD Project ...........................................................................9

2.1 Create Project Files........................................................................................................10

2.2 Set Project Properties & Options ................................................................................12

2.3 Set Project Defaults & Import Libraries....................................................................13

2.4 Defining Storm Events ...............................................................................................16

Section 3  Design of Storm Sewer System .......................................................................22

3.1 Layout of Storm Sewer System ................................................................................22

3.2 Input Design Data for Storm Sewer System .............................................................25

Section 4  Analyzing the System ......................................................................................30

4.1 Global Storm Event......................................................................................................30

4.2 Validate and Calculate the Model/System ................................................................31

4.3 Presentation of Results ...............................................................................................35

4.3.1 FlexTables.................................................................................................................35

4.3.2 Profiles.......................................................................................................................37

Section 5  Convert/Opening Existing StormCAD Project ..................................................39
What Bentley StormCAD version do I have?

StormCAD not open:

Using Window Explorer go to where StormCAD is installed. Look for StormCAD8 and search there for the Readme.pdf file. Open Readme.pdf.

StormCAD open:

From the MicroStation menu bar Click the following: → StormCAD → Help → About StormCAD

Instructions that follow are for StormCAD SS5 with MicroStation SS3
Section 1  Getting Started

Easy Storm Sewer Design and Modeling

StormCAD provides comprehensive modeling for the design and analysis of storm sewer systems. StormCAD is FEMA-approved and provides calculations for catchment runoff, gutters, inlets, junctions, pipe networks, and outfalls, and its intuitive interface makes the design and analysis of storm sewer systems easier. StormCAD software is approved by the Departments Hydraulics and Drainage Unit to use for roadway storm sewer design.

It is the designer’s responsibility to adhere to the CTDOT Drainage Manual and CTDOT Hydraulic & Drainage Directions.

On your desktop or under the Start → All Programs → Bentley → StormCAD V8i are two StormCAD V8i programs. StormCAD V8i for MicroStation V8i (preferred use) or StormCAD V8i, both are standalone programs, no need to go through Accounting.

Note: Before starting StormCAD, the designer should lay out the drainage systems in the drainage MicroStation file (HW_MST_1234_1234_Drainage_MDL.dgn) to reference into the
StormCAD MicroStation files. The designer should also calculate the Time of Concentration ($T_c$) and drainage areas. Each System will have its own MicroStation StormCAD file. StormCAD numbers each item but allows for the designer to add notes; it is helpful to have a sketch / schematic of the individual system with the necessary information such as: areas, elevations, lengths and slopes.

**IMPORTANT GUIDELINES FOR USING STORMCAD V8I FOR MICROSTATION**

**DO NOT** open other MicroStation files in the Project X-Drive container while in StormCAD V8i.  
**DO NOT** open the newly created StormCAD V8i file through Accounting.  
**DO NOT** open MicroStation through Accounting and then add StormCAD V8i as a MDL.  
**DO NOT** use the project design file(s) as your drainage design file while in StormCAD V8i.  
**DO** follow the [CTDOT MicroStation V8i Guide for Highway Designers](#).  
**DO** enter MicroStation through Accounting as normal and reference the StormCAD V8i MicroStation file in to your project design file(s).
1.1 Starting StormCAD V8i Integrated with MicroStation

1.1.1 Use the Correct MicroStation User Configuration File

You will open StormCAD V8i for MicroStation as a standalone (not opening through Accounting) either from your desktop or from Start. Before you start up StormCAD it is necessary that you copy the latest CTDOT user configuration file for StormCAD to your computer.

A. Using Windows Explorer copy the file: 
   W:/Workspace/StormCAD_RSC/stormcad.ucf

B. Paste to C:/Bentley_V8i/Workspace/ Users
1.1.2 Start StormCAD & Create MicroStation File

A. To open StormCAD double click the **StormCAD V8i for MicroStation V8i** icon located on your desktop (or click on START > All Programs > Bentley > StormCAD > StormCAD V8i for MicroStation V8i)

B. Change the MicroStation Interface to StormCAD as shown below:

![MicroStation Interface](image)

C. In the MicroStation File Manager box, select your X-drive project folder > Highways > _Eng_Data_/Drainage/ and select (click) the **New File** icon as shown:

![File Manager](image)

D. In the New file box, to select the seed file click on **Browse** and go to: **W:\Workspace\StormCAD_RSC\HaestadSeed2d.dgn** and click **Open**. It is **important** to use this seed file. Our CTDOT seed files have custom properties attached to it that will not work with StormCAD.
E. Type in the file name using file naming conventions in Appendix C of the *CTDOT DDE Guide*, example: **HW_MST_1234_1234_StormCAD_Sys-01.dgn**, select the file and click **Open**. StormCAD files reside in the `\Highways\Eng_Data\Drainage` folder.

F. After the MicroStation file is opened, **reference** in files as needed. Make sure scales are correct (use measure tool) and turn off Levels as needed. **Save Settings**.
Section 2  Create new StormCAD Project

After creating the MicroStation file using the Haestad seed file, the StormCAD project files, defaults and properties need to be established.

If this is the first time you are using StormCAD, we suggest you open the help menu, within the MicroStation Menu bar click on StormCAD → Help → Quick Start Lessons.

Use this workflow along with the Quick Start lessons to work your project / system scenarios or to learn using StormCAD.

Also, there is help available on the Bentley Learn Server. Please contact Samantha Scharpf of AEC Applications (Samantha.Scharpf@ct.gov) for a learning path of StormCAD V8i.

The user should be aware that the CTDOT workspace is not available within StormCAD V8i with MicroStation. This is a standalone application.
2.1 Create Project Files

A. Within MicroStation menu bar, click on StormCAD → Project → Seed → New from Seed.

B. The New from Seed dialog box opens, browse to the StormCAD Resource directory and select the StormCAD seed-file: W:\Workspace\StormCAD_RSC\StormCAD_CTDOT_ProjectFile_Seed.sews. This will start your StormCAD project with the defaults and settings required. The designer has to ensure the defaults and settings comply with the Drainage Manual for their project. StormCAD will create the files needed, you will see some screens pop-in and –out. Wait until StormCAD completed the start up.
C. StormCAD created the files and stores those in a temporary folder. The designer has to save all files to the project folder. Within MicroStation menu bar, click on **StormCAD → Project → Save Attached As . . .**

D. The “**Save As...**” dialog box opens, type in a logical file name for your system, make sure you specify the folder where the files are to be saved/stored (see below). And click “**Save**”.
E. In Windows Explorer you can see the files created by StormCAD in the file folder you specified. Close Windows Explorer.

2.2 Set Project Properties & Options

A. From the MicroStation menu bar select StormCAD → Project → Project Properties. The Project Properties dialog box lets you enter project-specific information to help identify the project. Project properties are stored with the project files. Click OK.
B. Select **Options** from the **StormCAD Components & Tools** task menu. Click on the **Drawing Tab** and select for Drawing mode: **Scaled** or **Schematic**.

![Image of StormCAD Components & Tools task menu](image1.png)

2.3 **Set Project Defaults & Import Libraries**

A. Next the Default Design Constraints are set for the project. From the StormCAD Components & Tools task **click and hold** Default Design Constraints, **select Default Design Constraints**.

![Image of StormCAD Components & Tools task menu](image2.png)
B. Set/Check the default design constraints according to the *CTDOT Drainage Manual*. Close.

C. Import the Conduit Catalog, from the StormCAD Components & Tools tasks left-click and hold-down the left mouse button and select Conduit Catalog….

D. Click on the book icon and select Import from Library. In the Engineering Libraries box check on the Conduit Library.xml. (C:\ProgramData\Bentley\StormCAD\8\Libraries\Conduits Library.xml => default)

E. Click on Select. StormCAD will import all conduits. One can also expand the folder and select all ‘Circular – Concrete’ pipes or just select a few as needed for the project. Close.
F. The CTDOT_Inlets.xml Catalog is already loaded. To see all available inlets go to the StormCAD Components & Tools tasks left-click and hold-down the left mouse button click on Inlet Catalog...

G. The Inlet Catalog box opens. All CTDOT catch basins are loaded.

H. The CT_DOT_Inlet.xml can be found at:
   W:\Workspace\StormCAD_RSC\CTDOT_Inlet.xml

I. Close the Inlet Catalog.

J. Save the project again. Click on StormCAD in the MicroStation menu, click on Project → Save Attached As..., in the “Save As” dialog box select the file name for your system and click “Save”. The message “file name” already exists. Do you want to replace it. Click “Yes”.

15
2.4  Defining Storm Events

The last piece of information needed is the rainfall data.

The Department’s Hydraulics and Drainage Unit advises the designer to use the *NOAA Atlas 14 data*, which can be accessed through the **NOAA Precipitation Frequency Data Server – PFDS** in conjunction with the CTDOT Drainage Manual.

**NOAA ATLAS 14 POINT PRECIPITATION FREQUENCY ESTIMATES: CT**

Follow the directions on the NOAA Atlas 14 screen and directions given by CTDOT Hydraulics & Drainage unit on how to develop the Point Precipitation Frequency (PF) Estimates. The precipitation frequency estimates can be downloaded in CSV-format and opened with Excel. See an example of the PF estimate on the next page.
The Location Information for the example is: Hartford, CT, US; Latitude: 41.7635°; Longitude: -72.6843°; Elevation: 70 ft.

The data you see in the PF tabular format will be used for StormCAD to create a new User Defined IDF table specific to your project location.
A. In StormCAD within the StormCAD Components & Tools task, click on **Storm Data**...

B. In the Storm Data box click the **New** icon and select **User Defined IDF Table**. A blank IDF table is created (User Defined IDF Table -1).

C. Right-click on User Defined IDF Table – 1 and click **Rename**. Rename your table, example **Hartford**. Or Project No.

D. Click on the **Notes Tab**. Add notes pertaining to the project: location, latitude, longitude and elevation from the NOAA Atlas 14 data. (This will help you and others to duplicate the data if needed).
E. Select the **Storm Event Input Tab** and click on the down arrow for **Add/Remove Return Periods**. Select **Add Range**...

F. The **Add Multiple Return Periods** box opens. Enter the return period (year) needed for your project. (2, 10, 25, 50 and 100 years). Click **OK** when all period years are entered.

G. Click on the down arrow for **Add/Remove Durations**. Select **Add Range**...
H. The **Add Multiple Durations** box opens. Right-Click on Duration (hours), click on **Units and Formatting**…, change Unit: from **hours to min**, click **OK**.

I. Enter the **Duration** (min) needed for your project. (5, 10, 15, 30, 60, 120, 180). Click **OK** when all durations needed are entered.

J. Your storm data dialog box should look as shown below:
K. Enter into each column (year – in/hr) the data from NOAA Atlas 14 Point Precipitation Frequency Estimates for your project.

L. The User Defined IDF Table should look similar as shown below:

![User Defined IDF Table - Hartford](image)

M. After all your input is completed click Close.

N. Again save the project. Click on StormCAD in the MicroStation menu, click on Project → Save Attached As..., in the “Save As” dialog box select the file name for your system and click “Save”. The message “file name” already exists. Do you want to replace it. Click “Yes”.

21
Section 3  Design of Storm Sewer System

3.1  Layout of Storm Sewer System

A. Using the StormCAD Layout tools place your drainage structures and conduits as needed. You can follow the Quick Start Lessons – Part 2.

B. As Example: Select **Catch Basin**, as your inlet and place at desired location

C. Next pick either conduit or channel. Start at the catch basin just placed, within the Layout Conduit box select your next inlet or outlet (example: catch basin).
D. Continue to place the conduit/channel until all of your system is placed ending with Outfall. You can change the structure using the pull-down menu from the Layout Conduit box. StormCAD will number everything.
E. Now place the catchment areas for each inlet (catch basin). You can just draw shapes and insert the size or you can draw the actual area shape and have StormCAD calculate the area.
3.2 Input Design Data for Storm Sewer System

F. Using the “Select Tool” double-click on the first catchment area, the properties box will open. Enter all the data for your SYSTEM, continue with the other items in your system. See most common examples (Catchment, Catch Basin, Conduit and Outfall) below:

- True = Incl. in Calc's
- False = Not Incl. in Calc's
- User Input
- StormCAD

![Diagram showing properties of a catchment area with labels for user input and StormCAD data]
Note:
“Structure Losses” (Headloss Method) for catch basins (inlets), Figure 7-6, typical bench configurations from the HEC-22 – Third Edition.

Benching tends to direct flow through the access hole, resulting in a reduction in energy losses. Figure 7-6 illustrates some typical bench configurations.

Figure 7-6. Access hole benching methods.
### Properties - Outfall - 0-6 (122)

#### General Properties
- **ID**: 122
- **Label**: 0-6
- **Notes**: ENDWALL STA. 125+35 RT
- **GIS-IDs**: 0
- **Hyperlinks**: 0
- **Station (ft)**: 0

#### Geometry Properties
- **X (ft)**: 835,284.97
- **Y (ft)**: 738,955.90

#### Active Topology
- **Is Active?**: True

#### Boundary Condition
- **Boundary Condition Type**: Free Outfall
- **Free Outfall**:
  - **Value**: True
  - **Significance**: True = Incl. in Calc's, False = Not Incl. in Calc's

#### Design Properties
- **Local Pipe Matching Constraints?**: False
- **Design Structure Elevation?**: True
- **Desired Sump Depth (ft)**: 0.00

#### Inflow (Wet)
- **Inflow (Wet) Collection**:
  - **Value**: False

#### Physical Properties
- **Update Ground Elevation from Terrain Model?**: False
- **Elevation (Ground) (ft)**:
  - **Value**: True
  - **Significance**: 344.50
  - **Significance**: 340.50

#### Results
- **Results (Flow)**:
  - **Elevation (Ground) (ft)**: Displays the ground elevation for the currently highlighted node.
Section 4  Analyzing the System

Before you can analyze the system you created you have to select Global Storm Event for your calculations.

4.1  Global Storm Event

A. Select **Global Storm Events**... from the StormCAD Components & Tools.

B. In the Global Storm Events box, click on ▼ (down arrow) and select the Global Storm Event needed for your calculation scenario. Click **Close**.
4.2 Validate and Calculate the Model/System

A. To analyze the system created, select Compute Center \(\rightarrow\) Validate. You may get a message for errors or warning. Click OK.

![Validate and Calculate the Model/System](image)

B. User Notifications may open displaying a list of warnings generated during the validation. There are two types:

- Red => error must be corrected before model (system) can be computed,
- Yellow => does not prevent successful calculation of model (system).

As Example:

User Notification:

![User Notification](image)

Meaning: Inlet calculations use the Headloss Method: HEC-22 Energy (3rd Edition) to use this, the Structure Loss mode must be set the Energy Grade Line in the calculation options.
Fix / Change: **Click on Calculations Options** in the StormCAD Components & Tools task bar.

In the Calculation Options box **right-click on Base Calculation Options** and **click Properties**. In the Properties – Solver – Base Calculation Options box **change** the Structure Loss Mode from Hydraulic Grade to Energy Grade. **Close** the boxes and **Validate again**.
User Notification:

Meaning: The culvert (pipe) doesn’t have enough cover as set in the Default Design Constraints.

Fix / Change: Pick a smaller culvert size and add extra barrel if needed, or lower the culvert elevations as needed, or leave as is and make culvert a Class V concrete culvert. Close the boxes and Validate again.
C. After you validated and all issues (RED) have been resolved as needed for your design system click the **Compute** button to calculate the model (system). After the calculation is complete, the **GVF-Rational Calculation Summary** is displayed. **Review** the Messages..., Details ... and **Close**. Make any changes necessary, validate and compute again to update your design.
4.3 Presentation of Results

After all the calculations are completed the designer needs to be able to display and print the information, StormCAD uses reports, flex tables and profiles to display and print the drainage model calculations. We discuss FlexTables and Profiles, users are encouraged to explore the presentation options more on their own.

4.3.1 FlexTables

Different FlexTables are available for a drainage system as needed. The designer should use the drainage manual as a guide to determine the information needed to represent the designed system, example: CTDOT Drainage Manual - Tables 11-4 & 11-5 Inlet Spacing Computation Sheet and Tables 11-8 & 11-9 Storm Drain Computation Sheet.

A. To view flex tables, from the menu bar select StormCAD → View → FlexTables or use the StormCAD Components and Tools task, left-click and hold on Element Symbology → FlexTables.
B. The FlexTables dialog box opens. Custom CTDOT Tables are available for catchment, catch basin, conduit, manhole, gutter and outfall. The designer can also create tables or modify tables. Multiple tables are stored and can be accessed by clicking on the checkbox for Tables – Predefined.

C. The designer should determine if all information needed is available. Individual flextables can be modified by Right-Click ➔ Edit to add and/or remove selected columns.

D. To view flextables and print click on the Report icon, in the preview window adjust columns as needed and print to pdf.
4.3.2 Profiles

Two types of profiles are available to the designer to show the storm drainage system. The designer should use the drainage manual as a guide to determine the information needed to represent the designed system, example: CTDOT Drainage Manual – Chapter 11 – Figure 11-12 Use Of Energy Losses In Developing A Strom Drain System.

A. To view profiles, from the menu bar select StormCAD → View → Profiles or use the StormCAD Components and Tools task, left-click and hold on Element Symbology → Profiles.
B. The Profiles box opens, click on the “New” icon and click **New**. The Profile Setup box opens. Click on **Select From Drawing**. The STORMCAD Elements ProfileSelection pick box opens. Select the structure items in your system to show as profile.

C. Select the profile option you want: **Open Profile** or **Open Engineering Profile**. The profile box will open, both boxes have various options to label, annotate and print the profile display.
Section 5  Convert/Opening Existing StormCAD Project

Should you need to open an existing StormCAD project please follow these directions. File extensions for StormCAD V8i SS3 have changed from previous versions. New files have to be created.

A. Create a new *.dgn file using the HaestadSeed2d.dgn file, see Section 1.1.2.

B. Select from the menu bar StormCAD → Project → Import → StormCAD Database

C. In the manager select the existing Prj_Nbr_Sys_XX.stc.mdb file. Click Open. Please be aware if the existing model/system is large it can take some time. Click Yes. Files with new extensions will be created by StormCAD V8i SS3.

D. The following question may come up: Do you wish to synchronize the drawing now? Click Yes.
E. The **Save As** box opens. **Save** the file into the project container. You will see the *.stsw* file extension.

![Save As dialog box](image)

F. StormCAD recreates the schematic in the new DGN-file and creates all the files needed with new extensions. After completion of the import you can make changes as needed, such as updating the rainfall intensity with a new User Defined IDF-table, see Section 3.