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Distribution 

This manual, in its entirety, may be freely copied and distributed for the purpose of providing a 

consistent guide to import InRoads data to HEC-RAS. 

Trademarks 

“MicroStation” and “InRoads”, are registered trademarks of Bentley Systems, Incorporated.  

Other trade names, computer protocols, and file formats mentioned in this manual are the 

trademarks of their respective owners.  In no event will the appearance of any graphic, 

description of a graphic, picture, screen display, or any other method of conveying meaning, be 

considered to impair the rights of the respective owners. 

Introduction 

This workflow was put together to help engineers create InRoads cross sections for import to 

HEC-RAS.   This workflow should be used in conjunction with the CTDOT InRoads V8i Guide. 

Basically InRoads creates and gets its information from the 3-D surface models (DTM’s).  For most 

Hydraulic designs the survey digital terrain model - DTM needs be requested and copied.  In some 

instances the Highway design model will need to be requested and combined, i.e. merged with 

the existing model.  Most design elements that InRoads creates and/or references on the surface 

models are referred to as Features.  For example, the stream alignment that you will create in 

InRoads for the HEC-RAS analysis is a Feature.  MicroStation, from an InRoads perspective, 

creates graphic elements and in general InRoads will not perform an operation on a graphic 

element.  In the following instructions, you will be directed to perform some operations using 

MicroStation and some operations using InRoads, be aware which program menu you are 

directed to.  Be aware that the InRoads program does not save anything automatically – You 

must save your work before exiting the program or you will lose your work.  Also, 

there is no “UNDO” command in InRoads.  You can modify and delete a feature that you created 

in InRoads.  InRoads will draw profiles and cross sections within the same MicroStation design file 

that you are working in.  If you place the “graphic” elements in the wrong place you can delete 

them and recreate them very easily.  If you use the survey file SV_MST_D#_XXXX_YYYY_GRN.dgn 

(most often named) your design should be in the geo-referenced location.  These instructions are 

very basic and only deal with extracting information needed to create HEC-RAS cross sections.  

For a HEC-RAS analysis, it is probably easier to modify the HEC-RAS model within the HEC_RAS 

program.  
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Section 1 Starting HEC-RAS/InRoads Project 

1.1 InRoads File Types 
See this section in the CTDOT InRoads V8i Guide for full information.  The InRoads design 

process uses several different file types.  All InRoads data is stored in external files.  The CAD 

file is used to view a graphical representation of the design data, but the graphics files do not 

store the InRoads Data. 

The following InRoads resource files have been configured especially for the HEC-RAS & V8i  

Environment  (for a complete list see CTDOT-IR-V8i Guide): 

Preference File (*.xin) - This file contains the control settings of all the dialog boxes within 

InRoads. The settings for surface, geometry and survey tools are all confined within the .xin file.   

This is the main source of standardization where all InRoads design and graphical output are 

configured to meet CTDOT standards. 

Drafting Notes (*.dft) - This file is used to enhance the production of final drawings. Use the 

commands across the design session to place intelligent annotation notes on features and 

geometry, in the plan, profile, and cross section views. 

The following InRoads files need to be created for the HEC-RAS project design: 

Projects (*.rwk) - This file contains directory and file information for loading and saving InRoads 

data files.  Once the project file is open, all of the specific project files are also opened.   

Geometry Projects (*.alg) – This file contains coordinate geometry and alignment information 

for a specific geometric project. 

1.2 Resource File Storage Location 
The latest versions of all V8i resource files will be kept in the workspace under InRoads_V8i 

_RSC.  Before starting an InRoads project, copy the necessary files from the workspace into the 

designated folder.  Resource files for Hydraulic and Drainage users are copied into the Hydro 

discipline folder within the project container. 

 

V8 _Environment folder (W:\Workspace\InRoads_V8i_RSC) holds all of the resource files 

needed to run InRoads Select Series with the V8 level structure.  
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1.3 Starting the InRoads Application 
 
Using Window Explorer: CTDOT users should ensure the W:\drive is mapped (CTDOT_V8 

Workspaces > Workspace). If not mapped, please contact Helpdesk via email or phone 

extension 3500, option 1.  

Other users should go to the ConnDOT webpage:  ConnDOT: CTDOT - SELECTseries DDE and 

follow the instructions. 

1.3.1 LAB – 1 Starting HEC-RAS InRoads Project 

 
A. Before resource files can be copied into the Hydro project directory an InRoads and HEC-

RAS folder need to be created.  Browse to your specific project folder and create in the 

Hydro folder two subfolders; one named InRoads, another named HEC-RAS.  For this lab 

use: 999_StudentXX_2007 or create a project folder on your computer’s D-drive. 

B. In Windows Explorer, browse to the workspace folder V8 Workspaces > Workspace > 

InRoads_V8i _RSC\V8_Environment.  From there copy the following files to the InRoads 

project folder you just created:  

CT_civil.XIN  

CT_notes.dft 

HW_typicals.itl  (only needed when creating proposed features)  

 

C. For this lab copy to the following folders:  \999_Student##_2007\Hydro\InRoads (or to the 

folder you created on your computer).  

D. Double Click on the Accounting icon located on your desktop. 

 

    Windows 7 

E. Within the CT DOT Accounting Menu select Run Program: (1), choose MS 8i Hydraulics 

(Highway).  Select the project number for your project from the Available Accounts (2) and 

then highlight it within the Frequently Used Accounts (3).  Select the correct Resource Type 

(4) and click on Start (5) button, see Figure 1. 
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Figure 1 - Accounting Menu 

F. The first time into MicroStation V8i follow the CTDOT-IR-V8i Guide.  When the 

MicroStation Manager opens, select the project number (for this lab:  

999_Student##_2007) or the project on your hard drive.  Browse to the Hydro folder and 

create a 3D design file in MicroStation. 

G. In the MicroStation Manger window, select the new file icon (Figure 2).  Click on the 

Browse button to select a 3D seed file.  Select and open the following seed file: 

CTDOT_V8_Workspaces\Workspace\Standards\seed\CT_Design_3D_V8i.dgn. 

 

Figure 2 - New File 
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H. Type in a file name, for this lab: Ex_Channel and click on Save.  Now double-click the file to 

open it. 

I. Reference in the Survey file and the Highway design file if needed.  For this lab we reference 

in the survey file only.  In MicroStation click on References icon, click on Tools > Attach… 

Browse to the survey directory for your project and click on the survey dgn file.  Click open.  

For this lab:  In the survey folder select SV_D1_0123_4567_GRN.dgn.  Select no nesting and 

click off raster, click OK.  Close the References box, see Figure 3. 

 

Figure 3 Attach Reference File 

J. In the MicroStation window click on Fit View.   Open Level Display  and turn 

off Levels in the survey file that are not needed, such as border and various texts.  Repeat 

these steps with the highway design file if attaching, not needed for this lab.  Close the 

Level Display box.   
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K. In MicroStation click on File > Save Settings.  This saves the settings and views for when you 

reopen this file the next time. 

L. Open InRoads.  In the MicroStation menu bar, select Applications > InRoads Group > 

Activate InRoads Suite, see Figure 4. 

 

Figure 4 - Open InRoads 

1.4 InRoads Interface and InRoads Explorer Windows 
When the InRoads application is opened, the InRoads Explorer will appear.  Right-Click in 

the gray space within the menu bar to open the shortcut to the LOCKS tool bar.  See the 

CTDOT-IR-V8i Guide for further explanations. 

 

Figure 5 - Locks 

1.5 Project Defaults and Options for HEC-RAS InRoads Project 
An organized work environment along with a standardized file management system 

provides a consistent way to maintain digital design data.   

To ensure file integrity, the correct project files must not only be used, but also 

maintained and updated.   

InRoads users must master file management techniques for all InRoads design and data 

files.  By setting up the project defaults and creating a project file, users can quickly load all 

files needed for project design.  Additionally, the project file helps coworkers load and 

analyze current design data.   

The Project Defaults command is used to open resource files including the preferences file 

(.xin), Storm and Sanitary files, drafting file, and the master item database.  This command 

is also used to set up default directories for all file types that can be accessed through the 
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File/Open and File/Save As dialog boxes.  These include Project (.rwk), Surface (.dtm), 

Geometry (.alg), and Typical Section Library (.itl); see the CTDOT-IR-V8i Guide for further file 

types.  All other files, which are opened or saved throughout the InRoads program, use the 

Project Default Directory setting.  The project default file directories are stored in the 

computer’s registry on the local hard drive.  

 The automated method based on variables, will not be used for HEC-RAS InRoads 

projects.   See the CTDOT-IR-V8i Guide for further assistance. 

 The conventional method allows each project to have its own Configuration Name 

based on hard-coded paths.  When a particular configuration is saved and users exit 

the dialog, that configuration is remembered as the "Current" configuration. The 

next time InRoads is accessed all the directory paths are set according to the last 

configuration used.  If the project has been changed, users will need to select the 

corresponding project configurations when opening a project.  This means a 

configuration name will be needed for every project that the user is working on. 

1.5.1 LAB – 2. A   Setting Up InRoads Files   

A. Click to File > Project Defaults on the InRoads Main Menu.  See Figure 6. 

B. Click on the New button and a new dialog box will appear, type in your project 

number (XXX_XXXX) – for this lab type in Hydro-1 for the configuration, click OK to 

save. 

C. Click the cursor in the Preferences (*.xin) box and click the Browse button.  The 

Open box will appear. Browse to the location of the CT_ civil.xin file that was 

previously saved into the Hydro folder, click Open, Repeat for Drafting Notes. 

D. Set Default Directory Paths, click the cursor in the Project Default Directory and click 

the Browse button.  The Open box will appear.  Browse to the location where the 

InRoads project will be stored, i.e. the project folder InRoads directory. Click Open. 

E. Repeat for all other paths or copy and paste. With the exception on Style Sheet and 

Survey Data (leave blank). 

F. For Style Sheet browse to C:\Bentley_V8i\Civil\InRoads Group V8.11\XML Data\ 

(or where InRoads is installed).  

G. To save the configuration, click the Apply button and then click the Close button. 
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H. Open Project Defaults again to define Discipline Settings.  Under Preferred 

Preference (bottom right of Set Project Defaults) select the required discipline 

name.  Use Highway preferences.  Click Apply, click Close. 

I. From the InRoads Menu Bar select File > Project Options. 

J. Select the General Tab then select the Preferences Button and data point on the 

Highway preference.  Select Load and Close. 

 

Figure 6 - Project Defaults 
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1.6 Setting up Project File (*.rwk) 
The Projects File (*.rwk) is composed of a list of files that pertain to a specific project’s design 

data.  Surfaces, a template library, geometry projects, can all be saved to the projects file. 

When saving project files, the InRoads program places the entire path name in the .rwk file.  If 

any of the files are moved, the .rwk file is invalid. Whenever the .rwk file is loaded, the software 

looks for the associated files in the same directory that the .rwk resides. 

1.6.1 LAB – 2. B   Setting Up InRoads Files   

A. Click File > Open on the InRoads Main Menu.  Change the Files of type to *.itl and select 

HW_typicals.itl.  Click Open  

B. Change the Files of type to *.dtm.  Browse to the projects survey folder and click on the 

needed dtm.  For this lab use 0123_4567ex.dtm.  Click Open and then Cancel. 

C. Create the .alg file (Geometry Project).  This command does not create an actual file, it 

only creates an internal name for the Geometry Project.  It needs to be saved. 

D. Click File > New. Click on the Geometry tab and type in a logical name, for this lab: 

Hydro-1 in the name box, you can add Existing Channel as Description. Click Apply. 

E. Change Type to Horizontal Alignment and type in a logical name, for this lab: Hydro-1, 

set  Style: Ex_CL_Channel, Curve Definition: Arc, Click Apply. 

F. Change Type to Vertical Alignment and type in a logical name, for this lab: Hydro-1, set  

Style: Ex_CL_Channel, Curve Definition: Parabolic, Click Apply.  Click Close.  

 

Figure 7 - Create Geometry Project 

G. Save the .alg (Geometry Project) file.  Click to File > Save > Geometry Project on the 

InRoads Menu Bar. Click on the Active space and select your geometry.  For this lab: 

Hydro-1.  The File name will appear in the File Name Box.  Click Save, and after the file is 

saved, click Cancel. 
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H. Save files in the RWK (Project), see Figure 8.  Click to File > Save As on the InRoads Main 

Menu.  Select the Save as type: Projects (*.rwk).   

I. Click the Options (…) button on the lower right corner of the ‘Save As’ dialog box.  The 

Project Options dialog box will appear.   

J. Click on the Surfaces Tab, click on Add for the Existing surface.  Other surfaces will be 

created later, and checked off under Add and Update. 

K. Click on the Geometry Project Tab, check on Add and Update for the Hydro-1 geometry 

project just created. 

L. Click on the XIN Preferences Tab, check on Add and Update for the CT_civil.XIN saved 

to the project InRoads folder. 

M. Click on Template Library; check Add and Update for the HW_typicals.  Click the OK 

button and the Project Options dialog box will close. 

N. On the Save As dialog box data point in the File name field and type in the name of the 

file e.g. Hydro-1.  Click the Save button and then click Cancel.  

 

Figure 8 - Save *.rwk File 
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Section 2 Surfaces 
A computerized model of a 3-D ground surface is a visual representation of point data. This 

data, in x, y, z numerical coordinates, defines the Digital Terrain Model (DTM), also 

commonly referred to as a surface. 

In InRoads, the DTM remains an integral and important part of a project.  Feature data resides 

in the DTM and can be displayed in plan, profile and cross section view.  Design analysis and 

computations are performed on the data in the DTM.  The Surface tools allow users to place 

features, execute commands, view surface properties, and make design modifications to the 

design surface. 

2.1 Types of DTM Display 
In the InRoads project, surface representation and features can be displayed in three different 

views or modes: 3-D Planimetric, Profile, and Cross Section.   

 3-D planimetric view, commonly referred to as plan, is a top-level aerial view of the 

entire surface.  

 Profile is an extracted side view of the vertical elevation of a surface along an entire 

active horizontal alignment (or just a portion of it).  

 Cross Section is a portion of the roadway/channel model at a specified location. 

Displayed in individual graphic windows, each section shows surface configurations 

perpendicular or at a skew angle to a linear feature, such as the horizontal alignment 

(often the centerline of the channel/roadway).  

Together, these display modes allow users to view, evaluate, and design projects from various 

important perspectives. Objects in the DTM can be represented in one view or all of these 

views.  For further descriptions see the CTDOT-IR-V8i Guide. 

2.2 Features in the DTM 
In InRoads, features are important to the design process.  A feature is a unique instance of an 

item or 3-D entity that is represented in the DTM by lines, points, or text.  A line is actually a 

linear segment.  Points can be represented as symbols or cells.  Annotation is considered text. 

The following are examples of common design features: 

• A single random point 

• A single interior boundary 

• A flowline 
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• A single curb line 

• A single utility (pipe, pole, manhole) 

• A collection of utilities (poles, manholes) 

Therefore, a feature is any single component that is part of the DTM.  Further, for features such 

as random points, users can store more than one random point feature type in a DTM.  This 

flexibility allows users to control the display of the random points in the surface separately 

from other features, such as manholes. 

In InRoads, features can be created or imported into the DTM with a level of “intelligence”.  In 

other words, features know to display themselves as features in InRoads.  Once features are 

defined or modified and displayed, they can be annotated within the design file. 

2.3 Surface Tools 
In InRoads users can easily copy, copy a portion, merge or transform a surface.  Use InRoads 

Help to further discover the various InRoads surface commands. 

2.3.1 LAB – 3  Copy Surface 

A. Before starting this lab the 123_0123ex.dtm file will need to be opened if it is not 

already.  Make sure the existing surface is active, red box around the surface symbol. 

   

B. Make sure the style lock is off.   The style lock will allow the dialog box to appear. 

 

C. On the InRoads Main Menu Bar click on Surface > Triangulate Surface, 

  make sure existing is active. Click Apply and Close.   

D. Click on Surface > View Surface > Triangles.  Click on Preferences… > select Survey > 

Load > Close.  In the View Triangles box select Apply. 

E. Review and check in the MicroStation file the triangles just created to see if all 

necessary data needed for the channel is available. 

F. Turn on Graphic Group in MicroStation and delete the triangles. 
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G. In InRoads click on Surface > Copy Surface.  In the Copy Surface dialog box, select the 

existing surface from the pull-down.  Should be the only surface available.  In the To 

portion for Name type in:  Name: HD_existing, Description: Hydro_existing ground and 

for Preference: existing.  Click Apply and Close. See Figure 9. 

 

Figure 9 - Copy Surface 

H. In MicroStation turn off the survey and highway design (if attached) reference files.  In 

InRoads make sure HD_existing is the active surface.  Click on Surface > View Surface > 

View Contours.     Click Preferences… > Highway > Load > 

Close.  In the View Contours box select Apply. 

I. Turn on the survey reference file with the contour levels on.  The contours just created 

in InRoads should be directly on the contours from the reference survey file.  

J. Delete the contours, turn on Graphic Group and delete.   

K. Save the HD_existing surface.  Right-click on HD_existing > Save As.  Click on Active bar.  

File name should be populated with HD_existing.dtm.  Click on Save and then Cancel.  

L. Click on File > Save As.  Save as type: select Projects (*.rwk), select Hydro-1.rwk 

previously created.  Click on Options…, on the Surfaces Tab click on Add and Update for 

the HD-existing surface.  Click OK.  In the Save As dialog box click Save.  Question: File 

already exists, do you want to replace?  May come up, Click Yes.  Then Cancel.  Also see 

Figure 8. 

2.4 Creating Horizontal Alignment 
For InRoads to develop cross sections and profile, a horizontal alignment must be present or 

created.  The user should use MicroStation first to place lines for the existing channel centerline 
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alignment.  When the graphical solution is developed the InRoads Horizontal Curve Set tools 

should be used to create a Horizontal alignment for the channel. 

2.4.1 LAB – 4 Creating Horizontal Alignment 

A. In MicroStation select Hydraulics line style HH-Hydrology-MISC-notes.  Activate the 

Place SmartLine command.  In the View window place a line in the center of the existing 

channel (start from downstream to upstream) for the entire length of the channel.  

Zoom in as necessary.  

B. Toggle Off AccuSnap. >> Toggle On ACS Plane.  In AccuDraw ‘Z’ direction type in 0.00, Hit 

Enter.  Start the smart line command.  These steps help keep the line on a one elevation 

(0.00) 

C. Check the line just placed and modify as necessary. 

D. Turn off survey reference file. 

E. In InRoads select the Geometry tab.  Make the previously created Horizontal Alignment 

Hydro-1 active. 

F. Create the horizontal alignment.  Click on Geometry > Horizontal Curve Set > Add PI. 

(Figure 10 

 

Figure 10 - ADD Horizontal PI 

 Starting from downstream to upstream.  Data point at each change of direction on the 

smart line placed in MicroStation.  At the end of the smart line, right-click twice once to 

end the alignment and second to end the Add PI command. 

G. Now in MicroStation delete the horizontal graphic placed with SmartLine and the 

InRoads alignment, make sure Graphic Group is on. 

H. Redisplay the horizontal alignment.  Select Geometry > View Geometry > Active 

Horizontal. 
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I. Set Stationing.  Click on Geometry > Horizontal Curve Set > Stationing.  In Stationing 

dialog box select Hydro-1 for Horizontal Alignment.  Starting Station 10+00.  Apply and 

Close. 

J. Apply Stationing.  Geometry > View Geometry > Stationing.  Click on Preferences.. > 

Highway > Load > Close.  Pick Hydro-1 from Horiz. Alignment pull-down.  Click on 

Limits.  Click off Cardinal Stations.  Click Apply and Close. 

K. If you want to edit the horizontal alignment, you can use the move, insert and delete PI 

commands.  Make sure you delete the graphics and redisplay the alignment and 

redisplay the stationing. 

2.5 Creating and Importing Surfaces Features 
After the horizontal alignment is established as the centerline of the channel the left and right 

bank and left and right overbank of the channel need to be added to the HD_existing dtm.   This 

again will involve MicroStation and InRoads commands. 

2.5.1 LAB – 5  Creating and Importing Surface Features 

A. In MicroStation make sure accusnap is OFF and the ACS plane lock is ON, (Figure 11).   

 

Figure 11 - Snaps & Locks 

B. Select the level HH-Hydraulics-L-Chnl Bnk, select the smartline drawing command and 

place a line in the MiocroStation view for the left bank and left overbank from down-

stream to up-stream (Figure 12).  Repeat these steps for right bank and right overbank 

using level HH-Hydraulics_R-chnl Bnk.  Turn off the survey file.   

 

 

Figure 12 - Levle Symbology & Smart Line Command 



Connecticut Department of Transportation Workflow for InRoads Export to HEC-RAS 

Issued August 2014  Page 19 of 29 
 

C. In InRoads making sure HD_existing is active.  Click on File > Import > Surface.  In the 

Import Surface dialog box click on the From Graphics Tab.  Select for Surface: 

HD_existing, Load From: Single Element, Elevations: Drape Surface, Intercept Surface: 

HD-existing.  Select for Features: Toggle on Use Tagged Graphics Information, Feature 

Style: select from drop-down Ex_LT_Ch_Bank, type the same name into the space for 

Seed Name, Point Type should be set to Breakline.  Click Apply; Figure 13. Follow the 

command prompts in the MicroStation command prompt bar.  Data Point on the Left 

Channel Bank line drawn in MicroStation.  Accept the line or Reject if you picked the 

wrong line. 

 

 

Figure 13 - Import Surface 
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D. Repeat these steps for the following features: Ex_LT_Ch_OverBank, Ex_RT_Ch_Bank 

and Ex_RT_Ch_OverBank. 

E. Close the Import Surface dialog box; Figure 13. 

F. Click on Surface > View Surface > Features.   In the View Features dialog box select each 

feature line just imported into the surface.  Make sure HD_exisiting is the selected 

surface.  From Features: select Ex_LT_Ch_Bank and click Apply.  A line should appear in 

the MicroStation window over the line drawn for the existing left channel bank.  Repeat 

for the other features:  Ex_LT_Ch_OverBank, Ex_RT_Ch_Bank and Ex_RT_Ch_OverBank; 

see Figure 14 

 

Figure 14 - View Features 

G. Re-Triangulate the surface.  Click on Surface > Triangulate Surface, select HD_existing, 

click Apply and Close.  

H. Redisplay the triangles.  Select Surface > View Surface > Triangles.  In the View Triangles 

select HD_existing.  Preferences… select Highway, click Load and close.  Click Apply and 

Close. 
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I. In MicroStation view you will see that the triangles break at the bank lines.  Delete the 

triangles. 
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Section 3 Profile and Cross Sections 
To view a profile or cross sections of your channel in InRoads a horizontal alignment is 

necessary.  With the horizontal alignment active InRoads can create a profile and cross sections 

at specified intervals. 

3.1 Profile 
A profile is a view generated along a defined horizontal geometry. 

3.1.1 LAB – 6 Profile 

A. Zoom out of the plan view in MicroStation, enough room is needed to place the profile. 

B. In InRoads select > Evaluation > Profile > Create Profile.    

C. Make sure Highway preferences are active.  Select HD_existing for Surfaces.  Source > 

Window and Data.  Click Apply.   

D. In MicroStation select the location you want to place the profile and data point.  A 

profile will be placed graphically in MicroStation. In our example draw the box culvert or 

display drainage structures.  See Figure 15. 

E. Close the Create Profile box. 

 

Figure 15 - Existing Profile 
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3.2 Cross Sections 
Cross sections are used to display surfaces and features in a vertical plane.  Normal cross 

sections are cut at a specified interval perpendicular to the channel geometry (horizontal 

alignment). 

3.2.1 LAB -7 Cross Sections 

A. Zoom out of the plan and profile views in MicroStation, enough room is needed to place 

the cross sections.   

B. In InRoads select > Evaluation > Cross Section.  In the Cross Sections dialog box load the 

Highway preferences if not already loaded.   

C. Open the Create Cross Section folder, in General select Window and Data, Interval: 50 

or what best suits your need.  Select HD_existing for Surfaces.  Click Apply.  In 

MicroStation select a location and data point on it.  Cross Sections will be placed 

graphically in MicroStation. See Figure 16. 

 

Figure 16 - Single Cross Section 

D. Close the Create Cross sections box. 

E. You can easily view the cross sections just created.  Select Evaluation > Cross Section > 

Cross Section Viewer.  Under Cross Section Set: select the set you want to review, for 

this lab Hydro-1.  Select 1.5 as Zoom Factor, select the view window you want to view 
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the sections in (for this lab 1) do the same for Plan View.  For Movie Mode 0.5 sec. as 

time interval and click Run.  Each cross section will be viewed for 0.5 sec.  Click Close.  

This allows you to get a general view of the channel cross section. 

 

Note: The cross sections created with InRoads are not necessarily the cross sections you will use 

for the HEC-RAS model. 
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Section 4 HEC-RAS Sections 
When you review the channel in plan view, profile and cross section you can determine where 

the HEC-RAS sections should be cut.  They may not follow the InRoads cross sections. 

4.1 Create HEC-RAS Sections 

4.1.1 LAB – 8  Develop HEC-RAS Sections 

A. In MicroStation zoom in to the horizontal alignment for the channel.  

B. Select smart line command and select level HH-Hydraulics-X-sect. 

 

C. Place lines in the plan view of the channel were you want HEC-RAS cross sections. 

 

D. In InRoads select Evaluation > Hydrology and Hydraulics > Generate Water Surface 

Data.  If Hydrology and Hydraulics is not available from the pull-down, select Tools > 

Application Add-Ins > Hydrology and Hydraulics Add-In. Click OK.  Now go to 

Evaluation etc.  
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E. Select the Cross Sections Tab and for Source choose Selection Set.  Leaving this dialog 

box open. See Figure 17. 

F. In MicroStation use the Element Selection tool and select all the cross section line 

strings you placed. 

G. Back in the InRoads Generate Water Surface Data dialog box.  Select the following: 

Surface > HD-existing, Alignment: > Hydro-1, Create: > Section Data, Section Format: > 

HEC-RAS, Maximum Points: 99. 

H. Enter the Stream Id and Reach ID that you want to use in the HEC-RAS model. For this 

lab use: Stream-1 and Reach-1 respectively. 

I. In the dialog box under Banks, click on the crosshair button for the Left Bank: and 

select the feature line for the left bank in the MicroStation window.  Repeat for the 

Left Over Bank, Right Bank and Right Over Bank. 

J. Click Apply.  The Save As window will open.  Save the *.geo file in the HEC-RAS folder. 

For this lab save as Hydro-1.geo. 

 

Figure 17 - Generate Water Surface Data 
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K. You can also extract HEC-2 data.  Under Section Format choose HEC-2, click apply and 

save the data file.   

L. If you have data for starting flow, water surface elevation, manning’s coefficients click 

on the Job Control tab in the Generate Water Surface data and enter the data you have, 

not applicable for HEC-RAS. 

M. Close the Generate Water Surface dialog box.  In InRoads select File > Save As > ;  select 

Projects (*.rwk) and click on Options….  In the Project Options dialog box make sure 

Add and Update are selected for HD_exsiting surface and Hydro-1 geometry project.  

Save the project. For this lab save as Hydro-1.rwk. 

N. You are now finished with the InRoads portion.  You can exit InRoads and MicroStation 

if you want, ensure your work is saved. 
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Section 5 Import InRoads Data to HEC-RAS 
As stated earlier – it will probably be more efficient to edit channel banks and River Station 

names within HEC-RAS rather than rerunning Inroads.   

Open HEC-RAS from your desktop, Double -Click the icon. 

 

A. Click on File > New Project.  Type in Hydro-1 existing as Title, this populates the File 

Name box with Hydro-1 existing.prj.  Browse to your project directory’s HEC-RAS folder. 

Click OK to create the project and folder.   

B. Click on Edit/Enter geometric data, Click on File > Import Geometry data > GIS Format. 

 

C. Select the Hydro-1.geo file created using InRoads.  Click OK. Select US Customary units.  

Click Finished - Import Data. 

D. The channel center line with the HEC-RAS cross section lines should appear in the 

Geometric Data box (see Figure 18).  

E. Click on the cross section icon and the Cross Section Data box opens.  Work the data as 

needed. 

F. Should you need proposed channel data, request the proposed surface (Design surface) 

from Highway Designer and repeat all the steps using proposed symbology: 

Pro_CL_Channel, Pro_Hydro_XSC, Pro_LT_Cha_Bank, Pro_LT_Cha_Over_Bank, 

Pro_RT_Cha_Bank and Pro_RT_Cha_OverBank. 
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Figure 18 - Geometric Data box 

 

 

Figure 19 - Cross Section Data box 


	Section 1 Starting HEC-RAS/InRoads Project
	1.1 InRoads File Types
	1.2 Resource File Storage Location
	1.3 Starting the InRoads Application
	1.3.1 LAB – 1 Starting HEC-RAS InRoads Project

	1.4 InRoads Interface and InRoads Explorer Windows
	1.5 Project Defaults and Options for HEC-RAS InRoads Project
	1.5.1 LAB – 2. A   Setting Up InRoads Files

	1.6 Setting up Project File (*.rwk)
	1.6.1 LAB – 2. B   Setting Up InRoads Files


	Section 2 Surfaces
	2.1 Types of DTM Display
	2.2 Features in the DTM
	2.3 Surface Tools
	2.3.1 LAB – 3  Copy Surface

	2.4 Creating Horizontal Alignment
	2.4.1 LAB – 4 Creating Horizontal Alignment

	2.5 Creating and Importing Surfaces Features
	2.5.1 LAB – 5  Creating and Importing Surface Features


	Section 3 Profile and Cross Sections
	3.1 Profile
	3.1.1 LAB – 6 Profile

	3.2 Cross Sections
	3.2.1 LAB -7 Cross Sections


	Section 4 HEC-RAS Sections
	4.1 Create HEC-RAS Sections
	4.1.1 LAB – 8  Develop HEC-RAS Sections


	Section 5 Import InRoads Data to HEC-RAS

