Training Guide Update Instructions

Replacement/Additional Pages, June 2014

Cover page through table of contents

All chapters
Training Guide

Release 2.13a

June 2014

Last Updated
June 2014

Prepared By

5700 SW 34th Street, Suite 1235, Gainesville, Florida 32608-5371 • Phone: (352) 381-4400 • Fax: (352) 381-4444 • info@infotechfl.com • www.infotechfl.com
FieldBook and FieldManager are registered trademarks of Info Tech, Inc. and represent products of Info Tech, Inc. and the Michigan Department of Transportation.

FieldNet is a trademark of Info Tech, Inc. and represents a product of Info Tech, Inc.

FieldBuilder and FieldPad are trademarks of Info Tech, Inc. and represent products of Info Tech, Inc. and the Michigan Department of Transportation.

AASHTO Trns•port, the AASHTO Trns•port logo, the AASHTOWare logo, Trns•port Estimator, the Trns•port Estimator logo, Trns•port Expedite, the Trns•port Expedite logo, Trns•port FieldBook, the Trns•port FieldBook logo, Trns•port FieldBuilder, the Trns•port FieldBuilder logo, Trns•port FieldManager, and the Trns•port FieldManager logo are registered trademarks of AASHTO.

AASHTOWare Project, AASHTOWare Project Estimator, AASHTOWare Project Expedite, AASHTOWare Project FieldManager, AASHTOWare Project FieldBook, AASHTOWare Project FieldBuilder, and AASHTOWare Project FieldNet are trademarks of the American Association of State Highway and Transportation Officials (AASHTO).

Estimator is a propriety product of Info Tech, Inc.

Other product names are trademarks or registered trademarks of their respective owners.

Copyright © 2014, Info Tech, Inc. All rights reserved. Printed in the United States of America. This document or parts thereof may not be reproduced in any form without written permission of Info Tech, Inc.
Contents

1. Introduction ............................................................................................................... 1-1
   1.1 Using This Training Guide ............................................................................... 1-1
       1.1.1 Documentation Conventions ................................................................. 1-1
   1.2 Using the Mouse and Keyboard ....................................................................... 1-2
   1.3 Terminology ..................................................................................................... 1-3

2. Getting Started .......................................................................................................... 2-1
   2.1 Logging On to Estimator .................................................................................. 2-1
       2.1.1 Starting Estimator ................................................................................. 2-1
       2.1.2 Entering Your Username and Password ............................................... 2-2
       2.1.3 Updating the Current Catalog ............................................................... 2-3
   2.2 Changing Your Estimator Password ................................................................ 2-4
   2.3 Understanding Estimates .................................................................................. 2-5
   2.4 Understanding Catalogs................................................................................... 2-5
   2.5 Understanding the Relationship Between Estimates and Catalogs .................. 2-6
   2.6 Working with Estimator Windows ................................................................... 2-6
       2.6.1 Activating a Window ............................................................................ 2-6
       2.6.2 Arranging Windows .............................................................................. 2-8
       2.6.3 Reviewing the Parts and Types of Estimator Windows ...................... 2-10
       2.6.4 Read-Only Windows ........................................................................... 2-11
       2.6.5 Catalog and Code Table Windows ...................................................... 2-11
       2.6.6 Dialog Boxes ....................................................................................... 2-12
   2.7 Opening an Estimate ....................................................................................... 2-12
   2.8 Undo and Redo Commands ............................................................................ 2-13
   2.9 Saving an Estimate ......................................................................................... 2-14
       2.9.1 Using Valid File Names ...................................................................... 2-15
       2.9.2 Using the Auto Save Utility ................................................................ 2-15
       2.9.3 Using the Archive Utility .................................................................... 2-17
   2.10 Printing an Estimate ..................................................................................... 2-18
       2.10.1 Printing the Estimate Funding Summary Report .............................. 2-20
   2.11 Opening a Catalog ........................................................................................ 2-21
   2.12 Closing an Estimate or Catalog .................................................................... 2-21
   2.13 Exiting Estimator .......................................................................................... 2-22

3. Working in Estimator ............................................................................................... 3-1
   3.1 Estimator Menus ............................................................................................... 3-1
       3.1.1 File Menu ............................................................................................ 3-1
       3.1.2 Edit Menu ........................................................................................... 3-1
       3.1.3 View Menu ........................................................................................ 3-2
3.1.4 Tools Menu ................................................................. 3-2
3.1.5 Window Menu ............................................................. 3-2
3.1.6 Help Menu ................................................................. 3-2
3.1.7 Enabled and Disabled Commands ................................. 3-2
3.2 Getting Help ................................................................. 3-3
3.3 Setting Up Your Working Environment .............................. 3-3
  3.3.1 Setting Preferences .................................................... 3-3
  3.3.2 The General Tab ........................................................ 3-4
  3.3.3 The Numeric/Rounding Tab ......................................... 3-6
  3.3.4 The URLs Tab ............................................................ 3-7
  3.3.5 The Internet Tab ........................................................ 3-8
  3.3.6 The Proxy Tab ........................................................... 3-9
  3.3.7 The Tree/Field Labels Tab .......................................... 3-10
  3.3.8 The Catalog Tab ........................................................ 3-11
Please see Section 4.10 for information about the Verifications Tab. 3-13
3.4 Navigating and Displaying Estimates and Catalogs ................ 3-13
  3.4.1 Hide/Show Columns .................................................. 3-14
  3.4.2 Show/Hide Tree View ............................................... 3-16
  3.4.3 Expand and Collapse All Tree View ............................. 3-18
3.5 Navigating With the Directional Arrows .............................. 3-19
3.6 Using the Expression Builder Window .................................. 3-20
3.7 Using Formulas from Code Table FORMULAS in the Expression Builder.. 3-21
4. Creating an Estimate .......................................................... 4-1
  4.1 Creating a New Estimate ................................................ 4-1
  4.2 Assigning Estimate Preferences ....................................... 4-4
    4.2.1 Setting the Estimate Options ................................... 4-4
    4.2.2 Maintaining the Estimate’s Users List ....................... 4-5
  4.3 Entering Information in the New Estimate Header Window .... 4-6
  4.4 Entering Group Information on the Groups and All Items Tabs .... 4-13
    4.4.1 Entering Information on the Groups Tab ..................... 4-14
    4.4.2 Entering Group Information on the All Items Tab ........ 4-16
  4.5 Adding Items to the Estimate .......................................... 4-19
    4.5.1 Entering Items on the Groups Tab .............................. 4-20
    4.5.2 Adding Items on the All Items Tab .............................. 4-21
    4.5.3 Adding an Item Using the Drop Down Menu ................ 4-23
    4.5.4 Adding an Item Using the Drag and Drop Functionality ... 4-24
    4.5.5 Adding Items Using the Find Item Window ................ 4-27
  4.6 The Estimate So Far ..................................................... 4-29
  4.7 Inserting and Moving Items Across Groups ....................... 4-29
    4.7.1 Moving an Item ...................................................... 4-30
    4.7.2 Inserting an Item ..................................................... 4-32
    4.7.3 Deleting an Item ..................................................... 4-33
    4.7.4 Deleting a Group .................................................... 4-34
  4.8 Working With Price Bases .............................................. 4-34
    4.8.1 Viewing an Item’s Price Basis ................................. 4-35
    4.8.2 Changing the Price Basis ........................................... 4-35
4.8.3 Adding a Price Basis ................................................................. 4-38
4.8.4 Toggling a Price Basis Active/Inactive ...................................... 4-40
4.9 Using a Percentage of the Estimate as a Price ............................... 4-40
4.10 Verifying the Estimate ................................................................. 4-42
4.11 Printing the Estimate ................................................................. 4-46

5. Other Estimator Features ............................................................... 5-1

5.1 Opening an Archived Estimate ...................................................... 5-1
5.2 Refining Estimates ........................................................................ 5-2
  5.2.1 Renumbering Estimate Items .................................................... 5-2
  5.2.2 Updating Price Information ......................................................... 5-5
5.3 Sorting in Estimator ....................................................................... 5-6
  5.3.1 Sorting Groups ....................................................................... 5-6
  5.3.2 Sorting Items ........................................................................ 5-6
  5.3.3 Sorting in the Current Catalog .................................................. 5-8
  5.3.4 Sorting Code Table Values ......................................................... 5-9

6. Working With Catalogs and Code Tables .......................................... 6-1

6.1 Working With Catalog Information .................................................. 6-1
6.2 Copying the Current Catalog .......................................................... 6-2
6.3 Switching the Current Catalog ......................................................... 6-3
6.4 Searching for Catalog Elements ...................................................... 6-4
  6.4.1 The Find Command .................................................................. 6-4
  6.4.2 Finding a Price Basis in an Estimate ............................................ 6-5
6.5 Scheduling Catalog Imports ............................................................. 6-7

7. Navigating Through Estimator .......................................................... 7-1

7.1 The Tree Area ................................................................................ 7-1
7.2 The Go Button ............................................................................... 7-1
  7.2.1 Using the Go Button in an Estimate ............................................ 7-1
  7.2.2 Using the Go Button in a Current Catalog ................................. 7-3
7.3 Navigation Arrows ........................................................................ 7-7
  7.3.1 Using the Navigation Arrows in an Estimate .............................. 7-8
  7.3.2 Using the Navigation Arrows in a Catalog ................................. 7-11
1. Introduction

AASHTOWare Project Estimator™ helps agencies estimate the cost of a construction project using cost-based, bid-based, and reference-based estimation methods. Estimator facilitates estimation data gathering and relieves the tedium of estimation activity. It also provides consistent and flexible methods for estimation.

Estimator can be used in conjunction with PES®, AASHTOWare Project Cost Estimation™, AASHTOWare Project BAMS/DSS™, and other applications.

1.1 Using This Training Guide

This guide offers step-by-step instruction on the most useful and frequently used Estimator functions. Windows training or experience is a prerequisite for Estimator. If you have never used computers or do not know how to use Windows, read the documentation that came with your Windows software before beginning this guide.

If it is relevant, the beginning of each chapter tells you what privileges are needed to complete the chapter. For example, no special privileges are needed to create an estimate. However, if you want to import a catalog, you need Catalog Import and Edit privileges.

1.1.1 Documentation Conventions

This guide uses various techniques to help identify important information. Small caps identify keys to press and buttons to click that invoke actions. An example of this is “Press the ALT key.” Tab names are also shown in small caps, such as the PAGE 1 tab shown in Figure 1-1.
Menu choices and user entries (information to enter using the keyboard) are shown in bold text, such as “Choose Verify Estimate from the Edit menu.”

Important terms are identified by italics.

**Note:** Important notes are indented from both the right and left margins and flagged with small note icons. Notes contain extra information that may help you work more efficiently or understand a process more fully.

**Caution:** Cautions look very similar to notes, but are flagged with an exclamation point icon. Read all cautions; they contain important information that should not be disregarded.

### 1.2 Using the Mouse and Keyboard

You can use the mouse or keyboard to activate Estimator commands and windows. If you are unfamiliar with working in Windows or with a mouse, please read the manuals that came with your Windows operating system.

In dialog boxes, the **TAB** key moves the cursor from field to field. The **TAB** key also moves from dialog box fields to the command buttons. When a command button is selected, a dotted line surrounds the button label. Press **ENTER** to activate a command button that displays the dotted line. You must always use the keyboard to type in field entries.

Many menu commands list keys next to each command. These **shortcut keys** are keystroke combinations you can quickly press to invoke a command. As you become more familiar with Estimator, you can use the shortcuts for the commands you use most frequently. Shortcut keys are defined on the menu where the action is located. For
example, to use the shortcut key to cut text, you would press CTRL + X. To access the File menu, you would press ALT + F.

1.3 Terminology

Construction cost estimation comes with its own jargon. Becoming familiar with the terms used for Estimator will help you understand how the software operates and will make this training guide easier to use.

- **Bid-based Price**: Unit price for a work item that is derived in Estimator using one of three estimation methods; in order of priority, they are regression, averages, and historical/reference price.
- **Bid History Data Catalog**: Stores data in the catalog that makes up the bid histories.
- **Catalogs**: The “information banks” of the system, which store core information for use in estimation. Catalogs consist of four sections: The Standard Item Catalog, Price Bases Catalogs, Rate Catalogs, and Code Table Catalogs.
- **Code Table Catalogs**: Catalogs that contain information used to fill in drop-down list options. If you have the correct permissions, these values can be entered manually or imported from another source.
- **Cost Sheet**: Utility used to tally the costs of the equipment, labor, and materials needed to complete an item. Cost sheets are used only for cost-based estimation.
- **Equipment**: Any mechanical tool or contrivance that must be bought, rented, or leased.
- **Estimate**: Estimates, which are made up of estimate header information and group and item lists, store the items used in a construction estimate, the price bases, and supporting information about the contract.
- **Grid Area**: Usually in the right pane of a catalog or estimate window, the grid area displays a list of the entities selected in the tree area.
- **Group**: An overall heading for related items in an estimate.
- **Group List**: A list displayed in the grid area of the GROUPS tab.
- **Header Information**: General information about the element with which it is associated. For an estimate, this includes the spec year, highway type, and county; for an item, this includes the unit price and system of measurement; for a catalog, this includes the name and description.
<table>
<thead>
<tr>
<th><strong>Item</strong></th>
<th>Stored in the Standard Item Catalog, items are the basic units of an estimate.</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Item List</strong></td>
<td>For an estimate, the item list is a list of all the items that comprise the estimate. For the Standard Item Catalog, it is a list of all the items in the catalog.</td>
</tr>
<tr>
<td><strong>Labor</strong></td>
<td>For costing purposes, labor is defined as work performed by people.</td>
</tr>
<tr>
<td><strong>Material</strong></td>
<td>Any quantifiable physical entity which is consumed in the performance of an item of work (excluding power or fuel for equipment).</td>
</tr>
<tr>
<td><strong>None</strong></td>
<td>A privilege level of None means that the user can not access a new estimate.</td>
</tr>
<tr>
<td><strong>Owner</strong></td>
<td>A privilege level of Owner means that the user can edit a new estimate as well as change information on the estimate's User list.</td>
</tr>
<tr>
<td><strong>Price Bases Catalogs</strong></td>
<td>The Cost Sheet, Bid History, and Reference Price Catalogs comprise the bases of how the estimate can be estimated.</td>
</tr>
<tr>
<td><strong>Privileges/Permissions</strong></td>
<td>The level of access to a new estimate or editing ability for catalogs. The access levels for an estimate are owner, user, write, read, and none.</td>
</tr>
<tr>
<td><strong>Rate Catalogs</strong></td>
<td>The Equipment Rate, Labor Rate, and Material Rate Catalogs comprise the information for the Cost Sheet Catalog.</td>
</tr>
<tr>
<td><strong>Read</strong></td>
<td>A privilege level of Read means that a user can access a new estimate, but not make any changes to it.</td>
</tr>
<tr>
<td><strong>Reference Price</strong></td>
<td>A price used as the basis for estimating an item’s cost. Reference prices may be stipulated directly or they may be derived from formulas.</td>
</tr>
<tr>
<td><strong>Spec Year</strong></td>
<td>A base year used for pricing purposes. The spec year is used to ensure that all pricing information within an estimate is correct for the time period encompassed by the estimate.</td>
</tr>
<tr>
<td><strong>Standard Item Catalog</strong></td>
<td>Catalog that contains information of the items that can be used in an estimate. These values can be entered manually or imported from another source.</td>
</tr>
<tr>
<td><strong>Super-User</strong></td>
<td>A user granted special privileges. A super-user has automatic owner access to new estimates, can edit and import new catalogs, and can change fields for a user in the Users Table.</td>
</tr>
<tr>
<td><strong>Tree Area</strong></td>
<td>Usually in the left pane of a catalog or estimate window, the tree area displays all the entities that comprise an estimate or catalog.</td>
</tr>
<tr>
<td><strong>User</strong></td>
<td>A privilege level of User means that a user can edit a new estimate and make changes to the estimate's User list, but not change any fields for a user designated as an Owner.</td>
</tr>
<tr>
<td><strong>Users List</strong></td>
<td>For Estimator, it is a list of all users, their real names, and new estimate and catalog access permission. For an estimate, it is a list of all users with privileges to at least read the estimate.</td>
</tr>
<tr>
<td><strong>Write</strong></td>
<td>A privilege level of Write means that a user can edit a new estimate.</td>
</tr>
</tbody>
</table>
2. Getting Started

This chapter describes how to log on to Estimator, complete basic tasks, and exit the software. It also explains the differences between estimates and catalogs and how they work together.

Estimator makes sophisticated, technologically advanced highway construction estimation easy. Estimation typically involves an unwieldy quantity of information that must be logically divided to organize the estimation process. You interact with Estimator through two basic elements: windows and commands. Windows display information and sometimes require you to enter information. Commands displayed in menus at the top of the screen or issued through shortcut keys and command buttons tell Estimator what function you want to perform. Estimator uses windows and commands to help you divide all the information into manageable estimates and catalogs.

2.1 Logging On to Estimator

Your computer must be running Windows when you start Estimator. While Windows is running, you can run Estimator and other Windows-compatible programs.

2.1.1 Starting Estimator

Click the START button on the Taskbar to display the Start menu. Place your mouse pointer over the Programs menu. A list of program icons appears. Locate the Estimator program group, then place your mouse pointer over it. A list of installed components for Estimator appears; yours may be different than the ones displayed in Figure 2-1. Click the Estimator program icon to start the program. You can also create a shortcut to access Estimator.
2.1.2 Entering Your Username and Password

Before you can use Estimator, you must identify yourself as an authorized user. Your system manager assigns you a username and password, which you must enter each time you begin Estimator.

After you start Estimator, the Estimator Login dialog box appears (see Figure 2-2). Dialog boxes are windows Estimator displays to convey information to you or to request information from you.
Estimator displays the name of the last person to access estimate from your particular computer. Enter your assigned user name and password in the appropriate fields. Use the TAB key to advance to the next field. Click the OK button to submit your login information or click CANCEL to cancel the login operation.

In Estimator, User Names are case *insensitive*, which means you can type the letters of your User Name in uppercase or lowercase. Your password is case *sensitive*. You must type in your password the same way each time.

If you type in the incorrect user name or password, Estimator displays this window:

![Invalid User Name or Password Window](image)

Click OK and retype your user name or password.

### 2.1.3 Updating the Current Catalog

Once you successfully log in, you may be presented with an Update Catalog window.
This window may appear if the transportation agency has designed a Web site to hold this information, and if this Web site's URL is entered in the Global Options window (see Section 3.3).

If you want to download the updated catalogs, click YES. If you don't, click NO. You can disable the window by selecting the Disable check box. If you decide to disable the window, make sure you run the command manually.

**Note:** To manually use the Update Catalog command, select **Check for Catalog Updates** from the **Catalog Tools** menu.

Once you choose to update your catalogs, follow the instructions in the Check for Updates wizard. Depending on your Estimator permissions, you may not be able to update the catalog. If this is the case, talk to your system manager about downloading the new catalog updates.

### 2.2 Changing Your Estimator Password

When you first log on to Estimator, you use a system manager-assigned password. You should change this password after the first time you log into Estimator.

Select **Change Password**s from the **Other Tools** menu to change your Estimator password. Estimator displays the Change Password dialog box shown in Figure 2-5.
Enter your old password and your new password twice. If the two entries of the new password are not exactly alike, Estimator displays an error message and you must enter the information again. When the new password has been entered the same way twice, Estimator accepts the new password. You must use the new password the next time you start an Estimator work session.

### 2.3 Understanding Estimates

Estimates in Estimator store all items used in a construction project, their price bases, and supporting information. The Estimate Header, Group List, and Item Lists comprise an Estimator estimate. The Header contains general information about the estimate. The Group List contains groups of items that are related to each other, and the Item Lists are detailed lists of items used in the estimate. The Item List can be viewed for each group on the GROUPS tab, or as one list on the ALL ITEMS tab. Estimator’s interface has been designed to allow estimators to quickly enter items and retrieve information from the Estimator catalogs.

### 2.4 Understanding Catalogs

Construction experience indicates that contract estimation involves a core set of information which is used to develop different estimates. Estimator catalogs are the information banks of the system, storing core information for use in estimation. Estimator catalogs make the often-used data readily available through a well-organized, easy-to-use interface. Estimators can quickly use information from the catalogs in their estimates. The catalog designated as the Current Catalog for a given estimate is the catalog that holds the information from which the estimate is derived.

Each catalog contains several smaller catalogs. These are the smaller catalogs available in each Estimator catalog:

- Standard Item Catalog
- Price Bases Catalogs:
- Cost Sheet Catalog
- Bid History Catalog
- Reference Price Catalog
- Code Table Catalogs
- Rate Catalogs:
  - Material Rate Catalog
  - Equipment Rate Catalog
  - Labor Rate Catalog

The Standard Item Catalog and the Cost Sheet Catalog draw on information from other catalogs. Estimator has an option of updating catalogs that have been updated by your system manager when you restart Estimator.

### 2.5 Understanding the Relationship Between Estimates and Catalogs

The key to understanding how estimates and catalogs relate is to understand how Estimator items are processed.

Items make up the Standard Item Catalog and Estimator estimates. Items consist of specific information and attached price basis information. Each item could have more than one price basis attached to it. Price bases are either retrieved from an Estimator catalog or entered manually.

Items are stored in the Standard Item Catalog. When you wish to use an item in an estimate, you copy it from the Standard Item Catalog into your estimate. Now, instead of dealing with the entire Standard Item Catalog, you are only dealing with the selected items in your estimate.

### 2.6 Working with Estimator Windows

A *window* is a named collection of related catalog or estimate information. Estimator displays catalog, estimate header, catalog information, list, and price basis windows.

#### 2.6.1 Activating a Window

In Estimator, you can open several windows at the same time. The active window is the window in which you are currently working. The active window appears in the
foreground and has a differently colored (usually brighter) title bar. Only the active window receives your keyboard input. If you select **Delete** from the **Edit** menu with the wrong active window displayed, you could delete unintended data. Make sure you know which window is currently active when you issue commands.

A window automatically activates when you open it. It remains active until you open another window or you activate a different open window. The lower portion of the Window menu lists the names of all open windows (a maximum of nine window names appear in the Window menu at one time). A check mark appears next to the name of the active window. Only one window can be active.

![Active Window Displayed With Checkmark](image)

You can activate an inactive open window in one of three ways: by clicking anywhere in the window with a mouse, by pressing **CTRL+F6** until the desired window is activated, or by choosing the name of the window you want to activate from the Window menu.

When you perform one of these actions, Estimator activates the selected window and, if the window was partially or completely hidden behind another window or windows, it reorganizes all the windows on the display screen so that the newly activated window is fully visible.

If ten or more windows are open on the screen at one time, the Window menu includes the More Windows… command. When you select **More Windows** from the **Window** menu, Estimator displays the Select Window dialog box, which lists the names of all open windows (see Figure 2-7).
To activate an open window, select the name of the desired window from the Windows list box and click **OK**.

### 2.6.2 Arranging Windows

You can modify how Estimator displays open windows on the screen. The upper portion of the Window menu contains the commands Tile and Cascade, which let you choose how you want the windows to appear. You can tile the windows either horizontally or vertically.

These commands organize the layout of the open windows. You can select these commands when two or more windows are open.

Select **Cascade** from the **Window** menu to organize the open windows into an overlapping, cascading format. Figure 2-8 illustrates a screen with cascading windows.
Select **Tile Horizontally** from the **Window** menu to organize the open windows so all windows are simultaneously visible on the computer screen. Figure 2-9 shows a screen with the windows tiled horizontally.

![Figure 2-9. Horizontally Tiled Windows](image)

Select **Tile Vertically** from the **Window** menu to organize the open windows so all windows are simultaneously visible on the computer screen with all estimates lined up against the menu bar. Figure 2-10 shows a screen with the windows tiled vertically.

![Figure 2-10. Vertically Tiled Windows](image)
2.6.3 Reviewing the Parts and Types of Estimator Windows

Figure 2-11 shows the main Estimator window and each window component.

This window always appears, even when other windows are also present on the screen. The components of the main window are also found on all other Estimator windows and perform specific functions.

**Control Menu Icon**
Click on the icon in the upper-left corner of the window to pull down or display the Control menu. You can use the Control menu to alter the size, placement, and state (closed or open) of the window. Every window in Estimator has a Control menu icon and a Control menu.

**Title Bar**
In the Estimator window, the title bar displays the name of the program. In other windows, the title bar displays the title of the window, the estimate file name, or both.

**Minimize Button**
The minimize button in the upper right corner of the window reduces the window to an icon, a miniature representation of the window. Estimator displays the icon at the bottom of the screen; the window remains open when it is minimized. To display the window in visible form, double-click on the icon.

**Maximize Button**
The maximize button in the top right corner of the window enlarges the Estimator window to occupy the entire screen area. Click the button again to restore the window to its original size.

**Menu Bar**
The Menu Bar appears across the top of the Estimator window only and displays the names of all of the Estimator command menus.
Working Area  
Estimator data appears in this area in various-sized windows when you issue appropriate commands.

Status Bar  
Shows the status of Estimator during the current task.

Estimator uses a variety of windows to display and record information. The operations you can perform depend upon the window type.

2.6.4 Read-Only Windows

If you do not have permission to edit an estimate or if you do not have edit access to the element you are trying to open, such as a catalog, then the element opens in a read-only window. The words Read Only appear in the title bar of the window or the element has unavailable fields (see Figure 2-12). If you change any information in these elements, you will not be able to save your work.

![Figure 2-12. Estimator Window with Read-Only Access](image)

2.6.5 Catalog and Code Table Windows

You can view each Estimator catalog (Standard Item; the Price Basis Catalogs: Cost Sheet, Bid History, Reference Price; and the Rate Catalogs: Equipment Rate, Labor Rate, and Material Rate) and code table (Work Type, Season, Urban or Rural, County, Units, and Highway Type) in a window after you log on to Estimator. To do this, select Show Open Catalogs from the Catalog Tools menu. To view a different catalog, select Switch Current Catalog from the Catalog Tools menu. Select the catalog you want to make the Current Catalog and click OK. You may need to select View Current Catalog from the View menu again.
2.6.6 Dialog Boxes

*Dialog boxes* are windows that convey information to you or request information from you. To enter information in a dialog box, use the mouse to click in the fields where you want to enter information or use the TAB key to move from field to field. Use the keyboard to enter field values.

![Image of Save Dialog Box]

Figure 2-13. Save Dialog Box

Most dialog boxes have OK and CANCEL buttons. Clicking a button once invokes the command. Click OK to add your entries or CANCEL to exit the dialog box without entering any information.

2.7 Opening an Estimate

Now that you know the parts of Estimator's windows and the difference between estimates and catalogs, we will start a new estimate.

Estimator stores information for your estimates in individual estimate files. You must create a new file for any new estimate or open an existing file to work on an estimate already defined.

To start a new estimate, select **New** from the **File** menu. Estimator opens the estimate header window.

You can open an existing estimate by choosing it from the bottom of the File menu (see Figure 2.14) or by selecting **Open** from the **File** menu and selecting an estimate file name.
If you do not have permission to view a chosen estimate - such as when you do not have read, write, user, or owner privileges for the estimate - Estimator displays this error message:

![Error Message]

Click OK and either open an estimate to which you have access or start a new estimate. If you do not have access to an estimate but think that you need to, contact your system manager.

### 2.8 Undo and Redo Commands

Estimator can undo certain actions or redo actions previously undone. *Undo* is your ability to reverse recent changes. *Redo* is your ability to reintroduce a change that you had undone. You can reverse several edits until the limit of changes is reached, and you can then redo those reversed edits.

The Undo and Redo commands are available for estimates, catalogs, and User Table documents. You can access the Undo command by selecting it from the **Edit** menu. The command displays what action will be undone. You cannot select the Redo command from the **Edit** menu until an Undo command has been issued.
After you use the Undo or Redo command, Estimator automatically displays the affected area of the command. For example, if you add an item to an estimate, and then undo the addition, Estimator places the cursor in the changed field to indicate what changed.

**Note:** Importing a catalog, sorting, resizing a window, or other similar activities cannot be undone with the Undo command.

If you save your work, you can no longer undo or redo any of your previous changes. The Auto-Save function does not prevent you from undoing or redoing changes.

### 2.9 Saving an Estimate

Estimator allows you to work on multiple estimates simultaneously within a single Estimator work session, though you can save and close an estimate at any time.

While you work on an estimate, Estimator retains your work temporarily in the computer, but it does not automatically save your work. You must save open estimates to store them permanently on your computer. Each Estimator estimate is stored in a separate estimate file, which you must name the first time you save it.

To save a new estimate, select **Save As** from the **File** menu. To save an estimate that has already been saved at least once, select **Save** from the **File** menu. When you create a new estimate, the Save command acts as the Save As command. After the estimate is saved for the first time, the Save command acts normally.

If you select **Save As**, Estimator displays the Save As window.

![Save As Window](image)

**Figure 2-16. Estimator Save As Window**

Enter a name for your estimate in the File Name field. Click **Save** to save the estimate.

When you exit Estimator, Estimator reminds you of any estimates you have changed but not yet been saved and gives you a chance to save them.
Click YES to save and close the estimate, NO to close the estimate without saving it, or CANCEL to return to the estimate without saving it.

Save your estimate frequently in case of a power failure or computer malfunction. If a power failure occurs before you save a new estimate, the estimate will be lost. If you have saved your work and a power failure occurs, you will lose only the work you did since the last time you saved the estimate.

2.9.1 Using Valid File Names

Every Estimator file must have a unique name. The file name can include letters, digits, and some special characters. Estimator appends .est to the file name so it can be recognized as an Estimator estimate file. The name you choose should relate to the task to be handled by the estimate so you can recognize which file corresponds to which estimate. You might find it convenient to use the contract number as the file name, such as 2007_0502.est.

2.9.2 Using the Auto Save Utility

The Auto Save utility, if activated, saves your estimate in a temporary folder. Once you save your estimate using the Save command, the temporary folder is deleted and the countdown for the auto save starts again. You can set the Auto Save utility to save your estimate anywhere from zero to every 15 minutes (a zero setting disables the auto save). Setting this function helps you recover newly added estimate information that was not saved in the event of a computer malfunction.

Note: You must first save your estimate using the Save or Save As command before the Auto Save utility can function.

To set the Auto Save utility:

1. Select Global Options from the Other Tools menu. The Global Options tab folder window appears.

2. Locate the Auto Save Interval (minutes) field in the middle of the GENERAL tab.
3. Using the arrows in the field, set the desired auto-save time. This can be anywhere from one to 15 minutes. Set the utility to zero if you do not want auto-saving enabled.

4. Click OK to start the Auto Save utility or CANCEL to set the field back to the original interval.

The Auto-Save utility starts to function after the estimate has been saved the first time using the **Save As** or **Save** command. If you set the Auto Save utility to nine, then Estimator will save your estimate every nine minutes. Once you manually save your estimate, the auto-saved estimate is deleted until the next nine minutes have passed and Estimator again saves your estimate.

You can recover an estimate that was saved with the Auto Save utility if your computer was not properly turned off. To do this, follow the steps below once you restart your computer:

1. Restart Estimator.

2. Select **Open** from the **File** menu. Estimator displays an Open Estimate window.

3. Select the estimate file and click **OPEN**.
4. If enough time has passed for the Auto Save utility to save your estimate, Estimator displays the Recovery window.

![Figure 2-19. Auto-Saved Estimate File](image)

5. Click YES to replace the estimate with the more current saved estimate, or NO to open the estimate as it was when the computer was turned off. Selecting NO disables the auto save functionality for the rest of the estimate session, but it is re-enabled when the estimate is closed and reopened.

### 2.9.3 Using the Archive Utility

The Archive Utility is a fully customizable, automated estimate historian. It allows you to store up to nine previous versions of an estimate. Using the Archive Level function in the Global Options window, you can scan through estimate developments or undo recent changes.

To enable estimate archiving:

1. While no estimates or catalogs are open, select **Global Options** from the **Other Tools** menu. The Global Options tab folder window appears

2. Locate the Archive Level field in the middle of the GENERAL tab. Use the arrows beside the field to determine the archive level.
3. Click APPLY if you are making more changes to the Options window, and click CLOSE when you are finished.

To change the number of archives:

1. Select **Global Options** from the **Other Tools** menu.

2. Use the arrows in the Archive Level field to scroll to the number of archives (0-9) you desire. If you select zero, then Estimator will not archive your estimate.

3. To update your archive level, click **OK** or **APPLY** and then click **CLOSE**. Click **CANCEL** to not change the archive level.

### 2.10 Printing an Estimate

You can produce a printout of your estimate when you have the estimate open. When you print an estimate, detailed information about the price basis being used for each item can also be printed if specified. You must have the correct permission to print the estimate.
Select **Print** from the **File** menu to print an estimate report. Estimator displays a Print Message box that contains several options.

![Figure 2-21. Estimator Print Options Window](image)

**Note:** For more information on what each item in the Estimate Print Options window means, please see Section 4.11.

Once you’ve selected the print options, click **OK**. Estimator displays a Print Setup window.

![Figure 2-22. Estimator Print Setup Window](image)
Here you can choose the printer on which you wish to have your estimate printed, the paper size, and the print orientation. Once you have selected the appropriate print options, click OK.

Estimator displays a Printing Records window that shows the status of your print job. When your estimate has finished printing, Estimator returns to the estimate.

Your Agency name appears in the printed estimate if the Agency field in the Global Options window is filled in. Talk to your system manager for more information.

2.10.1 Printing the Estimate Funding Summary Report

In order to print the Funding Summary Report in Microsoft Excel, you must first generate the report in Estimator through the Generate Fund Report function.

It is assumed that funds and fund packages have been assigned to an estimate. Follow these steps to generate the Funding Summary Report:

1. In Estimator, open an estimate (with funds and fund packages).
2. Select **Edit**, and then **Generate Fund Report**.
3. Estimator creates and opens a Microsoft Excel Fund Summary Report with the following worksheets:

   **Funding By Group and Item**
   
   Shows the estimate funding assignments at the Group and Item levels.
**Fund Totals**  Shows the total funded amount for each fund package.

**Fund Details**  Shows the funds available as entered in the Funding Grid View for the estimate.

**Group Summary**  Shows the summary of funding activity at the Group level.

**Item Summary**  Shows the summary of funding activity at the Item level.

**Fund Summary**  Shows the summary of funds used across fund packages.

**Fund Package Summary**  Shows the summary of fund packages and the funds they use at the Item and Group levels.

### 2.11 Opening a Catalog

Select **Show Open Catalogs** from the **Catalog Tools** menu to view the catalog in use by the estimate. You can change the Current Catalog by using the **Switch Current Catalog** command located under the **Catalog Tools** menu, which prompts you for another catalog to open.

If you switch catalogs while an estimate is open, the estimate becomes *read-only* and you will not be able to make any changes to the estimate. This is because the information in an estimate is geared to the Current Catalog. You cannot have more than one catalog associated with an estimate at a time.

### 2.12 Closing an Estimate or Catalog

If you want to exit the estimate or catalog in which you are working but stay in Estimator, you can close the estimate or catalog and return to the Estimator main window. Select **Close** from the **File** menu to close the active window, as well as other open windows that belong to the active window. If you made changes to the active window and did not save them, Estimator prompts you to save your work before it closes the file. You should always save your work before you close an estimate unless you made changes you want to abandon.

As previously discussed, it is a good idea to save your work periodically. When Estimator gives you the option to save your work, you should click **OK** unless you specifically want to discard the changes you made since your last save.
2.13 Exiting Estimator

To exit Estimator, select Exit from the File menu. If you have made changes to your estimate since your last save, an Estimator dialog box asks if you want to save your work. Click YES to save changes and exit Estimator, NO to ignore the changes and exit Estimator, or CANCEL to cancel the exit and return to Estimator.
3. Working in Estimator

This chapter explains Estimator system elements and how to manipulate the keyboard and mouse to make those elements interact. It tells you how to set up your working environment and describes Estimator menus. This chapter also describes ways to customize your estimate and catalog displays. Open Estimator if it is not already open so you can look at Estimator’s system elements.

3.1 Estimator Menus

Estimator lists the different commands you can use to develop your estimate or look at catalogs in menus. Each menu’s content can change depending on the active window.

3.1.1 File Menu

The File menu contains commands that perform file-related operations such as creating, storing, opening, and closing files. The File menu also contains some system commands.

When an estimate file is open and you have edit permission for that estimate, all commands on the File menu are enabled. If no estimate is open or if you have view-only permission for an open estimate, some commands are disabled.

3.1.2 Edit Menu

The Edit menu commands allow you to change the data in an estimate or a catalog. Although the Edit menu can always be displayed, not all Edit menu choices are available at all times. In addition, some of the commands on the Edit menu are window-dependent commands; that is, they perform different functions depending on which window is active when the commands are invoked.
3.1.3 View Menu

The View menu is divided into sections separated by a horizontal line. Commands in the top part of the window are used for navigation - you can move to different levels of your estimate or catalog. The middle section contains commands for displaying the columns of the catalog or estimate. Commands listed in the lower half of the View menu allow you to view the Estimator Status Bar and Toolbar.

3.1.4 Tools Menu

The Tools menu lists the command related to catalogs and Estimator options. You can switch Current Catalogs, create or delete catalogs or copy the Current Catalog, depending on your catalog permissions. You can also set the Global Options, change your password, or switch Estimator users from the Tools menu, depending on your permissions.

3.1.5 Window Menu

The Window menu is divided into upper and lower sections, which are separated by a horizontal line.

Commands listed in the upper half of the Window menu allow you to reorganize the layout of the open windows currently displayed on the screen (Tile or Cascade). It also allows you to arrange the icons.

The lower half of the Window menu contains an alphabetically ordered and numbered list of all open windows. The name of the active window has a check mark next to it. If more than one window is open, you can change the active window by selecting the desired window from the list of open windows in the Window menu.

3.1.6 Help Menu

The Help menu provides commands to help you use Estimator. It also contains information about the Estimator version you are using, and allows you to generate a support request if you are having problems using Estimator and you can not find the answer in any of the Estimator documentation.

3.1.7 Enabled and Disabled Commands

Some commands are only available at certain times, depending on what you are doing with Estimator, your privileges level, or both. For example, if you have read-only access, you cannot invoke commands that edit or change the information in an estimate. If you have clearance to modify an estimate, you can use the basic editing commands to add, modify, or delete estimate data, but cannot invoke the commands that edit or change the Estimator catalogs (unless edit permission for the Estimator catalogs has been assigned to you).
Some of the commands on a menu might have a grayed out appearance (or in some instances, a command might be omitted from the menu entirely). These commands are disabled and cannot be invoked. If you activate a different window or add an item to a list, Estimator might enable the command. When a command makes sense in a given context and you have the appropriate access, the command is enabled.

There are three possible display states for every Estimator command:

- Visible and enabled (black on the menu)
- Visible and disabled (unavailable on the menu)
- Invisible and disabled (absent from the menu)

You can only invoke visible and enabled commands.

### 3.2 Getting Help

Estimator provides an online Help system you can access while using the application.

You can access Help in a variety of ways, depending on the type of information you need. Select Help Topics from the Help menu to access the index for the Estimator Help system and then choose a topic. To get help on the active window, press SHIFT+F1 or select Context Help from the Help menu.

### 3.3 Setting Up Your Working Environment

You can set defaults in Estimator that manage how windows display on the screen, how often you save your work, and other preferences.

#### 3.3.1 Setting Preferences

You can modify your Estimator working environment according to your personal tastes. Select Global Options from the Other Tools menu to display the GENERAL tab of the Estimator Options dialog box shown in Figure 3-1.
Each tab contains user and system options for setting preferences in Estimator. You can edit the user options. System options are visible, so you can see the value of each option, but only someone with super-user status can edit the system options. You may be able to change some of these options for your individual estimates by selecting Estimate Options from the Edit menu.

### 3.3.2 The General Tab

You are able to edit the user options to your preference. These are the User Options available on the **GENERAL** tab:

- **Auto Save Interval** This option is discussed in Chapter 2.
- **Archive Level** This option is discussed in Chapter 2.

These are the system options available on the **GENERAL** tab:

- **Agency Name** This is the name of the Agency for which you work. If this field is filled in, then the Agency name is displayed on printed estimates.
<table>
<thead>
<tr>
<th>Feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Verify Estimates Upon Opening</td>
<td>If this check box is selected, the Estimator software checks an estimate for errors when it is opened. A message appears if the estimate contains errors.</td>
</tr>
<tr>
<td>Estimate Out of Range Bid History Prices</td>
<td>When a bid history is calculated in BAMS/DSS, it has a range of quantity that is valid for the data. The minimum and maximum quantities are displayed in the Bid History Catalog in Estimator. If this option is selected, then Estimator ignores the valid quantity range and produces a bid history price. This option should be used with care since it is possible to produce unreliable prices when using out of range quantities. Due to this, by default this option is not selected.</td>
</tr>
<tr>
<td>Roll Up Item Quantity for Bid History Prices</td>
<td>Most items have a price and quantity relationship where the unit price lowers when a higher quantity of the item is used. If this option is selected, quantities of like items are rolled up and this combined quantity is used for the bid history pricing of the individual items. This emulates how a contractor would price items that occur multiple times on a contract. Normally this is desirable and thus it is a default setting.</td>
</tr>
<tr>
<td>New Estimate Use Only Trns•port Items, Codes, and Rounding Levels</td>
<td>When adding items and code table values to the estimate, only those compatible with AASHTOWare Project (Trns•port) applications will be available when this option is selected. Checking the check box grays out the dropdown Rounding Levels for the Unit Price, Extended Amount, and Quantity for New Estimates on the Numeric/Rounding tab and cannot be changed. Deselecting the check box for this option allows you to change these values. Only the system manager can set this option.</td>
</tr>
<tr>
<td>Evaluate Formulas When Data Changes</td>
<td>When this option is selected, formulas will be automatically recalculated when a numeric field value that references a formula is changed.</td>
</tr>
</tbody>
</table>
3.3.3 The Numeric/Rounding Tab

There are no user options available on the NUMERIC/ROUNDING tab.

These are the system options available on the NUMERIC/ROUNDING tab:

**New Estimate Unit Price Rounding Level**
You can choose to round estimate unit prices from between one dollar ($1.00) to thousandths of cents ($0.00001).

**New Estimate Extended Amount Rounding Level**
You can choose to round an estimate’s extended amount from between one dollar ($1.00) to thousandths of cents ($0.00001).

**New Estimate Quantity Rounding Level**
You can choose to round estimate quantities from between one unit to thousandths of unit.

**Line Number Start**
This is the line number that appears when a new item is added to an estimate.

**Line Number Increment**
This is the amount the line numbers increment when new items are added to an estimate.

**Group Number**
The first group in an estimate is given this number when it is
Start created.

Group Number Increment
Each successive groups are numbered in this increment from the first group.

Increment Line Number Start by Group Number
Each item is numbered according to the group number, though incrementing accordingly within the group.

3.3.4 The URLs Tab

The URLs tab contains the paths for your catalog directory, your estimate directory, and your template folder.

![Estimator Options Window - URLs Tab](image)

Figure 3-3. The Global Options Window - URLs Tab

These are the user options available on the URLs tab:

**Catalog Path (HTTP or file)**
This field displays the location of the Estimator catalogs. This is the directory Estimator displays when you select Switch Catalog from the Tools menu.

**Estimate Folder**
This is the directory to which new estimates are saved.

**Cache Folder**
This is the local directory Estimator uses for file downloads when your user table or catalogs are stored on a web server.
These are the system options available on the URLs tab:

**Template Folder** This is the directory where estimate templates are kept.

### 3.3.5 The Internet Tab

The Internet tab allows Estimator to connect to a server and look for catalog updates, and download them into the Current Catalog.

![Figure 3-4. The Global Options Window - Internet Tab](image)

These are the user options available on the INTERNET tab:

**URL** The Internet site designated by the transportation agency where the catalog updates are located.

**Username** If the Internet site is secured, the username that will allow you to access the site.

**Password** If the Internet site is secured, the password that will allow you to access the site.

**Automatically Search for Catalog Updates on Startup** This option tells Estimator to look for catalog updates each time you start the program. You can also search for catalog updates by selecting **Check for Catalog Updates** from the Catalog Tools menu.
**Download Folder**  
This is the local directory Estimator uses for file downloads when you run the Catalog Update command.

There are no system options available on the **INTERNET** tab.

### 3.3.6 The Proxy Tab

The **PROXY** tab controls the way Estimator connects to the Internet.

![Figure 3-5. The Global Options Window - Proxy Tab](image)

These are the user options available on the **PROXY** tab:

- **Direct Connect to the Internet**  
  This indicates that your computer does not need to go through a proxy server to access the Internet.

- **Use Windows settings to connect to the Internet**  
  This tells Estimator to check the Windows settings when connecting to the Internet and to use the same settings.

- **Manual, use this proxy server**  
  Use this option to have Estimator use a proxy server not indicated by your Windows settings. Fill in the proxy server name in the Server field and the port number in the Port field.

There are no system options on the **PROXY** tab.
It is a good idea not to change any information in the PROXY tab unless told to by your system administrator or your network administrator. If you have any questions, contact your system administrator or your network administrator.

3.3.7 The Tree/Field Labels Tab

The TREE/FIELD LABELS tab allows the system manager to label certain elements of the estimate in the tree view and in the detail view. Only the system manager can change these options.

To change the labels in an estimate in the tree view, enter a value in the corresponding box in the Tree Labels column. To change the labels in an estimate in the detail view, enter a value next to the label listed under the Field Labels column.

**Note:** If upgrading from a version of Estimator prior to 2.11a, the values in the Tree Labels column are moved into the Field Labels column. The system manager should modify both the Field and Tree Labels values for their business process.

![Figure 3-6. The Global Options Window – Tree/Field Labels Tab](image)

These are the system manager options available on the TREE/FIELD LABELS tab:

**Estimate ID** The label of the estimate.
<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group Number</td>
<td>The label of the group.</td>
</tr>
<tr>
<td>Item</td>
<td>The label of the item.</td>
</tr>
<tr>
<td>Task List Name</td>
<td>The label of the Task List.</td>
</tr>
<tr>
<td>Ref Price ID</td>
<td>The label of the Reference Price.</td>
</tr>
<tr>
<td>Bid History ID</td>
<td>The label of the Bid History.</td>
</tr>
<tr>
<td>Cost Sheet Name</td>
<td>The label of the Cost Sheet.</td>
</tr>
<tr>
<td>Equipment</td>
<td>The label of the equipment.</td>
</tr>
<tr>
<td>Labor</td>
<td>The label of the labor.</td>
</tr>
<tr>
<td>Material</td>
<td>The label of the material.</td>
</tr>
</tbody>
</table>

The question mark (?) box next to each field contains the list of the fields after which the label can be named. For example, for the Estimate field, if you select %1, then the label will be based on the Estimate ID field. If you do not include a %, then the field will always be named after the text in the field.

### 3.3.8 The Catalog Tab

The CATALOG tab allows you to determine the proper selection for importing obsolete items. Three choices will be available and depending on the choice selected, obsolete items will be added or not to the standard item catalog. This tab also has two other options, one is to prevent duplicate items codes in catalogs and the other is to copy notes to estimates.
These are the system manager options available on the CATALOG tab:

**Prevent duplicate item codes in catalogs**
If selected, the system administrator will not be able to add or import duplicate item codes in catalogs.

**Allow obsolete items in catalogs**
If selected, during import of items, obsolete items as indicated by an obsolete flag will be imported into the standard item catalog.

**Allow obsolete items in catalogs but warn**
If selected, during import of items, obsolete items as indicated by an obsolete flag will be imported into the standard item catalog, however, a warning will be displayed in a verification log.

**Do not allow obsolete items in catalogs**
If selected, during import of items, obsolete items as indicated by an obsolete flag will not be imported into the standard item catalog.

The following user option is available on the CATALOG tab:

**Copy notes to estimate**
If selected when catalog elements are added to an estimate, the notes from the catalog will be included in the estimate file.
Please see Section 4.10 for information about the Verifications Tab.

3.4 Navigating and Displaying Estimates and Catalogs

There are two ways to display and navigate through windows in Estimator. The first way is with the tree area. The tree area displays information in the left pane of the window in a tree-like, hierarchical representation. The information in the right pane corresponds with the currently chosen item in the left pane. You navigate through the tree area using the plus (+) and minus (-) signs next to each item, or the yellow navigational arrows in the menu bar.

The grid area displays the items in a grid in the right pane of the window. The grid area gives more information about the selected item. You can navigate through the grid areas using the GO button or the yellow navigational arrows.

Note: The fields above the grid area are informational and are not used in navigation.
A window can display both the tree and grid area at the same time, as shown in Figure 3-9. It is up to you to decide which method of navigation you wish to use when both views are displayed.

3.4.1 Hide/Show Columns

You can hide columns in your estimate or catalog. For example, if your agency never uses the Alternate Code description for a group, you can hide that column from the grid area.

Look at the grid area of the GROUPS tab of your estimate. There are columns labeled Group Name, Group Total, Alternate Code, and Description.

1. Start a new estimate by selecting New from the File menu. Select Blank if the New Estimate window appears, and click OK.

2. Select Hide/Show Columns from the View menu. Estimator displays the Show/Hide Columns window.
Figure 3-10. Estimator Show/Hide Columns Window

This window lists the current columns, and shows which ones are being shown and which are hidden. The list of columns can change depending on what type of window you are in – group or all items, item, or catalog.

3. Select **Alternate Code** from the Show column and click **HIDE SELECTED**. The Alternate Code moves from the Show column to the Hide column.

4. Click **OK**. Estimate returns you to your new estimate with the Alternate Code column hidden.

Figure 3-11. New Estimate With Hidden Column
5. To view the column again, select **Show/Hide Columns** from the **View** menu. Estimator again displays the Show/Hide Column window, but with the Alternate Code in the Hide column.

![Show / Hide Columns](image)

Figure 3-12. Show/Hide Column Window With One Hidden Column

6. Select **Alternate Code** in the Hide list. Then click **SHOW SELECTED**. The column moves from the Hide list to the Show list.

7. Click **OK**. Estimator returns you to your new estimate with the Alternate Code list visible.

If you had wanted to hide all the columns, you would have clicked the **HIDE ALL** button in the Show/Hide Columns window. If you wanted all the hidden columns visible, you would have clicked the **SHOW ALL** button.

8. Select **Close** from the **File** menu. Do not save your estimate.

### 3.4.2 Show/Hide Tree View

If you prefer to work solely in the grid area, you can hide the tree view. If you change your mind, you can make the tree view visible again. You can hide the tree area in both estimates and catalogs.

1. Select **New** from the **File** menu to open a new estimate. Select **Blank** if the New Estimate window displays, and click **OK**. Estimator displays a new estimate.
Notice the tree area on the left side, and the grid on the right.

2. Select **Hide Tree View** from the **View** menu. The grid view widens, hiding the tree view.

You can navigate your entire estimate or catalog without the use of the tree view by using the yellow navigational arrows or the green GO buttons located in the lower half of the grid view. You cannot navigate without the grid view, however, as the grid view contains all the detailed information you need to create or refine your estimate.

3. To make the tree view visible again, select **Show Tree View** from the **View** menu.
3.4.3 Expand and Collapse All Tree View

Estimator has commands that will let you view all parts of the estimate or catalog in the tree area. When you choose to expand the tree view, Estimator acts as if you have clicked every plus (+) sign in the estimate or catalog. Each group, item, and price basis is visible when used in an estimate; each catalog and code table is visible when used in the current catalog.

We are going to use these commands with the current catalog.

1. Select **Show Open Catalogs** from the **Catalog Tools** menu. The current catalog opens.

2. If you don’t see the names of all the catalogs and code tables, click the plus (+) sign next to the catalog name. All catalogs and code tables are now visible.

3. Select **Expand All Tree View** from the **View** menu. Each catalog and code table expands, displaying every folder, subfolder, and element stored in the catalog.

![Figure 3-15. Current Catalog and Code Tables](image)

Notice how most catalogs and code tables have a plus (+) sign symbol. This indicates that the folder contains more information.
4. Use your scroll bar in the tree area to view the different folders in the current catalog.

5. When you are finished, select **Collapse All Tree View** from the **View** menu. The current catalog closes every folder.

6. Select **Close** from the **File** menu to close the current catalog.

### 3.5 Navigating With the Directional Arrows

There are yellow arrows available on the menu bar and in the grid area. You can use these yellow arrows to navigate through your estimate. Follow these steps to practice navigating with the directional arrows:

1. From the tree area, click Group 0005.

2. Click the yellow arrow in the grid area of Group 0005. This is the **UP** button. Clicking the yellow arrow brings you to the level above the window in the estimate hierarchy; in this case, the estimate header window.

3. Click the yellow arrow in the menu bar that points to the left. This is the **BACK** button. This takes you to where you were in the previous window; in this case, Group 0005.

4. Once you click **BACK**, the yellow arrow pointing to the right, or the **FORWARD** button, enables. The **FORWARD** button cannot be used until the **BACK** button is used. Click **FORWARD** to bring you to the estimate header window.
Practice using the directional arrows until you have a good idea what window opens when a particular button is selected. The yellow check mark next to the arrows is the Verify Estimate function; we will learn about that later in this guide.

### 3.6 Using the Expression Builder Window

The Expression Builder can be used to enter formulas or expressions in any field that requires a number. You can enter a mathematical expression that includes mathematical constants and variable data elements in the system. For example, you might want to calculate 150 percent of a unit price to arrive at another unit’s price.

Formulas stored in the code table FORMULAS can be accessed through the Expression Builder window. See Section 3.7 Using Formulas from Code Table FORMULAS in the Expression Builder.

Open the Expression Builder by clicking an ellipsis (…) located next to any numeric field. Estimator opens the Expression Builder window.

![Expression Builder Window](image)

Figure 3-17. Expression Builder Window

Enter an expression in the Expression being built field. Use the functions on the Expression tree in your expression. When you are finished, click **Evaluate**.

The Estimator software calculates the value of the expression, which appears in the Expression value field at the bottom of the window. If the expression is valid and can produce a number, that result appears. If the expression is invalid, an error message appears.

If a value in the Expression tree changes, the Expression value recalculates automatically.

Once you have a validated expression, click **OK** to add the expression to your estimate.
3.7 Using Formulas from Code Table FORMULAS in the Expression Builder

Formulas can be stored in the catalog code table FORMULAS and then utilized in the Expression Builder for numeric fields. Formulas cannot be validated at the catalog level. With the Expression Builder open, the Formulas option will appear at the bottom of the left pane. Click the + sign to open the formulas available from the code table FORMULAS. Click one of the formulas to add it to the right pane and then click the formula in the right pane to add it to the Expression Builder.
4. Creating an Estimate

This chapter familiarizes you with the basic Estimator procedures. You will learn how to define a new estimate, select items from the Standard Item Catalog and add them to the estimate, and select the price basis to use for estimating the cost of each item in the estimate.

This chapter assumes you are able to create new estimates. All other privileges are irrelevant. If this chapter contains an exercise that you cannot do, it is possible that you do not have the correct permissions to do it. See your system administrator for more information.

Estimator allows you to create a list of items to use in a construction estimate and then modify that list. You can close the estimate at any point in the development process and open it later for further modification. This process gives you the freedom to make changes with minimal effort and develop an estimate with step-by-step refinement.

If you have previously closed Estimator, open it and log in. Update any necessary catalogs. Before you open your new estimate, make sure that the Current Catalog has a unit system of English, which will be used to create the new estimate. To do this, select Show Open Catalogs from the Catalog Tools menu. If the catalog displayed is not the one you want to use, select Switch Current Catalog from the Catalog Tools menu, choose the correct one, and click OK.

4.1 Creating a New Estimate

Estimator produces estimates from information entered by you, the estimator. Estimator stores general information about an estimate in the estimate header. Information is stored in an estimate’s groups, and information about the estimate's items is stored in the item list.
Estimator stores the information for each estimate you create in individual estimate files. To work in Estimator, you must create a new file for new estimates or open an existing file and work on a previously-defined estimate.

Before we create our new estimate, return again to the TREE LABELS tab. To do this, select Global Options from the Other Tools menu and click the TREE LABELS tab. Our Tree Labels contain the settings displayed in Figure 4-1. If your tree does not contain the same labels, the tree area in our estimate will look different and some instructions may be harder to follow. Contact your system manager about the settings on the TREE LABELS tab. Once you are done viewing the tree labels, click CANCEL.

![Figure 4-1. Tree/Field Labels Tab Settings](image)

Note: You can see what each of the labels mean by clicking the question mark (?) next to each field.

As discussed in Chapter 3, all Estimator commands are located in menus. As you use Estimator, you will become more familiar with using menus to select commands. You can also use the buttons on the Estimator toolbar to select certain commands.

1. Select the File menu. Estimator displays the File menu, which contains commands relating to files (see Figure 4-2).
2. Select **New**. Estimator opens the New Estimate window, from which you can create an estimate based on an existing template or a completely new (blank) estimate.

**Note:** If no templates have been created for Estimator, then selecting New from the File menu opens a new estimate and you will not see the New Estimate window. Please see Chapter 5 of the Estimator User’s Guide for more information.

3. Select **<Blank Estimate>** and click OK. Estimator displays the PAGE 1 tab of the Estimate header window (see Figure 4-4).
4.2 Assigning Estimate Preferences

Estimator deals with each new estimate individually. The users for one estimate might not be the same for another. Some estimates might be used by AASHTOWare Project programs, and some might not. To establish the preference for each estimate, follow the instructions in this section.

4.2.1 Setting the Estimate Options

Global options for your estimate are set by the system manager. You can see what options were selected by choosing Global Options from the Other Tools menu and viewing each of the tabbed windows. Although you cannot change some global options, some options can be changed for your estimate. Global options can only be accessed when all other windows are closed.

You can set options specific to your estimate, such as how to round a unit price or if the estimate is going to be used in conjunction with AASHTOWare Project applications.

Select Estimate Options from the Edit menu. Estimator displays the Estimate Options window.
This window allows you to set the options regarding the rounding levels of items, prices, and units. If your estimate will be used by AASHTOWare Project (Trns•port) applications, be sure to select the Only Trns•port Items and Codes Allowed. When this is selected, it overrides the rounding options to conform with what is required by AASHTOWare Project applications.

Click OK. Estimator returns you to the estimate.

4.2.2 Maintaining the Estimate’s Users List

You can assign users to your estimate. The access of each user can range from read only to owner. As the creator of the estimate, you are automatically granted owner access, which allows you to view and edit the new estimate, change the catalog information, and add other users to an estimate. As an owner, you can also add and delete users to the owner level.

1. Select Estimate Users from the Edit menu. Estimator opens the Estimate Users window.
An estimate's Users list differs from Estimator's Users list. The only users that appear on the estimate's Users list are those who have been assigned access by the system manager and by you, as the creator and owner of the estimate.

For this guide, do not make any changes to the Estimate User List. Click CANCEL or OK to exit the window.

4.3 Entering Information in the New Estimate Header Window

In the new estimate’s header window, Estimator automatically enters the current date in the Base Date field, the Current Catalog spec year in the Spec Year field, the Unit System of the majority of the items in the current catalog in the Unit System field (metric, English, or none), and 0.00 in the Estimate Cost, Contingency %, and Estimate Total fields.

Estimator also creates a group in which you can add items and their price bases. The other fields are left blank. You can keep these default values or change them as appropriate.

To enter data into the fields displayed in the New Estimate Header window, you must move from field to field and enter values or choose them from a list of possible values when they are provided.

For example, when you click on the down arrow next to the County field, the County list displays a list of counties. You can view the remaining counties by clicking on the scroll down arrow or by dragging down the scroll box on the scroll bar. When you click the down arrow attached to the Work Type field, Estimator displays a drop-down list of different work types. You can select the work type by clicking on the type in the list.

Some fields in the New Estimate Header window are required; that is, they must have entries or Estimator notifies you of an error. If you do not have an entry in a required field when you verify your estimate (discussed later in this guide), an error appears with information about the missing fields. Also, an exclamation point (!) appears in the tree area where the error occurs. In Figure 4-4, the exclamation point appears because there is no Estimate ID entered for the estimate.

Follow these steps to begin creating our new estimate:

Note: This guide offers explicit entries to use in creating this estimate. You can use those entries, or select your own. If the explicit entry is not available, choose a different entry.

1. Click in the Estimate ID field. Type 2009_0827SS for the Estimate ID and press the TAB key twice (the Spec Year field is set by the catalog and cannot be changed). Note that the Estimate ID appears in the title of the estimate in

4-6 Creating an Estimate
the tree view, located in the left pane, and the exclamation point in the tree area has disappeared.

2. Click the down arrow next to the Base Date field. Using the directional arrows at the top of the calendar, select **August 27, 2009**, as the Base Date.

3. Leave the Unit System field with the default of the system of measurement of the Current Catalog (in this case, E, or English).

4. The next four fields, Longitude at Midpoint, Latitude at Midpoint, District, and Federal/State Project Number, are not required. These fields are used when the project will be passed into Trns•port PES.

5. Click in the Description field. Type **Ramp at I-99/SH 99 Interchange** for the description.

6. Click the down arrow next to the Work Type field. Scroll and select **Miscellaneous**. Estimator fills in the description for you.

   **Note:** If you had selected any of the Trns•port check boxes in the Estimate Options window, some of the drop-down values might not be available.

7. Click the down arrow next to the Highway Type field. Select **Asphalt**. Estimator fills in the description for you.

   We are going to sort the Urban/Rural Type field before we select a value.

8. Click on the down arrow next to the Urban/Rural Type field. Notice that the field values appear in alphabetical order. Click the down arrow again to release the values list.

9. Right-click on the down arrow next to the Urban/Rural Type field. Estimator displays sort options. These options are available for almost every list window in Estimator.
10. Select Sort Urban/Rural in Descending Order.

11. Click on the down arrow next to the Urban/Rural Type field. Notice how the field values are now displayed in descending alphabetical order.


13. Click the down arrow next to the Season field. Select Summer. Estimator fills in the description for you.

14. Use the sort option to sort the County field values in descending order. Select the county that is sixth from the top. Estimator fills in the county name for you.

15. Click the down arrow next to the District field and select the first district.

We are going to use the Expression Builder to find the contingency percent.

16. Click the ellipses next to the Contingency % field. The Estimator software opens the Expression Builder window.
We are going to create an expression that says if the estimate total is under $800,000 the contingency percent will be 2.5. If it is over, it will be 5.

1. Click IF.

**Note:** Spaces are not necessary, but can be used to view the expression more easily.

A) Click **Estimate** in the left column to see the available fields to use in the right column. Click **Total** and press the space bar.

B) Click >= (the greater than or equal to symbol) and press the space bar.

C) Enter **800000** after the >= in the Expression being built field and press the space bar. Do not use commas.

D) Click THEN and press the space bar.

E) Enter **5** in the Expression being built field and press the space bar.

F) Click ELSE and press the space bar.

G) Enter **2.5** in the Expression being built field and press the space bar.

H) Click **EVALUATE** to verify the expression is built correctly. The Expression value field returns the result of 2.5. Since the Estimate Total is currently 0.00, the expression was built correctly.
4-10 Creating an Estimate

A) Click OK to add the expression to the Contingency % field.

B) Because the field is based on an expression, the field display is blue.

2. Select Save As from the File menu. Click SAVE to save your estimate with 2009_0827SS as the file name.

Your estimate should now look similar to Figure 4-10.

Estimator initially displays an estimated total price of $0.00 for the estimate. This value is calculated from the estimate items and will change when you provide item details for the estimate.
17. Select the PAGE 2 tab.

![Figure 4-11. New Estimate Page 2 Tab](image)

Estimator automatically fills in the Estimated By field with the name of the person who created the estimate; in this case, you. The date defaults to the date the estimate was created, but this field should be updated when the estimate is finished.

The Checked By and Approved By fields, plus the corresponding Date fields, are used once the estimate is complete. These fields are used by the persons who check and approve the estimate.

Once you have filled out all relevant information on the PAGE 2 tab, save your work again by selecting **Save** from the **File** menu. Remember to save your work often.

You can add specific information to your estimate by selecting the **NOTES** tab, and entering the information in the Notes field.

18. Click the **NOTES** tab.

19. Enter Estimate created for the Estimator Training Guide. in the Notes field.

Remember that Estimator has an Undo function that can reverse recent changes. Let’s say you decide you want to leave the Notes field blank.

20. Select Undo Change Estimate Notes from the Edit menu.
21. The comment in the Notes field is deleted.

You can undo recent changes until the extent of Estimator’s memory is reached. Also, if
you save your estimate, the undo memory is erased.

Now let’s say you changed your mind again, and wish to add the comment back into the
Notes field.

22. Select Redo Change Estimate Notes from the File menu. Estimator adds the
comment back to the Notes field.

23. Save your work again.

24. Select the Edit menu.

Now that you have saved your estimate, you can see the Undo and Redo options are
unavailable. Click the Edit menu again to close it.

You can add additional information to your estimate by using the extra data tab. Extra
data is used when you have information for your estimate, group, or item and Estimator
does not have a designated place for it.

25. Click the EXTRA DATA tab at the bottom of the window. The Estimator
software displays the Extra Data fields.
Enter the name of the field in Name field. Enter the value that you want to appear in the estimate. Enter a description in the Description field. This field is not necessary, but it can help you identify what the field represents. For example, if you name the data field LOCAT1, you may forget what LOCAT1 represents. You can add Location field in the Description field.

You can also enter extra data fields for groups and items, plus you can include extra data fields as part of each new estimate you create. See Chapter 6 of the Estimator User’s Guide for more information.

You may also see an additional WEB SERVICES tab. This tab is related to the Web Services function on the Tools menu and is not used by all agencies. If the WEB SERVICES tab is not visible, then your agency does not use it. See your system manager for more information.

Once the estimate header information is entered, it is time to add groups and items to your estimate. You can enter groups and items two ways - through the GROUPS tab and through the ALL ITEMS tab.

4.4 Entering Group Information on the Groups and All Items Tabs

Now that you have entered the estimate header information for the current estimate, you can begin to add estimate groups or estimate items. Estimate groups consist of items and the item price basis. Each group can have more than one item, and each item can have more than one price basis. An item can also belong to more than one group, but items cannot be shared across groups. If an item is needed in more than one group, there must be a separate occurrence of the item for each group.

Before you can create the estimate groups, you must open the estimate. If you closed estimate 2009_0827SS, open it again by selecting it from the File menu. The GROUPS tab is always displayed the first time you open an estimate after opening Estimator. Remember that when you created the new estimate, Estimator assigned it a group.
There are two ways of entering groups and items into the estimate: the GROUPS tab and the ALL ITEMS tab. The two parts of this section goes over each method, starting with the GROUPS tab.

4.4.1 Entering Information on the Groups Tab

With your estimate open:

1. Make sure you are looking at the PAGE 1 tab. Click the green GO button next to Group 0005 in the grid area of the header window. Estimator displays the contents of Group 0005.

![Figure 4-14. Empty Group in Estimator](image)

- **Note:** Estimator groups and items in this guide are numbered starting at 0005 and incrementing by five for each additional group. This is done so groups can be inserted between other groups, and still have a number between the number of the other two groups. To change the start or incremental number, select **Global Options** from the **Other Tools** menu and change the field on the NUMERIC/ROUNDING tab. You may need to talk to your system manager if those options are unavailable to you. Remember that Global Options cannot be accessed if the estimate window is open.

2. Highlight the words **Initial Group** with the mouse and then press the DELETE key on your keyboard. This deletes the description. Press the TAB key.

When you press the TAB key, this leaves no description for the group. Because Description is a required field for Estimator, an exclamation point (!) icon appears in the tree area next to the name of the estimate and the specific group that contains the error. Once all errors are corrected, the exclamation point disappears.
3. Enter **Removal** in the Group Description field of PAGE 1 and press **TAB**. The exclamation points disappear.

You do not need to fill in the Alternate Code unless required by your agency. The Group Total field is populated by the price information from items added to the group. You can enter any notes for the estimate on the **NOTES** tab.

4. Save your work by selecting **Save** from the **File** menu or by clicking the **SAVE** icon.

5. Add another group to the estimate by highlighting the estimate name, 2009_0827SS, in the tree area. This returns you to the header window. Click in the empty Group Name cell in the grid area (in the empty cell under Group 0005). A new group appears. In our example, it is group number 0010.

Notice the yellow exclamation point by the estimate and group names in the tree area. Group 0010 does not contain the required information.

6. Click on the **GO** button next to Group 0010. Estimator brings you to the empty group header window.

7. Enter **Light Installation** in the Description field of Group 0010 and press the **TAB** key.

8. Save your work by selecting **Save** from the **File** menu.

9. Add one more group to the estimate by highlighting the estimate name in the tree area. This time, however, select **Add Group** from the **Edit** menu to add the new group.

10. Enter **Design/Build** in the Description field. Save your work.
4.4.2 Entering Group Information on the All Items Tab

In the previous section, we added three groups to the estimate without entering any item information. When you use the ALL ITEMS tab, the group is assigned as you enter items to the estimate. You can also create new groups as you are adding the items.

This section focuses on groups, and the ALL ITEMS tab is designed to focus on items. The ALL ITEMS tab will be discussed in more detail in Section 4.5.2.

11. Return to the estimate header window by clicking the yellow up navigation arrow in the estimate toolbar. Click the ALL ITEMS tab at the bottom of the window.

12. Click in the empty Group # cell of the ALL ITEMS tab. Press TAB to move your cursor out of the Group # cell. Estimator displays the Select Group window.

![Select Group Window](image)

**Figure 4-16. Select Group Window**

13. Click the down arrow next to the Select existing group for your new items field. The drop down list displays the three groups previously created on the GROUPS tab. Close the drop down list without selecting a group.

14. Click CREATE NEW GROUP. Estimator displays the Create New Group window.

![Create New Group Window](image)

**Figure 4-17. Create New Group Window**
In our example, the Group Number has incremented by five over the last added group. Even though this group was created in a different way than the other groups, the only difference is that this group was created for a specific item.

15. Enter **Administration** in the Group Description field and click **OK**. Estimator adds a new item row to the **ALL ITEMS** tab and assigns it to group 0020, **Administration**.

**Note:** The Item Line Number in our example is 0005. Even though this was the fourth group created, it was the first to have an item added to it.

16. Click the down arrow in the Item # field and select an item from the item drop down list for the group with the word **Telephone** in the description. Estimator automatically enters the Unit Price, Description, and Unit fields for that item, if available. Estimator also brings over any price bases attached to that item, and fills in the Price Source field in regards to the price bases.

17. Enter a quantity of **3**. Add a unit price of **476.00** if Estimator does not enter one for you.

**Note:** Lump Sum items always have a quantity of 1. If the item you selected is a lump sum item, enter a quantity of 1. This applies to all items entered in this training guide.

Estimator enters the Extension price, which is the unit price multiplied by the quantity.

Let’s use the Undo function again.

18. Select Undo Change Item Unit Price from the Edit menu.

19. Select the **Edit** menu.

Since you undid one action, you now have the option to redo it. Instead, we are going to undo more actions.

20. Select Undo Change Item Quantity from the Edit menu.

21. Select Undo Change Item Number from the Edit menu.

Each time an Undo command was performed, the corresponding field became blank.

22. Select Redo Change Item Number from the Edit menu.

The item is reassigned to the estimate.

23. Enter **1** in the Quantity field.

24. Select the **Edit** menu.
Because you did not continue issuing the Redo command, the Redo memory has been erased. However, you could undo the Quantity field entry and continue to undo all previous entries. Instead, we are going to continue with our estimate.

25. Add a unit price of **476.00** if Estimator did not enter one for you.

Use the scroll bars to see the remaining information on the **ALL ITEMS** tab. If you entered a unit price, the Price Source field is *ad hoc*, meaning the item had a manually-entered unit price. If the item had a unit price, the Price Source field shows what kind of price basis was used to get the unit price - bid based, cost sheet, or reference price. If there is more than one price basis attached to the item, then the Price Source is Multiple.

![Figure 4-18. Estimator's All Items Tab With Description and Price Source Displayed](image)

Now we are going to select a group that already exists.

26. Scroll back to the beginning of the rows in the **ALL ITEMS** tab. Click in the empty Group # cell. Select **Group 005, Removal** from the drop down list.

27. Click in the Item # cell and select from the drop down list an item that has *Remove, Removal, or Reduction* in the description.

28. Enter a Quantity of **17**. Enter a Unit Price of **53** if Estimator does not enter one for you. Save your work.

Click the plus signs (+) located next to groups 0005 and 0020 in the tree area of your estimate. Notice you can see each of the items added to the estimate.
4.5 Adding Items to the Estimate

When you create a new estimate, it initially has one blank group. Most of the time you will add standard items (items found in the Standard Item catalog); your organization might require you to use only standard items. The Standard Item Catalog stores information about standard items.

There are times when you will use a standard item as the basis for a non-standard item, and there may be times when you manually create a new item. If you are creating an estimate to use with AASHTOWare Project (Trns•port) programs, only standard items marked as a Trns•port item can be used. You can find information about adding non-standard items to your estimate in the Estimator User's Guide.

The Standard Item Catalog contains the Item Code, Item Description, Unit, and default Price Basis information for the most commonly used items. If the standard item has pricing information available, Estimator copies that information and uses it for pricing the estimate item. You need to specify the desired quantity of any item you add.

When entering items on the groups tab, you first need to select the group to which the item will belong. When entering items on the all items tab, groups are assigned as the items are entered. We will discuss both of these and other methods in this section.

Note: If the item that is selected is obsolete, a message popup will be displayed providing a choice to add the obsolete item or not. If selected, the item will be added. However, during a verification process the item will be indicated as an obsolete item.
4.5.1 Entering Items on the Groups Tab

First we are going to add items to our estimate using the GROUPS tab. Follow these steps:

1. Open your estimate if it was previously closed. Navigate to Group 0005. You can do this through the tree view, the GO button, or any of the navigation arrows.

2. Select Add Item from the Edit menu. Estimator displays the item header window, in which you add information about the new item.

   Note: Remember an item was already entered using the All Items view.

3. Click the down arrow next to the Item Number field. Select an item that has Disposal in its description.

   Note: You can use the Find Item window to locate an item with Disposal in its description. Click the ellipses (…) next to the Item Number field. Enter Disposal in the Description field and press TAB. Select one of the items and click OK. The Find Item window is discussed in more detail in Section 4.5.5. Remember that even though this guide offers items to pick, you may pick your own item to use.

4. Estimator automatically enters the Unit Price, Description, and Unit fields for that item, if available. Estimator also brings over any price bases attached to that item, and fills in the Price Source field in regards to the price bases.

5. Enter 45 in the Quantity field.

6. If the item selected has a unit price, leave it alone. If not, enter 48.07 in the Unit Price field and press TAB.
Estimator enters the Extension price, which is the unit price multiplied by the quantity. If you entered a unit price, the Price Source field is *ad hoc*, meaning the item had a manually-entered unit price. If the item had a unit price, the Price Source field shows what kind of price basis was used to get the unit price - bid based, cost sheet, or reference price. If there is more than one price basis attached to the item, then the Price Source is Multiple.

Your screen should now look similar to Figure 4-21.

![Figure 4-21. Item Header Window With Information and Ad Hoc Price Basis](image)

Use the **TAB** key or the scroll bars to see the information Estimator added to the item.

Select the Group 0005 title in the tree area. Notice the Group Total field now has a value. This value is based on the extension value of its items.

Estimator will only accept numeric data in the English standard format. Quantities and prices entered should use a period to mark the decimal point, but do not use a comma to mark the thousand’s place.

If your system manager entered a URL for any of the estimate's entities in the Web Services option, then a tab appears for the entity with the name of the service. The way the information is displayed on the **WEB SERVICES** tab is determined by the transportation agency.

You can add any notes about the item on the **NOTES** tab.

### 4.5.2 Adding Items on the All Items Tab

Sometimes the Item List is presented in such a way that adding groups as part of the item is easier when constructing the estimate instead of adding items to groups. For this situation, use the **ALL ITEMS** tab when adding items to your estimate.

This section adds items in the **ALL ITEMS** tab. Follow these steps:
1. Return to the estimate header window if you have not already done so by either the navigation arrows or by clicking the estimate name in the tree area.

2. Select the ALL ITEMS tab if it is not selected.

3. Click the empty Group # cell in the blank item row. Select Group 0020, Administration.

4. Click in the Item # cell. An arrow appears. Click the arrow to open the list of items. Select an item with the word Computer in the description.

5. Enter 2 in the Quantity field (unless it’s a lump sum item) and 1500 in the unit price field, if not provided by Estimator.

![Figure 4-22. Item Added on the All Items Tab](image)

Use the TAB key or the scroll bars to see the fields in the grid area. Estimator brings over the same information that it does if you added the item through the GROUPS tab.

6. Click the green GO button for the item. This displays the item information. This window is the same one that displayed when you added an item using the GROUPS tab.
7. Select the estimate name in the tree area to return to the **ALL ITEMS** tab. Add another item to your estimate and assign this one to Group 0010.

8. Use the drop down arrow next to the Item # field and select an item with **Light** in the description.

9. Enter **10** in the Quantity field and **425.50** in the Unit Price field. Save your work.

---

**Figure 4-24. Item Added to the All Items Tab**

**4.5.3 Adding an Item Using the Drop Down Menu**

We are going to add an item using the drop-down item list. Select Group 0010 in the tree area.
Follow these steps:

1. Click once in the empty Line # cell below the items. A new item row appears.

   ![Figure 4-25. Item Created Through the Header Window](image)

   2. Click the drop down arrow next to the Item # field and select an item with *Light* in its description.

   Use the TAB key or the scroll bars to see the fields in the grid area. Estimator brings over the same information that it does if you add the item through the ALL ITEMS tab.

   3. Enter 12 in the Quantity field and press TAB. If the item does not have a price basis attached to it, fill in an amount for the price. Save your work.

   **4.5.4 Adding an Item Using the Drag and Drop Functionality**

   In addition to adding an item to an estimate from the estimate, you can also copy items into the estimate from the Current Catalog. Follow these steps to add items by copying them from the Current Catalog:

   1. With your estimate still open, open the Current Catalog by selecting *Show Open Catalogs* from the Catalog Tools menu.

   2. View the Standard Item Catalog by clicking on the plus (+) sign next to the catalog title (if it is not already expanded) and then highlighting the title Standard Item Catalog in the tree area. A grid area of the standard items shows in the right pane.
If the fields in the grid area of the Standard Item Catalog are unavailable like those in Figure 4-26, that means that you do not have permission to edit catalogs. You can still use the information contained in the catalogs to create your estimate.

3. Position the opened catalog and estimate so both are visible in the Estimator window. You can use the Tile commands from the Window menu.

4. In the grid area of the catalog, scroll to an item that has Build in its description. Click the GO button next to that item. Estimator displays the detailed information for the item and highlights it in the tree view.
5. Select the item in the tree view, and, while pressing and holding down your left mouse button, drag that item to Group 0015 in your estimate. Estimator copies that new item to your estimate.

6. Close the Current Catalog by making it the active window, then selecting **Close** from the **File** menu. Expand the size of the estimate window.

7. Enter **1** in the Quantity field for the newly added item. Enter **17000** in the Unit Price field if Estimator has not already entered a value for that field. Press **TAB**. Estimator fills in the Extension and Price Source fields.

8. Save your work. Return to the estimate header window.
4.5.5 Adding Items Using the Find Item Window

When you know the description or item code of an item, you can use the Find Item window to search for that item. You can also use the Find Item window to find a particular Unit, Unit System, or Trnsport item. The more you know about an item, the easier it is to find it.

1. Select the Group 0015 header in the tree area. Select Add Item from the Edit menu.

Next to the Item Number field in the detail window is a button with an ellipses (…). This button give you access to the Find Item window.

2. Click the Find Item button. The Find Item window displays.

![Figure 4-30. Find Item Window]

We are going to search for an item based on its description.

3. Click in the Description field and enter Design. Press TAB.

Note: Do not press ENTER or click OK. If you do, Estimator adds the first item in the Matches list to your estimate.

Estimator displays only those items that have the word Design in their description.

4. Select the last item listed in the Find Item window and click OK. Estimator adds that item to your estimate. Enter quantity and price information for the item if necessary. Save your work.
Now try adding another item to Group 0015 by yourself using the Find Item window. Refer to earlier sections of this document if you need help. Search for an item that has the word **Build** in the description. Select one of the items to become the newly added item. Add the other item information as necessary.

**Note:** If an item is displayed with a line through it, it means the item does not match the unit system (English, metric, or none) of the estimate and cannot be selected.

When you are finished, save your work and return to the estimate header window.
4.6 The Estimate So Far

So far in this chapter, we have learned how to add groups and items to the estimate and the difference between the GROUPS and ALL ITEMS tabs. We learned about the Find Item window and how to add items directly from the catalog.

Let's take a moment to see the effect these groups and items had on your estimate. Return to the estimate header window with the GROUPS tab displayed if you are not already there.

![Figure 4-33. The Current Estimate](image)

Look in the Estimate Cost and Estimate Total fields. These fields were empty until items and prices were added to your estimate. Estimator totaled the prices and contingency percent to derive the Estimate Total.

Click on each of the group headings and look at the Group Total fields. The item prices in each group are added together to form the group totals. The group totals are added together to derive the Estimate Cost.

Continue selecting various estimate elements to see how each part of the estimate relates to the other. When you are finished, return to the estimate header window.

4.7 Inserting and Moving Items Across Groups

There might be times when you will have to add an item to a particular group. You may even want to add it between two other items. You can also move an item from one group to a different group.

Say your version of Estimator increments line numbers by five, as does the one in the pictures of this guide. When you add an item to an estimate group, Estimator adds it as the very last item in the group, and gives it the item number a specified increment greater
than the last item number (i.e. if your estimate items increase by five, and the estimate has items numbered up to 30, if you add an item, it will be number 35). Estimator numbers inserted items based on the item numbering in the group to which it is inserted. You can insert the item between other items, or add it as the first item, by positioning the cursor where you want the item located and selecting Insert Item from the Edit menu.

If you insert items or move them across groups, you can renumber the items in the estimate so they are arranged numerically. This function is discussed in Chapter 5.

Before we arrange the items, however, we are going to hide the tree view. You can navigate throughout Estimator only using the grid area.

1. If you have closed Estimate 2009_0827SS, open it again.

2. Select Hide Tree View from the View menu.

Estimator hides the tree area and shows only the grid.

![Figure 4-34. Estimate With Tree Area Hidden](image)

### 4.7.1 Moving an Item

After you create an item in a group, you can move that item’s order within that group or to another group. There are three ways of moving an item: You can use the ALL ITEMS tab to assign it to a different group; you can cut and paste the item using the Cut and Paste commands on the Edit or right mouse button menu; or you can use the mouse to drag the item to the desired location.

Follow these steps to move items across groups:

1. Select the ALL ITEMS tab if it is not already selected.

2. Sort the list according to group number by clicking the Group # column title once.
3. In the All Items grid, select the last item in the list.

4. Click the down arrow next to the Group # field and select Group 0015. Estimator moves the item to Group 0015 and reassigns the item line number. This changes the groups' totals, but all other information about the item remains the same.

In addition to using the ALL ITEMS tab to reassign items to different groups, you can also use the GROUPS tab.

5. Select the GROUPS tab.

6. Click the GO button next to Group 0005.

7. Select the first item in the Item list. Make sure the entire row is selected and not just one cell. Select Cut from the Edit menu.

8. Click the yellow UP arrow to return to the estimate header window.

9. Click the GO button next to Group 0015.

10. Select Paste from the Edit menu. Estimator pastes the item into Group 0015.

```
Figure 4-35. Item Moved to Group 0015
```

Another way to move and item is to drag it with the mouse. Follow these steps to move the item from Group 0015 back into Group 0020. You need to be able to see the tree area in order to drag the item with the mouse.

11. Select Show Tree View from the View menu.

12. Highlight the item in Group 0015 that was previously assigned to Group 0020. In our estimate, it is line number 0050. If you do not remember which item it was, highlight any of the items in Group 0015.
13. Without lifting your finger from the mouse, drag the item to the Group 0020 title in the tree area. Estimator places the item at the end of Group 0020 and assigns it a new line number.

Follow these steps to move an item within its group:

14. In the tree area, highlight the last item in Group 0015. In our estimate, it is line number 0050.

15. Drag it over the first item in Group 0015, so the first item is highlighted. 

16. Release the mouse.

Estimator places the last item before the first item, and renumbers it to fit its location in the estimate. In our estimate, it became line number 0032.

Figure 4-36. Moved Item in Group 0015

4.7.2 Inserting an Item

If you find you need to add an item to an estimate, and you want that item to be in a certain position in the group, you can insert the item into the group instead of simply adding it.

1. Select Group 0005 in the tree area to display the group information.

To insert an item, highlight the location that you want the new item to occupy.

2. Highlight the item in Group 0005. In our estimate, it is line number 0015.

3. Select Insert Item from the right mouse button menu.
Estimator adds new item line number 0010. The item is now ready for your input.

4. Select an item that has the words **Remove** in the description. Use the Find Item window if necessary by clicking the **GO** button to access the Item Detail window.

Estimator also allows you to enter a formula in a field to represent a number using percentages, addition, subtraction, multiplication, and division symbols. Estimator calculates the results of the formula for you. Specify multiplication by an asterisk (*) and division by a slash (/).

5. Enter **(49+5)*2-100** as the quantity and press **TAB**. Enter a unit price if necessary. Save your work.

- **Note:** If you often use equations to derive a total, you can store that equation on the **NOTES** tab of the estimate header, group, or item.

Estimator fills in the Price Source, and the Extension Price, and brings in the associated price bases, if any.

![Figure 4-37. New Inserted Item 0010](image)

### 4.7.3 Deleting an Item

If you add an item in error, or find another item that better suits your purpose, you can delete the item using the Delete command on the Edit menu. In the previous exercise, we deleted the item as part of the cut and paste functionality.

1. Select the last item in Group 0015.

2. Select **Delete Item** from the **Edit** menu. Save your work.

Estimator deletes the item and all associated price bases from the estimate.
Caution: Be careful when using this command. If you delete an item in error, you must recreate it (or retrieve it from the archives). If you realize your error before you save, you can use the Undo command on the Edit menu.

4.7.4 Deleting a Group

If you have too many item errors in one group, it may be better to delete the group and start over again than to try to fix all the errors within the group.


2. Select Delete Group from the Edit menu. Save your work.

Estimator deletes the group, plus all items and price bases within that group.

Figure 4-38. Estimate With Group Deleted

4.8 Working With Price Bases

Estimator can determine unit prices for items automatically if the item you select from the Standard Item Catalog has at least one price basis from one of Estimator’s price basis catalogs attached to it. Price bases include cost sheets, bid histories, and reference prices. (For a detailed discussion of these estimation methods, see Chapter 2.)

When you instruct Estimator to copy an item from the Standard Item Catalog, Estimator also copies all the price bases attached to the item. The active price basis defined in the Standard Item Catalog is the active price basis used when the item is copied from the catalog.

Although your Estimator system manager (or another person designated to maintain the Estimator catalogs) designates the default (active) price basis for a given Standard Catalog item, you can always designate a different price basis to be the active price basis.
for the items you add to your Item List. There can be more than one active price basis for any item.

If you do not want to use a price basis that is attached to an item, you can either make it inactive or delete it. It is recommended that you make it inactive until you are positive the price basis is no longer needed. Then you can delete it.

**Note:** Before starting this section, you may want to look in the catalog and find a few items that have a price basis attached. You can also talk to your system manager about setting up a price basis for selected items. Use those items when told to select an item by the training guide.

### 4.8.1 Viewing an Item’s Price Basis

To see what price bases an item brought over from the Standard Item Catalog, highlight the item in the tree area, click the GO button next to the group and then the item in the grid area of the GROUPS tab, or click the GO button next to the item in the ALL ITEMS tab. The grid area shows the item details, including the attached price bases. You can also click the plus (+) sign next to the item in the tree area to show the attached price bases.

To view an attached price basis, click the GO button next to the price basis in the grid area, or highlight the price basis in the tree area. Estimator displays the details of the price basis in the right pane.

**Note:** Depending on the items you chose, you may not have any price bases attached to the items.

![Image of Reference Price Details of Item]

Figure 4-39. Reference Price Details of Item

### 4.8.2 Changing the Price Basis

Follow these steps to change the price basis of an item:
1. Insert a new Group 0010 to your estimate. To do this, select Group 0015 and choose **Insert Group** from the **Edit** menu.

2. Enter the group description **Bridge Work**.

3. Add a new item to the Bridge Work group. Do not fill in any information for this item yet. In our estimate, this item is item line number 0060.

4. Display the new item in the item detail window.

Remember how we used sort options to choose values for the estimate header fields? These options are also available for the item list.

5. Right click on the down arrow next to the Item Number field. **Estimator** displays the sort options.

6. Select **Sort Standard Items by Description**.

   **Note:** If this option is unavailable, and it instead displays Sort Standard Items by ID, then your item list is already sorted by description.

7. Select an item with the words **Slope** in the Description. **Estimator** brings in the item, the item unit, and description, and the unit price and price basis if available.

8. Enter **9** in the Quantity field and press **TAB**.

When **Estimator** brought in the item, it also brought in its active price bases, if one was available. You can tell the active price basis by the checkmark in the Active column of the grid in the right pane.
**Note:** If there are no price bases attached to the item, you can add one by selecting **Add Reference Price** from the **Edit** menu. Enter the item number in the Reference Price ID field. Enter **14.79** in the Unit Price field, and enter **Added Price Basis** in the Description field.

9. Click the plus sign (+) next to the item in the tree area to see the price basis.

10. Clear the checkmark in the Reference Price Active column in the grid, making the price basis inactive.

Estimator places an X on the inactive price bases in the tree. This is another way of seeing which of the price bases is active.

Notice when the price basis is inactive, the values change for the Unit Price, Price Source, and Extension fields. These fields are based solely on the active price basis. If
there is no active price basis, the values for the numeric fields would be 0.00 and the Price Source would be None. This is because there would be nothing on which to base the price.

11. Make the price basis active again selecting the price basis in the tree area and selecting **Toggle Active/Inactive** from the right mouse button menu.

Suppose the supplier of the item who gave you the reference price had to increase the price due to inflation. You need to reflect that change in the estimate.

12. Look at the Extension field for the item in the item header window.
13. Click on the **GO** button next to the reference price for the item. This brings you to the detail window for the reference price.
14. Click in the Unit Price field. Change the unit price to **15.57**.
15. View the item's Extension field again. The change in price is shown in the item's detail window.

### 4.8.3 Adding a Price Basis

Suppose you have two estimate prices for one item, and wanted each to be available to use in the estimate. One could be for a low quantity of the item; the other could be for a higher quantity. You could create a price basis for both prices, and then decide later which to use.

Follow these steps to add a new price basis to line number 0040 (the last item in Group 0015):

1. If there is already a reference price basis attached to item 0040, select **Add Reference Price** from the **Edit** menu. Estimator brings in a blank Reference Price detail window, and makes it an active price basis along with the other active price bases.
2. Enter the already-existing reference price's Reference Price ID in the ID field for the newly added reference price. Add a unit price that is much higher than the already-existing price. Enter a description of **Low Quantity**.
3. If there is no existing reference price for item 0040, select **Add Reference Price** from the **Edit** menu. Estimator opens a blank Reference Price detail window.
4. Enter 100 in the Reference Price ID field if you were not able to copy an already-existing reference price. Enter 75 in the Unit Price field, and enter **High Quantity** in the Description field. Save your work.

5. Add another reference price to your estimate. Enter the same Reference Price ID. Enter a unit price of **104.79**, and enter **Low Quantity** to the description in the Description field. Save your work.

6. Select the item in the tree view. Estimator displays the new reference prices:

![Figure 4-44. Two Newly Added Reference Price Basis](image)

Look at the Price Source field of the item, which says Multiple. This is because the item has two active price bases, regardless that they are the same type. The Unit Price is the total of both active price bases unit prices. In order to have an accurate estimate, one of these price basis should become inactive.
4.8.4 Toggling a Price Basis Active/Inactive

Both reference prices for item are active. In our estimate, however, only one can be used, since the price changes with the quantity.

1. The Low Quantity reference price fits the quantity better, so make the High Quantity reference price inactive. To do this, highlight the reference price in the tree area, and select Toggle Active/Inactive from the Edit menu.

Estimator places a red X on the inactive price basis.

2. Save your work.

Now look at the item's Unit Price, Price Source, and Extension fields. The price is significantly less due to only one price basis being active. The Price Source reflects the type of active price basis.

You can also make a price basis active or inactive by using the Active check box in the group header window or in the price basis detail window.

Estimator does not check to see whether the price basis you chose for an item is appropriate or inappropriate. You must select a price basis that makes sense for the selected item quantity and estimate conditions. To be sure a price basis is appropriate, examine its contents.

4.9 Using a Percentage of the Estimate as a Price

When you are using a reference price as the price basis, you have the option of pricing the item as a percentage of the estimate total. Let's see how that works.
1. On the estimate header window, note the value in the Estimate Cost field.

2. Select the ALL ITEMS tab. You can use the GROUPS tab if you prefer.

3. Add a new item to your estimate. Add a new group named Mobilization, and add an item to that group with Mobilization in the description.

4. Enter 1 in the Quantity field.

5. If Estimator brought over any price bases with the item, make them inactive. Do this in the tree area or in the item header window.

6. Add a Reference Price to your item. Make the Reference Price ID field the same as the item number.


8. Select the Percent of Estimate check box.

Notice that the Unit Price field has become unavailable and a field appears for you to enter the percentage.

9. Enter 6.25 in the Percent field. Save your work.

A price appears in the Unit Price field. This is the current value of the item. Now when Estimator prices the estimate, the cost of the mobilization item is determined by the total cost of the estimate. This total can change depending on whether other items are added to the estimate or if the price of some of the items change.

Note: When using Percent of Estimate as a way of pricing an item, the percent is taken from the total of the estimate before the cost of any of the Percent of Estimate items are figured into the Estimate total.
10. Press the yellow **UP** arrow on the menu bar several times until Estimator displays the estimate header window.

![Figure 4-47. Estimate 2009_0827SS Header Window](image)

The header window shows the new groups, complete with group totals, which is the cost of all the items in a group, and the group descriptions. The Estimate Cost field reflects the item totals with the Mobilization item priced as a percentage of the estimate.

### 4.10 Verifying the Estimate

Estimator adds an exclamation point to any item or group that has missing or incorrect information. You can search for the information by locating those groups and items, or you can use the Verify Estimate option.

There are no exclamation points visible in this estimate, but we will cause an error so we can use the Verify Estimate option.

1. Locate and remember the value in the Quantity field for the first item in our estimate. Delete the value in the Quantity field (but not the item itself).

2. Press **TAB**.
3. Although Verify Estimate can be used anywhere within the estimate, return to the estimate header window.

4. Select **Verify Estimate** from the **Edit** menu.

The Verify Estimate option displays a table of what is missing or incorrect and the location of the errors in the estimate.

![Verify Estimate Window](image)

The window divides the errors first by ID of groups and items, displayed as line numbers. The Type tells you the reason it was flagged, and the Message tells you the error in greater detail.

Estimator allows you to save a log of your errors to print or for reference. To save the log, click **SAVE LOG** from the Verify Estimate window. Estimator saves the log in a .CSV format that allows it to be opened in a spreadsheet program, such as Excel.
You can jump to each error location by double clicking anywhere in the row for that error.

5. Double-click on the error with the Message The Item Quantity is not valid.

Estimator brings you to the error selected.

6. Re-assign the original quantity to the item and press **TAB**.

7. Instead of selecting Verify Estimate, click the yellow **CHECK MARK** in the menu bar. This is another way to access the verify function.

When all the errors have been corrected and you select Verify Estimate again, Estimator displays the following window:

```
Estimator

No associated errors were found.

OK
```

Figure 4-50. Verify Estimate - No Errors

8. Click **OK**. Remember to save your work.

**The Verifications Tab**

The Verifications tab allows the user to turn verification messages on or off. Often, verification messages are received because of business processes that do not require reporting each time the estimate is verified. This feature allows the user to turn off verification messages if desired.

Currently, verification messages default to business processes that were deemed necessary for the overall product and do not necessarily reflect agency business processes. When an estimate is verified, the verification messages are provided in a message popup window that identifies the error or warning, and the data can be saved in a CSV file.

The following verification options can be checked (allowing the verification messages to be displayed) or not checked (verification messages will not be displayed):

- **Funding**
  - If this option is checked and a funding package is assigned to the estimate, then funding verification messages will be displayed if there are funding-related issues.

- **Obsolete Items**
  - If this option is checked and the estimate has obsolete items, verification messages will be displayed.
**Duplicate Line Numbers**

If this option is checked and if existing estimates files or imported files have duplicate line numbers, verification messages will be displayed. Checking the "Prohibit Duplicate Line Numbers" checkbox in the General tab under Global Options will display verification messages for new estimates.

**AASHTOWare Project Compatibility**

If this option is checked and when the Estimate Option "Only Transport Item and Codes are allowed" is checked, verification messages are displayed.

**Multiple Active Price Bases**

If this option is checked, and if existing estimates files or imported files have multiple active price bases, verification messages will be displayed. Checking the "Prohibit Multiple Active Price Bases" checkbox in the General tab under Global Options will display verification messages for new estimates.

By default, all verification options are checked.

![The Global Options Window - Verifications Tab](image)

Figure 4-51. The Global Options Window - Verifications Tab
4.11 Printing the Estimate

Estimator uses Crystal Reports® to produce a quality printout of your estimate. When you print an estimate, detailed information about the price basis being used for each item can also be printed if specified. Your agency name will appear on the printed report provided the information has been entered by the system manager in the Global Options.

Now we are going to preview your estimate and then print it.

1. Select **Print Preview** from the **File** menu.

Estimator displays a Print Message box that contains several options.

When none of these check boxes are selected, Estimator prints a normal estimate that lists estimate header information, items, quantities, units and unit prices, the extended amount for each item, group subtotals, and the estimate total. If one or more of the boxes is selected, detailed item and price bases information may also be printed. Here are the available options:

- **Show Item Description**
  
  If this option is selected, the Show Item Description option prints the item description and supplemental description fields as part of the item text in the report.

- **Show Inactive Price Bases**
  
  If this option is selected, the Show Inactive Price Bases works with the Show Price Bases Details option to display any inactive price basis associated with the items of the estimate. However, if Show Price Bases Details is set to None, then the inactive price...
bases are not displayed.

<table>
<thead>
<tr>
<th>Hide Prices</th>
<th>If this option is selected, the estimate report will not display the estimate total, group total, the estimate items’ unit price and extended amount values. Selecting this option will also hide the price bases, as if the existing report setting of Price Bases Display level was set to None.</th>
</tr>
</thead>
<tbody>
<tr>
<td>No Page Breaks Within Items</td>
<td>If this option is selected, the No Page Breaks Within Items prevents an item and the item’s details from being split across two pages. When printing the item, the details will stay on one page.</td>
</tr>
<tr>
<td>Show Notes for Groups</td>
<td>If this option is selected, then any information on the NOTES tab for your groups will be printed on the estimate.</td>
</tr>
<tr>
<td>Show Notes for Items</td>
<td>If this option is selected, then any information on the NOTES tab for your items will be printed on the estimate.</td>
</tr>
<tr>
<td>Total Item Quantities Across Groups</td>
<td>If this option is selected, the items are organized numerically instead of by group. It combines like items together and only lists them once for the entire estimate. The item unit price is calculated by dividing the summed extended prices by the summed quantities for each grouping so the estimate total does not change. It sorts and lists the items by item and item supplemental description. Also, the Show Notes for Groups option and Show Notes for Items option become unavailable.</td>
</tr>
<tr>
<td>Summary of Quantities by Item and Group</td>
<td>If this option is selected, like items are grouped together but not combined. Thus repeating item/item supplemental description pairs would be listed once within a group. The item unit price is calculated by dividing the summed extended prices by the summed quantities for each grouping so the estimate total does not change. Also, the Show Notes for Groups option and Show Notes for Items option become unavailable.</td>
</tr>
<tr>
<td>Show Price Bases Details - Summary</td>
<td>If the Show Price Bases Details is set to Summary, every price basis is listed for each item as is the price basis description. It also includes the unit price for the item based on the price basis type.</td>
</tr>
<tr>
<td>Show Price Bases Details - Detailed</td>
<td>If the Show Price Bases Details is set to Detailed, any bid-based price bases also include the price basis details ranging from rate catalog information for cost sheets to the percent on top for reference prices.</td>
</tr>
</tbody>
</table>
Report Alignment

Use this option to select the way your estimate will be printed. Use the Portrait or Landscape check boxes to determine the layout of your printed estimate. If you choose Portrait, you can also set the alignment.

Select Customized Report

Use this option to assign a customized print report template to your estimate. If you do not have or do not specify a customized report, the default print options will be used.

2. Make sure the Show Item Descriptions and No Page Breaks Within Items check boxes are the only selected elements.

3. Click OK.

Estimator displays a preview of what your estimate will look like if this is the option you choose when you print.

4. Use the arrows in the menu bar of the print window to view the pages of your estimate. Your second page should look similar to Figure 4-53.

![Figure 4-53. Print Preview of an Estimate With Item Description (Page 2)](image)

5. Close the Print Preview window and again select Print Preview from the File menu.

6. Change the settings in the Print Options window to view the different ways your estimate can be printed.

Creating an Estimate
7. When you are finished, return to your estimate and select **Print** from the **File** menu.

8. Select your print options and click **OK**.

Estimator displays the Print Setup window. On this page, you can select the printer using the drop down list in the Name field. You can also determine if you want the estimate to print out portrait-style or landscape-style, the paper size, and other print options.

9. Make sure your printer is selected and click **OK**.

Once you click **OK**, a Printing Records status window appears. It shows you the progress of your print job until it has completed.

10. Review your printout, noting how the information in your estimate is displayed in print.

11. Close the estimate by selecting **Close** from the **File** menu. You may also exit Estimator if you wish.
5. Other Estimator Features

There are many features of Estimator that make estimating easier. This chapter offers a brief discussion of some of the many valuable functions that Estimator offers to help you create estimates.

5.1 Opening an Archived Estimate

As discussed in Chapter 2, you can save multiple versions of the estimate. If the Archive utility is enabled, then you can view previous versions of the estimate. When your estimate is closed, select Global Options from the Other Tools menu and look at the GENERAL tab. You can use the Archive Level command to create a history of the estimate, and then scan through estimate developments or undo recent changes. If there is a value in this field that is more than 0, then the archive utility is functional. Click CANCEL.

Estimator saves an archived estimate each time you save your estimate. Estimator appends a number (one through nine, depending on how high the archive is set) to the extension of the file name to mark it as an archive. To retrieve an archived estimate, select Open from the File menu. Estimator opens the Open Estimate window. Click the down arrow next to the Files of Type field and select All Files (*) .
Look for the files named **2009_0827SS**, and the file extension .est\text{n}, where \text{n} is the level of archive for that particular file.

\textbullet \textbf{Note:} Depending on how many times you saved Estimate 2009_0827SS, your archived estimates may look different than the one in Figure 5-1.

Select the archive you want to open and click OPEN. Estimator opens the archived estimate like a normal estimate.

If you save an archived estimate (by selecting Save from the File menu), it does not become the current estimate. It stays in the saved archive form with the file extension .est\text{n}. If you want the archived estimate to become the current one, use the Save As command instead.

Close the archived estimate.

### 5.2 Refining Estimates

Estimator makes it easy to modify an item, even after it is added to the Item List. Values for existing items can be changed, items can be added or deleted, the order of the items in the list can be modified, and entirely new price bases can be created and attached to items already appearing on the Item List.

#### 5.2.1 Renumbering Estimate Items

If you added items to your estimate using the ALL ITEMS tab, or if you inserted items into your estimate, then your estimate line numbers might have different increments between
each item when viewing the estimate sorted by groups or when the estimate is printed. While this is acceptable in Estimator, you may want to renumber the items to give your estimate a uniform look. You can do this by using either the Renumber Estimate Items command or the Renumber Using Current Order command. When you use either of these commands, the items in each group of your estimate are renumbered. You can use the Renumber Selected Items command to renumber only specific items.

You must be in an item grid to use the Renumber Using Current Order or Renumber Selected Items commands.

In this example, we will use the Renumber Estimate Items command.

1. Open Estimate **2009_0827SS** if it is not already open.
2. If the tree area is not expanding the Item List, select **Expand All Tree View** from the **View** menu to see the item numbers. This is not a necessary step, but allows you to see which items will be renumbered.
3. Click the item in Group 0010.

   ![Figure 5-2. Estimate 2009_0827SS With No Renumbering](image)

   The line number for the item in Group 0010 is 0060. When you renumber the estimates, Estimator changes the items to start at the designated starting number and increment by the designated increment; in our case, by five.

4. Select the **ALL ITEMS** tab. Click the Group # column heading to sort the items by their group if they are not already sorted. This allows you to see all the items in a row.

5. Look at the Line # column to see which numbers are out of order.
6. Select **Renumber Estimate Items** from the **Edit** menu. Estimator changes the items to increment by five, which can be seen in both the tree area and in the **ALL ITEMS** grid. Save your work.

*Note:* If your estimate items are not set to increment by five in the Global Options, then your numbers will be different.

You do not need to renumber your items in an estimate. However, having each item increment by the same amount can make viewing the estimate easier.

Now select other groups and items and renumber your estimate items with the other two renumbering commands. When you are finished, save your work.
5.2.2 Updating Price Information

If the system manager or any other super user makes any changes to the Equipment, Labor, or Material Catalogs that you want reflected in your estimate prices, you must refresh the prices in your estimate. For example, if the minimum wage increased, the Labor Catalog would need to be modified accordingly to reflect pay increases.

Open your estimate if it is not open already. You can choose to update the entire estimate by highlighting the estimate title, a selected group by highlighting the group, a selected item within a group by highlighting that item, or a price basis by highlighting the price basis.

Once you have selected the element for which you want to update the price information, select **Update Price Information** from the **Edit** menu. The Update Selected Price Information window opens with three available options.

![Figure 5-5. Update Selected Price Information](image)

If you choose the first option, **Refresh Time Dependent Data and Cost Sheet Structure**, then selected reference prices, bid history prices, and cost sheets are updated with the corresponding catalog element. If a cost sheet does not have any corresponding catalog elements, then Estimator attempts to update it by looking to the individual catalogs within the cost sheet (equipment, labor, and material).

If you choose the second option, **Refresh Time Dependent Data**, then selected reference prices and bid histories are updated with the corresponding catalog element. Selected equipment, labor, and material rates are updated with values from the catalog; however, the cost sheet structure and fields do not update, although the individual catalogs within the cost sheet (equipment, labor, and material) are updated.

If you chose the third option, **Refresh**, then Estimator compares the items in the estimate to the catalogs and then modifies the estimate’s cost sheets according to any new or changed information that exists in the catalog. (It writes in any new materials,
equipment, or labor rates from the Bid History Catalog, Material Rate Catalog, Equipment Rate Catalog, and Labor Rate Catalog, respectively.)

Once you decide which option to use, click OK, or click CANCEL to leave the price information with no updates.

5.3 Sorting in Estimator

Estimator can sort (reorder) groups and items in an estimate, as well as any catalog list. You can sort on any of several fields and you can sort in either ascending or descending order. If you make changes after you sort the Item List (additions or deletions to the Item List or changes in quantities or values of individual items), you might need to sort the list again to restore the desired ordering.

You can also sort code table values on the header window and the item list while choosing an item to add to your estimate.

Once you sort in Estimator, the list maintains that sort in the grid area even after you close the element (estimate or catalog, item, or code table). If you are sorting an estimate or catalog, the tree area does not reflect the sort.

5.3.1 Sorting Groups

To show how Estimator uses the sort function, we are going to sort the groups by Description.

1. Access the header window of estimate 2009_0827SS.
2. Select the groups tab. In the grid area, click the title of the Description column. Estimator sorts the groups in ascending numeric (0-9), then ascending alphabetic (A-Z) order by their descriptions.
3. Click the Description column again. Estimator sorts in descending alphabetic (Z-A), then descending numeric (9-0) order

When you sort groups in the grid, the tree remains the same. Sorting can be used to easily find a particular description of related groups.

5.3.2 Sorting Items

First, we are going to sort items within a group by the unit price.

Note: If you want to sort items across groups, you must do so from the ALL ITEMS tab.

1. Display the header information for Group 0015.
2. In the grid area, click the Unit Price column title. Estimator sorts the items based on their unit price in ascending numeric (0-9). Estimator reverses the sort if you click the column title again.

![Figure 5-6. Items in a Group Sorted by Unit Price](image)

Like sorting groups, sorting the items does not change the order of the items in the tree area. The ability to sort items is helpful if you want to find items that relate to one another, or the different units of measure, or any other item description.

Practice sorting the groups and items by the different column titles.

Now, we are going to sort items before they are chosen for your estimate.

1. Select Group **0025**.

2. Add an item to the group. Make sure the item appears in its own window and not part of the group header window.

3. Right-click on the down arrow next to the Item Number field. Estimator displays the Item sort options.
4. You can sort the item list by Item Description or by Item ID, in ascending or descending order. Once the option is selected, left-click the down arrow to choose the item to add to your group.

5. The Items list retains the sort option chosen. If you add a new item using the grid in the group header, the item list reflects the last sort chosen.

6. Close the item list without choosing an item and delete the new item.

7. Save your work and close the estimate.

5.3.3 Sorting in the Current Catalog

Open the Current Catalog by selecting Show Open Catalogs from the Catalog Tools menu. Access the Code Table SEASON.

Figure 5-7. Item Sort Options

Figure 5-8. Code Table SEASON
In the grid area, click the Description column title. Estimator sorts the code table values based on their description in ascending numeric (0-9), then ascending alphabetic (A-Z) order (if there are any alphabetic items). Estimator reverses the sort if you click the column title again.

Practice sorting the catalogs by column titles. When you are finished, close the Current Catalog. Even if you do not have catalog edit privileges, the catalog maintains the sort order.

5.3.4 Sorting Code Table Values

Let’s sort code table values to add to the estimate header.

1. Open estimate 2009_0827SS and access the header window.

2. Right-click the down arrow next to the Work Type field. Estimator displays the sort options. This window is available for any of the field values that are derived from a code table.

3. You can sort the field values by the code table ID in ascending or descending order. Once you have selected which option to sort by, click the down arrow next to the field and select the field value.

4. Close your estimate and close Estimator if desired.
6. Working With Catalogs and Code Tables

This chapter assumes a user with super-user status or catalog edit privileges. Even if you do not have super-user status or editing privileges, please read through this chapter as it does contain information for every type of user. If this chapter contains an exercise that you are not able to do, it is possible that you do not have the correct permissions to do it.

When estimating a project, estimators use a core set of information to develop several different estimates. Estimator catalogs are the “information banks” of the system, because they store core information for use in estimation. The Estimator catalogs make data readily available through a well-organized, easy-to-use interface. You can quickly use information from the catalogs in your Estimator projects.

The Code Table catalogs store the information used in drop down lists in fields where you select given choices, such as on the estimate header window.

While most users can view each catalog, only those with edit privileges can edit a catalog. However, all users who can view the catalog can use the drag and drop functionality when moving items or price bases from a catalog to an estimate. You can not use the drag and drop functionality with code tables.

- **Note:** For information on printing catalogs, please see the Estimator User’s Guide.

6.1 Working With Catalog Information

To see the Current Catalog, select Show Open Catalogs from the Catalog Tools menu.
Click on each of the catalog names to see the contents of the catalog. You can view the details for each catalog element by clicking the green GO button next to the desired element.

6.2 Copying the Current Catalog

If you have permission to edit the current catalog, Estimator allows you to copy the current catalog and save it under a different name. You can use the Copy Current Catalog command to accomplish a few tasks:

- Create archives of the current catalog for future reference
- Create metric unit or English unit specific catalogs by removing items with the wrong system of measure and saving the catalog under a different name
- Restore catalogs that may have been corrupted or temporarily changed

When an Estimator catalog window is active, Estimator enables the Copy Current Catalog command on the Catalog Tools menu. When you choose Copy Current Catalog, Estimator opens an Enter Name for New Copy of Current Catalog window.
The file name of the catalog being copied appears in the field above the catalog list. Enter a new file name for the copied catalog and click SAVE, or click CANCEL to not copy the catalog. Once you click SAVE, Estimator writes the catalog to the disk and makes the newly created catalog the Current Catalog.

### 6.3 Switching the Current Catalog

The different catalogs can reflect many things, such as a different system of measurement or a different customer base. When creating an estimate, you might need to change the Current Catalog to match the properties of the estimate.

To change the Current Catalog, select **Switch Current Catalog** from the **Catalog Tools** menu. Estimator displays the Select Catalog to Open window.
Select the catalog you want to be the Current Catalog, and click OK, or click CANCEL to keep the existing current catalog.

! **Caution**: Do not switch catalogs while an estimate is open. That estimate will become read-only.

Once the new Current Catalog is selected, Estimator loads the information related to that catalog, and that catalog is ready to use.

### 6.4 Searching for Catalog Elements

You can search for specific catalog items or price bases using the Find window and the Find command on the Tools menu. The Find command is accessible at any point when you are logged in to Estimator. The Find window is accessible only from the detail view for the specified element. These commands are available to Estimator users able to see the catalog or estimate.

#### 6.4.1 The Find Command

The Find command on the Tools menu allows you to search the Standard Item catalog, the Cost Sheet catalog, the Bid History catalog, and the Reference Price catalog. You can only search for one type of catalog at a time.

You can also use the Find command when in a specific catalog by selecting Find from the Edit menu when the heading of the catalog is highlighted.

To use the Find command on the Catalog Tools menu:

1. Select **Find**… from the **Catalog Tools** menu and choose the element for which you wish to search. Estimator displays the Find window for the selected element.

![Figure 6-4. Find Bid History Window](image)
2. Enter the search criteria in the available fields. Each time you enter search criteria, Estimator automatically displays the matching elements in the Matches list.

3. Select the desired element from the Matches list and click OK. Estimator highlights the catalog element in the catalog window, opening the Current Catalog if it is not already opened.

The Find command from the Tools menu can be used at any time when Estimator is open.

To use the Find command from the Edit menu:

1. With your Current Catalog open, select the heading of the catalog you wish to search.

2. Select **Find…** from the **Edit** menu. Estimator displays the Find window.

3. Enter the search criteria in the available fields. Each time you enter search criteria, Estimator automatically displays the matching elements in the Matches list.

4. Select the desired element from the Matches list and click OK. Estimator highlights the catalog element in the catalog window.

**6.4.2 Finding a Price Basis in an Estimate**

We already saw how to search for an item when building your estimate (Section 4.5.5). Estimator also allows you to search for specific catalog elements for your items. You cannot search for code tables in an estimate.
You can only search for an element that has been added to the item in the catalog. We are going to add a cost sheet to an item in our estimate, and then search for the desired cost sheet.

1. Open Estimator and access Estimate 2009_0827SS if they were previously closed.

2. Select an item that does not have any attached price basis. In our example, we are choosing line number 0020 in Group 0015.

3. Select **Add Cost Sheet** from the **Edit** menu. Estimator displays the Cost Sheet header window.

4. Click the ellipses (…) located next to the Cost Sheet Name field. Estimator displays the Find Cost Sheet window.

5. Enter the search criteria in the available fields; in our case, **haul** in the Description field. Each time you enter search criteria, Estimator automatically displays the matching elements in the Matches list.
6. Select the desired cost sheet from the Matches list and click OK. Estimator adds the cost sheet to the item in the estimate.

6.5 Scheduling Catalog Imports

In addition to manually updating catalogs and catalog components, you can schedule regular updates to import catalog data from an external file. The Catalog Import Scheduler allows users with catalog import authority to schedule catalog updates on a one-time or regularly scheduled basis. The following catalogs can be updated using .xls, .xlsx, .csv, or .txt files through the Catalog Import Scheduler:

- Standard Item catalog
- Bid History catalog
- Cost Sheet catalog
- Reference Price catalog
- Equipment Rate catalog
- Labor rate catalog
- Material rate catalog
- Code table PKWRKTyp
- Code table SEASON
- Code table URBRUR
- Code table COUNTY
- Code table UNITS
- Code table HWYTYPE
- Code table DISTRICT

To schedule a catalog update:

1. From the **Tools** menu, select **Catalog Import Scheduler**. The Catalog Update Scheduler window appears.

   ![Catalog Import Scheduler](image)

   **Figure 6-9. Catalog Update Scheduler**

2. Click **New Schedule**.

3. Select the catalog to update.

4. Navigate to a folder containing an .xls, .xlsx, .csv, or .txt file containing the catalog data you wish to import. Select the file and click **OK**.
**Note:** Whether you are scheduling a single catalog update or a recurring series of updates, AASHTOWare Project Estimator will always look to the path you select for the Excel file. If the path for this catalog file changes, remove the schedule you created and create a new schedule that references the new path for the Excel file.

5. Select a **Date and Time** for the catalog update from the selected file.

6. Select one of the following radio buttons under **Repeat Schedule**:

   - **Daily** – The catalog update occurs every day at the selected time, from the selected date.
   - **Weekly** – The catalog update occurs every seven days, starting with the selected date, at the selected time.
   - **Monthly** – The catalog update occurs every month, starting with the selected date, at the selected time.
   - **No Repeat** – The catalog update occurs at the selected date and time without repeating.

7. Click **OK** to finish.

   When the import runs as scheduled, a modal window showing the results of the import may appear. For example, if a non-repeatable schedule for the current time and date ran, then a pop-up window will open immediately. Otherwise, the Result Modal window appears when the import is scheduled to occur.

![Result Modal Window](image)

**Figure 6-10. Result Modal Window**

A log with the file name est_schedule_log.txt, containing the date and time stamp for the import, is created in your system whenever an update occurs successfully. This log is
saved to C:\ProgramData\Estimator for Windows 7 users and C:\Documents and Settings\All Users\Application Data\Estimator for Windows XP users.

To remove a scheduled catalog update, select it from the left panel on the Catalog Update Scheduler window and click Remove Schedule.
7. Navigating Through Estimator

There are many ways to navigate through Estimator. You can use the tree area and click directly on the information you need, or you can use the GO button in the grid area. You can also use the navigation arrows in the menu bar. It is up to you to decide what method of navigation to use when viewing or creating an estimate or catalogs.

7.1 The Tree Area

The tree area displays the information in an estimate or catalog in a hierarchical representation of the elements in the open estimate or catalog. It does not matter where you are in the tree if you want to access another element represented in the tree. Just click on the element you want to access.

You may need to click the plus sign (+) next to the heading of the section you want to see. For example, if you are in the Current Catalog, click the plus sign next to the Standard Item catalog to see the list of standard items (depending on how many items are in the list, it may take a while to appear). You can also select Expand All Tree View from the View menu to open every folder in your estimate or Current Catalog. When you are finished, you can select Collapse All Tree View from the View menu to close all open folders.

7.2 The Go Button

The GO button leads you through an open estimate, ending at the price bases. You can also use the GO button to navigate through an open catalog.

7.2.1 Using the Go Button in an Estimate

When creating or editing an estimate, the first GO button you encounter is in the estimate header window. It is part of the grid area that lists your estimate groups.
1. Click the **GO** button beside a group to show the item list for that group. These are the items that were specifically placed in that group, not as part of the Standard Item catalog.

2. Click the **GO** button beside an item to show the item header information and price bases.
3. Click the GO button next to the price basis to show the price basis details.

The GO button in an estimate does not bring you to any corresponding information in a catalog. Clicking the GO button in a catalog does not show any part of an estimate that uses the catalog information.

4. Go back to the header window and select the ALL ITEMS tab. Follow a GO button on that tab. When you are finished, close the estimate.

7.2.2 Using the Go Button in a Current Catalog

The GO button can also be used to navigate through catalogs. When you open a catalog, the GO button appears in the grid area next to each catalog entry.

1. Open the Current Catalog and access the Standard Item catalog.
The GO button appears in the grid area next to each item.

![Image](image1.png)

Figure 7-5. Standard Item Catalog

2. Select the GO button next to an item.

Estimator displays the details of the item, including attached price bases.

![Image](image2.png)

Figure 7-6. Standard Item Catalog Item Details

3. Click the GO button next to the price basis to show the price basis information from the appropriate price basis catalog.
4. Click the GO button beside the price basis ID to show price basis header information and details.

If the selected price basis was a cost sheet, you see more details and another GO button.
5. Click the GO button to bring you to the Cost Sheet Catalog.

6. Click the GO button to display the corresponding tab label (EQUIPMENT, LABOR, or MATERIAL) information.
7. Click the GO button beside the rate catalog name to show the corresponding rate catalog information.

8. Go back to the catalog header window and follow a different GO button. When you are finished, close the catalog.

7.3 Navigation Arrows

The navigation arrows in the menu bar allow you to go to the previously viewed window (BACK, pointing left), continue to the window viewed before heading back (FORWARD, pointing right), or go to the parent window of the current window (UP, pointing up). For an item in an estimate, the group is the parent window. For the group, it is the estimate header window.
7.3.1 Using the Navigation Arrows in an Estimate

When you first open an estimate, none of the navigation arrows are enabled. This is because you have not yet been anywhere in your estimate to use the BACK arrow, and the header window is the highest parent window in an estimate, so you can not use the UP arrow. The FORWARD arrow can only be used once the BACK arrow is used.

1. Open an estimate.

   ![Figure 7-13. Estimate Header Window](image)

The navigation arrows can be used in any part of the estimate, but we are going to use them on the ALL ITEMS tab.

2. Select the ALL ITEMS tab.

3. Select an item in the estimate.

   ![Figure 7-14. Item Detail Window](image)
Now the BACK and UP arrows are enabled.

4. Click the UP arrow either in the grid area or on the menu bar.

This brings you to the parent group of the item.

5. Click the UP arrow again.

This brings you back to the estimate header window.

6. Click the BACK arrow to bring you back to the group header.
Because you used the BACK arrow, the FORWARD arrow is now enabled.

7. Click the forward arrow to bring you to the estimate header window.

You might wonder why the FORWARD arrow brought you to the estimate header window instead of an item within the group. Remember that the FORWARD arrow brings you to the window viewed before the BACK button was used. Unlike the UP button, the FORWARD button does not recognize parent windows.

Now that you are again within the estimate header window, select the GROUPS tab and practice using the navigation arrows. When you are finished, close the estimate.
### 7.3.2 Using the Navigation Arrows in a Catalog

When you first open a catalog, none of the navigation arrows are enabled. This is because you have not yet been anywhere in your catalog to use the BACK arrow, and the header window is the highest parent window in a catalog, so you cannot use the UP arrow. The FORWARD arrow can only be used once the BACK arrow is used.

1. Open the Current Catalog.

   ![Current Catalog](image)

   **Figure 7-19.** Current Catalog

2. Practice using the navigation arrows on your own in the catalog and code tables.

3. Now try using the tree area and the GO button to navigate your way through the catalog.

When navigating through estimates and catalogs, sometimes it is easier to use the tree area, sometimes it is easier to use the GO button, and sometimes it is easier to use the navigation arrows. You can decide which navigation tools to use in each window.